精华内容
下载资源
问答
  • 华为策略路由配置实例.doc
  • 策略路由配置实例

    2021-07-26 21:26:07
    今天给大家介绍策略路由的配置。本文以华为eNSP模拟器,设计了一个实际的场景,并使用策略路由控制数据的转发,完成了相应的配置。 一、实验拓扑及要求 实验拓扑如上所示,现在假设AR2...策略路由配置如下: acl numbe

    今天给大家介绍策略路由的配置。本文以华为eNSP模拟器,设计了一个实际的场景,并使用策略路由控制数据的转发,完成了相应的配置。

    一、实验拓扑及要求

    在这里插入图片描述
    实验拓扑如上所示,现在假设AR2是内网,AR3是公网,要求内网发往公网的数据流量直接转发,公网发往内网的数据流量需要经过防火墙后再转发到内网。

    二、相关配置命令

    (一)配置思路

    分析上述题目需求,可以考虑使用策略路由来完成题目中指定的数据包转发流程。在配置策略路由时,可以使用MQC的方式进行配置。

    (二)策略路由相关配置

    策略路由配置如下:

    acl number 3000  
     rule 5 permit ip destination 192.168.1.0 0.0.0.255 
     rule 10 permit icmp destination 192.168.1.0 0.0.0.255 
    #
    traffic classifier PBR operator or
     if-match acl 3000
    #
    traffic behavior PBR
     redirect ip-nexthop 192.168.3.10
    #
    traffic policy PBR
     classifier PBR behavior PBR
    #
    interface GigabitEthernet0/0/1
     ip address 150.1.13.1 255.255.255.0 
     traffic-policy PBR inbound
    

    在上述配置中,在traffic behavior中,使用redirect ip-nexthop来控制数据包转发的下一跳。

    (三)关闭状态检测机制

    同时,为完成上述实验配置,还必须配置好防火墙的接口IP、路由、区域和安全策略。最容易忽略的是由于经过防火墙的转发路径不一致,因此必须要关闭防火墙的状态检测机制。命令如下:

    undo firewall session link-state check
    

    三、实验效果

    (一)内网到外网的数据流向

    在这里插入图片描述

    (二)外网到内网的数据流向

    在这里插入图片描述
    原创不易,转载请说明出处:https://blog.csdn.net/weixin_40228200/article/details/119118823

    展开全文
  • 华为设备BGP路由配置操作
  • 华为策略路由配置

    千次阅读 2019-09-18 17:23:44
    ISP1、ISP2、NET配置OSPF进行模拟 [NET]int GigabitEthernet 0/0/0 [NET-GigabitEthernet0/0/0]ip add 100.1.1.2 24 [NET-GigabitEthernet0/0/0]quit [NET]int GigabitEthernet 0/0/1 [NET-GigabitEthernet0/0/1]ip...

    拓扑图

    ISP1、ISP2、NET配置OSPF进行模拟
    
    [NET]int GigabitEthernet 0/0/0
    [NET-GigabitEthernet0/0/0]ip add 100.1.1.2 24
    [NET-GigabitEthernet0/0/0]quit
    [NET]int GigabitEthernet 0/0/1
    [NET-GigabitEthernet0/0/1]ip add 200.1.1.2 24
    [NET-GigabitEthernet0/0/1]quit
    [NET]int lo0
    [NET-LoopBack0]ip add 8.8.8.8 24
    [NET-LoopBack0]quit
    
    [NET]ospf 1 router-id 3.3.3.3
    [NET-ospf-1]area 0
    [NET-ospf-1-area-0.0.0.0]network 100.1.1.0 0.0.0.255
    [NET-ospf-1-area-0.0.0.0]network 200.1.1.0 0.0.0.255
    [NET-ospf-1-area-0.0.0.0]quit
    [NET-ospf-1]import-route direct type 1 //发布直连路由
    [NET-ospf-1]quit
    
    [ISP1]int GigabitEthernet 0/0/1
    [ISP1-GigabitEthernet0/0/1]ip add 100.
    展开全文
  • 要求:网通的用户5.5.5.X 访问1.1.1.1 走网通(R2) 电信的用户55.55.55.X 访问1.1.1.1 走电信(R4) 只能在R3上做配置
  • 路由策略简介,基本原理,配置路由策略-配置地址前缀列表、配置AS属性过滤器\配置团体属性过滤器
  • 华为配置策略路由

    2013-11-03 22:36:40
    华为防火墙做策略路由,需要的同学可以前来下载哦
  • 华为策略路由详解

    千次阅读 2021-02-25 15:23:40
    通过配置策略路由,可以用于提高网络的安全性能和负载分担。 策略路由PBR(Policy-Based Routing)是一种依据用户制定的策略进行路由选择的机制。 策略路由与路由策略(Routing Policy)存在以下不同: 策略...
     
     

    通过配置策略路由,可以用于提高网络的安全性能和负载分担。

        策略路由PBR(Policy-Based Routing)是一种依据用户制定的策略进行路由选择的机制。

     

        策略路由与路由策略(Routing Policy)存在以下不同:

        策略路由的操作对象是数据包。

        在路由表已经产生的情况下,不按照路由表进行转发,而是根据需要,依照某种策略改变数据包转发路径。

        路由策略的操作对象是路由信息。

        路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。

     

        传统的路由转发原理是首先根据报文的目的地址查找路由表,然后进行报文转发。但是目前越来越多的用户希望能够在传统路由转发的基础上根据自己定义的策略进行报文转发和选路。

     

        策略路由具有如下优点:

        可以根据用户实际需求制定策略进行路由选择,增强路由选择的灵活性和可控性。

        可以使不同的数据流通过不同的链路进行发送,提高链路的利用效率。

        在满足业务服务质量的前提下,选择费用较低的链路传输业务数据,从而降低企业数据服务的成本。

     

     

     

    一、配置策略路由

        配置策略路由可以将到达接口的转发报文重定向到指定的下一跳地址。

        通过配置重定向,设备将符合流分类规则的报文重定向到指定的下一跳地址。

        包含重定向动作的流策略只能在全局、接口或VLAN的入方向上应用。

     

        华为AR系列支持三种策略路由:

     

    1、本地策略路由

        本地策略路由是指仅对本地发送的报文有效的策略路由,对转发的报文不起作用。

        一条本地策略路由可以配置多个策略点,并且这些策略的具有不同的优先级,本机发送的报文优先匹配优先级高的策略点。

        本地策略路由支持acl或报文长度匹配规则。

        本地路由策略会根据本地策略路由节点的优先级依次匹配各个节点绑定的匹配规则发送报文,如果没有找到本地策略路由节点,则按照IP报文的一般流程根据目的地址查找路由。

        本地策略路由节点优先级顺序为(高到低):报文优先级-出接口-下一跳-缺省出接口。

     

     

    2、接口策略路由

        仅对转发的报文生效,对本地发送的报文不起作用,且只对接口入方向的报文生效。

        接口策略路由是通过在流行为中配置重定向实现的。

     

     

    3、智能策略路由(SPR)

        此功能需要购买华为license授权。

        智能策略路由是基于业务需求的策略路由,通过匹配链路质量和网络业务对链路质量的需求,实现智能选路。

    产生背景

        智能策略路由SPR(Smart Policy Routing)可以主动探测链路质量并匹配业务的需求,从而选择一条最优链路转发业务数据,可以有效的避免网络黑洞、网络震荡等问题。

     

    1、业务区分

        SPR支持通过以下属性对业务进行区分:

        根据协议类型区分:IP,TCP,UDP,GRE,IGMP,IPINIP,OSPF,ICMP。

        根据报文应用区分:DSCP,TOS,IP Precedence,Fragment,VPN,TCP-flag。

        根据报文信息区分:Source IP Address,Destination IP Address,Protocol,Source Port,Destination Port,Source IP Prefix,Destination IP Prefix。

        不同的业务对链路的时延D(Delay)、抖动时间J(Jitter)、丢包率L(Loss)以及综合度量指标CMI(Composite Measure Indicator)有不同的要求,如果业务对链路的某一项质量参数没有要求,就不需要配置该参数的阈值。

     

    2、探测链路和链路组

        探测链路是SPR实现智能选路的基础,每个探测链路都有一个与之相对应的探针,即NQA(Network Quality Analysis)测试例。如果测试失败,则表示对应的探测链路不可用。探测链路通过探针获取链路参数的质量,SPR根据探测链路的链路质量匹配业务需求,从而实现智能选路的需求。

        SPR不直接使用探测链路,而是通过链路组的形式使用探测链路。一个探测链路可以加入不同的链路组,同时一个链路组中可以有一条或多条探测链路。

        SPR的链路角色分为:主用链路组、备用链路组和逃生链路。SPR中业务无法从主用链路组和备用链路组中找到合适的链路传输数据时可以启用逃生链路。

        同一个链路组可以被不同的业务绑定,如链路组1可以作为业务1的主用链路组,同时也可以作为业务2的备用链路组。

     

     

    3、业务选路

        SPR根据NQA探测结果进行业务选路。

        在业务选路时,如果当前链路上已经部属了业务,则该链路的选择指数将降低,即选择的机率变小,这样宏观上可以达到负载均衡的效果。

     

     

    4、切换周期

        SPR中切换周期计时器主要用于链路质量不满足业务需求时控制链路切换。

        SPR根据NQA探测结果判断链路是否满足业务需求,SPR会定期获取NQA的探测结果,如果某次获取的NQA探测结果不满足业务需求,则切换周期计时器开始计时。

        在开始计时后切换周期到达之前,如果某次获取的探测结果满足了业务需求,则切换周期计时器清零,直到下次获取到不满足业务需求的探测结果时会再次开始计时。如果计时器开始计时后,在切换周期内获取到的探测结果都不能满足业务需求,则SPR切换链路。

     

    5、振荡抑制周期

        某些情况下,网络会出现时好时坏的情况,从而导致SPR频繁切换链路,严重影响业务体验。SPR的抑制振荡功能可以有效的避免此类情况产生。

        振荡抑制周期默认情况下不生效,周期值由用户自己配置。

        SPR切换链路后,振荡抑制周期计时器开始计时,如果业务驻留链路的时间没有达到振荡抑制周期的时间,则SPR不会执行链路切换。振荡抑制周期超时后,如果在一个切换周期内链路还是不满足业务需求,则SPR将切换链路;如果在一个切换周期内链路质量变好,满足业务需求,则SPR不会切换链路。

     

     

     

    二、策略路由具体配置

    1、本地策略路由具体配置

    1、创建策略路由和策略点

    [Huawei]policy-based-route 1 deny node 1

     

     

    2、设置本地策略匹配规则

    [Huawei-policy-based-route-1-1]if-match ?

      acl            Access control list #根据IP报文中的acl匹配

      packet-length  Match packet length #根据IP报文长度匹配

    -----------

    [Huawei-policy-based-route-1-1]if-match packet-length ?

      INTEGER<0-65535>  Minimum packet length #最短报文长度

    [Huawei-policy-based-route-1-1]if-match packet-length 100 ?

      INTEGER<1-65535>  Maximum packet length#最长报文长度

     

     

    3、设置本地路由策略动作

    3.1、设置报文的出接口

     [Huawei-policy-based-route-1-1]apply output-interface ? #直接设定出接口

      Serial  Serial interface

    --------

    [Huawei-policy-based-route-1-1]apply default output-interface ? #缺省出接口

      Serial  Serial interface

    #报文的出接口,匹配成功后将从指定接口发出去。接口不是能以太网等广播类型接口(改为P2P即可),因为多个下一跳可能导致报文转发不成功。

     

     

    3.2、设置报文的下一跳

    [Huawei-policy-based-route-1-1]apply ip-address ?

      default   Set default information #缺省下一跳,仅对在路由表中未查到的路由报文起作用

      next-hop  Next hop address# 直接设定下一跳

     

     

    3.3、设置VPN转发实例

    [Huawei-policy-based-route-1-1]apply access-vpn vpn-instance ?

      STRING<1-31>  VPN instance name

     

     

    3.4设置IP报文优先级

    [Huawei-policy-based-route-1-1]apply ip-precedence ?

      INTEGER<0-7>    IP precedence value

      critical        Set packet precedence to critical(5)(关键)

      flash           Set packet precedence to flash(3)(闪速)

      flash-override  Set packet precedence to flash override(4)(疾速)

      immediate       Set packet precedence to immediate(2)(快速)

      internet        Set packet precedence to Internet control(6)(网间)

      network         Set packet precedence to network control(7)(网内)

      priority        Set packet precedence to priority(1)(优先)

      routine         Set packet precedence to routine(0)(普通)

     

     

    3.5设置本地策略路由刷新LSP信息时间间隔

    [Huawei]ip policy-based-route refresh-time ?

      INTEGER<1000-65535>  Refresh time value (ms)

      <cr>   

     

     

    3.6应用本地策略路由

    [Huawei]ip local policy-based-route ?

      STRING<1-19>  Policy name

    #一台路由器只能使能一个本地策略路由(可以创建多条)

     

     

     

    2、接口策略路由具体配置

    1、设置流分类

    [Huawei]traffic classifier test1 operator ?#逻辑运算符

      and  Rule of matching all of the statements #与 关系

      or   Rule of matching one of the statements # 或关系

    2.1、设置分类匹配规则

    [Huawei-classifier-test1]if-match ?

      8021p              Specify vlan 802.1p to match

      acl                Specify ACL to match

      any                Specify any data packet to match

      app-protocol       Specify app-protocol to match

      cvlan-8021p        Specify inner vlan 802.1p of QinQ packets to match.

      cvlan-id           Specify inner vlan id of QinQ packets to match.  #基于内层VLAN ID分类匹配规则

      destination-mac    Specify destination MAC address to match

      dlci               Specify a DLCI to match

      dscp               Specify DSCP (DiffServ CodePoint) to match

      fr-de              Specify FR DE to match.

      inbound-interface  Specify an inbound interface to match

      ip-precedence      Specify IP precedence to match

      ipv6               Specify IPv6

      l2-protocol        Specify layer-2 protocol to match

      mpls-exp           Specify MPLS EXP value to match

      protocol           Specify ipv4 or ipv6 packets to match

      protocol-group     Specify protocol-group to match

      pvc                Specify a PVC to match

      rtp                Specify RTP port to match

      source-mac         Specify source MAC address to match

      tcp                Specify TCP parameters to match

      vlan-id            Specify a vlan id to match #基于外出VLAN ID

     

    3、设置流重定向

       将符合流分类规则的报文重定向到指定的下一跳或指定接口。只能在接口的入方向应用。

    3.1、设置流行为名

    [Huawei]traffic behavior test2

    [Huawei-behavior-test2]

    3.2、重定向符合流分类的报文

    [Huawei-behavior-test2]redirect ?

      interface     Status and configuration about the traffic on the interface # 重定向到指定接口(3G 或dialer)

      ip-nexthop    Redirect packets to nexthop # 重定向到下一跳

      ipv6-nexthop  Redirect packets to ipv6 nexthop

    -----------

    [Huawei-behavior-test2]redirect ip-nexthop 10.1.1.1 ?

      post-nat  Post nat

      track     Track nqa #支持与NQA联动

      <cr>      Please press ENTER to execute command

     

     

    4、应用流策略

    1、设置流策略名

    [Huawei]traffic policy test3

     

    2、关联流分类和流行为

    [Huawei-trafficpolicy-test3]classifier test1 behavior test2

     

    3、在接口应用(入方向)

    [Huawei-GigabitEthernet0/0/2]traffic-policy test3 inbound

    展开全文
  • 思路:使用策略路由,对内网流量进行过滤,IP重定向,自定义公网出口,并且使用NAT技术进行IP地址转换,使得内网IP使用公网IP可以访问互联网; 需求2:总公司和分公司需要内网直接通信,内网互相访问,公司希望建立...

    需求背景

    需求1:总公司有董事办网和员工网,并且有两条出口线路,其中1.1.1.2为中国电信1Gbps高速线路,2.2.2.2为中国移动100Mbps专线低速链路,公司希望董事办192.168.1.0/24可以总是走1Gbps专线,而员工网走中国移动100Mpbs专线;

    思路:使用策略路由,对内网流量进行过滤,IP重定向,自定义公网出口,并且使用NAT技术进行IP地址转换,使得内网IP使用公网IP可以访问互联网;

    需求2:总公司和分公司需要内网直接通信,内网互相访问,公司希望建立一条VPN GRE隧道,来使得总司和分司内部网络互通;

    思路:总公司和分公司出口路由器通过部署GRE隧道,使得内网互通;

    网络拓补图

    第一步:基础网络设备打通,使得彼此可以互相访问

    LSW1

    <Huawei>sy
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info-center en
    Info: Information center is disabled.
    [Huawei]sysname LSW1	
    [LSW1]dhcp en
    Info: The operation may take a few seconds. Please wait for a moment.done.	
    [LSW1]vlan batch  10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    
    [LSW1]interface Vlanif 10
    [LSW1-Vlanif10]ip address  10.1.1.2 24
    [LSW1-Vlanif10]quit
    
    [LSW1]interface Vlanif 20
    [LSW1-Vlanif20]ip address 192.168.1.1 24
    [LSW1-Vlanif20]dhcp se in
    [LSW1-Vlanif20]quit
    	
    [LSW1]interface Vlanif 30
    [LSW1-Vlanif30]ip address  192.168.2.1 24
    [LSW1-Vlanif30]dhcp select interface 
    [LSW1-Vlanif30]quit
    
    [LSW1]interface GigabitEthernet 0/0/1	
    [LSW1-GigabitEthernet0/0/1]port link-type access 
    [LSW1-GigabitEthernet0/0/1]port default vlan 10
    [LSW1-GigabitEthernet0/0/1]quit
    
    [LSW1]interface GigabitEthernet 0/0/3
    [LSW1-GigabitEthernet0/0/3]port link-type access 
    [LSW1-GigabitEthernet0/0/3]port default vlan 20
    [LSW1-GigabitEthernet0/0/3]stp edged-port enable 
    [LSW1-GigabitEthernet0/0/3]quit
    
    [LSW1]interface GigabitEthernet 0/0/4	
    [LSW1-GigabitEthernet0/0/4]port link-type access 	
    [LSW1-GigabitEthernet0/0/4]port default vlan 30
    [LSW1-GigabitEthernet0/0/4]stp edged-port enable 
    [LSW1-GigabitEthernet0/0/4]quit
    [LSW1]
    [LSW1]
    [LSW1]ospf 1	
    [LSW1-ospf-1]area 0
    [LSW1-ospf-1-area-0.0.0.0]network  192.168.1.0 0.0.0.255
    [LSW1-ospf-1-area-0.0.0.0]network  192.168.2.0 0.0.0.255
    [LSW1-ospf-1-area-0.0.0.0]network  10.1.1.2 0.0.0.0
    [LSW1-ospf-1-area-0.0.0.0]quit
    [LSW1-ospf-1]quit
    [LSW1]
    [LSW1]ip route-static 0.0.0.0 0 10.1.1.1  //配置一条默认路由,数据包都发往路由器网关
    

    AR1【总公司路由器】

    The device is running!
    
    <Huawei>sy
    Enter system view, return user view with Ctrl+Z.	
    [Huawei]undo  info-center e
    Info: Information center is disabled.
    [Huawei]sys	
    [Huawei]sysname AR1
    
    [AR1]interface GigabitEthernet 0/0/0
    [AR1-GigabitEthernet0/0/0]ip address 10.1.1.1 24
    [AR1-GigabitEthernet0/0/0]quit	
    [AR1]ospf 1
    [AR1-ospf-1]area  0 
    [AR1-ospf-1-area-0.0.0.0]network 10.1.1.1 0.0.0.255
    [AR1-ospf-1-area-0.0.0.0]quit
    [AR1-ospf-1]quit
    //打通内部网络,并且查看路由表,对获得IP的客户端进行ping操作,测试正常
    
    配置公网IP
    [AR1]interface GigabitEthernet 0/0/1
    [AR1-GigabitEthernet0/0/1]ip address  1.1.1.2 24
    [AR1-GigabitEthernet0/0/1]quit
    
    [AR1]interface GigabitEthernet 0/0/2
    [AR1-GigabitEthernet0/0/2]ip address  2.2.2.2 24
    [AR1-GigabitEthernet0/0/2]quit
    [AR1]

    AR6【分公司路由器】

    [Huawei]sysname AR6
    [AR6]undo  info-center enable 
    Info: Information center is disabled.
    [AR6]dhcp enable 
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [AR6]int	
    [AR6]interface g	
    [AR6]interface GigabitEthernet 0/0/1
    [AR6-GigabitEthernet0/0/1]ip address 172.16.1.1 24
    [AR6-GigabitEthernet0/0/1]dhcp  select interface 
    [AR6-GigabitEthernet0/0/1]quit
    //配置分公司内部网络
    
    
    配置公网IP 	
    [AR6]interface GigabitEthernet 0/0/0
    [AR6-GigabitEthernet0/0/0]ip address  100.1.1.2 24
    [AR6-GigabitEthernet0/0/0]quit
    [AR6]

    给运营商设备打通网络,模拟运营商,此处忽略代码,不与展示,此处我是用OSPF协议,使得公网IP能全通。

    需求1实验代码【总公司】

    //使用ACL将内网2个网段匹配出来
    [AR1]acl 3000
    [AR1-acl-adv-3000]rule  permit ip source 192.168.1.0 0.0.0.255
    [AR1-acl-adv-3000]rule permit ip source 192.168.2.0 0.0.0.255
    [AR1-acl-adv-3000]quit
    
    
    
    //写两条默认路由到公网,使得到2出公网都可达
    [AR1]ip route-static 0.0.0.0 0  1.1.1.1 
    [AR1]ip route-static 0.0.0.0 0 2.2.2.1
    
    //两个接口下分别配置EasyNat实现内网访问公网需求
    [AR1]interface GigabitEthernet 0/0/1	
    [AR1-GigabitEthernet0/0/1]nat outbound 3000
    [AR1-GigabitEthernet0/0/1]quit
    
    [AR1]interface GigabitEthernet 0/0/2	
    [AR1-GigabitEthernet0/0/2]nat outbound 3000
    [AR1-GigabitEthernet0/0/2]quit
    [AR1]
    
    [AR1]traffic classifier dongshi operator or //创建董事办流分类
    [AR1-classifier-dongshi]if-match acl 3001 //如果匹配董事办网段
    [AR1-classifier-dongshi]quit
    [AR1]traffic behavior dongshi //定义流行为
    [AR1-behavior-dongshi]redirect ip-nexthop 1.1.1.1 //重定向下一跳为中国电信高速链路
    [AR1-behavior-dongshi]quit
    
    [AR1]traffic classifier yuangon operator or
    [AR1-classifier-yuangon]if-match acl 3002
    [AR1-classifier-yuangon]quit
    [AR1]traffic behavior yuangon
    [AR1-behavior-yuangon]redirect ip-nexthop 2.2.2.1//重定向下一跳为中国移动低速链路
    [AR1-behavior-yuangon]quit
    
    [AR1]traffic policy company   //创建“company”流策略
    [AR1-trafficpolicy-company]classifier dongshi behavior dongshi //应用董事办策略
    [AR1-trafficpolicy-company]classifier yuangon behavior yuangon //应用员工网策略
    [AR1-trafficpolicy-company]quit
    
    
    [AR1]interface GigabitEthernet 0/0/0//在该接口下对流入的内网流量应用流策略
    [AR1-GigabitEthernet0/0/0]traffic-policy company inbound 
    [AR1-GigabitEthernet0/0/0]quit
    [AR1]
    <AR1>
    备注:重定向IP的时候,千万不要写错下一跳IP地址,不然不会生效

    需求1测试:

    PC1测试

    应用策略之前,走了移动低速链路
    PC>tracert 3.3.3.1
    
    traceroute to 3.3.3.1, 8 hops max
    (ICMP), press Ctrl+C to stop
     1  192.168.1.1   31 ms  15 ms  32 ms
     2    *  *  *
     3  2.2.2.1   47 ms  46 ms  63 ms
     4  5.5.5.2   62 ms  32 ms  47 ms
     5  4.4.4.1   78 ms  62 ms  63 ms
     6  3.3.3.1   93 ms  63 ms  62 ms
    
    
    应用策略之后,走了电信高速链路
    PC>
    PC>
    PC>tracert 3.3.3.1
    
    traceroute to 3.3.3.1, 8 hops max
    (ICMP), press Ctrl+C to stop
     1  192.168.1.1   32 ms  15 ms  31 ms
     2    *  *  *
     3  3.3.3.1   63 ms  62 ms  47 ms
    //备注:因为3.3.3.1和1.1.1.1是同一台设备,所以此处的确走了出口IP:1.1.1.1
    

    PC2测试

    应用流策略之前,员工网络走了电信高速路径
    
    
    PC>tracert 1.1.1.1
    
    traceroute to 1.1.1.1, 8 hops max
    (ICMP), press Ctrl+C to stop
     1  192.168.2.1   16 ms  15 ms  32 ms
     2    *  *  *
     3  1.1.1.1   31 ms  47 ms  47 ms
    
    
    
    
    应用流策略之后,不论公网哪个IP地址,都走了下面的低速链路
    PC>
    PC>tracert 1.1.1.1
    
    traceroute to 1.1.1.1, 8 hops max
    (ICMP), press Ctrl+C to stop
     1  192.168.2.1   32 ms  15 ms  32 ms
     2    *  *  *
     3  2.2.2.1   46 ms  47 ms  47 ms
     4  5.5.5.2   63 ms  47 ms  78 ms
     5  4.4.4.1   62 ms  63 ms  78 ms
     6  1.1.1.1   62 ms  63 ms  78 ms

    分公司内网PC访问外网需求

    
    [AR6]ip route-static 0.0.0.0  0 100.1.1.1
    [AR6]acl 3000
    [AR6-acl-adv-3000]rule  permit  ip source 172.16.1.0 0.0.0.255
    [AR6-acl-adv-3000]quit
    	
    [AR6]interface GigabitEthernet 0/0/0	
    [AR6-GigabitEthernet0/0/0]nat outbound 3000
    [AR6-GigabitEthernet0/0/0]quit
    [AR6]
    [AR6]
    
    
    
    
    
    分公司PC测试ping公网任意IP地址可达,证明OK
    
    PC>ping 4.4.4.4
    
    Ping 4.4.4.4: 32 data bytes, Press Ctrl_C to break
    Request timeout!
    
    --- 4.4.4.4 ping statistics ---
      2 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 4.4.4.1
    
    Ping 4.4.4.1: 32 data bytes, Press Ctrl_C to break
    From 4.4.4.1: bytes=32 seq=1 ttl=253 time=31 ms
    From 4.4.4.1: bytes=32 seq=2 ttl=253 time=31 ms
    From 4.4.4.1: bytes=32 seq=3 ttl=253 time=16 ms
    From 4.4.4.1: bytes=32 seq=4 ttl=253 time=31 ms
    From 4.4.4.1: bytes=32 seq=5 ttl=253 time=31 ms
    
    --- 4.4.4.1 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 16/28/31 ms
    
    PC>ping 1.1.1.1
    
    Ping 1.1.1.1: 32 data bytes, Press Ctrl_C to break
    From 1.1.1.1: bytes=32 seq=1 ttl=252 time=32 ms
    From 1.1.1.1: bytes=32 seq=2 ttl=252 time=31 ms
    From 1.1.1.1: bytes=32 seq=3 ttl=252 time=31 ms
    From 1.1.1.1: bytes=32 seq=4 ttl=252 time=31 ms
    From 1.1.1.1: bytes=32 seq=5 ttl=252 time=16 ms
    
    --- 1.1.1.1 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 16/28/32 ms
    
    PC>

    需求2实验代码

     

    总公司路由器设置,写静态路由,去往172.16.1.0的路由,从tunnel隧道发出
    
    #
    interface Tunnel0/0/0
     ip address 192.168.100.1 255.255.255.0 
     tunnel-protocol gre
     source 1.1.1.2
     destination 100.1.1.2
    #
    ip route-static 172.16.1.0 255.255.255.0 Tunnel0/0/0
    #
    
    
    
    分公司路由器设置,使用静态路由进行互访
    #
    interface Tunnel0/0/0
     ip address 192.168.100.2 255.255.255.0 
     tunnel-protocol gre
     source 100.1.1.2
     destination 1.1.1.2
    #
    ip route-static 192.168.1.0 255.255.255.0 Tunnel0/0/0
    ip route-static 192.168.2.0 255.255.255.0 Tunnel0/0/0
    
    
    
    
    =====================================================================================
    2个客户端ping测试
    总公司PC1
    PC>ipconfig
    
    Link local IPv6 address...........: fe80::5689:98ff:fe47:2689
    IPv6 address......................: :: / 128
    IPv6 gateway......................: ::
    IPv4 address......................: 192.168.1.254
    Subnet mask.......................: 255.255.255.0
    Gateway...........................: 192.168.1.1
    Physical address..................: 54-89-98-47-26-89
    DNS server........................:
    
    PC>ping 172.16.1.254
    
    Ping 172.16.1.254: 32 data bytes, Press Ctrl_C to break
    From 172.16.1.254: bytes=32 seq=1 ttl=125 time=78 ms
    From 172.16.1.254: bytes=32 seq=2 ttl=125 time=62 ms
    From 172.16.1.254: bytes=32 seq=3 ttl=125 time=78 ms
    From 172.16.1.254: bytes=32 seq=4 ttl=125 time=63 ms
    From 172.16.1.254: bytes=32 seq=5 ttl=125 time=62 ms
    
    --- 172.16.1.254 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/68/78 ms
    
    PC>
    =====================================================================================
    分公司路由器
    
    PC>ipconfig
    
    Link local IPv6 address...........: fe80::5689:98ff:fe5d:62fe
    IPv6 address......................: :: / 128
    IPv6 gateway......................: ::
    IPv4 address......................: 172.16.1.254
    Subnet mask.......................: 255.255.255.0
    Gateway...........................: 172.16.1.1
    Physical address..................: 54-89-98-5D-62-FE
    DNS server........................:
    
    PC>
    PC>PING 192.168.1.254
    
    Ping 192.168.1.254: 32 data bytes, Press Ctrl_C to break
    Request timeout!
    From 192.168.1.254: bytes=32 seq=2 ttl=125 time=78 ms
    From 192.168.1.254: bytes=32 seq=3 ttl=125 time=63 ms
    From 192.168.1.254: bytes=32 seq=4 ttl=125 time=78 ms
    From 192.168.1.254: bytes=32 seq=5 ttl=125 time=78 ms
    
    --- 192.168.1.254 ping statistics ---
      5 packet(s) transmitted
      4 packet(s) received
      20.00% packet loss
      round-trip min/avg/max = 0/74/78 ms
    
    PC>
    

     

    展开全文
  • 华为路由器OSPF+RIP+静态路由配置实例

    千次阅读 多人点赞 2019-07-06 14:39:47
    二、路由器配置 AR1配置: # interface GigabitEthernet0/0/0 ip address 192.168.1.1 255.255.255.0 ospf enable 1 area 0.0.0.1 # interface LoopBack0 ip address 1.1.1.1 255.255.255.255 # ospf 1 router-...
  • 策略路由PBR配置实例

    千次阅读 2018-07-03 19:41:10
    3.2.1.2 路由器配置举例1.1.0.0 à ISP A.1.2.0.0 à ISP B.RouterA(config)# access-list 1 permit ip 1.1.0.0 0.0.255.255RouterA(config)# access-list 2 permit ip 1.2.0.0 0.0.255.255RouterA(config)# rout...
  • 华为S5700配置实例

    2018-09-27 13:00:08
    华为S5700配置实例
  • 华为交换机配置策略路由

    千次阅读 2020-06-19 18:57:39
    https://support.huawei.com/enterprise/zh/doc/EDOC1000069432?section=j00f 工作繁重,时间紧迫,先留图流链接。待来日有时间再整理。
  • 资源名称:华为路由器配置实例全集   资源目录: 【】004Tab键使用示例 【】005定义快捷键示例 【】001配置通过Console口登录示例 【】003配置通过AUX方式登录示例 【】002配置通过...
  • (思科,华为)路由器配置实例--各100例.rar
  • 华为——策略路由(校园网配置

    千次阅读 2020-04-06 15:31:58
    华为——策略路由(校园网配置) 作用:通过分析数据报的源地址和目标地址,按照策略规则选择不同的网关,进行数据转发。提供冗余,负载,但是还是单线路的速度。只是提供了不同的方向,并没有进行合并线路。 拓扑图...
  • 路由策略和策略路由配置与管理 “路由策略”与“策略路由”之间的区别就在于它们的主体(或者说“作用对象”)不同,前者的主体是“路由”,是对符合条件的路由(主要)通过修改路由属性来执行相应的策略动作(如...
  • 华为单臂路由配置

    万次阅读 2011-07-15 09:04:48
    完美讲解 单臂路由(Vlan间路由) 众多中小企业内部网络结构都很简单,仅仅是用一台交换机将所有员工机以及服务器连接到一起,然后通过光纤访问internet而已。当然为了保证部分主机的安全性以及分割内部广播包提高...
  • 本帖最后由 taxigps 于 2021-3-17 11:52 编辑一、应用场景家里安装了电信500M和移动...经比较各类升级方案后,综合考虑安全、稳定、经济三方面因素后,决定采用华为AR111-S企业路由器支持双线接入+AX3PRO做AP支持WI...
  • 路由策略和策略路由配置与管理-1

    万次阅读 多人点赞 2017-02-24 12:43:14
    路由策略和策略路由配置与管理 “路由策略”与“策略路由”之间的区别就在于它们的主体(或者说“作用对象”)不同,前者的主体是“路由”,是对符合条件的路由(主要)通过修改路由属性来执行相应的策略动作(如...
  • 华为路由配置命令

    2020-12-15 10:42:06
    华为路由配置命令 display ip int brief 查看接口ip地址 display interface brief 查看接口的简要信息 display current-configuration 显示当前配置文件 display current-configuration 关键词(查看关键词当前...
  • 路由策略和策略路由配置与管理-2

    万次阅读 多人点赞 2017-03-05 20:18:34
    策略路由基础 “路由策略”(Routing Policy,RP)与“策略路由”(Policy-BasedRouting,PBR)有着本质上的区别。“路由策略”中的“路由”是名词,而“策略”是动词,操作对象是路由信息。“路由策略”主要用来...
  • 华为NQA与策略路由

    千次阅读 2019-09-18 21:36:42
    ISP1、ISP2、NET配置OSPF进行模拟 [NET]int GigabitEthernet 0/0/0 [NET-GigabitEthernet0/0/0]ip add 100.1.1.2 24 [NET-GigabitEthernet0/0/0]quit [NET]int GigabitEthernet 0/0/1 [NET-GigabitEth...
  • 5.策略路由配置 acl number 3001  rule 10 permit ip source 10.1.1.0 0.0.0.255 acl number 3002  rule 10 permit ip source 10.1.2.0 0.0.0.255 policy-based-route huawei permit node 1  if-match acl 3001 ...
  • huawei 策略路由配置

    万次阅读 2014-03-27 13:13:04
    1.1 配置ACL Quidway-acl-adv-3999]di th  # 
  • 交换机配置(一)端口限速基本配置 华为3Com 2000_EI、S2000-SI、S3000-SI、S3026E、S3526E、S3528、S3552、S3900、S3050、S5012、S5024、S5600系列: 华为交换机端口限速 2000_EI系列以上的交换机都可以限速! ...
  • 综合案例:配置基于源地址的策略路由 项目目的: 通过配置策略路由实现不同源地址数据通过不同的链路转发 组网需求: 某企业主要分为市场部和研发部两个部门,组网如图5-3所示,FW位于企业网出口,该企业部署了两条...
  • 1.基本IP地址及连通性配置 (1)内网IP地址配置 (2)配置外网IP地址 [ISP1-GigabitEthernet0/0/0]ip add 20.1.1.2 24 [ISP1-GigabitEthernet0/0/1]ip add 40.1.1.2 24 [ISP2-GigabitEthernet0/0/0]ip add 30.1.1.3...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,222
精华内容 888
关键字:

华为策略路由配置实例