精华内容
下载资源
问答
  • 2021-04-21 08:43:55

    目录

    三层交换机S1的配置:

    二层交换机S2的配置:

    二层交换机S3的配置:


    1. “ip routing”配置命令开启三层交换机的IP路由;
    2. VLAN能将不同网段的广播隔离开;
    3. 二层交换机无法实现不同VLAN间的路由功能;
    4. 三层交换机的功能 = 二层交换机的功能 + 路由器的功能;
    5. 在VLAN端口配置IP,将GW指向相应VLAN的SVI地址可实现不同VLAN间的通信。
    6. 交换虚拟端口(SVI, Switch Virtual Interface):虚拟的路由器与每个VLAN进行连接的端口。 

    三层交换机S1的配置:

    //配置三层接口之前,首先创建VLAN及端口分配
    S1(config)#VLAN 2 //创建vlan2
    S1(config-vlan)#exit
    
    S1(config)#interface fa0/1 //进入端口配置模式
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface fa0/2
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface vlan 1 
    S1(config-if)#ip address 192.168.1.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口 
    
    S1(config)#interface vlan 2
    S1(config-if)#ip address 192.168.2.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口
    S1(config-if)#exit
    
    S1(config)#ip routing //开启三层交换机的IP路由功能

    二层交换机S2的配置:

    S2(config)#vlan 2 //在全局配置模式下创建VLAN
    S2(config-vlan)#exit
    
    S2(config)#interface fa0/1 //进入端口配置模式
    S2(config-if)#switchport mode trunk //端口配置为Trunk模式用来进行交换机互联,可允许多个VLAN通信
    
    S2(config-if)#interface fa0/2 //进入端口配置模式
    S2(config-if)#switchport access vlan 1 //将端口分配到vlan 1
    
    S2(config-if)#interface fa0/3
    S2(config-if)#switchport access vlan 2 //将交换机端口分配到vlan2

    二层交换机S3的配置:

    S3(config)#vlan 2
    S3(config-vlan)#exit
    
    S3(config)#interface fa0/1
    S3(config-if)#switchport mode trunk
    
    S3(config-if)#interface fa0/2
    S3(config-if)#switchport access vlan 2
    
    S3(config-if)#interface fa0/3
    S3(config-if)#switchport access vlan 1

     

    更多相关内容
  • 这是三层交换机跨Vlan通信实验的Cisco Packet Tracer文件。实验包括有两个vlan,两个二层交换机,一个三层交换机。
  • 本次实验使用单臂路由实现了跨VLAN通信。主要步骤有建立网络拓扑、二层交换机的接口设置(创建VLAN、交换机的VLAN端口分配、交换机的端口分配)、路由器的接口设置。

    系列文章目录

    【计算机网络】思科实验(1):交换机的VLAN划分

    【计算机网络】思科实验(2):交换机间的VLAN通信

    【计算机网络】思科实验(3):使用三层交换机实现跨VLAN间的通信

    【计算机网络】思科实验(4):综合实验作业之办公室的跨VLAN通信

    【计算机网络】思科实验(5):单臂路由跨VLAN通信

    【计算机网络】思科实验(6):路由器的静态路由配置

    【计算机网络】思科实验(7):网络地址转换之路由器静态NAT模拟

    【计算机网络】思科实验(8):网络地址转换之路由器动态NAT模拟

    【计算机网络】思科实验(9):动态路由协议RIPv2

    【计算机网络】思科实验(10):动态路由协议OSPF

    【计算机网络】思科实验(11):综合实验作业之局域网与路由协议


    实验环境:Packet Tracer


    前言

    本次实验主题:利用单臂路由实现跨VLAN通信。实验内容来自课堂。本文仅对实验步骤做记录。


    一、背景知识

    VLAN能将不同网段的广播隔离开,但是也隔离了不同VLAN间的数据传输。二层交换机无法实现不同VLAN间的路由功能,为了实现跨VLAN的主机通信,必须使用路由器或三层交换机。

    传统Vlan间路由的实现方法是通过将路由器的不同物理接口连接至交换机的不同物理端口来执行Vlan间路由。

    如图网络拓扑:在交换机上创建2个Vlan,并分配交换机端口到相应的Vlan,将交换机上2个以太网端口连接到路由器的2个物理接口。配置路由器的物理接口IP地址为所属Vlan的默认网关地址。并将PC的默认网关设置为同一Vlan中的路由器物理接口地址即可。采用这种方法实现N个Vlan间通信,路由器需要N个物理接口连接交换机的N个端口,扩展性很差,在实际应用中并不可行。
    双臂路由

    单臂路由通过单个物理接口实现网络中多个Vlan之间数据流量的传递,单臂路由实现Vlan间通信如下网络拓扑:

    路由器只需要一个物理接口和交换机以太网端口相连,这个交换机以太网端口设置为Trunk端口。在路由器的物理接口创建多个子接口。路由器的软件中配置了子接口,每个子接口分别配置相应Vlan的默认网关IP地址,并承载IEEE802.1q封装的Vlan流量,从而将子接口配置到不同的Vlan。

    单臂路由

    二、建立网络拓扑

    添加2台计算机,标签名为PC0、PC1;

    添加1台二层交换机2960 ;

    添加1台路由器2811;

    交换机划分的VLAN及端口根据如下拓扑图,使用直通线连接好计算机、交换机、路由器,并为每台计算机设置好相应的 IP和SM(Subnet Mask,子网掩码)。

    建立网络拓扑

    三、二层交换机的接口设置

    3.1 创建VLAN

    在Switch0上划分2个Vlan(Vlan10和Vlan20) 。
    划分2个Vlan

    代码如下:

    Switch>enable
    Switch#conf t
    Switch(config)#vlan 10
    Switch(config-vlan)#name vlan10
    Switch(config-vlan)#exit
    Switch(config)#vlan 20
    Switch(config-vlan)#name vlan20
    Switch(config-vlan)#exit
    

    3.2 交换机的VLAN端口分配

    1、打开Switch0的Config
    2、单击INTERFACE下选项,进入某接口
    3、选择其对应的VLAN
    交换机的VLAN端口分配
    交换机的VLAN端口分配

    3.3 交换机的端口分配

    设置交换机与路由相连的端口模式为Trunk。
    交换机的端口分配
    设置为Trunk

    四、路由器的接口设置

    当交换机收到VLAN10的计算机PC0发送的数据帧后,从Trunk端口fa0/24发送带有VLAN10标签的数据给路由器,数据帧到达路由器后,路由器对数据解封并查找路由表,当数据要转发到VLAN20,路由器将用VLAN20的标签重新封装数据帧并通过Trunk连路发送到交换机的Trunk端口,交换机收到该帧后去掉VLAN20标签,发送给VLAN20上的计算机PC1,从而实现跨VLAN间通信。

    路由器的接口设置

    代码如下:

    Router>enable
    Router#conf t
    Router(config)#interface fa0/0								//	进入端口fa0/0
    Router(config-if)#no shutdown								//	开启端口fa0/0
    Router(config-if)#interface fa0/0.1							//	进入子接口fa0/0.1,开启端口
    Router(config-subif)#encapsulation dot1q 10					//	子接口封装802.1q,配置到不同的Vlan中,encapsulation dot1q 后面的数字应为vlan ID
    Router(config-subif)#ip address 192.168.1.1 255.255.255.0	//	设置子接口IP为相应Vlan中的网关地址
    Router(config-subif)#exit
    Router(config)#interface fa0/0.2
    Router(config-subif)#encapsulation dot1q 20
    Router(config-subif)#ip address 192.168.2.1 255.255.255.0
    Router(config-subif)#end
    

    五、查看路由设置

    使用show ip route命令可以看到已经完成路由设置。

    代码如下:

    Router#show ip route
    

    路由设置

    六、Ping测试

    使用PC0与不同VLAN的PC1做ping测试,可ping通。
    ping
    一开始ping不通的时候,可以多ping几次,或者去检查一下相关配置,是不是漏了某个步骤导致没有ping通。


    总结

    本次实验使用单臂路由实现了跨VLAN通信。主要步骤有建立网络拓扑、二层交换机的接口设置(创建VLAN、交换机的VLAN端口分配、交换机的端口分配)、路由器的接口设置。完成以上步骤后,可以查看路由设置并进行ping测试,如果路由配置正确,不同VLAN下的PC可以通过路由器ping通,本次实验就做完了。

    展开全文
  • 两台主机之间的通信,但是VLAN不一样,这是就需要跨vlan通信了,这个实验报告就详细的介绍了跨vlan的通信
  • ip routing要记得开启,不同vlan通信需要三层功能。 3.二层配置好相应的vtp。一般核心层用service,汇聚层用Client(客户机模式,只学习不转发),接入层用Transparent(透明模式,不学习不转发,),交换机默认...

    实验思路:

    1.首先规划好vlan。ip地址。三层交换机个vlan配置好相应的IP充当网关和服务器地址。

    2.在三层交换开启VTP,DHCP服务。ip routing要记得开启,不同vlan间通信需要三层功能。

    3.二层配置好相应的vtp(同域间互相学习或转发VLAN)。一般核心层用service,汇聚层用Client(客户机模式,只学习不转发),接入层用 Transparent(透明模式,不学习不转发,),交换机默认情况是service服务器模式(可以创建,可以学习,可以转发,全能型选手)。

    4.交换机之间的链路开启trunk

    5.划分相应vlan。

    watermark,type_d3F5LXplbmhlaQ,shadow_50,text_Q1NETiBAQmxvZ19fMF8wX18=,size_20,color_FFFFFF,t_70,g_se,x_16

    三层交换:

    SW_3L(config)#vtp domain www

    Changing VTP domain name from NULL to www

    SW_3L(config)#vtp password 123

    Setting device VLAN database password to 123

    不用配置service模式了,默认开启了。show vtp status可查看。

    watermark,type_d3F5LXplbmhlaQ,shadow_50,text_Q1NETiBAQmxvZ19fMF8wX18=,size_18,color_FFFFFF,t_70,g_se,x_16

    SW_3L(config)#vlan 10

    SW_3L(config)#vlan 20

    SW_3L(config)#vlan 30

    SW_3L(config)#int vlan 10

    SW_3L(config-if)#ip add 192.168.10.254 255.255.255.0(vlan20,30以此类推)

    SW_3L(config)#ip dhcp pool vlan_10

    SW_3L(dhcp-config)#network 192.168.10.0 255.255.255.0

    SW_3L(dhcp-config)#default-router 192.168.10.254(后面以此类推)

    SW_3L(config)#interface range f0/1-2

    SW_3L(config-if-range)#switchport trunk encapsulation dot1q

    SW_3L(config-if-range)#switchport mode trunk

    SW_3L(config-if-range)#switchport trunk allowed vlan 10,20,30

    SW_3L(config)#ip routing   !

    二层交换(汇聚层):

    SW_hj1(config)#vtp domain www

    Domain name already set to www.

    SW_hj1(config)#vtp password 123

    SW_hj1device VLAN database password to 123

    SW_hj1(config)#vtp mode client

    Setting device to VTP CLIENT mode

    SW_hj1(config)#int range f0/1-3

    SW_hj1(config-if-range)#switchport mode trunk

    SW_hj1(config-if-range)#switchport trunk allowed vlan 10,20,30

    第二台亲双胞胎兄弟一样的配置。

    接入层:

    Switch(config)#vtp domain www

    Domain name already set to www.

    Switch(config)#vtp password 123

    Setting device VLAN database password to 123

    Switch(config)#vtp mode transparent

    Setting device to VTP TRANSPARENT mode.

    SW_jr1(config)#int f0/3

    SW_jr1(config-if)#switchport mode trunk

    SW_jr1(config-if)#switchport trunk allowed vlan 10

    SW_jr1(config)#int f0/1

    SW_jr1(config-if)#switchport mode access

    SW_jr1(config-if)#switchport access vlan 10

    另外的设备以此类推。

    最后pc开启DHCP获取IP地址,实验即可完成。可简化实验减少一些设备,我也是闲着无聊哈哈哈。

    有哪里不好的地方,请大家指点指点🌚🌚,还有有什么问题可以私信交流,互相讨论🤔🤔🤔

    展开全文
  • ip address 192.168.10.254 255.255.255.0 vlan 20 interface Vlan20 ip address 192.168.20.254 255.255.255.0 2-SW1: vlan 10 int vlan 10 exit vlan 20 int vlan 20 interface FastEthernet0/1 switchport mode...

    目的:PC0 ping通 PC1

     3-SW1:

    ip routing                                                   #三层交换机开启路由功能

    interface FastEthernet0/1

    switchport trunk encapsulation dot1q        #为交换机接口启动bot1q协议

    switchport mode trunk                                #接口模式改为trunk

    vlan 10                                                        #创建vlan 10

    interface Vlan10                                        #将vlan 10 写入路由表

    ip address 192.168.10.254 255.255.255.0

    vlan 20

    interface Vlan20

    ip address 192.168.20.254 255.255.255.0

    2-SW1:

    vlan 10            

    int vlan 10

    exit

    vlan 20

    int vlan 20

    interface FastEthernet0/1

    switchport mode trunk

    interface FastEthernet0/2

    switchport access vlan 10

    interface FastEthernet0/3

    switchport access vlan 20

    PC:

    效果:

    展开全文
  • 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。 计算机网络实验报告:包含拓扑图的详细配置,以及实现原理分析。
  • 6-计算机网络-跨VLAN通信的实现.pdf
  • 跨vlan通信之vlanif配置-华为ensp

    千次阅读 2021-11-16 13:43:32
    跨vlan通信的手段之一:vlanif 定义:VLANIF(Virtual Local Area Network Interface),是华为交换机的一个配置项,应用于三层交换机。这是一种逻辑接口,物理上不存在。 在配置好二层vlan后,三层交换机上使用...
  • GNS3 分配vlan 跨vlan通信实验

    千次阅读 2019-11-22 02:01:44
    一、在一台交换机下分配VLAN 搭建网络拓扑,在一个交换机下分配VLAN,交换机使用CISCO的3725路由器模仿 启动所有设备,并为每台PC配置IP地址 PC1> ip 192.168.0.101 255.255.255.0 Checking for duplicate ...
  • 本次实验使用3台二层交换机和1台三层交换机,实现了办公室内跨VLAN间的通信
  • 出现无法上外网 [Huawei]vlan batch 10 20 [Huawei]interface GigabitEthernet 0/0/1 [Huawei-GigabitEthernet0/0/1]port link-type access [Huawei-GigabitEthernet0/0/1]port default vlan 10 [Huawei]interface ...
  • 设备VLAN通信

    千次阅读 2020-07-15 20:50:34
    在SW1上创建两个VLAN:10及20(分别将这两个VLAN分配给技术部与会计部),然后将GE0/0/1和GE0/0/2接口加入VLAN 10,那么这两个接口所连接的PC(PC1、PC2)也就加入了VLAN 10,并且它们属于同一个广播域。 将GE0/0/3加入...
  • 拓扑如下: 其中g0/0.1与g0/0.2是基于g0/0口(物理端口)的虚拟端口,...注意:encapsulation dot1Q 10 为封装协议,其中10要与Vlan号一样,即vlan10的网关要封装dot1Q 10,vlan20封装dot1Q 20,以此类推。 PC1: ...
  • 跨vlan通信-----单臂路由技术 实验目标: 1):实现跨vlan通信 为什么要使用vlan: 1):提高性能-----------------同一个广播域发送广播,造成网络堵塞。 2):提高安全性--------------同一广播域中,机器设备过多...
  • vlan跨交换机通信

    千次阅读 2021-08-07 20:16:11
    今天周末,这个疫情比较严重被困在家里闲来无事,还是吧vlan之间的通信写一下。主要讲一下昨天没说的trunk,还有单臂路由。 目录 一、vlan交换机运作 二、trunk的作用 三、vlan跨交换机的传输过程 相同vlan间...
  • 单臂路由实现不同VLAN通信 链路类型 子接口 单臂路由的缺陷 CEF是一种基本拓扑转发的模式 交换网络环形路的产生 总结 单臂路由实现不同VLAN通信 链路类型 交换机连接主机的端口为access链路 ...
  • 1)华为的VLAN规则: ①所有数据帧在一个交换机内部转发时,必须存在标签 ②在每一个交换机的接口上均存在转发允许列表,只有被允许的流量才能通过该接口进或出 ③流量从一个接口出去时,可以继续携带标签或者被剥离...
  • 主要介绍了Docker基于macvlan实现主机容器通信,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友可以参考下
  • 和Trunk接口一样,Hybrid接口也能够允许多个VLAN帧通过并且还可以指定哪些VLAN数据帧被剥离标签。在设置允许指定的VLAN通过Hybrid端口之前,该VLAN必须已经存在。Hybrid端口和Trunk端口在接收数据时,处理思路方法是...
  • eNSP单臂路由,跨vlan通信一、实验题目二、实验拓扑图三、实验内容1.配置确定2.主机配置3.配置二层交换机4.配置单臂路由5.测试不同vlan间连通性四、实验总结 一、实验题目 三台二层交换机,一台路由器,四台PC,...
  • 实习周记1:跨vlan通信

    千次阅读 2021-11-25 13:41:47
    跨vlan通信 1.拓扑图: 2.要求:不同vlan的两台pc通过二层交换机实现二层互通 3.命令: [H3C-GigabitEthernet2/0/1]port link-type hybrid 把端口模式改为hydrid [H3C-GigabitEthernet2/0/1]port hybrid vlan 2 ...
  • 1.新建两个pc机器,并配置好ip地址 具体如下 这里我将pc0的ip地址配置为192.168.10.1,pc1ip地址配置为192.168.20.1 ...默认网关分别配置为192.168.10.254和192.168.20.254 ...同样,我们为switch1创建一个vlan20.
  • 网段VLAN间的通信

    千次阅读 2022-03-03 17:44:50
    文章目录网段VLAN间的通信技术背景使用路由器物理接口实现vlan通信使用路由器子接口实现通信子接口处理流程子接口配置示例实例: 网段VLAN间的通信 技术背景 实际网络部署中一般都会将不同IP地址段划分到不同...
  • 二层设备跨vlan通信

    2013-04-16 01:13:10
    三种端口接收到与缺省自己vlanid相同的帧时,它们就会接受,而不同时,access端口就丢弃。Trunk和Hybrid端口看看是否和自己允许的vlanid相同,相同时接受,不同时,抛弃。 在发送时,三种端口vlanid...
  • Switch(config)#vlan 2 //全局配置模式下创建VLAN 2 Switch(config-vlan)#exit Switch(config)#vlan 3 Switch(config-vlan)#exit Switch(config)#int f0/1 //进入端口配置模式 Switch(config-if)#switchport mode ...
  • 文章目录前言一、拓扑图1.Trunk的作用二、划分VLAN三、配置trunk四、测试连通性总结 前言 因为这两天经常遇到划VLAN的问题,所以写个博客加深一下记忆 提示:以下是本篇文章正文内容,下面案例可供参考 一、拓扑图...
  • 1、在多层交换机中配置VLAN间路由选择(IVR),通常配称为交换虚拟接口(SVI)。 2、启用命令:IP routing启用路由选择进程。 3、使用命令:interface VLAN X 为每个VLAN创建一个虚拟接口。 4、给每个虚拟接口...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,256
精华内容 3,302
关键字:

跨vlan通信