精华内容
下载资源
问答
  • 2020-10-18 15:35:37

    内网搭建web服务器

    用Go写了一个网盘,之前一直是在局域网内调试,真正使用起来肯定还是需要能外网访问的。所以,就想着搞一个外网能访问的web服务器。

    之前有了解过如何让外网访问局域网的主机,这样调试什么的都比较方便。当然也可以租个阿里云服务器,把网盘挂上去,这样最简单,看了一下,租个服务器一个月要花好几十,最后决定自己搭服务器。申请公网IP或者用花生壳的内网穿透服务应该可以搞定。

    记录一下整个流程:

    1. 申请公网IP

    2. 端口映射

    3. 申请域名

    一、申请公网IP

    这个比较简单,直接打运营商客服就行了。我用的电信,直接10000号让客服给开通公网IP就好了。然后通过光猫的设置界面能查到WAN IP,这个IP如果和百度搜索本机IP的结果一样的话,说明已经开通公网IP了。但是公网IP不是固定的,在重启光猫后,运营商分配的IP会改变。这里会导致域名解析后,IP地址已经更换了,后面需要设置动态域名解析配置可以解决这个问题的。
    在这里插入图片描述
    在这里插入图片描述

    二、 端口映射

    光猫拥有公网IP后,接入到光猫的设备,会被路由设置为局域网IP,这时,外网是没有办法访问到这些被分配局域网IP的设备的。可以通过将光猫配置桥接模式,然后通过拨号来实现外网设备访问内网设备。或者是通过端口映射或者是DMZ来配置。这里我尝试了光猫改桥接模糊,这时需要光猫的超级管理员账户登陆,通过网上的方法破解了超级管理员的密码,然后登陆进去了,改桥接模式需要拨号账户,也就是宽带账户,这个可以通过中国电信官网查询到的。但是我没有这样做,因为事前没有准备这个账户,修改后,没办法拨号上网。最后尝试了端口映射。这里外部端口应该要大于5000。一般这个设置不是叫端口映射就是脚虚拟主机服务。

    找到一篇讲解的很详细的关于端口映射的文章。

    在这里插入图片描述

    这里又一个疑问,在我映射好后,不知道为什么从外网Ping不同这个主机。不知道是不是因为端口号的原因。尝试把内部端口号改为ssh的默认端口号,ssh服务也登陆不上。(原因:因为运营商对一些常用的端口号进行封禁了,所以我们的21,443,80都是用不了的,所以最好是使用端口映射,将内部的默认端口映射到一个大于5000的端口号)

    DMZ是和端口映射类似的服务。只是相当于把内部端口和外部端口全部映射。这样就不用一个端口一个端口的配置了。测试了DMZ主机,同样也是能访问到内网主机的。并且ssh也能使用了,但是速度ssh的访问速度非常的慢,而且非常大概率的连不上。

    这里我运行我的网盘程序netdisk,然后通过另外一个外网设备(网络是通过联通卡手机开的热点)在地址栏输入http://公网IP:外部端口/login,发现已经能访问我的netdisk服务了。说明映射是成功的。只是好奇为什么Ping不通。(运营商对ping服务也是封禁的)

    在这里插入图片描述

    三、申请域名

    域名我是通过阿里云万网申请的,花了点钱,然后设置域名解析,将这个域名和我的公网IP绑定(这里域名服务商平台有提供这个设置的)。这样访问这个域名就能跳转到我的公网IP下端口映射的服务器了。因为这个公网IP在光猫重启后会改变,所以肯定还是要想办法解决。

    由于路由器一般都是内置的花生壳的动态域名解析服务。所以我申请的阿里云万网域名没有办法用。

    但是,阿里云提供了修改DNS的接口。各个语言的SDK都有API,这里因为我的网盘是Go语言写的,所以我用Go写了一个DDNS的服务,用来实现动态域名解析,解决公网IP变化的问题。

    阿里云设置DDNS(动态域名解析)

    在这里插入图片描述

    之后,通过地址栏输入sault.top:外部端口/login,也访问到了我的netdisk服务。

    在这里插入图片描述

    另外的问题就是,如果是两台设备在一个局域网中,通过公网IP和域名,都是没有办法访问到我的网盘服务的。网上说的是通过DMZ服务实现所有端口的映射就可以了。目前还没尝试。如果要是可以在局域网内进行域名解析的话,这样调试器来也会方便很多的。可以自己配合各DNS服务器,然后将这台DNS服务器作为局域网内的DNS服务器,这样应该就可以实现局域网内的域名解析了。

    更多相关内容
  • 内网主机pc1根据内网DHCP服务器自动获取IP: 内网路由器命令: router(路由器配置(命令行)): no en configure terminal #添加标准ACL列表 access-list 1 permit any #设置分配IP地址池 ip nat pool web 100.0....

    各个接口以及各IP地址的网络拓扑图:

    各个端口以及主机IP,网关按照上述图片配置各个IP等

    内网主机pc1根据内网DHCP服务器自动获取IP:

     内网路由器命令:

    router(路由器配置(命令行)):
    no
    en
    configure terminal
    #添加标准ACL列表
    access-list 1 permit any
    #设置分配IP地址池
    ip nat pool web 100.0.0.3 100.0.0.4 netmask 255.0.0.0
    #设置动态NAT,通过路由器fa1/0接口访问外网
    ip nat inside source list 1 interface fa1/0 overload
    #路由器se2/0为外网网关(出口)(靠近外网的路由器接口)
    int fa1/0
    ip nat outside
    no shutdown
    exit
    #路由器fa4/0为内网网关(入口)(靠近内网的路由器接口)
    int fa0/0
    ip nat inside
    no shutdown
    exit
    #配置静态路由web和dns服务器(将内部的web和dns服务器内部地址映射到相对于外网的地址)
    ip nat inside source static 192.168.1.2 100.0.0.3
    ip nat inside source static 192.168.1.3 100.0.0.4
    
    ##RA(内网循州110段去100查找)
    ip route 110.0.0.1 255.0.0.0 100.0.0.10

    外网路由器RB命令:
     

    ##RB(外网找192段去100段查找)
    ip route 192.168.1.0 255.255.255.0 100.0.0.1

    RA,RB路由器接口se2/0均需要更改时钟频率:

    RA接口se2/0时钟频率:

     RB接口se2/0时钟频率:

     DNS服务器配置网页域名和服务器IP对应:

     DHCP服务器添加一个域名池:

    验证测试:

    内网主机ping外网网址www.it.com:

     

     外网web服务器ping内网网址www.jsj.com:

     

    展开全文
  • 公司现在有个需求是想让外网下载和上传文件到内网的一台服务器,用vpn经常被封不考虑!端口映射吧公司路由器的ip也是一个内网的没法做!我在考虑能不能用一个阿里云服务器做中转所有的请求都访问阿里云然后内网...
  • 通过分析可知,需要将内网服务器IP转换成外网公网IP,被互联网访问。 网络拓扑图: 各个接口名称: DNS网站转换: WEB服务器配置: DNS配置: 内网主机配置: 路由器接口配置: 内网网关...

    假设你是某公司的网络管理员,公司只向ISP申请了一个公网IP,现公司的网站在内网,要求在互联网也可以访问公司网站。

    192.168.1.2是Web服务器的IP地址(内网地址)。通过分析可知,需要将内网服务器IP转换成外网公网IP,被互联网访问。

    网络拓扑图:

    各个接口名称:

     

    DNS网站转换:

     

     WEB服务器配置:

     

     

     DNS配置:

     

     

     

     内网主机配置:

     

     

     路由器接口配置:

    内网网关出口接口fa0-0

     

     外部网关入口接口fa1-0:

     

     

     路由器命令行配置:

    router(路由器配置(命令行)):
    no
    en
    configure terminal
    #添加标准ACL列表
    access-list 1 permit any
    #设置动态NAT,通过路由器fa1/0接口访问外网
    ip nat inside source list 1 interface fa1/0 overload
    #路由器fa1/0为外网网关(出口)(靠近外网的路由器接口)
    int fa1/0
    ip nat outside
    no shutdown
    exit
    #路由器fa0/0为内网网关(入口)(靠近内网的路由器接口)
    int fa0/0
    ip nat inside
    no shutdown
    exit
    #配置静态路由web和dns服务器(将内部的web和dns服务器内部地址映射到相对于外网的地址)
    ip nat inside source static 192.168.1.2 100.0.0.3
    ip nat inside source static 192.168.1.3 100.0.0.4

     验证测试:

    外网ping网站网址可以通

     

     内网ping外网ip可以通

     

    外网通过网站正常访问内部网址

     

     外网通过映射ip正常访问内网网站

     

    展开全文
  • 说明,本机上有web服务器,用一个动态域名解析服务软件进行内网和公网之间的ip地址解析 一 首先在内本机上安装web服务器,windows 是IIS服务器 linux 是Apache 服务器,如下用windows 下的IIS为例: 在系统的...

    说明,本机上有web服务器,用一个动态域名解析服务软件进行内网和公网之间的ip地址解析

    一  首先在内网本机上安装web服务器,windows 是IIS服务器  linux 是Apache 服务器,如下用windows 下的IIS为例:

    在系统的安装过程中IIS是默认不安装的,在系统安装完毕后可以通过添加删除程序加装 IIS。IIS是微软推出的架设 WEB、FTP、SMTP 服务器的一套整合系统组建,捆绑在上列NT核心的服务器系统中。本文针对通过Windows2003 IIS组件配合花生壳动态域名解析软件向互联网提供WEB服务。 

    第一步:安装组件

    在控制面板的添加/删除程序——Windows组件向导——应用程序服务器——选中“Asp.NET”,然后他就会自动把“Internet 信息服务(IIS)”的相关服务也装上。如下图:

    选中后,在网上下载IISxp-5.1,解压后安装。

    二 动态域名解析软件

    1. 每步、希网、花生壳和WingDNS都是动态域名解析软件,打开百度找到他们的网址进行注册用户,在我的控制台里自动生成域名,本人的域名是yedeqixian.@@@@.net/

    2  下载动态域名客户端,而后登陆如下图

    花生壳是。当您安装并注册该项服务,无论您在任何地点、任何时间、使用任何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。

    这时候,花生壳软件已经在线了 ,我们所申请的免费域名已经绑定到当前的公网IP地址,互联网可通过所申请的域名直接访问到当前主机的服务了,如果你的主机接在路由器或代理服务器后,请参考内网建站的文档。下面我们继续WEB服务搭建

    三   建立WEB站点

    1、打开Internet 信息服务(IIS)管理器,可以在 开始 – 运行 – 输入“Inetmgr”打开,也可以通过 控制面板 – 管理工具 进行打开。

    IIS v5.1怎么新建网站呢?

    我刚装完,IIS v5.1。发现无法创建网站,没有这个功能。

    只能在“默认网站”的地方,按右键,然后创建虚拟目录。

    在“网站”那个地方按右键没有新建网站的功能。

    XP系统下的IIS不支持新建网站这个功能,2003系统+IIS 6.0才有这个功能。如果你想使用该功能,只有安装2003系统+IIS 6.0;据说2000系统+IIS 5.0也有该功能,但没试过,不敢肯定。

    IIS建立网站

    下面建立第一个Web站点

    比如本机的IP地址为192.168.0.100,自己的网页放在C:Inetpubwxbweb目录下,网页的首页文件名为Index.htm,现在想根据这些建立好自己的Web服务器。

    对于此Web站点,我们可以用现有的“默认网站”来做相应的修改后,就可以轻松实现。请先在“默认网站”上单击右键,选“属性”,以进入名为“默认Web站点属性”设置界面。

    1.修改主目录:转到“主目录”窗口,再在“本地路径”输入(或用“浏览”按钮选择)好自己网页所在的“C:Inetpubwxbweb”目录。执行权限选中执行脚本,文本

    2.添加首页文件名:转到“文档”窗口,再按“添加”按钮,根据提示在“默认文档名”后输入自己网页的首页文件名“Index.html”。

    3.添加虚拟目录:比如你的主目录在“C:Inetpubwxbweb下。

    4.在网站标识中的描述里写上http://yedeqixian.oi@@.net/

    第五步:测试站点

    打开IE浏览器,在地址栏中输入yedeqixian.oi@@.net/进行测试。在这里要提醒用户,很多时候忘记设置自己的默认首页文档,因此造成无法访问。(可以在站点属性――文档中进行设置),如果自动跳到yedeqixian.oi@@.net//login.asp

    局域网中任何一台登录“动态域名软件”都解析为你的WAN口IP地址,访问到路由器就不足为怪了。应在路由器里设置端口映射(转发规则),把来自外网的访问的80和21端口指向局域网内服务端IP地址就OK了。

    六最后测试

    打开IE浏览器,在地址栏中输入http://yedeqixian.oi@@.net/进行测试。所以不同地方的电脑都可以通过这个你的个人域名访问了

    也祝大家顺利完成!!!

     
    转自: http://jingyan.baidu.com/article/d713063500d12c13fdf475c9.html

    展开全文
  • NAT(Network Address Translation)网络地址转换。
  • 外网访问局域网服务器的六种方法

    万次阅读 多人点赞 2021-12-25 20:56:18
    因为需要在外网访问局域网的服务器,所以研究了下策略。这里做个总结。 2 为什么局域网的服务器无法在外网访问 服务器、电脑之间靠IP地址寻址,目前大部分基于IPV4进行寻址访问。但是因为IPV4的地址数量有限,中国分...
  • 外网如何访问本地tomcat web服务器

    万次阅读 多人点赞 2018-04-16 09:46:59
    首先你要知道你是出于内网还是外网下,其实很简单,百度一下“IP查询”,第一个就是你的外网ip,然后你本地cmd中ipconfig一下就能知道你的本机ip,如果两个ip一样,那么你现在是外网,如果不一样,你就是内网。...
  • 外网访问内网linux服务器方法

    千次阅读 2020-12-19 11:29:23
    结合了Linux提速方法和外网访问内网Linux服务器的方法进行分析。加速Linux的方法:撤消多余的服务根据机器的用途,很多服务是不需要的。要是Linux只用作桌面,就不需要sendmail、httpd和另外许多服务。如果你的...
  • 内部网络的所有主机均可共享一个合法的外部IP地址实现对Internet的访问,从而可以最大限度的节约IP地址资源。同时,又可以英寸那个网络内部的所有主机,有效的避免Internet的攻击。 网络结构图: 说明:被红色矩形...
  • 外网访问内网ERP【内网穿透】

    千次阅读 2022-04-25 16:04:41
    在大内网环境下,要想实现外网访问内网,主要是通过内网穿透来实现,通过第三方有公网IP的服务器来转发,不需要公网IP,不需要进入路由器,也不需要运维人员搭建VPN,在本地安装个内网穿透工具就可以了。...
  • 1.确认路由器的公网IP是不是真...2.搭建服务器web服务端(可以是其他的) web服务端搭建参考:https://blog.51cto.com/u_13869720/2306896 3.确认服务器IP地址和映射端口号 我的是web服务端,用的是默认的80端.
  • 实验环境:思科模拟器Cisco Packet Tracer IP地址划分: WEB:192.168.1.1 DNS:192.168.1.2 ...内网能正常访问外网外网只能访问内网的DNS服务器和WEB服务器 实验拓扑图: 在路由器上的配置: 1、添加标准A...
  • 本篇教程主要将如何快速地搭建本地服务器,以及使用免费的内网穿透工具,实现外网访问内网服务器,将本地网站发布到外网可访问,方便进行微信公众号、小程序开发本地调试等。
  • 外网访问内网(内网穿透)

    千次阅读 2022-05-19 17:30:48
    非学术的说法: 通常个人电脑无论是连接WIFI上网还是用网线上网,都是属于局域网里边的,外网无法直接访问到你的电脑,内网穿透可以让你的局域网中的电脑实现外网访问功能,全国都能访问 内网穿透有什么用? 通过内网...
  • 如何从公网访问局域网WEB服务器

    千次阅读 2018-11-20 13:20:35
    公网访问局域网WEB服务器 本地安装了WEB服务器,只能在局域网内访问,怎样从公网也能访问本地WEB服务器? 本文将介绍具体的实现步骤。 1. 准备工作 1.1 安装并启动WEB服务器 默认安装的WEB服务器端口是80。 2. 实现...
  • 内网穿透:用花生壳实现从外网访问内网web项目一、内网穿透1.1 什么是内网穿透1.2 内网穿透的作用1.3 内网穿透的方法二、花生壳1.1 什么是内网穿透1.2 内网穿透的作用1.3 内网穿透的方法 一、内网穿透 1.1 什么是...
  • 解决局域网用公网域名访问内网web服务器
  • web 服务器内网地址为 10.0.0.1 外网地址为 211.6.15.1 域名为 xx.love.com 问题:在内网10.0.0.2的机器上访问 外网地址 211.6.15.1 或者域名 xx.love.com  都无法访问,  解
  • 在本地内网/局域网环境下搭建的网站,正常情况下只能在同个局域网下访问,想要实现外网用户也能够正常访问,可以通过内网穿透来实现。
  • 但是对于“内网主机通过外网地址访问内网服务器”这一场景,各厂商的实现不通,下面就这个场景,分别说一下各厂商的实现。1.华为2.华三内网用户通过NAT地址访问内网服务器1组网需求 · 某公司内部网络中有一台FTP...
  • 使用ip在主机访问虚拟机中的windows server 2016的web项目(phpstudy) 主机IP:192.168.0.105 虚拟机(windows server2016)ip:192.168.91.129 http://192.168.91.129/或http://localhost/ 主机访问:...
  • 现在184服务器是无法访问外网的,需要使用代理的方法让184通过有外网的183访问外网。 该操作一共可以分为两个部分:一、配置184代理 二、在服务器183上安装代理程序。 配置184代理 直接配置环境变量即可,可以在/etc...
  • Router0: Router>en Router#conf t Router(config)#int g0/0 Router(config-if)#ip address 200.1.8.7 255.255.255.0 Router(config-if)#no shutdown Router(config-if)#exit Router(config)#int g0/1 ...
  • 内网通过外网IP访问内网服务器

    万次阅读 2017-04-21 12:41:19
    我想这个拓扑应该是非常普遍的了,我认为就是因为这个非常普遍的拓扑,造成了很多人所反应的“内网不能通过公网地址访问内网服务器”这个问题。我认为这个问题的关键原因就在于掩码,就是在3层上做文章。 第一...
  • 用静态NAT实现外网PC访问内网服务器

    千次阅读 2019-06-13 21:19:02
    下面是我用思科的仿真软件搭建的一个实验环境,实现外网PC访问内网服务器。 先说明一下实验环境: 路由器R0左边为内网环境,右边为外网环境,内网服务器IP地址为192.168.1.2,网关为R0接口地址192.168.1.1,...
  • 这时可以做内网穿透,通过第三方公网IP服务器进行数据转发,实现外网访问内网服务器。这里推荐一款内网穿透工具——`cpolar`,支持http/https/tcp协议,不限制流量,也支持永久免费使用(随机公网地址、4条免费隧道...
  • 在ipv4公网IP资源枯竭的情况下,运营商基本不会分配公网IP。而想要实现公网访问内网/局域网,普遍是通过内网穿透来实现。...能够将本地端口映射到公网上,生成公网,实现外网任意地点远程访问内网
  • Nginx代理内网服务器访问外网

    千次阅读 2020-11-11 15:10:49
    Nginx代理内网服务器访问外网1.SpringBoot工程配置文件改写2. SpringBoot静态工具类注入配置文件变量3. SpringBoot 使用4. 配置Nginx 问题描述: 有一台服务器A可以访问外网, 服务器B和服务器C和A在一个局域网内, ...
  • 一,动态公网IP环境1,环境描述:路由器分配的是动态公网IP,且有路由管理权限,LINUX主机部署在路由内网。...动态域名解析windows版,实现步骤参考《外网访问内网LINUX-动态公网IP动态域名解析...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 29,786
精华内容 11,914
关键字:

外网访问内网web服务器