精华内容
下载资源
问答
  • 在Packet Tracer 思科模拟器中,进行默认路由器和静态路由的相关配置,在三层路由实现不同vlan间的通信的基础之上,测试多台pc机的连通性。
  • 主要介绍了详解Spring Cloud Gateway基于服务发现的默认路由规则,小编觉得挺不错的,现在分享给大家,也给大家做个参考。一起跟随小编过来看看吧
  • 三层交换机默认路由

    2018-03-10 20:07:44
    配置三层交换机的默认路由,实现不同vlan间的通信。有完整的拓扑图和命令
  • 配置静态路由域默认路由 通过此次实验知道报文的转发,有直接交付与间接交付。如果在同一个域则直接交付,如果不是则交付给其他的路由器,这时需要下一跳路由,如果没有下一跳则交付给默认路由,如果默认路由都找偶...
  • 最全网络路由学习手册,建议网络初级工程师下载使用
  • FatAP3X10XN_V200R005C10SPC700 升级文件
  • 静态路由是指由网络管理员手工配置的路由信息,默认路由是一种特殊的静态路由,本文下面就带来了使用Cisco模拟器进行静态路由和默认路由的配置的教程,希望对大家有所帮助
  • (1) 在路由设置之前,已经给各路由器的接口设置了适当的参数...默认路由的目的地址是0.0.0.0 ,子网掩码为0.0.0.0,第三部分即为下一跳地址,若下一跳为192.168.254.3,则这个整体表达为0.0.0.0 0.0.0.0 192.168.254.3。
  • 默认网关与默认路由

    千次阅读 2021-01-07 17:42:43
    1. 网关 要实现这两个网络之间的通信,则必须通过网关, 网关的IP地址是具有路由功能的设备的IP地址,具有路由功能的设备有路由器、启用了路由协议的服务器...默认路由是一种特殊的静态路由,指的是当路由表中与包的目

    1. 网关

    要实现这两个网络之间的通信,则必须通过网关,
    网关的IP地址是具有路由功能的设备的IP地址,具有路由功能的设备有路由器、启用了路由协议的服务器(实质上相当于一台路由器)、代理服务器(也相当于一台路由器)
    一台主机可以有多个网关。默认网关的意思是一台主机如果找不到可用的网关,就把数据包发给默认指定的网关,由这个网关来处理数据包。现在主机使用的网关,一般指的是默认网关。
    其实我们在我们PC机上配的默认网关就是默认路由

    2. 默认路由(缺省路由)

    默认路由是一种特殊的静态路由,指的是当路由表中与包的目的地址之间没有匹配的表项时路由器能够做出的选择。(默认情况下在路由表中直连路由优先级最高,静态路由优先级其次,下来为动态路由默认路由最低!)如果没有默认路由,那么目的地址在路由表中没有匹配表项的包将被丢弃。

    3. 交换机上的vlan

    3.1 同一物理交换机中的VLAN形成原理

    理解VLAN的形成原理关键就是要理解“虚拟”这两个字。“虚拟”表示VLAN所组成的是一个虚拟,或者说是逻辑 LAN,并不是一个物理 LAN。通过不同的划分规则(具体要依据不同的 VLAN 划分方式而定,将在下节具体介绍)把连接的交换机上的各个用户主机划分到不同的 VLAN 中,同一个交换机中划分的各个 VLAN 可以理解为一个个虚拟交换机。图6-2所示的物理交换机中就划分了5个VLAN,相当于有5个相互只有逻辑连接关系的虚拟交换机。
    在这里插入图片描述
    其实只要把一个 VLAN 看成一台交换机(只不过它是逻辑意义上的虚拟交换机 ),以前许多问题就比较好理解了,因为虚拟交换机与物理交换机具有许多相同的基本属性。同一物理交换机上的不同VLAN之间就像永远不可能有物理连接,只有逻辑连接 的不同物理交换机一样。既然没有物理连接,那不同VLAN肯定是不能直接相互通信的,即使这些不同VLAN中的成员都处于同一IP网段,因为不同VLAN间的二层通信是隔离了的,只能通过更高的三层进行相互通信。但要注意,这里有一个必须的条件,就是这些不同VLAN必须位于同一个物理交换机上 ,如果同处于一个IP网段的不同VLAN位于不同交换机上,则又会有所不同(有时是可以直接互通的),具体将在本节后面介绍。

    位于同一VLAN中的端口成员就相当于同一物理交换机上的端口成员一样,不同情况仍可以按照物理交换机来处理。如同一 VLAN 中的各成员计算机可以属于同一个 IP网段,也可以属于不同IP网段,但通常是把属于同一网段的节点划分到同一VLAN中。如果VLAN的各成员计算机都属于同一个IP网段,则没什么,肯定可以相互通信,就像同一物理交换机上连接同一网段的各计算机一样;但如果同一VLAN中的成员计算机是属于不同IP网段,则相当于一台物理交换机上连接处于不同网段的主机用户一样,这时肯定得通过路由或者网关配置来实现相互通信了,即使它们位于同一个VLAN中。

    3.2 不同物理交换机中的VLAN

    因为一个VLAN中成员计算机不是依据成员的物理位置来划分的,所以这些成员计算机通常连接在网络中的不同交换机上,这样才更显示出 VLAN 切分的灵活性和实用性。也就是说一个VLAN可以跨越多台物理交换机,这就是VLAN的中继(Trunk)功能。这时就不要总按照物理交换机来看待用户主机的分布了,而要从逻辑的VLAN角度来看待了。图 6-3就不是把它当成两台物理交换机,而是把它当成是五台(VLAN 1、VLAN 2、VLAN 3、VLAN 4和VLAN 5)仅存在逻辑连接关系,但两台物理交换机中相同的 VLAN 间有相互物理连接关系(就是两台物理交换机间的物理连接)的虚拟交换机了。通常情况下(有特殊情况,具体在下一段介绍),这五个VLAN间的用户是二层隔离的,也就是不能直接互通,仅可以通过网络体系结构中的第三层(网络层)实现互通。
    在这里插入图片描述
    在同一物理交换机上不可能存在两个相同的VLAN,而在不同交换机上可以有相同的VLAN,而且这些不同物理交换机 上的相同VLAN 间一般情况下是可以直接互访的,当然这得要求它们都位于同一个IP网段,且在物理交换机连接的端口上允许这些VLAN数据包通过。不仅如此,如果位于不同交换机 上的两个不同VLAN 处于同一个IP网段 ,且交换机间连接的两个端口是分别隶属通信双方VLAN的Access端口,或者不带VLAN标签的Hybrid端口,则这两个VLAN间也是可以直接通信的。这就涉及Access、Trunk和Hybrid这三种最基本的二层端口的属性和数据收、发规则了,具体将在本章后面介绍具体二层端口类型时再进行介绍。

    【经验之谈】 这里要区分“VLAN 中继”和“中继端口”这两个概念。
    VLAN 中继是指在一台交换机上的VLAN配置信息可以传播、复制到网络中相连的其他交换机上,在华为交换机上采用的是GVRP(GARP VLAN Registration Protocol,GARP VLAN注册协议)的VLAN自动注册功能来实现的;
    而Trunk(中继)端口则是指在一个交换机端口允许一个或多个 VLAN 通信到达网络中相连的另一台交换机上相同的 VLAN 中。这是两个不同的概念。有关GVRP的VLAN注册功能及配置方法将在本章6.8节具体介绍。

    3.3 两种VLAN间通信方式

    VLAN间的三层通信存在两种不同的情形:一是相互通信的不同VLAN同处于一个交换机上,二是相互通信的不同VLAN处于不同的交换机上。下面分别介绍这两种VLAN间通信方式。

    1.同一台交换机上的VLAN间通信

    这种情形的示意图如图 6-18所示。示例中的VLAN 2、VLAN 3和VLAN 4在同一个三层交换机(也可以是路由器)上。此时要实现这3个VLAN间的三层通信只需在该三层交换机为这3个VLAN各自配置VLANIF接口IP地址(要求在不同IP子网中)即 可,因为在华为交换机中IP路由功能是一直启用的,加上这些VLAN是直接连接在同一台三层交换机上,相当于直连路由,所以无需其他额外配置就可以实现同一台交换机上不同VLAN间的三层互通。
    在这里插入图片描述
    2.不同交换机上的VLAN间通信

    这种情形的示意图如图 6-19所示。示例中的VLAN 2、VLAN 3和VLAN 4不仅在同一台三层交换机(也可以是路由器)上有,而且在不同的三层交换机上也有,这就涉及跨三层设备的VLAN间通信问题了。如果相互通信的不同VLAN位于不同的三层交换机上,不仅要为各VLAN配置VLANIF接口IP地址(不同交换机中的相同VLAN各自可以配置一个同网段的 VLANIF接口IP地址),还要在三层设备上配置到达各个 VLANIF 接口所在网段的可达路由(可以是静态路由,也可以是各种动态路由)。
    在这里插入图片描述

    vlan 间

    通过VLANIF接口实现跨越三层网络通信的配置示例

    VLANIF接口实现跨越三层网络通信

    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 !---允许VLAN 10通过
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interfacegigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 30 !---允许VLAN 30通过
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.10.10.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 30.30.30.1 24
    [SwitchA-Vlanif30] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network10.10.10.0 0.0.0.255 !----宣告VLAN 10所在的网段
    [SwitchA-ospf-1-area-0.0.0.0] network30.30.30.0 0.0.0.255 !----宣告VLAN 30所在的网段
    [SwitchA-ospf-1-area-0.0.0.0] quit
    
    
    
    [SwitchB] vlan batch 10 30
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 30 
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 20.20.20.1 24
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif30
    [SwitchB-Vlanif30] ip address 30.30.30.2 24 
    [SwitchB] router id 2.2.2.2
    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network20.20.20.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network30.30.30.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    

    配置通过子接口实现VLAN间通信

    通过子接口实现VLAN间通信

    [HUAWEI] interfacegigabitethernet1/0/1.1
    [HUAWEI-GigabitEthernet1/0/1.1] dot1q termination vid 10
    [HUAWEI-GigabitEthernet1/0/1.1] ip address 10.10.10.1 24
    [HUAWEI-GigabitEthernet1/0/1.1] arp broadcast enable
    [HUAWEI-GigabitEthernet1/0/1.1] quit
    [HUAWEI] interface gigabitethernet 1/0/2.1
    [HUAWEI-GigabitEthernet1/0/2.1] dot1q termination vid 20
    [HUAWEI-GigabitEthernet1/0/2.1] ip address 20.20.20.1 24
    [HUAWEI-GigabitEthernet1/0/2.1] arp broadcast enable
    [HUAWEI-GigabitEthernet1/0/2.1] quit
    

    通过VLAN Switch实现VLAN间通信

    VLAN Switch功能仅在 SS7700、S9300、S9300E和 S9700等华为高端 S系列交换机中支持 ,可通过以下两种方式实现VLAN间通信。

    (1)替换外层VLAN标签,即VLAN Switch switch-vlan功能,与VLAN Mapping (VLAN映射)功能类似,可实现VLAN间通信。本节主要介绍VLAN Switch switch-vlan功能的配置方法。

    (2)添加外层VLAN标签功能,即VLAN Switch stack-vlan功能,与VLAN Stacking功能类似,是一种针对用户不同VLAN封装外层VLAN标签的二层技术。关于VLAN Switch stack-vlan功能的配置将在本章后面介绍QinQ协议时再介绍。
    在这里插入图片描述

    1.配置SwitchA、SwitchB的相关接口加入VLAN
    2. 配置Switch的VLAN Switch功能。把GE1/0/1端口上接收到的VLAN 10帧中的VLAN标签替换成VLAN 20,然后从GE1/0/2端口发送出去

    <HUAWEI>system-view
    [HUAWEI] vlan-switch name1 interfacegigabitethernet1/0/1 vlan 10 interfacegigabitethernet1/0/2 switch-vlan 20
    

    注意
    VLAN10、VLAN20不能是Switch已经创建的全局VLAN,且GE1/0/1端口不能 加入VLAN 10,GE1/0/2端口不能加入VLAN 20,否则无法配置VLAN Switch。
    配置完成后,VLAN10内的PC与VLAN20内的PC能够相互访问。从中看出,采用VLAN Switch功能实现VLAN间通信的配置很简单。

    展开全文
  • 默认路由与浮动路由

    千次阅读 2021-07-26 13:25:32
    文章目录前言一、默认路由1.为什么要用默认路由2.什么情况用默认路由3.路由器转发数据包的封装过程4.交换机与路由器对比5.配置默认路由1.拓扑图2.配置R13.配置R24.配置R35.pc配置6.测试连通性二、浮动路由1.浮动路由...


    前言

    默认路由是静态路由的一种特殊形式,是用来匹配用户的不同的上网需求


    一、默认路由

    1.为什么要用默认路由

    当路由器在路由表中找不到目标网络的路由条目时,路由器把请求转发到默认路由接口,表示形式 0.0.0.0/0

    2.什么情况用默认路由

    末节网络才可使用默认网络

    3.路由器转发数据包的封装过程

    数据转发过程中,源 目 IP保持不变;MAC地址随转发对象不同而不同

    4.交换机与路由器对比

    路由器工作在网络层:根据“路由表”转发数据;路由选择;路由转发。
    交换机工作在数据链路层:根据“MAC地址表”转发数据;硬件转发。

    5.配置默认路由

    1.拓扑图

    在这里插入图片描述

    2.配置R1

    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
    [R1-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 10.1.1.1 24	
    [R1-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R1-GigabitEthernet0/0/1]q
    [R1]ip route-static 0.0.0.0 0 10.1.1.2
    
    

    3.配置R2

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 10.1.1.2 24	
    [R2-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 10.1.2.2 24	
    [R2-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R2-GigabitEthernet0/0/1]q
    [R2]ip route-static 192.168.1.0 24 10.1.1.1
    [R2]ip route-static 192.168.2.0 24 10.1.2.3
    

    4.配置R3

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 10.1.2.3 24	
    [R3-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 192.168.2.3 24
    [R3-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R3-GigabitEthernet0/0/1]q
    [R3]ip route-static 0.0.0.0 0 10.1.2.2
    
    

    5.pc配置

    在这里插入图片描述
    在这里插入图片描述

    6.测试连通性

    在这里插入图片描述
    在这里插入图片描述

    二、浮动路由

    1.浮动路由是什么

    浮动路由指的是配置两条静态路由,默认选取链路质量优(带宽大的)作为主路径,当路径出现故障时,由带宽较小的备份路由顶替,保持网络的不中断。

    2.在默认路由基础上配置浮动路由

    1.拓补图

    AR1和AR2之间加了一条链路,网段设为 10.1.3.0/24
    在这里插入图片描述

    2.配置R1

    [R1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip add 10.1.3.1 24	
    [R1-GigabitEthernet0/0/2]undo shutdown 
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [R1-GigabitEthernet0/0/2]q
    [R1]ip route-static 0.0.0.0 0 10.1.3.2 preference 65
    //优先级要设置比60大,范围为1-255
    
    

    3.配置R2

    [R2]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip add 10.1.3.2 24	
    [R2-GigabitEthernet0/0/2]undo shutdown 
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [R2-GigabitEthernet0/0/2]q
    [R2]ip route-static 192.168.1.0 24 10.1.3.1 preference 65
    
    

    4.验证

    关闭10.1.1.0网段链路,PC1和PC2仍可互通,证明备用链路可用

    [R1]int g0/0/1	
    [R1-GigabitEthernet0/0/1]shutdown 
    
    

    在这里插入图片描述
    验证成功


    总结

    默认路由可以简化路由器路由表配置,简洁高效。浮动路由提高可靠性,保持网络的不中断。

    展开全文
  • 静态路由和默认路由小结

    千次阅读 2018-09-16 09:33:59
    静态路由和默认路由 介绍: 路由器在转发数据时,需要现在路由表中查找相应的路由,有三种途径: (1)直连路由:路由器自动添加和自己直连的路由 (2)静态路由:管理员手动添加的路由 (3)动态路由:由路由...

    静态路由和默认路由

    介绍:

    路由器在转发数据时,需要现在路由表中查找相应的路由,有三种途径:

    (1)直连路由:路由器自动添加和自己直连的路由

    (2)静态路由:管理员手动添加的路由

    (3)动态路由:由路由协议动态建立的路由

    静态路由:

    缺点是不能动态的反映网络拓扑,当网络发生变化的时候,管理员必须手动的改变路由

    优点是不会占用路由器太多的cpu和RAM资源,也不会占用太多带宽。

    如果出于安全的考虑想隐藏网咯的某些部分或者管理员想控制数据转发路径也可以使用静态路由,小网络也可以配置静态路由 因为便捷

    配置静态路由的命令为“ip route”例子如下

    ip route 192.168.1.0 255.255.255.0 s0/0

    ip route 192.168.1.0 255.255.255.0 12.1.1.1

    注意:写静态路由时,如果链路是点到点的网络(或者ppp封装的链路等)采用接口模式或网关都可以

             如果是多路访问的链路,只能使用网关格式

     

    R1#show ip route

    Codes; C - connected, S -static, I - IGRP, R - RIP, M - mobile, B - BGP

           D- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

           N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1- OSPF external type 1, E2 - OSPF external type 2, E - EGP

           i- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -IS-IS inter area

           *- candidate default, U - per-user static route, o - ODR

           P- periodic downloaded static route

     

    Gateway of last resort is not set

    R   172.160.0.0/16[120/2]via 10.1.0.2,00;00;21, Serial0/0

                      [120/2]via 10.3.0.2,00;00;06,Serial0/1

         10.0.0.0/16 is subnetted, 4 subnets

    R     10.2.0.0[120/1]via 10.1.0.2,00;00;21,Serial0/0

    C     10.3.0.0 is directly connected, Serial0/1

    C     10.1.0.0 is directly connected, Serial0/0

    R     10.4.0.0[120/1]via 10.3.0.2,00;00;06, Serial0/1

    C   192.168.1.0/24 is directly connected, FastEthernet0/0

    解析:“C”为直连网络 “S”为静态路由。”R”表示这条路由是”RIP”协议学习得到的;

    ”10.2.0.0”是目的网络;”[120/1]”是管理距离(Administrative Distance ,AD)/度量值(Metric);

    ”via 10.1.0.2”是达目的网络的下一跳路由器的IP地址;”00;00;21”是指路由器最近一次得知路由到现在的时间;

    ”Serials0/0”是指到达下一跳应从哪个端口出去。

    技术要点:

    管理距离(AD)用来表示路由的可信度,路由器可能从多种途径获得同一路由,路由表中管理距离值越小,说明路由的可靠程度就越高,

     

     

    路由协议的默认管理距离

    路由协议

    管理距离

    直连接口

    0

    静态路由

    1

    外部BGP

    20

    内部EIGRP

    90

    IGRP

    100

    OSPF

    110

    技术要点:

    度量值:(metric)某一个路由协议判别到达目的网络的最佳路径的方法。当路由器有多个路径到达某一目的网络,路由协议判断哪一条是最佳的放到路由表中,路由协议会给每一条路径计算出一个数值,这个数值就是度量值,没有单位。度量值越小,路径越佳。不同的路由协议定义的度量值方法不用,选出的最佳路径可能也不一样

     

    默认路由

    是指路由器在路由表中如果找不到到达目的得具体路由时,最后会采用的路由,默认路由通常会在出口网络中使用 

    命令为:ip route 0.0.0.0 0.0.0.0 {网关地址| 接口}

    列子:ip route 0.0.0.0 0.0.0.0 s0/0

             ip route 0.0.0.0 0.0.0.0 12.12.12.12

     

    ip classless:

    看本图 如果在R1上配置了默认路由:ip route 0.0.0.0 0.0.0.0 s0/0/0,那么路由器R1是否会把到达10.2.2.0/24的网络数据从s0/0/0接口发出去将取决于是否执行了“ip classless”命令,如果执行了(实际上是默认值),则路由器存在默认路由时,所有在路由表中查不到具体路由的数据包将通过默认路由发送

     

    如果执行了“no ip classless”,当路由器存在一主类网络的某一子网时,路由器将认为自己已经知道该网络主类网络的全部的子网的路由,这样即使存在默认路由,到达该主类网络子网的数据包不会通过默认路由发送。图中执行了”no ip classless”后,由于路由器R1上有10.0.0.0的子网10.1.1.0/24(这是直连路由),因此路由器R1收到到达10.2.2.0/24子网的数据包不会使用默认路由进行发送。然而,如果数据包是要达10.2.2.0/24的,默认路由会被采用,因为R1没有任何10.0.0.0子网的路由

    1静态路由和默认路由

    介绍:

    路由器在转发数据时,需要现在路由表中查找相应的路由,有三种途径

    (1)直连路由:路由器自动添加和自己直连的路由

    (2)静态路由:管理员手动添加的路由

    (3)动态路由:由路由协议动态建立的路由

    静态路由的缺点是不能动态的反映网络拓扑,当网络发生变化的时候,管理员必须手动的改变路由

                   优点是不会占用路由器太多的cpu和RAM资源,也不会占用太多带宽。

    如果出于安全的考虑想隐藏网咯的某些部分或者管理员想控制数据转发路径也可以使用静态路由,小网络也可以配置静态路由 因为便捷

    配置静态路由的命令为“ip route”列子如下

    ip route 192.168.1.0 255.255.255.0 s0/0

    ip route 192.168.1.0 255.255.255.0 12.1.1.1

    注意:写静态路由时,如果链路是点到点的网络(或者ppp封装的链路等)采用接口模式或网关都可以

             如果是多路访问的链路,只能使用网关格式

     

    R1#show ip route

    Codes; C - connected, S -static, I - IGRP, R - RIP, M - mobile, B - BGP

           D- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

           N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1- OSPF external type 1, E2 - OSPF external type 2, E - EGP

           i- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -IS-IS inter area

           *- candidate default, U - per-user static route, o - ODR

           P- periodic downloaded static route

     

    Gateway of last resort is not set

    R   172.160.0.0/16[120/2]via 10.1.0.2,00;00;21, Serial0/0

                      [120/2]via 10.3.0.2,00;00;06,Serial0/1

         10.0.0.0/16 is subnetted, 4 subnets

    R     10.2.0.0[120/1]via 10.1.0.2,00;00;21,Serial0/0

    C     10.3.0.0 is directly connected, Serial0/1

    C     10.1.0.0 is directly connected, Serial0/0

    R     10.4.0.0[120/1]via 10.3.0.2,00;00;06, Serial0/1

    C   192.168.1.0/24 is directly connected, FastEthernet0/0

    :“C”为直连网络“S”为静态路由。”R”表示这条路由是”RIP”协议学习得到的;”10.2.0.0”是目的网络;”[120/1]”是管理距离(Administrative Distance ,AD)/度量值(Metric);”via 10.1.0.2”是达目的网络的下一跳路由器的IP地址;”00;00;21”是指路由器最近一次得知路由到现在的时间;”Serials0/0”是指到达下一跳应从哪个端口出去。

    技术要点:

    管理距离(AD)用来表示路由的可信度,路由器可能从多种途径获得同一路由,路由表中管理距离值越小,说明路由的可靠程度就越高,

     

    路由协议的默认管理距离

     

    路由协议

    管理距离

    直连接口

    0

    静态路由

    1

    外部BGP

    20

    内部EIGRP

    90

    IGRP

    100

    OSPF

    110

    技术要点:

    度量值:(metric)某一个路由协议判别到达目的网络的最佳路径的方法。当路由器有多个路径到达某一目的网络,路由协议判断哪一条是最佳的放到路由表中,路由协议会给每一条路径计算出一个数值,这个数值就是度量值,没有单位。度量值越小,路径越佳。不同的路由协议定义的度量值方法不用,选出的最佳路径可能也不一样

     

    默认路由

    是指路由器在路由表中如果找不到到达目的得具体路由时,最后会采用的路由,默认路由通常会在出口网络中使用 

    命令为:ip route 0.0.0.0 0.0.0.0 {网关地址| 接口}

    列子:ip route 0.0.0.0 0.0.0.0 s0/0

             ip route 0.0.0.0 0.0.0.0 12.12.12.12

     

    ip classless:

    看本图 如果在R1上配置了默认路由:ip route 0.0.0.0 0.0.0.0 s0/0/0,那么路由器R1是否会把到达10.2.2.0/24的网络数据从s0/0/0接口发出去将取决于是否执行了“ip classless”命令,如果执行了(实际上是默认值),则路由器存在默认路由时,所有在路由表中查不到具体路由的数据包将通过默认路由发送

     

    如果执行了“no ip classless”,当路由器存在一主类网络的某一子网时,路由器将认为自己已经知道该网络主类网络的全部的子网的路由,这样即使存在默认路由,到达该主类人椅子往的数据包不会通过默认路由发送。图中执行了”no ip classless”后,由于路由器R1上有10.0.0.0的子网10.1.1.0/24(这是直连路由),因此路由器R1收到到达10.2.2.0/24子网的数据包不会使用默认路由进行发送。然而,如果数据包是要达20.2.2.0/24的,默认路由会被采用,因为R1没有任何20.0.0.0子网的路由

    展开全文
  • 配置静态路由,动态路由,默认路由

    万次阅读 多人点赞 2019-07-30 16:06:09
    一、什么是路由 路由(routing)是指分组从源到目的地时,决定端到端路径的网络范围的进程[1]。路由工作在OSI参考模型第三层——网络层的数据包转发设备。路由器通过转发数据包来实现网络互连。虽然路由器可以支持...

    一、什么是路由

          路由(routing)是指分组从源到目的地时,决定端到端路径的网络范围的进程 [1]  。路由工作在OSI参考模型第三层——网络层数据包转发设备。路由器通过转发数据包来实现网络互连。虽然路由器可以支持多种协议(如TCP/IP、IPX/SPX、AppleTalk等协议),但是在我国绝大多数路由器运行TCP/IP协议。路由器通常连接两个或多个由IP子网或点到点协议标识的逻辑端口,至少拥有1个物理端口。路由器根据收到数据包中的网络层地址以及路由器内部维护的路由表决定输出端口以及下一跳地址,并且重写链路层数据包头实现转发数据包。路由器通过动态维护路由表来反映当前的网络拓扑,并通过网络上其他路由器交换路由和链路信息来维护路由表。\

         路由器用一句话概况就是可以使不同网段的主机进行通信

      1.交换算法

            交换算法相对而言较简单,对大多数路由协议而言是相同的,多数情况下,某主机决定向另一个主机发送数据,通过某些方法获得路由器的地址后,源主机发送指向该路由器的物理(MAC)地址的数据包,其协议地址是指向目的主机的。

            路由器查看了数据包的目的协议地址后,确定是否知道如何转发该包,如果路由器不知道如何转发,通常就将之丢弃。如果路由器知道如何转发,就把目的物理地址变成下一跳的物理地址并向之发送。下一跳可能就是最终的目的主机,如果不是,通常为另一个路由器,它将执行同样的步骤。当分组在网络中流动时,它的物理地址在改变,但其协议地址始终不变。

       2.工作原理

            路由器的某一个接口接收到一个数据包时,会查看包中的目标网络地址以判断该包的目的地址在当前的路由表中是否存在(即路由器是否知道到达目标网络的路径)。如果发现包的目标地址与本路由器的某个接口所连接的网络地址相同(直连端口),那么马上数据转发到相应接口;如果发现包的目标地址不是自己的直连网段,路由器会查看自己的路由表,查找包的目的网络所对应的接口,并从相应的接口转发出去;如果路由表中记录的网络地址与包的目标地址不匹配,则根据路由器配置转发到默认接口,在没有配置默认接口的情况下会给用户返回目标地址不可达的 ICMP (ping命令)信息。

    3.什么是路由表

           在计算机网络中,路由表(routing table)或称路由择域信息库(RIB, Routing Information Base),是一个存储在路由器或者联网计算机中的电子表格(文件)或类数据库。路由表存储着指向特定网络地址的路径(在有些情况下,还记录有路径的路由度量值)。路由表中含有网络周边的拓扑信息。路由表建立的主要目标是为了实现路由协议和静态路由选择。

    路由表从左到右对应的参数为

    destination/Mask      Proto       Pre    Cost        Flag           NextHop               Interface

    目的地址/子网掩码   优先级     路由开销           标识         下一跳IP地址         输出接口

    对应的含义

    destination:目的地址,用来标识IP包的目的地址或者目的网络。

    mask:网络掩码,与目的地址一起标识目的主机或者路由器所在的网段的地址。

    pre:标识路由加入IP路由表的优先级。可能到达一个目的地有多条路由,但是优先级的存在让他们先选择优先级高的路由进行利用。

    cost:路由开销,当到达一个目的地的多个路由优先级相同时,路由开销最小的将成为最优路由。

    interface:输出接口,说明IP包将从该路由器哪个接口转发。

    nexthop:下一跳IP地址,说明IP包所经过的下一个路由器。

     4.为什么使用路由器

       想要讲清这个问题,读者需要先了解VLAN的作用,(点这里https://blog.csdn.net/ck784101777/article/details/97659535)

       在一个局域网中,通常有不同网段(不同vlan)的机群,仅使用交换机是无法使它们互相通信的,而路由器就是解决不同vlan之间互相通信而存在的.

    二、配置静态路由

         静态路由(英语:Static routing),一种路由的方式,路由项(routing entry)由手动配置,而非动态决定。与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是由网络管理员逐项加入路由表

         静态路由需要管理员手动配置,一般用于主机数量较少的情况

         如图所示有三个网段的主机群,并且通过两个路由器进行跨网段转发数据.

        

    利用eNSP建立拓扑图,设置主机ip/子网掩码,对路由器R1,R2进行配置

    路由配置思路:

          ①为路由器的端口配置ip地址

          ②配置路由表

         这里使用静态路由配置路由表,目的是在路由表中加入需访问网段的ip地址,并添加下一跳的端口ip

         如R1,需要配置192.168.3.1和192.168.4.1的主机ip,并且下一跳的端口为R2的g0/1端口(192.168.2.2)                 

       R1配置:

    1. <Huawei>system-view                                                                     //进入系统视图
    2. [Huawei]interface GigabitEthernet 0/0/0                                          //进入0/0/0接口视图
    3. [Huawei-GigabitEthernet0/0/0]ip address 192.168.1.254 24           //为端口0/0/1配置ip地址
    4. [Huawei-GigabitEthernet0/0/0]quit                                                   //离开接口视图
    5. [Huawei]interface GigabitEthernet 0/0/1                                          //进入0/010接口视图
    6. [Huawei-GigabitEthernet0/0/1]ip address 192.168.2.1 24        
    7. [Huawei]ip route-static 192.168.3.0 24 192.168.2.2                  //配置静态路由,连通3.0的网段,设置下一跳地址为R2的1接口
    8. [Huawei]ip route-static 192.168.4.0 24 192.168.2.2                       //配置静态路由,连通4.0的网段

      R2配置:

    1. <Huawei>system-view
    2. [Huawei]interface GigabitEthernet 0/0/0
    3. [Huawei-GigabitEthernet0/0/0]ip address 192.168.3.254 24            //为端口0配置ip
    4. [Huawei-GigabitEthernet0/0/0]quit
    5. [Huawei]interface GigabitEthernet 0/0/1
    6. [Huawei-GigabitEthernet0/0/1]ip address 192.168.2.2 24            //为端口1配置ip
    7. [Huawei-GigabitEthernet0/0/1]quit
    8. [Huawei]interface GigabitEthernet 0/0/2
    9. [Huawei-GigabitEthernet0/0/2]ip address 192.168.4.254 24         //为端口2配置ip
    10. [Huawei]ip route-static 192.168.1.0 24 192.168.2.1                //配置静态路由,连通1.0的网段

    为3台主机配置ip地址,子网掩码和网关,网关填写所连路由器上的端口ip

    测试内容:

          1.0网段ping 2.0网段      通信成功

          1.0网段ping 4.0 网段     通信成功

          2.0网段ping 4.0 网段     通信成功

    三、配置动态路由

      看一下这个案例,我们需要实现全网互通,即vlan1.2.3.4实现互通

    1.用什么设备   

    我们使用一台普通交换机,一台三层交换机,一台路由器,和4台主机

       那么如何实现全网互通呢? 我们需要分析三台设备各种执行什么功能.

       普通交换机:划分vlan1,vlan2,vlan3,将同网段的主机添加到所属vlan中,使用trunk中继链路向三层交换机传递数据

       三层交换机:这是整个拓扑图的关键所在,在整个案例中,三层交换机充当了路由器的效果,即配置了3个虚拟端口(通过vlan),因为每个vlan的主机都需要配置自己的网关,并且是相同网段的网关,而路由器通常只有三个接口,所以这里使用三层交换机创建虚拟端口来代替路由器的端口(实际上三层交换机也可以充当路由器使用,但是它少了很多路由器的功能)

       路由器:在这个案例中,这台路由器显得有点多余,因为我们已经使用三层交换机充当路由器了,ip为192.168.5.1的主机可以直接访问三层交换机的端口. 为什么使用路由器呢? 因为路由器实际上实现了很多三层交换机不具备的功能,并且处理数据的能力要强于三层交换机,所以这个使用还是添加了路由器,大家可以对这个案例拓展一下,移除路由器,尝试使用三层交换机进行不同vlan之间的通信.

     2.用什么协议 -ospf

        有了设备后,我们还需要一种协议来做动态路由配置,那就是ospf协议

          OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯加算法被用来计算最短路径树。OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等.

           OSPF的简单说就是两个相邻的路由器通过发报文的形式成为邻居关系,邻居再相互发送链路状态信息形成邻接关系,之后各自根据最短路径算法算出路由,放在OSPF路由表,OSPF路由与其他路由比较后优的加入全局路由表。整个过程使用了五种报文、三个阶段、四张表.

      s3700普通交换机配置:

    1. [Huawei]vlan batch 2 3            //创建VLAN2、3 ,vlan1默认存在
    2. [Huawei]interface Ethernet0/0/2           //进入2接口
    3. [Huawei-Ethernet0/0/2]port link-type access    //将连接模式改为access (如果不做这个操作是无法划分vlan的)
    4. [Huawei-Ethernet0/0/2]port default vlan 2          //添加到vlan2中
    5. [Huawei]interface Ethernet0/0/3          //进入3接口
    6. [Huawei-Ethernet0/0/3]port link-type access
    7. [Huawei-Ethernet0/0/3]port default vlan 3
    8. [Huawei]interface Ethernet0/0/22        
    9. [Huawei-Ethernet0/0/22]port link-type trunk           //将连接类型改为trunk  中继链路(因为有三个vlan的数据需要传递)
    10. [Huawei-Ethernet0/0/22]port trunk allow-pass vlan all   //允许所有网段传输

     S5700三层交换机配置:

    1. [Huawei]vlan batch 2 3 4            //创建VLAN2、3、4 ,目的是为了配置虚拟端口
    2. [Huawei]interface Vlanif 1           //进入vlan1
    3. [Huawei-Vlanif4]ip address 192.168.1.254 24   //配置ip 作为端口使用
    4. [Huawei]interface Vlanif 2 
    5. [Huawei-Vlanif4]ip address 192.168.2.254 24
    6. [Huawei]interface Vlanif 3
    7. [Huawei-Vlanif4]ip address 192.168.3.254 24
    8. [Huawei]interface Vlanif 4
    9. [Huawei-Vlanif4]ip address 192.168.4.1 24
    10. [Huawei]interface GigabitEthernet 0/0/1              //进入端口1
    11. [Huawei-GigabitEthernet0/0/1] port link-type trunk           //这个端口是连接普通交换机的,同样配置成trunk类型
    12. [Huawei-GigabitEthernet0/0/1] port trunk allow-pass vlan all
    13. [Huawei]interface GigabitEthernet 0/0/2                  //进入端口2
    14. [Huawei-GigabitEthernet0/0/2] port link-type access    //这个端口连接路由器,借用vlan4的ip作为虚拟端口使用
    15. [Huawei-GigabitEthernet0/0/2] port default vlan 4       
    16. [Huawei]ospf 1                              //使用ospf协议进行宣告,告诉邻居路由器自己所连同的主机地址
    17. [Huawei-ospf-1]area 0                  //进入区域0 (area从0开始)
    18. [Huawei-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255     //三层交换机所连同的网段一共有4个,每一网段都需要宣告
    19. [Huawei-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    20. [Huawei-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    21. [Huawei-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255

     路由器配置:

    1. [Huawei]interface GigabitEthernet 0/0/0            //为端口0配置ip连通三层交换机,需同一网段
    2. [Huawei-GigabitEthernet0/0/0] ip address 192.168.4.2 24
    3. [Huawei]interface GigabitEthernet 0/0/1              //为端口0配置ip,作为主机ip为192.168.5.0网段主机的网关
    4. [Huawei-GigabitEthernet0/0/0] ip address 192.168.5.254 24
    5. [Huawei]ospf 1               //使用ospf协议宣告
    6. [Huawei-ospf-1]area 0
    7. [Huawei-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255      //本台路由器连同的网段有两个
    8. [Huawei-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255    

    为4台主机配置ip/子网掩码 和网关,网关为路由器上端口ip号

    3. 测试

           1) 使用pc1(192.168.1.1) ping 其他三个网段的主机     

                  pc1(192.168.1.1) ping pc2 (192.168.2.1)   通信成功

                  pc1(192.168.1.1) ping pc3 (192.168.3.1)   通信成功

                  pc1(192.168.1.1) ping pc4 (192.168.5.1)   通信成功

     

    四、配置默认路由

          默认路由(Default route),是对IP数据包中的目的地址找不到存在的其他路由时,路由器所选择的路由。目的地不在路由器的路由表里的所有数据包都会使用默认路由。这条路由一般会连去另一个路由器,而这个路由器也同样处理数据包: 如果知道应该怎么路由这个数据包,则数据包会被转发到已知的路由;否则,数据包会被转发到默认路由,从而到达另一个路由器。每次转发,路由都增加了一跳的距离。

        默认路由是特殊的静态路由,配置命令如下:

        [HUAWEI] ip route-static 0.0.0.0 0 192.168.1.1

        命令内容为若找不到下一跳的路由器,默认调用跳向端口ip为192.168.1.1的路由器

        默认路由使用的必要性:

               1.最为最后选择: 如果找不到下一跳的端口,那么就是用默认路由规定的端口,这样至少可以将数据发出去而不至于死在路由上.

               2.作为对外网的出口:  我们不知道外网端口的ip地址,但是我们可以将这个数据抛出去而不用在意到底抛到哪

    展开全文
  • 静态路由及默认路由——基本配置

    万次阅读 多人点赞 2019-05-11 11:51:22
    原理简述: 1。静态路由:是指用户或网络管理员手工配置的路由信息。当网络拓扑结构或链路状态发生改变时,需要网络管理员手工配置静态路由信息。 相比较动态路由协议,静态路由无需频繁的交换各自的...默认路由...
  • 1、 子网的划分和依据,子网掩码的设置。 2、 静态路由的配置 3、 默认路由的配置 4、 验证配置的正确性 5、 静态路由和默认路由的应用场合
  • 静态路由与默认路由

    2021-04-02 17:27:48
    静态路由原理与配置 一.路由器的工作原理 路由器本质上是一种网关,是互联网的一个结点设备。实现的功能是对不同网络之间的数据包进行存储和分组转发。简单来说,大家可以把路由器理解为网络分发工具。 除了分发工具...
  • 路由表的形成二、静态路由和默认路由1.静态路由2.默认路由3.路由转发数据包的原理4.交换与路由对比三、静态路由和默认路由的配置1.思科的静态路由和默认路由配置2.华为的静态路由和默认路由的配置: 一、 路由 1....
  • linux 默认路由 主机路由 网络路由

    千次阅读 2018-12-18 10:17:48
    网关地址,”*” 表示目标是本主机所属的网络,不需要路由 Genmask 网络掩码 Flags 标记。一些可能的标记如下:   U — 路由是活动的   H — 目标是一个主机   G — 路由指向网关 ...
  • 静态路由介绍: 静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递...
  • 主要介绍了vue-cli 默认路由再子路由选中下的选中状态问题及解决代码,非常不错,具有一定的参考借鉴价值,需要的朋友可以参考下
  • 静态路由、默认路由详解

    千次阅读 2019-10-23 10:04:18
    静态路由的概念 (1)最为原始的配置路由方式,纯手工,易管理,但是耗时,一般用于小型企业或者中等偏下型企业 (2)静态路由的缺点是不能动态反映网络拓扑,当网络拓扑发生变化时,管理员必须手工改变路由表; ...
  • 5-默认路由

    千次阅读 2018-05-12 16:17:30
    1. 默认路由(默认网关)   默认路由(Default Route)一般应用于网络(企业网、校园网、园区网等)出口,用于指向互联网,实现内网主机能够跟外网通信。一般放在路由表的最底部,只有当常规的路由列表没有匹配时...
  • 静态路由原理与配置一、路由概述1、路由 :从源主机到目标主机的转发过程2、路由器的工作原理(1)、根据路由表转发数据(2)、路由表的形成(3)、静态路由(4)、默认路由二、路由器转发数据包的封装过程三、交换...
  • 掌握目标一、配置设备名称与 IP 地址:二、配置静态路由三、配置浮动路由用于备份四、配置默认路由五、了解华为不同路由协议的优先级博客地址
  • 因为业务需求,使用2块网卡,IP地址不在同一个网段,需要更改配置路由表,并且默认路由也需要更改,研究后记录一下操作步骤,以免大家以后也会遇到。 查看IP地址: root@localhost ~]# ip a 1: lo: <LOOPBACK,UP,...
  • 华为路由器配置静态路由&默认路由

    万次阅读 多人点赞 2020-01-06 15:35:24
    1、路由器基本配置  R1: <Huawei>system-view [Huawei]sysname R1 ...[R1-GigabitEthernet0/...Cisco 模拟器中静态路由和默认路由设置请参考: https://blog.csdn.net/qq_34889607/article/details/103782200
  • windows添加默认路由

    千次阅读 2020-12-21 11:59:53
    连结多个vpn后,原本能访问的网址打不开了,这时就需要加一条路由 在windows上添加路由即可 C:\WINDOWS\system32>route add 10.128.86.199 mask 255.255.255.0 172.29.0.254 格式:route add 目的网路地址 ...
  • 配置默认路由配置如下:

    千次阅读 2020-02-13 13:55:00
    在AR1和AR3上配置默认路由: 0.0.0.0 0.0.0 在AR2上配置静态路由: x.x.x.x 24 x.x.x.x 在AR-1设备上配置如下命令: [AR-1]ip route-static 0.0.0.0 0.0.0.0 192.168.2.2 默认路由 在AR-3设备上配置如下命令: [AR-3]...
  • 静态路由和默认路由的区别

    万次阅读 2018-10-18 08:48:13
    路由表中明细的路由(静态路由)时,就会先找明细路由,在明细中找不到路由时, 就走默认的。地址掩码越小、精度越高,就匹配哪个!!! 比如同样的目标地址,... 路由协议或路由种类|相应的默认路由优先级(Prefer...
  • 默认路由是对IP数据包中的目标地址找不到存在的其他路由时,路由器所选择的路由。 目的地不在路由器的路由表里的所有数据包都会使用默认路由默认路由会产生路由回环 解决方法的话是要将其中一台边缘路由修改默认...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 339,054
精华内容 135,621
关键字:

默认路由