精华内容
下载资源
问答
  • PostgreSQL安装

    2020-08-03 16:12:08
    PostgreSQL安装一、 下载安装二、 安装stack builder参考: 一、 下载安装 postgreSQL下载地址: https://www.enterprisedb.com/downloads/postgres-postgresql-downloads 本文以 9.6.18 windows 64位版本为例 ...

    一、 下载安装

    postgreSQL下载地址: https://www.enterprisedb.com/downloads/postgres-postgresql-downloads

    本文以 9.6.18 windows 64位版本为例

    postgreSQL安装步骤可以设置一路默认,设置好管理员密码,端口,安装地址和安装内容,区域(Locale)选择默认即可。

    password.png
    locale

    二、 安装stack builder

    PostgreSQL安装完成后,出现以下界面,勾选选择安装stack builder(或者在postgreSQL目录打开)

    setup.png

    setup2.png

    stackbuilder1.png

    出现问题:不能连接上applications-v2.xml

    stackbuilderError.png

    解决办法:

    1. 尝试该方法(未使用过)

    2. 关闭安全中心的实时保护(经测试有效)

    选择安装postGIS插件版本,安装地址要和postgresql的安装路径一致,接下来,一路默认安装即可。

    空间扩展

    spatialExtension.png

    安装完成!

    done.png

    参考:

    postgresql+postgis安装、postgresql汉化

    展开全文
  • postgresql安装

    2020-10-16 15:19:00
    postgresql安装 window一、安装二、初始化配置三、启动 一、安装 1.下载postgresql安装包。 (1)下载地址:官网下载地址 (2)开始安装 ① 双击下载的安装包 ②选择程序安装目录 ③选择数据存放目录 ④...

    一、安装

    1.下载postgresql安装包。
    (1)下载地址:官网下载地址
    在这里插入图片描述
    (2)开始安装

    • ① 双击下载的安装包
      在这里插入图片描述

    • ②选择程序安装目录
      在这里插入图片描述

    • ③选择数据存放目录
      在这里插入图片描述

    • ④输入用户的密码(要记住)
      在这里插入图片描述

    • ⑤设置服务监听端口,默认为5432
      在这里插入图片描述

    • ⑥选择运行时语言环境
      在这里插入图片描述
      (注:选择数据库存储区域的运行时语言环境(字符编码格式)。
      在选择语言环境时,若选择"default locale"会导致安装不正确;同时,PostgreSQL 不支持 GBK 和 GB18030 作为字符集,如果选择其它四个中文字符集:中文繁体 香港(Chinese[Traditional], Hong Kong S.A.R.)、中文简体 新加坡(Chinese[Simplified], Singapore)、中文繁体 台湾(Chinese[Traditional], Taiwan)和中文繁体 澳门(Chinese[Traditional], Marco S.A.R.),会导致查询结果和排序效果不正确。建议选择"C",即不使用区域。
      ----我选择了default localt,安装正确;建议选择default localt。)

    • ⑦直到最后安装结束,去掉勾选,直接点 Finish
      在这里插入图片描述

    二、初始化配置

    • ①首先cmd打开一个命令窗口
      键入(参照自己的文件路径,后续在在bin下执行)
      cd E:PostgreSQL\bin
    • ②初始化数据库
      initdb -D E:\PostgreSQL\data -E UTF8
      如果data目录存在,可以先删除,再重新键入上面语句;也可以直接忽略此步骤
    • ③注册服务
      即将postgres注册为服务,服务名为pgsql
      继续键入:
      pg_ctl register -D E:\software\postgresql\data -N pgsql
    • ④启动服务,另开一个cmd输入net start pgsql
      会显示启动成功
      后续启动服务可以直接这样造作(成功的话任务管理器的服务下也会出现该服务名称的)

    三、启动

    打开 pgAdmin 4(在开始菜单里直接找即可)
    在这里插入图片描述
    pgAdmin 主页如下:
    在这里插入图片描述

    点击左侧的 Servers
    在这里插入图片描述

    首次进入一般需要输入密码(安装时设置的那个密码),点击 OK 即可

    最终连接成功后打开的界面:
    在这里插入图片描述

    展开全文
  • postgreSQL 安装

    2018-09-26 17:39:55
    运行环境Debian8.8  root模式下   安装数据库 apt-get install postgresql 安装pgAdminIII 数据库图形客户端 ...apt-get install pgadmin3 ...启动服务器 (启动之后 进行用户切换.../etc/init.d/postgresql sto...

    运行环境Debian8.8 

    root模式下

     

    安装数据库

    apt-get install postgresql

    安装pgAdminIII 数据库图形客户端

    apt-get install pgadmin3

    启动服务器 (启动之后 进行用户切换即可)

    /etc/init.d/postgresql start

    关闭服务器

    /etc/init.d/postgresql stop

    用户切换

    su postgres

    新建数据库

    createdb testdb

    进入交互psql工具

    psql testdb

     

    建立表 插入数据

    CREATE TABLE testtable(id varchar(10),name varchar(20));

    INSERT INTO testtable values('id_1','name_1');

     

    查询数据

    SELECT * FROM TESTTABLE;

    退出

    \q

     

    数据库端口查询

    netstat -a | grep PGSQL

     

     

     

    密码修改

    su postgres

    psql

    ALTER USER POSTGRES WITH PASSWORD '123456'

    \q

     

    远程连接时需要配置postgresql.conf

    路径/etc/postgresql/9.4/main

    第59行

    前面的#要去掉

     

    修改同目录下的pg_hba.conf

    添加允许访问ip

    host all all 0.0.0.0/0 md5

    重启数据库 

    service postgresql restart

    展开全文
  • postgreSQL安装

    2018-09-21 09:52:07
    wget -c https://ftp.postgresql.org/pub/source/v9.5.0/postgresql-9.5.0.tar.bz2tar jxvf postgresql-9.5.0.tar.bz2 出现错误: 原因:需要安装wget yum install wget -y wget -c https://ftp.postgres...

    首先来安装postgre

     

    wget -c https://ftp.postgresql.org/pub/source/v9.5.0/postgresql-9.5.0.tar.bz2tar jxvf postgresql-9.5.0.tar.bz2

    出现错误:

    原因:需要安装wget

    yum install wget -y

    wget -c https://ftp.postgresql.org/pub/source/v9.5.0/postgresql-9.5.0.tar.bz2tar jxvf postgresql-9.5.0.tar.bz2

     

    注意这里还是不行的。需要去这个ftp去看一下了。是不是有这个文件。

    https://ftp.postgresql.org/pub/source/v9.5.0/

    或者打开

    https://ftp.postgresql.org/pub/source/v9.5.0/postgresql-9.5.0.tar.bz2tar

     

    还真的有坑,可以发现是404

     

    这里注意使用这个路径:

    https://ftp.postgresql.org/pub/source/v9.6.6/postgresql-9.6.6.tar.bz2

     

    1.使用命令:

     

    cd /usr/local/src/

    wget -c https://ftp.postgresql.org/pub/source/v9.6.6/postgresql-9.6.6.tar.bz2

    tar jxvf postgresql-9.6.6.tar.bz2

     

    2.安装依赖

    yum install gcc* readline-devel* -y

     

     

    3.编译

     

       cd postgresql-9.6.6

     

    ./configure --prefix=/usr/local/pgsql --with-python --with-blocksize=32 PYTHON='/usr/local/python/bin/python'

     

     

    make world&&make install-world

     

    有报错。

     

     

     

    现在已经是第二天早上9点40,果然navicat打开就会报错是:

     

     

    看到了吧,还记得昨天把,肯定是iptables因为服务器重启的关系又被重启了。

    没事儿,接着关。

    chkconfig iptables off

    chkconfig ip6tables off

    service iptables stop

    都被关掉了都不行。

    再来看下ip是不是变了。

    可以看到ip没有变,那应该就是postgre没有启动。

     

    现在验证一下是不是postgre没启动的关系。

     

    果然重启就可以了。

     pg_ctl -D /home/postgres/pgsql/data -l logfile restart
     

     psql -U postgres -d dw -h 172.16.13.23 -p 5432

     

     

    然后就可以了。

    ok,一会儿搞个文档配置开机自启动以及postgre调优吧。

    展开全文
  • Postgresql 安装

    2016-07-13 16:35:51
    version:Postgresql 9.5.2 ...建议先 运行 yum list installed mysql* 命令 查看安装了哪些mysql 卸载 yum remove mysql5.6(比如) 同样 把 早期的 postgresql 版本卸载掉 rpm -qa |grep postgr
  • postgresql 安装

    2015-04-17 00:25:21
    PostgreSQL 是一种非常复杂的对象-关系型数据库管理系统(ORDBMS),也是目前功能最强大,特性最丰富和最复杂的自由软件数据库系统。有些特性甚至连商业数据库都不具备。这个起源于伯克利(BSD)的数据库研究计划...
  • Postgresql安装

    2011-04-13 20:43:00
    Postgresql简介  Postgresql是一款object-relational DBMS,提供了如下的feature: 复杂查询complex queries 外键foreign key  触发器trigger  视图views 支持事务transactional ...
  • PostgreSQL安装指南

    2019-07-26 19:51:00
    PostgreSQL安装指南 PostgreSQL安装指南 挂载新磁盘到PostgreSQL数据目录 安装PostgreSQL 配置PostgreSQL 参考文献 PostgreSQL是一个开源的关系型数据库管理系统,提供诸多企业级特性,比如支持窗口函数(用户...
  • PostgresQL 安装环境

    2019-12-05 13:49:26
    PostgresQL 安装环境 一、CentOS 7 安装 1. 环境说明 CentOS7 PosgreSQL 11.2 2. 在线安装 到目前为止(2019-08-10),CentOS7 默认携带了9.2.24版本的PostgreSQL,我们可以直接从源进行安装: # 在线安装 sudo ...
  • postgresql安装过程

    2017-08-17 23:40:47
    postgresql安装过程 1百度下载软件:
  • PostgreSQL安装+破解

    2019-08-02 15:06:05
    PostgreSQL安装+破解 ...
  • PostgreSQL安装+TimescaleDB安装(Windows)

    千次阅读 热门讨论 2019-10-30 13:24:30
    PostgreSQL安装+TimescaleDB安装(Windows)一、安装环境1.系统2.PostgreSQL安装包3.TimescaleDB安装包4.Visual Studio Community 2019二、PostgreSQL安装1.安装PostgreSQL2.配置环境变量3.验证是否安装成功三、...
  • 官方安装文档:...1. 检查PostgreSQL 是否已经安装 Linux-软件包管理-rpm命令管理-查询 rpm -qa | grep postgres 检查PostgreSQL 是否已经安装 rpm -qal | grep postgres 检查PostgreSQL 安装位置 ...
  • PostgreSQL安装与配置

    千次阅读 2019-04-05 22:09:17
    PostgreSQL安装与配置1、下载PostgreSQL的二进制安装文件。2、解压压缩包,配置环境变量3、初始化数据库4、启动数据库5、注册服务6、使用PgAdmin,建立数据库连接 (此处只介绍window安装) 1、下载PostgreSQL的二...
  • postgresql安装及配置

    2017-09-28 16:29:00
    postgresql安装及配置
  • postgresql安装与登录

    2020-09-07 16:18:11
    今天练习使用postgresql数据库,首先安装 sudo apt-get install postgresql 安装完成后,直接在terminal输入创建数据库的命令 createdb mydb 结果系统提示 createdb: could not connect to database template1: ...
  • CentOS7 postgresql安装与使用

    千次阅读 2018-06-12 15:59:37
    CentOS7 postgresql安装与使用 安装配置postgresql # 安装 [root@vm-06 ~]# yum -y install postgresql-server # 初始化 [root@vm-06 ~]# postgresql-setup initdb Initializing database ... OK # 设置...
  • 安装postgresql服务器 sudo apt-get insatll postgresql 安装postgresql 客户端 sudo apt-get install postgresql 一般情况下,安装完成后,postgresql服务器会自动在5432端口开启 如果想安装图形化管理界面 ...
  • postgresql安装目录:/opt/postgresql/9.6 postgresql数据库目录:/data/postgresql/ 准备包: postgresql:https://www.postgresql.org/ftp/source/ postgresql-9.6.2.tar.gz uuid-ossp:...
  • PostgreSQL安装(Mac)

    千次阅读 2019-08-05 21:01:54
    PostgreSQL安装(Mac) 文章目录PostgreSQL安装(Mac)1. 简介2.参考文献3.开始安装4.数据库配置的初始化和修改5. 登录数据库6. 初始化数据库7. 常用控制台命令 好记性不如烂笔头啊,还是记录一下! 最近自己做的...
  • linux中安装 postgresql 安装官方教程一步一步执行命令就可以了。https://www.postgresql.org/download/linux/redhat/ 当安装完成 切换到 postgres 用户(安装过程自动创建),使用psql便可登陆终端。 如果需要使用...
  • PostgreSQL安装hstore

    千次阅读 2015-07-15 23:03:43
    PostgreSQL安装hstore 搭建rubygems.org 这个项目,执行迁移 # rake db:migrate RAILS_ENV=development 时候遇到一个错误 错误信息: -- enable_extension("hstore") rake aborted! StandardError: An error ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,310
精华内容 6,124
关键字:

postgresql安装