精华内容
下载资源
问答
  • C++版的大漠多线程模板源码,生成的obj.h和obj.cpp即是使用在VC++平台下的类库封装. 具体如何使用这个类,请查看example(ui).rar,example(console).rar以及example(多线程模板).rar的工程. vs2008 vs2010 vs2012 vs...
  • c#大漠多线程模板
  • 3.大漠多线程之参数传递 易语言调用大漠插件之多线程中级教程(第五套) 第一章  1.易大漠多线程中级之同步器原理介绍  2.易大漠多线程中级之同步器界面思路  3.易大漠多线程中级之同步器设置主窗与多线程创建 ...
  • VS上运行通过,下载可直接运行,有助于学习C#多线程技术
  • 大漠多线程绑定例子

    2014-12-05 09:26:29
    易语言大漠实现多线程例子,适合新手学习使用
  • 大漠多线程范例源码

    2013-12-27 20:22:06
    大漠多线程范例源码
  • dm.dll dmreg.dl 放入运行目录+/data 大漠 VIP码自己添加
  • dm.dll dmreg.dl 放入运行目录+/data 大漠 VIP码自己添加
  • 易语言大漠多线程模板多线程启动

    千次阅读 2020-06-01 09:10:19
    511遇见易语言多线程大漠多线程 多线程启动源码 .版本 2 .支持库 EThread .子程序 多线程_启动, 逻辑型, , 成功返回真,失败返回假 .参数 窗口句柄, 整数型 .局部变量 主序号, 整数型 ' 判断句柄 .如果真 ...

    多线程启动主要是启动主线程,副线程的启动放到主线程里,多线程启动就是把线程的句柄,线程PID,窗口句柄等,通过UI更新到窗口的超级列表框。

    511遇见易语言多线程大漠多线程

    多线程启动源码

    .版本 2
    .支持库 EThread
     
    .子程序 多线程_启动, 逻辑型, , 成功返回真,失败返回假
    .参数 窗口句柄, 整数型
    .局部变量 主序号, 整数型
     
     
    ' 判断句柄
    .如果真 (窗口句柄 = 0)
        日志输出 (“无效的窗口句柄”)
        返回 (假)
    .如果真结束
     
    ' 多线程_是否启动
    .如果真 (多线程_是否启动 (窗口句柄))
        日志输出 (“给句柄线程已经启动了”)
        返回 (真)
     
    .如果真结束
     
    ' 判断,多线程_取空余位置
    主序号 = 多线程_取空余位置 ()
    .如果真 (主序号 = -1)
        日志输出 (“没有空余线程位置了”)
        返回 (假)
    .如果真结束
     
    ' 更新UI,
    ' 第一主线程
    线程信息 [主序号].线程句柄 = 0
    线程信息 [主序号].窗口句柄 = 窗口句柄
    线程信息 [主序号].进程PID = 全局大漠.GetWindowProcessId (窗口句柄)
    线程信息 [主序号].是否暂停 = 假
    线程信息 [主序号].是否结束 = 假
    线程信息 [主序号].线程状态 = #线程状态_正在启动
     
     
     
    ' 副线程
    线程信息 [主序号 + MaxHwnd].线程句柄 = 0
    线程信息 [主序号 + MaxHwnd].窗口句柄 = 窗口句柄
    线程信息 [主序号 + MaxHwnd].进程PID = 全局大漠.GetWindowProcessId (窗口句柄)
    线程信息 [主序号 + MaxHwnd].是否暂停 = 假
    线程信息 [主序号 + MaxHwnd].是否结束 = 假
    线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在启动
    ' UI更新
    UI_更新 (主序号, #UI_增加)
     
     
    ' 启动线程(),这里只创建了主线程,副线程放到主线程里去创建
     
    .如果真 (启动线程 (&脚本主线程, 主序号, 线程信息 [主序号].线程句柄) = 假)
        UI_更新 (主序号, #UI_删除)
        多线程_复位 (主序号)
        多线程_复位 (主序号 + MaxHwnd)
        日志输出 (“线程创建失败!”)
        返回 (假)
    .如果真结束
     
    日志输出 (“启动 hwnd =” + 到文本 (窗口句柄) + “,主序号” + 到文本 (主序号))
    返回 (真)

    源码:易语言多线程大漠多线程-35大漠多线程模板-5多线程启动

    展开全文
  • 进程-线程-多线程 1、进程(process) 狭义定义:进程就是一段程序的执行过程 简单的来讲进程的概念主要有两点: 第一,进程是一个实体。每一个进程都有它自己的地址空间,一般情况下...511遇见易语言多线程大漠多线程

    进程-线程-多线程

    1、进程(process)
    狭义定义:进程就是一段程序的执行过程
    简单的来讲进程的概念主要有两点:
    第一,进程是一个实体。每一个进程都有它自己的地址空间,一般情况下,包括文本区域(text region)、数据区域(data region)和堆栈(stack region)。
    第二,进程是一个“执行中的程序”。程序是一个没有生命的实体,只有处理器赋予程序生命时,它才能成为一个活动的实体,我们称其为进程。
    进程状态:进程有三个状态,就绪、运行、阻塞。

    511遇见易语言多线程大漠多线程


    2、线程(thread)
    通常在一个进程中可以包含若干个线程,当然一个进程中至少有一个线程,不然没有存在的意义。线程可以利用进程所拥有的资源。
    3、进程与线程的区别:
    每个进程都有私有的虚拟地址空间,进程的所有线程共享同一地址空间。每个线程被CPU分配一个时间片,一旦被激活,它正常运行直到时间片耗尽并被挂起,此时,操作系统选择另一个线程进行运行。
    简而言之,一个进程至少有一个线程.
    线程的划分尺度小于进程,使得多线程程序的并发性高。
    1)线程是程序执行的最小单位,而进程是操作系统分配资源的最小单位;
    2)一个进程由一个或多个线程组成,线程是一个进程中代码的不同执行路线;
    3)进程之间相互独立,但同一进程下的各个线程之间共享程序的内存空间(包括代码段、数据集、堆等)及一些进程级的资源(如打开文件和信号),某进程内的线程在其它进程不可见;
    4)调度和切换:线程上下文切换比进程上下文切换要快得多。
    4、什么是单线程和多线程?
    单线程,顾名思义即是只有一条线程在执行任务
    多线程,创建多条线程同时执行任务
    5、并行和并发的区别,
    并发:交替做不同事的能力
    并行:同时做不同事的能力
    行话解释:
    并发:不同代码块交替执行的性能
    并行:不同代码块同时执行的性能
    6、多线程在多核上是并发还是并行?
    对于单核,多线程的多任务是在单cpu交替执行,属于并发;
    对于多核,多线程的任务如果能够分布在各个cpu,上(线程数少许核心数),那么就是并行。
    7、拓展
    同步和异步 ----- 异步的反义词是同步
    顺序和并发 ----- 并发的反义词是顺序
    串行和并行 ----- 并行的反义词是串行
    简单的说:并行是多线程的一种形式,多线程是并发的一种形式。异步也是并发的一种形式。
    8、线程的生命周期
    9、线程的安全
    10、线程池

    展开全文
  • 易语言大漠多线程模板多线程结束

    千次阅读 2020-06-02 09:06:06
    为了在线程结束时保证线程安全,首先采用WaitForSingleObject自然等待结束,设置了30s的...511遇见易语言多线程大漠多线程 源码: .版本 2 .支持库 EThread .子程序 多线程_设置结束标志, , , 在多线程全部结束.

    为了在线程结束时保证线程安全,首先采用WaitForSingleObject自然等待结束,设置了30s的等待时间,当自然结束失败时,如果等待自然线程失败,没有办法的情况下,只能强制粗暴的结束线程,同时我们对象对计数器进行恢复。

    1、多线程_设置结束标志
    2、多线程_结束
    3、_内部结束
    4、WaitForSingleObject
    5、ReleaseRef

    511遇见易语言多线程大漠多线程

    源码:

    .版本 2
    .支持库 EThread
     
    .子程序 多线程_设置结束标志, , , 在多线程全部结束时,加快结束的速度
    .参数 主序号, 整数型
     
    ' 判断主序号
    .如果真 (主序号 ≤ 0 或 主序号 ≥ MaxHwnd)
        返回 ()
     
    .如果真结束
    ' 判断句柄
    .如果真 (线程信息 [主序号].线程句柄 = 0)
        返回 ()
    .如果真结束
     
    ' 主线程
    线程信息 [主序号].是否结束 = 真
    线程信息 [主序号].线程状态 = #线程状态_正在停止
    ' 副线程
    线程信息 [主序号 + MaxHwnd].是否结束 = 真
    线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在停止
     
    ' 大漠插件设置结束标志
    线程信息 [主序号].dm.SetExitThread (1)
    线程信息 [主序号 + MaxHwnd].dm.SetExitThread (1)
    UI_更新 (主序号, #UI_更新)
     
     
    .子程序 _内部结束, , , 这个接口是内部调用,不对外
    .参数 主序号, 整数型
    .局部变量 wait_time, 整数型
     
    日志输出 (“结束  主序号:” + 到文本 (主序号))
    多线程_设置结束标志 (主序号)
    ' 设置等待时间30秒
    wait_time = 30 × 1000
    ' 主
    .如果真 (线程信息 [主序号].线程句柄 ≠ 0)
        .如果真 (WaitForSingleObject (线程信息 [主序号].线程句柄, wait_time) ≠ 0)
            ' 如果等待自然线程失败,没有办法的情况下,只能强制粗暴的结束线程
            日志输出 (“主线程 等待线程失败,强制结束线程”)
            强制结束线程 (线程信息 [主序号].线程句柄)
     
        .如果真结束
     
        关闭线程句柄 (线程信息 [主序号].线程句柄)
     
    .如果真结束
     
    ' 副
    .如果真 (线程信息 [主序号 + MaxHwnd].线程句柄 ≠ 0)
        .如果真 (WaitForSingleObject (线程信息 [主序号 + MaxHwnd].线程句柄, wait_time) ≠ 0)
            日志输出 (“副线程 等待线程失败,强制结束线程”)
            强制结束线程 (线程信息 [主序号 + MaxHwnd].线程句柄)
     
        .如果真结束
     
        关闭线程句柄 (线程信息 [主序号].线程句柄)
     
    .如果真结束
     
    ' 对象计数恢复
    线程信息 [主序号].dm.ReleaseRef ()
    线程信息 [主序号 + MaxHwnd].dm.ReleaseRef ()
    ' 释放对象
    线程信息 [主序号].dm.释放 ()
    线程信息 [主序号 + MaxHwnd].dm.释放 ()
     
    .子程序 多线程_结束, , , 设置结束标识
    .参数 主序号
     
     
    ' 判断主序号
    .如果真 (主序号 ≤ 0 或 主序号 ≥ MaxHwnd)
        返回 ()
     
    .如果真结束
    ' 判断句柄
    .如果真 (线程信息 [主序号].线程句柄 = 0)
        返回 ()
    .如果真结束
     
    _内部结束 (主序号)
    多线程_复位 (主序号)
    多线程_复位 (主序号 + MaxHwnd)
     
    UI_更新 (主序号, #UI_删除)
    日志输出 (“线程结束成功 主序号:” + 到文本 (主序号))

    源码:易语言大漠多线程模板-10多线程结束

     
    展开全文
  • 511遇见易语言多线程大漠多线程 1、多线程_重新运行 2、时钟事件 教程源码: .版本 2 .支持库 EThread .子程序 多线程_重新运行, 逻辑型 .参数 主序号, 整数型 .局部变量 索引 ' 判断 .如果真 (主序号 ≤ 0 ...

    多线程在暂停后,采用先内部结束线程,再重启主线线程,再重新副线程的方法开始线程的重新运恢复。

    511遇见易语言多线程大漠多线程

    1、多线程_重新运行
    2、时钟事件

    教程源码:

    .版本 2
    .支持库 EThread
     
    .子程序 多线程_重新运行, 逻辑型
    .参数 主序号, 整数型
    .局部变量 索引
     
    ' 判断
    .如果真 (主序号 ≤ 0 或 主序号 > MaxHwnd)
        返回 (假)
     
    .如果真结束
     
    .如果真 (线程信息 [主序号].线程句柄 = 0)
        返回 (假)
    .如果真结束
     
     
    ' 先结束
    _内部结束 (主序号)
     
    ' 再重启主线程
    线程信息 [主序号].窗口句柄 = 0
    线程信息 [主序号].线程状态 = #线程状态_正在启动
    线程信息 [主序号].是否暂停 = 假
    线程信息 [主序号].是否结束 = 假
     
     
    ' 再重启副线程
    线程信息 [主序号 + MaxHwnd].窗口句柄 = 0
    线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在启动
    线程信息 [主序号 + MaxHwnd].是否暂停 = 假
    线程信息 [主序号 + MaxHwnd].是否结束 = 假
     
     
    ' 通知UI更新
    UI_更新 (主序号, #UI_更新)
    ' 创建主线程,副线程放到主线程里面创建,这里只创建主线程
    .如果真 (启动线程 (&脚本主线程, 主序号, 线程信息 [主序号].窗口句柄) = 假)
        UI_更新 (主序号, #UI_删除)
        多线程_复位 (主序号)
        多线程_复位 (主序号 + MaxHwnd)
        日志输出 (“线程重新创建失败”)
     
        返回 (假)
    .如果真结束
     
    日志输出 (“重新运行线程  Hwnd =” + 到文本 (线程信息 [主序号].窗口句柄) + “, 主序号:” + 到文本 (主序号))
     
    返回 (真)

    源码:易语言大漠多线程模板-11多线程重新运

    展开全文
  • 511遇见易语言多线程大漠多线程 多线程全部暂停恢复 .版本 2 .子程序 多线程_暂停, , , 设置暂停标识 .参数 主序号, 整数型 ' 判断主序号 .如果真 (主序号 ≤ 0 或 主序号 ≥ MaxHwnd) 返回 () .如果真...
  • 大漠多线程模板中,脚本副线程的作用主要是一个监控线程,可以监控游戏窗口是否存在,游戏是否卡屏,是否掉线,当然你可以用来进行游戏里的其他检测监控。 511遇见易语言多线程大漠多线程 大漠多线程主副线程 ...
  • 当前版本3.9---------------------- 修正:普通填表类错误 ... 新增:免注册调用大漠() '可以免注册调用大漠免费版本与收费版本,让免费版支持免注册调用不是梦 修正:上一个版本调试直接完毕的情况. 优化:部分函数代码.
  • 多线程初始化,在启动...511遇见易语言多线程大漠多线程 多线程初始化 .版本 2 .子程序 多线程_初始化 .局部变量 i, 整数型 MaxHwnd = 100 .计次循环首 (MaxHwnd × 2, i) ' 防止避免多线程访问文本型变量引..
  • 易语言多线程大漠多线程模板UI更新

    千次阅读 2020-06-01 09:09:37
    大漠多线程模板源码: .版本 2 .支持库 iext .子程序 UI_更新, , , 用来更新窗口的超级列表框相关线程信息 .参数 主序号, 整数型 .参数 操作, 整数型 .局部变量 列表索引, 整数型 ' 增加 .如果真 (操作 = #UI_...
  • 511遇见易语言多线程大漠多线程-1进程线程多线程511遇见易语言多线程大漠多线程-2中转子程序传多参511遇见易语言多线程大漠多线程-3线程传参数据变量地址511遇见易语言多线程大漠多线程-4线程传参指针地址511遇见...
  • 大漠C#版的多线程模板,是大漠VIP专用模板,大漠本人写的模板,多线程的启动暂停,恢复,销毁,都非常的专业。
  • 大漠插件作者提供的易语言大漠多线程例子
  • 易语言大漠多线程创建线程

    千次阅读 2020-05-30 09:22:19
    进程(process)和线程(thread)是操作系统的基本概念 进程是具有一定独立功能的程序关于某个数据集合上的一次运行活动,进程是系统进行资源分配和调度的一...同一个进程中的线程之间可以并发执行 第一课易语言大
  • 易语言大漠多线程模板脚本主线程

    千次阅读 2020-06-01 09:10:55
    511遇见易语言多线程大漠多线程 大漠多线程模板脚本主线程源码 .版本 2 .支持库 EThread .子程序 脚本主线程, , , 游戏的动作逻辑都在这里 .参数 序号, 整数型 .局部变量 dm, dmsoft .局部变量 dm_ret, 整数型 ...
  • 大漠的c#多线程模板

    2018-11-07 22:37:24
    大漠最新的c#多线程模板,里面一个完整的例子。 
  • 自动切换账号是多线程模板的一个变化应用,你有100个账号,每次开始10个线程,当第一...本套也是执行效率最高,优化系统资源占用最好的一题。 易语言大漠多线程循环登录自动切换账号 截图预览 ...1.易语言大漠多线程
  • 大漠多线程线程传参数据变量地址

    千次阅读 2020-05-30 09:18:52
    511遇见易语言多线程大漠多线程 课程源码: .版本 2 .支持库 spec .支持库 EThread .程序集 窗口程序集_启动窗口 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 .局部变量 地址, 整数型 文本 = “511遇见...
  • 511遇见易语言多线程大漠多线程 大漠多线程脚本延时 .版本 2 .子程序 脚本延时, , , 用来控制脚本的暂停恢复 .参数 序号, 整数型 .参数 时间, 整数型 .局部变量 死循环, 逻辑型 死循环 = 真 ' 判断是否有结束...
  • 我们在超级列表框里增加一个对辅助进度环节的监控反馈,它同时监控几个窗口,同时录制了线程结束的部分。 监控反馈及线程结束源码: .版本 2 .支持库 iext .支持库 EThread .子程序 监控反馈, , , 反馈线程执行...
  • 易语言大漠多线程模板游戏实例化

    千次阅读 2020-06-02 09:06:57
    要把大漠多线程模板实例化,原模板是采用记事本演示的,我们需要修改句柄获取方式,修改窗口后台绑定模式。 511遇见易语言多线程大漠多线程 1、实例化游戏 2、获取游戏窗口句柄的两种方法 (1)大漠 (2)API ...
  • 前排提示:笔者萌新,对大漠多线程运用都不大熟练,自学出道,莫得文化,出现错误还请理解指正。 首先介绍下目标: 剑侠情缘1网络版 一款十分有年代感的2D游戏 配置选项里有3D但是开了不知道有啥用hhhhh 目标是写...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 624
精华内容 249
关键字:

大漠多线程