精华内容
下载资源
问答
  • 什么是网卡Mac地址?网卡MAC码是由全球惟一的一个固定组织来分配的,未经认证和授权的厂家无权生产网卡。每块网卡都有一个固定的卡号,并且任何正规厂家生产的网卡上都直接标明了卡号,一般为一组12位的16进制数。...
    1cf5de30d6cd911d8a074d17c8d44e74.png

    什么是网卡Mac地址?

    网卡MAC码是由全球惟一的一个固定组织来分配的,未经认证和授权的厂家无权生产网卡。每块网卡都有一个固定的卡号,并且任何正规厂家生产的网卡上都直接标明了卡号,一般为一组12位的16进制数。其中前6位代表网卡的生产厂商。

    怎么查看Mac地址?怎么样获取到Mac地址?

    1、Windows 系统:开始菜单 » 运行 cmd » 在命令行窗口中输入 ipconfig /all 命令

    2、安卓手机:系统设置 » 关于手机

    3、iOS 系统:设置 » 通用 » 关于本机 » 无线局域网地址/蓝牙

    4、路由器等其它网络设备:设备管理后台、设备标签或包装盒上。

    MAC地址相关常识

    MAC(Media Access Control或者Medium Access Control)地址,意译为媒体访问控制,或称为物理地址、硬件地址,用来定义网络设备的位置。在OSI模型中,第三层网络层负责 IP地址,第二层数据链路层则负责 MAC地址。因此一个主机会有一个MAC地址,而每个网络位置会有一个专属于它的IP地址。

    MAC(Medium/Media Access Control)地址,用来表示互联网上每一个站点的标识符,采用十六进制数表示,共六个字节(48位)。其中,前三个字节是由IEEE的注册管理机构RA负责给不同厂家分配的代码(高位24位),也称为“编制上唯一的标识符”(Organizationally Unique Identifier),后三个字节(低位24位)由各厂家自行指派给生产的适配器接口,称为扩展标识符(唯一性)。一个地址块可以生成224个不同的地址。MAC地址实际上就是适配器地址或适配器标识符EUI-48。

    由于网卡的MAC地址具有全球唯一性,主要用它来识别网络中用户的身份。例如:ADSL上网时,电信用它来记费,确认是你上的网;在校园网中,MAC地址也可以用来识别用户。校园网的正式用户,其MAC地址会登记在服务器端,假如你是非法用户,服务器中就没有你的网卡MAC地址,这样当你试图连上网时,服务器就会立刻认出你、阻止你连上网络。

    在一个稳定的网络中,IP地址和MAC地址是成对出现的。如果一台计算机要和网络中另一外计算机通信,那么要配置这两台计算机的IP地址,MAC地址是网卡出厂时设定的,这样配置的IP地址就和MAC地址形成了一种对应关系。在数据通信时,IP地址负责表示计算机的网络层地址,网络层设备(如路由器)根据IP地址来进行操作;MAC地址负责表示计算机的数据链路层地址,数据链路层设备(如交换机)根据MAC地址来进行操作。IP和MAC地址这种映射关系由ARP(Address Resolution Protocol,地址解析协议)协议完成。

    MAC地址查询 - 根据网卡MAC地址查询厂商信息 地址如下

    https://mac.51240.com/?from=singlemessage

    展开全文
  • [SW1]dis mac-address summary显示MAC地址总体信息看出可用MAC地址表共可用数量32768个。MAC的学习是在同一个广播域里学习到的。所以一般这些MAC条目够用。基于MAC地址的攻击:泛洪和欺骗泛洪攻击:伪造大量不同源...

    为什么需要MAC安全?

    任何网络接入都需要交换机。

    不管什么型号的交换机这对二层数据转发都会有MAC地址表来进行指导转发。

    [SW1]dis mac-address summary

    显示MAC地址总体信息

    看出可用MAC地址表共可用数量32768个。

    MAC的学习是在同一个广播域里学习到的。所以一般这些MAC条目够用。

    基于MAC地址的攻击:泛洪和欺骗

    泛洪攻击:伪造大量不同源mac的数据包,如果设备没有ARP防护的话就会让交换机的MAC地址条目占满,交换机如果没有目的MAC地址的交换表,就会泛洪该数据包,所有处在同一广播域的设备都会收到。

    MAC泛洪攻击实验:

    使用Kali Linux系统中的工具macof工具对本地局域网进行ARP泛洪攻击并使用wireshark进行抓包观察。

    短短三十秒Kali就发出了66万条源MAC不同的数据包。

    一旦交换机的MAC地址表占满,交换机收到数据包后就会泛洪。

    会造成严重的信息泄露。

    MAC地址欺骗:攻击者通常伪装成网关。局域网内的设备不能访问外网。

    9637fb0a356a20f1770c19476dd90f30.png

    一---修改所有SW的MAC地址表老化时间为1000S

    mac-address aging-time 1000

    二---MAC地址安全

    (1)静态MAC地址条目优于动态

    手动配置PC-1的MAC地址绑定在G0/0/10接口,配置完成后再补更改PC-1连线的情况下Ping测PC-2的地址,测试是否通,解释原因

    [Huawei] mac-address static 5489-98f1-329d GigabitEthernet0/0/10 vlan 1

    21c4e6693defdecfbb1d44d99de5639f.png

    无法ping通,因为lsw1收到pc1的数据帧后先查看源mac地址,若mac地址表存在与该mac相同表项时刷新老化时间,若不存在,则记录到mac地址表。此处mac地址在mac地址表中,但接口不一致,又因为静态配置大于动态学习,无法覆盖mac地址表,于是不进行加表。于是回传给5489-98f1-329d 的数据从g0/0/10发出,到达不了pc1,所以无法ping通。

    (2)关闭MAC地址学习,可对MAC表项不存在对应条目的数据设定丢弃处理

    PC-3为合法用户,PC-4为攻击者,请确保用户PC-3的通信,拒绝为攻击者提高数据转发服务

    [Lsw1]mac-address static 5489-98a2-1e94 GigabitEthernet0/0/3 vlan 1

    interface GigabitEthernet0/0/3

    mac-address learning disable action discard

    在关闭g0/0/3接口mac地址学习功能前不做ping命令,以免pc-3和pc-4的mac地址加表。

    c00b92792c000dff4edbac9f9ab30633.png
    098278409f210514e752ce1887fb69cc.png

    此时pc-3能ping通,pc-4不能ping通。

    当关闭mac地址学习功能后,pc-3和pc-4都能ping通pc-2. SHAPE * MERGEFORMAT

    SHAPE * MERGEFORMAT SHAPE * MERGEFORMAT

    cc54280e69c77f46a596e720838b8202.png

    并且会在mac地址表中加表,此时再关闭mac地址学习功能,pc-4依然可以正常通信

    三---MAC地址漂移

    (1)接口MAC地址学习优先级一致情况下针对同一MAC地址的学习记录,后学到的会覆盖最先学到的

    请使用调整接口优先级的方式确保伪装者PC-6发出的数据不会被SW-2所转发(选做:解释你如此配置的原因)

    [Huawei-GigabitEthernet0/0/5]mac-learning priority 3

    将lsw2的g0/0/5接口mac地址学习的优先级提高,此时交换机能从两个接口学到同一个mac地址,但是优先级更高的加表。未加表的接口无法收到回应的数据。

    f4a8eb7393d0cf60179112eed41b2771.png
    68304d4d25dcc36afacb1544c4a71ede.png

    (2)MAC地址检测可以对人为出现MAC地址漂移的接口执行惩罚动作

    基于此特性确保合法用户PC-7通信正常,伪装PC-8的接口会被SW自动shutdown(选做:解释你如此配置的原因)

    注意此项测试,PC-5和PC-6同时长pingPC-1至少30S以上可看到效果

    [SW-2]mac-address flapping detection

    先开启mac地址漂移检查功能

    interface GigabitEthernet0/0/8

    mac-address flapping trigger error-down

    在g0/0/8口发生mac地址漂移则down掉接口

    [SW-2]erromacr-down auto-recovery cause mac-address-flapping interval 30

    因mac地址漂移down掉的接口恢复时间为30秒

    c1fef649c3ab604bbcd7f0b968a893bb.png
    6df3c855edcdbc3dbf6c9bb13ed04d53.png

    两个接口都会发生mac地址漂移,但是配置mac地址漂移时只down掉伪装者的接口,这样合法用户正常访问,伪装者无法访问。

    疑问? 两台电脑同时通讯,伪装者down掉接口恢复之后,没有再次down掉,可以一直通讯。

    展开全文
  • 拓扑图:静态MAC地址简介MAC地址表项是交换机通过报文的源MAC地址学习过程而自动生成的,而通过用户手动配置也可以生成静态的MAC地址表项。手动配置静态MAC,一般是为了防止假冒身份的非法用户骗取数据,由网络管理...

    拓扑图:

    4db59412b48b46e3956e9cd838634d73.png

    269d78b82db5c5929d575a87faa809ba.png

    静态MAC地址简介

    269d78b82db5c5929d575a87faa809ba.png

    MAC地址表项是交换机通过报文的源MAC地址学习过程而自动生成的,而通过用户手动配置也可以生成静态的MAC地址表项。

    手动配置静态MAC,一般是为了防止假冒身份的非法用户骗取数据,由网络管理员手动在MAC地址表中添加合法用户的MAC地址表项。

    手动配置静态MAC地址表项的数量比较大时,不便于网络管理员维护,此时可以使用端口安全功能实现MAC地址和接口的动态绑定。

    269d78b82db5c5929d575a87faa809ba.png

    配置注意事项

    本举例适用于S系列交换机所有产品的所有版本。

    组网需求

    269d78b82db5c5929d575a87faa809ba.png

    如图1所示,服务器通过GE1/0/2接口连接交换机。为避免交换机在转发目的地址为服务器地址的报文时进行广播,要求在交换机上设置服务器的静态MAC地址表项,使交换机始终通过GE1/0/2接口单播发送去往服务器的报文。

    为了保证PC用户和服务器的安全通信,同时把PC用户的MAC地址和接口GE1/0/1静态绑定。

    配置思路

    采用如下思路配置静态MAC:

    1. 在交换机上创建VLAN,并将接口加入VLAN,实现二层转发功能。2. 在交换机上配置服务器的静态MAC地址表项。3. 在交换机上配置PC的静态MAC地址表项。

    269d78b82db5c5929d575a87faa809ba.png

    操作步骤

    1. 在Switch上创建VLAN 2,并把接口GE1/0/1和GE1/0/2加入VLAN 2

    <HUAWEI>system-view

    [HUAWEI]sysname Switch

    [Switch]vlan batch 2

    //创建VLAN 2

    [Switch]interface gigabitethernet 1/0/1

    [Switch-GigabitEthernet1/0/1]port link-type access

    //和接入设备PC相连的接口类型必须是access,接口默认类型不是access,需要手动配置为access

    [Switch-GigabitEthernet1/0/1]port default vlan 2

    //接口GE1/0/1加入VLAN

    2[Switch-GigabitEthernet1/0/1]quit

    [Switch]interface gigabitethernet 1/0/2

    //接口GE1/0/2的配置方法和接口GE1/0/1相同

    [Switch-GigabitEthernet1/0/2]port link-type access

    [Switch-GigabitEthernet1/0/2]port default vlan 2

    [Switch-GigabitEthernet1/0/2]quit

    2.在Switch上添加服务器对应的静态MAC地址表项

    [Switch]mac-address static 4-4-4 gigabitethernet 1/0/2 vlan 2

    3.在Switch上添加PC对应的静态MAC地址表项

    [Switch]mac-address static 2-2-2 gigabitethernet 1/0/1 vlan 2

    4.检查配置结果

    # 在任意视图下执行display mac-address static vlan 2命令,查看静态MAC表是否添加成功。

    10806faaa9d6b3d3c70e2a78296949e6.png

    配置文件

    Switch的配置文件

    #

    sysname Switch

    #

    vlan batch 2

    #

    interface GigabitEthernet1/0/1

    port link-type access

    port default vlan 2

    #

    interface GigabitEthernet1/0/2

    port link-type access

    port default vlan 2

    #

    mac-address static 0002-0002-0002 GigabitEthernet1/0/1 vlan 2

    mac-address static 0004-0004-0004 GigabitEthernet1/0/2 vlan 2

    #

    return

    展开全文
  • 总结下网络中常见的几种类型的路由表,ARPMAC地址表有何作用的?举个例子说说举个例子:我们想要访问到114.114.114.114这个目的,首先经过三层设备进行路由查表,进行三层转发。(好比你要通过快递公司要邮寄...

    总结下网络中常见的几种类型的表

    路由表,ARP表,MAC地址表有何作用的?举个例子说说

    举个例子:

    我们想要访问到114.114.114.114这个目的,首先经过三层设备进行路由查表,进行三层转发。(好比你要通过快递公司要邮寄一个包裹,这时候收件人目的)

    达到这个IP所在的网关,或者对应的三层设备,这时候进行ARP查询MAC地址。(好比快递终于到达你所在目的附近的丰巢,这时候需要凭借取件码取快递)

    如果这时候中间有交换机(二层或者三层),此时查找MAC地址对应的接口。(好比你要知道这个丰巢点所在的位置)

    1.路由表

    路由表有全局路由表和虚拟路由表

    1.1.路由表作用

    路由表是路由和接口的对应关系,进行三层转发的时候用。

    按照路由匹配的三个原则

    1)最长掩码匹配(掩码越长越精准)

    2)管理距离(越小越优)

    3)度量值(动态路由协议判断)

    f209f8fcb17842e4cd0e9ec77f78078f.png

    1.2.全局路由表和虚拟路由表

    1)全局路由表

    常见的路由表,NA NP阶段正常使用的就是全局路由表。

    直接查看的就是全局表。

    2)虚拟路由表

    在三层设备上面虚拟出来的路由表项,独立于全局路由表使用。

    可以将路由器进行拆分为多个路由器。(逻辑上)

    2.ARP表

    IP地址对应MAC地址,三层网络设备、PC、服务器。

    IP→MAC地址

    5f70ec06941084eec49571373a5f1c94.png

    3.MAC地址表

    MAC地址表

    MAC地址→接口

    f874c39ea29a4ec584084041f014371b.png

    8a9004a802e8608092a0346294a8fbe4.png

    4.用途

    常用的三张表很多用途,比如故障定位到接口,比如中毒直接拔网线(反正知道IP地址就能定位接口,NAT就比较麻烦一些,需要查看转换表才能定位。VPN就是要一步步查也比较麻烦,简单使用还是OK)。

    展开全文
  • 不少朋友问到关于局域网的ip地址如何显示?这个在项目中经常需要用到,其实解决的办法挺多的,最直接...一、如何显示局域网内ip地址与mac地址arp -a ,当你需要显示当前ip地址对应mac地址时使用在命令提示符中输入...
  • 2020以太网数据帧、MACYuLong XiaoZhan玉 龙 ...二层交换机设备维护CAM,而CAM中存放的是MAC地址。今天给大家介绍一下以太网数据帧格式和MAC地址格式。以太网数据帧以太网II帧格式Ethernet_II 帧类型值大于等于...
  • 陈拓 chentuo@ms.xab.ac.cn 2020/10/19-2020/10/211. 概述在《电脑连接树莓派3B+》晨之清风:电脑连接树莓派3B+​zhuanlan.zhihu.com和《树莓派修改HostName》晨之清风:树莓派修改HostName...用IP地址连接树莓派更...
  • 概述MAC地址学习虽然说起来比较简单,但是在工作中,还是经常看小伙伴不能正确的应用,遇到问题时也比较迷茫,不知道如何分析问题。究其原因,可能还是对MAC地址学习的工作原理了解的不够,所以我今天写一篇文章,给...
  • MAC 地址由 48 比特长、12 位的 16 进制数字组成,其中从左到右开始,0 到 23bit 是厂商向 IETF 等机构申请用来标识厂商的代码,24 到 47bit 由厂商自行分派,是各个厂商制造的所有网卡的一个唯一编号。MAC 地址可以...
  • 上次我们简单的提到了IPv4的组播地址,但是不够全面,对IP组播这方面的内容来说,下面从IPv4组播地址、IPv6组播地址、IPv4组播MAC地址和IPv6组播MAC地址四个方面详细总结一下。1、IPv4组播地址D类地址,最高位1110,...
  • 昨天遇到个需求:要通过路由器的MAC地址查询它是什么品牌和型号,捯饬了一下午,品牌很好查,但查型号就无能为力了,做也做了,就发出来分享一下吧。一、在线搜索1.便民查询网网址:https://mac.51240.com/这个网站...
  • MAC(Media Access ...交换机之所以能够直接对目的节点发送数据包,而不是像集线器一样以广播方式对所有节点发送数据包,最关键的技术就是交换机可以识别连在网络上的节点的网卡MAC地址,并把它们放到一个叫做MA...
  • LwIP的ARP协议实现系列文章LwIP中的ARP实现(1)之 ARP缓存的数据结构LwIP中的ARP实现(2)之 ARP缓存的超时处理LwIP中的ARP实现(3)之 发送ARP请求包LwIP中的ARP实现(4)之 ARP数据包接收LwIP中的ARP实现(5...
  • MAC地址和制造厂商对应表
  • MAC地址厂商对应表 TXT文档,有3M多 有数万条记录 是从H3C的管理软件导出来的 非常准确 非常全
  • 对IEEE官网提供的最新mac地址数据源oui.txt进行分析处理格式化之后,导入数据库,供匹配查询之用。目前涵盖最新的mac地址厂商信息。
  • 对IEEE官网提供的最新mac地址数据源oui.txt进行分析处理格式化之后,导入数据库,供匹配查询之用。目前涵盖最新的mac地址厂商信息。利用提供的脚本文件可随时获取最新版的数据。
  • 原理就是根据MAC地址前3字节来判断的,前3个字节、对应制造商的名称 此TXT资源是MAC前3字节与对应制造商的名称的对应关系,如下所示: 000000 Xerox 000001 Xerox 000002 Xerox 000003 Xerox 000004 Xerox 000005 ...
  • MAC地址厂商分配

    2020-11-06 16:30:30
    MAC地址厂商分配 这个MAC对照资源是从wireshark源码中获取的。 每块网卡都有一个MAC地址,MAC地址是一个6字节、也即48bit的数据。前3字节称为OUI,是由IEEE组织注册给网络设备生产商的;每个厂商拥有一个或多个OUI...
  • MAC地址厂商查询网址

    万次阅读 2018-01-03 10:13:41
    MAC地址厂商查询网址: https://regauth.standards.ieee.org/standards-ra-web/pub/view.html#registries 在该网站中可以将MAC厂商对应表下载到本地。
  • 这个MAC对照资源是从wireshark源码中获取...原理就是根据MAC地址前3字节来判断的,前3个字节、对应制造商的名称 CSDN已经有个同学上传过类似文档了,但是不太全,竟然查不到中兴的设备,这次重传,应该是个比较全的
  • IPOP 4.1.rar

    2020-04-03 11:38:25
    MAC地址厂商对应表; 本机网络报文统计功能; 本机端口列表、远程端口扫描功能; 常用端口对照表; 端口映射功能; 网卡流量统计与指示功能; 本机IP报文捕获与发送功能; 多窗口telnet、串口维护...
  • MAC地址表里面记录MAC地址和接口对应关系 * 交换机学习源MAC地址,记录在缓存内 * 初始状态→MAC地址学习→广播未知数据帧→接收方回应→交换机实现单播 * 交换机广播地址:48位“1”,即FFFF FFFF FFFF 4.配置...
  • 【IPOP 介绍】

    千次阅读 2018-07-24 21:30:11
    IPOP软件是华为出品的一个IP工具集合,功能包含:IP绑定,路由配置,MAC信息设置查看,网络统计,端口信息,端口映射,网卡流量,报文捕获,终端工具,抓...MAC地址厂商对应表; 本机网络报文统计功能; 本机端口...
  • 交换机工作原理小结

    千次阅读 2012-04-28 16:03:38
    二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址对应的端口记录在自己内部的一个地址中。 工作流程 过程  (1) 当交换机从某个端口收到一个数据包,...
  • 交换机原理与模式

    2020-12-02 20:31:14
    3 第三章交换机原理与模式 3.1 MAC地址构成 MAC地址是由十六进制表示的 比如 00-D0-09-A1-D7-B7,前24位是厂商向IEEE申请的厂商...交换机中有一个MAC地址表对应着计算机的MAC地址和交换机相连的端口号 1、MAC地址学习
  • mac地址表是这样的(以华为交换机为例,其他各厂商类似) 如图,交换机记录了每个PC的mac地址对应的接口号,这样就可以帮他们进行数据转发了。 (mac地址学习原理可查看专栏相关文章,本文暂不详述) 测试...
  • wireshark网络安全(三)

    2020-08-21 19:26:39
    修改的mac地址的前三个字节要与存在的厂商的mac的前三个字节对应mac地址泛洪:使用macof工具 使用mac泛洪命令前的mac 在kali终端输入mac泛洪 再次查看CAM 此时再相互ping几个终端,网络不可达。因为CAM在...

空空如也

空空如也

1 2 3
收藏数 42
精华内容 16
关键字:

mac地址厂商对应表