精华内容
下载资源
问答
  • 交换机mac地址绑定

    2010-08-20 14:52:49
    cisco交换机mac地址绑定,以提高网络的安全性
  • 主要介绍了h3c交换机mac地址绑定、三层交换机固定ip上网、三层交换机端口配置ip地址的方法,需要的朋友可以参考下
  • 不会使用思科交换机绑定mac地址的老铁们可以看一下,简单实用
  • 交换机端口MAC地址绑定命令
  •  (1)理解二层交换机MAC地址绑定技术的意义及作用。  (2)掌握配置交换机MAC地址绑定的方法   2 实验设备  计算机(>1台);交换机(1台), Console电缆(1根),直连双绞线(>1根)   3 实验内容   ...

     

    实验一:交换机MAC地址与端口的绑定

     

    1 实验目的

      1)理解二层交换机MAC地址绑定技术的意义及作用。

      2)掌握配置交换机MAC地址绑定的方法

     

    2 实验设备

       计算机(>1);交换机(1), Console电缆(1根),直连双绞线(>1根)

     

    3 实验内容

     

    通常交换机支持动态学习 MAC 地址的功能,每个端口可以动态学习多个 MAC地址,从而实现端口之间已知 MAC地址数据流的转发。当 MAC地址老化后,则进行广播处理。也就是说,交换机某接口上学习到某 MAC地址后可以进行转发,如果将连线切换到另外一个接口上交换机将重新学习该 MAC地址,从而在新切换的接口上实现数据转发。

    但是,有些情况下为了安全和便于管理,需要将 MAC地址与端口进行绑定,端口只允许已绑定 MAC的数据流的转发。即,MAC地址与端口绑定后,该 MAC地址的数据流只能从绑定端口进入,其他没有与端口绑定的 MAC地址的数据流不可以从该端口进入。

      MAC地址与端口的绑定可以有效防止陌生计算机的接入,也可以有效防止人为随意调换交换机端口。

     

       配置命令:

    1.        使能端口的 MAC地址绑定功能

    格式(端口配置模式):switchport port-security

    2.        端口 MAC地址的锁定

    a)格式(端口配置模式):switchport port-security lock

    解释:锁定端口。当端口锁定之后,端口的 MAC地址学习功能将被关闭;

        b)格式(端口配置模式):switchport port-security convert

    解释:将端口学习到的动态安全 MAC 地址转化为静态安全 MAC地址。

    c)格式(端口配置模式):switchport port-security timeout  <value>

    解释:打开端口锁定定时器功能

    d) 格式(端口配置模式):switchport port-security mac-address <mac-address>

    解释:添加静态安全 MAC地址

     

    3.        MAC地址绑定的属性配置

    a)格式(端口配置模式):switchport port-security maximum  <value>

    解释:设置交换机端口最大安全 MAC 地址数

       b)格式(端口配置模式):switchport port-security violation {protect | shutdown}

    解释:设置当违反了端口的绑定规则时,对端口的处理方式。protect方式当违反规则后,对数据帧作简单抛弃处理;shutdown方式则会使得端口进shutdown掉。

     

     

    实验步骤:

                       

                                                               1MAC地址绑定拓扑图

    1、实验前测试即准备:配置PC0 IP192.168.0.1PC1 ip192.168.0.2PC0连接交换机FastEthernet 0/1口;PC1连接交换机FastEthernet 0/2口。

     

    PC0上使用ipconfig /all命令得出其MAC地址为00E0.A360.C454

    同理得PC1MAC地址为:000D.BDAD.DACD

     

    PC0ping PC1的结果为:

     

    2、配置MAC地址绑定

    Switch>enable

    Switch#configure t

    Switch(config)#interface f0/1

    Switch(config-if)#switchport mode access   f0/1端口配置为接入模式

    Switch(config-if)#switchport port-security  打开MAC地址绑定功能

    Switch(config-if)#switchport port-security mac-address 00E0.A360.C454 f0/1端口上绑定静态安全MAC地址为00E0.A360.C454

    Switch(config-if)#switchport port-security violation protect   配置端口绑定违反处理为protect方式

     

    使用show port-secutity address命令显示绑定结果:

    测试连接:

    1、在PC0ping PC1的结果为:

    测试结果表明:PC0可以访问PC1

    2、在交换机的f0/1端口上更换主机为PC2,其MAC地址为:0060.3E4D.02A2IP地址配置成为与PC0相同的ip地址:192.168.0.1

    连接图为:

     

    PC2PING PC1的结果为:

    表明PC2不能接入交换机。

     

    小节:1.通过手动端口绑定MAC应用的安全协议。

                 2.通过自学习。

    展开全文
  • 华为交换机怎么绑定绑定ip地址/MAC地址?主要是预防IP地址被盗用等网络安全威胁的问题,该怎么设置绑定呢?下面我们就来看看详细的设置教程,需要的朋友可以参考下
  • 掌握交换机mac地址绑定的方法 实验环境 Windows 2003,Cisco模拟器 相关知识 交换机的端口安全,是一种交换机的过滤策略,即为交换机的某个端口绑定一个固定的mac地址,使其他的mac地址访问的时候触发策略,down掉...

    实验目的

    掌握交换机mac地址绑定的方法

    实验环境

    Windows 2003,Cisco模拟器

    相关知识

    交换机的端口安全,是一种交换机的过滤策略,即为交换机的某个端口绑定一个固定的mac地址,使其他的mac地址访问的时候触发策略,down掉端口或者拒绝服务。

    实验过程

    1. 配置交换机IP为192.168.1.100

    代码块:

    Switch>enable
    Switch#config terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.100 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan1, changed state to up
        
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
    Switch(config-if)#exit
    Switch(config)#exit
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    

    运行图

    2. 配置计算机A的IP为192.168.1.10,并获取计算机的mac地址

    在这里插入图片描述
    在这里插入图片描述

    3. 配置交换机端口mac地址绑定功能

    代码块:

    Switch#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#interface Fa 0/5
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport port-security
    Switch(config-if)#switchport port-security mac-address 000A.F34C.8499
    Switch(config-if)#exit
    Switch(config)#exit
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    
    Switch#show port-security
    Secure Port MaxSecureAddr CurrentAddr SecurityViolation Security Action
                   (Count)       (Count)        (Count)
    --------------------------------------------------------------------
            Fa0/5        1          1                 0         Shutdown
    ----------------------------------------------------------------------
    Switch#show port-security address
    			Secure Mac Address Table
    -------------------------------------------------------------------------------
    Vlan	Mac Address	Type			Ports		Remaining Age
    								(mins)
    ----	-----------	----			-----		-------------
    1	000A.F34C.8499	SecureConfigured	FastEthernet0/5		-
    ------------------------------------------------------------------------------
    Total Addresses in System (excluding one mac per port)     : 0
    Max Addresses limit in System (excluding one mac per port) : 1024
    Switch#
    

    在这里插入图片描述

    验证。用网线把计算机A连接到计算机的第五个端口,ping交换机的IP地址,网络正常。再把计算机B换到交换机的第五个端口,再次ping计算机的IP地址,网络不通。

    计算机A ping通:
    在这里插入图片描述
    计算机B ping 不通
    在这里插入图片描述
    计算机连接如图:
    在这里插入图片描述

    展开全文
  • mac地址和端口绑定配置:set ethernet-switching-options secure-access-port interface ge-0/0/1.0 mac-limit 1set ethernet-switching-options secure-access-port interface ge-0/0/1.0 mac-limit action dropset...

    mac地址和端口绑定配置:
    set ethernet-switching-options secure-access-port interface ge-0/0/1.0 mac-limit 1
    set ethernet-switching-options secure-access-port interface ge-0/0/1.0 mac-limit action drop
    set ethernet-switching-options secure-access-port interface ge-0/0/1.0 allowed-mac
    set ethernet-switching-options secure-access-port interface ge-0/0/1.0 static-ip X.X.X vlan XX mac

    转载于:https://blog.51cto.com/holger/2056982

    展开全文
  • 这里用一台华三S2126-E0002交换机为例,演示华三低端交换机如何把mac地址绑定端口
  • CCNA第三天主要讲了交换机mac地址的静态绑定,以及这个实验的一些前置知识。 OSI参考模型: 这一天我们主要学习前两层:物理层和数据链路层。 物理层: 作用:定义线缆标准,例如:电压、线速、规格等。 设备:...

    CCNA第三天主要讲了交换机mac地址的静态绑定,以及这个实验的一些前置知识。

    OSI参考模型:

    在这里插入图片描述

    这一天我们主要学习前两层:物理层和数据链路层。

    物理层:

    作用:定义线缆标准,例如:电压、线速、规格等。
    设备:modem调制解调器、集线器中继器

    在这里插入图片描述

    数据链路层

    作用:定义的是线路物理标准,连接器标准,物理地址。
    协议:IEEE 802协议
    有线标准:IEEE 802.2、802.3、802.5、FDDI
    无线标准:IEEE 802.11(a、b、g、n、ac),现网中常用的无线标准是IEEE 802.11ac
    PS:以太网IEEE 802.3、令牌环网IEEE 802.5、FDDI这三种协议称为局域网大三协议。
    设备:交换机
    mac地址的学习:
    交换机的默认mac地址表为空,在接收到数据帧时,记录下接收的端口和数据源设备的Mac地址。

    Mac地址表的静态绑定

    MAC地址表静态绑定
    应用场景:办公网络环境中,交换机决定了内网数据的转发,因此交换机的mac地址表稳定是非常重要的,为了安全起见,不至于让交换机即插即用,我们对交换机的mac地址表进行静态映射(绑定)static。然后再启用端口安全,使除了绑定的mac地址这台设备以外,其他所有设备都无法进行数据发送,保证内网安全。
    配置:交换机全局模式下
    int range f0/1 - 4
    ///同时进入f0/1到f0/4所有接口,“range”接口范围。接口范围根据交换机上使用的接口来。
    Sw mode access
    /// 接口设置为接入模式,即此接口用于连接终端设备
    exi
    ///退出到全局模式
    Spanning-tree portfast default
    ///开启所有access接口的快速转发,此功能可以使交换机的access接口在接上设备之后,接口能够立刻进入转发状态(变绿)
    Int f0/1 ///进入f0/1接口
    Switchport port-security ///开启端口安全
    Switchport port-security mac-address +电脑1mac地址 ///静态绑定电脑的mac地址到交换机的f0/1接口上
    Switchport port-security violation shutdown ///定义端口安全的动作,一旦出现冲突(f0/1接口上的mac地址与绑定的mac地址不一致),接口动作立刻关闭(shutdown)
    Int f0/2
    Sw po
    Sw po mac +电脑2mac地址
    Sw po vio sh
    Int f0/3
    Sw po
    Sw po mac +电脑3mac地址
    Sw po vio sh
    Int f0/4
    Sw po
    Sw po mac +电脑4mac地址
    Sw po vio sh
    测试:找一台新电脑,接到已经绑定mac地址的接口上
    现象:接口立刻关闭(变红)

    展开全文
  • 华为交换机ip地址与MAC地址绑定

    千次阅读 2020-04-23 10:43:17
    user-bind static ip-address 192.168.2.1 mac-address 5489-981b-6e1b interface GigabitEthernet0/0/1 vlan 2 端口模式下输入: interface GigabitEthernet0/0/5 port link-type access port default vlan 4 ip s....
  • 关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定交换机设置关于IP-MAC地址绑定的...
  • 华为s5700交换机IP地址与MAC地址绑定

    千次阅读 2020-02-13 15:47:54
    [SW1]dhcp enable //开启dhcp服务 [SW1]vlan 10 //创建...[SW1]ip pool vlan10 //新建地址池名为vlan10 [SW1]gateway-list 192.168.1.254 //设置网关 [SW1]network 192.168.1.0 maks 255.255.255.0 //设置网段 ...
  • 交换机IP-MAC地址绑定

    2013-12-06 22:01:43
    前段时间朋友问我在交换机下面怎么同时绑定IP地址和MAC之前没怎么注意这方面,最近在客户这边改造DHCP,发现客户在6509上面... 大家都知道,用户可使用端口特性来限制并标识允许访问端口的MAC地址,这样的特性是在端...
  • cisco交换机IP-MAC地址绑定配置

    千次阅读 2017-11-08 23:54:00
    一、基于端口的MAC地址绑定 思科2950交换机为例,登录进入交换机,输入管理口令进入配置模式,敲入命令: Switch#c onfig terminal 进入配置模式 Switch(config)# Interface fastethernet 0/1 #进入具体端口配置...
  • Cisco_2960交换机中如何绑定IP与MAC地址
  • H3C交换机MAC绑定

    千次阅读 2012-07-27 14:41:37
    2.PORT+MAC绑定:将报文的接收端口和源MAC地址绑定。3.PORT+IP+MAC绑定:将报文的接收端口、源IP地址和源MAC地址绑定。4.IP+MAC绑定:将报文的源IP地址和源MAC地址绑定。绑定命令1.端口+MA...
  • 交换机的端口安全,是一种交换机的过滤策略,即为交换机的某个端口绑定一个固定的mac地址,使其他的mac地址访问的时候触发策略,down掉端口或者拒绝服务 以下为拓扑图   交换机配置    enable 进入特权...
  • 思科交换机如何实现ip与mac地址绑定
  • H3C低端交换机MAC绑定

    2019-08-03 00:38:27
    1、MAC地址和端口的绑定<h3c>system[h3c]interface e0/1[h3c-interface]mac-address max-count 0 #关闭交换机端口的MAC学习功能[h3c] mac-address port-bind H-H-H interface e0/1 vlan 1012.四元绑定H3C的四...
  • 了解什么情况下需要MAC地址与IP地址的绑定; 了解如何接入交换机上的配置MAC地址与IP地址。 二、 实验设备 DCS二层交换机1台 三、 实验步骤 switch(Config)#switch(Config)...
  • 2、掌握交换机MAC地址表的管理方法 实验拓扑 【欢迎关注微信公众号:厦门微思网络】 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、测试主机之间以及主机和服务器之间的网络连通性; 3、把...
  • 请问:在2960交换机中如何进行端口MAC地址绑定,并同时绑定IP与MAC地 址? 网友1: conf t arp 192.168.1.1 0000.1001.2200 arpa fa0/1 网友2: IP地址与MAC地址的关系: IP地址是根据现在的IPv4标 准...
  • 华为交换机 端口绑定MAC地址

    千次阅读 2019-10-08 19:03:57
    华为S2352P二层交换机绑定MAC与端口绑定最近有这个需求:如何配置MAC与端口绑定,使其他设备在此端口不能上网?#1.在端口中关闭MAC学习 [huawei]interface Ethernet0/0/1 [huawei-Ethernet0/0/1]mac-address ...
  • 交换机中如何进行端口MAC地址绑定,并同时绑定IP 与MAC 地址? 网友1 : <br /> conf t arp 192.168.1.1 0000.1001.2200 arpa fa0/1 <br /> 网友2 : 无线路由器密码破解 ...
  • 环境Cisco Packet Tracer 5.3Windows 10操作操作:按照如图所示连接拓扑图1、进入相应的接口(以端口1设置Mac地址绑定,PC0接1端口举例)Switch>enable Switch#config Configuring from terminal, memory, or ...
  • 交换机实现MAC地址表的绑定和过滤

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 582
精华内容 232
关键字:

交换机mac地址绑定