精华内容
下载资源
问答
  • lan

    2009-10-16 01:16:00
  • LAN8720芯片在ESP32的驱动源码
  • OpenWRT(二)配置WAN口和LAN

    万次阅读 2016-12-15 19:43:39
    LAN:Local Area Network 的英文简称,即局域网 **我们计算机和路由连在一起就是接这个口**WAN: Wide Area Network 的英文简称,即广域网 **运营商拉进来的网线就是和这个口连在一起**VLAN( Virtual Local Area ...

    一、基本概念

    1. LAN:Local Area Network 的英文简称,即局域网
      我们计算机和路由连在一起就是接这个口

    2. WAN: Wide Area Network 的英文简称,即广域网
      运营商拉进来的网线就是和这个口连在一起

    3. VLAN( Virtual Local Area Network)的中文名为"虚拟局域网"
      VLAN通常是在局域网中逻辑地再划分为几个网段来构成VLAN。一个局域网中可以划分为N多个VLAN,使VLAN之间不可直接互相通信。LAN和WAN都属于VLAN

    二、配置WAN口和LAN口

    1. 首先要将OpenWRT系统下载到开发板(RT5350),然后将开发板上电进入OpenWRT系统,使用secureCRT进行命令操作。(secureCRT对于熟悉Linux嵌入式开发的人应该so easy)

    2. OpenWRT中的配置文件在/etc/config/下面,WAN和LAN的配置在/etc/config/network中
      这里写图片描述
      上面是打开该文件后的截图

    3. 分析上面文件中的信息(只讲重点的):

      config interface 'lan'  //配置LAN口
        option type 'bridge' //桥接方式
        option ifname 'eth0.1' // 代表vlan1,这个很重要,下面配置会用到
        option proto 'static' //静态IP
    
       config device 'lan_dev' //配置LAN硬件信息
    	   option macaddr           //设置MAC地址
    
       config interface 'wan'  //配置WAN口
    	    option type 'dhcp' //dhcp方式(dhcp自行百度)
    
      config switch     //switch是交换机的意思
    		option enable_vlan  '1'    // 1表示开启vlan口
    
      config switch_vlan  
        option vlan '1'  //VLAN1, 和上面的option ifname 'eth0.1'相匹配,所以是配置LAN口
        option ports '0 1 2 3 6t'   //0~3都是LAN口,RT5350有5个端口。6t表示,经过端口6的数据包会被打上标记,它通常是内部端口,是在芯片内部的。
    
      config switch_vlan  
        option vlan '2'  //VLAN2, 和上面的option ifname 'eth0.2'相匹配,所以是配置WAN口
        option ports '4 6t'   //4是WAN口
    

    好了,通过上面的介绍应该就能随意配置端口为LAN口或WAN口了

    上面的network文件是UCI配置文件,要深入学习可以到https://wiki.openwrt.org/doc/uci

    欢迎大家关注我的微信公众号!!
    展开全文
  • LAN-to-LAN互连方案

    2020-03-04 10:49:08
    本文将为大家介绍LAN-to-LAN互连的方案。
  • LAN8742A/LAN8742Ai

    2017-11-16 17:01:13
    LAN8742A LAN8742Ai 网络接口芯片 Small Footprint RMII 10/100 Ethernet Transceiver with HP Auto-MDIX and flexPWR® Technology
  • 主要介绍了LAN是什么意思?LAN局域网基础知识介绍,LAN是Local Area Network的简称,中文名称:局域网,本文详细讲解了它的基础知识,需要的朋友可以参考下
  • LAN8742.PDF

    2021-05-27 19:46:16
    LAN8742
  • 前言(也叫废话):虽然这个功能叫局域网唤醒,但配合路由器的...进入BIOS后找一下有没有Wake On LAN、网卡唤醒、WOL等字样的选项,找到后启用。 二、注册花生壳账号 传送门:https://console.oray.com/passport...

    前言(废话):虽然这个功能叫局域网唤醒,但与路由器的端口映射功能配合,广域网唤醒也是很容易的。只要有一台能上网的电脑或手机,就能把家中电脑打开,需要用家里电脑又不在家的时候很方便。
    注意事项:
    此教程是为了实现外网唤醒内网主机,所以开始之前请确保您的宽带运营商分配给你的IP是公网IP!!!如果您的路由器获取的IP是内网IP(下面有IP段),就不能在外网唤醒了。不过!!如果您用的是光猫路由一体机,下面的路由器获取的也是内网IP,这时就需要登录光猫,将连接方式改为桥接,然后通过路由器拨号上网,这样路由器获取的才能是公网IP,路由器的DDNS功能才能将域名解析到你的公网IP上。
    内网IP段:192.168.0.0-192.168.255.255、172.16.0.0-172.31.255.255、10.0.0.0-10.255.255.255
    请确保您的路由器有DDNS功能(现在应该是都有的)

    一、开启WOL功能
    开机狂按 进BIOS设置
    BIOS热键
    不同品牌的BIOS中WOL的名字可能不同,所以进入BIOS后找一下有Wake On LAN、网卡唤醒、WOL等字样的选项,找到后启用。

    二、注册账号(路由器设置里有DDNS服务提供商的地址)
    不详细说了,百度以下注册就可以了。

    三、设置路由器

    1. 登陆路由器,路由器底部有账号密码和登录地址, 地址一般为 http://192.168.0.1 或者 http://192.168.1.1,然后登录DDNS账号
      在这里插入图片描述
      这里注意,有的路由器(比如我这个)域名信息显示的域名前面有1.、2.,这只是个序号,后面填写域名的时候记得去掉
    2. 设置IP与MAC绑定
      找到你电脑的MAC地址,绑定
      在这里插入图片描述
    3. 设置端口映射,有的路由器上叫虚拟服务器
      注意IP地址与电脑的IP一致,就是刚才MAC绑定时的IP地址,端口随便开一个就行(但是不要用运营商封禁的端口,推荐使用9端口)。另外协议类型选择UDP或者ALL!!因为唤醒数据包是通过UDP协议发送的,所以协议类型只选择TCP协议的话 数据包是进入不了内网的!!
      在这里插入图片描述

    四、设置网卡
    如果是Windows系统:
    把网卡的关机网络唤醒魔术封包唤醒设置为开启
    在这里插入图片描述
    打上勾
    在这里插入图片描述
    如果是Linux, 安装ethtool
    执行ethtool eth0 eth0是你的网卡地址,视情况更改
    看到

    Supports Wake-on: g
    Wake-on: g
    

    如果显示g,表示wol功能已经开启
    否则执行 ethtool -s eth0 wol g 来开启WOL功能
    (我的自己PC(Debian10)上测试的情况是, 开机后执行ethtool eth0看到wol功能是开启的, 但是关机后唤醒不了, 需要每次开机都执行一次开启命令 ethtool -s eth0 wol g 关机后才能被唤醒, 如果你的情况和我一样, 添加一个自启脚本即可解决, 具体方法自行百度)
    五、尝试唤醒
    你可以在手机上下载有关WOL唤醒的软件进行唤醒,如果不想安装软件,可以用下面的网站进行唤醒。
    用网站的话不用记MAC地址和域名,唤醒时只要输入账号密码就可以了,在任何地方都能唤醒电脑,只要有能上网东西就行,也可以记住密码。
    传送门:https://wol.qwq.plus 点击“注册账号”
    输入账号密码,MAC地址,域名填写申请的免费域名,端口填写刚才映射的端口
    在这里插入图片描述
    注册完毕后关闭电脑,用其他设备打开 https://wol.qwq.plus 输入刚注册的账号密码,唤醒,或者用手机上的软件唤醒,如果成功唤醒,恭喜!折腾完了,到此结束。如果电脑没开,继续往下看。
    如果是Windows 10系统,把快速启动关掉试试,不行在看下面(有人不关可以唤醒,有的必须关了才能唤醒)
    六、排查问题
    下载sokit 1.3汉化版(这我就不发链接了,百度一搜一大堆),UDP监听刚才开的端口,然后用上面网站,或者用手机WOL软件,唤醒,如果能成功收到数据包,说明网络设置没问题,如果收不到,检查下注册时信息有没有填错,或者唤醒软件上填的信息有没有填错,端口映射、MAC绑定什么的检查一下。如果能收到就看下一步
    在这里插入图片描述
    七、更新网卡驱动
    打开电脑,下载、安装驱动人生或驱动精灵之类的软件,把网卡驱动更新为最新。更新完重启,关机,网卡重新设置一遍。再次唤醒。如果更新网卡还不管用的话,我也无能为力了。

    PS:
    关于公网IP:因为IPv4地址短缺,有的运营商已经偷偷把公网IP换成内网IP了。有人说打客服投诉会给你分配公网IP,你是内网IP的话可以打电话试试,网上有人说态度强硬点就给你换。我家用的联通, 至今还有公网IP。
    有的网友说关机时间长了就不能唤醒了,百度了一下,可能是路由器的问题,以下是网络上的答案

    静态IP-MAC绑定有时候不稳定
    路由器ARP条目消失。消失后就无法网络唤醒了

    转载请注明出处!!!

    展开全文
  • LAN8742替换LAN8720

    千次阅读 2019-12-25 22:20:13
    LAN8742可以替换LAN8720吗? 肯定可以的,LAN8742就是8720的升级版 两者引脚是pin to pin兼容的 8742比8720多了一个wol网络唤醒功能,8742和电脑直连时可以使用直连网线,芯片自己交叉tx和rx信号线。 那么用8742...

    LAN8742可以替换LAN8720吗?

    肯定可以的,LAN8742就是8720的升级版

    两者引脚是pin to pin兼容的

    8742比8720多了一个wol网络唤醒功能,8742和电脑直连时可以使用直连网线,芯片自己交叉tx和rx信号线。

    那么用8742的驱动可以驱动8720吗?

    可以,但是要注意下芯片的电路图。如果两个芯片设计的电路图不同,就有些要注意的地方,比如下面是野火开发板用的8720,NUCLEO用的是8742

     

    注意箭头指的地方,这三个引脚关系到mode的配置,NUCLEO外接了上拉电阻,所以配置的是111,这样是通过硬件配置,启动自动协商,8742上电后自动和路由协商是100M带宽还是10M带宽,是全双工还是半双工。

    但是野火的开发板没有上拉,索引野火的程序是在软件复位8720芯片后软件启动协商。那么在野火开发板运行NUCLEO的程序时,就要在low_level_init()函数中增加启动协商代码

     //软件启动自动协商,NUCLEO是把MODE0:2上拉实现硬件初始化自动协商

      //而野火没有上拉,在野火的资料程序中是用的软件启动协商,所以这里要加协商
      if(LAN8742_StartAutoNego(&LAN8742) != LAN8742_STATUS_OK)
      {
          while(1)
          {
              BSP_LED_On(LED3);
          }
      }

    所以其实两个芯片没啥区别,如果不涉及到wol的话。完全可以替换。

    展开全文
  • LAN8720A中文手册,
  • LAN8700.PDF

    2020-07-10 10:43:07
    The Microchip LAN8700/LAN8700i is a low-power, industrial temperature (LAN8700i), variable I/O voltage, analog interface IC with HP Auto-MDIX support for high-performance embedded Ethernet ...
  • minutarion-Czech-point.lan Xvideos / .lan
  • LAN8720.pdf

    2020-04-11 16:30:41
    LAN8720/LAN8720i Small Footprint RMII 10/100 Ethernet Transceiver with HP Auto-MDIX Support
  • LAN Messenger是一个开放源代码,多功能,最小且简单的轻量级Messenger,可帮助您在公用网络上与朋友,同事,同事等聊天。 该Messenger不需要您连接到Internet。 在Whatsapp,Line,微信,Viber等无法正常工作的...
  • lan-js 从 Web 浏览器探测 LAN 设备。 文档 见 。 示例代码: 扫描您网络上的以下设备,并打印任何匹配的设备 lan.DeviceScan.start(['192.168.0.1', '192.168.0.2', '192.168.1.1', '10.0.0.1'], { found: ...
  • 本次上传内容是stm32f767对驱动lan8720的相关程序。
  • Wake On LAN库和系统可执行文件 前提条件 Ruby 1.8.6或更高版本 安装 您可以使用RubyGems [rubyforge.org/projects/rubygems]远程安装WakeOnLAN库的最新版本。 gem install --remote wakeonlan 用法 ↑ require...
  • LAN_Realtek

    2014-10-20 23:38:46
    LAN_Realtek
  • Lan Action-开源

    2021-04-23 17:34:21
    Lan Action提供了用于网络聚会计划和管理的Web前端。 它是完全模块化的,并提供了非常强大的组处理功能。 Lan Action已在某些lan上使用,许多模块已接近完成。
  • LAN8720A.pdf

    2021-03-21 17:54:07
    LAN8720A芯片数据手册
  • LAN8720A.PDF

    2020-07-10 10:47:16
    he LAN8720A/LAN8720Ai is a low-power 10BASE-T/100BASE-TX physical layer (PHY) transceiverwith variable I/O voltage that is compliant with the IEEE 802.3-2005 standards. The LAN8720A/LAN8720Ai supports...
  • LAN Checker 允许您分析进出计算机的网络流量。 它代表了技术人员和业余爱好者的完美解决方案。 我们甚至出于安全目的开发此程序:您可以使用它来发现使用您网络的恶意软件和间谍软件。
  • OPNET LAN Modeling

    2015-05-10 12:14:03
    OPNET的Tutorials里 LAN Modeling的实例代码。4个城市之间建立LAN网络进行仿真。
  • LAN8720数据手册

    2020-10-13 13:48:58
    以太网PHY层芯片LAN8720的数据手册,高性能的10/100M以太网传输模块,支持RMⅡ接口,两个状态LED输出......
  • 2LAN冗余.pka

    2020-04-02 12:14:30
    2LAN冗余.pka
  • 4无线LAN.pka

    2020-04-02 12:13:13
    4无线LAN.pka
  • lan scanner

    2010-01-11 08:13:43
    program to scan lan network
  • LAN Convention-开源

    2021-04-23 18:42:15
    LANCon是LANParty和LAN Tournament管理系统,可帮助组织和运行LAN Party或游戏活动。 LANCon用ASP(VBScript)编写,不需要数据库,因为所有数据都存储在XML中。
  • LAN8720手册

    2016-01-15 20:29:28
    这是LAN8720的手册,有需要的下载,不需要分。
  • MapleStoryM-lan-源码

    2021-03-15 15:10:18
    MapleStoryM-lan

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 132,657
精华内容 53,062
关键字:

lan