精华内容
下载资源
问答
  • 链路聚合配置思科
    千次阅读
    2021-04-08 11:08:39

    基本配置思想

    配置逻辑

    将交换机的端口逻辑上融合成一个端口,然后再另一台直连的交换机上直连端口也进行相应的配置。(配置前记得将使用到的端口先关闭,配置完后在启用)(配置的端口要属于同一 端口组 能进行通信)

    步骤一:验证交换机的端口配置

    命令:

    目前未知效果命令:show int | include eth(作用有待考究)

    查看端口状态命令:show int sta

    查看trunk口命令:show int tr

    步骤二:配置端口通道

    命令:

    对多个端口进行相同的配置:int range f0/xx-xx

    首先关闭使用到的端口:shutdown

    再将使用到的端口进行逻辑划分(划分成一个逻辑接口):channel-group 1 mode 逻辑接口状态

    划分完后将使用到的端口启用:no shutdown

    将逻辑链路划分完后要将(逻辑)端口设置为中继端口:

    1. int port-channel 逻辑端口号
    2. switchport mode trunk

    提示:

    1. 对于接口的配置必须是双向的,才能让链路通信生效。
    2. 逻辑接口状态这个参数,在不同的协议下有不同的参数,比如思科专有协议(PAgP)接口状态有desirable(期望),auto(自动)。以太网协议(LACP)接口状态有active(主动),passive(被动)。
    3. 除了逻辑接口状态这个参数不同外,在思科的配置中链路聚合的配置基本一致。

    步骤三:查看 以太网通道 配置信息

    命令:

    show eth sum

    其他的配置命令

    端口禁用DTP命令

    命令:

    switchport nonegotiate

    查看生成树状态

    命令:

    show spanning-tree

    手动设置根桥

    方法一:设置主根
    命令:

    spanning-tree vlan 1 root primary

    方法二:设置优先级
    命令:

    spanning-tree vlan 1 priority 24576

    其他知识

    什么是端口组?

    个人理解:

    就是将多个端口划分为一个逻辑接口,这个逻辑接口就叫端口组。

    在配置中需要注意的部分

    1. 如果端口启用了DTP(动态配置模式),但是没有把端口模式设置为中继模式,那么链路是不会变成中继模式的
    2. 在进行链路聚合之前,最好将要捆绑的端口关闭。(若不先关闭则可能会出现配置的时候将端口禁用)

    可能有些有些专业名词解释的并不是很正确,如果有更好的理解欢迎探讨。

    更多相关内容
  • Cisco交换机链路聚合配置

    千次阅读 2021-10-01 11:48:19
    文章目录1、拓扑图2、Sw1配置3、Sw2配置 1、拓扑图 2、Sw1配置 ...把接口加入链路聚合接口1:Sw1(config-if)#description f0/1,f0/2 更改接口传输模式:Sw1(config-if)#switchport mode trunk 允许

    1、拓扑图

    在这里插入图片描述

    2、Sw1配置

    1. 进入特权模式:Switch>en
    2. 进入全局模式:Switch#conf t
    3. 更改设备名称:Switch(config)#hostname Sw1
    4. 更改接口传输模式:Sw1(config-if)#switchport mode trunk
    5. 允许所有vlan通过:Sw1(config-if)#switchport trunk allowed vlan all
    6. 进入全局模式:Sw1(config-if)#exit
    7. 进入交换机接口:Sw1(config)#int range f0/1-2
    8. 将接口绑定链路聚合1:Sw1(config-if-range)#channel-group 1 mode on
    9. 修改传输模式:switchport mode trunk
    10. 进入特权模式:Sw1(config-if-range)#exit Sw1(config)#exit
    11. 保存配置:Sw1#wr

    3、Sw2配置

    1. 进入特权模式:Switch>en
    2. 进入全局模式:Switch#conf t
    3. 更改设备名称:Switch(config)#hostname Sw2
    4. 修改接口模式传输模式:Sw2(config-if)#switchport mode trunk
    5. 运行所有vlan通过:Sw2(config-if)#switchport trunk allowed vlan all
    6. 进入全局模式:Sw2(config-if)#exit
    7. 进入交换机接口:Sw2(config)#int range f0/1-2
    8. 将接口绑定链路聚合1:channel-group 1 mode on
    9. 修改传输模式:Sw2(config-if-range)#switchport mode trunk
    展开全文
  • Cisco三层交换机链路聚合配置应用实例!!!!
  • 华为、思科交换机链路聚合配置(lacp)
  • CISCO链路聚合基础命令详解。

    千次阅读 2021-08-25 11:18:04
    首先,准备两台S2960交换机与两台...链路汇聚命令详解如下(SW2与SW3都需进行相同配置): 首先进入全局模式 Switch(config)#int range f0/2-4 /进入交换机2、3、4端口 Switch(config-if-range)#channel-group 1...

    首先,准备两台S2960交换机与两台电脑,如图所示连接。

     ※图上可以看出,未汇聚之前三条连接线路只有一条是,正常通信状态。

        PC2链接SW2 F0/1端口,PC3链接SW3 F0/1端口。

       SW2与SW3之间用F0/2-4连接。

     链路汇聚命令详解如下(SW2与SW3都需进行相同配置):

    首先进入全局模式

    Switch(config)#int range f0/2-4 /进入交换机2、3、4端口

    Switch(config-if-range)#channel-group 1 mode on /将端口加入聚合端口1 并开启

    Switch(config-if-range)#exit /退出端口视图

    iSwitch(config)#int port-channel 1 /进入聚合端口

    Switch(config-if)#switchport mode trunk /配置端口模式为 trunk

    Switch(config-if)#switchport trunk allowed vlan all /允许端口全 VLAN通过

    Switch(config-if)#exit /退出至用户模式

    Switch>show etherchannel summary /查看端口通道状态

    至此配置完成。查看通道状态如下:

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ------+-------------+-----------+----------------------------------------------

    1 Po1(SU) - Fa0/2(P) Fa0/3(P) Fa0/4(P)

     

     

    完成后可以看到,三条连接线路都显示正常通信,尝试断开其中一条,在PC端使用PING命令测试通信依旧正常。

     

     

    展开全文
  • 链路聚合配置命令

    万次阅读 2018-04-09 21:18:49
    1.1 概述1.1.1 链路聚合简介在路由器上使用多链路进行互连时,可以把多条物理链路进行捆绑,对外呈现一条逻辑链路,并屏蔽实际的物理链路。这种方式称之为链路聚合(Aggregate,简称AG),且把实际的物理链路称之...

    1.1    概述

    1.1.1    链路聚合简介

    在路由器上使用多链路进行互连时,可以把多条物理链路进行捆绑,对外呈现一条逻辑链路,并屏蔽实际的物理链路。这种方式称之为链路聚合(Aggregate,简称AG),且把实际的物理链路称之为AG的成员链路。锐捷设备所提供的AG功能符合IEEE802.3ad标准,它可以用于扩展链路带宽,提供更高的连接可靠性。

    AG功能支持流量平衡,可以把流量均匀地分配给各成员链路。AG功能还实现了链路备份,当AG中的一条成员链路断开时,系统会将该成员链路的流量自动地分配到AG中的其它有效成员链路上去。AG中一条成员链路收到的广播或者多播报文,将不会被转发到其它成员链路上。

    图 1‑1 典型拓扑场景

    路由器上每个AG口最多包含的成员口数量都为8个。

    1.1.2    流量均衡简介

    AG可以根据报文的源IP地址,目的IP地址,源IP地址+目的IP及源IP和目的端口号等特征值把流量平均地分配到AG的成员链路中。可以在接口模式下用route-aggregateportload-balance设定流量分配方式。

    “源IP流量平衡”是根据报文的源IP把报文分配到AG的各个成员链路中。不同源IP的报文根据源IP在各成员链路间平衡分配,相同源IP的报文,固定从同一个成员链路转发。该方式为三层AG默认的流量平衡方式。

    “目的IP流量平衡”是根据报文的目的IP把报文分配到AG的各个成员链路中。相同目的IP的报文,固定从同一个成员链路转发,不同目的IP的报文,根据目的IP在各成员链路间平衡分配。

    “源IP地址+目的IP流量平衡”是根据报文的源IP地址+目的IP把报文分配到AP的各个成员链路中。具有不同的源IP地址+目的IP的报文根据源IP地址+目的IP在各成员链路间平衡分配,而具有相同的源IP地址+目的IP的报文则固定分配给同一个成员链路。

    “源IP和目的端口号流量平衡”是根据源IP和目的端口号进行流量分配。不同源IP和目的端口号的报文根据源IP和目的端口号在各成员链路间平衡分配,相同源IP和目的端口号的报文则固定通过相同的成员链路转发。

    当前在路由器上的流量均衡主要由:源IP、目的IP、源端口号、目的端口号为元素的组合进行流量平衡。在路由器RSR77系列上除了支持上述的流量平衡模式外,还支持其他的流量均衡模式,如:基于源和目的端口、基于源IP和目的端口号、基于目的IP和源端口号等,具体配置命令详见下面配置例子。

    我们应根据不同的网络环境设置合适的流量分配方式,以便能把流量较均匀地分配到各个链路上,充分利用网络的带宽。


    相关的协议规范或参见的标准:

      802.1AX-2014 - IEEE Standard for Local and metropolitan areanetworks -- Link Aggregation

      RFC7130, Bidirectional Forwarding Detection (BFD) on LinkAggregation Group (LAG) Interfaces


    配置步骤

    步骤

    配置任务

    说明

    1

    创建AG接口

    必选

    2

    将以太口加入AG接口

    必选

    3

    配置AG接口

    可选

    配置举例

    组网需求

    为了提高带宽和链路可靠性,RouterA与RouterB之间通过不同的运营商链路进行互连


    配置要点

    l   RouterA和RouterB上分别创建AG口,分别将gi 0/0和gi 0/1加入AG口;

    l   RouterA和RouterB上AG口配置IP地址及BFD会话。

    配置步骤

    1)    在RouterA上创建AG口1,并将gi 0/0和gi 0/1加入AG口:

    RouterA#configure terminal

    RouterA(config)#interfaceroute-aggregateport 1

    RouterA(config-if-Route-aggregateport1)#exit

    RouterA(config)#

    RouterA(config)#interfacegigabitEthernet 0/0

    RouterA(config-if-GigabitEthernet0/0)#route-port-group 1

    RouterA(config-if-GigabitEthernet0/0)#exit

    RouterA(config)#

    RouterA(config)#interfacegigabitEthernet 0/1

    RouterA(config-if-GigabitEthernet0/1)#route-port-group 1

    RouterA(config-if-GigabitEthernet0/1)#exit

    2)    RouterA上的AG口配置IP地址及BFD会话。

    RouterA(config)#

    RouterA(config)#interfaceroute-aggregateport 1

    RouterA(config-if-Route-aggregateport1)#ip address 124.115.8.1 255.255.255.0

    RouterA(config-if-Route-aggregateport1)#bfd interval 50 min_rx 50 multiplier 3

    RouterA(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/0 bind bfd peer-ip 124.115.8.2

    RouterA(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/1 bind bfd peer-ip 124.115.8.2

    3)    在RouterB上创建AG口1,并将gi 0/0和gi 0/1加入AG口:

    RouterB#configure terminal

    RouterB(config)#interfaceroute-aggregateport 1

    RouterB(config-if-Route-aggregateport1)#exit

    RouterB(config)#

    RouterB(config)#interfacegigabitEthernet 0/0

    RouterB(config-if-GigabitEthernet0/0)#route-port-group 1

    RouterB(config-if-GigabitEthernet0/0)#exit

    RouterB(config)#

    RouterB(config)#interfacegigabitEthernet 0/1

    RouterB(config-if-GigabitEthernet0/1)#route-port-group 1

    RouterB(config-if-GigabitEthernet0/1)#exit

    4)    RouterB上的AG口配置IP地址及BFD会话。

    RouterB(config)#

    RouterB(config)#interfaceroute-aggregateport 1

    RouterB(config-if-Route-aggregateport1)#ip address 124.115.8.2 255.255.255.0

    RouterB(config-if-Route-aggregateport1)#bfd interval 50 min_rx 50 multiplier 3

    RouterB(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/0 bind bfd peer-ip 124.115.8.1

    RouterB(config-if-Route-aggregateport1)#member interface GigabitEthernet 0/1 bind bfd peer-ip 124.115.8.1

    显示验证

    1)查看RouterA上的AG口的接口统计:

    RouterA#show interfaceroute-aggregateport 1

    Index(dec):35 (hex):23

    Route-aggregateport 1 is UP  , line protocol is UP   

    Hardware is  Route-aggregateport, address is001a.a93e.dd31 (bia 001a.a93e.dd31)

    Interface address is: 124.115.8.1/24

    后面省略。。。。

    展开全文
  • Cisco Packet Tracer---链路聚合简单配置

    万次阅读 多人点赞 2019-03-26 13:45:54
    第二步:添加一条线路,第二条一端变绿,未使用链路聚合 第三步:交换机创建聚合接口并描述将要加入聚合接口的端口加入 Enable---------------------进入配置 Conf t-----------------------进入...
  • Cisco Packet Tracer中配置链路聚合

    万次阅读 多人点赞 2018-10-20 11:29:57
    Cisco Packet Tracer中配置链路聚合 聚合链路介绍:、 链路聚合(Link Aggregation),是指将多个物理端口捆绑在一起,成为一个逻辑端口,以实现出/ 入流量在各成员端口中的负荷分担,交换机根据用户配置的端口...
  • 链路聚合_链路聚合配置命令

    千次阅读 2020-11-21 16:08:38
    二、知识梳理链路聚合链路聚合能够使用两台设备之间的多个物理链路创建一条个逻辑链路,物理链路之间能够进行负载共享,而不是通过STP来阻塞一条个或多条个链路。EtherChannel技术 以太网通道(EtherChannel)技术可以...
  • Cisco模拟)链路聚合 Eth-trunk

    万次阅读 2021-12-27 16:33:20
    一、链路聚合简述: Eth-Trunk以太网链路聚合简称链路聚合 将多个物理端口形成的物理链路捆绑为一条大的逻辑链路实现[增加带宽]的目的 同时捆绑在一起的链路通过相互间的动态备份[提高链路可靠性] 二、目的: 将多...
  • 命令为介绍华三的链路聚合使用,并且是在某医院做过实际操作的配合思科上联设备,作为下联设备时所遇到的问题如何处理使用,全是干货 有图
  • 将连接多个物理链路的端口捆绑在一起形成一个逻辑端口,这个逻辑端口成为聚合端口(AP)。聚合端口AP的功能遵循IEEE802.3ad标准,目标是扩展链路带宽,提高链路可靠性。 端口聚合条件: 一般交换机最多支持8个物理...
  • 1.创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。system-view[Quidway]sysnameSwitchA[SwitchA]interfaceEth-Trunk1[SwitchA-Eth-Trunk1]trunkportethernet0/0/1to0/0/3[SwitchA-Eth-Trunk1]quit说明接口缺省...
  • 链路聚合在实际交换机互连中用的还是比较多的,本次教程就带大家来熟悉一下如何在思科交换机上进行简易的链路聚合配置,相信会对大家有所帮助。一般由于设备兼容性不同,支持的链路聚合协议也可能不同,动态的链路...
  • 三层交换机链路聚合实验 一.实验内容 互联网结构如图所示,三层交换机S1和S2的端口3-5构成端口通道,这一对端口通道作为实现S1和S2互连的三层接口。三层交换机S1和S2的端口6-8构成端口通道,这一对端口通道构成三层...
  • Cisco交换机 ——链路聚合

    千次阅读 多人点赞 2018-12-27 17:48:24
    为了充分利用交换机之间的多条链路,可使用端口信道化技术,Ether Channel就是一种,Cisco开发它的初衷是用于在交换机之间将多条快速以太网或吉比特以太网链路组合成一条逻辑信道 启用端口信道化技术之后,第2层STP...
  • cisco 思科三层交换机配置命令

    千次阅读 2020-09-29 10:25:28
    1.交换机支持的命令 交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 ...
  • cisco链路聚合配置

    千次阅读 2013-03-25 01:06:44
    端口聚合又称作链路聚合,即将几个链路作聚合处理以达到增加交换机之间的连接带宽,避免网络瓶颈的目的。 链路聚合控制协议实现了如何将两个以上的以太网链路组合起来成为高带宽通道。其实现方法是在交换机上把多个...
  • 定义链路聚合或端口聚合,将多条物理链路聚合成一条逻辑上的链路(这条逻辑链路带宽相当于物理链路带宽之各),不单独配置物理口,这些物理链路作为这个逻辑通道的成员,配置时只配置这个逻辑通道。这些物理口同时都在...
  • 一、单臂路由 1.实现VLAN之间的路由 方法一:采用路由器的多个物理接口 方法二:采用单臂路由的方式(子接口的方式) 2.单臂路由概述 单臂路由实现不同VLAN间通信 链路类型: ...
  • 华三和华为交换机叫 链路聚合 思科交换机叫 端口聚合 华三配置 一、聚合方式: 1、lacp 静态链路聚合 动态链路聚合 2、手工负载分担 二、配置步骤 静态端口聚合(两台交换机都按照下面命令配置) ...
  • 三层交换机如何实现链路聚合

    千次阅读 2021-08-20 23:52:58
    二、配置步骤及命令 CE1 [~SW1]int eth-trunk 1 //创建eth-trunk组1 [*SW1-Eth-Trunk1]undo portswitch //开启eth-trunk 1 接口三层功能 [*SW1-Eth-Trunk1]ip add 10.1.1.1 24 //给eth-trunk 1接口设置ip地址...
  • 链路聚合技术及其配置

    千次阅读 2019-09-01 15:50:39
    链路聚合技术 (链路捆绑) ** 链路聚合技术背景 交换机与交换机之间如果流量很大的时候会出现带宽不足的问题。(路由器与路由器)(交换机与服务器之间)------------链路聚合技术 (链路捆绑) 因为当我们在...
  • 链路聚合配置

    千次阅读 2020-08-02 16:23:07
    [H3C-Bridge-Aggregation1]link-aggregation mode dynamic //配置该接口为动态聚合模式 [H3C-Bridge-Aggregation1]quit [H3C]interface g1/0/1 [H3C-GigabitEthernet1/0/1]port link-aggregation group 1 //将端口...
  • 链路聚合(cisco、华为)

    千次阅读 2019-09-24 20:17:30
    背景:当交换机与交换机,服务器与服务器,交换机和服务器之间有的时候中间带宽会存在不足的情况-----链路聚合或者链路捆绑。 因为当我们在交换机与交换机增加线路时会出现环路,默认情况下CISCO启用了STP技术(会...
  • M-LAG(跨设备链路聚合配置命令

    千次阅读 2020-12-24 14:55:14
    # 查看M-LAG发生故障的原因。... 表7-34 display m-lag troubleshooting命令输出信息描述项目 描述 Total M-LAG出现故障的次数。 Seq 序号。 Time M-LAG出现故障的时间。 Event Description M-LAG出现故障的原因。
  • 链路聚合LACP配置与结果验证

    千次阅读 2020-09-09 14:50:33
    SWA中F0/1-2端口做聚合: 此时我们会看到端口两个协议lacp与pagp,pagp是端口汇聚协议,是思科私有的。lacp是链路汇集控制协议,IEEE标准的。 此时交换机A的1口2口做成了channel group 1,通道组1. 根据如上配置,...
  • 链路聚合笔记

    2020-12-30 20:31:25
    链路聚合:通过多条以太网物理链路捆绑在一起成为一条逻辑链路,从而增加链路带宽的目的,提高链路的可靠性链路聚合两种类型二层聚合组/二层聚合接口:Bridge-aggregation interface,BAGG三层聚合组/三层聚合接口:...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,274
精华内容 909
关键字:

链路聚合配置命令cisco