精华内容
下载资源
问答
  • NULL 博文链接:https://ligaosong.iteye.com/blog/1750085
  • 1、将高版本jdk安装包上传至服务器并解压 2、编辑/etc/profile中jdk配置的环境变量信息,并保存。执行source etc/profile使修改生效。 3、进入weblogic安装域中,并编辑修改setDomainEnv.sh中关于jdk的配置 4、...

    1、将高版本的jdk安装包上传至服务器并解压

    2、编辑/etc/profile中jdk配置的环境变量信息,并保存。执行source  etc/profile使修改生效。

    3、进入weblogic安装域中,并编辑修改setDomainEnv.sh中关于jdk的配置

    4、修改完成后重启weblogic即可

    展开全文
  • Linux更换JDK+weblogic更换JDK 全局更换JDK Linux更换JDK+weblogic更换JDK 全局更换JDK
  • weblogic部署jdk版本问题

    千次阅读 2019-01-04 14:58:42
    做了个最简单的应用部署在weblogic上, weblogicjdk是1.6 的. 然后 临时应用时1.8的jdk. 临时用我就直接部署了. 然后 weblogic 上边安装也没有问题, 可以正常访问. 过了些天. 又需要一个别的静态页面的时候,我加上...

    之前做了一个ca验证的静态页面.
    做了个最简单的应用部署在weblogic上, weblogic的jdk是1.6 的. 然后 临时应用时1.8的jdk.
    临时用我就直接部署了. 然后 weblogic 上边安装也没有问题, 可以正常访问.
    过了些天. 又需要一个别的静态页面的时候,我加上去,然后准备更新上weblogic控制台更新一下应用的时候, 意外情况,weblogic控制台直接挂了.无奈重启weblogic, 然后却发现之前部署的应用的java环境不对,就是jdk了.重新启动不了 .
    最后重新编译了一个应用 … 用 jdk1.6 的环境, 部署上去后, 解决问题.
    总结: 应用的jdk环境需要和web容器的一致. 如果不一致的话, 有可能在不重启weblogic的情况下.直接安装的话可能成功.但是 如果再次重启weblogic 的时候,就会出现问题. 目前表面上就是这样. 至于到低为什么待有时间再研究…

    展开全文
  • 目前jdk版本是java version 1.6.0__24,目前使用的weblogic版本WebLogic Server 版本: 12.1.1.0。现weblogic存在漏洞,计划升级为最新的weblogic,自行下载fmw_12.1.3.0.0_wls.jar,安装过程提示不支持
  • weblogic12.1.1支持Jdk 8么

    2017-01-19 11:51:21
    求问weblogi 12.1.1 最多支持jdk 几?官方文档有说明么?哪位大神指导下?
  • 二、修改属性,指定新的JDK路径三、重启WebLogic。 一、打开安装目录找到setDomainEnv.cmd文件。 JDK配置文件位置: D:\Oracle\Weblogic\user_projects\domains\domain\bin\setDomainEnv.cmd 打开setDomainEnv.cmd...

    一、打开安装目录找到setDomainEnv.cmd文件。

    JDK配置文件位置:

    D:\Oracle\Weblogic\user_projects\domains\domain\bin\setDomainEnv.cmd
    

    打开setDomainEnv.cmd文件。

    二、修改属性,指定新的JDK路径

    修改位置大概在41行和54行左右。
    图片上JDK版本为1.6。
    配置JDK的文件
    修改后JDK版本为1.8。将41的set SUN_JAVA_HOME和54行的JAVA_HOME属性值修改为新的JDK路径。
    指定到JDK根目录就可以,不用到JDK下的bin目录。

     set SUN_JAVA_HOME=D:\JDK\jdk1.8
     JAVA_HOME= D:\JDK\jdk1.8
    

    修改后:
    在这里插入图片描述

    三、重启WebLogic。

    修改JDK路径后,需要重启WebLogic才能生效。
    重启WebLogic

    展开全文
  • jdk1.8+weblogic12.2.1.4.0

    2020-09-15 23:49:02
    压缩包中含有jdk-8u231-linux-x64.tar.gz+fmw_12.2.1.4.0_wls.jar,适用于linux上搭建weblogic中间件
  • weblogic 12c的JDK问题

    千次阅读 2018-06-09 11:53:28
    ..............................\user_projects\domains\base_domain\bin下的setDomainEnv.cmd里面的JDK路径被修改后没有启动新指定的JDK,因为卸载weblogic 12c 需要的还是原来的JDK,说明还有其他地方需要设置JDK...

    ..............................\user_projects\domains\base_domain\bin下的setDomainEnv.cmd里面的JDK路径被修改后没有启动新指定的JDK,因为卸载weblogic 12c 需要的还是原来的JDK,说明还有其他地方需要设置JDK。所以请大家注意。

                                                                                                                                           如有不对的地方,欢迎老哥们指正

    展开全文
  • 现在很多人在使用SSH架构(Spring, Struts, Hibernate)开发, Tomcat 上开发完了...首先是JDK支持问题, Tomcat 5.0 开始都支持 Java 5和 Java EE 5, 但 WebLogic 8 只支持 JDK 1.4, J2EE 1.3; WebLogic 9 之后才能支持...
  • weblogic修改jdk版本遇到的问题与解决方法
  • 修改Weblogic jdk版本

    千次阅读 2018-01-22 10:02:52
    1、E:\develop-tools\toolsInstall\weblogic是我的weblogic安装目录 2、E:\develop-tools\toolsInstall\weblogic\user_projects\domains\base_domain是我的域创建目录 找到E:\develop-tools\toolsInstall\weblogic...
  • linux安装weblogic对应jdk版本问题

    千次阅读 2018-05-22 10:58:26
    前段时间去另一个项目组帮忙,需要搭建weblogic环境来给我的webservice提供服务,一开始手头没有linux环境...当时Linux服务器用的是jdk1.6,于是抱着试一试的心态从第三方平台又下载了weblogic11g(10.3.6)的安装包...
  • WebLogic Server 10.3.6.0 更改jdk版本

    千次阅读 2018-10-30 14:59:45
    基础环境 OS:Red Hat Enterprise Linux Server release 7.3 (Maipo)weblogic :name="WebLogic Server" version="10.3.6.0" weblogic原来java 版本: [weblogic@prod04 jvm]$ ./java-1.7.0-openjdk-1.7....
  • 如何修改weblogicJDK版本

    万次阅读 2016-10-11 23:15:31
    如何修改WEBLOGICJDK版本 说明: 1.D:\bea为笔者weblogic安装目录 2.D:\bea\user_projects\domains\base_domain为笔者域创建目录 3.我是用方法3处理好的 方法1: 修改文件:D:\bea\wlserver_10.3\common\bin\commEnv....
  • 我用的是1.6,没反应,安装完成后点什么都没反应,卸载都不行!是不是版本太低?
  • Weblogic升级JDK

    2021-01-27 16:52:44
    Weblogic升级JDK 背景: Weblogic远程代码执行漏洞(CVE-2021-2109)... 升级Weblogic运行环境的JDK版本,具体参考如下 升级方法(路径根据实际情况修改): 1)修改 ./Oracle/Middleware/user_projects/domains...
  • weblogic各个版本JDK和Spring的支持

    万次阅读 2012-10-09 10:49:35
    现在很多人在使用SSH架构(Spring, Struts, Hibernate)开发, Tomcat 上开发完了, 认为往...首先是JDK支持问题, Tomcat 5.0 开始都支持 Java 5和 Java EE 5, 但 WebLogic 8 只支持 JDK 1.4, J2EE 1.3; WebLogic 9 之后
  • jdkweblogic安装配置

    2018-10-19 11:28:53
    详细介绍了jdkweblogic安装配置步骤,每一步均有图片说明
  • Weblogic】更改域内jdk版本

    千次阅读 2019-05-15 16:46:34
    weblogic安装后,新建域时如果已经选择了默认jdk版本,可以通过配置文件进行修改, 搜索看到有三种,这里只说一种,我尝试了可以的 修改 启动文件 user_projects/domains/base_domain/bin/startWebLogic.sh 如下,...
  • 修改weblogicjdk版本

    万次阅读 2015-10-14 19:03:38
    打开安装目录下的setDomainEnv.cmd 修改JAVA_HOME为需要修改的路径
  • 如何修改weblogicjdk版本

    千次阅读 2018-02-01 16:53:11
    1.D:\bea为笔者weblogic安装目录 2.D:\bea\user_projects\domains\base_domain为笔者域创建目录 方法1: 修改文件:D:\bea\wlserver_10.3\common\bin\commEnv.cmd 修改如下行: @rem Reset JAVA Home set JAVA_...
  • 修改Linux上Weblogic使用的jdk $JAVA_HOME/jre/lib/security/java.security 文件  将securerandom.source=file:/dev/urandom 修改为  securerandom.source=file:/dev/./urandom  这样可以解决任何一个域...
  • 今天在给客户安装升级域时,使用以下方法 修改C:\Oracle\Middleware\user_...无果,启动时cmd窗口显示依然是原来1.6的版本 再次修改了C:\Oracle\Middleware\wlserver_10.3\common\bin\commEnv.cmd 执行startweblog...
  • WebLogic 10.3.6与JDK 1.7的兼容问题

    千次阅读 2017-08-24 08:58:22
    最近将weblogic(wlserver_10.3)装在jdk1.7上面发现之前的应用不能够deploy上去了,老是报错java.lang.ClassCastException: weblogic.wsee.jaxws.spi.WLSEndpoint cannot be cast to org.apache.cxf.jaxws....
  • weblogic JDK升级

    2020-06-28 19:50:53
    安装新版JDK cd /usr/local/ tar -zxvf jdk1.8.0_251.tar.gz 修改配置文件 # 编辑文件 # /home/weblogic/Oracle/Middleware/Oracle_Home/user_projects weblogic的安装目录 # /domains/base_domain/ 域的目录 vi /...
  • WebLogic 11gR1修改jdk版本

    千次阅读 2017-10-09 10:18:23
    WebLogic 11gR1默认是支持jdk1.6的 我们可以进入到E:\weblogic\user_projects\domains\base_domain\bin中的修改setDomainEnv.cmd文件 修改完毕重启即可
  • weblogic8不支持jdk1.4以上版本

    千次阅读 2010-11-26 09:25:00
    最近开发程序用到泛型,部署的时候发现报错如下 8967743,name=WebRoot,context-path=)] Servlet failed with Exception weblogic.servlet.jsp.JspException: (line 4): class 'me.ws.Sxcx' could not be loaded ...
  • weblogic12.1.3.0.0 是 12c支持JDK1.7的最高版本。(本次安装) weblogic12.2.1.3.0 只支持JDK1.8以上版本。 下载 JDK1.7下载地址(本次安装) JDK1.8下载地址 weblogic版本下载地址 一、安装JDK1.7 如果是虚拟机...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 26,497
精华内容 10,598
关键字:

weblogic14支持的jdk版本