精华内容
下载资源
问答
  • 2020-12-20 00:22:41

    华为交换机链路聚合命令

    配置链路聚合

    1、创建聚合组

    sys

    interface eth-trunk 2

    2、配置聚合模式为手工模式

    interface eth-trunk 2

    mode manual load-balance 表示手工模式

    mode lacp   lacp模式,可以自动检测链路是否错误;

    3、将接口成员加入聚合组

    interface eth-trunk 2

    trunkport g1/0/1 to 1/0/3 mode { active | passive }

    或者进到接口模式下:

    interface g1/0/1

    eth-trunk 2 mode { active | passive }

    注意:

    一个以太网接口只能加入到一个Eth-Trunk接口;

    当成员接口加入Eth-Trunk后,学习MAC地址或ARP地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习;

    删除聚合组时需要先删除聚合组中的成员接口

    4、配置链路聚合的负载分担方式(可选)

    Eth-Trunk的负载分担是逐流进行的,逐流负载分担能保证包的顺序,保证了同一数据

    流的帧在同一条物理链路转发。而不同数据流在不同的物理链路上转发从而实现分担负载;

    可以配置普通负载分担模式,基于报文的IP地址或MAC地址来分担负载;

    由于负载分担只对出方向的流量有效,因此链路两端接口的负载分担模式可以不一致,两端互不影响;

    配置普通负载分担方式:

    interface eth-trunk 2

    <
    更多相关内容
  • 华为交换机端口聚合使用实例,华为交换机命令配置使用
  • 一、服务器环境和交换机环境 1、服务器 ubuntu18 4.15.0-159-generic 2、交换机 Huawei Versatile Routing Platform Software VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600) Copyright (C) 2000-...

    一、服务器环境和交换机环境

    1、服务器

    ubuntu18  4.15.0-159-generic  

    2、交换机

    Huawei Versatile Routing Platform Software
    VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600)
    Copyright (C) 2000-2016 HUAWEI TECH CO., LTD
    HUAWEI S5720S-28P-SI-AC Routing Switch uptime is 0 week, 1 day, 5 hours, 8 minutes

    3、网卡绑定的作用

    • 当一个网卡不够用的时候,可以使用两个网卡绑定在一起增加带宽
    • 当一个网卡断的话,另一个网卡可以形成备份,增加链路冗余
    • 主备模式只能做成链路备份,不能负载,负载需要服务器和交换机互相配合

    4、bond 的七种模式

    每种模式的特点可以参考(Linux----bond技术及mode模式详解_weixin_45726050的博客-CSDN博客

    这七种模式分别是:
    802.3ad balance-alb balance-tlb broadcast active-backup balance-rr balance-xor

    mode=0 round-robin轮询策略(Round-robin policy)
    mode=1 active-backup主备策略(Active-backup policy)
    mode=2 load balancing (xor)异或策略(XOR policy)
    mode=3 fault-tolerance (broadcast)广播策略(Broadcast policy)
    mode=4 lacp IEEE 802.3ad 动态链路聚合(IEEE 802.3ad Dynamic link aggregation) #我这边使用是这种模式
    mode=5 transmit load balancing适配器传输负载均衡(Adaptive transmit load balancing)
    mode=6 adaptive load balancing适配器负载均衡(Adaptive load balancing)

    二、服务器配置

    1、查看有没有bonding kernel module,一般ubuntu18,默认就有的。

    modinfo bonding | head -n 3

    filename: /lib/modules/4.15.0-159-generic/kernel/drivers/net/bonding/bonding.ko
    author: Thomas Davis, tadavis@lbl.gov and many others
    description: Ethernet Channel Bonding Driver, v3.7.1

    2、网络配置

    vim /etc/network/interfaces

    # interfaces(5) file used by ifup(8) and ifdown(8)

    auto lo

    iface lo inet loopback

    auto eno1

    iface eno1 inet manual

    bond-master bond0

    bond-primary eno1

    bond-mode 4

    auto eno2

    iface eno2 inet manual

    bond-master bond0

    bond-primary eno2

    bond-mode 4

    auto bond0

    iface bond0 inet static

    address 192.168.10.113

    netmask 255.255.255.0

    gateway 192.168.10.254

    slaves eno1 eno2

    bond-mode 4

    bond-miimon 100

    bond-downdelay 200

    bond-updelay 200

    3、重启网卡

    #/etc/init.d/networking restart

    4、查看bonding状态

    #cat /proc/net/bonding/bond0

    Ethernet Channel Bonding Driver: v3.7.1 (April 272011)

    Bonding Mode: IEEE 802.3ad Dynamic link aggregation

    Transmit Hash Policy: layer2 (0)

    MII Status: up

    MII Polling Interval (ms): 100

    Up Delay (ms): 200

    Down Delay (ms): 200

    802.3ad info

    LACP rate: slow

    Min links: 0

    Aggregator selection policy (ad_select): stable

    System priority: 65535

    System MAC address: ac:1f:6b:e1:d6:05

    Active Aggregator Info:

            Aggregator ID: 1

            Number of ports: 2

            Actor Key: 9

            Partner Key: 561

            Partner Mac Address: e8:68:19:c9:7d:60

    Slave Interface: eno2

    MII Status: up

    Speed: 1000 Mbps

    Duplex: full

    Link Failure Count: 0

    Permanent HW addr: ac:1f:6b:e1:d6:05

    Slave queue ID: 0

    Aggregator ID: 1

    Actor Churn State: none

    Partner Churn State: none

    Actor Churned Count: 0

    Partner Churned Count: 0

    details actor lacp pdu:

        system priority: 65535

        system mac address: ac:1f:6b:e1:d6:05

        port key: 9

        port priority: 255

        port number: 1

        port state: 61

    details partner lacp pdu:

        system priority: 32768

        system mac address: e8:68:19:c9:7d:60

        oper key: 561

        port priority: 32768

        port number: 2

        port state: 61

    Slave Interface: eno1

    MII Status: up

    Speed: 1000 Mbps

    Duplex: full

    Link Failure Count: 0

    Permanent HW addr: ac:1f:6b:e1:d6:04

    Slave queue ID: 0

    Aggregator ID: 1

    Actor Churn State: none

    Partner Churn State: none

    Actor Churned Count: 0

    Partner Churned Count: 0

    details actor lacp pdu:

        system priority: 65535

        system mac address: ac:1f:6b:e1:d6:05

        port key: 9

        port priority: 255

        port number: 2

        port state: 61

    details partner lacp pdu:

        system priority: 32768

        system mac address: e8:68:19:c9:7d:60

        oper key: 561

        port priority: 32768

        port number: 1

        port state: 61

    三、交换机配置


    1、首先进入system-view 进入以太网端口视图

    >system-view

    #进入聚合口trunk2
    interface Eth-Trunk2

    #配置为接入模式
    port link-type access 

    # 放行vlan,如果用的是默认的vlan1,那可以不需要执行
    port default vlan ID

    #模式
    mode lacp 

    #流量分流算法模式,总共有6总,常用的是src-dst-ip
    load-balance src-dst-ip

    #配置之后可以 dis this 查看一下配置

    display this
    #
    interface Eth-Trunk2
    port link-type access
    port default vlan 192
    mode lacp
    #


    ** 注意:
    加入聚合之前请删除端口中的配置**

    undo eth-trunk
    undo link-type

    2、配置聚合端口信息

    # 进入g 1/0/19 端口

    interface GigabitEthernet1/0/19

    #** 加入trunk2**
    eth-trunk 2


    #跟上面一样进入另一个端口加入聚合

    #进入g 2/0/2 端口
    interface GigabitEthernet2/0/20

    #加入trunk2
    eth-trunk 2

    查询: dis interface Eth-Trunk 查看所有聚合表

    display interface Eth-Trunk

    Eth-Trunk2 current state : UP

    Line protocol current state : UP

    Description:

    Switch Port, Link-type : access(configured),

    PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 2G, Current BW: 2G, The Maximum Frame Length is 9216

    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is e868-19c9-7d60

    Current system time: 2021-10-12 12:52:24

    Last 300 seconds input rate 6984 bits/sec, 6 packets/sec

    Last 300 seconds output rate 19608 bits/sec, 12 packets/sec

    Input:  24351 packets, 2528598 bytes

      Unicast:                      23372,  Multicast:                         372

      Broadcast:                      607,  Jumbo:                               0

      Discard:                          0,  Pause:                               0

      Frames:                           0

      Total Error:                      0

      CRC:                              0,  Giants:                              0

      Runts:                            0,  DropEvents:                          0

      Alignments:                       0,  Symbols:                             0

      Ignoreds:                         0

    Output:  39962 packets, 5490082 bytes

      Unicast:                      23702,  Multicast:                       10219

      Broadcast:                     6041,  Jumbo:                               0

      Discard:                          0,  Pause:                               0

      Total Error:                      0

      Collisions:                       0,  Late Collisions:                     0

      Deferreds:                        0

        Input bandwidth utilization  :    0%

        Output bandwidth utilization :    0%

    -----------------------------------------------------

    PortName                      Status      Weight

    -----------------------------------------------------

    GigabitEthernet0/0/20         UP          1

    GigabitEthernet0/0/19         UP          1

    -----------------------------------------------------

    The Number of Ports in Trunk : 2

    The Number of UP Ports in Trunk : 2

    四、验证

    验证的方式较为简单,两个网卡同时插上网线,并连接到交换机上,断掉其中任何一个,不影响使用。

    展开全文
  • 华为交换机端口聚合(☆亲测)

    万次阅读 2021-07-11 12:53:20
    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生 2.优点 2.1增加冗余链路:...

    1.含义

    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生

    2.优点

    2.1增加冗余链路:只要组内不是所有的端口都down掉,两个交换机之间仍然可以继续通信。

    2.2增加带宽:带宽相当于组成组的端口的带宽总和。

    2.3负载均衡:可以在组内的端口上配置,使流量可以在这些端口上自动进行负载均衡。

    3. 汇聚类型

    3.1人为配置

    手工聚合和静态lacp聚合都是人为配置的聚合组,不允许系统自动添加或删除手工或静态聚合端口。手工或静态聚合组必须包含至少一个端口,当聚合组只有一个端口时,只能通过删除聚合组的方式将该端口从聚合组中删除。手工聚合端口的lacp协议为关闭状态,禁止用户使能手工聚合端口的lacp协议。静态聚合端口的lacp协议为使能状态,当一个静态聚合组被删除时,其成员端口将形成一个或多个动态lacp聚合,并保持lacp使能。禁止用户关闭静态聚合端口的lacp协议。

    在手工聚合组中,端口因存在硬件限制(如不能跨板聚合)无法聚合在一起,而无法与处于selected状态的最小端口聚合的端口将处于standby状态。

    在静态聚合组中,系统按照原则设置端口处于selected或者standby状态:与处于selected状态的最小端口所连接的对端设备不同,或者连接的是同一个对端设备但端口在不同的聚合组内的端口将处于standby状态。与处于selected状态的最小端口的基本配置不同的端口将处于standby状态。

    3.2动态聚合

    动态lacp聚合是一种系统自动创建/删除的聚合,不允许用户增加或删除动态lacp聚合中的成员端口,即使只有一个端口也可以创建动态聚合,此时为单端口聚合。动态聚合端口的lacp协议为使能状态。

    4.简单配置

    以下只列出了设备A 的配置,设备 B 上应作相应的配置,汇聚才能实际有效:

    (1) 采用手工聚合方式(华为交换机的端口聚合,与Cisco有不同之处)

    # 创建汇聚组1

    [Quidway] link-aggregation group 1 mode manual

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/3] port link-aggregation group 1

    # 当聚合组端口序号连续时,可以直接把多个端口聚成一组,组号由系统自行分配。

    [Quidway] link-aggregation ethernet2/1/1 to ethernet2/1/3 both

    (2) 采用静态LACP 聚合方式

    # 创建静态汇聚组1

    [Quidway] link-aggregation group 1 mode static

    # 将以太网端口Ethernet2/1/1 Ethernet2/1/3 加入聚合组1

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/1] port link-aggregation group 1

    [Quidway-Ethernet2/1/1] interface ethernet2/1/2

    [Quidway-Ethernet2/1/2] port link-aggregation group 1

    (3) 采用动态LACP 聚合方式

    # 开启以太网端口Ethernet2/1/1 Ethernet2/1/3 LACP 协议。

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/1] lacp enable

    [Quidway-Ethernet2/1/2] interface ethernet2/1/2

    [Quidway-Ethernet2/1/2] lacp enable

    [Quidway-Ethernet2/1/2] interface ethernet2/1/3

    [Quidway-Ethernet2/1/3] lacp enable

    只有端口的基本配置、速率、双工等参数一致时,上述端口在开启LACP 协议之后

    才能聚合到同一个动态聚合组内,实现端口的负载分担。

    展开全文
  • 华为交换机设置端口聚合的方法

    万次阅读 2014-11-19 15:09:11
     首先为什么要设置交换机端口聚合呢,因为网口绑定的话可以提高带宽,负载均衡,提高稳定性,好处多多,绑定的模式有Mode0-6这7种,有些是不需要交换机支持的,比如mode6,这些模式在主机设置几个配置文件就行了,...

           《网口绑定的方法》一文中已经介绍了交换机设置端口聚合的方法了,但是不同的交换机设置的方法不同,准确来说,原理是一样的,就是命令大同小异啦。今天又体验了一把华为交换机设置端口绑定的方法。

            首先为什么要设置交换机端口聚合呢,因为网口绑定的话可以提高带宽,负载均衡,提高稳定性,好处多多,绑定的模式有Mode0-6这7种,有些是不需要交换机支持的,比如mode6,这些模式在主机设置几个配置文件就行了,没交换机什么事儿, 《网口绑定的方法》中也有说方法,但是有一些是需要在交换机做设置的,比如Mode0,mode4等。

            下面来讲怎么设置交换机了,首先你要知道交换机上的众多端口那个连接的是哪个主机,你才能知道要绑定哪两个端口。下图是我的环境的示意图:

            

            各自中的标记是“主机号-网口号”,同一个主机两个网口连接的两个端口就是我们需要绑定的啦,我一共需要设置6台,这里以55举例。

            怎么知道这些端口在交换机内部怎么编号的呢:

            #sys #进入system模式

            #dis interface Ethernet brief

            

            显示各个端口的情况,有12个up的端口就是上图对应的12个端口了,再拔掉55-1和55-2的网线,有两个端口的状态从up变成dwon了,我们就知道这两个对应的是55的端口,需要绑定在一起。  

            

            上图是我的6台主机对应的交换机内部的端口标示号,以55为例,这时我们只要0/0/6和0/0/14是要绑定在一起的。

            interface Eth-Trunk1 设置聚合组的名称

            description 55            描述这个端口是主机55的

            interface XGigabitEthernet0/0/6       进入0/0/6这个端口

            eth-trunk 1                   把它加入到聚合组1中

            quit

             interface XGigabitEthernet0/0/14       进入0/0/14这个端口

             eth-trunk 1                   把它加入到聚合组1中

            quit

            这样就设置完一个了,display eth-trunk这个命令可以查看当前trunk的状态,如下图所示:

                   



    展开全文
  • 端口聚合介绍: TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立...
  • 我们知道端口聚合能够提高链路的带宽和增加冗余性,目前华为设备负载分担有三种模式,分别是手工负载分担链路聚合和LACP模式链路聚合以及动态LACP聚合。手工负载分担模式链路聚合手工负载分担模式下,Eth-Trunk的...
  • 2.5.1配置手工负载分担模式链路聚合示例2.5.2配置静态LACP 模式链路聚合示例2.5.1配置手工负载分担模式链路聚合示例2 LACP 配置组网需求如图2-4 所示,S-switch-A和S-switch-B为两台S-switch设备,它们之间的链路为...
  • # 将以太网端口Ethernet2/0/1至Ethernet2/0/3加入聚合组1。[DeviceA] interface ethernet 2/0/1[DeviceA-Ethernet2/0/1] port link-aggregation group 1[DeviceA-Ethernet2/0/1] interface ethernet 2/0/2[DeviceA-...
  • 介绍了华为交换机的链路聚合方法
  • 华为交换机端口链路聚合命令详解

    千次阅读 2021-02-24 10:55:15
  • 华为交换机端口速率

    千次阅读 2020-12-20 14:19:56
    看懂用好华为交换机端口信息在遇见下面这样情况的时候一般大家会采取何种方法去判断? 1、交换机某一端口下的用户出现丢包 2、交换机下所有用户都在丢包 3、用户......来源: /sosofa/blog/item/7a595ccf270e503bf9dc...
  • 在Sw1和Sw2上的G0/0/1-G0/0/2端口设置链路聚合,编号为1 负载分担方式为dst-ip方式 3、Sw1配置 进入系统视图:system-view 修改设备名字:[Huawei]sysname Sw1 进入Eth-trunk接口:[Sw1]int Et
  • 华为交换机常见链路聚合操作 将接口批量加入聚合组 [HUAWEI] interface eth-trunk 1 [HUAWEI-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/5 将指定接口从聚合组中删除 [HUAWEI] interface eth-trunk 1 ...
  • 华为交换机链路聚合配置命令

    千次阅读 2020-12-20 00:23:58
    手工负载分担模式链路聚合介绍了手工负载分担模式链路聚合配置场景、step及注意事项。1.1.1 建立配置任务1.1.2 创建Eth-Trunk1.1.3 (可选)配置Eth-Trunk 工作模式为手工负载分担模式1.1.4 向Eth-Trunk 中加入成员...
  • 华为交换机关闭端口

    千次阅读 2020-12-31 05:03:44
    急)这里交换机是通过动作来保护非法接入,比如:当一台交换机端口进行mac绑定后,则只允许该mac的PC上网,如果发现其他的mac出现在这个端口上,交换机会认为这个端口被非法接入了,这时就会执行了设置好的一个安全...
  • 链路聚合也称为链路绑定,英文名有:Link Aggregation、Link Trunking、Link Bonding. 这里所说的链路聚合技术,针对的都是以太网链路。 基本原理其实就是<流量分担>的原理:多条成员链路共同分担了聚合链路...
  • 华为交换机链路聚合命令
  • 可以按照如下方式进行操作:1、...华为交换机常用命令:1、displaycurrent-configuration显示当前配置2、displayinterfaceGigabitEthernet1/1/4显示接口信息3、displaypacket-filterinterfaceGigabitEthernet1/1/4...
  • 华为汇聚交换机链路聚合配置命令

    千次阅读 2020-12-20 00:23:30
    华为汇聚交换机链路聚合配置命令为了增加带宽和网络连接的安全性,一般汇聚交换机都会具备链路聚合的功能。华为汇聚交换机也不例外,本文主要介绍华为汇聚交换机S6500/S8500、S7800、S9300系列的链路聚合数据配置:...
  • 选择合适的聚合协议,IP三层端口绑定,扩展链路带宽。
  • 原标题:教大家查看华为交换机端口状态的方法以及命令华为交换机怎么打开端口?登录进交换机,进入系统视图,命令为:system-view。2、进入以太网端口视图,命令格式: interface interface-type interface-number。 ...
  • 查看以太网端口的简要信息,物理端口是否连通,端口是否是全双工,带宽是多少,端口的流入流出的流量百分比。可以排查端口的基本信息,比如有的端口用户网速慢,可以查看该端口的接口速率,是否是全双工状态,是否是...
  • Esxi是否支持华为交换机端口聚合

    千次阅读 2014-10-20 09:36:38
    华为交换机配置中端口聚合称为eth-trunk,是将多个物理端口组合成一个逻辑端口。目地是为了增加带宽、线路冗余各流量负载。工作模式有手工负载分担与LACP两种。 LACP模式是一种利用LACP协议进行聚合参数协商、确定...
  • 学习目标 ·掌握接口速率的配置方法 ·掌握使用手动模式配置链路聚合的方法 ·掌握使用静态LACP模式配置链路聚合的方法 ...·掌握在静态LACP模式下配置接口优先级的方法 ...华为交换机接口默认开启了自协...
  • H3C和华为配置端口聚合的问题

    千次阅读 2022-03-13 15:20:12
    h3c和华为做端口聚合,H3C的需要在端口和全局配置一致,
  • 2 H3C物理端口要保持和聚合组的配置一样,否则聚合端口始终无法UP 华为6880: interface Eth-Trunk10 description test port link-type trunk port trunk allow-pass vlan 51 华三5130: interface Bridge-...
  • 配置端口保护功能,实现主备接口的备份,以保证业务的无中断传输。背景信息现网中,主机一般使用缺省网关与外部网络联系,如果缺省网关出接口发生故障,主机与外部网络的通信将被中断,无法保证业务的正常传输,设备...
  • 查看当前端口配置信息:]dis this1、不同vlan不同网段互通创建vlan[Huawei]vlan batch 10 20配置接口加入vlan[Huawei]interface g0/0/1[Huawei-GigabitEthernet0/0/1]port link-type access[Huawei-GigabitEthernet0...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,177
精华内容 870
关键字:

华为交换机做端口聚合