精华内容
下载资源
问答
  • cisco交换机端口模式

    千次阅读 2012-02-21 08:36:37
    cisco网络中,交换机在局域网中最终稳定状态的接口类型主要有四种:access/ trunk/ multi/ dot1q-tunnel。 1、access: 主要用来接入终端设备,如PC机、服务器、打印服务器等。 2、trunk: 主要用在连接其它...
      
    
    switch mode详解:
    
    cisco网络中,交换机在局域网中最终稳定状态的接口类型主要有四种:access/ trunk/ multi/ dot1q-tunnel。 
      1、access: 主要用来接入终端设备,如PC机、服务器、打印服务器等。
    
      2、trunk: 主要用在连接其它交换机,以便在线路上承载多个vlan。
    
      3、multi: 在一个线路中承载多个vlan,但不像trunk,它不对承载的数据打标签。主要用于接入支持多vlan的服务器或者一些网络分析设备。现在基本不使用此类接口,在cisco的网络设备中,也基本不支持此类接口了。
    
      4、dot1q-tunnel: 用在Q-in-Q隧道配置中。
    
      Cisco网络设备支持动态协商端口的工作状态,这为网络设备的实施提供了一定的方便(但不建议使用动态方式)。cisco动态协商协议从最初的DISL(Cisco私有协议)发展到DTP(公有协议)。根据动态协议的实现方式,Cisco网络设备接口主要分为下面几种模式:
    
      1、switchport mode access: 强制接口成为access接口,并且可以与对方主动进行协商,诱使对方成为access模式。
    
      2、switchport mode dynamic desirable: 主动与对协商成为Trunk接口的可能性,如果邻居接口模式为Trunk/desirable/auto之一,则接口将变成trunk接口工作。如果不能形成trunk模式,则工作在access模式。这种模式是现在交换机的默认模式。
    
      3、switchport mode dynamic auto: 只有邻居交换机主动与自己协商时才会变成Trunk接口,所以它是一种被动模式,当邻居接口为Trunk/desirable之一时,才会成为Trunk。如果不能形成trunk模式,则工作在access模式。
    
      4、switchport mode trunk: 强制接口成为Trunk接口,并且主动诱使对方成为Trunk模式,所以当邻居交换机接口为trunk/desirable/auto时会成为Trunk接口。
    
      5、switchport nonegotiate: 严格的说,这不算是种接口模式,它的作用只是阻止交换机接口发出DTP数据包,它必须与switchport mode trunk或者switchport mode access一起使用。
    
      6、switchport mode dot1q-tunnel: 配置交换机接口为隧道接口(非Trunk),以便与用户交换机的Trunk接口形成不对称链路。
    展开全文
  • 交换机用户模式、特权模式、全局模式、端口模式

    万次阅读 多人点赞 2019-09-17 17:04:03
    1.用户模式 ... 在用户模式下输入enable(可简写为en)命令就可以进入特权模式,用户在该模式下可以查看并修改Cisco设备的配置。  Switch>en  Switch# 3.全局配置模式  在特权模式下输入con...

    1.用户模式



      交换机启动完成后按下Enter键,首先进入的就是用户模式,在些用户模式下用户将受到极大的限制,只能用来查看一些统计信息。

      Switch>
    2.特权模式

      在用户模式下输入enable(可简写为en)命令就可以进入特权模式,用户在该模式下可以查看并修改Cisco设备的配置。

      Switch>en

      Switch#

     3.全局配置模式

      在特权模式下输入config terminal(可简写conf t)命令即可,用户在该模式下可修改交换机的全局配置。如修改主机名。

      Switch#conf t

      Switch(config)#

     4.接口模式

      在全局配置模式下输入interface fastethernet 0/1(可简写int f0/1)就可以进入到接口模式,在这个模式下所做的配置都是针对f0/1这个接口所设定的。如设定IP

      Switch(config)#int f0/1

      Switch(config-if)#

    展开全文
  • 思科交换机设置端口 trunk 模式报错

    千次阅读 2019-11-20 21:02:26
    描述 Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to ...原因分析:因为端口没有还没有封装协议,还是端口自动的协议。所以不能完成配置 解决办法 既然是还没有封装...

    描述

    Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
    

    意思是:拒绝命令:主干封装为“Auto”的接口不能配置为“trunk”模式。
    原因分析:因为端口没有还没有封装协议,还是端口自动的协议。所以不能完成配置
    解决办法
    既然是还没有封装协议,那么封装一个不就ok了么
    比如:

    Switch(config-if)#switch trunk encapsulation dot1q
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#
    
    展开全文
  • 简析交换机三种端口模式

    千次阅读 2020-09-21 10:26:57
    交换机常见的三种端口模式

    环境:华为Ensp模拟器进行实验。
    交换机端口的三种模式

    1. Access
    2. Trunk
    3. Hybrid

    Access接口通常是交换机连接电脑终端的接口,Trunk接口是交换机与交换机之间连接的接口,Hybrid接口说实话我以前都没有怎么听说过这个类型的接口,主要是access和trunk已经足够使用了。直到偶然看到有这么一个接口类型。Hybrid接口可以说是Access+Trunk的集合吧(个人理解,不对请指正)。
    先看下标准的Access和Trunk口在网络上的应用吧。
    拓扑图如下:
    在这里插入图片描述
    配置:SW1(左)

    G0/0/1口配置trunk口
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     
    G0/0/2配置划分Access口到vlan10:
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    
    G0/0/3配置Access划分到vlan20:
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    
    

    配置SW2(右)

    G0/0/1口配置trunk口
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     
    G0/0/2配置划分Access口到vlan10:
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    
    G0/0/3配置Access划分到vlan20:
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    

    两边交换机配置是相似的,然后电脑配置好地址
    PC1
    在这里插入图片描述
    PC2
    在这里插入图片描述
    PC3
    在这里插入图片描述
    PC4
    在这里插入图片描述
    联通性测试:
    PC1 ping PC3,PC2 ping PC4
    在这里插入图片描述

    在这里插入图片描述
    实验结果:交换机通过1口设置Trunk口允许VLAN 10 20 通过,2口,3口分别设置Access口,证明不同交换机同一个VLAN可以通过Trunk实现通信。这个是比较常用的配置。

    下面实验Hybrid口进行实验。
    拓扑图还是差不多,就是都是使用Hybrid接口进行配置
    在这里插入图片描述
    简析:
    交换机通过G0/0/1口;连接,设置为hybrid口,两端默认的pvid保持一致,给vlan 10 vlan 20 打标记,允许通过这段链路。
    交换机连接电脑的接口也配置为hybrid接口,然后配置·对应的pvid,相当于access口划分VLAN,然后还要配置untagged,允许通过的vlan接口。

    SW1配置:

    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    

    SW2配置:

    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    

    交换机配置还是差不多的,就是用不到trunk口和access口。
    测试联通性截图:
    加粗样式
    在这里插入图片描述
    测试都是可以互通的。
    结论:过去都是实验Trunk+Access口来配置交换机和电脑,现在也可以使用Hybrid接口来配置,相对于其他的接口,hybrid更加灵活,兼具两种接口的特性。

    展开全文
  • 交换机三种端口模式

    2014-03-18 17:03:23
    以太网端口有三种链路类型:Access、Hybrid和Trunk。   Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机...
  • 思科端口限速

    2020-07-30 14:29:18
    在全局模式下开启cef Router(config)#ip cef 定义标准或者扩展访问列表(定义一个方向就可以了): Router(config)#access-list 111 permit ip 192.168.1.0 0.0.0.255 any 在限制的端口上进行rate-limit: ...
  • 而trunk又分为两种:1.ISL(思科私有的协议)2.IEEE 802.1Q 公有的协议 而他们是如何实现vlan间在不同的交换机上传输的呢,其实它们是通过在“中继链路(交换机A和交换机B中间相连的那条线)”打标记tag的方式来...
  • 几个基本概念: 1.端口发送指交换机内部往外发送 2.数据帧在交换机内部处理时,均... 交换机三种端口模式Access、Hybrid和Trunk的理解  以太网端口有三种链路类型:Access、Hybrid和Trunk。  Access类型的端...
  • 交换机的端口模式

    千次阅读 2020-06-08 15:40:36
    接口定义 1、Trunk口 Trunk口上可以同时传送多个VLAN的包,一般用于交换机之间的...3、Access口 Access口只能属于1个VLAN,一般用于连接计算机的端口。 4、Tag和Untag tag是指vlan的标签,即vlan的id,用于指名数据.
  • interface GigabitEthernet0/1switchport trunk native vlan 100 (vlan100作为access模式的)switchport trunk allowed vlan 11,100switchport mode trunk 转载于:https://blog.51cto.com/zhanguo1110/1...
  • CISCO端口兼容性

    千次阅读 2018-10-25 12:17:43
    思科端口兼容性 ASR9000 int g 0/1/0/6 transceiver permit pid all --打开端口模块兼容性 另外对于unsupported transceiver,有一个隐藏的命令可以让客户尝试一下看管不管用: e.g.configured hidden command which...
  • Cisco端口安全

    2015-05-13 21:31:03
    端口安全简介什么是端口安全交换机中的端口安全(Port security)功能可以使你限制在端口上使用的MAC地址(称之为“安全MAC地址”)数,允许你阻止未授权MAC地址的访问,其实也就是通常所说的端口与MAC地址绑定。...
  • Cisco 端口安全

    2009-11-15 01:46:38
    思科cisco交换机端口安全配置 你可以使用端口安全特性来约束进入一个端口的访问,基于识别站点的mac地址的方法。当你绑定了mac地址给一个端口,这个口不会转发限制以外的mac地址为源的包。如果你限制安全...
  • 思科端口优化和聚合

    2018-05-02 19:24:17
    1、选择一个端口在对端口进行配置之前,应先选择所要配置的端口端口选择...2、选择多个端口对于 Cisco 2900,Cisco 2950和Cisco 3550交换机,支持使用range关键字,来指定一个端口范围,从而实现选择多个端口,并...
  • cisco端口聚合配置

    千次阅读 2020-04-17 11:05:16
    理解端口聚合基本原理; 掌握一般交换机端口聚合的配置方法; 实验背景 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端...
  • 以太网端口有 3种链路类型:access、trunk、hybird ** Access类型端口:只能属于1个VLAN,一般用于连接计算机端口; Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文, 一般用于交换机与交换机相关...
  • 思科端口安全总结

    2013-12-20 17:00:44
    交换机端口安全总结交换机最常用的对端口安全的理解就是可根据MAC地址来做对网络流量的控制和管理,稍微引申下端口安全,就是可以根据802.1X来控制网络的访问流量。交换机最常用的对端口安全的理解就是可根据MAC地址...
  • 计网|实验二 基于端口模式的VLAN实现 山东大学 软件工程 实验练习
  • 2950与3560交换机进行2端口端口汇聚1)出现故障内容:由于布线的问题,由于资金的问题,一台2950(全是100M端口)交换机,一台3750(全是千兆端口)交换机,2950与3560交换机进行2端口端口汇聚?是否可以?是可以...
  • 用户的网络访问控制方面,最直接、最简单的方法就是配置基于端口的安全模式,不仅Cisco交换机如此,H3C交换机也有类似的功能,而且看起来功能更加强大
  • Cisco思科)路由器端口的配置

    千次阅读 2020-12-14 18:25:52
    Cisco思科)路由器端口的配置 小编都是喜欢借助实验写博客 一、拓扑图 结合图可以知道我们一共有四个网段(四个vlan) 1.vlan 1 ip:192.168.1.0网段 自带的vlan不需要在路由器添加的 2.vlan 2 ip:192.168.2.0...
  • cisco端口排错步骤

    2014-04-08 09:46:18
    1.物理层:在两端用测线查看网线是否有问题,或者水晶头的线序是否做错。...在端口配置模式使用noshutdown。3.应用层:使用showlogging命令查看日志提示,看是否有对于端口down原因的描述。 ...
  • 思科CISCO)交换机端口镜像配置

    千次阅读 2014-06-18 13:34:01
    思科(CISCO)交换机配置镜像(SPAN)端口思科培训机构  Switch(config)# monitor session 1 source interface fastethernet 4/10  Switch(config)# monitor session 1 filter vlan 57  Switch(config)# monitor ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 23,344
精华内容 9,337
关键字:

cisco端口模式