精华内容
下载资源
问答
  • 路由器怎么映射?路由器一开始分配的是动态公网IP地址,或甚至是内网IP地址时该怎么映射?今天我们就来看看路由器端口映射在动态公网和内网IP的教程,需要的朋友可以参考下
  • 汇总中了如何映射在H3C路由器中 对外映射开放端口
  • 华三路由器如何配置端口映射到内网服务器 在工作中常会遇到把内网的某个服务器或设备映射到公网上,方便远程维护管理,这时需要在内网出口的路由器上做端口映射并绑定在WAN口上即可。 如下图,左侧为远端访问区通过...

    华三路由器如何配置端口映射到内网服务器

    在工作中常会遇到把内网的某个服务器或设备映射到公网上,方便远程维护管理,这时需要在内网出口的路由器上做端口映射并绑定在WAN口上即可。

    如下图,左侧为远端访问区通过出口路由器访问互联网,与公司出口的公网地址互通。右侧为公司内网,出口路由器WAN口为固定公网地址,内网为172.16.20.0/24网段。现要求把公司内网交换机管理地址通过端口映射方式映射到公网,使得远程端pc能访问和管理。
    具体拓扑接口和网段如图
    在这里插入图片描述

    一,配置右侧公司出口路由器

    配置路由器接口地址
    [R1]interface GigabitEthernet 0/1
    [R1-GigabitEthernet0/1]ip add
    [R1-GigabitEthernet0/1]ip address 11.11.11.1 24
    [R1-GigabitEthernet0/1]interface GigabitEthernet 0/2
    [R1-GigabitEthernet0/2]ip address 172.16.20.1 24

    配置内网上网的网段
    [R1]acl basic 2000
    [R1-acl-ipv4-basic-2000]rule permit source 172.16.20.0 0.0.0.255
    [R1-acl-ipv4-basic-2000]qu

    绑定acl 2000到路由器出口
    [R1]interface GigabitEthernet 0/1
    [R1-GigabitEthernet0/1]nat outbound 2000

    在路由器端口映射内网交换机

    [R1]interface GigabitEthernet 0/1
    [R1-GigabitEthernet0/1]nat server protocol tcp global 11.11.11.1 64321 inside 172.16.20.2 22 //把交换机的22端口映射为路由器出口11.11.11.1的64321端口。

    二,配置内网交换机
    [SW1]interface vlan 1
    [SW1-Vlan-interface1]ip address 172.16.20.2 24

    开启交换机的ssh远程管理
    [SW1]ssh server enable

    [SW1]public-key local create rsa

    [SW1]public-key local create dsa
    [SW1]local-user admin
    [SW1-luser-manage-admin]password simple admin
    [SW1-luser-manage-admin]service-type ssh
    [SW1-luser-manage-admin]authorization-attribute user-role level-15
    [SW1-luser-manage-admin]qu

    [SW1]user-interface vty 0 4
    [SW1-line-vty0-4]authentication-mode scheme
    [SW1-line-vty0-4]protocol inbound ssh
    [SW1-line-vty0-4]qu

    配置默认路由
    [SW1]ip route-static 0.0.0.0 0 172.16.20.1

    三,配置远程端的路由器
    [R2]interface GigabitEthernet 0/1
    [R2-GigabitEthernet0/1]ip address 11.11.11.2 24

    [R2]interface GigabitEthernet 0/2
    [R2-GigabitEthernet0/2]ip address 192.168.10.1 24

    配置上网
    [R2]acl basic 2000
    [R2-acl-ipv4-basic-2000]rule permit source 192.168.10.0 0.0.0.255
    [R2-acl-ipv4-basic-2000]qu

    [R2]interface GigabitEthernet 0/1
    [R2-GigabitEthernet0/1]nat outbound 2000

    配置默认路由
    [R2]ip route-static 0.0.0.0 0 11.11.11.1

    四,测试效果
    远程端到公司外网可通
    在这里插入图片描述
    Telnet 11.11.11.1 64321端口可通
    在这里插入图片描述
    在这里插入图片描述

    使用工具远程登录
    在这里插入图片描述

    输入用户名和密码,可正常连接上内网交换机进行管理
    在这里插入图片描述
    完成。

    五,对于添加的端口映射如何删除
    使用undo命令即可,

    [R1-GigabitEthernet0/1]undo nat server protocol tcp global current-interface 64321

    查看,已删除端口映射
    在这里插入图片描述

    具体情况根据需要去映射相应的端口还实现不同设备不同服务的远程登录和管理。

    展开全文
  • 本文档详细描述了华3路由器中关于NAT及端口映射的具体配置和操作步骤
  • 内网服务器映射端口到公网实战配置: 内网端口通过内外网网闸映射端口,再通过路由器映射到公网上 拒绝一切理论派
  • 如果你是ADSL、CABLE MODEM或光纤等宽带接入用户,想在网吧或公司内部建一个游戏服务器或WEB服务器,...要想让外面用户访问到服务器,那么你就要在路由器上做一个转发设置,也就是端口映射设置,让用户的请求到了路由器

    如果你是ADSL、CABLE MODEM或光纤等宽带接入用户,想在网吧或公司内部建一个游戏服务器或WEB服务器,并且能够让互联网上的用户访问你的服务器,那么你就会遇到端口映射问题。

    通常情况下,路由器都有防火墙功能,互联网用户只能访问到你的路由器WAN口(接ADSL线口),而访问不到内部服务器。要想让外面用户访问到服务器,那么你就要在路由器上做一个转发设置,也就是端口映射设置,让用户的请求到了路由器后,并能够到达游戏服务器或WEB服务器。这就是端口映射。

    目前,所有的宽带路由器都有端口映射功能,只是各个路由器厂商所取功能名称不一样,有的叫虚拟服务器,有的叫NAT设置。。。

    端口映射设置很简单,例如要映射一台IP地址为192.168.1.254的WEB服务器,只需把服务器的IP地址192.168.1.254和TCP端口80填入到路由器的端口映射表中就OK了。

    端口映射功能可以让内部网络中某台机器对外部提供WWW服务,这不是将真IP地址直接转到内部提供WWW服务的主机,如果这样的话,有二个蔽端,一是内部机器不安全,因为除了WWW之外,外部网络可以通过地址转换功能访问到这台机器的所有功能;二是当有多台机器需要提供这种服务时,必须有同样多的IP地址进行转换,从而达不到节省IP地址的目的。端口映射功能是将一台主机的假IP地址映射成一个真IP地址,当用户访问提供映射端口主机的某个端口时,服务器将请求转到内部一主机的提供这种特定服务的主机;利用端口映射功能还可以将一台真IP地址机器的多个端口映射成内部不同机器上的不同端口。 端口映射功能还可以完成一些特定代理功能,比如代理POP,SMTP,TELNET等协议。理论上可以提供六万多个端口的映射,恐怕我们永远都用不完的

    展开全文
  • 做了端口映射后可以这样进得测试 1:ping xxxx.vicp.net(申请的域名)如果能PING通而且不是本机的内部IP就说明解析成功 2:telnet xxxx.vicp.net yy(YY...例:检验SQL SERVER 2000用路由器进行端口映射后,在...

    做了端口映射后可以这样进得测试  
      1:ping   xxxx.vicp.net(申请的域名)如果能PING通而且不是本机的内部IP就说明解析成功  
       
      2:telnet   xxxx.vicp.net   yy(YY表示的是你映射的端口号)如果没有任何提示就能进入一片全黑的状态(CMD方式下),就说明映射成功

      例:检验SQL SERVER 2000用路由器进行端口映射后,在DOS命令提示符下,进行检测:

       telnet 192.168.1.22 1443

    展开全文
  • 华三交换机端口映射命令配置教程

    千次阅读 2020-12-22 17:00:55
    华三交换机端口映射命令配置教程一,用固定的公网ip做映射命令Systemint dialer 0[Quidway-Ethernet3/0] nat server protocol tcp global 200.200.200.1 外网端口 inside 192.168.1.254 内网端口[Quidway-Ethernet3/...

    华三交换机端口映射命令配置教程

    一,用固定的公网ip做映射命令

    System

    int dialer 0

    [Quidway-Ethernet3/0] nat server protocol tcp global 200.200.200.1 外网端口 inside 192.168.1.254 内网端口

    [Quidway-Ethernet3/0] nat server protocol tcp global 200.200.200.1 外网端口 inside 192.168.1.254 内网端口

    【提示】

    1、global后跟公网地址,inside后跟的是私网服务器地址,www和ftp可以改为端口号

    2、内部用户不能使用公网地址来访问内部服务器,必须使用内网地址访问.,如

    192.168.1.0/24网段的用户,不能访问https://200.200.200.1,而只能访问https://192.168.1.254

    二,如果没有固定ip,对于上面命令要作修改,修改如下

    system

    int dialer 0

    nat server pro tcp global current 内网端口 inside 192.168.1.2 外网端口

    删除命令

    在前面加上undo nat server pro tcp global current 内网端口 inside 192.168.1.2 外网端口

    三,display nat all命令用来显示所有的地址转换的配置信息

    【视图】

    任意视图

    【缺省级别】

    1:监控级

    【参数】

    【描述】

    display nat all命令用来显示所有的地址转换的配置信息。

    【举例】

    # 显示所有的关于地址转换的配置信息。

    display nat all

    NAT address-group information:

    There are currently 1 nat address-group(s)

    1 : from 202.110.10.10 to 202.110.10.15

    NAT outbound information:

    There are currently 2 nat outbound rule(s)

    Ethernet1/0: acl(2001) --- NAT address-group(1) [no-pat]

    Ethernet2/0: --- static

    NAT server in private network information:

    There are currently 1 internal server(s)

    Interface:Ethernet1/0, Protocol:6(tcp),

    [global] 202.110.10.10: 8080 [local] 10.110.10.10: 80(www)

    NAT static information:

    There are currently 2 static table(s)

    GlobalAddr InsideAddr Vpn-instance

    192.168.1.111 2.3.4.5 ----

    4.4.4.4 3.3.3.3 ----

    NAT aging-time value information:

    tcp ---- aging-time value is 86400 (seconds)

    udp ---- aging-time value is 300 (seconds)

    icmp ---- aging-time value is 60 (seconds)

    pptp ---- aging-time value is 86400 (seconds)

    dns ---- aging-time value is 60 (seconds)

    tcp-fin ---- aging-time value is 60 (seconds)

    tcp-syn ---- aging-time value is 60 (seconds)

    ftp-ctrl ---- aging-time value is 7200 (seconds)

    ftp-data ---- aging-time value is 300 (seconds)

    NAT log information:

    log enable : enable acl 2000

    flow-begin : enable

    flow-active : 10(minutes)

    表1-5 display nat all命令显示信息描述表

    字段

    描述

    NAT address-group information

    显示NAT地址池信息

    There are currently 1 nat address-group(s)

    存在1条NAT地址池信息

    1 : from 202.110.10.10 to 202.110.10.15

    1号地址池的IP地址范围从202.110.10.10到202.110.10.15

    NAT outbound information:

    显示内部地址和外部地址的转换配置信息

    There are currently 2 nat outbound rule(s)

    存在2条地址转换关联信息

    Ethernet1/0: acl(2001) --- NAT address-group(1) [no-pat]

    在Ethernet1/0配置了1个地址转换关联:ACL规则2001与地址池1关联,进行多对多方式的地址转换;[no-pat]表示不进行端口的转换

    Ethernet2/0: --- static

    在Ethernet1/0配置了静态地址转换

    NAT server in private network information

    显示内部服务器信息

    There are currently 1 internal server(s)

    存在1条内部服务器信息

    Interface:Ethernet1/0, Protocol:6(tcp),

    [global] 202.110.10.10: 8080 [local] 10.110.10.10: 80(www)

    在Ethernet1/0配置了1个内部服务器:使用TCP协议;公网地址是202.110.10.10,端口号为8080;内部地址是10.110.10.10,端口号为80

    NAT static information:

    静态地址转换信息

    There are currently 2 static table(s)

    存在2条静态转换表项

    GlobalAddr

    外部IP地址

    InsideAddr

    内部IP地址

    Vpn-instance

    内部IP地址所属的三层VPN名

    NAT aging-time value information

    显示各个协议的NAT转换有效时间

    tcp ---- aging-time value is 86400 (seconds)

    TCP协议地址转换有效时间为86400秒

    udp ---- aging-time value is 300 (seconds)

    UDP协议地址转换有效时间为300秒

    icmp ---- aging-time value is 60 (seconds)

    ICMP协议地址转换有效时间为60秒

    pptp ---- aging-time value is 86400 (seconds)

    PPTP协议地址转换有效时间为86400秒

    dns ---- aging-time value is 60 (seconds)

    DNS协议地址转换有效时间为60秒

    tcp-fin ---- aging-time value is 60 (seconds)

    TCP 协议fin 或 rst连接地址转换有效时间为60秒

    tcp-syn ---- aging-time value is 60 (seconds)

    TCP 协议syn连接地址转换有效时间为60秒

    ftp-ctrl ---- aging-time value is 7200 (seconds)

    FTP协议控制链路地址转换有效时间为7200秒

    ftp-data ---- aging-time value is 300 (seconds)

    FTP协议数据链路地址转换有效时间300秒

    NAT log information

    log enable : enable acl 2000

    日志使能信息,对匹配acl 2000的数据流做日志记录

    flow-begin : enable

    新建流使能

    flow-active : 10(minutes)

    活跃流的间隔时间为10分钟

    四.区分路由器和防火墙

    在Telnet的设备上输入以下命令:

    disp ver

    Copyright Notice:

    All rights reserved (Feb 22 2008).

    Without the owner's prior written consent, no decompiling

    nor reverse-engineering shall be allowed.

    Huawei Versatile Routing Platform Software

    VRP software, Version 3.40, Feature 1652

    Copyright (c) 1998-2008 Huawei Technologies Co., Ltd. All rights reserved.

    Quidway SecPath //此处如果是SecPath,则为防火墙100F uptime is 0 week, 0 day, 3 hours, 10 minutes

    CPU type: Mips IDT RC32438 266MHz

    256M bytes DDR SDRAM Memory

    16M bytes Flash Memory

    Pcb Version:3.0

    Logic Version:1.0

    BootROM Version:1.17

    [SLOT 0] 4FE (Hardware)3.0, (Driver)2.0, (Cpld)1.0

    [SLOT 1] 3FE (Hardware)3.0, (Driver)2.0, (Cpld)1.0

    dis ver

    Copyright Notice:

    All rights reserved (Jun 14 2005).

    Without the owner's prior written consent, no decompiling

    nor reverse-engineering shall be allowed.

    Huawei-3Com Versatile Routing Platform Software

    VRP(R) software, Version 3.40, Release RT-0011

    Copyright (c) 2003-2005 Hangzhou Huawei-3Com Tech. Co.,Ltd. All rights reserved.

    Copyright (c) 2000-2003 Huawei Tech. Co.,Ltd. All rights reserved.

    Quidway AR28-31//此为路由器,AR28-31为路由器的型号. uptime is 0 week, 0 day, 21 hours, 13 minutes

    CPU type: PowerPC 8245 300MHz

    128M bytes SDRAM Memory

    32M bytes Flash Memory

    128K bytes NvRAM Memory

    Pcb Version:1.0

    Logic Version:1.0

    BootROM Version:9.12

    [SLOT 0] 2FE (Hardware)2.1, (Driver)2.0, (Cpld)0.0

    [SLOT 2] 4E1-F (Hardware)1.0, (Driver)1.0, (Cpld)1.0

    展开全文
  • H3C路由器之NAT+端口映射实战

    千次阅读 2015-02-12 16:30:43
    实践环境就一台H3C路由器外网接Internet,新联通的静态IP接入。内网直联非网管交换机。配置如下:[RouterGate]display current-configuration#sysname RouterGate //路由器的名字cpu-usage cycle 1min#radius scheme...
  • H3C路由器端口映射

    千次阅读 2010-08-29 14:14:57
    华三路由器vlan划分好了,下面该做其他的应用了。公司下面有几个门店,有一套销售软件,门店各有一个sql数据库,总部也有一个数据库,每天门店定时与总部数据库做数据交换。需要把内网里的服务器的端口映射出去,...
  • 关于HBC路由器设置端口映射

    千次阅读 2017-04-06 16:48:00
    关于HBC路由器设置端口映射
  • 该楼层疑似违规已被系统折叠隐藏此楼查看此楼配置如下:麻烦高手给指点#version 5.20, Release 2511P02#sysname H3C#super password level 3 hash cipher $h$6$S*********$ENKYXBOEJTv/w/nqKBv2U1lSmxZVH8gGMWaDs6...
  • 华三路由器双向NAT

    千次阅读 2020-04-17 10:15:36
    注意事项 本例中内网地址向外映射为1.1.1.2这个单独的地址,一般情况广域网互联为30位掩码,所以可以把内网地址映射路由器出口地址 H3C路由器做NAT时,必须把nat server接口与nat outbond接口上的快转功能关闭。...
  • H3C路由器映射端口到外网

    千次阅读 2018-03-01 10:19:00
    登录路由器web管理端 选择高级设置->虚拟服务器->新增虚拟服务器 转载于:https://www.cnblogs.com/biaopei/p/8487128.html
  • H3C华三路由器nat实践

    2021-12-08 21:17:46
    商户client通过双线接入分支机构网络中,R1、R2写静态一对一 outbound nat对商户server IP进行映射(outbound nat映射会产生一条null 0路由,并且null 0路由会通过R1,R2重分发进入ospf进程),sw1上会形成商户IP的...
  • H3C MSR系列路由器典型配置举例(V5)-6W100-MSR系列路由器NAT多实例访问公网典型配置案例 (1)
  • 若您是通过ADSL连接到internet的,某些应用在直接用电脑拨号时可以正常使用,如在线播放、网络游戏、财经软件等,而使用路由器后发现无法使用了,某些情形下,端口映射/触发也能解决。您可以先咨询这些应用程序的...
  • 然后点击“虚拟服务器”选项打32313133353236313431303231363533e58685e5aeb931333365663563开路由器端口映射设置12、在“虚拟服务器”设置选项下,点击:添加 按钮,开始配置路由器端口映射设置23、然后在“外部...
  • 路由器的线路连接到防火墙的WLAN端口,然后将防火墙的LAN端口连接到内部交换机。2进入防火墙web配置页面,配置WLAN ip192.168.1.2网关192.168.1.1 dns61.233.154.33。一般不设置LAN端口。设置IP 192.168.1.3-254...
  • 登录华三路由器 依次点击菜单 “防火墙”--》“NAT”--》“内部服务器” 将看到一个内部服务器转换的列表页面 点击列表页面的的新建然后完善页面提交即可 如下操作: 转载于:...
  • h3c端口映射本地主机或服务器

    万次阅读 2018-06-26 08:28:32
    本地打开网站或服务器记住端口xxx,进入h3c服务器,进入内部服务器做端口映射接口选择 wan口 ,使用当前外部IP,外部端口建议使用高数字端口,内部IP地址为服务器或网站所在的IP地址,内部端口为使用的端口。...
  • 路由器的电线连接到防火墙WLAN端口。然后防火墙LAN端口连接到内部交换机。进入防火墙web配置页面,配置WLAN ip192.168.1.2网关192.168.1.1 dns61.233.154.33。不需要设置LAN端口。内网计算机设置了IP 192.168.1.3-...
  • H3C路由器常用基本配置命令

    千次阅读 2021-01-17 10:13:37
    H3C路由器常用基本配置命令[Quidway]sysname router_name命名路由器(或交换机)[Quidway]delete删除Flash ROM中的配置[Quidway]save将配置写入Flash ROM[Quidway]interface serial 0进入接口配置模式[Quidway]quit...
  • H3C SecPath 防火墙设置之端口映射

    千次阅读 2012-12-20 11:17:14
    端口映射命令及设备查看计算机 2009-03-21 17:15:00 阅读 315 评论 0  字   号:大中小 订阅 一,用固定的公网 ip 做映射命令 System int dialer 0 [Quidway-Ethernet3/0] nat server protocol...
  • 答:nat server pro tcp gl 公网IP 端口 inside 内网IP 端口。 和网关没有关系,要在公网出口上做nat。答:h3cmsr830路由器进入设置界面可以通过以下操作实现:答:1、查看网关,窗口键+R键先输入cmd回车。 2、在...
  • 使得公网侧的用户可以通过V7的MSR路由器的WAN接口+端口号来访问内网的WEB服务器,本案例中,服务器的服务端口为443,服务器内网地址为192.168.1.1,路由器外网地址为56.16.16.16,映射的外网端口为4433。 2、配置...
  • 端口映射与NAT负载均衡

    千次阅读 2018-07-04 11:32:23
    (3)掌握NAT端口映射的配置;(4)掌握基于TCP的NAT负载均衡的配置;(5)掌握NAT均衡负载的测试;4.2 实验原理1.NAT负载均衡的工作原理利用NAT可以将多台相同的服务器映射为单个外网地址,对每次连接请求动态转换...
  • 对于一般的家庭路由器而言,我们是不需要对他进行配置的。因为家庭路由器这一种小型路由器一般都已经了确定的指令去执行。但是对于一些大型路由器而言,配置命令是非常重要的。正是因为有了配置命令的存在,才能够使...

空空如也

空空如也

1 2 3 4 5 ... 15
收藏数 282
精华内容 112
关键字:

华三路由器端口映射