精华内容
下载资源
问答
  • 网络工程师下午试题解析汇总
  • 软考网络工程师下午题知识点汇总

    千次阅读 多人点赞 2020-09-06 21:55:48
    下午题基础知识整理 华为交换机配置基础 1.vlan的配置 2.vlan与trunk配置案例 3.以太网端口有三种链路类型:Access、Hybrid和Trunk 4.Hybrid端口发送数据的处理 5.交换机管理IP的设置 6.MSTP负载均衡的例子 华为...


    去年已经拿到这个证书了,小小整理一下,都比较基础,软考网络工程师下午题的难度最多就到这种程度(配置方面)。 上午题需要的评论回复邮箱,我发PDF过去,这里就不整理了 (狗头偷懒)

    在这里插入图片描述
    建议多刷题(51CTO小程序,每日打卡),该记记该背背。

    华为交换机配置基础

    1.vlan的配置

    华为设备中划分VLAN的方式有:

    • 静态的划分:基于接口
    • 动态划分:基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、Ip地址)。
      其中基于接口划分VLAN,是最简单,最常见的划分方式。
      基于接口划分VLAN指的是根据交换机的接口来划分VLAN。需要网络管理员预先给交换机的每个接口配置不同的PVID即可。

    2.vlan与trunk配置案例

    <HUAWEI> system-view
    [HUAWEl]sysname SwitchA
    SwitchA]vlan batch23//批量创建VLAN2和VLAN3
    [SwitchA]interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1]port link-type access//设置接口类型为access
    [SwitchA-GigabitEthernet1/0/1]port default vlan 2//将接口GE1/0/1加入VLAN2
    [SwitchA-GigabitEthernet1/0/1]quit
    [SwitchA]interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2]portlink-type access
    [SwitchA-GigabitEthernet1/0/2]port default vlan 3//将接口GE1/0/2加入VLAN3
    [SwitchA-GigabitEthernet1/0/2]quit
    [SwitchA-GigabitEthernet1/0/2]interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3]port link-type trunk//设置接口类型为trunk
    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan2 3//允许该接口上透传VLAN2和VLAN3到上层交换机
    YSwitchA-GigabitEthernet1/0/3]quit
    

    3.以太网端口有三种链路类型:Access、Hybrid和Trunk

    • Acces类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    • Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    • Hybrid类型的端口是华为设备中的一种新的端口类型,其特点是可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,既可以用于交换机之间连接,也可以用于连接用户的计算机。

    注意:
    Hybrid端囗和Trunk端囗是有区别的:
    在接收数据时,Hybrid端口和Trunk端口处理方法是一样的,唯一不同之处在发送数据时,Hybrid端口可以允许多个VLAN的报文发送时不打标签,而runk端口只允许缺省VLAN的报文发送时不打标签。
    缺省VLAN:通常Access端口只属于1个VLAN,所以它的缺省VLAN1,无需设置。而Hybrid端口和Trunk端口可以属于多个VLAN,因此需要设置缺省VLANID。缺省情况下,Hybrid端口和Trunk端囗的缺省VLAN为VLAN1所有华为交换机的默认接口类型为hybrid。

    4.Hybrid端口发送数据的处理

    当端口接收到不带VLANTag的报文后,则将报文转发到属于缺省VLAN的端口(如果设置了端囗的缺省VLANID)。当端口发送带有VLAN Tag的报文时,如果该报文的VLANID与端口缺省的VLANID相同,则系统将去掉报文的VLANTag,然后再发送该报文。

    [Switch-Ethernet0/1]interface Ethernet 0/1   \\进入ethernet 0/1接口
    [Switch-Ethernet0/1]port link-type hybrid  \\设置接口类型为hybrid
    [Switch-Ethernet0/1]port hybrid pvid vlan 10  \\接口的PVID是vlan10
    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged  //对VLAN为10、20的报文,剥掉VLAN Tag
    

    5.交换机管理IP的设置

    华为部分设备有Meth接口,一个专门用于带外管理的接口,不能用于业务数据的传输。如果是二层的接入交换机,需求远程管理这台机器,则需要给这台机器配置个管理IP。通过ssh,telnet等的带内管理,通常默认的管理vlan是vlan1,也可以自己设置为其他Vlan。
    下面以s5700为例,介绍使用用Vlan5作为管理Vlan,管理IP地址为192.168.1.1/24的配置、用户可以通过GigabitEthernet 0/0/1的接口连接到Vlanif5.

    <55700>system-view/进入系统视图
    [S5700-vlan5]quit
    [S5700linterface Vlanif5//进入Vlanif5
    [S5700-Vlanifs]Jip address 192.168.1.124//设置Vlanif5网关192.168.1.1掩码255.255.255.0
    [S5700-Vlanif5]quit/退出
    [S5700]interface GigabitEthernet0/0/1	//进入物理端口GE0/0/1
    [S5700-GigabitEthermet0/0/1]port link-type access	//设置端口access模式
    [S5700-GigabitEthermet0/0/1]port default vlan 5	//将此端口划分到Vlan5
    [S5700-GigabitEthemet0/0/1]quit	//退出
    [S5700]aaa
    //进入aaa
    [S5700-aaa]local-user admin passwordcipher 123456//创建用户admin设置密码为123456密码加密方式为cipher
    [55700-aaa]local-user admin privilege level15//设置admin最高权限等级15
    [S5700-aaa]local-user admin service-type telnet ssh//授权admin用户可以使用telnet、ssh
    [S5700-aaa]quit/退出
    [S5700]user-interfacevty04
    [S5700-ui-vtyO-4Jauthentication-mode aaa
    

    6.MSTP负载均衡的例子

    如左图所示,四台交换机都运行MSTP。它们彼此相连形成了一个有冗余链路的环网。为实现接入层交换机上的VLAN2VLAN10和VLAN11
    VLAN20的分别在不同的STP域中,实现流量负载分担:
    因此需要配置两个MSTl,即MSTI1对应Vlan2-
    Vlan10和MSTl2对应Vlan11-20。他们经过MSTP之后,生成的无环路拓扑如图所示。
    在这里插入图片描述

    (1)交换机的MSTP区域配置
    在交换机A上创建一个相同的MST域(域名为RG1)、两个多生树实例MSTl1和MSTl2,然后为Vlan2-10映射到MSTl1,Vlan11-20映射到MSTI2。最后激活MST域配置。

    [SwitchA]stp region-configuration
    [SwitchA-mst-region]region-name RG1
    [SwitchA-mst-region]instance 1 vlan 2 to 10
    [SwitchA-mst-region]instance 2 vlan 11 to 20
    [SwitchA-mst-region]active region-configuration
    [SwitchA-mst-region]quit
    

    注意:因为这4台交换机都在同一个域(域名相同)才能起作用,因此其他三台设备也进行同样的配置。

    (2)配置MSTI1与MSTI2的根桥与备份根桥

    [SwitchA]stp instance 1 root primary	//配置switchA为MSTI1的根桥
    [SwitchA]stp instance 2 root secondary	//配置SwitchA为MSTI2的备份根桥
    [SwitchB]stp instance 1 root secondary	//配置Switch8为MST11的备份根桥
    [SwitchB]stp instance 2 root primary	//配置SwitchB为MSTI2的根桥
    

    (3)分别配置MSTI1和MSTI2中要被阻塞的端口,消除二层环路

    [Switch A-D]stp pathcost-standard legacy	//配置采用华为的私有端口路径开销计算方法,四台设备同样的标准
    
    [SwitchC]interface gigabitethernet 0/0/2
    [SwitchC-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchC-GigabitEthernet0/0/2]quit
    
    [SwitchD]interface gigabitethernet 0/0/2
    [SwitchD-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchD-GigabitEthernet0/0/2]quit
    

    在这里插入图片描述

    (4)在四台交换机上全局使能MSTP,使以上MSTP配置生效,消除二层环路

    [SwitchA]stp enable
    [SwitchB]stp enable
    [SwitchC]stp enable
    [SwitchD]stp enable
    

    (5)将与终端PC相连的端口去使能MSTP

    [SwitchC]interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1]stp disable
    [SwitchC-GigabitEthernet0/0/1]quit
    

    (6)在两个实例对应的根桥设备的指定端口上配置根保护功能

    [SwitchA]interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1]stp root-protection
    [SwitchB]interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1]stp root-protection
    

    (7)最后在各交换机上创建ID号为2~20的共19个VLAN,然后把四台交换机间的直连链路的端口配置为Trunk类型,并允许这19个VLAN通过。把连接PC的链路端口设置为Access类型,加入对应的VLAN

    [SwitchA]vlan batch 2 to 20
    [SwitchA]interface g0/0/1
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    [SwitchA]interface g0/0/2
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    
    dis stp brief
    

    华为路由器配置基础

    路由协议或路由种类相应路由的优先级
    DIRECT0
    OSPF10
    IS-IS15
    STATIC60
    RIP100

    DHCP配置

    DHCP的三种角色
    DHCP组网中,包括以下三种角色:
    DHCP客户端:通过DHCP协议请求获取P地址等网络参数的设备。例如,lP电话、PC、手机、无盘工站等。
    DHCP服务器:负责为DHCP客户端分配网络参数的设备。
    DHCP中继(可选):负责转发DHCP服务器和DHCP客户端之间的DHCP报文,协助DHCP服务器向DHCP客户端动态分配网络参数的设备。

    dhcp relay:dhcp select relay,使能接口的DHCP中继功能(缺省情况下未使能)

    在这里插入图片描述
    (1)使能DHCP服务

    <Huawei>system-view
    [Huawei]sysname Router
    [Router]dhcp enable
    

    (2)配置接口加入VLAN

    #配置Eth2/0/0接口加入VLAN10。
    [Router]vlan batch 10 to 11
    [Router]interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 10
    [Router-Ethernet2/0/0] quit
    

    (3)配置VLANIF11接口地址

    [Router]interface vlanif 11
    [Router-Vlanif11]ip address 10.1.2.1 24
    [Router-Vlanif11]quit
    

    (4)配置接口地址池

    配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。
    [Router]interface vlanif 10
    [Router-Vlanif10]dhcp select interface
    [Router-Vlanif10]dhcp server lease day 30
    [Router-Vlanif10]dhcp server domain-name huawei.com
    [Router-Vlanif10]dhcp server dns-list 10.1.1.2
    [Router-Vlanif10]dhcp server excluded-ip-address 10.1.1.2
    [Router-Vlanif10]dhcp server statuc-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
    

    ACL

    分类编号范围支持的过滤选项
    基本ACL2000~2999匹配条件较少,只能通过源lP地址和时间段来进行流量匹配,在一些只需要进行简单匹配的功能可以使用。
    高级ACL3000~3999匹配条件较为全面,通过源P地址、目的IP地址、To5、时间段、协议类型、优先级、ICMP报文类型和ICMP报文码等多个维度来对进行流量匹配,在大部分功能中都可使用高级ACL来进行精确流量匹配。
    基于MAC地址的ACL4000~4999由于数据链路层使用MAC地址来进行寻址,所以在控制数据链路层帧时需要通过MAC地址来对流量进行分类。基于MAC地址的ACL就可以通过源MAC地址、目的MAC地址、co5、协议码等维度来进行流量匹配。

    ACL规则

    acl number 2004
    rule 0 deny 202.38.0.0 0.0.255.255
    rule 10 permit 202.38.160.0 0.0.0.255
    
    
    配置好的ACL,应用到相应的接口才会生效。
    interface GigabitEthernet 0/0/1
    traffic-filter inbound acl 2004  //在接口上应用ACL,进行报文过滤,某些类型的设备可以使用packet-filter 3000
    
    ACL应用规则
    1.标准访问控制列表,靠近目标网络
    2.高级访问控制列表,靠近源网络
    

    两条规则结合则表示禁止一个大网段(202.38.0.0)上的主机但允许其中的一小部分主机(202.38.160.0)的访问。

    具体:
    acl number 3001
    rule deny source 192.168.2.0 0.0.0.255 destination 192.168.3.0 0.0.0.255

    在这里插入图片描述
    对内网地址192.168.1.12/24访问外网做限制,使其无法访问所有WEB界面

    acl number 3005		//定义用于报文过滤的访问控制
    description deny_source_ip_www
    rule 5 deny tcp source 192.168.1.12 0 destination-port eq www
    rule 10 permit tcp source 192.168.1.12 0
    
    interface g0/0/1
    ip address 192.168.1.2 255.255.255.0
    traffic-filter inbound acl 3005
    

    交换机进行ACL配置应用的例子
    1、先定义ACL

    [Switch]acl 3001   //新建一个高级ACL
    [Switch-acl-adv-3001]rule 5 deny ip source 192.168.5.0 0.0.0.255 destination 192.168.2.0 0.0.0.255   //禁止5网段访问2网段
    [Switch-acl-adv-3001]rule 100 permit ip		//允许访问任何网段
    

    2、配置基于ACL的流分类

    [Switch]traffic classifer tc1	//创建流分类
    [Switch-classifier-tc1]if-match acl 3001	//将ACL与流分类关联
    

    3、配置流行为

    [Switch]traffic behavior tb1	//创建流行为
    [Switch-behavior-tb1]deny	//配置流行为动作为拒绝报文通过
    

    4、配置流策略

    [Switch]traffic policy tp1	//创建流策略
    [Switch-trafficpolicy-tp1]classifier tc1 behavior tb1	//将流分类tc1与流行为tb1关联
    

    5、在接口下应用流策略

    [Switch]interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1]traffic-policy tp1 inbound	//流策略应用在接口入方向
    

    华为防火墙配置

    防火墙

    路由器的安全规则定义再接口上,而防火墙的安全规则定义在安全区域之间
    Local
    Trust
    DMZ
    Untrust

    域间的数据流分两个方向:
    入方向(inbound):数据由低级别的安全区域向高级别的安全区域传输的方向;
    出方向(outbound):数据由高级别的安全区域向低级别的安全区域传输的方向。

    防火墙的安全区域规则:

    • 本域内不同接口间不过滤直接转发
    • 进、出接口相同的报文被丢弃
    • 接口没有加入域之前不能转发包文

    在这里插入图片描述

    配置区域dmz
    [Eudemon]firewall zone name dmz1
    [Eudemon-zone-dmz1]set priority 70
    
    把接口加入到区域中
    把相应的接口加入到相应的区域中去
    配置接口Ethernet 1/0/0加入到防火墙DMZ域
    [Eudemon]firewall zone dmz
    [Eudemon-zone-dmz]add interface ethernet 1/0/0
    

    IP包过滤技术介绍
    对防火墙需要转发的数据包,先获取包头信息,然后和设定的规则进行比较,根据比较的结果对数据包进行转发或者丢弃。而实现包过滤的核心技术是访问控制列表
    五元组:源地址、目的地址、源端口、目的端口、协议号

    在区域间应用访问控制列表
    例子:创建编号为3001的访问控制列表。

    [华为]acl number 3001
    #配置ACL规则,允许特定用户从外部网访问内部服务器。
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.30 destination129.38.1.10
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.20
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.30
    下面的配置是在包过滤应用中引用ACL
    policy interzone trust untrust outbound 
    #将ACL规则3000作用于Trust区域到untrust区域间的出方向。
    [华为-Interzone-trust-untrust]packet-filter 3000 outbound
    #将ACL规则3001作用于Trust区域到Untrust区域间的入方向。
    [华为-Interzone-trust-untrust]packet-filter 3001 inbound
    #在Trust区域和Untrust区域之间使能FTP协议的应用协议检测。
    [华为-Interzone-trust-untrust]detec tftp
    

    Nat Server配置

    Nat Server 里面有 NAT Server配置案例
    内部服务器(Nat Server)功能是使用一个公网地址来代表内部服务器对外地址。在防火墙上,专门为内部的服务器配置一个对外的公网地址来代表私网地址。对于外网用户来说,防火墙上配置的外网地址就是服务器的地址。

    使用NAT可以灵活地添加内部服务器,通过配置内部服务器,可将相应的外部地址、端口等映射到内部的服务器上,提供了外部网络可访问内部服务器的功能。

    配置内部Web和FTP服务器。

    [USG] nat server wwwserver protocol tcp global 202.169.10.1 80 inside 192.168.20.2 8080
    [USG] nat server ftpserver protocol tcp global 202.169.10.1 ftp inside 192.168.20.3 ftp
    

    Easy IP配置

    Easy IP的概念很简单,当进行地址转换时,直接使用接口的公有IP地址作为转换后的源地址。同时它也利用访问控制列表控制哪些内部地址可以地址转换

    应用级网关ALG

    在这里插入图片描述
    NAT ALG实现原理
    配置:
    在系统视图下执行下列命令则使能了相应协议的ALG功能
    nat alg enable {ftp|h323|icmp|ras|qq|msn}

    在域间视图下为应用层协议配置ASPF检测
    firewall interzone trust untrust
    detect ftp 开启ASPF 和 NAT ALG。 这两个的命令是共用的

    双机热备

    防火墙入侵与检测 day04 防火墙双机热备

    在这里插入图片描述
    VGMP组管理

    • 状态一致性管理
      VGMP管理组控制所有的VRRP备份组统一切换。
    • 抢占管理
      当原来出现故障的主设备故障恢复时,其优先级也会恢复,此时可以重新将自己的状态抢占为主。

    HRP基本概念

    • HRP(Huawei Redundancy Protocol)协议,用来将主防火墙关键配置和连接状态等数据向备防火墙上同步。
    • 首包会话快速备份
    • 更新报文会话快速备份

    防火墙双机热备三大协议

    • VRRP 是 主备
    • VGMP 是 状态切换一致性
    • HRP 是 配置会话表的同步

     

    交换机三种端口

    交换机三种端口类型特点:
    以太网端口有三种链路类型:Access、Hybrid和Trunk。
    ■ Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    ■ Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
    ■ Hybrid 端口和Trunk 端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    交换机接口出入数据处理过程:
    ■ Access端口收报文:收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)
    ■ Access端口发报文:将报文的VLAN信息剥离,直接发送出去
    ■ trunk端口收报文:收到一个报文,判断是否有VLAN信息:如果有,判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃;如果没有VLAN信息则打上端口的PVID,并进行交换转发。
    ■ trunk端口发报文:比较将要发送报文的VLAN信息和端口的PVID,如果不相等则直接发送。如果两者相等则剥离VLAN信息,再发送。
    ■ hybrid 端口收报文:收到一个报文,判断是否有VLAN信息:如果有,则判断该hybrid 端口是否允许该VLAN的数据进入(在untagged和tagged列表中的都算允许通过,这个就相当于trunk的allow-pass vlan),如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用);如果没有则打上端口的PVID,并进行交换转发。
    ■ hybrid 端口发报文:1)、判断该VLAN在本端口的属性(disp interface即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)2)、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送.

    [Switch1]vlan 5 //创建 VLAN5 
    [Switch1-vlan5]management-vlan //设备 VLAN5 为管理 VLAN 
    [Switch1-vlan5]quit 
    [Switch1]interface vlanif 5 //创建管理 VLAN 的 VLANIF 接口 
    [Switch1-Vlanif5]ip add 10.10.1.1 24 //配置 VLANIF 接口 IP 地址 
    [Switch1-Vlanif5]quit 
    
    
    [Switch1]telnet server enable //Telnet 默认是关闭的,需要打开 
    [Switch1]user-interface vty 0 4 //开启 VTY 线路模式 
    [Switch1-ui-vty0-4]protocol inbound telnet //配置 Telnet 协议 
    [Switch1-ui-vty0-4]authentication-mode aaa //配置认证方式 
    [Switch1-ui-vty0-4]quit
    
    [Switch1]int g0/0/10
    [Switch1-GigabitEthernet0/0/10]port link-type trunk  //配置上联接口类型(trunk)
    [Switch1-GigabitEthernet0/0/10]port trunk allow-pass vlan all  //允许所有 VLAN 通过
    
    [SW2]interface Ethernet 0/0/2 
    [SW2-Ethernet0/0/2]port link-type access //配置接口类型为 access
    [SW2-Ethernet0/0/2]port default vlan 10 //将接口加入 VLAN10
    [SW2-Ethernet0/0/2]quit
    
    [Huawei-GigabitEthernet0/0/1]port link-type hybrid //配置接口类型为 hybrid 
    [Huawei-GigabitEthernet0/0/1]port hybrid pvid vlan 10 //配置接口的 PVID 
    [Huawei-GigabitEthernet0/0/1]port hybrid untagged vlan 10 30 //配置接口的 untgged vlan
    

    端口
    1.配置POP3服务器时,邮件服务器中默认开放TCP的 (D) 端口。
    A、21
    B、25
    C、53
    D、110
    2.电子邮件应用程序利用POP3协议( D )。
    A. 创建邮件 B. 加密邮件 C. 发送邮件 D. 接收邮件

    FTP服务器使用20和21两个网络端口与FTP客户端进行通信。主动模式下,FTP服务器的21端口用于传输FTP的控制命令,20端口用于传输文件数据

    HTTP:80 Telnet:23
    SNMP消息全部通过UDP端口161接收,只有Trap信息采用UDP端口162。 SNMP用的是无连接的UDP协议
    IMAP4端口 143


    Linux:
    inetd.conf 是 系统超级服务进程inetd的配置文件
    lilo.conf 是 操作系统启动程序LILO的配置文件
    httpd.conf 是 web服务器Apache的配置文件
    resolv.conf是 DNS解析的配置文件

    在Linux操作系统中,与DHCP相关的主要配置文件如下:
    DHCP服务器配置文件 /etc/dhcpd.conf(DHCP服务的主配置文件)
    启动DHCP服务的脚本 /etc/rc.d/ink.d/dhcpd
    执行DHCP服务的程序 /usr/sbin/dhcpd
    记录客户端租用信息的文件 /var/state/dhcpd.leases(保存客户端租约信息的文件)
    重启DNS服务器:service named restart

    对称加密算法:DES、3DES、RC5、IDEA 适用于大量数据加密
    公开密匙(非对称)加密算法:RSA、DSA、ECC 加密速度慢,计算量大,不适合会话通信

    1、OSPF默认的Hello报文发送间隔时间是 4秒,
    Hello用于发现邻居,保证邻居之间keepalive,keepalive,是在TCP中一个可以检测死连接的机制。
    来建立和维护相邻邻居路由器之间的链接关系
    默认的Hello报文的发送间隔是10秒,默认无效时间间隔是Hello时间间隔的 4倍,即如果在40秒内没有从特定的邻居接收到这种分组,路由器就认为那个邻居不存在了。
    Hello组播地址为224.0.0.5
    2、在进行域名解析过程中,当主域名服务器查找不到IP地址时,由(转发域名服务器)负责域名解析
    3、路由器的描述中,路由器的串口之间通常是 点对点连接
    4、OSPF协议把网络划分成 4种区域,其中(存根区域)不接受本地自治系统以外的路由信息,对自治系统以外的目标采用默认路由0.0.0.0
    5、帧中继: 本地管理接口类型:提供面向连接的服务,高效的数据链路技术,充分复用了光纤通信和数字网络技术的优势。
    6、运行OSPF协议的路由器在选举 DR/BDR之前,DR是路由器自身,备份指定路由器(BDR)
    7、内部网关协议(IGP):在同一个自治系统内交换路由信息。IGP的主要目的是发现和计算自治域内的路由信息
    IGP使用的路由协议有:RIP、OSPF、IS-IS

    在这里插入图片描述

    展开全文
  • 软考网络工程师2019下半年下午真题解析,梳理解题思路,重点知识及答题技巧,祝大家早日通过软考网络工程师考试,升职加薪!!!!
  • 2020年下半年网络工程师下午真题及答案

    万次阅读 多人点赞 2020-11-10 16:38:43
    试题一(20分) 某校园宿舍WLAN网络...2020年下半年网络工程师下午答案及解析 试题一(20分) 单击此链接查看真题解析视频https://ke.qq.com/course/261351?tuin=7d818187 问题1(10分) 一、小任老师网...

    试题一(20分)

        某校园宿舍WLAN网络拓扑结构如图1-1所示,数据规划如表1-1内容所示。该网络采用敏捷分布式组网在每个宿舍部署一个APAP连接到中心AP,所有AP和中心AP统一由AC进行集中管理,为每个宿舍提供高质量的WLAN网络覆盖。

     

    2020年下半年网络工程师下午答案及解析

    试题一(20分)   单击此链接查看真题解析视频https://ke.qq.com/course/261351?tuin=7d818187

    问题1(10分)

     

    一、小任老师网络工程师视频教程

    1、网络工程师_基础知识视频 https://edu.51cto.com/course/1187.html

    2、上午历年真题解析视频https://edu.51cto.com/course/4925.html

    3、下午历年真题解析视频 https://edu.51cto.com/course/2017.html

    二、小任老师高级网络规划设计师视频教程

    1、网络规划设计师-综合知识视频精讲 http://edu.51cto.com/course/course_id-1219.html

    2、上午历年真题解析视频http://edu.51cto.com/course/course_id-6081.html

    3、下午案例分析历年真题解析视频 http://edu.51cto.com/course/course_id-1545.html

    4、论文写作技巧精讲视频 http://edu.51cto.com/course/course_id-1792.html

    展开全文
  • 今天距离软考网络工程师只有45天,如何在不足两个月的时间里实现一次自我飞跃,相信是大多备考的朋友比较关注的。 所以今天就给大家分享软考网络工程师学习方法和备考建议和重点知识示例。 备考技巧 考试冲刺时间...

    今天距离软考网络工程师只有45天,如何在不足两个月的时间里实现一次自我飞跃,相信是大多备考的朋友比较关注的。

    所以今天就给大家分享软考网络工程师学习方法和备考建议和重点知识示例。

    备考技巧

    考试冲刺时间至少预留一个半月左右,每天复习时间在两到三个小时。建议固定好学习时间形成一种习惯,推荐晚上9点到11半,周末可适当增加。

    方法推荐:先看纸质版的教材将不懂的地方标出来,接着看相应章节视频,注意听自己存在疑问的知识点(教材都看的懂的朋友就没必要看视频了,看视频是非常耗费时间的)。

    教材每天看50-70页,视频每天看1.5-2小时,花20天左右看完教材及视频。

    好记性不如烂笔头。买个笔记本专门记录知识重点、常见的英文缩写词汇、重点公式等。

    重点知识示例

    数据的表示方法:原码、反码、补码、移码

    最高位为符号位,0表示正数,1表示负数

    正数的原码=正数的补码=正数的反码

    负数的反码:符号位不变,其余位变反。

    负数的补码:符号位不变,其余位变反,最低位加1。

    移码在正负补码的基础上符号位取反。

    英文缩写笔记示例

    FDM:频分多路复用

    TDM:时分多路复用

    WDM:波分多路复用

    CDMA:码分多路复用

    中继器(Repeater) 网桥(Bridge)

    交换机(Switch) 路由器(Router)

    域(Domain)

    ARP(Address Resolution Protocol)地址解析协议

    DNS(Domain Name System)域名系统

    要大家记住一些英文缩写示例是因为题目中会出现,选择题题干出现一个缩写,你要看的懂,才能理解题目到底考什么。

    必备真题

    知识储备完成后,开始做历年真题,认真做好每一套历年真题,不懂的题目看解题分析。

    每天做一套上午或下午历年真题10多年的真题够做一个月了。

    从近年的做起,真题回溯到11年就可以了,之前的由于考点变化,也没有大的价值了。例如,近年考试全是华为的配置,你把精力放到思科的配置上就没啥用处了。

    将经常做错的题目记录下来,方便冲刺的时候重点复习。最后10天做模拟题查缺补漏,翻阅笔记。

    以上,就是给大家分享的软考网工的备考小技巧,大家可以把这些技巧运用到自己的备考复习中去。

    展开全文
  • 软考网络工程师2019上半年下午真题解析,梳理解题思路,重点知识及答题技巧,祝大家早日通过软考网络工程师考试,升职加薪!!!!
  • 系统硬件及设备:主要包括主机服务器及其主要部件、专门的存储设备、网络交换机、路由器,等。监控方法:采用通用或者专用的管理监控工具,通常具有自动监测、跟踪和报警的功能 软件:主要针对其应用性能、软件Bug和...

    企业如何应对用户需求变更

    使用需求变更管理,大概步骤:客户提出需求变更、审核需求变更、客户确认、通知相关人员、监督。

    测试类型

    1. 单元测试需要从程序的内部结构出发设计测试用例。主要采用白盒测试的测试用例,辅之以黑盒测试的测试用例。
    2. 恢复测试将检测系统的容错能力。检测方法是采用各种方法让系统出现故障,检验系统是否能按照要求从故障中恢复过来,并在预定的时间内开始处理事务,而且不对系统造成任何损害。
    3. 增量式测试,把下一个要测试的模块组合到已测试好的模块中,测试完后再将下一个需测试的模块组合进来进行测试,逐步把所有模块组合在一起,并完成测试。

    测试步骤

    单元测试 -> 组装测试 -> 确认测试 -> 系统测试
    首先是单元测试,对源程序中的每一个程序单元进行测试,验证每个模块是否满足系统设计说明书的要求。组装测试是将已测试过的模块组合成子系统,重点测试各模块之间的接口和联系。确认测试是对软件的检验,根据系统分析说明书来考察软件是否满足要求。系统测试是将软件、硬件、网络等系统的各个部分连接起来,对整个系统进行总的功能、性能等方面的测试。
    系统测试的主要内容包括:恢复测试、安全性测试、强度测试、性能测试、可靠性测试、安装测试等


    故障管理即包含了故障监视、故障调研、故障支持和恢复、故障分析定位以及故障终止5项基本活动。

    在故障管理中针对不同监视对象有哪些监视方法

    1. 系统硬件及设备:主要包括主机服务器及其主要部件、专门的存储设备、网络交换机、路由器等。监控方法:采用通用或者专用的管理监控工具,通常具有自动监测、跟踪和报警的功能
    2. 软件:主要针对其应用性能、软件Bug和变更需求。监控方法:采用管理工具,专门的测试工程师负责,使用过程中用户发现提出。变更需求也是在用户使用和监视二合一的过程中发现
    3. 人员:系统操作人员、系统开发工程师、用户、来访者,甚至包括系统所在机房的清洁工和运输公司的职工,等。监控方法:对与系统接触的过程中的行为进行跟踪和记录,防止或者及早发现非标准的操作带来的系统故障或者服务故障。

    不同类型的数据库故障及恢复措施

    1. 事务故障:系统自动恢复。
    2. 系统故障:重启系统后系统自动恢复。
    3. 介质故障:DBA转入最新的数据副本,使数据库恢复到最近一次转储时的一致性状态;日志文件副本;执行系统恢复命令,具体的恢复仍由DBMS完成。

    问题控制目标

    1. 将由IT基础架构中的错误引起的故障和问题对业务的影响降低到最低限度。
    2. 找出出现故障和问题的根本原因,防止再次发生与这些错误有关的故障。
    3. 实施问题预防,在故障发生之前发现和解决有关问题。

    问题控制步骤

    1. 发现和记录问题
    2. 归类问题
    3. 调查和分析问题
    4. 错误控制

    安全审计对数据安全保障的作用

    1. 检测对系统的入侵,对潜在的攻击者起到震慑或警告作用。
    2. 发现计算机的滥用情况,对于已经发生的系统破坏行为提供有效的追纠证据。
    3. 为系统安全管理员提供有价值的系统使用日志,从而帮助系统安全管理员及时发现系统入侵行为或潜在的系统漏洞。
    4. 为系统安全管理员提供系统运行的统计日志,使系统安全管理员能够发现系统性能上的不足或需要改进与加强的地方。

    HTTPS协议在传输过程中如何保障数据安全

    1. 内容加密,建立一个信息安全通道,来保证数据传输的安全;
    2. 身份认证,确认网站的真实性;
    3. 数据完整性,防止内容被第三方冒充或者篡改;

    HTTPS与HTTP的区别

    1. https协议需要CA申请证书。
    2. http是超文本传输协议,信息是明文传输;https 则是具有安全性的ssl加密传输协议。
    3. http和https使用的是完全不同的连接方式,用的端口也不一样,前者是80,后者是443。
    4. http的连接很简单,是无状态的;HTTPS协议是由SSL+HTTP协议构建的可进行加密传输、身份认证的网络协议,比http协议安全。

    信息化人员的安全管理包括哪些方面

    1. 多人负责的原则:每项与安全有关的活动都必须有两人或多人在场。这些应是由系统主管领导指派的,应忠诚可靠,能胜任此项工作。
    2. 任期有限原则:一般地讲,任何人最好不要长期担任与安全有关的职务,以免误认为这个职务是专有的或永久的。
    3. 职责分离原则:除非系统主管领导批准,在信息处理系统工作的人员不要打听、了解或参与职责以外、与安全有关的任何事情。

    两条百兆网络出口线路的配置策略路由

    使用双主干策略路由,配置策略路由步骤为:

    1. 定义路由策略;
    2. 定义每个路由策略的匹配规则或条件;
    3. 定义每个规则或条件匹配后的行为;
    4. 将策略应用到指定的端口上;

    历年(2006~2018)真题下载:https://download.csdn.net/download/hwhsong/11184430

    展开全文
  • 2020年下半年网络工程师上午真题及答案

    万次阅读 多人点赞 2020-11-10 16:55:35
    2020年下半年网络工程师上午真题及答案 1.关系型数据库采用( )解决数据并发引起的冲突。 A.锁机制 B.索引 C.分区表 D.读写分离 2.把模块按照系统设计说明书的要求组合起来进行测试,属于( )。 A.单元...
  • 【软考】--下午题答题技巧

    千次阅读 多人点赞 2014-11-10 11:57:57
    一生至少该有一次,为了某件事... 总结一下下午题的答题技巧,希望能对大家有所帮助。 一、数据流图  概要:本题主要考察的数据流图的知识,主要是让写出实体、数据存储、缺失数据流。做好这个题,要利用父图子...
  • 软考下午题攻略

    千次阅读 多人点赞 2020-11-01 13:04:55
    对于基础知识这块,由于考查的知识面非常广,也非常细,个人而言无法找到一个行之有效的办法能让你迅速的提高上午的成绩,因此就不在这里总结了,我们要做的就是看书,做,再看书,再做,然后接着看书,在看书与做的...
  • 一些考试分值占比很少而且比较抽象的建议就多刷题,不要纠结于这个知识点,从而浪费了时间,多关注分值占比大的章节(如因特网与网络互联技术,安全方面的) 二、常见的公式一定要记住 常见的香农理论,奈奎定理,...
  • 相关场景: 想从事网络行业,之前也参加了行业内某知名某某服的面试,分享的是最近一个面试,这个是湖南某网络公司 ——网络工程师面试过程。 之前已经做过了一面的笔试逻辑,然后这次算是二面。 因为当事人是个...
  • 备考技巧: 考试冲刺时间至少预留一个半月左右,每天复习时间在两到三个小时。建议固定好学习时间形成一种习惯,推荐晚上9点到11半,周末可适当增加。 方法推荐:先看纸质版的教材将不懂的地方标出来,接着看相应...
  • 2008年下半年 网络工程师 上午试卷 ● 计算机内存一般分为静态数据区、代码区、栈区和堆区,若某指令的操作数之一采用立即数寻址方式,则该操作数位于 (1) 。 (1)A.静态数据区 B.代码区 C.栈区 D.堆区试题...
  • 1.尽量不要临时抱佛脚,我当时备考的时候,时间比较急,事情比较多,基本只给自己预留了两周多的时间,疯狂1.5倍速看视频,人都搞醉了,还...4.我本身也没有从事过网络工程方面的经验,所以我考完的感受就是网络工程师
  • 软考中级网络工程师
  • 2006年下半年 网络工程师 上午试卷 ● 若内存按字节编址,用存储容量为32K X 8 比特的存储器芯片构成地址编号A0000H至DFFFFH的内存空间,则至少需要 (1) 片。 (1)A.4 B.6 C.8 D.10试题解析:答案:C● 某...
  • ps:小技巧( switch(config)# interface range f0/1-5 ; interface range f0/6-8,0/9-0/22 , switchport access vlan 10) 将主干线路设置为trunk工作模式 Switch(config)#interface fastEthernet 0/23...
  • 案例分析下午的考试,软考中级系统集成项目管理工程师有4-5道案例(最近2次都是4道),满分75分。 对于这些案例分析题目来说,一般有四大类的题型:原因,方法,计算,知识。 “原因”就是要从案例的...
  • 网络工程师复习计划 网盘资源链接:https://www.cnblogs.com/gh110/p/12095988.html 链接:https://pan.baidu.com/s/1oToz6rF_pug9RM9_mbLxGQ 提取码:p4w9 盘中其他资料可以参考!!! 大家好,由于市面上的网络...
  • 软考网络工程师备考详细介绍

    千次阅读 2019-02-12 20:37:29
    网络工程师考试属于全国计算机技术与软件专业技术资格考试(即软考)中的一个中级考试。通过本考试的合格人员能根据应用部门的要求进行网络系统的规划、设计和网络设备的软硬件安装调试工作,能进行网络系统的运行、...
  • ·国家信息化体系要素:信息技术应用、信息资源、信息网络、信息技术和产业、信息化人才、信息化法规政策和标准规范。 二、电子政务 ·电子政务概念:指政府机构在其管理和服务职能中运用现代化信息技术,实现政府...
  • 网络工程师的5天修炼 新近主著、参编图书有《攻克要塞-系统集成项目管理工程师...
  • 本串讲视频教程根据最新的网络工程师考试大纲和作者进行考试辅导和阅卷的经验,对其中的难点问题进行了详细的分析和讲解。本串讲视频教程包括了网络工程师考试的所有考点,对于教材中没有涉及到的知识点或者讲得不...
  • 今年软考报名已经开始了,不知道各位复习的怎么样了。给目前正在备考网工的朋友分享下备考经验,...下午考试是问答,主要会考华为命令、配置、填空等等,需要多做,多练习。 下面进入正题 备考第一步,找好复
  • 系统集成项目管理工程师考试历年真题讲解 赵冲 系统集成项目管理工程师(IT...
  • 今年软考报名已经开始了,不知道各位复习的怎么样了。给目前正在备考网工的朋友分享下备考经验,...下午考试是问答,主要会考华为命令、配置、填空等等,需要多做,多练习。 下面进入正题 备考第一步,找好复
  • 从2016年上半年考试开始,软考网络工程师考试中,对下午部分的网络设备:交换机,路由器和防火墙设备不在局限于cisco的ios和pix设备,增加了华为的部分设备的配置。很多学员就感觉考试难度增加,又要多学一个操作...
  • 网络工程师正是这一学科的主导。 有网友评价说:网络工程师是现在最适合低学历人群的热门高薪职业。为什么会这样说呢?接下来让小编为你详细解读网络工程师网络工程师到底是做什么的? 网络工程师是通过学习和...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,275
精华内容 510
关键字:

网络工程师下午题技巧