精华内容
下载资源
问答
  • 软考网络工程师下午题命令归纳(完全版合集)
  • 2019年上半年(5月)软考网络工程师下午真题及答案解析。全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 软考网络工程师下午题知识点汇总

    千次阅读 多人点赞 2020-09-06 21:55:48
    下午题基础知识整理 华为交换机配置基础 1.vlan的配置 2.vlan与trunk配置案例 3.以太网端口有三种链路类型:Access、Hybrid和Trunk 4.Hybrid端口发送数据的处理 5.交换机管理IP的设置 6.MSTP负载均衡的例子 华为...


    去年已经拿到这个证书了,小小整理一下,都比较基础,软考网络工程师下午题的难度最多就到这种程度(配置方面)。 上午题需要的评论回复邮箱,我发PDF过去,这里就不整理了 (狗头偷懒)

    在这里插入图片描述
    建议多刷题(51CTO小程序,每日打卡),该记记该背背。

    华为交换机配置基础

    1.vlan的配置

    华为设备中划分VLAN的方式有:

    • 静态的划分:基于接口
    • 动态划分:基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、Ip地址)。
      其中基于接口划分VLAN,是最简单,最常见的划分方式。
      基于接口划分VLAN指的是根据交换机的接口来划分VLAN。需要网络管理员预先给交换机的每个接口配置不同的PVID即可。

    2.vlan与trunk配置案例

    <HUAWEI> system-view
    [HUAWEl]sysname SwitchA
    SwitchA]vlan batch23//批量创建VLAN2和VLAN3
    [SwitchA]interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1]port link-type access//设置接口类型为access
    [SwitchA-GigabitEthernet1/0/1]port default vlan 2//将接口GE1/0/1加入VLAN2
    [SwitchA-GigabitEthernet1/0/1]quit
    [SwitchA]interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2]portlink-type access
    [SwitchA-GigabitEthernet1/0/2]port default vlan 3//将接口GE1/0/2加入VLAN3
    [SwitchA-GigabitEthernet1/0/2]quit
    [SwitchA-GigabitEthernet1/0/2]interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3]port link-type trunk//设置接口类型为trunk
    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan2 3//允许该接口上透传VLAN2和VLAN3到上层交换机
    YSwitchA-GigabitEthernet1/0/3]quit
    

    3.以太网端口有三种链路类型:Access、Hybrid和Trunk

    • Acces类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    • Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    • Hybrid类型的端口是华为设备中的一种新的端口类型,其特点是可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,既可以用于交换机之间连接,也可以用于连接用户的计算机。

    注意:
    Hybrid端囗和Trunk端囗是有区别的:
    在接收数据时,Hybrid端口和Trunk端口处理方法是一样的,唯一不同之处在发送数据时,Hybrid端口可以允许多个VLAN的报文发送时不打标签,而runk端口只允许缺省VLAN的报文发送时不打标签。
    缺省VLAN:通常Access端口只属于1个VLAN,所以它的缺省VLAN1,无需设置。而Hybrid端口和Trunk端口可以属于多个VLAN,因此需要设置缺省VLANID。缺省情况下,Hybrid端口和Trunk端囗的缺省VLAN为VLAN1所有华为交换机的默认接口类型为hybrid。

    4.Hybrid端口发送数据的处理

    当端口接收到不带VLANTag的报文后,则将报文转发到属于缺省VLAN的端口(如果设置了端囗的缺省VLANID)。当端口发送带有VLAN Tag的报文时,如果该报文的VLANID与端口缺省的VLANID相同,则系统将去掉报文的VLANTag,然后再发送该报文。

    [Switch-Ethernet0/1]interface Ethernet 0/1   \\进入ethernet 0/1接口
    [Switch-Ethernet0/1]port link-type hybrid  \\设置接口类型为hybrid
    [Switch-Ethernet0/1]port hybrid pvid vlan 10  \\接口的PVID是vlan10
    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged  //对VLAN为10、20的报文,剥掉VLAN Tag
    

    5.交换机管理IP的设置

    华为部分设备有Meth接口,一个专门用于带外管理的接口,不能用于业务数据的传输。如果是二层的接入交换机,需求远程管理这台机器,则需要给这台机器配置个管理IP。通过ssh,telnet等的带内管理,通常默认的管理vlan是vlan1,也可以自己设置为其他Vlan。
    下面以s5700为例,介绍使用用Vlan5作为管理Vlan,管理IP地址为192.168.1.1/24的配置、用户可以通过GigabitEthernet 0/0/1的接口连接到Vlanif5.

    <55700>system-view/进入系统视图
    [S5700-vlan5]quit
    [S5700linterface Vlanif5//进入Vlanif5
    [S5700-Vlanifs]Jip address 192.168.1.124//设置Vlanif5网关192.168.1.1掩码255.255.255.0
    [S5700-Vlanif5]quit/退出
    [S5700]interface GigabitEthernet0/0/1	//进入物理端口GE0/0/1
    [S5700-GigabitEthermet0/0/1]port link-type access	//设置端口access模式
    [S5700-GigabitEthermet0/0/1]port default vlan 5	//将此端口划分到Vlan5
    [S5700-GigabitEthemet0/0/1]quit	//退出
    [S5700]aaa
    //进入aaa
    [S5700-aaa]local-user admin passwordcipher 123456//创建用户admin设置密码为123456密码加密方式为cipher
    [55700-aaa]local-user admin privilege level15//设置admin最高权限等级15
    [S5700-aaa]local-user admin service-type telnet ssh//授权admin用户可以使用telnet、ssh
    [S5700-aaa]quit/退出
    [S5700]user-interfacevty04
    [S5700-ui-vtyO-4Jauthentication-mode aaa
    

    6.MSTP负载均衡的例子

    如左图所示,四台交换机都运行MSTP。它们彼此相连形成了一个有冗余链路的环网。为实现接入层交换机上的VLAN2VLAN10和VLAN11
    VLAN20的分别在不同的STP域中,实现流量负载分担:
    因此需要配置两个MSTl,即MSTI1对应Vlan2-
    Vlan10和MSTl2对应Vlan11-20。他们经过MSTP之后,生成的无环路拓扑如图所示。
    在这里插入图片描述

    (1)交换机的MSTP区域配置
    在交换机A上创建一个相同的MST域(域名为RG1)、两个多生树实例MSTl1和MSTl2,然后为Vlan2-10映射到MSTl1,Vlan11-20映射到MSTI2。最后激活MST域配置。

    [SwitchA]stp region-configuration
    [SwitchA-mst-region]region-name RG1
    [SwitchA-mst-region]instance 1 vlan 2 to 10
    [SwitchA-mst-region]instance 2 vlan 11 to 20
    [SwitchA-mst-region]active region-configuration
    [SwitchA-mst-region]quit
    

    注意:因为这4台交换机都在同一个域(域名相同)才能起作用,因此其他三台设备也进行同样的配置。

    (2)配置MSTI1与MSTI2的根桥与备份根桥

    [SwitchA]stp instance 1 root primary	//配置switchA为MSTI1的根桥
    [SwitchA]stp instance 2 root secondary	//配置SwitchA为MSTI2的备份根桥
    [SwitchB]stp instance 1 root secondary	//配置Switch8为MST11的备份根桥
    [SwitchB]stp instance 2 root primary	//配置SwitchB为MSTI2的根桥
    

    (3)分别配置MSTI1和MSTI2中要被阻塞的端口,消除二层环路

    [Switch A-D]stp pathcost-standard legacy	//配置采用华为的私有端口路径开销计算方法,四台设备同样的标准
    
    [SwitchC]interface gigabitethernet 0/0/2
    [SwitchC-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchC-GigabitEthernet0/0/2]quit
    
    [SwitchD]interface gigabitethernet 0/0/2
    [SwitchD-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchD-GigabitEthernet0/0/2]quit
    

    在这里插入图片描述

    (4)在四台交换机上全局使能MSTP,使以上MSTP配置生效,消除二层环路

    [SwitchA]stp enable
    [SwitchB]stp enable
    [SwitchC]stp enable
    [SwitchD]stp enable
    

    (5)将与终端PC相连的端口去使能MSTP

    [SwitchC]interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1]stp disable
    [SwitchC-GigabitEthernet0/0/1]quit
    

    (6)在两个实例对应的根桥设备的指定端口上配置根保护功能

    [SwitchA]interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1]stp root-protection
    [SwitchB]interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1]stp root-protection
    

    (7)最后在各交换机上创建ID号为2~20的共19个VLAN,然后把四台交换机间的直连链路的端口配置为Trunk类型,并允许这19个VLAN通过。把连接PC的链路端口设置为Access类型,加入对应的VLAN

    [SwitchA]vlan batch 2 to 20
    [SwitchA]interface g0/0/1
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    [SwitchA]interface g0/0/2
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    
    dis stp brief
    

    华为路由器配置基础

    路由协议或路由种类相应路由的优先级
    DIRECT0
    OSPF10
    IS-IS15
    STATIC60
    RIP100

    DHCP配置

    DHCP的三种角色
    DHCP组网中,包括以下三种角色:
    DHCP客户端:通过DHCP协议请求获取P地址等网络参数的设备。例如,lP电话、PC、手机、无盘工站等。
    DHCP服务器:负责为DHCP客户端分配网络参数的设备。
    DHCP中继(可选):负责转发DHCP服务器和DHCP客户端之间的DHCP报文,协助DHCP服务器向DHCP客户端动态分配网络参数的设备。

    dhcp relay:dhcp select relay,使能接口的DHCP中继功能(缺省情况下未使能)

    在这里插入图片描述
    (1)使能DHCP服务

    <Huawei>system-view
    [Huawei]sysname Router
    [Router]dhcp enable
    

    (2)配置接口加入VLAN

    #配置Eth2/0/0接口加入VLAN10。
    [Router]vlan batch 10 to 11
    [Router]interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 10
    [Router-Ethernet2/0/0] quit
    

    (3)配置VLANIF11接口地址

    [Router]interface vlanif 11
    [Router-Vlanif11]ip address 10.1.2.1 24
    [Router-Vlanif11]quit
    

    (4)配置接口地址池

    配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。
    [Router]interface vlanif 10
    [Router-Vlanif10]dhcp select interface
    [Router-Vlanif10]dhcp server lease day 30
    [Router-Vlanif10]dhcp server domain-name huawei.com
    [Router-Vlanif10]dhcp server dns-list 10.1.1.2
    [Router-Vlanif10]dhcp server excluded-ip-address 10.1.1.2
    [Router-Vlanif10]dhcp server statuc-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
    

    ACL

    分类编号范围支持的过滤选项
    基本ACL2000~2999匹配条件较少,只能通过源lP地址和时间段来进行流量匹配,在一些只需要进行简单匹配的功能可以使用。
    高级ACL3000~3999匹配条件较为全面,通过源P地址、目的IP地址、To5、时间段、协议类型、优先级、ICMP报文类型和ICMP报文码等多个维度来对进行流量匹配,在大部分功能中都可使用高级ACL来进行精确流量匹配。
    基于MAC地址的ACL4000~4999由于数据链路层使用MAC地址来进行寻址,所以在控制数据链路层帧时需要通过MAC地址来对流量进行分类。基于MAC地址的ACL就可以通过源MAC地址、目的MAC地址、co5、协议码等维度来进行流量匹配。

    ACL规则

    acl number 2004
    rule 0 deny 202.38.0.0 0.0.255.255
    rule 10 permit 202.38.160.0 0.0.0.255
    
    
    配置好的ACL,应用到相应的接口才会生效。
    interface GigabitEthernet 0/0/1
    traffic-filter inbound acl 2004  //在接口上应用ACL,进行报文过滤,某些类型的设备可以使用packet-filter 3000
    
    ACL应用规则
    1.标准访问控制列表,靠近目标网络
    2.高级访问控制列表,靠近源网络
    

    两条规则结合则表示禁止一个大网段(202.38.0.0)上的主机但允许其中的一小部分主机(202.38.160.0)的访问。

    具体:
    acl number 3001
    rule deny source 192.168.2.0 0.0.0.255 destination 192.168.3.0 0.0.0.255

    在这里插入图片描述
    对内网地址192.168.1.12/24访问外网做限制,使其无法访问所有WEB界面

    acl number 3005		//定义用于报文过滤的访问控制
    description deny_source_ip_www
    rule 5 deny tcp source 192.168.1.12 0 destination-port eq www
    rule 10 permit tcp source 192.168.1.12 0
    
    interface g0/0/1
    ip address 192.168.1.2 255.255.255.0
    traffic-filter inbound acl 3005
    

    交换机进行ACL配置应用的例子
    1、先定义ACL

    [Switch]acl 3001   //新建一个高级ACL
    [Switch-acl-adv-3001]rule 5 deny ip source 192.168.5.0 0.0.0.255 destination 192.168.2.0 0.0.0.255   //禁止5网段访问2网段
    [Switch-acl-adv-3001]rule 100 permit ip		//允许访问任何网段
    

    2、配置基于ACL的流分类

    [Switch]traffic classifer tc1	//创建流分类
    [Switch-classifier-tc1]if-match acl 3001	//将ACL与流分类关联
    

    3、配置流行为

    [Switch]traffic behavior tb1	//创建流行为
    [Switch-behavior-tb1]deny	//配置流行为动作为拒绝报文通过
    

    4、配置流策略

    [Switch]traffic policy tp1	//创建流策略
    [Switch-trafficpolicy-tp1]classifier tc1 behavior tb1	//将流分类tc1与流行为tb1关联
    

    5、在接口下应用流策略

    [Switch]interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1]traffic-policy tp1 inbound	//流策略应用在接口入方向
    

    华为防火墙配置

    防火墙

    路由器的安全规则定义再接口上,而防火墙的安全规则定义在安全区域之间
    Local
    Trust
    DMZ
    Untrust

    域间的数据流分两个方向:
    入方向(inbound):数据由低级别的安全区域向高级别的安全区域传输的方向;
    出方向(outbound):数据由高级别的安全区域向低级别的安全区域传输的方向。

    防火墙的安全区域规则:

    • 本域内不同接口间不过滤直接转发
    • 进、出接口相同的报文被丢弃
    • 接口没有加入域之前不能转发包文

    在这里插入图片描述

    配置区域dmz
    [Eudemon]firewall zone name dmz1
    [Eudemon-zone-dmz1]set priority 70
    
    把接口加入到区域中
    把相应的接口加入到相应的区域中去
    配置接口Ethernet 1/0/0加入到防火墙DMZ域
    [Eudemon]firewall zone dmz
    [Eudemon-zone-dmz]add interface ethernet 1/0/0
    

    IP包过滤技术介绍
    对防火墙需要转发的数据包,先获取包头信息,然后和设定的规则进行比较,根据比较的结果对数据包进行转发或者丢弃。而实现包过滤的核心技术是访问控制列表
    五元组:源地址、目的地址、源端口、目的端口、协议号

    在区域间应用访问控制列表
    例子:创建编号为3001的访问控制列表。

    [华为]acl number 3001
    #配置ACL规则,允许特定用户从外部网访问内部服务器。
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.30 destination129.38.1.10
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.20
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.30
    下面的配置是在包过滤应用中引用ACL
    policy interzone trust untrust outbound 
    #将ACL规则3000作用于Trust区域到untrust区域间的出方向。
    [华为-Interzone-trust-untrust]packet-filter 3000 outbound
    #将ACL规则3001作用于Trust区域到Untrust区域间的入方向。
    [华为-Interzone-trust-untrust]packet-filter 3001 inbound
    #在Trust区域和Untrust区域之间使能FTP协议的应用协议检测。
    [华为-Interzone-trust-untrust]detec tftp
    

    Nat Server配置

    Nat Server 里面有 NAT Server配置案例
    内部服务器(Nat Server)功能是使用一个公网地址来代表内部服务器对外地址。在防火墙上,专门为内部的服务器配置一个对外的公网地址来代表私网地址。对于外网用户来说,防火墙上配置的外网地址就是服务器的地址。

    使用NAT可以灵活地添加内部服务器,通过配置内部服务器,可将相应的外部地址、端口等映射到内部的服务器上,提供了外部网络可访问内部服务器的功能。

    配置内部Web和FTP服务器。

    [USG] nat server wwwserver protocol tcp global 202.169.10.1 80 inside 192.168.20.2 8080
    [USG] nat server ftpserver protocol tcp global 202.169.10.1 ftp inside 192.168.20.3 ftp
    

    Easy IP配置

    Easy IP的概念很简单,当进行地址转换时,直接使用接口的公有IP地址作为转换后的源地址。同时它也利用访问控制列表控制哪些内部地址可以地址转换

    应用级网关ALG

    在这里插入图片描述
    NAT ALG实现原理
    配置:
    在系统视图下执行下列命令则使能了相应协议的ALG功能
    nat alg enable {ftp|h323|icmp|ras|qq|msn}

    在域间视图下为应用层协议配置ASPF检测
    firewall interzone trust untrust
    detect ftp 开启ASPF 和 NAT ALG。 这两个的命令是共用的

    双机热备

    防火墙入侵与检测 day04 防火墙双机热备

    在这里插入图片描述
    VGMP组管理

    • 状态一致性管理
      VGMP管理组控制所有的VRRP备份组统一切换。
    • 抢占管理
      当原来出现故障的主设备故障恢复时,其优先级也会恢复,此时可以重新将自己的状态抢占为主。

    HRP基本概念

    • HRP(Huawei Redundancy Protocol)协议,用来将主防火墙关键配置和连接状态等数据向备防火墙上同步。
    • 首包会话快速备份
    • 更新报文会话快速备份

    防火墙双机热备三大协议

    • VRRP 是 主备
    • VGMP 是 状态切换一致性
    • HRP 是 配置会话表的同步

     

    交换机三种端口

    交换机三种端口类型特点:
    以太网端口有三种链路类型:Access、Hybrid和Trunk。
    ■ Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    ■ Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
    ■ Hybrid 端口和Trunk 端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    交换机接口出入数据处理过程:
    ■ Access端口收报文:收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)
    ■ Access端口发报文:将报文的VLAN信息剥离,直接发送出去
    ■ trunk端口收报文:收到一个报文,判断是否有VLAN信息:如果有,判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃;如果没有VLAN信息则打上端口的PVID,并进行交换转发。
    ■ trunk端口发报文:比较将要发送报文的VLAN信息和端口的PVID,如果不相等则直接发送。如果两者相等则剥离VLAN信息,再发送。
    ■ hybrid 端口收报文:收到一个报文,判断是否有VLAN信息:如果有,则判断该hybrid 端口是否允许该VLAN的数据进入(在untagged和tagged列表中的都算允许通过,这个就相当于trunk的allow-pass vlan),如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用);如果没有则打上端口的PVID,并进行交换转发。
    ■ hybrid 端口发报文:1)、判断该VLAN在本端口的属性(disp interface即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)2)、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送.

    [Switch1]vlan 5 //创建 VLAN5 
    [Switch1-vlan5]management-vlan //设备 VLAN5 为管理 VLAN 
    [Switch1-vlan5]quit 
    [Switch1]interface vlanif 5 //创建管理 VLAN 的 VLANIF 接口 
    [Switch1-Vlanif5]ip add 10.10.1.1 24 //配置 VLANIF 接口 IP 地址 
    [Switch1-Vlanif5]quit 
    
    
    [Switch1]telnet server enable //Telnet 默认是关闭的,需要打开 
    [Switch1]user-interface vty 0 4 //开启 VTY 线路模式 
    [Switch1-ui-vty0-4]protocol inbound telnet //配置 Telnet 协议 
    [Switch1-ui-vty0-4]authentication-mode aaa //配置认证方式 
    [Switch1-ui-vty0-4]quit
    
    [Switch1]int g0/0/10
    [Switch1-GigabitEthernet0/0/10]port link-type trunk  //配置上联接口类型(trunk)
    [Switch1-GigabitEthernet0/0/10]port trunk allow-pass vlan all  //允许所有 VLAN 通过
    
    [SW2]interface Ethernet 0/0/2 
    [SW2-Ethernet0/0/2]port link-type access //配置接口类型为 access
    [SW2-Ethernet0/0/2]port default vlan 10 //将接口加入 VLAN10
    [SW2-Ethernet0/0/2]quit
    
    [Huawei-GigabitEthernet0/0/1]port link-type hybrid //配置接口类型为 hybrid 
    [Huawei-GigabitEthernet0/0/1]port hybrid pvid vlan 10 //配置接口的 PVID 
    [Huawei-GigabitEthernet0/0/1]port hybrid untagged vlan 10 30 //配置接口的 untgged vlan
    

    端口
    1.配置POP3服务器时,邮件服务器中默认开放TCP的 (D) 端口。
    A、21
    B、25
    C、53
    D、110
    2.电子邮件应用程序利用POP3协议( D )。
    A. 创建邮件 B. 加密邮件 C. 发送邮件 D. 接收邮件

    FTP服务器使用20和21两个网络端口与FTP客户端进行通信。主动模式下,FTP服务器的21端口用于传输FTP的控制命令,20端口用于传输文件数据

    HTTP:80 Telnet:23
    SNMP消息全部通过UDP端口161接收,只有Trap信息采用UDP端口162。 SNMP用的是无连接的UDP协议
    IMAP4端口 143


    Linux:
    inetd.conf 是 系统超级服务进程inetd的配置文件
    lilo.conf 是 操作系统启动程序LILO的配置文件
    httpd.conf 是 web服务器Apache的配置文件
    resolv.conf是 DNS解析的配置文件

    在Linux操作系统中,与DHCP相关的主要配置文件如下:
    DHCP服务器配置文件 /etc/dhcpd.conf(DHCP服务的主配置文件)
    启动DHCP服务的脚本 /etc/rc.d/ink.d/dhcpd
    执行DHCP服务的程序 /usr/sbin/dhcpd
    记录客户端租用信息的文件 /var/state/dhcpd.leases(保存客户端租约信息的文件)
    重启DNS服务器:service named restart

    对称加密算法:DES、3DES、RC5、IDEA 适用于大量数据加密
    公开密匙(非对称)加密算法:RSA、DSA、ECC 加密速度慢,计算量大,不适合会话通信

    1、OSPF默认的Hello报文发送间隔时间是 4秒,
    Hello用于发现邻居,保证邻居之间keepalive,keepalive,是在TCP中一个可以检测死连接的机制。
    来建立和维护相邻邻居路由器之间的链接关系
    默认的Hello报文的发送间隔是10秒,默认无效时间间隔是Hello时间间隔的 4倍,即如果在40秒内没有从特定的邻居接收到这种分组,路由器就认为那个邻居不存在了。
    Hello组播地址为224.0.0.5
    2、在进行域名解析过程中,当主域名服务器查找不到IP地址时,由(转发域名服务器)负责域名解析
    3、路由器的描述中,路由器的串口之间通常是 点对点连接
    4、OSPF协议把网络划分成 4种区域,其中(存根区域)不接受本地自治系统以外的路由信息,对自治系统以外的目标采用默认路由0.0.0.0
    5、帧中继: 本地管理接口类型:提供面向连接的服务,高效的数据链路技术,充分复用了光纤通信和数字网络技术的优势。
    6、运行OSPF协议的路由器在选举 DR/BDR之前,DR是路由器自身,备份指定路由器(BDR)
    7、内部网关协议(IGP):在同一个自治系统内交换路由信息。IGP的主要目的是发现和计算自治域内的路由信息
    IGP使用的路由协议有:RIP、OSPF、IS-IS

    在这里插入图片描述

    展开全文
  • 2014-2020年软考网络工程师历年真题合集包含上午下午真题及答案解析,全网最清晰,答案最正确的软考真题资料,小任老师出品,必属精品!
  • 2021软考网络工程师下午知识点汇总+历年真题 《华为基础实验》指导手册、55页华为命令实验宝典、AR600, AR6000 V300R019 配置指南-(命令行)、软考网络工程师-华为命令实验手册、网络工程师考试知识点总结、网络...
  • 软考中级网络工程师下午)路由器、交换机、IPv6-over-IPv4 隧道技术、OSPF等配置语句
  • 1、第一时间发布2016年下半年软考网络工程师真题答案,使参加下半年软考的同学对自己考试情况做一个准确评估。2、为未来参加网络工程师考试的学员展现网络工程师最新的考题形式,考察要点,助其有重点的复习软考网络...
  • 软考 网络工程师 下午 配置汇总 2010年5月份软考网络工程师必备资料
  • 2019年5月上半年软考网络工程师下午案例分析真题解析答案
  • 1、第一时间发布2016年下半年软考网络工程师真题答案,使参加下半年软考的同学对自己考试情况做一个准确评估。2、为未来参加网络工程师考试的学员展现网络工程师最新的考题形式,考察要点,助其有重点的复习软考网络...
  • 2020年下半年网络工程师下午真题及答案解析,全网最清晰,答案最正确的软考真题资料,小任老师出品,必属精品!
  • 软考网络工程师2019下半年下午真题解析,梳理解题思路,重点知识及答题技巧,祝大家早日通过软考网络工程师考试,升职加薪!!!!
  • 软考是每个搞IT人跨不过的门槛,尤其是在行政事业单位或者国有企业工作的技术人员,软考更是必不可少的聘职称利器,缺了它还真拼不了,既然这么重要,那么一起来看看2019上半年软考网络工程师考试下午真题,其实并不...

    软考是每个搞IT人跨不过的门槛,尤其是在行政事业单位或者国有企业工作的技术人员,软考更是必不可少的聘职称利器,缺了它还真拼不了,既然这么重要,那么一起来看看2019上半年软考网络工程师考试下午真题,其实并不难,如下“”:
    试题一、阅读以下说明,回答问题1至问题4,将解答填入答题纸对应的解答栏内。
    【说明】
    某企业分支与总部组网方案如图1-1所示,企业分支网络规划如表1-1所示。

    企业分支与总部组网说明:

    1. 企业分支采用双链路接入Internet,其中ADSL有线链路作为企业分支的主Internet 接口; 3G/LTE Cellular无线链路作为企业分支的备用Internet接口。
    2. 指定Router1作为企业出口网关,由Router1为企业内网用户分配IP地址。
    3. 在Router1上配置缺省路由,使企业分支内网的流量可以通过xDSL和3G/LTE Cellular无线链路访问Internet。
    4. 企业分支与总部之间的3G/LTE Cellular无线链路采用加密传输。

    问题内容:
    【问题1】(每空2分,共4分)
    依据组网方案,为企业分支Router1配置互联网接口板卡,应该在是( 1 )和( 2 )单板中选择配置。
    (1) ~ (2)备选答案:
    A. xDSL B.以太WAN C. 3G/LTE D. E3/T3
    【问题2】(每空2分,共6分)
    在Router1上配置DHCP服务的命令片段如下所示,请将相关内容补充完整。
    [Huawei] dhcp enable
    [Huawei] interface vlanif 123
    [Huawei-Vlanif123] dhcp select global // ( 3 )
    [Huawei-Vlanif123 ] quit
    [Huawei] ip( 4 )lan
    [Huawei-ip-pool-lan] gateway-list( 5 )
    [Huawei-ip-pool-lan] network 192.168.100.0 mask 24
    [Huawei-ip-pool-lan] quit
    【问题3】(每空1分,共6分)
    在Router1配置上行接口的命令如下所示,请将相关内容补充完整。.
    #配置NAT地址转换
    [Huawei] acl number 3002
    [Huawei-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Huawei-acl-adv-3002] quit
    [Huawei] interface virtual-template 10 // ( 6 )
    [Huawei-Virtual-Template 10] ip address ppp-negotiate
    [Huawei-Virtual-Template 10] nat outbound ( 7 )
    [Huawei-Virtual-Template 10] quit
    #配置ATM接口
    [Huawei] interface atm 1/0/0
    [Huawei-Atm1/0/0] pvc voip 1/35 //创建 PVC (ATM 虚电路)
    [Huawei-atm-pvc-Atm1/0/0-1/35-voip] map ppp virtual-template 10 //配置PVC上的PPPoA映射
    [Huawei-atm-pvc-Atm1/0/0-1/35-voip] quit
    [Huawei-Atm1/0/0] standby interface cellular 0/0/0 // ( 8 )
    [Huawei-Atm1/0/0] quit
    #配置APN与网络连接方式
    [Huawei] apn profile 3gprofile
    [Huawei-apn-profile-3gprofile] apn wcdma
    [Huawei-apn-profile-3gprofile] quit
    http://www.zcjsj8.com/lnzt/228.html
    这个是华为路由器的操作界面,如今的软考基本不考思科及国外的一些路由器,大可放心,下载华为模拟器,在本机大胆的操作。

    居中并且带尺寸的图片: Alt

    当然,我们为了让用户更加便捷,我们增加了图片拖拽功能。

    如何插入一段漂亮的代码片

    博客设置页面,选择一款你喜欢的代码片高亮样式,下面展示同样高亮的 代码片.

    // An highlighted block
    var foo = 'bar';
    

    生成一个适合你的列表

    • 项目
      • 项目
        • 项目
    1. 项目1
    2. 项目2
    3. 项目3
    • 计划任务
    • 完成任务

    创建一个表格

    一个简单的表格是这么创建的:

    项目Value
    电脑$1600
    手机$12
    导管$1

    设定内容居中、居左、居右

    使用:---------:居中
    使用:----------居左
    使用----------:居右

    第一列第二列第三列
    第一列文本居中第二列文本居右第三列文本居左

    SmartyPants

    SmartyPants将ASCII标点字符转换为“智能”印刷标点HTML实体。例如:

    TYPEASCIIHTML
    Single backticks'Isn't this fun?'‘Isn’t this fun?’
    Quotes"Isn't this fun?"“Isn’t this fun?”
    Dashes-- is en-dash, --- is em-dash– is en-dash, — is em-dash

    创建一个自定义列表

    Markdown
    Text-to- HTML conversion tool
    Authors
    John
    Luke

    如何创建一个注脚

    一个具有注脚的文本。1

    注释也是必不可少的

    Markdown将文本转换为 HTML

    KaTeX数学公式

    您可以使用渲染LaTeX数学表达式 KaTeX:

    Gamma公式展示 Γ ( n ) = ( n − 1 ) ! ∀ n ∈ N \Gamma(n) = (n-1)!\quad\forall n\in\mathbb N Γ(n)=(n1)!nN 是通过欧拉积分

    Γ ( z ) = ∫ 0 ∞ t z − 1 e − t d t   . \Gamma(z) = \int_0^\infty t^{z-1}e^{-t}dt\,. Γ(z)=0tz1etdt.

    你可以找到更多关于的信息 LaTeX 数学表达式[here][1].

    新的甘特图功能,丰富你的文章

    Mon 06 Mon 13 Mon 20 已完成 进行中 计划一 计划二 现有任务 Adding GANTT diagram functionality to mermaid
    • 关于 甘特图 语法,参考 [这儿][2],

    UML 图表

    可以使用UML图表进行渲染。 Mermaid. 例如下面产生的一个序列图::

    张三 李四 王五 你好!李四, 最近怎么样? 你最近怎么样,王五? 我很好,谢谢! 我很好,谢谢! 李四想了很长时间, 文字太长了 不适合放在一行. 打量着王五... 很好... 王五, 你怎么样? 张三 李四 王五

    这将产生一个流程图。:

    链接
    长方形
    圆角长方形
    菱形
    • 关于 Mermaid 语法,参考 [这儿][3],

    FLowchart流程图

    我们依旧会支持flowchart的流程图:

    Created with Raphaël 2.2.0 开始 我的操作 确认? 结束 yes no
    • 关于 Flowchart流程图 语法,参考 [这儿][4].
      附:软考网络工程师2004—2019历年考试真题及答案解析打印版百度网盘
      链接:https://pan.baidu.com/s/12NvDW9-XjvK0vFFcZ6J_6Q 提取码:bu78

    1. 注脚的解释 ↩︎

    展开全文
  • 软考-网络工程师-下午考试知识点 软考-网络工程师-下午考试知识点
  • 2017年下半年(11月份)软考 网络工程师下午真题及答案解析,全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 网络可以实现的网络功能有: 1.汇聚层交换机A与交换机B采用VRRP技术组网; 2.用防火墙实现内外网地址转换和访问策略控制; 3.对汇聚层交换机、接入层交换机(各车间部署的交换机)进行VLAN划分。 [问题1] (6...

    试题一(共20分)

    阅读以下说明,回答问题1至问题4,将解答填入答题纸对应的解答栏内。

    【说明】

    某企业网络拓扑图如图1-1所示。该网络可以实现的网络功能有:

    1.汇聚层交换机A与交换机B采用VRRP技术组网;

    2.用防火墙实现内外网地址转换和访问策略控制;

    3.对汇聚层交换机、接入层交换机(各车间部署的交换机)进行VLAN划分。

    1.png

    [问题1] (6分)

    为图1-1中的防火墙划分安全域,接口①应配置为(1)区域,接口②应配置为(2)区域,接口③应配置为(3)区域。

    [问题2](4分)

    VRRP技术实现(4)功能,交换机A与交换机B之间的连接线称为(5)线,其作用是(6).

    [问题3] (6分)

    图1-1中PCI的网关地址是(7);在核心交换机上配置与防火墙互通的默认路由,其目标地址应是(8);若禁止PCI访问财务服务器,应在核心交换机上采取(9)措施实现。

    [问题4](4分)

    若车间1增加一台接入交换机C,该交换机需要与车间1接入层交换机进行互连,其连接方式有(10)和(11);其中(12)方式可以共享使用交换机背板带宽,(13)方式可以使用双绞线将交换机连接在一起。

    试题二(共20分)

    阅读以下说明,回答问题1至问题3,将解答填入答题纸对应的解答栏内。

    【说明】

    图2-1所示为某单位网络拓扑图片段。

    展开全文
  • 考试试题 赶紧下载 你懂得 呵呵
  • 详细解析了2016年5月新网络工程师下午的考试,对每一道都进行了重点的讲解,并点出了相关的考察点。对于一些发散的知识点也给广大考生做了相应的说明。相信大家通过本次试题讲解能够抓住网络工程师上午考试的要点...
  • 第15章 网络需求分析和计划 第16章 组网技术 11月网络设计师 试题一15分 阅读以下说明回复问题1和问题3将解答填入答题纸对应解答栏内 说明 某企业规模扩大既要考虑确保现在土建装修效果不被破坏又要满足网络扩容和...
  • 2018年上半年网络工程师上午+下午真题及答案解析(计算机软考)
  • 软考网络工程师下午考试知识点整理

    万次阅读 多人点赞 2017-07-15 14:45:31
    IPSec不是一个单独的协议,给出了应用于IP层上网络数据安全的一整套体系结构,包括网络认证协议AH,封装安全载荷协议ESP,密钥管理协议IKE和用于网络认证及加密的一些算法。 IPSec规定了如何在对等层之间选择安全...

    设置端口为接入链路模式:switchport mode access
    把某个端口分配:switchport access vlan11
    no shuntdown开启端口

    standby 1 ip 203.12.12.253 开启了冗余热备份(HSRP)并设虚IP地址
    standby 1 priority 110 定义这个三层交换机在冗余热备份组1中的优先级为110
    standby 1 preempt 设置切换许可,即抢占模式

    优先级的范围:1-254
    优先级0为系统保留给特殊用途
    优先级255系统保留给IP地址拥有者
    默认情况下 优先级的取值是100

    ISL VLAN ID最大为1023

    查询路由表的命令 show ip route

    路由器的配置模式:
    router(config) # 全局模式
    router > 用户模式
    router # 特权模式
    router (config-if) # 局部配置模式(接口/端口配置模式)

    接口使用帧中继封装格式,命令:encapsulation frame-delay

    IPSec不是一个单独的协议,给出了应用于IP层上网络数据安全的一整套体系结构,包括网络认证协议AH,封装安全载荷协议ESP,密钥管理协议IKE和用于网络认证及加密的一些算法。
    IPSec规定了如何在对等层之间选择安全协议,确定安全算法,密钥交换,向上提供了访问控制,数据源认证,数据加密等网络安全服务

    IPsec有隧道和传输两种工作方式
    传输模式:为上层协议提供安全保护,保护IP包的有效载荷(保护的是上层协议如TCP UDP ICMP)
    隧道模式:为整个IP包提供保护。
    有新IP头的是隧道方式
    有ESP的支持报文加密
    端到端通信采用传输模式

    IPSec安全体系
    包括AH, ESP,ISAKMP/Oakley
    IPSec认证头提供了数据完整性和数据源认证,不提供保密服务
    AH包含对称密钥散列函数,使得第三方无法修改传输中的数据
    AH为IP包提供信息源和报文完整性验证,不支持加密服务
    IPSec封装安全负荷(ESP)提供了数据加密功能。ESP利用对称密钥对IP数据(如TCP包)进行加密。

    IKE:
    IKE 传送认证和加密数据之前,就协议,加密算法,使用的密钥进行协商,在密钥交换前还要对远程系统进行初始认证
    IKE实际上是ISAKMP OAKLEY SKEME的混合体

    在路由器R1中简历IKE策略:
    R1(config)#crypto isakmp policy 110 进入isakmp配置模式
    R1(config-isakmp)# encryption des 采用des加密算法
    R1(config-isakmp)#hash md5 采用MD5散列算法
    R1(config-isakmp)#authentication pre-share 认证采用预共享密钥
    R1(config-isakmp)#group 1 参数1表示密钥使用768位密钥,参数2表示使用1024密钥
    R1(config-isakmp)# lifetime 3600 安全关联生存期为1天

    R2 R1之间采用预共享密钥 12345678建立IPsec安全关联
    R1:crypt isakmp key 12345678 address+IP地址
    R2:crypt isakmp key 12345678 address

    设置名为testvpn的VPN,采用MD5认证,DES进行数据加密
    crypto transform-set testvpn ah-md5-hmac esp-des esp-md5-hmac

    crypto map名为test 优先级20 IPSec采用IKE自动协商
    crypto map test 20 ipsec-isakmp

    指定此VPN线路,对端的IP地址为192.168.1.1
    set peer 192.168.1.1

    IPSec传输模式的名字为testvpn
    set transform-set testvpn

    access-list 300 permit ip 192.168.100.0 0.0.0.255
    crypto map vpntest 1 ipsec-isakmp 创建crypto map名字为vpntest
    set peer 202.100.2.3
    set transform-set link 指定传输模式为link
    match address 300 指定应用访问控制列表
    interface serial10/0
    crypto map vpntest 将加密图应用到接口vpntest

    默认路由是特殊的静态路由
    当路由表中与目的地址之间没有匹配的表项时路由器能够做出的选择
    默认路由大大简化路由器的配置,减轻管理员的工作负担,提高网络性能

    ip nat inside指定与内部网络相连的内部端口
    ip nat outside指定与外部网络相连的外部端口

    解决无线AP安全,需要通过SSID和MAC地址过滤防止非法链接

    无线网络加密方式:
    WEP 有线等效私密
    WPA/WPA2 (wifi protected access)使用TKIP,加密算法RC4
    WPA-PSK/WPA2-PSK AES(高级加密算法)

    单模多模
    单模兼容多模
    单模光纤:远程通讯,100M以太网以及1G千兆网,都支持5km的传输距离
    多模光纤:10mbps-100mbps 2000m
    1Gbps 550m
    10Gbps 100m
    基带同轴电缆
    宽带同轴电缆
    双绞线:100m以内
    1类双绞线
    5类双绞线
    6类双绞线:传输速率1Mhz-250Mhz 提供两倍于超5嘞的带宽,适于传输速率高于1Gbps的应用
    2km超出了双绞线,多模光纤距离

    200m超出了双绞线距离

    MPLS:IP数据报封装在MPLS数据包中
    MPLS VPN有三种类型路由器:
    P路由器:运营商网络主干路由器,根据分组的外层标签对VPN数据进行透明转发。相当于标签交换路由器(LSR),只维护到PE路由器的路由信息,不维护VPN相关路由信息
    PE路由器:运行商边缘路由器,LER,将来自CE或标签交换路径(LSP)的VPN数据处理后进行转发,同时负责和其他PE交换信息
    CE路由器:用户边缘设备,用户端路由器。CE通过连接一个或多个PE,为用户提供服务接入

    debug:提供端口传输信息,节点产生的错误信息

    POE的标准供电电压为48V

    三种NAT-PT机制实现IPV4到IPV6地址之间的相互转换:
    1。静态映射
    2.动态映射
    3. NAPT-PT机制

    策略路由:
    根据目的地址进行的策略:目的地址路由
    根据源地址进行的策略:源地址路由

    NAPT 网络地址和端口翻译 M:1
    用一个公网IP地址将子网中的所有主机的IP地址都隐藏起来

    conduct permit tcp host 202.134.135.99 eq www any
    允许任意外网主机访问202.134.135.99提供的www服务

    PAP使用明文身份验证
    CHAP通过使用MD5和质询-响应机制提供一种加密身份验证

    PPTP和L2TP是两种隧道协议,都是使用PP协议对数据进行封装,添加附加包头用于数据在互连网络上的传输

    PPP会话拨号过程:
    创建链路阶段,认证阶段,网络协商阶段
    创建链路:由LCP创建链路,协商工作方式,认证方式,链路压缩。协商成功后,表示底层链路已经建立,进入到认证阶段。
    认证阶段:PPP进行用户认证。支持PAP和CHAP两种认证方式。CHAP需要对通信双方进行认证,PAP是认证方对被认证方的身份进行确认,确认成功后进入网络协商阶段
    有限的认证方式:口令字认证协议(PAP)挑战握手认证协议(CHAP)微软挑战握手认证协议(MS-CHAP)
    网络协商阶段:成功后,通过PP链路发送报文。NCP协议交换数据报文、

    创建PPP链路,用户验证,PPP回叫控制,调用网络层协议

    linux系统的默认目录
    每个目录的含义 P407

    文件类型 d代表目录 -代表普通文件

    更改文件的权限的命令 chmod
    chmod [who] [opt] [mod]
    chgrp改变文件所属群组
    vi编辑文件
    which查找文件

    Linux系统中的Samba的主要配置文件/etc/samba/smb.conf
    smb.conf文件中有3个主要部分:
    全局参数字段
    目录共享字段
    打印机共享字段

    inetd/xinetd是Linux系统中的一个重要服务
    xinted负责网络服务的守护进程

    r w x 可读 可写 可执行

    RDU2对终端服务具有用户访问和来宾访问权限

    Windows Server 2003的活动目录必须安装在NTFS分区,并且需要有DNS服务的支持
    全局组可以访问域林中的任何资源的权限,域本地组只能访问本地域的资源,通用组可以授予多个域中的访问权限

    netstat - nr显示路由信息
    route add default gw 192.168.0.254添加网关为默认路由

    /etc/fstab是一个重要的系统配置文件,存放系统中文件系统的信息。系统启动时,自动从这个文件读取信息,自动将此文件中指定的文件系统挂载到指定的目录。
    超级用户可以通过Mount命令将分区加载到指定目录,从而该分区可以在Linux系统中使用

    etc/profile每个用户登录时都会运行的环境变量设置

    fdisk指令是Linux下通用的磁盘分区工具,可以操纵磁盘分区表,完成对硬盘分区进行管理的各种操作

    默认路由:
    变种的静态路由,当路由器在路由表里没有找到去往特定目标网络的路由条目时,自动将该目标网络的所有数据发送到默认路由指定的下一跳路由器

    esp 3des sha1
    IPSec采用ESP报文,加密算法采用3DES 认证算法采用SHA-1

    Hosts文件:
    用于存储计算机网络中节点信息的文件,将主机名映射到相应的IP地址,实现DNS功能,由计算机用户控制
    windows系统下:c:\windows\system32\drivers\etc\

    Linux服务器配置web服务之前,执行命令[root@root] rpm -qa | grep httpd 检查Apache软件包是否成功安装

    RPM:red hat package manager
    用于在Linux下安装,删除软件
    RPM常用参数:
    -vh显示安装进度
    -U升级软件包
    -qpl列出RPM软件包内的文件信息
    -qpi列出RPM软件包的描述信息
    -qf查找指定文件属于哪个RPM文件包
    -Va校验素有RPM软件包,查找丢失的文件
    -qa查找相应文件 例如rqm -qa mysql

    WEB服务配置完成后,用service httpd start启动web服务

    显示当前DNS缓存:ipconfig/displaydns
    刷新DNS缓存:ipconfig/flushdns
    更新所有DHCP租约并重新注册DNS域名:ipconfig/registerdns

    Record T也字段为4,存储记录是MX
    2,存储记录 IP地址对应的域名(反向解析)
    12 PTR

    perimit tcp host 192.168.1.2 host 10.10.1.10 eq telnet
    使得内网主机192.168.1.2可以使用Telnet对web服务器进行维护

    访问控制列表
    可以用编号和名字来引用
    用名字引用的ACL被称为命名ACL
    扩展访问列表:能够基于目的地址,端口号和协议来控制数据报

    标准ACL命令格式:
    access-list access-list-number {perimit|deny] {source [source-wildcard] |any}
    扩展ACL格式:
    access-list access-list-number {perimit|deny} {protocol \ protocol-keyword} {source [source-wildcard] |any } {protocol-specific options} {destination [destination-wildcard] |any} {protocol-specific options} {log}
    e.g. access-list 101 permit tcp any host 192.168.10.30
    允许所有主机访问192.168.10.30
    access-list 101 permit tcp 192.168.3.0 0.0.0.255 host 192.168.10.20
    允许192.168.3.0访问192.168.10.20

    int vlan 10
    ip access-group 101 in 在vlan10的入方向上应用acl 101
    access-list 102 deny any any 拒绝所有流量
    int vlan 1
    ip access-group 102 in 禁止非网络管理员访问网络设备和网管服务器

    配置mac和ip绑定:
    host pcl {
    hardware
    fixed-address
    }

    两台web服务器采用同一域名主要是对web服务实现负载均衡或防止单点失效

    测试DNS服务器是否正常工作;nslookup ping

    vsftpd:
    应用层FTP协议
    传输层TCP协议,默认端口号21
    service vsftpd start
    service vsftpd stop

    利用windows系统开启ICS连接共享功能,实现企业内部用户代理上网需要两个网络连接(不一定是两张网卡)。需要再一个网络连接上开启ICS功能后,另一个网络连接自动分配192.168.0.1的地址,并且作为内部用户主机的网关

    windows下DHCP服务器的默认地址租约是8天

    DHCP作用域:添加保留
    DHCP地址池:添加排除地址范围

    DHCP功能配置:
    ip dhcp excluded-address 192.168.2.1 192.168.2.2
    ip dhcp pool_name
    network 192.168.0.0 255.255.0.0 为所有客户机动态分配的地址段
    domain-name csai.com 为客户机配置域后缀
    dns-server 192.168.1.1
    netbios-name-server 192.168.1.1 为客户机配置wins服务器,没有可以不用配置
    lease 10 地址租约期限为10天
    default-router 192.168.1.2 为客户机配置默认的网关地址

    IIS下web服务配置,网站属性中“网站”选项卡中的IP地址选择“全部未分配”,则该web服务器任意IP地址(如果服务器有多个IP地址的话)都可以响应来自web客户端的请求

    虚拟主机:
    windos下web服务器实现虚拟主机,在一台计算机上运行多个网站
    不同的IP地址
    相同的IP地址,不同的TCP端口号
    相同的IP地址,相同的TCP端口号,不同的主机头

    防火墙配置:
    PIX(config)#interface ethernet0 anto
    interface ethernet1 100full
    interface ethernet2 100full
    ip address outside ip 掩码
    ip address inside ip 掩码
    ip address dmz ip 掩码
    global (outside) 1 224.4.5.1-224.4.5.6 指定公网地址范围,定义地址池
    nat (inside) 1 0.0.0.0 0.0.0.0 表示内网的所有主机都可以访问外网
    route outside 0 0 224.4.5.2 设置默认路由

    配置网关地址为Linux服务器的内网卡地址
    指定DHCP服务器本身也是DNS服务器 P471

    客户机地址租约时间到达默认租约时间的50Z%.DHCP客户端会向DHCP服务器单播DHCP request包,实现续约请求。同意DHCP ACK 不同意 DHCP NAK

    windows环境下添加/删除静态或默认路由命令格式:
    route add 0.0.0.0 mask 0.0.0.0 网关地址 //添加默认路由
    route delete 0.0.0.0 删除默认路由
    route delete 0.0.0.0 mask 0.0.0.0 删除默认路由
    route add 192.168.1.0 mask 255.255.255.0 吓一跳地址(网关地址) //添加静态路由
    route delete 192.168.1.0 //删除一条静态路由

    windows下DHCP用命令行导入导出DHCP数据库的命令:
    导出:netsh dhcp server export c:\dhcpbackup.txt
    导出:netsh dhcp server import c:\dhcpbackup.txt
    必须具有本地管理员组(Administrators组)权限才能导出数据

    telent端口23

    Linux系统目录结构
    /etc 系统配置文件
    /sbin 指令文件(用于root用户)
    /home 用户主目录,新建用户后,该用户的源文件默认建立在此目录下
    /boot 内核和启动文件
    /dev 设备文件
    /usr 应用程序放置目录
    /mnt 光驱
    /tmp 临时文件
    /root root用户主目录
    /opt 空文件夹
    /proc 内存中实际参数和内核的映像,此文件夹的文件不宜改动
    /lib 类库,用于动态加载内核
    /lost+found 恢复误删除文件

    在linux系统中,每张网卡都有其独有的配置文件,网卡配置文件根目录为/etc/sysconfig/network-scripts/
    网卡参数配置文件配置完成后,需要重启网卡脚本,配置内容才能生效
    /etc/rc.d/init.d/network restart //脚本启动

    测试DNS服务器状态的命令:ping tracert nslookup
    arp:维护和查看arp记录,与DNS无关
    ipconfig:查看网卡参数,如IP地址,子网掩码,默认网关,DNS服务器地址等,不能测试DNS服务状态

    网络服务:DNS DHCP WINS服务组件

    宽带接入技术:
    FTTx+PON HFC FTTx+LAN WLAN WiMax xDSL PLC
    FTTx+PON 局端放置OLT,单根光纤到小区或大楼中心机房,中心机房经光分器连接到用户端ONU
    HFC:基于有线电视网络的接入方式,允许用户通过有线电视网实现高速接入互联网。
    优点速率较高,接入方式方便,可实现多类视频服务,高速下载
    用户端要部署CableModem
    FTTx+LAN:通过光纤接入到小区节点或者楼道,再由网线连接到各个共享点上的光纤,提供一定区域的高速互联接入。速率高,抗干扰能力强,缺点是一次性布线成本高
    xDSL:本地环路提供数字服务,ADLS,ADLSMODEM
    WiMax:全球微波互联接入 802.16 50km QOS保障,传输速率高,业务丰富
    PLC:电力线通信技术,指利用电力线传输数据和媒体信号的一种通信方式,电力线载波

    PON技术是未来FTTx的主要解决方案。GPON EPON
    EPON结合以太网和PON,实现上下行1.25Gbps

    展开全文
  • 详细解析了2015年11月网络工程师下午的考试,对每一道都进行了重点的讲解,并点出了相关的考察点。对于一些发散的知识点也给广大考生做了相应的说明。相信大家通过本次试题讲解能够抓住网络工程师上午考试的要点。...
  • 2011年上半年软考网络工程师下午试题分析及答案
  • 仅供参考,大家可以用来估分,不一定是标准答案。
  • 2016年5月软考网络工程师下午试题解析 10年以上软考培训经验,线下培训学...
  • 2018年下半年(11月份)软考 网络工程师 下午真题及答案解析,全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 2009年上半年网络工程师下午试题 2009年上半年网络工程师下午答案 2008年下半年网络工程师上午试题 2008年下半年网络工程师上午答案 2008年下半年网络工程师下午试题 2008年下半年网络工程师下午答案 2008年上...
  • 2012上半年软考网络工程师 下午试题
  • 压缩包里面包括2017年下半年软件设计师【上午+下午】试题及参考答案及详解,可打印。 压缩包里面包括2017年下半年软件设计师【上午+下午】试题及参考答案及详解,可打印。
  • 2019年上半年软考网络工程师软考真题上午和下午习题原与答案和解析word版本无广告可打印。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,077
精华内容 430
关键字:

软考网络工程师下午题