精华内容
下载资源
问答
  • 华为交换机组播配置

    2014-07-21 14:18:05
    华为交换机组播配置华为交换机组播配置华为交换机组播配置
  • 华为组播配置

    2021-09-03 19:22:09
    multicast routing-enable igmp-snooping enable int vlan 1 igmp-snooping enable igmp-snooping prompt-leave igmp-snooping querier enable int vlanif 1 igmp prompt-leave

    multicast routing-enable

    igmp-snooping enable

    int vlan 1

        igmp-snooping enable

        igmp-snooping prompt-leave

        igmp-snooping querier enable 

    int vlanif 1 

        igmp prompt-leave

    展开全文
  • 基于eNSP的组播配置实验基于eNSP的组播配置实验基于eNSP的组播配置实验基于eNSP的组播配置实验基于eNSP的组播配置实验基于eNSP的组播配置实验
  • 华为multicast简单配置

    万次阅读 2016-09-21 00:36:49
    session 1 三层组播简单配置 一、配置PIM-Dense Mode 密集模式 首先搭建底层igp协议,全网使用ospf协议area0区域(IGP部分省略)配置路由可达 在AR1上的配置 [AR1]multicast routing-enable 全局开启组播 [AR1]...

    session 1 三层组播简单配置

    一、配置PIM-Dense Mode 密集模式


    首先搭建底层igp协议,全网使用ospf协议area0区域(IGP部分省略)配置路由可达

    在AR1上的配置

    [AR1]multicast routing-enable                                             全局开启组播

    [AR1]interface g0/0/0

    [AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24

    [AR1-GigabitEthernet0/0/0]pim dm                                     接口下使用dm模式

    [AR1-GigabitEthernet0/0/0]quit

    [AR1-GigabitEthernet0/0/1]ip add 12.1.1.1 24

    [AR1-GigabitEthernet0/0/1]pim dm 

    [AR1-GigabitEthernet0/0/1]quit

    AR2和AR3的配置

    [AR2]multicast routing-enable 

    [AR2]interface g0/0/0

    [AR2-GigabitEthernet0/0/0]ip add 12.1.1.2 24

    [AR2-GigabitEthernet0/0/0]pim dm 

    [AR2-GigabitEthernet0/0/0]quit

    [AR2-GigabitEthernet0/0/1]ip add 172.16.1.1 24

    [AR2-GigabitEthernet0/0/1]igmp enable                                 连接用户端口启用igmp协议

    [AR2-GigabitEthernet0/0/1]igmp static-group 225.1.1.3        用端口模拟PC加入组225.1.1.3

    [AR2-GigabitEthernet0/0/1]quit

    [AR1]display pim interface 
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
     GE0/0/0             up    0      30         1          192.168.1.1     (local)
     GE0/0/1             up    1      30         1          12.1.1.2       
    [AR1]

    二、配置PIM-Sparse Mode 密集模式

    1、ASM模型,其中AR1为RP和BSR


    首先搭建底层igp协议,全网使用ospf协议area0区域(IGP部分省略)配置路由可达

    在AR1上的配置

    [AR1]multicast routing-enable                                             全局开启组播

    [AR1]interface g0/0/0

    [AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24

    [AR1-GigabitEthernet0/0/0]pim sm                                     接口下使用sm模式

    [AR1-GigabitEthernet0/0/0]quit

    [AR1-GigabitEthernet0/0/1]ip add 12.1.1.1 24

    [AR1-GigabitEthernet0/0/1]pim sm 

    [AR1-GigabitEthernet0/0/1]quit

    [AR1]acl 2999                                     创建acl2999,匹配225.1.1.3这个组播组

    [AR1-acl-basic-2999]rule permit source 225.1.1.3 0.0.0.0

    [AR1-acl-basic-2999]quit

    [AR1]pim

    [AR1-pim]c-rp g0/0/0 group-policy 2999 priority 255    使用acl限制RP为225.1.1.3组服务,优先级为255,默认为0最低

    [AR1-pim]c-bsr g0/0/0           指定C-BSR所在接口的位置  (全网就一个C-BSR所以肯定会选举为BSR,C-RP同理)

    [AR1-pim]c-bsr group 225.1.1.0 24 priority 255        指定BSR服务的组和选举优先级,默认是0最低

    [AR1-pim]quit

    [AR1]interface g0/0/0

    [AR1-GigabitEthernet0/0/0]pim bsr-boundary            指定BSR组播域的边界接口(一般都是连接源的接口)

    [AR1-GigabitEthernet0/0/0]quit

    AR2和AR3的配置相同

    [AR2]multicast routing-enable 

    [AR2]interface g0/0/0

    [AR2-GigabitEthernet0/0/0]ip add 12.1.1.2 24

    [AR2-GigabitEthernet0/0/0]pim sm 

    [AR2-GigabitEthernet0/0/0]quit

    [AR2-GigabitEthernet0/0/1]ip add 172.16.1.1 24

    [AR2-GigabitEthernet0/0/1]igmp enable                               连接用户端口启用igmp协议

    [AR2-GigabitEthernet0/0/1]igmp static-group 225.1.1.3        用端口模拟PC加入组225.1.1.3

    [AR2-GigabitEthernet0/0/1]pim silent                                   接口禁止收发PIM协议(因为是连接用户的接口,怕被冒牌邻居攻击,不影响IGMP)

    [AR2-GigabitEthernet0/0/1]quit

    2、SSM模型,无需RP和BSR

    首先搭建底层igp协议,全网使用ospf协议area0区域(IGP部分省略)配置路由可达

    在AR1上的配置
    [AR1]multicast routing-enable                                             全局开启组播
    [AR1]interface g0/0/0
    [AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
    [AR1-GigabitEthernet0/0/0]pim sm                                     接口下使用sm模式
    [AR1-GigabitEthernet0/0/0]quit
    [AR1-GigabitEthernet0/0/1]ip add 12.1.1.1 24
    [AR1-GigabitEthernet0/0/1]pim sm 
    [AR1-GigabitEthernet0/0/1]quit
    [AR1]acl 2999                                     创建acl2999,限定225.1.1.3这个组播组
    [AR1-acl-basic-2999]rule permit source 225.1.1.3 0.0.0.0
    [AR1-acl-basic-2999]quit

    [AR1]pim

    [AR1-pim]ssm-policy 2999                  限定SSM模型使用的组播组范围是225.1.1.3这个组

    [AR1-pim]quit

    AR2和AR3的配置相[AR1-vlan10]multicast-vlan enable同

    [AR2]multicast routing-enable 

    [AR2]interface g0/0/0

    [AR2-GigabitEthernet0/0/0]ip add 12.1.1.2 24

    [AR2-GigabitEthernet0/0/0]pim sm 

    [AR2-GigabitEthernet0/0/0]quit

    [AR2-GigabitEthernet0/0/1]ip add 172.16.1.1 24

    [AR2-GigabitEthernet0/0/1]igmp enable                                连接用户端口启用igmp协议

    [AR2-GigabitEthernet0/0/1]igmp version 3

    [AR2-GigabitEthernet0/0/1]igmp static-group 225.1.1.3        用端口模拟PC加入组225.1.1.3

    [AR2-GigabitEthernet0/0/1]pim silent                                     接口禁止收发PIM协议(因为是连接用户的接口)

    [AR2-GigabitEthernet0/0/1]quit

    [AR2]acl 2999                                     创建acl2999,限定225.1.1.3这个组播组
    [AR2-acl-basic-2999]rule permit source 225.1.1.3 0.0.0.0
    [AR2-acl-basic-2999]quit

    [AR2]pim

    [AR2-pim]ssm-policy 2999                  限定SSM模型使用的组播组范围是225.1.1.3这个组

    [AR2-pim]quit

    [AR2]acl 3999                                      创建acl3999,限定用户只能接受源192.168.1.100发往组225.1.1.3的报文
    [AR2-acl-basic-2999]rule permit source 192.168.1.100 0 destination 225.1.1.3 0    
    [AR2-acl-basic-2999]quit

    [AR2]interface g0/0/1

    [AR2-GigabitEthernet0/0/1]pim join-policy ssm 3999        (这里ssm改成sm再加上rp和bsr就是SFM模型了

    [AR2-GigabitEthernet0/0/1]quit
    检查命令

    [AR2]display pim interface


    session 2 二层组播简单配置


    一、IGMP Snooping基本功能

    IGMP Snooping(IGMP监听),这个功能就是让交换机有了能够查看三层的IGMP报文的功能(本来二层交换机是没能力看懂三层报文的),通过查看IGMP报文从而知道这个报文中的组地址对应的自己的哪些端口,从而知道了这些端口下的主机是该组的成员,可以帮助组成员进行组播流量的收发,否则不启用IGMP Snooping功能交换机就不知道组播地址225.1.1.1对应的MAC地址是哪个也就没法知道去往225.1.1.1的流量从哪个端口转发出去,从而进行泛红转发(可能有些交换机不支持组播泛红转发所以不通),因为组播地址对应的MAC不会在交换机的任意端口上的,所以需要使IGMP Snooping功能将端口和组播组225.1.1.1做一个静态的映射,让交换机知道去往225.1.1.1的组播流量都应该从哪些端口去转发而已。

    AR上配置

    [AR]multicast routing-enable                                                  开启组播功能

    [AR]interface g0/0/0
    [AR-GigabitEthernet0/0/0]ip add 12.1.1.1 255.255.255.0          
    [AR-GigabitEthernet0/0/0]pim sm                                      使用pim sparse-mode模式

    [AR]pim                                                                                 进入pim协议配置

    [AR-pim]static-rp 12.1.1.1 2000 preferred                            指定静态rp为12.1.1.1并只ACL2000中匹配的组播组地址服务,preferred参数用于让静态RP优先于动态RP

    [AR-pim]c-bsr g0/0/0                                                              指定候选bsr和候选rp为g0/0/0口(配置动态RP为了和静态RP做冗余)

    [AR-pim]c-rp g0/0/0



    SW1上配置

    [SW1]vlan 20

    [SW1]igmp-snooping enable                                                  全局v开启igmp-snooping功能
    [SW1]igmp-snooping enable vlan 20                                      vlan开启igmp-snooping功能
    [SW1]

    [SW1]interface g0/0/1

    [SW1-GigabitEthernet0/0/1]port link-type access 

    [SW1-GigabitEthernet0/0/1]port default vlan 20

    [SW1-GigabitEthernet0/0/1]igmp-snooping static-router-port vlan 20         指定接口g0/0/1在vlan20中为组播的路由接口(连接组播路由器的上行接口)

    [SW1-GigabitEthernet0/0/1]quit

    [SW1]interface g0/0/2

    [SW1-GigabitEthernet0/0/2]port link-type trunk 

    [SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan 20

    [SW1-GigabitEthernet0/0/2]l2-multicast static-group group-address 225.1.1.1 vlan 20        指定接口g0/0/2在vlan20中为组播组225.1.1.1的成员端口(该端口下的PC可以收发到组225.1.1.1的组播流量)


    sw2上的配置

    [SW2]vlan 20

    [SW2]igmp-snooping enable 
    [SW2]igmp-snooping enable vlan 20
    [SW2]

    [SW2]interface g0/0/1
    [SW2-GigabitEthernet0/0/1]

    [SW2-GigabitEthernet0/0/1]port link-type trunk 

    [SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan 20

    [SW2-GigabitEthernet0/0/1]igmp-snooping static-router-port vlan 20

    [SW2-GigabitEthernet0/0/1]q

    [SW2]interface g0/0/2
    [SW2-GigabitEthernet0/0/2]port link-type access 

    [SW2-GigabitEthernet0/0/2]port default vlan 20

    [SW2-GigabitEthernet0/0/2]l2-multicast static-group group-address 225.1.1.1 vlan20

    [SW2-GigabitEthernet0/0/2]quit

    [SW2]interface g0/0/3
    [SW2-GigabitEthernet0/0/3]port link-type access 

    [SW2-GigabitEthernet0/0/3]port default vlan 20

    [SW2-GigabitEthernet0/0/3]l2-multicast static-group group-address 225.1.1.1 vlan20

    [SW2-GigabitEthernet0/0/3]quit

    查看配置结果:
    [AR]display pim interface 
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
     GE0/0/0             up            0      30           1             12.1.1.1          (local)                 //RD的ip是12.1.1.1
    [AR]
    [AR]display pim rp-info 225.1.1.1
     VPN-Instance: public net
     BSR RP Address is: 12.1.1.1
         Priority: 0
         Uptime: 00:16:11
         Expires: 00:02:19
      Static RP Address is: 12.1.1.1
     RP mapping for this group is: 12.1.1.1 (local host)
    [AR]

    [SW1]display igmp-snooping router-port vlan 20                               查看组播路由接口(连接PIM路由器的接口)
     Port Name                       UpTime        Expires       Flags       
     ---------------------------------------------------------------------
     VLAN 20, 1 router-port(s)
     GE0/0/1                         00:13:51      --            STATIC | DYNAMIC
    [SW1]display igmp-snooping port-info vlan 20                                  查看组成员接口,G0/0/2在组225.1.1.1中,vlan20
     -----------------------------------------------------------------------
                         (Source, Group)  Port                          Flag
      Flag: S:Static     D:Dynamic     M: Ssm-mapping                       
     -----------------------------------------------------------------------
     VLAN 20, 1 Entry(s)
                          (*, 225.1.1.1)  GE0/0/2                       S-- 
                                              1 port(s)
     -----------------------------------------------------------------------
    [SW1]
    [SW1]display l2-multicast forwarding-table vlan 20
    VLAN ID : 20, Forwarding Mode : IP
    ----------------------------------------------------------------------
                         (Source, Group)    Interface             Out-Vlan
    ----------------------------------------------------------------------
                             Router-port    GigabitEthernet0/0/1     20                        对应了路由接口
                          (*, 225.1.1.1)       GigabitEthernet0/0/1     20                       这两个对应了组接口
                                                   GigabitEthernet0/0/2     20   
    ----------------------------------------------------------------------
    Total Group(s) : 1
    [SW1]


    [SW2]display igmp-snooping router-port vlan 20
     Port Name                       UpTime        Expires       Flags       
     ---------------------------------------------------------------------
     VLAN 20, 1 router-port(s)
     GE0/0/1                         00:06:18      --            STATIC      
    [SW2]

    [SW2]display igmp-snooping port-info vlan 20
     -----------------------------------------------------------------------
                         (Source, Group)  Port                          Flag
      Flag: S:Static     D:Dynamic     M: Ssm-mapping                       
     -----------------------------------------------------------------------
     VLAN 20, 1 Entry(s)
                          (*, 225.1.1.1)  GE0/0/2                       S-- 
                                          GE0/0/3                       S-- 
                                                    2 port(s)
     -----------------------------------------------------------------------
    [SW2]

    [SW2]display l2-multicast forwarding-table vlan 20
    VLAN ID : 20, Forwarding Mode : IP
    ----------------------------------------------------------------------
                         (Source, Group)    Interface             Out-Vlan
    ----------------------------------------------------------------------
                             Router-port    GigabitEthernet0/0/1     20   
                          (*, 225.1.1.1)    GigabitEthernet0/0/1     20   
                                            GigabitEthernet0/0/2     20   
                                            GigabitEthernet0/0/3     20   
    ----------------------------------------------------------------------
    Total Group(s) : 1
    [SW2]


    二、IGMP SSM

    [sw]igmp-snooping enable

    [sw]vlan 10

    [sw-vlan10]igmp-snooping enable

    [sw-vlan10]igmp-snooping version 3

    [sw-vlan10]igmp-snooping ssm-mapping enable

    [sw-vlan10]igmp-snooping ssm-mapping 225.1.1.3 0 192.168.1.100      将组播源与组进行绑定映射关系,构建(S,G)表项

    客户端设备只需要配置IGMPv1、v2即可

    三、组播vlan的配置


    [lsw2]igmp-snooping enable 

    [lsw2-vlan10]igmp-snooping enable 

    [lsw2-vlan10]multicast-vlan enable       启用组播vlan功能

    [lsw2-vlan10]multicast-vlan user-vlan 20 30      在组播vlan10下绑定要复制组播流量去的vlan20 30

    检测命令:

    [AR1]display multicast-vlan vlan


    展开全文
  • 为数通网络专业人员提供一份华为数通产品“常用特性典型配置”和“一些的综合部署典型配置”的快速参考指南,是本配置实例集的写作目的。 这个版本V2.0在2007年发布的V1.0的基础上增加了组播和QoS部分的案例,使...
  • 使用华为ENSP模拟器验证IGMP基本功能,附上幕布笔记链接 https://share.mubu.com/doc/HwPI4xfDPn

    使用华为ENSP模拟器验证IGMP基本功能,附上幕布笔记链接

    https://share.mubu.com/doc/HwPI4xfDPn

    展开全文
  • 最新的华为设备维修工具,可打开目前所有华为设备的维修模式,telnet ftp等。可辅助光猫超级用户密码破解等
  • 华为交换配置案例

    2018-04-22 21:26:00
    三层交换机组播配置.................................................................................................................41 中低端交换机DHCP-RELAY配置 ..........................................
  • 带你走进华为组播IGMP 简单易懂

    万次阅读 多人点赞 2021-03-25 13:20:23
    作用:IGMP用来在接收者主机和与其直接相邻的组播路由器之间建立和维护组播组成员关系。 IGMP snooping 的作用是减少组播流量的泛洪。

    哈喽,大家好!我是艺博东 ,一个思科出身专注于华为的网工;好了,话不多说,我们直接进入正题。

    IGMP

    分析lGMP协议的作用,各版本之间的差异

    作用:IGMP用来在接收者主机和与其直接相邻的组播路由器之间建立和维护组播组成员关系。IGMP通过在接收者主机和组播路由器之间交互IGMP报文实现组成员管理功能,IGMP报文封装在IP报文之上,协议号为2。

    lGMPv1

    1.查询器 PIM-DR
    查询器的选举:1.优先级越大越优;如果优先级一样;就比较IP地址,IP地址大的优选。

    2.普遍组查询报文
    由组播路由器发出,报文发送的目的地址为224.0.0.1,周期性发,每60S发送一次。

    3.成员报告报文
    接收者发出,用于表明加入那个组播组中;第一次加组,MRT超时(10S)

    4.成员抑制
    随机响应时间小于等于10S(MRT),谁先超时,谁先发。

    5.离组机制(组成员离开机制)
    静默离开(130S,120+10 两次普遍组查询报文+MRT),130S无主机回应,删除该组表项。

    lGMPv2

    1.查询器
    自己选,选择IP地址小的

    2.普遍组查询报文
    同V1由组播路由器发出,报文发送的目的地址为224.0.0.1,周期性发,每60S发送一次。

    3.成员报告报文
    同V1接收者发出,用于表明加入那个组播组中;第一次加组,MRT超时(10S)

    4.成员抑制
    MRT默认为10S,可改动(1-25S)

    5.离组机制
    发leave报文,组地址 离开那个组目的地址就是那个组。
    特定组查询机制,查看有无成员;如果有成员,就继续转发组播流量;如果无成员,就不用转发组播流量。只有last-reporter发送的离开报文才会触发特定组查询机制。

    6.last-reporter
    目的就是用于减少,leave报文、特定组查询报文、成员报告报文

    lGMPv3

    1.查询器
    同V2自己选,选择IP地址小的

    2.普遍组查询报文
    同V2由组播路由器发出,报文发送的目的地址为224.0.0.1,周期性发,每60S发送一次。

    3.报告机制

    报文:
    加组信息,还有源信息;
    六种组记录,
    ① Mode is include 加那个组,发一个报告报文 group 225.1.1.1 S 100.1.1.1 200.1.1.1
    ② Mode is exclude group 225.1.1.1 S 100.1.1.1 200.1.1.1 就这两个S不接收,其他的接受
    ③ Change to include mode 3、4模式改变
    ④ Change to exclude mode 3、4模式改变
    ⑤ Allow new source 增加 group 225.1.1.1 S 100.1.1.1 200.1.1.1 100.1.1.2 在原来的基础上加 100.1.1.2这个地址
    ⑥ Bloking old source 删除 group 225.1.1.1 S 100.1.1.1 200.1.1.1 100.1.1.1 把100.1.1.1这个地址删除

    4.无leave报文
    5.无成员抑制

    IGMPv3没有定义专门的成员离开报文,成员离开通过特定类型的报告报文来传达。
    IGMPv3成员离开通过发送加入组播源地址列表为空的成员报告报文来表示离开。

    IGMP Snnoping

    IGMP Snooping的机制?不同proxy有什么不同?snooping有什么缺点?snooping检查所有组播报文?如何做到的?

    (1)IGMP Snnoping的作用

    IGMP snooping 的作用是减少组播流量的泛洪;当PC1加组225.1.1.1,上面的路由器会泛洪下来,二层MAC是组播MAC,交换机收到这二层组播MAC数据流的时候会进行泛洪,泛洪给PC1,同时也会泛洪PC2、PC3;PC2、PC3即使没有加组也会收到组播数据流。为了解决这个问题在交换机上开启 IGMP snooping ,开启了之后可以监听路由和主机IGMP的相关的报文,普遍组查询报文,报告报文,通过监听这些报文,就可以得知PC1加组是这个组,PC2、PC3没有加组,收到这个组的组播流的时候,只转发给PC1,不转发给PC2、PC3。就可以减少组播流量的泛洪,这个就是IGMP snooping的作用。

    在这里插入图片描述

    (2)IGMP Snooping 的两种端口角色

    1.路由器端口角色:
    1)通过侦听IGMP普遍组查询报文或 PIM HELLO报文来感知哪些接口是路由器端口。从上面收到的普遍组查询报文或 PIM HELLO报文就认为这个接口(S的G0/0)为路由器端口。
    2)通过手工指定路由器端口。

    进入VLAN视图。

    (可选)执行命令undo igmp-snooping router-learning,禁止动态学习路由器端口。
    缺省情况下,VLAN的路由器端口动态学习功能处于使能状态。

    2.成员端口:
    1)收到IGMP report报文的接口将被认为是动态成员端口。从下面主机收到的成员报告报文的接口就成为成员端口(S的G0/1)
    2)手工配置成员端口

    进入接口视图

    (可选)执行命令undo igmp-snooping learning vlan { { vlan-id1 [ to vlan-id2 ] } &<1-10> | all },禁止动态学习组播成员端口。
    缺省情况下,成员端口动态学习功能处于使能状态。禁止动态学习组播成员端口功能之后,如果要完成组播数据的转发,接口只能静态加入组播组。

    (3)IGMP snooping的工作机制

    1.普遍组查询报文:同VLAN内泛洪(IGMP三层报文,三层报文进来这个接口会打vlan标签 S的G0/0接口)
    2.Report:记录加组信息,向路由端口转发
    3.Leave报文:向路由器转发
    4.特查报文:向该组成员接口转发

    (4)IGMP Snooping的缺点有哪些?

    [R1] vlan 100
    [R1-vlan100] igmp-snooping enable  //命令用来使能VLAN内的IGMP Snooping功能
    

    1.CPU和内存开销问题,CPU需要处理IGMP报文来维护二层组播转发表,如果交换机下的组很多的话,二层组播转发表需要占用的内存也是相当大的。
    2.如果在不能识别IGMP报文的二层交换机上打开igmp snooping会监听所有的组播报文,并且会把这些组播报文全部送给CPU处理,会加重CPU的负载。

    在这里插入图片描述
    (5)IGMP snooping proxy

    [R1] vlan 100
    [R1-vlan100] igmp-snooping enable  //命令用来使能VLAN内的IGMP Snooping功能
    [R1-vlan100] igmp-snooping proxy   //命令用来使能VLAN内的IGMP Snooping Proxy功能
    

    在这里插入图片描述

    背景

    路由器是不需要关心下面哪些主机加组,它只关心有没有加组就行。一个加组,两个加组,三个加组,对于它来说是不影响的。但这个时间R收到大量报文,这是没必要的。所以在snooping上开启代理机制,使得路由器减少报告报文的接收。S作为中间代理人,对于R来说S是一个成员,它对于主机来说是一个查询器,就可以减少report的发送。

    工作机制
    1.普遍组查询报文:向VLAN内泛洪,主动回复report
    2.Reort:维护组表项(不老化);特例的情况会老化,新表项建立时转发
    3.Leave:发特查(主机发leave报文,S向下发特查报文,删组时向上发leave报文的)
    4.特查报文:根据主表项应答 回report报文;有组表项就回应答,没有就不用管。

    交换机作为中间人,PC相当于各个成员,它负责把各个成员信息汇总发给R。

    PIM

    (1)建SM邻居

    建立邻居的过程同PIM-DM一致,协商参数、报文格式类型也完全一致。DR竞选规则也一致。

    [R2]multicast routing-enable 
    [R2]pim 
    [R2-pim]int g0/0/1
    [R2-GigabitEthernet0/0/1]pim dm
    

    (2)RP发现

    首先RP的位置

    1)每一个组播组只能存在一个RP
    2)RP的地址必须要全网可达,能通过IGP协议实现访问(建立RPT树)
    3)RP所在的接口地址必须要运行PIM SM

    成为RP的方式:

    手工指定:

    (配置:在PIM视图下,static-rp 10.1.12.2)
    1.每个组播路由器都需要配置
    2.没有冗余备份

    动态发现:

    1.不需要每台组播路由器配置RP,可以自动学习到RP
    2.有冗余备份,一个组播组可以配置多个C-RP,一个主多个备份
    (配置:在PIM视图下, c-rp loopback 0 group-policy 2000 priority 10 #acl为2000)
    在PIM视图下,c-bsr gigabitethernet1/0/0

    在这里插入图片描述

    (3)构建RPT树

    由成员端DR向RP发送Join消息在通向RP的路径上逐跳创建 (*,G) 表项,生成以一棵以RP为根的RPT;
    (*,G) 表项是由收到成员报告或者收到join报文而创建的。
    上游接口是根据RP的地址路由得到的;
    下游接口是根据收到的join报文或者成员报告报文的接口确定的;

    (4)构建SPT树

    由组播源端DR向RP沿途创建(S,G)表项;
    组播源发送正常组播流;
    组播源端DR收到后,创建(S,G)表项,并将组播数据进行封装成注册报文,单播发给RP;
    RP收到注册报文后,解封装将组播源数据发送下去;同时,向组播源端DR发送join报文;
    RP到组播源端DR沿途创建(S,G)表项;
    RP继续向组播源端DR单播发送注册停止报文,让组播源端DR不再发送注册报文;

    RP上游接口是根据收到注册消息的接口成为上游接口;
    RP下游接口根据(*,G)表项下游接口复制而来;

    (5)SPT树的切换

    [AR1pim
    [AR1-pim]spt-switch-threshold 1000 
    //开启SPT切换,阈值为1000,当AR1组播的速率到达每秒1000的时候就开始spt切换,默认为0
    

    作用

    1)组播源到接收者走的是最优的路径
    2)减轻RP的负担

    切换的过程

    1)当最后一跳路由器的DR组播流达到一定的阈值,会向组播源的方向发出(S,G)的join的消息;

    2)当上游路由器收到(S,G)的join消息,会将(S,G)的flag位切换为SPT置位,上游接口为离组播源最近的接口,下游接口为接收(S,G)的join消息接口,并且继续往组播源的方向发(S,G)的join消息,建立SPT树;

    3)当遇到分叉点的组播路由器收到两份组播流,会触发(S,G)RPT置位的剪枝报文,朝RP方向进行发送,作用是为了删除掉RPT树上(S,G)的下游接口。

    情商:是指人在情绪,意志,耐受,挫折等方面的品质。 有十条标准!1.热情和激情,2.包容和宽容,3.沟通与交流,4.真诚赞美别人,5.保持好情绪,6.聆听是好习惯,7.有责任心,8.每天进步一点点,9.用心对待他人,10不抱怨,不指责。


    在这里插入图片描述
    好了这期就到这里了,如果你喜欢这篇文章的话,请点赞评论分享收藏,如果你还能点击关注,那真的是对我最大的鼓励。谢谢大家,下期见!

    展开全文
  • 华为PIM-SSM配置实例

    2021-06-29 19:59:51
    本文主要介绍了PIM SSM模式的... (三)配置完成后效果展示 查看PIM路由表 使用组播播放四个视频(我们的两个组播源播放两个不同的视频,组播接受者也只接受该组播源所发送的视频流量): 原创不易,转载请注明地址:...
  • 本文主要介绍组播功能在具体组网中的应用配置,包括以下两种典型组网应用: 域内的二、三层组播应用情况,以及域间的三层组播应用情况
  • 华为路由器配置实例

    万次阅读 2018-05-18 09:32:08
    #sysname GZ //路由器名字GZftpserver enable //ftp 服务开通以便拷贝出配置文件备份#voice#http server port 1025  //httpundo ...
  • 此前实验发现,组播服务经过MPLS XXX后就各路由器组播流量无法发送与接收,网上查阅相关资料后未发现满意结果,在平哥,松哥以及本人的共同研究下,将此实验完成。 现将实验配置方法贴出,如有不足之处,欢迎评论私...
  • 华为交换机组IGMP Snooping配置教程(一): http://www.023wg.com/Multicast/230.html 华为交换机组IGMP Snooping配置教程(二): http://www.023wg.com/Multicast/231.html?TPWlanWarnChecked=0 S5700S...
  • 华为路由器配置OSPF实例

    万次阅读 多人点赞 2016-07-26 13:44:37
     ospf的组播地址:224.0.0.5(所有路由器发送hello选举DR/BDR,后DB统一下发LSU给其他路由器)、224.0.0.6(DR监听其他路由器发的LSU)  ospf中DR/BDR不具备抢占机制,为了稳定性已经成为DR的路由器不会因为...
  • 华为 组播之IGMPv2、IGMPv3

    万次阅读 多人点赞 2020-12-23 10:50:33
    报文有2种发送机制: 1、只要主机离,就发送离报文。 2、只有本轮查询的报告者离时,由报告者发送离报文,本轮的非报告者离不会送离报文,静默离
  • IPV6组播配置案例

    千次阅读 2020-02-18 10:10:52
    案例配置拓扑: 案例配置需求: 1、 互联IP为CC1E:XY::/64 EUI 64,Loopback 0的IP为CC1E:XXXX::X/64,其中X为本设备ID;...4、 通过配置,使得R3的F0/0能接收来自组FF08::1的组播信息; 案例配置思路: ...
  • 华为路由器BGP路由配置实例

    万次阅读 多人点赞 2016-07-28 13:47:07
    mpls和ipv4-mdt等子地址族,ipv6地址族下有ipv6单播和ipv6组播等子地址族,在哪个(子)地址族模式下配置的就只能影响该地址族,而在BGP全局下配置的影响所有地址族。  igp路由选择使用metric,而bgp中使用路由...
  • 网络组播配置案例

    2012-02-24 13:47:00
    主要讲述基于VLAN的静态二层组播示例,基于华为s9300核心交换机。
  • 1、解决二层组播解析 2、实验拓扑 3、基础配置 IOU1配置 ip multicast-routing interface Ethernet0/0 ip address 192.168.1.1 255.255.255.0 ip pim sparse-mode IOU3配置 interface Ethernet0/0 ip add...
  • 80EV600R003C00SPCa00(LPUF-21板卡支持组播***)公网PIM-SSM+M×××(BGP-AD)私网PIM-SM(staticRP)一、开启组播组播×××功能multicastrouting-enablemulticast-***slot6multicastload-splittinggroup...
  • 六、通过VGMP实现VRRP备份的统一管理 七、双机热备的配置 八、总结 一、双机热备是什么? 1、双机热备的作用 多台设备运行双机热备; 一台设备故障其他设备接替工作; 增强网络稳定性; 保证业务的连续性; ...
  • OSPFv3配置实例

    2021-07-25 20:21:01
    本文使用华为eNSP模拟器,针对一种实际场景进行了OSPFv3的简要配置。 阅读本文,您需要有一定的IPv6和OSPFv2、OSPFv3基础,如果您对此还存在困惑,欢迎查阅我的博客,相信您一定会有所收获。 一、实验要求及拓扑 ...
  • 华为DHCP中继配置

    千次阅读 多人点赞 2019-06-02 12:01:48
    以R1作为DHCP服务器,三层交换机作为DHCP中继设备,创建两个接口将它们接入到不同的vlan,在vlanif10和vlanif20配置两个网段的网关,且使能DHCP中继,使用rip协议互通。 DHCP服务器R1配置 [ R1 ] dhcp enable ...
  • 华为交换机配置

    万次阅读 多人点赞 2018-06-23 16:36:23
    华为交换机型号左侧:右侧:2 配置3 命令操作4 常见功能参考: http://network.51cto.com/art/201001/177448.htm史上最全华为路由器交换机配置命令大合集,熟练掌握下面的华为路由器交换机配置知识,你只需...
  • 华为交换机IPv6配置案例

    千次阅读 2020-01-09 14:38:38
    学点芝士 | IPv6系列之“相遇” IPv6(Internet Protocol Version 6)是...它是Internet工程任务IETF(Internet Engineering Task Force)设计的一套规范,是IPv4(Internet Protocol Version 4)的升级版本。IPV6...
  • 华为5700设置某一端口组播屏蔽

    千次阅读 2016-03-11 21:11:59
    实例中以屏蔽 GigabitEthernet0/0/6 的UDP为例,亲测通过。 [Quidway] [Quidway]acl 3000  [Quidway-acl-adv-3000]rule 5 deny udp [Quidway-acl-adv-3000]quit [Quidway] Oct 1 2008 07:54:02-05:13...
  • 所谓的双机热备无非就是以7X24小时不中断的为企业提供服务为目的,各种双机热备的技术很多,那么华为使用了这个共有协议的热备协议——VRRP。 华为的双机热备是通过部署两台或多台防火墙实现热备及负载均衡,两台...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,478
精华内容 591
关键字:

华为组播配置实例