精华内容
下载资源
问答
  • 思科交换机常用指令
    千次阅读
    2020-11-23 12:19:39

    title: 思科交换机常用指令(持续更新)
    tags: 教程
    author: caijinbo
    date: 2019-11-19

    思科交换机常用指令

    vlan设置

    console>enable    //进入特权模式
    console#configure      //进入配置视图
    console(config)#vlan database     //进入vlan配置
    console(config-vlan)#vlan 2   //创建vlan2
    console(config-vlan)#no vlan 2      //删除vlan 2
    console(config-vlan)#exit    //退回到特权模式下
    console(config)#interface vlan 2      //进入vlan2的配置视图
    console(config-if-vlan2)#name xxx    //为vlan2修改名字
    

    端口配置

     console(config)#interface ethernet 1/g1    //进入网口1,/1/g1指的是第一个插槽上的第一个千兆网口
    console(config-if-1/g1)#     //接口视图模式
    console(config-if-1/g1)# speed 10/100/1000      //定义端口的带宽,只能从这三种模式中做选择。
    console(config-if-1/g1)# duplex full/half     //定义双工模式
    console(config-if-1/g1)# negotiation    //启用自动协商速度和双工参数
    console(config-if-1/g1)# no negotiation  //禁用自动协商速度和双工参数
    console(config-if-1/g1)# switchport mode access/trunk/general       //定义端口类型,总共有三种类型
    console(config-if-1/g1)# switchport access vlan 2     //将端口以access模式加入到vlan 2 中
    console(config-if-1/g1)# shutdown     //关闭当前端口
    console(config-if-1/g1)# no shutdown       //打开当前端口
    console(config)#interface   ethernet 1/g24        //进入汇聚千兆口24,共有四个千兆combo口21-24
    console(config-if-1/g24)#      //接口视图模式
    console(config-if-1/g24)#duplex  auto/full/half      //设置端口工作模式为 自适应/全双通/半双通
    console(config-if-1/g24)#switchport mode trunk      //设置当前端口模式为汇聚口
    console(config-if-1/g24)#switchport mode access    //设置当前端口模式为接入模式
    console(config-if-1/g24)#switchport trunk allowed vlan add/remove 1,2     //将当前汇聚端口加入或移除从vlan 1 ,2通过,vlan修剪,默认为all,全部允许
    console(config-if-1/g24)#switchport access vlan 2    //将当前端口以access模式加入到vlan2 中
    
    若21-24号口用作光口的话,配置接口就对应1/xg1-1/xg4代表使用光纤做10G上联口用:
    console(config)#interface ethernet 1/xg1       //进入汇聚万兆口1,共有4个千兆combo口21-24对应四个1/xg1-1/xg4万兆光口
    console(config-if-1/xg1)#
    console(config-if-1/xg1)#duplex auto/full/half      //设置端口工作模式为  自适应/全双通/半双通
    console(config-if-1/xg1)#switchport mode trunk   //设置当前端口模式为汇聚口
    console(config-if-1/xg1)#switchport mode access  //设置当前端口模式为接入模式
    console(config-if-1/xg1)#switchport trunk allowed vlan add/remove  1,2    //将当前汇聚端口加入或移除从vlan1,2通过,vlan修剪,默认为all,全部允许
    console(config-if-1/xg1)#switchport access vlan 2  //将当前端口以access模式加入vlan2中
    

    将单个端口加入vlan

    console(config)#interface ethernet 1/g1
    console(config-if-1/g1)#switchport mode access 
    console(config-if-1/g1)#switchport access vlan 2
    

    将多个端口加入到vlan中

    console(config)#interface range ethernet 1/g1-1/g12     //进入1-12这个接口组里配置
    console(config-if)#switchport mode access
    console(config-if)#switchport access vlan 2
    
    console#show vlan    //用于查看配置后结果
    

    设置VTP
    cisco专有的vlan终级协议也成为局域网干道协议,作用是十几台交换机在企业网中,配置vlan工作量大,可以使用VTP协议,把一台交换机配置成VTP server,其余交换机配置成VTP client,这样他们可以自动学习到server上的vlan信息

    交换机配置IP地址

    console(config)#interface vlan 1       //进入vlan1
    console(config-if-vlan1)#ip address 119.167.223.221 255.255.255.128  //设置交换机的管理ip地址
    console(config)#ip default-gateway 119.167.223.254    //设置交换机的默认网关
    console(config)#end     //退出当前模式
    

    交换机保存设置命令

    console#copy running-config startup-config    //将当前正在使用中的配置保存到交换机开机需要加载的配置文件里去。
    console#copy running-config backup-config      //将当前的配置保存到备份配置文件里
    

    交换机显示命令
    特权模式下:

    console#show running-config    //显示当前正在使用的配置信息
    console#show startup-config    //显示交换机开机时自动加载的配置文件
    console#show vlan    //显示vlan的配置信息
    console#show interfaces configuration ethernet 1/g1       //显示二层端口状态,可以用来决定此口是否为二层或三层口
    console#show ip interface vlan 100    //查看交换机vlan100的IP配置信息
    console#show version    //查看交换机固件版本信息
    

    基于端口的mac地址绑定

    console#config  //进入配置视图模式
    console(config)#interface ethernet 1/g1     //进入具体端口视图模式下
    console(config-if-1/g1)#switch port-secruity     //配置端口安全模式
    console(config-if-1/g1)#switchport port-seruity mac-address MAC(主机的mac地址)     //配置该端口要绑定的主机mac地址
    console(config-if-1/g1)# no switchport port-seruity mac-address MAC(主机的mac地址)  //删除绑定主机的mac地址
    

    配置交换机的snmp功能

    console(config)#snmp-server community xxx ro     //xxx为自定义的共同体名称,并且团体的权限为只读
    console(config)#snmp-server host x.x.x.x(ip地址)xxx(团体名)    //设置管理机x.x.x.x同时允许该管理机以团体名xxx访问。
    console(config)#snmp-server enable traps     //启用snmp服务
    

    交换机禁ping配置

    console(config)#access-list 110 deny icmp any any      //配置访问控制列表(Access Control List,ACL)110指的是ICMP对应ping。
    console(config)#access-list 110 permit ip any any   //运行所有的ip协议的应用
    console(config)#int vlan 1
    console(config-if-vlan1)#ip access-group 110 in 
    console(config)#int vlan 2
    console(config-if-vlan2)#ip access-group 110 in
    console(config)#int vlan 3
    console(config-if-vlan3)#ip access-group 110 in
    console(config)#interface ethernet 1/g1     //端口禁ping
    console(config-if-1/g1)#ip access-group 110 in
    

    恢复交换机出厂设置

    console#clear config    //恢复交换机出厂设置
    console#reload     //重新启动交换机
    
      交换机工作于OSI参考模型的第二层,即数据链路层。交换机内部的cpu会在每个端口成功连接时,通过将mac地址和端口对应,形成一张mac表。在今后的通讯中,发往该mac地址的数据包将仅送往其对应的端口,而不是所有的端口。因此,交换机可用于划分链路层广播,即冲突域,但它不能划分网络层广播,即广播域。
     交换机拥有一条很高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的mac(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部交换矩阵迅速将数据包传送到目的端口,目的mac若不存在,广播到所有的端口,接收端口回应后,交换机会“学习”新的mac地址,并把它添加到内部mac地址表中。使用交换机也可以把网络“分段”,通过对照IP地址表,交换机只允许必要的网络流量通过交换机。通过交换机的过滤和转发,可以有效的减少冲突域,但它不能划分网络层广播,即广播域。
    
    更多相关内容
  • cisco思科交换机命令参考大全

    千次阅读 2020-12-10 09:04:14
    1.设置主机名/系统名 IOS:switch(config)# hostname "hostname" CLI:switch(enable) set system name name-string 2.设置登录口令 IOS:switch(config)# enable password level 1 password ...

    1.设置主机名/系统名

    IOS:switch(config)# hostname "hostname"

    CLI:switch(enable) set system name name-string

    2.设置登录口令

    IOS:switch(config)# enable password level 1 password

    CLI:switch(enable) set password

    switch(enable) set enalbepass

    3.设置远程访问

    IOS:switch(config)# interface vlan 1

    switch(config-if)# ip address ip-address netmask

    switch(config-if)# ip default-gateway ip-address

    CLI:switch(enable) set interface sc0 ip-address netmask broadcast-address

    switch(enable) set interface sc0 vlan

    switch(enable) set ip route default gateway

    4.启用和浏览 CDP 信息

    IOS:switch(config-if)# cdp enable

    switch(config-if)# no cdp enable

    CLI:switch(enable) set cdp {enable|disable} module/port

    5.查看 Cisco 邻接设备的 CDP 通告

    IOS:switch# show cdp interface [type modle/port]

    switch# show cdp neighbors [type module/port] [detail]

    CLI:switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

    6.端口描述

    IOS:switch(config-if)#description escription-string

    CLI:switch(enable)set port name module/number description-string

    7.设置端口速度

    IOS:switch(config-if)# speed{10|100|auto}

    CLI:switch(enable) set port speed moudle/number {10|100|auto}

    switch(enable) set port speed moudle/number {4|16|auto}

    8.设置以太网的链路模式

    IOS:switch(config-if)# duplex {auto|full|half}

    CLI:switch(enable) set port duplex module/number {full|half}

    9.配置静态 VLAN

    IOS:switch# vlan database

    switch(vlan)# vlan vlan-num name vla

    switch(vlan)# exit

    switch# configure teriminal

    switch(config)#interface interface module/number

    switch(config-if)# switchport mode access

    switch(config-if)# switchport access vlan vlan-num

    switch(config-if)# end

    CLI:switch(enable) set vlan vlan-num [name name]

    switch(enable) set vlan vlan-num mod-num/port-list

    10.配置 VLAN 中继线

    IOS:switch(config)# interface interface mod/port

    switch(config-if)# switchport mode trunk

    switch(config-if)#switchport trunk encapsulation {isl|dotlq}

    switch(config-if)# switchport trunk allowed vlan remove vlan-list

    switch(config-if)# switchport trunk allowed vlan add vlan-list

    CLI:switch(enable)set trunk module/port [on|off|desirable|auto|nonegotiate]

    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    11.配置 VTP 管理域

    IOS:switch# vlan database

    switch(vlan)# vtp domain domain-name

    CLI:switch(enable) set vtp [domain domain-name]

    12.配置 VTP 模式

    IOS:switch# vlan database

    switch(vlan)# vtp domain domain-name

    switch(vlan)# vtp {sever|cilent|transparent}

    switch(vlan)# vtp password password

    CLI:switch(enable) set vtp [domain domain-name]

    [mode{ sever|cilent|transparent }][password password]

    13.配置 VTP 版本

    IOS:switch# vlan database

    switch(vlan)# vtp v2-mode

    CLI:switch(enable) set vtp v2 enable

    14.启动 VTP 剪裁

    IOS:switch# vlan database

    switch(vlan)# vtp pruning

    CLI:switch(enable) set vtp pruning enable

    15.配置以太信道

    IOS:switch(config-if)# port group group-number [distribution {source|destination}]

    CLI:switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

    16.调整根路径成本

    IOS:switch(config-if)#spanning-tree [vlan vlan-list] cost cost

    CLI:switch(enable)set spantree portcost moudle/port cost

    switch(enable)set spantree portvlancost moudle/port [cost cost][vlan-list]

    17.调整端口 ID

    IOS:switch(config-if)#spanning-tree[vlan vlan-list]port-priority port-priority

    CLI:switch(enable)set spantree portpri {mldule/port}priority

    switch(enable)set spantree portvlanpri {module/port}priority [vlans]

    18.修改 STP 时钟

    IOS:switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

    switch(config)#spanning-tree [vlan vlan-list] forward-time seconds

    switch(config)#spanning-tree [vlan vlan-list] max-age seconds

    CLI:switch(enable) set spantree hello interval[vlan]

    switch(enable) set spantree fwddelay delay [vlan]

    switch(enable) set spantree maxage agingtiame[vlan]

    19.启用或禁用 Port Fast 特征

    IOS:switch(config-if)#spanning-tree portfast

    CLI:switch(enable)set spantree portfast {module/port}{enable|disable}

    20.启用或禁用 UplinkFast 特征

    IOS:switch(config)#spanning-tree uplinkfast [max-update-rate pkts-per-second]

    CLI:switch(enable)set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols

    off|on]

    为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个 IP 地址,然后使用下列命令:

    switch(config)# cluster enable cluster-name

    21. 为了从一条中继链路上删除 VLAN,可使用下列命令:

    switch(enable) clear trunk module/port vlan-range

    22. 用 show vtp domain 显示管理域的 VTP 参数.

    23. 用 show vtp statistics 显示管理域的 VTP 参数.

    24. 在 Catalyst 交换机上定义 TrBRF 的命令如下:

    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

    25. 在 Catalyst 交换机上定义 TrCRF 的命令如下:

    switch (enable) set vlan vlan-num [name name] type trcrf {ring hex-ring-num|decring

    decimal-ring-num} parent vlan-num

    26. 在创建好 TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给 VLAN

    分配端口:

    switch(enable) set vlan vlan-num mod-num/port-num

    27. 命令 show spantree 显示一个交换机端口的 STP 状态.

    28. 配置一个 ELAN 的 LES 和 BUS,可以使用下列命令:

    ATM (config)# interface atm number.subint multioint

    ATM(config-subif)# lane serber-bus ethernet elan-name

    29. 配置 LECS:

    ATM(config)# lane database database-name

    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address

    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address

    ATM(lane-config-databade)# name ...

    30. 创建完数据库后,必须在主接口上启动 LECS.

    命令如下: ATM(config)# interface atm number

    ATM(config-if)# lane config database database-name

    ATM(config-if)# lane config auto-config-atm-address

    31. 将每个 LEC 配置到一个不同的 ATM 子接口上.命令如下:

    ATM(config)# interface atm number.subint multipoint

    ATM(config)# lane client ethernet vlan-num elan-num

    32. 用 show lane server 显示 LES 的状态.

    33. 用 show lane bus 显示 bus 的状态.

    34. 用 show lane database 显示 LECS 数据库可内容.

    35. 用 show lane client 显示 LEC 的状态.

    36. 用 show module 显示已安装的模块列表.

    37. 用物理接口建立与 VLAN 的连接:

    router# configure terminal

    router(config)# interface media module/port

    router(config-if)# description description-string

    router(config-if)# ip address ip-addr subnet-mask

    router(config-if)# no shutdown

    38. 用中继链路来建立与 VLAN 的连接:

    router(config)# interface module/port.subinterface

    router(config-ig)# encapsulation[isl|dotlq] vlan-number

    router(config-if)# ip address ip-address subnet-mask

    39. 用 LANE 来建立与 VLAN 的连接:

    router(config)# interface atm module/port

    router(config-if)# no ip address

    router(config-if)# atm pvc 1 0 5 qsaal

    router(config-if)# atm pvc 2 0 16 ilni

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-mask

    router(config-if)# lane client ethernet elan-num

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-name

    router(config-if)# lane client ethernet elan-name

    router(config-if)# ...

    40. 为了在路由处理器上进行动态路由配置,可以用下列 IOS 命令来进行:

    router(config)# ip routing

    router(config)# router ip-routing-protocol

    router(config-router)# network ip-network-number

    router(config-router)# network ip-network-number

    41. 配置默认路由: switch(enable) set ip route default gateway

    42. 为一个路由处理器分配 VLANID,可在接口模式下使用下列命令:

    router(config)# interface interface number

    router(config-if)# mls rp vlan-id vlan-id-num

    43. 在路由处理器启用 MLSP: router(config)# mls rp ip

    44. 为了把一个外置的路由处理器接口和交换机安置在同一个 VTP 域中:

    router(config)# interface interface number

    router(config-if)# mls rp vtp-domain domain-name

    45. 查看指定的 VTP 域的信息: router# show mls rp vtp-domain vtp domain name

    46. 要确定 RSM 或路由器上的管理接口,可以在接口模式下输入下列命令:

    router(config-if)#mls rp management-interface

    47. 要检验 MLS-RP 的配置情况: router# show mls rp

    48. 检验特定接口上的 MLS 配置:router# show mls rp interface interface number

    49. 为了在 MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:

    set mls flow [destination|destination-source|full]

    50. 为使 MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:

    router(config)# mls rp ip input-acl

    51. 当某个交换机的第 3 层交换失效时,可在交换机的特权模式下输入下列命令:

    switch(enable) set mls enable

    52. 若想改变老化时间的值,可在特权模式下输入以下命令:

    switch(enable) set mls agingtime agingtime

    53. 设置快速老化:switch(enable) set mls agingtime fast fastagingtime pkt_threshold

    54. 确定那些 MLS-RP 和 MLS-SE 参与了 MLS,可先显示交换机引用列表中的内容再确定:

    switch(enable) show mls include

    55. 显示 MLS 高速缓存记录: switch(enable) show mls entry

    56. 用命令 show in arp 显示 ARP 高速缓存区的内容。

    57. 要把路由器配置为 HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:

    router(config-if)# standby group-number ip ip-address

    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:

    router(config-if)# standy group-number preempt

    59. 访问时间和保持时间参数是可配置的:

    router(config-if)# standy group-number timers hellotime holdtime

    60. 配置 HSRP 跟踪:router(config-if)# standy group-number track type-number interface-priority

    61. 要显示 HSRP 路由器的状态:router# show standby type-number group brief

    62. 用命令 show ip igmp 确定当选的查询器。

    63. 启动 IP 组播路由选择:router(config)# ip muticast-routing

    64. 启动接口上的PIM: dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

    65. 启动稀疏-稠密模式下的 PIM:

    router# ip multicast-routing

    router# interface type number

    router# ip pim sparse-dense-mode

    66. 核实 PIM 的配置: dallasr1># show ip pim interface[type number] [count]

    67. 显示 PIM 邻居: dallasr1># show ip neighbor type number

    68. 为了配置 RP 的地址,命令如下:

    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

    69. 选择一个默认的 RP: dallasr1># ip pim rp-address

    通告 RP 和它所服务的组范围:

    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number

    为管理范围组通告 RP 的地址:

    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1

    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255

    设定一个 RP 映像代理:dallasr1># ip pim send-rp-discovery scope ttl

    核实组到 RP 的映像:

    dallasr1># show ip pim rp mapping

    dallasr1># show ip pim rp [group-name|group-address] [mapping]

    70. 在路由器接口上用命令 ip multicast ttl-threshold ttl-value 设定 TTL 阀值:

    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

    71. 用 show ip pim neighbor 显示 PIM 邻居表。

    72. 显示组播通信路由表中的各条记录:

    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

    73. 要记录一个路由器接受和发送的全部 IP 组播包:

    dallasr1> #debug ip mpacket [detail] [access-list][group]

    74. 要在 CISCO 路由器上配置 CGMP: dallasr1>(config-if)# ip cgmp

    75.配置一个组播路由器,使之加入某一个特定的组播组:

    dallasr1>(config-if)# ip igmp join-group group-address

    76. 关闭 CGMP: dallasr1>(config-if)# no ip cgmp

    77. 启动交换机上的 CGMP: dallasr1>(enable) set cgmp enable

    78. 核实 Catalyst 交换机上 CGMP 的配置情况:

    catalystla1>(enable) show config

    set prompt catalystla1>

    set interface sc0 192.168.1.1 255.255.255.0

    set cgmp enable

    79. CGMP 离开的设置: Dallas_SW(enable) set cgmp leave

    80. 在 Cisco 设备上修改控制端口密码:

    R1(config)# line console 0

    R1(config-line)# login

    R1(config-line)# password Lisbon

    R1(config)# enable password Lilbao

    R1(config)# login local

    R1(config)# username student password cisco

    81. 在 Cisco 设备上设置控制台及 vty 端口的会话超时:

    R1(config)# line console 0

    R1(config-line)# exec-timeout 5 10

    R1(config)# line vty 0 4

    R1(config-line)# exec-timeout 5 2

    82. 在 Cisco 设备上设定特权级:

    R1(config)# privilege configure level 3 username

    R1(config)# privilege configure level 3 copy run start

    R1(config)# privilege configure level 3 ping

    R1(config)# privilege configure level 3 show run

    R1(config)# enable secret level 3 cisco

    83. 使用命令 privilege 可定义在该特权级下使用的命令:

    router(config)# privilege mode level level command

    84. 设定用户特权级:

    router(config)# enable secret level 3 dallas

    router(config)# enable secret san-fran

    router(config)# username student password cisco

    85. 标志设置与显示:

    R1(config)# banner motd ‘unauthorized access will be prosecuted!'

    86. 设置 vty 访问:

    R1(config)# access-list 1 permit 192.168.2.5

    R1(config)# line vty 0 4

    R1(config)# access-class 1 in

    87. 配置 HTTP 访问:

    Router3(config)# access-list 1 permit 192.168.10.7

    Router3(config)# ip http sever

    Router3(config)# ip http access-class 1

    Router3(config)# ip http authentication local

    Router3(config)# username student password cisco

    88. 要启用 HTTP 访问,请键入以下命令: switch(config)# ip http sever

    89. 在基于 set 命令的交换机上用 setCL1 启动和核实端口安全:

    switch(enable) set port security mod_num/port_num...enable mac address

    switch(enable) show port mod_num/port_num

    在基于 CiscoIOS 命令的交换机上启动和核实端口安全:

    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]

    switch# show mac-address-table security [type module/port]

    90. 用命令 access-list 在标准通信量过滤表中创建一条记录:

    Router(config)# access-list access-list-number {permit|deny} source-address

    [source-address]

    91. 用命令 access-list 在扩展通信量过滤表中创建一条记录:

    Router(config)#access-list access-list-number

    {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination

    destination-wildcard|any}[protocol-specific options][log]

    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name in [type number]

    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name out [interface-name]

    routing-process| autonomous-system-number

    94. set snmp 命令选项:

    set snmp community {read-only|ready-write|read-write-all}[community_string]

    95. set snmp trap 命令格式如下:

    set snmp trap {enable|disable} [all|moudle|classis|bridge|repeater|

    auth|vtp|ippermit|vmps|config|entity|stpx]

    set snmp trap rvcr_addr rcvr_community

    96. 启用 SNMP chassis 陷阱: Console>(enable) set snmp trap enable chassis

    97. 启用所有 SNMP chassis 陷阱: Console>(enable) set snmp trap enable

    98. 禁用 SNMP chassis 陷阱: Console>(enable) set snmp trap disable chassis

    99. 给 SNMP 陷阱接收表加一条记录: Console>(enable) set snmp trap 192.122.173.42 public

    100. show snmp 输出结果。

    101. 命令 set snmp rmon enable 的输出结果。

    102. 显示 SPAN 信息:Consile> show span

    展开全文
  • 交换机ping命令的使用

    万次阅读 2017-01-17 09:39:32
    命令ping [ -a ip-address ] [ -c count ] [ -d ] [ -f ] [ -h ttl ] [ -i interface-type interface-number ] [ ip ] [ -n ] [ - p pattern ] [ -q ] [ -s packetsize ] [ -t timeout ] [ -tos tos ] [ -v ] h
    命令】

    ping [ -a ip-address ] [ -c count ] [ -d ] [ -f ] [ -h ttl ] [ -i interface-type interface-number ] [ ip ] [ -n ] [ - p pattern ] [ -q ] [ -s packetsize ] [ -t timeout ] [ -tos tos ] [ -v ] host

    【视图】

    任意视图

    【参数】

    -a ip-address:设置发送ICMP ECHO-REQUEST报文的源IP地址,该地址必须是本地的接口IP地址。

    -c:count为发送ICMP ECHO-REQUEST报文次数,范围1~4294967295,缺省为5次。

    -d:设置socket为DEBUGGING模式,缺省为非DEBUGGING模式。

    -f:当数据包长度大于接口MTU时不被分片,直接丢弃。

    -h ttl:指定ICMP ECHO-REQUEST报文中的TTL数值,取值范围1~255。缺省为255。

    -i interface-type interface-number:指定发送ICMP ECHO-REQUEST报文的接口的类型和编号。指定该参数后,报文的ttl值被自动设置为1以用来测试直连设备(即设备的IP地址和指定接口的IP地址在同一网段)。

    ip:配置设备支持IPv4协议。缺省情况下,设备支持IPv4协议。

    -n:将host参数直接作为IP地址,而不需作域名解析;缺省情况下,host首先被当作IP地址,如果不是IP地址则进行域名解析。

    -p:pattern为ICMP ECHO-REQUEST报文填充字节,格式为16进制,如-p ff 将报文全部填充为ff,缺省填充方式为从0x01开始,逐渐递增,直到0x09为止,然后重复。

    -q:除统计数字外,不显示其它详细信息,缺省为显示包括统计信息在内的全部信息。

    -s packetsize:为ICMP ECHO-REQUEST报文长度(不包括IP和ICMP报文头),以字节为单位,取值范围为20~32000,缺省报文长度为56字节。

    -t timeout:为发送完ICMP ECHO-REQUEST后,等待ICMP ECHO-REPLY的超时时间,以ms为单位,取值范围为0~65535,缺省超时时间为2000ms。

    -tos tos:指定ICMP ECHO-REQUEST报文中的ToS数值,取值范围为0~255。缺省为0。

    -v:显示接收到的非ECHO-REPLY的其它ICMP报文;缺省不显示其它非ECHO-REPLY的ICMP报文。

    host:目的主机域名或IP地址。

    【描述】

    ping命令用来检查IP网络连通性及主机是否可达。

    ping执行过程为:向目的地发送ICMP ECHO-REQUEST报文,如果到目的地网络连接工作正常,则目的主机接收到ICMP ECHO-REQUEST报文后,向源主机响应ICMP ECHO-REPLY报文。

    可以用ping命令测试网络连接是否出现故障或网络线路质量等,其输出信息包括:

    l              目的地对每个ICMP ECHO-REQUEST报文的响应情况,如果在超时时间内没有收到响应报文,则输出“Request time out.”,否则显示响应报文的字节数、报文序号、TTL和响应时间等。

    l              最后的统计信息,包括发送报文个数、接收到响应报文个数、未响应报文数百分比和响应时间的最小、最大和平均值。

    如果网络传输速度较慢,可以适当加大等待响应报文的超时时间。

    相关配置可参考命令tracert。

    【举例】

    # 检查IP地址为202.38.160.244的主机是否可达。

    <Sysname> ping 202.38.160.244

    ping 202.38.160.244 : 56 data bytes, press CTRL_C to break

    Reply from 202.38.160.244 : bytes=56 sequence=1 ttl=255 time = 1ms

    Reply from 202.38.160.244 : bytes=56 sequence=2 ttl=255 time = 2ms

    Reply from 202.38.160.244 : bytes=56 sequence=3 ttl=255 time = 1ms

    Reply from 202.38.160.244 : bytes=56 sequence=4 ttl=255 time = 3ms

    Reply from 202.38.160.244 : bytes=56 sequence=5 ttl=255 time = 2ms

    --202.38.160.244 ping statistics--

    5 packet transmitted

    5 packet received

    0% packet loss

    round-trip min/avg/max = 1/2/3 ms

    以上信息表明,目的主机可达,源设备发出的探测报文均能得到回应,报文往返的最短时间、平均时间和最长时间分别为1ms、2ms和3ms。
    展开全文
  • 思科交换机关闭服务端口

    千次阅读 2021-12-23 17:40:47
    思科中,acl只能用在三层物理接口上,如果在交换机中要用acl,需要将接口进行 no switchport,转换成三层接口,然而转换后的接口自动不在属于vlan,就是你通过此接口pingping不同vlan地址了,这个接口就相当

    电厂要求关闭交换机telnet、ssh等远程服务端口,如:常用的23、22口等,可以通过建立acl进行对端口的访问控制???。

    需要确保acl中源端口、目的端口与交换机在适用的接口进出方向一致。

    如果通过vlan地址进行telnet远程,不适用此方法(acl),原因如下:

    在思科中,acl只能用在三层物理接口上,如果在交换机中要用acl,需要将接口进行 no switchport,转换成三层接口,然而转换后的接口自动不在属于vlan,就是你通过此接口ping都ping不同vlan地址了,这个接口就相当于路由器接口了,需要对接口配地址了。所以通过vlan进行telnet的方式,如果要求关闭23端口,那么直接关闭telnet即可,no password

    int f0/1

    no sw

    ip acc 101 in 

    int f0/1

    sw

     

     

    展开全文
  • 满意答案miwen93092013.05.31...假设三层交换机的fa0/1到fa0/6分别连接pc0至pc5,那么请参考如下命令:enablevlan databasevlan 10vlan 11exitconfigure terminalip routinginterface vlan 10ip address 192.168.10...
  • 思科交换机如何配置Trunk?

    千次阅读 2021-02-25 14:30:58
    步骤4:网络连通性测试 测试PC1和PC3的连通性: PC1> ping 10.1.1.284 bytes from 10.1.1.2 icmp_seq=1 ttl=64 time=1.603 ms84 bytes from 10.1.1.2 icmp_seq=2 ttl=64 time=1.234 ms84 bytes from 10.1.1.2 icmp_...
  • Cisco 2960-24配置命令及验证过程
  • 使用tftp32软件对思科交换机导入导出配置 在几种常见类型的交换机里,华三、华为、赫斯曼都可以通过网页或bootrom导入/导出配置文件,思科交换机导入和导出配置的方法比较特别,tftp导出导入配置的方法操作步骤见...
  • 思科交换机dhcp配置

    2021-10-13 19:55:12
    **PS: 1.sw是switchport缩写 2.m是mode缩写 3.acc是access缩写 4.all是allowed缩写 ...交换机1: Switch(config)#(在全局模式下进行) VLAN 10 VLAN 20 int f0/2 sw m acc sw acc all vlan 10 no sh ex .
  • 思科交换机 ssh和telnet远程登录

    千次阅读 2021-05-18 14:20:06
    Cisco SSH Telnet 远程登录配置 拓扑 一、Sw0上建立一个管理Vlan 8 Switch(config)#hostname HOM #更改交换机名称如果不更改rsa生成秘钥时会报错 HOM(config)#int vlan 8 HOM(config-if)#ip add 10.0.8.1 255.255....
  • 实验之前: 实验过程: 1.点击PC1,进入Desktop下的IP ... 2.配置PC1的IP地址和子网掩码: ...3.同样的步骤配置PC2的IP地址为192.168.1.2,子网掩码为255.255.255.0: ...5.输入ping 192.168.1.1, 此时两...
  • Cisco Packet Tracer 命令大全基本配置文件操作启动配置密码设置接口配置CDP路由RIPIGRPEIGRPOSPFACLNAT PAT 配置负载分发DHCPHDLCPPPFRARP(默认启用)ISDNIS-ISBGP路由优化异步连接QoS 转载自:...
  • Ping大包命令格式详解如下:ping全称Packet Internet Grope—英特网包探索器,是一个Windows自带可执行命令,主要用来检测网络是否通畅或者网络链接速度的命令,利用网络上的机器IP地址的唯一性,给目标地址发送一个...
  • (1)模式转换命令 用户模式一-特权模式,使用命令"enable" ...全局模式:配置所有信息、针对整个路由器或交换机的所有接口 接口模式:针对某一个接口的配置 线控模式:对路由器进行控制的接口配置 (...
  • 思科交换机端口聚合

    千次阅读 2020-10-27 20:32:33
    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道...
  • 思科交换机基础命令

    千次阅读 2018-06-21 15:57:24
    enable 进入特权模式S# configure terminal 进入全局配置模式S(config)# hostname name 改变交换机名称S(config)# enable password level level_# password 设置用户口令(level_#=1)或特权口令(level_#=15)S...
  • 思科交换机如何配置trunk?

    千次阅读 2021-04-02 14:43:43
    步骤4:网络连通性测试 测试PC1和PC3的连通性: PC1> ping 10.1.1.284 bytes from 10.1.1.2 icmp_seq=1 ttl=64 time=1.603 ms84 bytes from 10.1.1.2 icmp_seq=2 ttl=64 time=1.234 ms84 bytes from 10.1.1.2 icmp_...
  • 思科交换机日志管理

    千次阅读 2020-12-24 12:37:25
    Cisco配置发送日志到日志服务器logging 133.3.3.2logging onlogging trap 7 //指定日志消息的级别 (0:紧急(Emergencies) 1:告警(Alerts) 2:严重的(Critical) 3:错误(Errors) 4:警告(Warnings) 5:通知(Notifications)...
  • 华农计算机网络综合性实验(实验一) 实现所有 PC、交换机和路由器的全 PING 通 pkt文件,可以直接到思科平台打开进行截图
  • 思科交换机配置命令大全!

    千次阅读 多人点赞 2012-11-22 15:26:46
    1. 交换机支持的命令交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 ...
  • 10、测试连通性 四、导出配置到FTP服务器 1、先测试交换机到FTP服务器是否可达,发现可以ping通。 2、配置FTP用户名和口令(这一步对应3.8身份验证,如不需要可以不配),我这里不需要配置,仅作为演示 YGRZ3560-16F...
  • 1、理解交换机的工作原理 2、掌握交换机MAC地址表的管理方法 实验拓扑 【欢迎关注微信公众号:厦门微思网络】 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、测试主机之间以及主机和服务器之间...
  • 思科交换机vlan

    2020-06-18 10:16:37
    Cisco 交换机不仅仅具有2 层交换功能,它还具有VLAN 等功能。VLAN 技术可以使我们很容易地控制广播域的大小。 有了VLAN,交换机之间的级联链路就需要Trunk 技术来保证该链路可以同时传输多个VLAN 的数据。同时为...
  • 思科路由器交换机常用命令

    千次阅读 2017-12-03 15:21:27
    常用命令 1. 几种模式 用户模式 //提示符为 “ >” 特权模式 //在用户模式下输入 enable 提示符为 “#” 全局配置模式 //在特权模式下输入 conf t 提示符为“(config)#” 接口配置模式 //在全局配置模式下输入 int ...
  • 本次实验采用思科交换机仿真软件Boson NetSim,仿真了最简单的网络拓扑结构的交换机虚拟局域网划分方法。并查看了划分前、划分后、不同的Trunk配置下各台终端设备的连通情况。同时熟悉了思科交换机的配置命令
  • 思科交换机命令

    2019-06-28 14:09:39
    交换机模拟器实验六 2.查看端口名字 SWA#sh vlan default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8 f是端口名子 default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7...
  • (1)模式转换命令 用户模式一-特权模式,使用命令"enable" ...全局模式:配置所有信息、针对整个路由器或交换机的所有接口 接口模式:针对某一个接口的配置 线控模式:对路由器进行控制的接口配置 ...
  • 新手学习思科交换机和路由器常用技术配置命令
  • 思科交换机配置ipv6实验

    千次阅读 2020-03-18 10:14:10
    一台核心交换机 两台接入交换机 3台服务器分别在vlan50、vlan21、vlan13 1、接入交换机1配置: ipv6 unicast-routing #开启 nterface GigabitEthernet0/0 switchport access vlan 50 switchport mode a...
  • 思科交换机端口安全

    千次阅读 2017-11-16 20:20:00
    交换机端口安全1.本实验是将switch中的f0/1的端口做成安全端口,构建mac地址绑定,只让pc0能够进入这个单口,pc1不能进入2.在f0/1上进行配置,先进入端口 1>Switch(config)#int f0/1 Switch(config-if)#shut...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,041
精华内容 1,216
关键字:

思科交换机ping命令