精华内容
下载资源
问答
  • 公网与私网
    千次阅读
    2021-02-10 09:49:32


    公网/外网

    就是我们通常所说的互联网

    私网/内网

    一个私有网络,仅限于内部通信

    组建私网的原因

    IP地址不够用的解决方法:
    1.DHCP动态地址分配
    2.NAT网络地址转换(主要就是用于组建私网,私网中的主机能内部通信,或者使用统一一个对外的IP地址上网)
    在这里插入图片描述
    私网之间,只要网络不相邻,网络号就可以相同,分配的IP地址就可以冲突(因为对外上网就会通过NAT服务转换为对外的地址进行上网,对外来说没有冲突)

    组建私网的网络号

    注意不能随便使用,与公网上某个网络冲突了就不合适了
    可以组建私网的有以下几种:
    10. * . * . * ----用于组建大型私网
    172.16. * . * ~ 172.31. * . * -----用于组建中型私网
    192.168. * . *----用于组建小型私网

    更多相关内容
  • 相当于是一个局域网,也叫做私网,只有属于局域网内部的成员,才可以访问。比如公司内部服务器上搭建的FTP文件系统,你只能使用公司内部的电脑才可以访问,脱离了内网环境,你就不能访问服务器上的任何文件了。

    一, 公网与私网介绍两者间的联系

    公网
    顾名思义,就是公共网络,也叫做外网,没有限制,只要能上网的用户,都可以访问,比如类似百度,新浪这样的网站,只要你有网络,不管你是宽带,光纤,还是5G,WIFI,都可以访问打开。

    比如:有些学校或大型的单位虽然分配公网IP给用户,但学校或单位为了安全起见,会封闭校外对校内的访问请求。这部分用户虽然有公网IP地址,但依然要用内网动态域名来建网站。

    内网
    相当于是一个局域网,也叫做私网,只有属于局域网内部的成员,才可以访问。比如公司内部服务器上搭建的FTP文件系统,你只能使用公司内部的电脑才可以访问,脱离了内网环境,你就不能访问服务器上的任何文件了。

    简要概述,其本质差别,一个是对外(所有用户),一个是对内(局域网内部成员)。

    二,公网ip与私有ip的区别

    公有地址:

    公有地址(Public address):由Inter NIC(因特网信息中心)负责。这些IP 地址分配给注册并向Inter NIc提出申请的组织机构,公有IP 全球唯一,通过它直接访问因特网(直接能上网)。主要有A、B、C、D、E五类地址:

    • A类 : 地址范围是 1.0.0.0127.255.255.255,主要分配给大量主机而局域网网络数量较少的大型网络﹔
    • B类 :地址范围是128.0.0.0191.255.255.255,一般用于国际性大公司和机构;
    • C类:地址范围是192.0.0.0223.255.255.255,用于一般小公司校园网研究机构等;
    • D类:地址范围是224.0.0.0239.255.255.255,用于特殊用途,又称做广播地址;
    • E类:地址范围是240.0.0.0255.255.255.255,暂时保留。

    私有地址:

    私有地址(Private address):属于非注册地址,专门为组织机构内部使用,说白了,私有IP 不能直接上网。主要有A、B、C三类.

    • A类地址范围是10.0.0.0-10.255.255.255 ,

    • B类地址范围是172.16.0.0 -172.31.255.255

    • B类地址范围是192.168.0.0-192.168.255.255
      另外127.0.0.0到127.255.255.255为系统环回地址。

      而我们平时通过运营商(主要是电信、移动、联通宽带等)上网,通过家用路由器之后,就会变成私有IP,大家可能会疑问,我们可以上网啊,怎么会是私有IP呢?

    其实我们不是通过私有iP上网的,是通过公有IP。通俗的讲,运营商有公有IP,但是IPV4下iP资源有限,所以这些IP不能每个人分配单独分配一个IP,所以需要动态给上网的用户。

    所以A和B的IP相同是很正常的一件事情,但是对于公网服务器(比如说百度)来说,它并不关心对方的私有IP是什么,它也不知道,它只知道访问它的肯定是公有IP。

    三,私有网络如何访问公有网络?

    比如:下图用户(私网)访问 百度 (公网)的过程利用端口映射来进行访问

    在这里插入图片描述

    1,端口映射技术

    简述:端口映射(Port Mapping)是将外网主机的IP地址的一个端口映射到内网中一台机器,提供相应的服务。是NAT的一种。它的功能是把在公网的地址转翻译成私有地址, 采用路由方式的ADSL宽带路由器拥有一个动态或固定的公网IP,ADSL直接接在HUB或交换机上,所有的电脑共享上网。
    简单地说:
    端口映射又称端口转发。端口映射过程就如同你家在一个小区里B栋2410室,你朋友来找你,找到小区门口,不知道你住哪层哪号?就问守门的保安,保安很客气的告诉了他你家详细门牌号,这样你朋友很轻松的找到了你家。这个过程就是外网访问内网通过端口映射的形象说法。

    利用端口映射功能还可以将一台外网IP地址机器的多个端口映射到内网不同机器上的不同端口。
    端口映射功能还可以完成一些特定代理功能,比如代理POP,SMTP,TELNET等协议。理论上可以提供65535(总端口娄)-1024(保留端口数)=64511个端口的映射。

    思路: 既然端口映射可以将一台外网P地址机器多个端口映射到内网中不同机器上的不同端口。那当用户访问外网IP的这个端口时,服务器自动将请求映射到对应局域网内部的机器上。

    比如,我们在内网中有一台主机,但是外网中的用户是没有办法直接访问该服务器的。于是我们可以在路由器上设置一个端口映射,只要外网用户访问路由器ip的80端口,那么路由器会把自动把流量转到内网主机的80端口上。并且,在路由器上还存在一个Session,当内网服务器返回数据给路由器时,路由器能准确的将消息发送给外网请求用户的主机。在这过程中,路由器充当了一个反向代理的作用,他保护了内网中主机的安全。

    在这里插入图片描述

    我们平时上网的过程就是先经过路由器,然后通过宽带,最终通过运营商的转换最终到web服务器的,返回的数据先到运营商那边,然后再把数据发送到用户的主机上。

    实际上路由器有两个端口:LAN口,WAN口。

    WAN: 接外部IP地址用,通常指的是出口,转发来自内部LA接口的IP数据包。
    LAN: 接内部IP地址用,LAN内部是交换机。我们可以不连接 WAN口,把路由器当做普通交换机来使用。

    2,nat技术 (网络地址转换 )

    简述:
    网络地址转换(英语:Network Address Translation,缩写:NAT,又称:网络掩蔽、IP掩蔽)在计算机网络中是一种在IP数据包通过路由器或防火墙时重写来源IP地址或目的IP地址的技术。这种技术被普遍使用在有多台主机但只通过一个公有IP地址访问互联网的私有网络中。它是一个方便且得到了广泛应用的技术。当然,NAT也让主机之间的通信变得复杂,导致了通信效率的降低。

    功能 : 隐藏并保护网络内部的计算机

    详细概述:
    它实现内网的IP地址与公网的地址之间的相互转换,将大量的内网IP地址转换为一个或少量的公网IP地址,减少对公网IP地址的占用。NAT的最典型应用是:在一个局域网内,只需要一台计算机连接上 Internet,就可以利用NAT 共享Internet连接,使局域网内其他计算机也可以上网。使用NAT协议,局域网内的计算机可以访问Internet 上的计算机,但 Internet上的计算机无法访问局域网内的计管和

    NAT技术类型
    静态NAT(Static NAT)、动态地址NAT(Pooled NAT)、网络地址端口转换NAPT(Port—Level NAT)。

    nat网络地址转换具体配置方式后续再更新

    五,VPN技术

    也叫虚拟专用网络,两个局域网或者是公网与私网之间进行加密通讯的方法

    什么是vpn技术?
    虚拟私人网络(英语:Virtual Private Network,缩写:VPN)是一种常用于连接中、大型企业或团体与团体间的私人网络的通讯方法。它利用隧道协议(Tunneling Protocol)来达到保密、发送端认证、消息准确性等私人消息安全效果,这种技术可以用不安全的网络(例如:互联网)来发送可靠、安全的消息。需要注意的是,加密消息与否是可以控制的,如果是没有加密的虚拟专用网消息依然有被窃取的危险。VPN可通过服务器、硬件、软件等多种方式实现。

    实现方式 : 服务器,硬件,软件,集成

    用 途 : 加密通讯

    连接协议 :PPTP、L2TP、IPSec

    基本网络功能

    VPN属于远程访问技术,简单地说就是利用公用网络架设专用网络。例如某公司员工出差到外地,他想访问企业内网的服务器资源,这种访问就属于远程访问。

    在传统的企业网络配置中,要进行远程访问,传统的方法是租用DDN(数字数据网)专线或帧中继,这样的通讯方案必然导致高昂的网络通讯和维护费用。对于移动用户(移动办公人员)与远端个人用户而言,一般会通过拨号线路(Internet)进入企业的局域网,但这样必然带来安全上的隐患。

    让外地员工访问到内网资源,利用VPN的解决方法就是在内网中架设一台VPN服务器。外地员工在当地连上互联网后,通过互联网连接VPN服务器,然后通过VPN服务器进入企业内网。为了保证数据安全,VPN服务器和客户机之间的通讯数据都进行了加密处理。有了数据加密,就可以认为数据是在一条专用的数据链路上进行安全传输,就如同专门架设了一个专用网络一样,但实际上VPN使用的是互联网上的公用链路,因此VPN称为虚拟专用网络,其实质上就是利用加密技术在公网上封装出一个数据通讯隧道。有了VPN技术,用户无论是在外地出差还是在家中办公,只要能上互联网就能利用VPN访问内网资源,这就是VPN在企业中应用得如此广泛的原因。

    工作原理

    • 通常情况下,VPN网关采取双网卡结构,外网卡使用公网IP接入Internet。
    • 网络一(假定为公网internet)的终端A访问网络二(假定为公司内网)的终端B,其发出的访问数据包的目标地址为终端B的内部IP地址。
    • 网络一的VPN网关在接收到终端A发出的访问数据包时对其目标地址进行检查,如果目标地址属于网络二的地址,则将该数据包进行封装,封装的方式根据所采用的VPN技术不同而不同,同时VPN网关会构造一个新VPN数据包,并将封装后的原数据包作为VPN数据包的负载,VPN数据包的目标地址为网络二的VPN网关的外部地址。
    • 网络一的VPN网关将VPN数据包发送到Internet,由于VPN数据包的目标地址是网络二的VPN网关的外部地址,所以该数据包将被Internet中的路由正确地发送到网络二的VPN网关。
    • 网络二的VPN网关对接收到的数据包进行检查,如果发现该数据包是从网络一的VPN网关发出的,即可判定该数据包为VPN数据包,并对该数据包进行解包处理。解包的过程主要是先将VPN数据包的包头剥离,再将数据包反向处理还原成原始的数据包。
    • 网络二的VPN网关将还原后的原始数据包发送至目标终端B,由于原始数据包的目标地址是终端B的IP,所以该数据包能够被正确地发送到终端B。在终端B看来,它收到的数据包就和从终端A直接发过来的一样。
    • 从终端B返回终端A的数据包处理过程和上述过程一样,这样两个网络内的终端就可以相互通讯了。

    通过上述说明可以发现,在VPN网关对数据包进行处理时,有两个参数对于VPN通讯十分重要:原始数据包的目标地址(VPN目标地址)和远程VPN网关地址。根据VPN目标地址,VPN网关能够判断对哪些数据包进行VPN处理,对于不需要处理的数据包通常情况下可直接转发到上级路由;远程VPN网关地址则指定了处理后的VPN数据包发送的目标地址,即VPN隧道的另一端VPN网关地址。由于网络通讯是双向的,在进行VPN通讯时,隧道两端的VPN网关都必须知道VPN目标地址和与此对应的远端VPN网关地址。

    六,总结概述

    私网就是局域网,比如说学校,企业内部等等,公网也就是外网,比如说是百度,两者之间通信的话需要借助NAT技术与端口映射技术,而VPN技术则是一种特殊形式,比如说员工外出出差,此时通过外面的网络(其他的局域网)访问内部网络的一种手段,也就属于远程访问。

    展开全文
  • 其功能是负责地址管理路由选择(为每一条网络中的数据根据想去的地方选择合适的路径),典型的协议是IP协议,典型的设备是路由器 IP协议 IP协议的工作类似于邮政服务,事先不需要通知 版本号:包含IP版本号,...

    网络层是用信子网的边界,是通信设备的协议最高层.其功能是负责地址管理与路由选择(为每一条网络中的数据根据想去的地方选择合适的路径),典型的协议是IP协议,典型的设备是路由器

    IP协议

    IP协议的工作类似于邮政服务,事先不需要通知收信人,邮政服务会接收信件,并将其按照邮递路线送给收信人。无连接数据通信也是不通知终端主机就将IP数据包发送出去。IP协议是作为低开销协议设计的,它只提供网络系统从源主机向目的主机传送数据包所必须的功能,该协议并不负责跟踪和管理数据包的流动。因此Internet在网络层就是采用无连接的数据报服务设计思路
    在这里插入图片描述
    版本号:包含IP版本号,例如IPV4/IPV6
    首部长度:标识IP报头的长度,以4字节为单位(最小20字节/最大60字节)
    服务类型:用于确定每个数据报的优先级级别
    报文总长度:指头部和数据之和的长度,单位为字节,因此数据报的最大长度不超过64k,总长度必须不超过数据链路层中的最大传送单元MTU
    标识:若IP报文大小大于数据链路层中指定的MTU,但是又符合数据长度字段,则这条数据会在数据链路层中进行数据分片。用于唯一的标识主机发送的报文. 如果IP报文在数据链路层被分片了, 那么每一个片里面的这个id都是相同的
    假设以太组网方式默认MTU=1500,假设报文长度为1500,下面是进行分片操作图解
    在这里插入图片描述
    一个完整的报文,有可能因为mtu的因素,在数据链路层中进行数据分片,而这些分片在对端就需要分片重组,重新组合称为一个完整报文
    标志:1位保留,1位不分片位FD,当DF为0时才允许分片;如果DF为1则,表示禁止分片,如果数据包大于MTU,则该路由器将数据包丢弃。还有1位是更多分片MF,当MF为1是表示后面还有分片;当MF为0则表示是最后一个分片
    片偏移:当分片在对端进行重组时,就需要确定这个分片在原数据包中的相对位置,偏移单位为8字节,也就是13位最大能够表示2^13*8=65536,所以每个分片(除了最后一个)长度都是8的整数倍
    生存时间TTL:表示报文的最大生命周期,每经过一次路由器就会-1,当该值为0时,路由器会将丢弃数据报(默认为64,现在大多为128),主要是防止路由环路的问题
    协议:记录传输层所使用的协议,便于目的主机解析格式时应该对应用哪种协议。典型的值有01-ICMP,06-TCP,17-UDP
    校验和:校验数据的一致性(每层都会有相应设备对数据的校验,不会去校验其他层,所以每层都会进行校验)
    源IP/目的IP:描述通信中的两台主机在网络层中的地址
    选项数据:提供一种途径允许后续版本协议包含原设计中未出现的信息

    地址管理----网段划分

    IP地址 = 网络号 + 主机号
    网络号:一个网络的标识,由个网络中所分配的IP地址都会带有这个网络号,网络号也叫网段
    主机号:标识同一网络中的不同主机,也就是同一网络有同一网络号,但是有不同的主机号

    IP协议版本有两种,IPV4IPV6,IPV4,IPV4地址类型是uint32_t,总共40多亿个IP地址,用于在网络中唯一标识主机

    IP地址是计算机进行动态分配的(DHCP),但是计算机在分配IP地址时是如何做到所有主机不会产生分配冲突的呢----网段划分

    早期的网段划分是将IP地址分成五类

    在这里插入图片描述
    A:用于组建大型网络,高1位固定为0,7位网络号,24位主机号;网络号范围:0~ 127,IP地址范围:0.0.0.0~127.255.255.255
    B:用于组建中型网络,高2位固定为10,14位网络号,16位主机号;网络号范围:128.0~ 191.255,IP地址范围:128.0.0.0~191.255.255.255
    C:用于组建小型网络,高3位固定为110,,2位网络号,8位主机号;网络号范围:192.0.0~ 223.255.255,IP地址范围:192.0.0.0~223.255.255.255
    D:特殊IP地址
    E:特殊IP地址

    缺点:存在大量IP地址的浪费(大量公司的申请的都是B类网络),导致B类地址很快就分配完了, 而A类却浪费了大量地址

    CIDR划分方案

    特殊的IP地址

    地址描述
    0.0.0.0可以识别当前主机上的任意网卡地址,常用于服务端的监听地址(表示绑定监听本机上的所有IP地址)
    255.255.255.255全网广播地址(任意一个主机收到这个地址的数据,都会认为是发送给自己的,适配所有IP地址,常用语DHCP请求地址)
    127.0.0.1本地虚拟回环网卡的IP地址(常用与本地的网络通信测试,给自己发送数据查看网络是否正常)
    主机全为0实际就是网络号,是网络的表示,因此全为0的主机号是不能分配给网络中的主机
    主机号全为1实际是UDP局域网广播地址(适配与当前网络中的所有主机,因此全为1的主机号是不能分配给网络中的主机

    CIDR方案就是引入子网掩码来划分网络

    子网掩码是uint32_t类型的数字,这个数字由连续的二进制1来组成,通常用一串0来收尾,例如我们平时家用网络的子网掩码一般都是255.255.255.0
    在这里插入图片描述
    子网掩码与IP地址相与得到当前的网络号
    255.255.255.0 & 192.168.137.1 = 192.168.137.0
    子网掩码取反就可以获得这个网络中的主机号范围
    ~255.255.255.0 = 0.0.0.255,则这个网络中的主机号范围为:0 ~255

    假设一个公司要申请了一个C类网络,IP地址为200.161.30.0,现在公司中有4个部门,希望从这个网络中平均划分出四个子网供给各个部门使用,请计算每个子网的网络号为多少,和对应的子网掩码为多少,且IP地址的范围又为多少?
    :C类网络中的子网掩码为255.255.255.0,即前3个字节200.161.30为网络号,子网划分将从第四个字节的第一个比特位开始。现需要划分为4个子网,即需要2个比特位,因此子网掩码为255.255.255.11000000,即255.255.255.192
    子网1的网络号:200.161.30.00000000;即200.161.30.0
    子网2的网络号:200.161.30.01000000;即200.161.30.64
    子网3的网络号:200.161.30.10000000;即200.161.30.128
    子网4的网络号:200.161.30.11000000;即200.161.30.192

    每个子网都有64个主机号,则有效主机IP地址范围为(去除主机号全为1和全为0的ip)
    子网1:200.161.30.00 000001 ~ 200.161.30.00 111110;即200.161.30.1 ~ 200.168.30.62
    子网2:200.161.30.01 000001 ~ 200.161.30.01 111110;即200.161.30.65 ~ 200.168.30.126
    子网3:200.161.30.10 000001 ~ 200.161.30.10 111110;即200.161.30.129 ~ 200.168.30.190
    子网4:200.161.30.11 000001 ~ 200.161.30.11 111110;即200.161.30.193 ~ 200.168.30.254

    :当要划分不是2的次方整数倍时,需要向上划分。例如划分5个子网,此时必须划分为8个子网。也就是前3个比特位为网络号

    公网与私网

    公网也称外网,也就是我们所说的互联网;私网也称内网,仅限于内部通信
    IP地址的数量是有限的,只有40多亿个,DHCP动态地址分配并不能完全解决这个问题。此时就引入了NAT来解决IP地址不够用的问题

    NAT全称(Network Address Translation,网络地址转换),主要用于组建私网,将私网的IP地址转换为对外的IP地址。
    私网中的主机都有各自的IP地址,而私网对外只有一个IP地址。也就不同私网的主机,即使IP地址相同,也没有关系。因为他们对外上网的时候会通过NAT服务转换为对外的IP地址进行上网。但是要注意私网之间,网络不能相邻,否则就会造成冲突
    在这里插入图片描述
    但是私网的网络号也不能随便使用,万一与公网上的某个网络号冲突了就不合适了。在RFC文档1918规定,能够用于组建私网的网络号有以下几种
    10.* . *. *----用于组建大型私网
    172.16. * . * ~ 172.31. * . *----用于组建中型私网
    192.168. *. *----用于组建小型私网

    路由选择

    路由器的功能就是实现数据包的寻址和转发
    路由选择:就是路由器的寻址,寻址数据包到达目的IP地址的最佳路径
    路由表:路由表存储了有关本地网络和远程网路的数据转发信息

    在Linux操作系统下,可以使用route命令查看路由表信息
    在这里插入图片描述
    重要名词解释
    Destination:目标网络
    Gateway:网关地址
    Genmask:子网掩码
    Iface:连接指定网络的网卡

    在这里插入图片描述

    DestinationGatewayGenmaskIface
    192.168.3.0255.255.255.0eth0
    192.168.2.0255.255.255.0eth1
    default192.168.2.1eth1

    假如主机1要给主机2发送数据,并不会直接将数据发送给主机2,而是要先将数据发送给路由器1,然后路由器进行路由选择,先查看主机1是否属于自己的私网,利用主机1的IP地址和自己组建的私网的子网掩码相与得到一个网络号,如何得到的网络号和自己组建时的网络号相同,则表示主机1属于自己的私网,这时候就可发送给主机2。但是发送给主机2之前,先要确认主机2是否属于自己的私网,也是要拿主机2的IP地址和自己组建的私网的子网掩码相与,如果与自己组建的网路号相同,就才会发送给主机2

    假如主机1要上百度上网,会将数据发送给路由器1,然后路由器要发送给百度,百度的IP地址为39.156.69.79,然后发送时将这个IP地址依次从表格的上到下和子网掩码相与,看有没有相同的网络号,如果没有就可以通过eth1网卡发送到default的网关上,此时数据就到达了运营商路由器。运营商路由器也有自己的路由表,然后根据自己的路由表寻找目的地。以此类推,最后才将数据发送给百度

    私网之间的主机是无法直接进行通信的,例如主机1不能和主机3和主机4直接进行通信的
    主机1要和主机3通过qq进行网络通信,会先将数据发送到路由器1,再将数据发送到运营商服务器,再发送到互联网,互联网再发送到qq服务器,然后qq服务器再发送至互联网,再到运营商服务器,然后再到路由器2,再发送到主机3。这里发送数据时都路由器都会记录两网卡之间的映射关系,是由哪个源IP地址和端口发送到哪个目标IP地址和端口,这个技术叫做NAPT。例如路由器1与记录主机1之间的映射关系 192.168.3.2 <-> 192.168.2.2

    相邻网络:一个路由器上边连接的网络,对于这个路由器都是相邻网络。例如下图中的路由器1和路由器2并不相邻,路由器1和路由器2都和运营商路由器相邻
    相邻网络不能使用同一个网络号,如果使用了用同一个网络号,此时路由器会记录两个同样的网络号,如果发送数据,就不知道发送给谁了
    私网之间是不能通信的,他们有可能具有相同的IP地址
    在这里插入图片描述
    网关就类似于一个中转站,两个主机之间要进行通信,就必须经过网关。
    互联网中路由器上记录的路由表,包含的不仅仅是与自己相连接的网络的路由信息,与自己不相连的也会记录

    展开全文
  • nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www ##外访问私网服务器HTTP服务时,转换地址为9.9.9.9 nat outbound 2000 address-group 1 no-pat ##动态NAT私网与公网池对应 nat outbound...

    一、NAT概述

    网络地址转换技术NAT (Network Address Translation)主要用于实现位于内部网络的主机访问外部网络的功能。当局域网内的主机需要访问外部网络时,通过NAT技术可以将其私网地址转换为公网地址,并且多个私网用户可以共用一个公网地址,这样既可保证网络互通,又节省了公网地址。
    企业或家庭所使用的网络为私有网络,使用的是私有地址;运营商维护的网络为公共网络,使用的是公有地址。私有地址不能在公网中路由,此时需要用到NAT技术进行地址转换。
    NAT- -般部署在连接内网和外网的网关设备上。
    接下来通过实例介绍几种NAT配置方法,实验图示如下,灰色部分为私有网络白色为公共网络。
    在这里插入图片描述

    二、静态NAT——不能节省公网IP地址

    静态NAT是一个私网地址到公网中转换成对应的一个公网地址,并且一个公网IP只会分配给唯一且固定的内网主机,实现了私有地址和公有地址的一对一映射,所以不会节省公网IP地址。
    这里PC5访问外网的方式是静态NAT。
    静态NAT:一个私网IP地址对应一个公网IP地址(有两种配置方法)
    第一种:全局模式下 nat static global 8.8.8.8 inside 192.168.10.10
    在接口上启动nat static enable 功能
    int g0/0/1
    nat static enable

    第二种:直接在接口上声明nat static
    int g0/0/1
    nat static global 8.8.8.8 inside 192.168.10.10

    三、动态NAT——不能节省公网IP地址

    动态NAT是基于地址池来实现私有地址和共有地址的转换,先建立公网地址池,然后私网地址池的地址访问公网的时候去公网地址池里按顺序拿一个公网地址访问公网,这是一种多对多的模式,所以也不能节省公网IP地址。
    动态NAT:多个私网IP地址对应多个公网IP地址
    nat address-group 1 212.0.0.100 212.0.0.200(新建为1的nat地址池)
    acl 2000(acl编号)
    rule permit source 192.168.20.0 0.0.0.255
    rule permit source 11.0.0.0 0.0.0.255//可不写
    int g0/0/1(外网口)
    nat outbound 2000 address-group 1 no-pat

    四、NAPT——能节省公网IP

    网络地址端口转换NAPT允许多个内部地址映射到同一个公有地址的不同端口,就是说,多个私网地址在访问公网的时候,通过转换成同一个公网地址跟上不同端口号的形式访问,需要设置一个公网地址,并且运营商的路由器需要配置一个回程路由,所以虽然能节省公网地址,但是不普遍采用。

    五、Easy IP——能节省公网IP

    Easy IP与NAPT很像,都是多对一,允许多个内部地址映射到同一个共有地址的不同端口,然而更好的是,它转换使用的公网地址就是外网口——网关出接口的地址,不需要另设一个公网IP,且不需要配回程路由。
    EasyIp:多个私网IP地址对应外网口公网IP地址(12.0.0.1)
    acl 3000(acl编号)
    rule permit ip source 192.168.30.0 0.0.0.255
    int g0/0/1(外网口)
    nat outbound 3000
    nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www

    六、整体配置

    在这里插入图片描述
    LSW3:

    vlan batch 10 20 30 40 ##创建vlan 10 20 30 40

    interface Vlanif10 ##虚拟接口设vlan10的网关
    ip address 192.168.10.1 255.255.255.0

    interface Vlanif20 ##虚拟接口设vlan20的网关
    ip address 192.168.20.1 255.255.255.0

    interface Vlanif30 ##虚拟接口设vlan30的网关
    ip address 192.168.30.1 255.255.255.0

    interface Vlanif40 ##虚拟接口设vlan40的网关
    ip address 11.0.0.2 255.255.255.0

    interface GigabitEthernet0/0 ##配置接口类型为acess,划分为vlan 10
    port link-type access
    port default vlan 10

    interface GigabitEthernet0/0/2 ##配置接口类型为acess,划分为vlan 20
    port link-type access
    port default vlan 20

    interface GigabitEthernet0/0/3 ##配置接口类型为acess,划分为vlan 30
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/4 ##配置接口类型为acess,划分为vlan 10
    port link-type access
    port default vlan 10

    interface GigabitEthernet0/0/5 ##配置接口类型为acess,划分为vlan 40
    port link-type access
    port default vlan 40

    ip route-static 0.0.0.0 0.0.0.0 11.0.0.1 ##设置向上的默认路由,指明私网地址转发的方向

    R5:

    acl number 2000 ##编号2000
    rule 5 permit source 192.168.20.0 0.0.0.255 ##私网地址池(动态NAT)

    acl number 3000 ##编号3000
    rule 5 permit ip source 192.168.30.0 0.0.0.255 ## 私网地址池(Easy IP模式)

    nat address-group 1 212.0.0.100 212.0.0.200 ##新建编号为1的公网地址池(动态NAT使用)

    interface GigabitEthernet0/0/0
    ip address 11.0.0.1 255.255.255.0

    interface GigabitEthernet0/0/1
    ip address 12.0.0.1 255.255.255.0
    nat static global 8.8.8.8 inside 192.168.10.10 netmask 255.255.255.255 ##静态NAT模式,PC1地址转换为8.8.8.8访问外网
    nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www ##外网访问私网服务器HTTP服务时,转换地址为9.9.9.9
    nat outbound 2000 address-group 1 no-pat ##动态NAT私网池与公网池对应
    nat outbound 3000 ##Easy IP模式,外网口对应私网池3000

    ip route-static 0.0.0.0 0.0.0.0 12.0.0.2 ##向上指默认,指向公网方向
    ip route-static 192.168.10.0 255.255.255.0 11.0.0.2 ##向下指静态,指明到192.168.10.0的路由
    ip route-static 192.168.20.0 255.255.255.0 11.0.0.2 ##向下指静态,指明到192.168.20.0的路由
    ip route-static 192.168.30.0 255.255.255.0 11.0.0.2 ##向下指静态,指明到192.168.30.0的路由

    R6:

    interface GigabitEthernet0/0/0
    ip address 12.0.0.2 255.255.255.0

    interface GigabitEthernet0/0/1
    ip address 13.0.0.1 255.255.255.0

    interface LoopBack0
    ip address 114.114.114.114 255.255.255.255 ##环回口,用于作为内网访问外网的测试地址

    ip route-static 8.8.8.0 255.255.255.0 12.0.0.1 ##静态NAT的回程路由
    ip route-static 9.9.9.0 255.255.255.0 12.0.0.1 ##外网访问内网服务器的路由指路
    ip route-static 212.0.0.0 255.255.255.0 12.0.0.1##动态NAT的回程路由

    七、抓包看地址转换

    PC5:
    在这里插入图片描述
    地址转换成8.8.8.8
    在这里插入图片描述
    PC6:
    在这里插入图片描述
    地址从212.0.0.100到212.0.0.104,按顺序从地址池拿地址
    在这里插入图片描述
    PC7:
    在这里插入图片描述
    转换为12.0.0.1访问外网
    在这里插入图片描述
    外网访问私网服务器HTTP服务:

    在这里插入图片描述
    出现TCP三次握手,然后进行HTTP服务,地址转换成9.9.9.9
    在这里插入图片描述

    展开全文
  • 网络管理员需要在分公司总公司之间减少广播流量,增强网络安全性,做到二层隔离的同时又能实现三层互联。 分公司为小型网络,流量由路由器AR1处理,且通过AR1连接互联网。总公司分为三层网络,接入层接入时为终端...
  • 公网IP和私网IP

    万次阅读 多人点赞 2018-11-25 18:45:02
    详解公网Ip和私网ip;详解网络分类ABC; ipconfig查出来的是你本机的IP地址,也就是内网私有地址,此类地址仅在局域网使用,不能联通外。 百度搜索IP查出来的地址是你上网的公有地址,并不是你主机的地址,...
  • 公网ip与私网ip区别联系

    万次阅读 多人点赞 2019-07-23 12:13:59
    一般的私网的网段 100.0.0.0 10.0.0.0 172.16.0.0 192.168.0.0 什么是公网ip 有了公网ip,那么在互联网上你的宽带就有一个唯一的ip地址,家庭的宽带的公网ip地址都是动态变动的,有了这个ip地址你就可以...
  • 私网与公网地址转换

    千次阅读 2022-03-16 16:11:29
    私网与公网地址转换NAT概述NAT功能静态NAT动态NATEASYIP(多个内网地址对一个接口)PAT端口多路复用 NAT概述 NAT(Network Address Translation,网络地址转换)是1994年提出的。当在专用内部的一些主机本来已经...
  • [NET]什么是公网私网、内网、外
  • 最难申请的移动公网IP成功了,教你区分宽带是公网IP还是私网IP
  • 2、安全防护:NAT之内的Pc联机到Internet上面时,他所显示的IP是NAT主机的公网IP,所以client端的PC就具有一定程度的安全了,外界在进行portscan(端口扫描)的时候,就侦测不到源client端的PC。优点:节省公有合法IP...
  • 网络协议从入门到底层原理 路由 实践1 - 让4台主机之间可以互相通信 实践2 - 让4台主机之间可以互相通信 数据包的传输过程(简) 第一个包的丢失 ...网络 (Network)、互联网 ...公网IP、私网IP NAT(Network Address
  • 简述公网IP、私网IP、动态IP、静态IP

    千次阅读 2022-03-20 10:56:25
    简述一下公网IP、私网IP、动态IP、静态IP这四个概念。 1、先说公网IP和私网IP 我们都听过IP地址,但对公网IP和私网IP可能就比较挠头了。把IP的问题放在一边,我们先说一下什么是公网,什么是私网公网又名广域...
  • 公网私网、配置内外通用

    千次阅读 2018-11-29 23:03:07
    IPv4公网 A类IP地址1.0.0.0 -126.0.0.0 B类IP地址128.0.0.0-191.255.255.255 C类IP地址192.0.0.0-223.255.255.255 私网: A类:10.0.0.0-10.255.255.255 B类:172.16.0.0-172.31.255.255 C类:192.168.0.0-...
  • 私网地址转换成公网地址,达到内网到外的访问,用到的技术是NAT技术。
  • 10.私网与公网的转换---NAT网络地址转换技术

    千次阅读 多人点赞 2022-06-19 10:41:46
    在IP地址空间中,A, B, C三类地址中各有一部分地址,他们被称为私有地址(私网IP地址),其余的被称为公有地址(公网IP地址)。 A: 10.0.0.0 - 10.255.255.255 —相当于一个完整的A类网段 B:172.16.0.0 - 172.31.255...
  • 对于ip是否是公网ip,网上已经有很多文章进行了描述。但我每次都记不太住,总要查找一下才又清楚。因此决定在这里记录下来,方便以后查询:)ip地址分为五类。E类为保留为今后使用,D类为组播地址。用于主机网络地址...
  • 然而这就面临一个问题,如何将公网私网的流量分开统计呢?特别是当机器流量异常的时候,如何快速的判断流量是来自公网还是私网。当然云厂商一般也提供了eip的监控,然而很多公司也有一套自己的监控,对于自建监控...
  • 如何通过IP地址分辨公网私网、内网、外 内、外是相对于防火墙而言的,在防火墙内部叫做内网,反之就是外。 在一定程度上外等同于公网,内网等同于私网。 地址为如下3个区域就是处于私网: 1:10...
  • 公网IP、私网IP和IP分类

    千次阅读 多人点赞 2020-04-21 22:18:12
    0. 源于????      ...IP查询是一个经常性的操作,Windows...发现我的IP通常是因为我到处蹭:192.168.10.xxx。不是说IP地址全球唯一吗?怎么还有多个相同网段的IP呢?    &n...
  • 文章目录实验拓扑图实验目的配置命令测试 ...实现公网主机和私网主机都能通过公网IP访问私网服务器 配置命令 // 配置缺省路由 [AR1]ip route-static 0.0.0.0 0 11.11.11.2 // 配置Easy IP方式的NAT O...
  • 云计算系列知识点——网络(公网私网、VPN等)基础知识计费模式 文章目录系列文章目录VPC腾讯云网络连接服务腾讯云负载均衡腾讯云云网络计费 VPC VPC(私有网络)由子网组成。 IP地址组成:xxxx xxxx xxxx ...
  • 问题环境:在开发的情况下,在测试环境前端有BUG的情况下,想...把上面显示的切换成Disabled就可以实现公网与私网的链接!!!! 困扰我一段时间的问题总算完成了。 总结:还是别乱更新,但是浏览器一般还是会更新的,
  • 私网公网相关

    千次阅读 2019-03-04 14:31:41
    私网公网 公网是指整个互联网,外部的终端都可以访问,路由器外面的世界。 私网可以看作是局域网,通过路由器连接内部的网络,这是一种内网。 内网也就是局域网,内网的计算机以NAT(网络地址转换)协议,通过一个...
  • 私网ip和公网ip_详解

    万次阅读 多人点赞 2018-12-11 16:57:20
    我们的私网ip是自成体系的,在合理的建设完私网ip后,我们只需利用nat技术将公网ip和私网ip做一个转换即可。大概就跟下图所示一样,二楼使用的是172.16.xx.xx开头的网址,三楼是172.17.xx.xx,四楼是172.18.xx.xx,从...
  • 公网地址和私网地址有哪些类型?

    千次阅读 2022-01-14 23:27:44
    私网地址 是指在机构内部用的地址 这些地址有明显的特征。我们看一眼就知道这是私网IP address。 我们将所有的IP分为三类 ABC类。每一类中有划出来的一部分的私有地址 和划出来得一部分保留地址。 ①A类地址。A类...
  • 公网与私网隔离

    2011-01-21 15:42:00
    接触了安防的一些东西,了解到公网与私网如何隔离了 小流量控制数据走串口线//这个如何防范 视频走视频线
  • 公网ip和私网ip的区别是什么,哪个能重复哪个不能? 如何实现两个设备之间的信息通信? 是通过公网ip查找还是私网ip查找? 路由表包含的信息有哪些? ARP协议的作用以及格式? ARP缓存表的作用? NAT地址转换协议的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 18,889
精华内容 7,555
关键字:

公网与私网