精华内容
下载资源
问答
  • openwrt 编译出错求解决方案

    万次阅读 2018-10-29 21:49:32
    新手入门openwrt 编译出错求解决方案 Configuring kmod-sched-cake. Configuring kmod-ifb. Configuring iptables-mod-conntrack-extra. Configuring sqm-scripts. Configuring ip6tables. Configuring bird1-ipv4-...

    新手入门openwrt 编译出错求解决方案

    Configuring kmod-sched-cake.
    Configuring kmod-ifb.
    Configuring iptables-mod-conntrack-extra.
    Configuring sqm-scripts.
    Configuring ip6tables.
    Configuring bird1-ipv4-uci.
    Configuring kmod-rt2800-soc.
    Configuring kmod-ipt-offload.
    Configuring ppp-mod-pppoe.
    Collected errors:

    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-sqm:
    • luci-base *
    • opkg_install_cmd: Cannot install package luci-app-sqm.
    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-bird1-ipv4:
    • luci-base *
    • opkg_install_cmd: Cannot install package luci-app-bird1-ipv4.
    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-bird1-ipv6:
    • luci-base *
    • opkg_install_cmd: Cannot install package luci-app-bird1-ipv6.
    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-bmx6:
    • luci-lib-json * luci-base * luci-lib-httpclient *
    • opkg_install_cmd: Cannot install package luci-app-bmx6.
    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-bmx7:
    • luci-lib-json * luci-mod-admin-full * luci-lib-httpclient *
    • opkg_install_cmd: Cannot install package luci-app-bmx7.
    • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-cjdns:
    • luci-base *
    • opkg_install_cmd: Cannot install package luci-app-cjdns.
      package/Makefile:65: recipe for target ‘package/install’ failed
      make[2]: *** [package/install] Error 255
      make[2]: Leaving directory ‘/home/linyugui/openwrt/openwrt’
      package/Makefile:104: recipe for target ‘/home/linyugui/openwrt/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_install’ failed
      make[1]: *** [/home/linyugui/openwrt/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_install] Error 2
      make[1]: Leaving directory ‘/home/linyugui/openwrt/openwrt’
      /home/linyugui/openwrt/openwrt/include/toplevel.mk:216: recipe for target ‘world’ failed
      make: *** [world] Error 2
      linyugui@linyugui-ThinkPad-X60s:~/openwrt/openwrt$ make menuconfig
      WARNING: Makefile ‘package/feeds/packages/acme/Makefile’ has a dependency on ‘luci-base’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/bird1-ipv4-openwrt/Makefile’ has a dependency on ‘luci-base’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/bird1-ipv6-openwrt/Makefile’ has a dependency on ‘luci-base’, which does not exist
      WARNING: Makefile ‘package/feeds/packages/dynapoint/Makefile’ has a dependency on ‘luci-lib-nixio’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx6/Makefile’ has a dependency on ‘luci-lib-json’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx6/Makefile’ has a dependency on ‘luci-base’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx6/Makefile’ has a dependency on ‘luci-lib-httpclient’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx7/Makefile’ has a dependency on ‘luci-lib-json’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx7/Makefile’ has a dependency on ‘luci-mod-admin-full’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-bmx7/Makefile’ has a dependency on ‘luci-lib-httpclient’, which does not exist
      WARNING: Makefile ‘package/feeds/routing/luci-app-cjdns/Makefile’ has a dependency on ‘luci-base’, which does not exist
      WARNING: Makefile ‘package/feeds/packages/prometheus-node-exporter-lua/Makefile’ has a dependency on ‘luci-lib-nixio’, which does not exist
      WARNING: Makefile ‘package/feeds/packages/sqm-scripts/Makefile’ has a dependency on ‘luci-base’, which does not exist
    展开全文
  • 通用应用编译出错

    千次阅读 2016-06-16 15:20:34
    通用应用编译出错(金庆的专栏)编译lua5.3.2 Windows静态库时,创建VS2015工程时选择了 Visual C++ -> Windows 通用 -> 静态库(通用 Windows). 结果再选择按C++编译时报错:lua-5.3.2\src\loslib.c(132): error C...
    通用应用编译出错

    (金庆的专栏)

    编译lua5.3.2 Windows静态库时,创建VS2015工程时选择了
      Visual C++ -> Windows 通用 -> 静态库(通用 Windows).
     
    结果再选择按C++编译时报错:
    lua-5.3.2\src\loslib.c(132): error C3861: “system”: 找不到标识符

    跳到system()的定义:

    // APIs Only Available in Desktop Apps
    #ifdef _CRT_USE_WINAPI_FAMILY_DESKTOP_APP
        ...
        int __cdecl system(...);
        ...
    #endif // _CRT_USE_WINAPI_FAMILY_DESKTOP_APP

    看上去必须是桌面应用才有system()。

    以前用premake5生成的工程是能顺利编译的。
    于是又新建了premake5脚本来生成另一个工程,比较发现通用项目文件有:
        <AppContainerApplication>true</AppContainerApplication>
        <ApplicationType>Windows Store</ApplicationType>

    打开项目属性,看到
        目标平台:Windows 10
    并且不可更改。

    而Premake5生成的项目目标平台为 Windows, 也是不可更改。
    这样就明白了应该是工程创建时选错了模板。
    仔细查看,原来 Win32 项目包含了Dll和静态库,不应该与Window通用搞混。

    Window通用应用应该是Win10跨桌面与移动设备的应用。


    展开全文
  • IDEA 编译出错

    千次阅读 2015-09-25 15:16:08
    IDEA 编译出错 2015-03-31 17:43 946人阅读 评论(0) 收藏 举报 参考 问题: http://www.oschina.net/question/657237_117513 IDEA 进行编译代码的时候,特别是新项目 特别容易出现 编码错误,但是 File-...

    IDEA 编译出错

     946人阅读 评论(0) 收藏 举报

    参考 问题:  http://www.oschina.net/question/657237_117513


    IDEA 进行编译代码的时候,特别是新项目 特别容易出现 编码错误,但是 File-Encoding中设置的又没有问题,而且maven 是能打包的,就是用 idea 自带的 编译的时候 就会出现提示  找不到字符,错误开头会提示

    [html] view plaincopy在CODE上查看代码片派生到我的代码片
    1. java: Multiple encodings set for module chunk test  
    2.   
    3. "GBK" will be used by compiler  

    但是我们的设置里面 设置的 是 UTF-8 那么显然哪个地方把它设置为 GBK 了; 


    最后解决办法 是按连接中的答案进行操作的:  检查.idea/encodings.xml是否对某些类指定了charset,删除即可

    版权声明:本文为博主原创文章,未经博主允许不得转载。


    地址: http://download.csdn.net/category

    展开全文
  • VS Code | 编译出错原因

    2019-12-01 10:27:56
    VS Code | 编译出错原因

    windows下vscode编译出现这样的问题是因为文件名中有空格。


    修改文件名,去掉空格即可。

    展开全文
  • codeblocks c++ 编译出错

    千次阅读 2016-04-01 11:28:33
    codeblocks编译出错今天编译一个c++程序调用模板的时候,出现错误 error This file requires compiler and library support for the \ ISO C++ 2011 standard. This support is currently experimental, and ...
  • apktool反编译apk出错如下: Exception in thread "main" org.jf.util.ExceptionWithContext: Encountered small uint that is out of range at offset 0x38 报错的原因是apk中不止smali目录下面的dex文件,其他...
  • 这个问题,困扰我一下午,之前没加Q_OBJECT导致不能使用信号和槽功能,导致我的程序已知编译出错,后来发现加上后,还是不能编译成功,继续出错。最后在overfolow stack上面找到了答案。原因首先是编译时没加Q_...
  • libmemcached编译 出错

    千次阅读 2013-05-20 13:20:00
    libmemcached编译 出错 转自 http://blog.csdn.net/flyrainer/article/details/7742368 编译错误: libmemcached/auto.cc: In function 'memcached_return_t text_incr_decr(memcached_server_st*, bool,...
  • 转:编译出错 ninja: build stopped: subcommand failed Android 源码编译
  • Latex参考文献BibTex编译出错问题

    千次阅读 2020-09-10 10:39:39
    Latex参考文献BibTex编译出错问题 马上要国赛了,学Latex引用参考文献时出现了Bibtex编译出错的问题,网上查了一些方法都不管用,就自己摸索了一下,最后真的成功了,就分享一下自己的经验吧! 编译时的错误代码: I ...
  • VS 编译出错之文件编码
  • OpenCV 编译出现perf_precomp.hpp编译出错

    千次阅读 2017-10-31 14:20:14
    编译到88%左右的时候时错误出现了,打印显示预编译头文件perf_precomp.hpp编译出错,诡异的是换一台电脑后是另外一个模块同样文件编译出错,错误在不同位置。问题解决:使用用cmake创建时,本来使用的是G:/xxx/xxx/...
  • gcc编译出错提示要怎样设置才会中文显示?各位大佬帮帮忙。小弟感激不尽
  • ccf刷题编译出错

    千次阅读 2016-02-26 16:31:59
    在我刷ccf题时,我用的是DEV C++ IDE软件,程序运行结果正常,但是一旦提交到ccf在线OJ时,就会一直报编译出错。我思前想后,把代码贴到VC++ 6.0里面,发现原来是有个toupper()标准函数没有包含头文件ctype.h,但是...
  • 使用caffe时编译出错

    万次阅读 2015-09-07 19:01:27
    使用caffe时编译出错 使用自己机器编译的include和lib (caffe/build/lib, caffe/include) caffe.pb.h丢失问题: /home/wuliwei/caffe/include/caffe/blob.hpp:9:34: fatal error: caffe/proto/caffe.pb.h: No such ...
  • arduino程序编译后不成功,提示“exit status 1 为开发板arduino UNO编译出错”,这种情况就是编译环境的问题,可以尝试更换编译器版本。亲测有用。
  • C++ goto 编译出错问题

    千次阅读 2017-12-21 15:38:06
    C++ goto 编译出错 error: jump to label ‘discard_packet’ [-fpermissive] ××××××× goto discard_packet; ×××××××× crosses initialization of ‘cv::Mat ppp’
  • Android 使用mm编译出错问题

    千次阅读 2018-07-12 16:52:47
    使用mm进行模块编译前要先执行...有时候编译出错 make: *** No rule to make target `out/target/common/obj/JAVA_LIBRARIES/libprotobuf-Java-2.3.0-nano_intermediates/javalib.jar', needed by `out/target/c...
  • Latex moderncv模板使用 编译出错

    千次阅读 2017-03-16 16:41:19
    最近想整理一下简历,下载了一个latex的模板却一直各种编译出错。找了好久终于解决了问题。 我使用的是winEdt,下载的模板需要moderncv的包支持。但是winEdt自带的包太老了,所以一直编译出错。可以去官网上下载最新...
  • ^M导致的编译出错

    千次阅读 2017-05-23 22:38:36
    有时候我们会在Windows下编写代码,然后再放到Linux下进行编译。...但是当我将该文件放到Linux上使用gcc进行编译,编译出错,提示如下: 提示第322行出错,但是322行是return 0;没啥毛病啊。我把321行和322行屏蔽
  • Latex 加了参考文献编译出错

    千次阅读 2019-01-08 14:14:55
    这里特指加网页博客或者新闻等作为参考文献,可能会出现没加参考文献之前编译正常,加了之后编译出错,然后即使删除那篇新加的参考文献还是出现同样的错误。这个时候很有可能是参考文献的网址格式有误,比如下划线。...
  • idea中maven编译出错问题

    万次阅读 2017-08-24 18:02:42
    刚刚接触maven,总是出现maven编译出错问题,在此记录一下。 一、出现找不到某模块的情况 先找到有root的模块,进行clean和install,如果有依赖模块,就先对公共依赖模块进行clean和install,再进行对root模块的...
  • 快速解决Androidkiller总是反编译出错

    千次阅读 2018-04-01 21:02:58
    解决Androidkiller总是反编译出错 原因: AndroidKiller的ShakaApktool.jar文件比较旧,去网上下载个新版的ApkTool.jar,再把AndroidKiller的ShakaApktool.jar文件进行替换(路径:AndroidKiller\bin\apktool\...
  • Android编译出错:The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.51 and higher. Project ‘Test’ is using version 1.2.30. 打开build.gradle(Project) 修改buildscript中的...
  • Xcode8中CoreData编译出错的解决方法

    千次阅读 2017-01-10 23:46:01
    Xcode8中创建CoreData托管对象后编译出错的解决办法:一、删除掉自己创建的NSManagedObject SubClass类,因为在托管对象中创建Entity属性后会自动生成对应的类,如果自己再手动创建就会导致重复。Build工程之后,...
  • Dev C++编译出错,出现source file not compiled弹窗 问题分析: 装了不同版本的devC++,错点了以前不用的devc++版本,两个devC++配置冲突了 解决方式: 换回来你最近使用的版本devC++即可,问题解决。。。 ...
  • Undefined symbols for architecture x86_64: 编译出错 其实是mac os xcode 带的c++标准库问题,如果还是老的库就会出错,要升级xcode,或用最新c++库 前阵子编译php mysql就遇到这个问题,后来升级xcode后一路...
  • 编译出错和运行出错的区别

    千次阅读 2019-05-26 17:03:32
    要区分编译时错误和运行时错误, 先要明白什么是编译什么是运行 首先来看这张图 编译期就是将我们写的java源代码交给编译器执行的过程, 起翻译的作用 ...
  • Cmake编译出错

    千次阅读 2017-07-24 18:22:23
    CMake使用Visual Studio 14 2015 Win64编译报错: The C compiler identification is unknown The CXX compiler identification is unknown CMake Error at CMakeLists.txt:5 (project): No CMAKE_C_COMPILER ...
  • jemalloc 编译出错

    千次阅读 2017-06-22 20:35:56
    linux编译jemalloc,按照install.md的安装说明: Building and installing a packaged release of jemalloc can be as simple as typing the following while in the root directory of the source tree: ./...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 403,945
精华内容 161,578
关键字:

编译出错