精华内容
下载资源
问答
  • 1、显卡驱动不要下到中文路径 当处在tty1界面,此时显卡驱动还卸载了,中文路径也打不出来,在此界面无法安装驱动,sudo vim也没反应,转到2 2、输入startx可以回去调整位置(打开X-window),但这时候还处在sudo ...

    在安装了CUDA10.0后,发现显卡驱动是384,不匹配这个,所以要把这个卸载了,然后重新装一个驱动。
    我把系统切换成英文才解决了tty1乱码的问题。。
    ubuntu用命令行进行中文/英文环境切换
    安装办法:ubuntu安装显卡驱动的三种方法
    看这个:Ubuntu16.04 nvidia 显卡驱动过程及遇到的问题

    重复登陆:
    ctrl alt f1
    sudo service lightdm stop
    sudo chmod +x ./NVIDIA-Linux-x86_64-460.84.run
    sudo ./NVIDIA-Linux-x86_64-460.84.run -no-opengl-files

    出现的问题

    1、tty1界面内不能用小键盘,否则无法通过密码验证

    1、显卡驱动不要下到中文路径

    当处在tty1界面,此时显卡驱动还卸载了,中文路径也打不出来,在此界面无法安装驱动,sudo vim也没反应,转到2

    2、输入startx可以回去调整位置(打开X-window),但这时候还处在sudo service lightdm stop的状态
    3、关闭X-window:也可以直接输入logout
    4、此时打开终端sudo service lightdm start就可回去了(正常就是ctrl alt f7回来)

    出现了菱形乱码
    5、Ubuntu13.10纯文本模式/终端中文乱码解决方法

    最后,验证一下:
    nvidia-smi

    nvidia-settings

    验证一下CUDA的例程是不是可以用了:
    ubuntu16.04安装CUDA10.0和对应版本的cudnn详细流程

    展开全文
  • Ubuntu 16.04上已装有CUDA 8.0,现在想再安装CUDA 10.0,由于已安装的显卡驱动版本396.54不支持CUDA 10.0,因此安装CUDA 10.0之前需要先升级显卡驱动到410及以上版本。 可在...

    Ubuntu 16.04上已装有CUDA 8.0,现在想再安装CUDA 10.0,由于已安装的显卡驱动版本396.54不支持CUDA 10.0,因此安装CUDA 10.0之前需要先升级显卡驱动到410及以上版本。

    可在https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html中查看对应的显卡驱动支持的CUDA版本。

    1. 升级显卡驱动版本到430,依次执行如下命令后,重启电脑,

    sudo apt-get update
    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt install nvidia-430

    通过终端nvidia-smi命令查看,可查看显卡驱动信息,结果如下图所示,升级成功:

    2. 安装CUDA 10.0:

    (1).从https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1604 下载runfile(local)的CUDA,即cuda_10.0.130_410.48_linux.run;

    (2).执行如下命令,安装CUDA 10.0:

    sudo sh cuda_10.0.130_410.48_linux.run

    在终端所做的选择:

    Do you accept the previously read EULA? accept
    Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 410.48? n
    Install the CUDA 10.0 Toolkit? y
    Enter Toolkit Location [ default is /usr/local/cuda-10.0 ]: Enter
    Do you want to install a symbolic link at /usr/local/cuda? y
    Install the CUDA 10.0 Samples? y
    Enter CUDA Samples Location [default is /home/xxxx ]: Enter

    (3).验证CUDA 10.0是否安装正确,依次执行如下命令:

    cd /usr/local/cuda/samples
    sudo make -k
    ./1_Utilities/deviceQuery/deviceQuery

    执行结果如下图所示,说明CUDA 10.0安装正确:

    3. 安装cuDNN:

    (1).从https://developer.nvidia.com/rdp/cudnn-archive下载:cuDNN v7.3.0 Runtime Library for Ubuntu16.04 (Deb), cuDNN v7.3.0 Developer Library for Ubuntu16.04 (Deb), cuDNN v7.3.0 Code Samples and User Guide for Ubuntu16.04 (Deb)即libcudnn7_7.3.0.29-1+cuda10.0_amd64.deb、libcudnn7-dev_7.3.0.29-1+cuda10.0_amd64.deb、libcudnn7-doc_7.3.0.29-1+cuda10.0_amd64.deb;

    (2).安装.deb包:默认cudnn动态库会安装在/usr/lib/x86_64-linux-gnu目录下,cudnn.h会安装到/usr/include目录下,cudnn_samples_v7会安装到/usr/src目录下

    sudo dpkg -i libcudnn7_7.3.0.29-1+cuda10.0_amd64.deb
    sudo dpkg -i libcudnn7-dev_7.3.0.29-1+cuda10.0_amd64.deb 
    sudo dpkg -i libcudnn7-doc_7.3.0.29-1+cuda10.0_amd64.deb

    4. Export CUDA路径,打开/etc/profile文件:

    (1).在原有LD_LIBRARY_PATH值的基础上增加/usr/local/cuda-10.0/lib64;

    (2).在原有PATH值的基础上增加/usr/local/cuda-10.0/bin;

    5.验证cuDNN是否安装正确:

    (1).进入到/usr/src/cudnn_samples_v7/mnistCUDNN目录下;

    (2).依次执行如下命令:

    sudo make
    ./mnistCUDNN

    执行结果如下图所示,说明安装正确:

    GitHubhttps://github.com/fengbingchun/CUDA_Test

    展开全文
  • 现在官网提供Tensorflow_gpu、Pytorch都只支持CUDA 10.0,但NVIDIA官网不再更新10.0,很多新的显卡或系统无法安装CUDA10.0。 怎么办?其实可以很方便的使得10.1向下兼容10.0,下载附件的批处理文件并运行,就可以了...
  • 问题描述: Win10笔记本电脑升级cuda10.0之后,Geforce GTX 1060 Max-Q显卡无法识别。cuda10.0自带显卡驱动版本为411.31 解决办法: 升级驱动版本到更高版本,例如441.66 ...

    问题描述:

    Win10笔记本电脑升级cuda10.0之后,Geforce GTX 1060 Max-Q显卡无法识别。cuda10.0自带显卡驱动版本为411.31

    解决办法:

    升级驱动版本到更高版本,例如441.66  

    https://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/Windows/441.66/441.66-desktop-win10-64bit-international-dch-whql.exe&lang=us&type=TITAN

    展开全文
  • 现在官网提供Tensorflow_gpu、Pytorch都只支持CUDA 10.0,但NVIDIA官网不再更新10.0,很多新的显卡或系统无法安装CUDA10.0。 怎么办?其实可以很方便的使得10.1向下兼容10.0,下载附件的批处理文件并运行,就可以了...
  • 1.安装显卡驱动 具体看上一篇文章,我再ssh里安装,没涉及到关闭什么的问题,有需要自行百度 2.安装cuda ctrl+c快速跳过,不安装Driver,因为已安装驱动**(这里需要强调一下) 安装完会出现: Please make ...

    1.安装显卡驱动

    具体看上一篇文章,我再ssh里安装,没涉及到关闭什么的问题,有需要自行百度

    2.安装cuda

    ctrl+c快速跳过,不安装Driver,因为已安装驱动**(这里需要强调一下)

    安装完会出现:

    Please make sure that  
     -   PATH includes /usr/local/cuda-9.1/bin  
     -   LD_LIBRARY_PATH includes /usr/local/cuda-9.1/lib64, or, add /usr/local/cuda-9.1/lib64 to /etc/ld.so.conf and run ldconfig as root  
      
    To uninstall the CUDA Toolkit, run the uninstall script in /usr/local/cuda-9.1/bin  
      
    Please see CUDA_Installation_Guide_Linux.pdf in /usr/local/cuda-9.1/doc/pdf for detailed information on setting up CUDA.  
      
    ***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 384.00 is required for CUDA 9.1 functionality to work.  
    To install the driver using this installer, run the following command, replacing <CudaInstaller> with the name of this run file:  
     sudo <CudaInstaller>.run -silent -driver  
    vim ~/.bashrc
    export CUDA_HOME=/usr/local/cuda
    export PATH=$PATH:$CUDA_HOME/bin
    export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
    source ~/.bashrc

     

     

    3.安装cudnn

    下载

    tar -zxvf 解压

     

    sudo cp cuda/include/cudnn.h /usr/local/cuda/include/
    sudo cp cuda/lib64/libcudnn* /usr/local/cuda/lib64/
    sudo chmod a+r /usr/local/cuda/include/cudnn.h
    sudo chmod a+r /usr/local/cuda/lib64/libcudnn*
    
    展开全文
  • 从源代码编译TensorFlow,支持CUDA 10.0

    千次阅读 2019-02-27 16:18:51
    CUDA早已推出9.2甚至10.0, 官方发布的编译好之后的TensorFlow却仍然只支持CUDA 9.0。要想让TensorFlow支持CUDA 10.0, 需要自行从源代码编译。编译过程中有诸多坑,权且记录在此。 平台和版本 64位CentOS 7.6, CUDA ...
  • win10下RTX 2080ti安装cuda10.0和cudnn7.6.5

    万次阅读 2020-12-01 11:36:20
    2 安装cuda10.0 在cuda历史版本列表中下载cuda10.0 cuda10.0下载链接 下载完成后安装cuda,采用默认安装即可。 3 下载并配置cudnn cudnn并不是一个安装程序,而是一个C++运行库,包含头文件、lib文件、dll文件。...
  • 文章目录Ubuntu16.04下安装CUDA10.0及cuDNN7.4.2准备工作一、安装nvidia显卡驱动安装二、安装cuda10.0安装三、安装cudnn7.0下载安装 准备工作 linux版本、nvidia显卡驱动、cuda版本、cudnn版本之间关系 (1)显卡...
  • 显卡驱动之前已经安装完毕, 后因需要跑其他代码, 重新安装了cuda10.0, 当时默认重新安装了显卡驱动,但是出错了 出错效果如下 接下来是解题流程 2 解题流程 2.1 方法1 卸载所有nvidia相关,重装 sudo apt purge ...
  • centos 离线安装CUDA 10.0 CUDNN 7.6.5

    千次阅读 2020-08-25 18:20:08
    自己离线环境下安装cuda10.0和cudnn7.6.5的过程 安装gcc 显卡驱动 cuda和cudnn 安装gcc sudo yum install gcc gcc-c++ sudo yum install make sudo yum install kernel-devel sudo yum install elfutils-libelf-...
  • Centos7安装NVIDIA显卡驱动和CUDA10.0

    万次阅读 2018-12-04 09:43:38
    CUDA下载 检查linux是否安装了GPU lspci | grep -i nvidia 安装gcc、g++编译器 yum install gcc yum install g++ 安装kernel-devel和kernel-headers yum install kernel-devel yum install kernel-...
  • 1. cuda10.0下载地址:cuda10.0 2. 运行‘sudo sh cuda_10.0.130_410.48_linux.run’遵循提示安装。不要安装cuda自带的显卡驱动 3.配置环境 sudo gedit ~/.bashrc 在文件末尾添加如下代码: export PATH=/...
  • ubuntu18.04安装CUDA10.0

    2021-04-14 20:11:28
    对于CUDA10.0,要求驱动版本大于410.48,因此首先要更新驱动 ubuntu-drivers devices(查看所有驱动) sudo ubuntu-drivers autoinstall(自动安装最适合的驱动) 查看驱动版本 nvidia-smi 2、下载CUDA10.0 ...
  • Cuda10.0在Ubuntu安装

    千次阅读 2019-10-31 15:33:02
    第一步:安装显卡驱动 第二步:根据表中对应的显卡驱动找到适配的CUDA版本: ...cuda10.0版本下载地址: https://developer.nvidia.com/cuda-10.0-download-archive 我选择的runfile安装: 把.run文件下载到...
  • 我的显卡是1660Ti,cuda10.0,tensorflow1.14,python3.7.5,win10笔记本常用的比较稳定的配置。
  • 安装CUDA10.0 准备工作 验证系统是否安装了gcc 在终端中输入 gcc --version 验证系统是否安装了kernel header和 package development sudo apt-get install linux-headers-$(uname -r) 查表判断自己的kernel和gcc...
  • ubuntu16.4安装cuda10.0

    2020-12-21 23:31:49
    一、下载cuda10.0 cuda10的下载链接 下载完毕后,终端使用以下命令检测,序号不合重新下载 md5sum cuda_10.0.130_410.48_linux.run 二、安装cuda10 1、禁用nouveay(在安装NVIDIA驱动的时候已经禁过了) ...
  • 挺折腾的.先是更新了显卡驱动,然后vs2017社区版,然后安装cuda9.2,然后cudnn。之后tensoflow,才发现,tensoflow 要1.13...于是,安装了另一个版本显卡驱动,安装cuda10.0,然后cudnn,然后安装tensoflow。完事。 ...
  • Ubuntu 18.04安装CUDA 10.0笔记

    千次阅读 2019-09-30 12:46:04
    CUDA官网上下载CUDA 10.0的Ubuntu 18.04安装包: https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804&...
  • 配置深度学习框架 需要显卡 本实验所使用的是ubuntu18.04的系统 2080ti的显卡 cudnn 安装过程中需要的安装包3 libcudnn7_7.4.2.24-1+cuda10.0_amd64.deb ...libcudnn7_7.4.2.24-1+cuda10.0_amd64.deb
  • ubuntu18.04安装CUDA10.0与cuDNN7.6.5一、安装CUDA10.01.检查版本和类型2.禁用nouveau驱动3.安装驱动4.安装CUDA5.安装cuDNN 一、安装CUDA10.0 1.检查版本和类型 首先查看自己的系统版本,命令如下: 可以看到我的...
  • Win10+tensorflow1.12.0+CUDA10.0+cudnn7.3.1

    千次阅读 2019-04-02 20:43:51
    Win10+tensorflow1.12.0+CUDA10.0+cudnn7.3.1简介CUDA10.0安装配置cudnn7.3.1安装配置路径配置安装tensorflow1.12.0测试tensorflow-gpu 简介 垃圾电脑的垃圾CPU受够了,决心献出显卡,放GPU出来溜溜。 下面介绍...
  • Win10系统下CUDA10.0的安装

    千次阅读 2020-08-18 09:54:46
    进入官网下载CUDA10.0,直接搜索CUDA10.0即可,注意:只有你的电脑上配置的显卡是NVIDIA的显卡才可以装CUDA,AMD显卡的电脑是不行的 对于下载的exe文件双击进行安装,自定义选择安装路径 点击OK后进入系统兼容...
  • 配置深度学习框架 需要显卡 本实验所使用的是ubuntu18.04的系统 2080ti的显卡 cudnn 安装过程中需要的安装包3 libcudnn7-dev_7.4.2.24-1+cuda10.0_amd64.deb ...libcudnn7-dev_7.4.2.24-1+cuda10.0_amd64.deb
  • 1、安装Nvidia驱动,可参考https://blog.csdn.net/weixin_40512640/article/details/91958123(注意CUDA10.0要求显卡驱动版本大于等于418.39,其他版本的CUDA可参考...2、安装CUDA 参考了 https:/...
  • 一开始作者用ubuntu18.04安装CUDA10.1,但碰到了一些问题,后来改成10.0,安装成功,但存在内核不兼容问题(wifi无法使用),故改成16.04 安装CUDA10.0成功 一开始,尝试Ubuntu18.4安装CUDA10.1 第一步安装显卡驱动...
  • 本文将用最简单的方式来配置深度学习环境:Ubuntu 18.04 LTS + NVIDIA Driver 433.40 + Cuda 10.0 + Cudnn 7.6。
  • Ubuntu16.04安装完显卡驱动后,可以安装CUDA10.0和完整的OpenCV。 根据自己的NVIDIA驱动版本选择对应的CUDA版本,博主的驱动是nvidia-418,所以选择了CUDA10.0,依据NVIDIA官网给出的方法,依照提示安装CUDA10.0和...
  • win10系统CUDA10.0安装教程(for tensorflow2.0)

    万次阅读 多人点赞 2019-11-19 10:08:53
      前言:目前最新的CUDA版本是10.1,但是出于某种神秘的原因,目前tensorflow2.0仅支持CUDA10.0。这个已经在我的电脑与一部分网友的反馈中得到了证实。tensorflow2.0不仅绑定了CUDA的版本,还对CUDA安装配置有一定...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,645
精华内容 1,458
关键字:

cuda10.0支持的显卡