精华内容
下载资源
问答
  • NAT地址转换配置

    2021-05-05 10:02:07
    NAT地址转换技术

    NAT地址转换配置

     


    一、NAT技术介绍

    NAT背景:由于企业内网大都使用私有网络地址,私有地址只能在局域网中使用,不能出现在互联网上,那么使用私有地址的内部主机想要访问互联网,就必须使用地址转换技术NAT将其转换为公有地址。

    NAT地址转换技术:将私有地址转换为在互联网应用的公有地址

    ACL技术:在使用NAT地址转换技术时,往往要使用ACL技术来指定允许转换的内部主机地址范围。

    NAT技术划分:根据映射方式,NAT技术分为静态NAT动态NAT

    1.静态NAT:它是手工配置的内部私有地址和外部公共地址的对应关系,除非人工修改,否则不会变化,一般对外发布服务器使用静态NAT技术

    2.动态NAT:它是多个内部主机和外部公共地址随机对应的一种方式,主要通过指定内部允许转换的地址范围和外部允许使用的地址范围,然后对两个范围映射。这样具体外部的一个公共地址被内部哪台主机使用不确定。主要使用于业务内网大量用户的客户端访问外网。


    二、NAT配置举例

    1.定义ACL

    Router-Switch(config)#access-list 100 permit ip any 61.192.93.0 0.0.0.255           //定义允许所有网段访问网段61.192.93.0 0/24的ACL100

    Router-Switch(config)#access-list 101 deny ip any 61.192.93.0 0.0.0.255            //定义拒绝所有网段访问网段61.192.93.0 0/24的ACL101

    Router-Switch(config)#access-list 101 permit ip any                         //定义允许除61.192.93.0 0/24的所有网段访问的ACL100

    2.定义NAT地址池

    Router-Switch(config)#ip nat pool ISP-A 61.192.93.100 61.192.93.102 netmask 255.255.255.0              //定义访问ISP-A的合法地址池

    Router-Switch(config)#ip nat pool ISP-B 202.102.100.100 202.102.100.102 netmask 255.255.255.0     //定义访问ISP-B的合法地址池

    Router-Switch(config)#ip nat inside source list 100 pool ISP-A overload       //为内网用户ISP-A实现区分目标运营商网络进行匹配的NAT转换

    Router-Switch(config)#ip nat inside source list 101 pool ISP-B overload        //为内网用户ISP-B实现区分目标运营商网络进行匹配的NAT转换

    3.将静态NAT转换应用到设备

    Router-Switch(config)#ip nat inside source static tcp 192.168.1.100 80 61.192.93.100 80_extendable     //为内网WEB服务器192.168.1.100主机配置ISP-A的静态NAT转换

    Router-Switch(config)#ip nat inside source static tcp 192.168.1.100 80 202.102.100.100 80_extendable     //为内网WEB服务器192.168.1.100主机配置ISP-B的静态NAT转换


    三、NAT应用到端口

    1.端口配置

    Router-Switch(config)#int s0                   //进入s0的子接口配置模式

    Router-Switch(config)#ip nat outside     //指定NAT的外部转换接口

    Router-Switch(config)#int s1                 //进入s1的子接口配置模式

    Router-Switch(config)#ip nat outside     //指定NAT的外部转换接口

    Router-Switch(config)#int f/0/1              //进入f0/1的子接口配置模式

    Router-Switch(config)#ip nat inside       //指定NAT的内部转换接口

    2.配置路由转发

    Router-Switch(config)#ip route 61.192.93.0 255.255.255.0 s0     //配置到达ISP-A的流量从s0口转发

    Router-Switch(config)#ip route 0.0.0.0 0.0.0.0 s1                         //配置默认路由指定从s1口转发

    Router-Switch(config)#ip route 0.0.0.0 0.0.0.0 s0 120                  //配置备份路由,或者配置浮动路由

     

    展开全文
  • H3C IPv6隧道技术配置,详细描述了配置基于IPv6的NAT地址转换方式
  • 华为NAT地址转换配置

    2021-12-16 08:51:03
    一、 静态NAT地址转换 1、[Huawei]ip route-static 0.0.0.0 0.0.0.0 202.19.18.2 //写默认路由 2、[Huawei-GigabitEthernet0/0/0]nat static global 202.19.18.5 inside 192.168.10.1 //进外部端口做静态nat地址转换...

    在这里插入图片描述

    禁止转载

    一、 静态NAT地址转换

    1、[Huawei]ip route-static 0.0.0.0 0.0.0.0 202.19.18.2 //写默认路由
    2、[Huawei-GigabitEthernet0/0/0]nat static global 202.19.18.5 inside 192.168.10.1  //进外部端口做静态nat地址转换
    

    二、 动态NAT地址转换

    1、[Huawei]nat address-group 1 202.19.18.3 202.19.18.9 //创建外部地址范围
    2、[Huawei]acl number  2000 //创建ACL控制访问列表
    [Huawei-acl-basic-2000]rule 5 permit source 192.168.10.0 0.0.0.255 //设置列表访问规则允许来自192.168.10.0网段的ip通过
    3、[Huawei-GigabitEthernet0/0/0]nat outbound  2000 address-group 1 no-pat //进入外部端口将公网地址范围聚合组与acl列表关联起来
    

    三、 Easy ip地址转换

    1、[Huawei]acl number  2000 //创建ACL控制访问列表
    [Huawei-acl-basic-2000]rule 5 permit source 192.168.10.0 0.0.0.255 //设置列表访问规则允许来自192.168.10.0网段的ip通过
    2、[Huawei-GigabitEthernet0/0/0]nat outbound 2000 //直接将acl列表与公网端口关联起来,让这些ip共用这个端口的ip
    
    展开全文
  • 华为Router 动态NAT地址转换配置

    万次阅读 多人点赞 2018-06-19 11:01:13
    一、组网需求:某公司A部门和B部门的私网用户和...A部门允许使用公网IP地址比较多(202.169.10.100~202.169.10.200),所以使用no-pat转换方式(只转换数据包的IP地址,并不使用端口号)的NAT方式替换A部门内部的主...

    一、组网需求:

    某公司A部门和B部门的私网用户和互联网相连,路由器上接口GigabitEthernet0/0/0的公网地址为202.169.10.1/24,对端运营商侧地址为202.169.10.2/24。

    A部门允许使用公网IP地址比较多(202.169.10.100~202.169.10.200),所以使用no-pat转换方式(只转换数据包的IP地址,并不使用端口号)的NAT方式替换A部门内部的主机地址(网段为192.168.20.0/24),访问因特网。

    B部门允许使用公网IP地址比较少(202.169.10.201~202.169.10.202),所以使用pat转换方式(同时转换数据包中的IP地址和端口号)的NAT替换B区内部的主机地址(网段为10.0.0.0/24),访问因特网。

    1、网络拓扑


    2、配置思路

    配置接口IP地址、缺省路由和在WAN侧接口下配置NAT Outbound,实现内部主机访问外网服务功能。

    二、操作步骤

    1、配置A、B部门主机IP地址,网关分别是192.168.20.1、10.0.0.1
    2、在SWA上配置vlan
    <Huawei>system-view
    [Huawei]sysname SWA
    [SWA]vlan 100
    [SWA-vlan100]q
    [SWA]interface  Ethernet0/0/1
    [SWA-Ethernet0/0/1]port link-type access
    [SWA-Ethernet0/0/1]port default vlan 100
    [SWA-Ethernet0/0/1]q
    [SWA]interface  Ethernet 0/0/2
    [SWA-Ethernet0/0/2]port link-type trunk
    [SWA-Ethernet0/0/2]port trunk allow-pass vlan all
    [SWA-Ethernet0/0/2]q
    3、在SWB上配置vlan
    [Huawei]sysname SWB
    [SWB]vlan 200
    [SWB-vlan200]q
    [SWB]interface Ethernet0/0/1
    [SWB-Ethernet0/0/1]port link-type access 
    [SWB-Ethernet0/0/1]port default vlan 200
    [SWB-Ethernet0/0/1]q
    [SWB]interface Ethernet 0/0/2
    [SWB-Ethernet0/0/2]port link-type trunk 
    [SWB-Ethernet0/0/2]port trunk allow-pass vlan all 
    [SWB-Ethernet0/0/2]q
    4、在Router上配置接口IP地址
    <Huawei>system-view 
    [Huawei]sysname Router
    [Router]vlan batch 100 200
    [Router]interface Vlanif 100
    [Router-Vlanif100]ip address 192.168.20.1 24
    [Router-Vlanif100]q
    [Router]interface Vlanif 200
    [Router-Vlanif200]ip address  10.0.0.1 24
    [Router-Vlanif200]q
    [Router]interface Ethernet 0/0/0
    [Router-Ethernet0/0/0]port link-type trunk 
    [Router-Ethernet0/0/0]port trunk  allow-pass vlan all 
    [Router-Ethernet0/0/0]q
    [Router]interface Ethernet 0/0/1
    [Router-Ethernet0/0/1]port link-type trunk 
    [Router-Ethernet0/0/1]port trunk allow-pass  vlan all
    [Router-Ethernet0/0/1]q
    [Router]interface  GigabitEthernet  0/0/0
    [Router-GigabitEthernet0/0/0]ip address  202.169.10.1 24
    [Router-GigabitEthernet0/0/0]q

    这时候主机就可以ping通网关了

    5、在Router上配置缺省路由,指定下一跳为202.169.10.2
    [Router]ip route-static 0.0.0.0 0.0.0.0 202.169.10.2
    6、在Router上配置NAT Outbound(记住在出接口上应用)
    [Router]nat address-group 1 202.169.10.100 202.169.10.200
    [Router]nat address-group 2 202.169.10.201 202.169.10.202
    [Router]acl number 3001
    [Router-acl-adv-3001]rule 5 permit  ip source  192.168.20.0 0.0.0.255
    [Router-acl-adv-3001]q
    [Router]acl number 3002
    [Router-acl-adv-3002]rule  5 permit  ip source  10.0.0.0 0.0.0.255
    [Router-acl-adv-3002]q
    [Router]interface  GigabitEthernet 0/0/0
    [Router-GigabitEthernet0/0/0]nat outbound 3001 address-group 1 no-pat
    [Router-GigabitEthernet0/0/0]nat outbound 3002 address-group 2
    [Router-GigabitEthernet0/0/0]q
    [Router]ip soft-forward enhance enable

    如果需要在Router上执行ping -a source-ip-address命令通过指定发送ICMP ECHO-REQUEST报文的源IP地址来验证内网用户可以访问因特网,需要配置命令ip soft-forward enhance enable使能设备产生的控制报文的增强转发功能,这样,私网的源地址才能通过NAT转换为公网地址。

    7、查看结果
    [Router]display  nat outbound 
     NAT Outbound Information:
     --------------------------------------------------------------------------
     Interface                     Acl     Address-group/IP/Interface      Type
     --------------------------------------------------------------------------
     GigabitEthernet0/0/0         3001                              1    no-pat
     GigabitEthernet0/0/0         3002                              2       pat
     --------------------------------------------------------------------------
      Total : 2
    [Router]ping -a 192.168.20.1 202.169.10.2
      PING 202.169.10.2: 56  data bytes, press CTRL_C to break
        Reply from 202.169.10.2: bytes=56 Sequence=1 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=2 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=4 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=5 ttl=255 time=10 ms
    
      --- 202.169.10.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/10/10 ms
    
    [Router]ping -a 10.0.0.1 202.169.10.2
      PING 202.169.10.2: 56  data bytes, press CTRL_C to break
        Reply from 202.169.10.2: bytes=56 Sequence=1 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=2 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=4 ttl=255 time=10 ms
        Reply from 202.169.10.2: bytes=56 Sequence=5 ttl=255 time=10 ms
    
      --- 202.169.10.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/10/10 ms
    8、查看NAT映射表项
    [Router]display nat session all verbose



    展开全文
  • 动态NAT地址转换配置实验(中兴)

    千次阅读 2020-06-12 23:24:57
    动态NAT地址转换配置实验一、实验目的二、实验内容三、实验流程四、查看和验证五、实验总结 一、实验目的 1.掌握中兴动态NAT技术的基本原理和作用,及其数据的转发过程; 2.掌握动态NAT技术的基本原理和作用; 二、...

    一、实验目的

    1.掌握中兴动态NAT技术的基本原理和作用,及其数据的转发过程;
    2.掌握动态NAT技术的基本原理和作用;

    二、实验内容

    1.两台PC机设置为两个不同网段并用路由器相连;
    2.配置NAT地址池为1.2.3.1 1.2.3.10;
    3.验证 PC1、 PC2 主机之间可以互相通信;
    4.完成中兴1800路由器动态NAT技术的配置和结果查看;

    三、实验流程

    (一)配置任务说明
    如下图所示:对于城域网内部的服务器,既要求内部用户能够从内部通过私网IP访问,数据不需要出私网,也要求非城域网的用户能够从公网上以真实IP地址访问该服务器;
    将PC1 IP地址设置为100.0.0.2/24,网关为100.0.0.1/24,PC2 IP地址设置200.0.0.2/24,网关为200.0.0.1/24,路由器R1(NAT)的 gei-2/1接口与PC1相连,IP地址为100.0.0.1/24,路由器R1的 gei-2/2接口与PC2相连,IP地址为200.0.0.1/24;
    在这里插入图片描述
    (二)实验配置过程
    1、路由器R1的基本配置如下:
    configure terminal
    hostname R1-NAT
    interface gei-2/1
    ip address 100.0.0.1 255.255.255.0
    no shutdown
    exit
    interface gei-2/2
    ip address 200.0.0.1 255.255.255.0
    no shutdown
    exit
    ipv4-access-list test
    rule permit any
    exit
    cgn
    cgn-pool test poolid 1 mode pat
    section 1 1.2.3.1 1.2.3.10
    exit
    domin 1 1 type sr ipv4-issued
    dynamic source rule-id 1 ipv4-list test permit pool test
    exit
    subscriber ipv4 public subscripber-id nat-domain 1
    interface gei-2/1
    exit
    ip route 0.0.0.0 0.0.0.0 200.0.0.2
    show cgn translations all-sessions //查看R1的NAT地址转换表

    四、查看和验证

    (一)实验结果查看
    R1查看NAT地址转换表:
    在这里插入图片描述
    (二)实验结果验证
    PC1 ping PC2:
    在这里插入图片描述
    验证可以ping通。

    PC2 ping PC1:
    在这里插入图片描述
    验证可以ping通。

    五、实验总结

    NAT需要在专用网连接到因特网的路由器上安装NAT软件,装有NAT软件的路由器叫做NAT路由器,它至少有一个有效的外部IP地址,这样,所有使用本地地址的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成外部1P地址,才能和因特网连接,NAT不仅能解决IP地址不足的问题,而且还能够有效地避免来自网络外部的攻击,险藏并保护网络内部的计算机。
    动态转换是指将内部网络的私有IP地址转换为公用IP地址时,IP地址是不确定的,是随机的,所有被授权访问上Internet的私有IP地址可随机转换为任何指定的合法IP地址,动态转换可以使用多个合法的外部地址集。

    展开全文
  • 静态NAT地址转换配置实验一、实验目的二、实验内容三、实验流程四、查看和验证五、实验总结 一、实验目的 1.掌握中兴1800路由器的静态NAT技术的配置方法和结果查看; 2.掌握静态NAT技术的基本原理和作用; 二、实验...
  • NAT网络地址转换 NAT(Network Address Translation)又称为网络地址转换,用于实现私有网络和公有网络之间的互访。 NAT工作原理 1.NAT用来将内网地址和端口号转换成合法的公网地址和端口号,建立一个会话,与公网主机...
  • NAT(地址转换技术) 将私有地址转换成公有地址 私有地址满足企业用户在Intranet上使用的需求 私有地址不能在Internet上使用 私有地址包括3组 10.0.0.0~10.255.255.255 172.16.0.0~172.31.255.255 192....
  • 1)静态路由# 配置路由器Router 静态路由:[H3C] ip route-static 1.1.3.0 255.255.255.0 1.1.2.2[H3C] ip route-static 1.1.4.0 255.255.255.0 1.1.2.2[H3C] ip route-static 1.1.5.0 255.255.255.0 1.1.2.2或只配...
  • NAT网络地址转换原理和配置 NAT原理: 随着Internet的发展和网络应该的增加,IPV4地址枯竭已经成为制约网络发展的瓶颈。尽管ipV6可以从根本上解决IPV4地址空间不足的问题,但目前众多的网络设备和网络应用仍是基于...
  • 网络地址转换NAT配置

    2012-12-26 14:16:51
    使用的计算机网络实验报告 关于网络地址转换NAT配置 与大家分享!
  • 华为eNSP配置网络地址转换NAT

    千次阅读 2021-01-22 09:18:19
    华为eNSP配置网络地址转换NAT一、配置路由器R1和R2的接口地址(一)配置R1路由器接口(二)配置R2路由器接口二、配置缺省路由联通整个网络三、静态一对一映射NAT技术四、NAT Easy IP技术五、Server NAT 技术(一)...
  • 1、大家应该知道企业内网中终端使用的私网IP地址,如果我们需要上网,出口一般配置NAT进行地址转换,通过NAT技术把内网私网IP地址转换为公网IP地址。 2、同时IPv4公网缺乏,IPv6开始商用。作为前期解决公网IP地址...
  • 理解 NAT 网络地址转换的原理及功能 掌握静态 NAT配置,实现局域网访问互联网 实验背景 你是某公司的网络管理员,欲发布公司的 WWW 服务。现要求将内网 Web 服务器 IP地址映射为全局 IP 地址,实现外部网络可以...
  • 这里写目录标题NAT技术简介NAT主要应用NAT的分类静态NAT动态NATNARTEASY IPNAT基本配置 NAT技术简介 随着Internet的发展和网络应用的...网络地址转换技术NAT (Network Address Translation)主要用于实现位于内部网络的
  • 思科模拟器 --- 网络地址转换NAT配置

    千次阅读 2019-11-11 10:36:55
    学习目标:理解NAT网络地址转换的原理及功能、掌握静态NAT配置,实现局域网访问互联网 1.定义 ①网络地址转换NAT(Network Address Translation),被广泛应用于各种类型Internet接入方式和各种类型的网络中。原因...
  • 华为NAT地址转换技术)

    万次阅读 多人点赞 2020-09-06 16:45:44
    NAT属于接入广域网(WAN)技术,是一种将私有(保留)地址转化为合法公网IP地址的IP地址转换技术,它被广泛应用于各种类型 Internet接入方式和各种类型的网络中。 2、NAT类型 (1)静态----NAT(static NAT):内部...
  • 举个栗子,一段报文想离开私网,必须经过NAT网关将数据传输给公网Internet,通过nat实现源IP地址映射为公网IP地址,Internet发现该IP实际是私有IP,就将请求的服务实现,并通过网关回传给源IP。这样一次由私网主机向...
  • Network Address Translation一,应用场景二,静态NAT(一对一)三,基本原理四,动态NAT五,NAPT网络地址端口转换(特殊的NAT,有地址池)六,Easy IP七,NAT服务器1,将私网服务器映射到公网服务器2,静态NAT配置3...
  • 文章目录实验要求 实验要求 ...PC2到PC5,使用动态NAT,创建NAT地址池1,范围为10.1.1.3-10.1.1.10 PC3到PC5,使用NAPT,创建NAT地址池2,范围为:10.1.1.11-10.1.1.20 PC4到PC5,使用easy ip ...
  • NAT(网络地址转换)及配置实验

    千次阅读 2020-03-07 23:29:46
    NAT,全称Network Address Translation,即网络地址转换。 作用:NAT就是进行内外网地址转换。 二、为什么学习NAT? 1.IPv4地址严重不够用 x.x.x.x x=0-255 如192.168.1.1 0.0.0.0 — 255.255.255.255 IPv6地址...
  • 静态NAT地址转换示例

    千次阅读 2019-10-17 11:38:58
    1.路由器(R2):给对应端口配对应IP地址,并配置默认路由 2.路由器(R1):给对应端口配对应IP地址,并配置默认路由 3.交换机(sw):配双工和速率 4.给各个PC机配对应IP地址 (1)PC1 PC1> ip 192....
  • NAT地址转换配置
  • 网络地址转换--动态NAT配置

    万次阅读 多人点赞 2018-07-04 11:23:31
    (3)掌握NAT转换中访问控制列表的应用;(4)掌握静态NAT的配置2.2 实验原理1.动态NAT动态转换(亦称NAT pool)是指不建立内部地址和全局地址的一对一的固定对应关系。而通过共享NAT地址池的IP地址动态建立NAT的...
  • NAT配置网络地址转换

    千次阅读 2019-03-27 18:48:36
    理解NAT网络地址转换的原理及功能; 掌握静态NAT配置,实现局域网访问互联网; 二、实验背景 公司欲发布WWW服务,现要求将内网Web服务器IP地址映射为全局IP地址,实现外部网络可访问公司内部Web服务器。 三、...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 48,618
精华内容 19,447
关键字:

nat地址转换配置