精华内容
下载资源
问答
  • Ubuntu安装CUDA10.2

    千次阅读 2020-06-10 11:05:53
    准备工作 确定你有支持CUDA的NVIDIA GPU ...确定要安装CUDA Toolkit版本 注意: 如果是用来训练TensorFlow、Pytorch等深度学习框架,请参考此类深度学习框架GPU版本的编译环境进行安装。 版本向下兼容??

    准备工作
    确定你有支持CUDA的NVIDIA GPU

    $ lspci | grep -i nvidia
    3b:00.0 3D controller: NVIDIA Corporation GP100GL [Tesla P100 PCIe 16GB] (rev a1)
    
    

    并前往这里对应位置查看当前GPU是否支持CUDA。

    确定要安装的CUDA Toolkit版本
    注意: 如果是用来训练TensorFlow、Pytorch等深度学习框架,请参考此类深度学习框架GPU版本的编译环境进行安装。

    版本向下兼容??(不确定,但应安装较新版本的CUDA)
    获取安装文件

    $ wget http://developer.download.nvidia.com/compute/cuda/10.2/Prod/local_installers/cuda_10.2.89_440.33.01_linux.run
    

    名称解释 cuda_10.2.89_440.33.01_linux.run
    10.2.89 :CUDA版本

    请自行验证文件的md5码。

    https://blog.csdn.net/qq_40930088/article/details/103389244

    展开全文
  • Ubuntu16.04安装CUDA10.2+CUDNN8.0 文章目录前言一、CUDA1.禁用nouveau驱动2.下载与安装3.配置环境变量二、CUDNN1.下载2.解压并复制文件3.查看cudnn版本 前言 自己在安装cuda和cudnn过程中遇到了很多问题,看了好多...

    Ubuntu16.04安装CUDA10.2+CUDNN8.0


    前言

    自己在安装cuda和cudnn过程中遇到了很多问题,看了好多篇文章,有些文章有小错误容易产生误导。今天终于安装成功把项目跑起来了,有心情记录一下我觉得比较重要的安装过程(检查自己电脑是否支持CUDA、各种验证那些步骤就略过了),为了自己以后方便查看,也希望能帮到有同样问题的人。


    一、CUDA

    1.禁用nouveau驱动

    这个步骤我在安装NVIDIA的驱动时做过了,差点忘了。
    (1)需要安装vim:

    sudo apt-get install vim

    (2) 编辑文件blacklist.conf:

    sudo vim /etc/modprobe.d/blacklist.conf

    在文件最后加入两行内容:

    blacklist nouveau

    options nouveau modeset=0

    (3)更新系统

    sudo update-initramfs -u

    (4)重启(reboot)后验证:

    lsmod | grep nouveau

    成功的话应该是没有输出,可以参考这几篇博客:
    link
    link
    link

    2.下载与安装

    看了好多文章,有些说的不清楚,有的甚至有错,最后发现直接去官网下载最清楚最直接。
    (1)下载之前要先查看自己的显卡对应的CUDA版本,否则版本不对应还要重头再来,直接去官网查看:
    link
    CUDA的历史版本链接:
    link
    推荐使用runfile方式安装,比较方便:
    CUDA的选择
    按照指示,第一条下载,下载成功后先不要执行第二条指令。
    (2)第二条安装(这里有的博主说需要关闭图形界面,但我是直接在文件所在目录的终端里安装成功的),如图所示:
    下载与安装指令
    (3)安装过程
    运行第二条指令后等待一段时间后会让选择,具体内容没看,大概是协议之类的,输入accept;

    然后再等一段时间选择安装内容,这里要注意不要装驱动,也就是把第一个X去掉:
    不要安装驱动
    然后选Install静静等待就可以了,最后安装成功会有提示,一个未选择,两个安装成功。

    3.配置环境变量

    (1)编辑bashrc文件:

    sudo gedit ~/.bashrc

    在文件最后加入:

    export CUDA_HOME=/usr/local/cuda
    export PATH=$PATH:$CUDA_HOME/bin
    export LD_LIBRARY_PATH=/usr/local/cuda-10.2/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
    

    保存文件,让环境变量生效:

    source ~/.bashrc

    (2)持久化守护程序(可选)

    # 以root用户启动NVIDIA Persistence Daemon
    $ /usr/bin/nvidia-persistenced --verbose
    

    (3)查看是否安装成功

    nvcc -V

    二、CUDNN

    1.下载

    需要有NVIDIA账户才可以下载,在历史版本版本中选择自己需要的:
    link

    2.解压并复制文件

    (1)解压tgz文件

    tar -xzvf cudnn文件名.tgz

    (2)复制文件到CUDA路径(这里防止输错可以看官网:link

    $ sudo cp cuda/include/cudnn*.h /usr/local/cuda/include
    $ sudo cp -P cuda/lib64/libcudnn* /usr/local/cuda/lib64
    $ sudo chmod a+r /usr/local/cuda/include/cudnn*.h /usr/local/cuda/lib64/libcudnn*
    

    3.查看cudnn版本

    cat /usr/local/cuda/include/cudnn_version.h | grep CUDNN_MAJOR -A 2


    展开全文
  • 1、前提是你已经正确安装cuda10.2.89,检查: nvidia-smi nvcc -V 2、重点来了哦 # 干正事(重点就这二步): cd /usr/local/cuda-10.2/targets/x86_64-linux/lib/ sudo ln -s libcudart.so.10.2.89 li

    目前tensorflow2.4.x以下官方标配cuda10.1,也是官方在github给出方案,修改cuda软链接即可,非常简单。也不影响pytorch1.5(cuda10.2.89)的继续使用。

    1、前提是你已经正确安装cuda10.2.89,检查:


    nvidia-smi
    nvcc -V
    

    2、重点来了哦

    
    # 干正事(重点就这二步):
    cd /usr/local/cuda-10.2/targets/x86_64-linux/lib/
    sudo ln -s libcudart.so.10.2.89 libcudart.so.10.1
    sudo ln -s libcupti.so.10.2.75 libcupti.so.10.1
    
    # 如果使用的是cudnn8.X 如果是cudnn7.x 请略过
    cd /usr/local/cuda-10.2/lib64
    sudo ln -s libcudnn.so.8 libcudnn.so.7
    
    
    # 检查添加路径:
    sudo vi ~/.bashrc
    
    export CUDA_HOME=/usr/local/cuda-10.2
    export LD_LIBRARY_PATH=${CUDA_HOME}/lib64:${CUDA_HOME}/extras/CUPTI/lib64
    export PATH=${CUDA_HOME}/bin:${PATH}
    
    source ~/.bashrc
    

    检查GPU:

    # 检查GPU:
    >python
    >>>import tensorflow as tf
    >>>tf.__version__
    2.3.1
    >>>tf.test.is_gpu_available()
    True
    >>>tf.config.list_physical_devices('GPU')
    [PhysicalDevice(name='/physical_device:GPU:0', device_type='GPU'),
     PhysicalDevice(name='/physical_device:GPU:1', device_type='GPU'),
     PhysicalDevice(name='/physical_device:GPU:2', device_type='GPU'),
     PhysicalDevice(name='/physical_device:GPU:3', device_type='GPU')]
    
    

    至此,大功告成!

    注:尽量使用TensorFlow2.x推荐版本,以免遇到不必要的问题。

    展开全文
  • ubuntu20.04安装CUDA10.2失败! 按照网上教程安装CUDA10.1 或 CUDA10.2时候,即执行官方的命令的时候 sudo sh cuda_10.2.89_440.33.01_linux.run 执行完这条命令后,直接提示了安装错误。 查看log [INFO]: md5 ...

    ubuntu20.04安装CUDA10.2失败!

    按照网上教程安装CUDA10.1 或 CUDA10.2时候,即执行官方的命令的时候

    sudo sh cuda_10.2.89_440.33.01_linux.run
    

    执行完这条命令后,直接提示了安装错误。
    查看log

    [INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/
    [ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/"
    [INFO]: md5 matches, removing file /usr/local/cuda-10.2/libnsight/plugins/org.eclipse.equinox.p2.core_2.3.0.v20131211-1531.jar
    [INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/
    [ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/"
    [INFO]: md5 matches, removing file /usr/local/cuda-10.2/libnsight/plugins/org.eclipse.core.net.linux.x86_64_1.1.100.v20140124-2013.jar
    [INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/
    [ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/"
    [INFO]: md5 matches, removing file /usr/local/cuda-10.2/libnsight/plugins/org.eclipse.core.contenttype_3.4.200.v20140207-1251.jar
    [INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/
    [ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Visual_Tools_10.2-components/"
    [INFO]: md5 matches, removing file /usr/local/cuda-10.2/libnsight/plugins/org.eclipse.ant.core_3.3.0.v20140518-0042.jar
    

    经过查阅资料,发现
    在sh xx.run后面加入路径即可正常安装,命令如下

    sh XX.linux.run --silent --toolkit --samples --librarypath=/usr/local/cuda
    #比如是CUDA10.1   则输入
    sudo sh cuda_10.2.89_440.33.01_linux.run  --silent --toolkit --samples --librarypath=/usr/local/cuda-10.1
    

    这样子就可以正常安装了。

    展开全文
  • ubuntu 安装 cuda10.2 8.0 及 cuBLAS

    千次阅读 2020-02-07 18:55:56
    1. 下载文件 Base Installer: cuda_8.0.61_375.26_linux.run(1.47G) 下载地址:...**Patch 2:**cuda_8.0.61.2_linux.run(9...
  • ubuntu18.04+cuda10.2+cudnn7.6.5
  • ubuntu cuda10.2+cudnn7.6.5

    2021-01-18 10:12:01
    cuda_10.2.89_440.33.01_linux.run cudnn-10.2-linux-x64-v7.6.5.32.tgz
  • ubuntu18 安装cuda10.2

    2020-08-31 08:34:21
    官网下载链接 这个是官网的cuda10的下载链接,教程也几乎不需要...sudo sh cuda_10.2.89_440.33.01_linux.run 选要注意的是,第一条下载命令在ubuntu上经常下载到一半失败,所以我都是在win10下用迅雷下载好再拷到ubu
  • (1)检查一下Ubuntu系统是否有nouveau在运行 lsmod | grep nouveau 如果有输出即说明nouveau正在运行 (2)禁用nouveau sudo gedit /etc/modprobe.d/blacklist.conf 打开blacklist.conf,在文件的最后输入 blacklist...
  • ubuntu16.04安装cuda10.2

    2021-03-03 20:53:19
    wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/cuda-ubuntu1604.pin ...wget https://developer.download.nvidia.com/compute/cuda/10.2/Prod/local_instal.
  • ubuntu18.04安装cuda10.2

    千次阅读 2021-01-01 16:13:02
    ubuntu18.04 2080Ti 安装cuda 最开始我用的是CPU自带的集成显卡,VGA接口直接插到主板的VGA口上的。...安装cuda时,提醒安装驱动失败,网上说要先禁用系统的显卡驱动。注意以下操作很危险,小心成砖。 一定要先给电脑电
  • Ubuntu18.04安装CUDA10.2 + cuDNN v7.6.5

    千次阅读 2020-02-14 15:28:04
    Ubuntu18.04安装CUDA10.2 + cuDNN v7.6.5 CUDA下载网址 cuDNN下载网址 1.安装CUDA10.2 NVIDIA CUDA Linux官方安装指南 1.1 安装前检查系统是否具有支持CUDA的GPU 如果您的显卡来自NVIDIA,并且在支持CUDA的GPU列表中...
  • 进入官网,找到对应的10.2版本,选择要安装的平台; 在终端执行命令: wget http://developer.download.nvidia.com/compute/cuda/10.2/Prod/local_installers/cuda_10.2.89_440.33.01_linux.run ...
  • ubuntu18.04 安装 cuda10.2 cudnn pytorch1.6.0心得 只能说,太心累了 一定一定一定在开始装之前,先确定好各个版本,版本不匹配可能会导致失败。 我用的各个版本:ubuntu18.04+cuda10.2+cudnn7.6.5+pytorch1.6.0 几...
  • wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-ubuntu1804.pin ...wget https://developer.download.nvidia.com/compute/cuda/10.2/Prod/local_installer
  • Ubuntu16.04在cuda10.2的基础上安装cuda11.0并存 文章目录Ubuntu16.04在cuda10.2的基础上安装cuda11.0并存前言一、安装cuda11.0二、安装cuDNN v8.0.4后记 前言 在ubuntu16.04系统中,安装cuda10.2版本,但是yolov...
  • Ubuntu16.04 RTX2060 安装CUDA10.2

    千次阅读 2020-07-15 11:14:32
    安装显卡驱动 一、查看适配显卡版本并下载 到英伟达官网搜索驱动https://www.nvidia.cn/geforce/drivers/ 搜索结果:(注意,非特殊需求,不要选择带BETA的版本) 选择最新的即可,(注意,非特殊需求,不要...
  • pycuda下载链接 https://pypi.tuna.tsinghua.edu.cn/simple/pycuda/ 安装过程 pip install -i 链接 pycuda --no-binary :all:
  • 由于研究需要,需要从Windows转移到Linux进行深度学习研究,遇见很多很多没有遇见的问题...Ubuntu现在推荐的是20.04LTS版本,但是在之后安装cuda时会显示错误。估计是版本兼容问题,所以请选择18.04LTS进行安装。 ...
  • ubuntu18.04.4安装cuda10.2 显卡驱动是上一篇文档中的版本 安装显卡驱动版本cuda-10.2 链接 记得要修改~/.bashrc export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda-10.2/lib64 export PATH=$PATH:/usr/...
  • ubuntu18.04安装cuda10.2+pytorch+pyg

    千次阅读 2020-07-31 22:38:15
    Anaconda安装 在服务器上装py环境,我建议首先装anaconda,我目前个人理解像是一个环境管理工具,在上面怎么玩也不怕崩,方便重来。 安装特别简单,官网下载或者随便怎么搞到安装包,然后 bash 安装包路径/安装包名....
  • Ubuntu 18安装CUDA10.2

    千次阅读 2020-04-30 11:21:42
    CUDA已经更新到10.2了,并且支持的最低的显卡驱动版本是440。然鹅...系统自带的显卡最高版本是435,要自己安装最新版本的显卡驱动,这就有点烦。 第一步,禁用nouveau 这里网上教程一搜一大把,汇总一下,首先在...
  • Ubuntu16.04安装cuda10.2 以及报错

    千次阅读 2020-08-03 20:13:04
    cuda官网按命令操作 添加链接描述 wget ...sudo mv cuda-ubuntu1604.pin /etc/apt/preferences.d/cuda-repository-pin-600 wget http://developer.download.nvidia.com/compute/cuda/1
  • Ubuntu环境下CUDA10.2安装

    万次阅读 2020-02-05 14:55:21
    Ubuntu环境下CUDA10.2安装 禁用nouveau 这里先解释下何为nouveau以及我们为什么要禁用它 首先说明下什么是Nouveau,为什么有些系统安装N卡驱动的时候会提示“ERROR: The Nouveau kernel driver is ...
  • 注:以下操作都在重装后的ubuntu进行 一.cmake 自定义版本安装 !!!!!!!!!!!!!!!!!!!!!!!!!!!!1 千万不要 apt-get autoremove cmake 否则重装系统吧 autoremove删除很多依赖,后续编译...
  • https://blog.csdn.net/qq_33431368/article/details/84717053
  • ubuntu18.04 安装cuda10.2 ``` sudo sh cuda_10.2.89_440.33.01_linux.run ``` 已禁用nouveau nvidia 显卡驱动已安装 出现Extraction failed的错误 cuda安装失败 ![图片说明]...
  • 目录1,官网下载cuda及cudnn2,安装cuda(包含驱动,在命令行模式下操作)3,配置cuda环境变量4,安装cudnn 环境虐我千百遍,我待环境如初恋,说多了都是泪,开装。 1,官网下载cuda及cudnn cuda中包含NVIDIA驱动,...
  • cuda安装 会提示: ***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 384.00 is required for CUDA 10.0 functionality to work.忽略就行...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,471
精华内容 1,388
关键字:

ubuntu安装cuda10.2