精华内容
下载资源
问答
  • VLAN 千次阅读
    2019-05-22 09:48:48

    VLAN报文结构:

    VLAN11.png

    è¿éåå¾çæè¿°

    TPID    2Byte    Tag Protocol Identifier(标签协议标识符),表示数据帧类型。    表示帧类型,取值为0x8100时表示IEEE 802.1Q的VLAN数据帧。如果不支持802.1Q的设备收到这样的帧,会将其丢弃。 各设备厂商可以自定义该字段的值。当邻居设备将TPID值配置为非0x8100时, 为了能够识别这样的报文,实现互通,必须在本设备上修改TPID值,确保和邻居设备的TPID值配置一致。
    PRI    3bit    Priority,表示数据帧的802.1p优先级。    取值范围为0~7,值越大优先级越高。当网络阻塞时,设备优先发送优先级高的数据帧。
    CFI    1bit    Canonical Format Indicator(标准格式指示位),表示MAC地址在不同的传输介质中是否以标准格式进行封装,用于兼容以太网和令牌环网。    CFI取值为0表示MAC地址以标准格式进行封装,为1表示以非标准格式封装。在以太网中,CFI的值为0。
    VID    12bit    VLAN ID,表示该数据帧所属VLAN的编号。    VLAN ID取值范围是0~4095。由于0和4095为协议保留取值,所以VLAN ID的有效取值范围是1~4094。

     

    同类型接口添加或剥除VLAN标签的比较
    接口类型    对接收不带Tag的报文处理    对接收带Tag的报文处理    发送帧处理过程
    Access接口    接收该报文,并打上缺省的VLAN ID。    当VLAN ID与缺省VLAN ID相同时,接收该报文。当VLAN ID与缺省VLAN ID不同时,丢弃该报文。    先剥离帧的PVID Tag,然后再发送。
    Trunk接口    打上缺省的VLAN ID,当缺省VLAN ID在允许通过的VLAN ID列表里时,接收该报文。打上缺省的VLAN ID,当缺省VLAN ID不在允许通过的VLAN ID列表里时,丢弃该报文。    当VLAN ID在接口允许通过的VLAN ID列表里时,接收该报文。当VLAN ID不在接口允许通过的VLAN ID列表里时,丢弃该报文。    当VLAN ID与缺省VLAN ID相同,且是该接口允许通过的VLAN ID时,去掉Tag,发送该报文。当VLAN ID与缺省VLAN ID不同,且是该接口允许通过的VLAN ID时,保持原有Tag,发送该报文。
    Hybrid接口    打上缺省的VLAN ID,当缺省VLAN ID在允许通过的VLAN ID列表里时,接收该报文。打上缺省的VLAN ID,当缺省VLAN ID不在允许通过的VLAN ID列表里时,丢弃该报文。    当VLAN ID在接口允许通过的VLAN ID列表里时,接收该报文。当VLAN ID不在接口允许通过的VLAN ID列表里时,丢弃该报文。    当VLAN ID是该接口允许通过的VLAN ID时,发送该报文。可以通过命令设置发送时是否携带Tag。

     

    - 当接收到不带VLAN标签的数据帧时,Access接口、Trunk接口、Hybrid接口都会给数据帧打上VLAN标签,但Trunk接口、Hybrid接口会根据数据帧的VID是否为其允许通过的VLAN来判断是否接收,而Access接口则无条件接收。

    当接收到带VLAN标签的数据帧时,Access接口、Trunk接口、Hybrid接口都会根据数据帧的VID是否为其允许通过的VLAN(Access接口允许通过的VLAN就是缺省VLAN)来判断是否接收。

    当发送数据帧时:

    Access接口直接剥离数据帧中的VLAN标签。
    Trunk接口只有在数据帧中的VID与接口的PVID相等时才会剥离数据帧中的VLAN标签。
    Hybrid接口会根据接口上的配置判断是否剥离数据帧中的VLAN标签。
    因此,Access接口发出的数据帧肯定不带Tag,Trunk接口发出的数据帧只有一个VLAN的数据帧不带Tag,其他都带VLAN标签,Hybrid接口发出的数据帧可根据需要设置某些VLAN的数据帧带Tag,某些VLAN的数据帧不带Tag。
     

     

     

    更多相关内容
  • 任务4 Super VLAN技术配置示例 0 1 【知识目标】 熟悉Super VLAN的基本原理 【能力目标】 能学会Super VLAN的配置 【思政目标】 培养学生的工匠精神,提高综合职业素养,树立社会主义职业精神。 课程目标 Super VLAN...
  • 可以将RealTek瑞昱网卡设置为Trunk模式,虚拟多个网卡连接不同vlan。适合单机要连接多个vlan的环境,亲测可用。
  • Windows中realtek-VLAN驱动

    2017-02-06 22:15:40
    Windows中realtek-VLAN驱动
  • 一、VLAN基本概念 什么是VLAN 逻辑划分、不受地理位置限制 VLAN的作用 VLAN=LAN=局域网=IP子网=广播域 所以VLAN能够隔离广播域 VLAN帧格式 TPID:标签协议标识符,字段长度16字节,值为0x8100,表示该帧是带802.1Q...

    一、VLAN基本概念

    什么是VLAN
    逻辑划分、不受地理位置限制

    VLAN的作用
    VLAN=LAN=局域网=IP子网=广播域
    所以VLAN能够隔离广播域

    VLAN帧格式
    在这里插入图片描述
    TPID:标签协议标识符,字段长度16字节,值为0x8100,表示该帧是带802.1Q标签
    Pri:表示数据帧的802.1P优先级,字段长度3bit,取值为0-7,用于Qos
    CFI:0表示经典格式,1表示非经典,如令牌环网
    VID:表示该帧所属 VLAN,字段长度为 12bit ,取值1-4095

    链路类型
    接入链路:用于连接用户主机和交换机的链路。
    干道链路:用于交换机间的互连或交换机与路由器之间的连接。

    缺省VLAN
    每种类型的接口都可以配置一个缺省 VLAN,对应的 VLAN ID 为 PVID(Port Default VLAN ID)。接口类型不同,缺省 VLAN 的含义也有所不同。
    PVID表示端口缺省情况下所属VLAN

    VLAN划分方式
    在这里插入图片描述

    各类型接口对数据帧处理方式
    在这里插入图片描述
    Trunk和Hybrid区别:
    发送数据帧的过程中,在允许通过的情况下,trunk模式下,只允许缺省 VLAN 的报文发送时不打标签;hybrid模式下,允许多个 VLAN 的报文发送时不打标签。

    Hybrid应用场景:
    使用策略划分VLAN的网络中,交换机的一个接口下可能连接了多台属于不同VLAN的设备,这些设备发的数据帧都不带标签,交换机接收后需要根据策略给数据帧打上不同VLAN的标签,这时必须要使用Hybrid接口

    实验
    在这里插入图片描述
    实验现象:PC5能ping通PC6,PC1不能ping通PC4,PC2不能ping通PC3

    二、QinQ

    简介
    QinQ 是在 802.1Q VLAN 的基础上增加了一层 802.1Q VLAN 标签,拓展了 VLAN 空间。

    报文格式
    在这里插入图片描述
    QinQ实现方式
    QinQ实现方式分为两种:基本QinQ和灵活QinQ
    ①基本QinQ:开启接口的基本QinQ功能后,当该接口接收到报文,设备会为该报文打上本接口缺省VLAN的VLAN Tag。如果已带有Tag,就会成为双Tag报文;如果没有Tag,打上该接口VLAN Tag报文。
    ②灵活QinQ:基于端口和VLAN相结合的方式实现的。除基本QinQ功能之外,对于同一个接口接收的报文可以根据不同的VLAN做不同的动作。
    在这里插入图片描述

    TPID(标签协议标识符)
    通过检查TPID的值,设备可确定收到的帧,承载的是运营商VLAN Tag还是用户VLAN Tag。
    通常在QinQ中设备的内外层标签TPID值均采用协议规定的0x8100,但是某些厂商的设备将QinQ报文外层Tag TPID值设置为0x9100、0x9200

    实验
    基本QinQ实验
    在这里插入图片描述

    SW1:
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    
    SW2:
    #
    interface GigabitEthernet0/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    
    SW3:
    interface GigabitEthernet0/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    
    SW4:
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    

    实验现象:
    PC1 ping PC3时,抓取SW2的G0/0/1数据包
    在这里插入图片描述
    同时抓取SW2的G0/0/2数据包
    在这里插入图片描述

    灵活QinQ实验
    在这里插入图片描述

    SW1:
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    
    SW2:
    interface GigabitEthernet0/0/1
     qinq vlan-translation enable
     port hybrid tagged vlan 10 20
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 stack-vlan 100
     port vlan-stacking vlan 20 stack-vlan 200
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    
    SW3:
    interface GigabitEthernet0/0/1
     qinq vlan-translation enable
     port hybrid tagged vlan 10 20
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 stack-vlan 100
     port vlan-stacking vlan 20 stack-vlan 200
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    
    SW4:
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    

    实验现象:
    PC1 ping PC3时,抓取SW2的G0/0/1数据包
    在这里插入图片描述
    同时抓取SW2的G0/0/2数据包
    在这里插入图片描述
    PC2 ping PC4时,抓取SW2的G0/0/1数据包
    在这里插入图片描述
    同时抓取SW2的G0/0/2数据包
    在这里插入图片描述

    三、VLAN Aggregation

    产生背景
    一般在三层交换机中,通常是采用一个VLAN对应一个三层逻辑接口的方式实现广播域之间的互通。当遇到同一个子网、不同VLAN的情况下,两个(两个以上)的三层逻辑接口不能配置同一个子网的网关。

    实现原理
    VLAN Aggregation用于多个VLAN隔离广播域,使不同VLAN属于同一个的子网
    在这里插入图片描述
    Sub-VLAN之间通信
    不同的Sub-VLAN的主机使用的是同一个网段的地址和共用同一个网关地址,彼此通信时只会做二层转发,而不会通过网关进行三层转发。实际上不同的 Sub-VLAN的主机在二层是相互隔离的,这就造成了 Sub-VLAN 间无法通信的问题。
    解决方法:在Super-VLAN开启ARP Proxy。

    实验
    在这里插入图片描述

    SW1:
    vlan batch 10 20 30 100
    #
    vlan 100
     aggregate-vlan
     access-vlan 10 20 30
    #
    interface Vlanif100
     ip address 192.168.1.254 255.255.255.0
     arp-proxy inter-sub-vlan-proxy enable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    

    实验现象:能够实现PC1与PC2互访:
    在这里插入图片描述

    四、MUX VLAN

    产生背景
    如果要实现部分用户之间互通、部分用户之间隔离。比如企业内部员工之间互相通信,企业客户之间互相隔离。
    如果企业拥有大量的用户,这就需要大量的VLAN ID,增加工作量和维护难度。
    所以通过MUX VLAN来解决这个缺点。

    基本概念
    在这里插入图片描述
    在这里插入图片描述
    实验
    在这里插入图片描述

    SW1:
    sysname SW1
    #
    vlan batch 10 20 30 40
    #
    vlan 10
     description caiwu Group VLAN 10
    vlan 20
     description shichang Group VLAN 20
    vlan 30
     description kehu Separate VLAN 30
    vlan 40
     description fuwuqi Principal VLAN 40
     mux-vlan
     subordinate separate 30
     subordinate group 10 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 40
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 40
    
    SW2:
    sysname SW2
    #
    vlan batch 10 20 30 40
    #
    vlan 10
     description caiwu Group VLAN 10
    vlan 20
     description shichang Group VLAN 20
    vlan 30
     description kehu Separate VLAN 30
    vlan 40
     description fuwuqi Principal VLAN 40
     mux-vlan
     subordinate separate 30
     subordinate group 10 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 10
     port mux-vlan enable
    
    SW3:
    sysname SW3
    #
    vlan batch 10 20 30 40
    #
    vlan 10
     description caiwu Group VLAN 10
    vlan 20
     description shichang Group VLAN 20
    vlan 30
     description kehu Separate VLAN 30
    vlan 40
     description fuwuqi Principal VLAN 40
     mux-vlan
     subordinate separate 30
     subordinate group 10 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 30
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
     port mux-vlan enable
    

    实验现象:
    Server与所有主机都能通信
    PC1与PC5二层流量互通,PC1与PC2、3、4 二层流量不通
    PC2与PC1、3、4、5二层流量不通
    PC3与PC1、2、4、5二层流量不通
    PC4与PC1、2、3、5二层流量不通
    PC5与PC1二层流量互通,PC5与PC2、3、4 二层流量不通

    注意事项:
    在配置开启mux-vlan情况下,不能配置三层逻辑接口,所以所有vlan同属一个子网。

    [Huawei]VLAN batch 2 3 4
    [Huawei]INT VLAN 2
    [Huawei-Vlanif2]IP AD 192.168.1.1 24
    [Huawei]vlan 2
    [Huawei-vlan2]	
    [Huawei-vlan2]mux-vlan 
    Error: The VLAN has a L3 interface, Please delete it first.
    

    五、Voice VLAN

    产生背景
    保证语音数据优先传输,减少传输过程中时延的产生和丢包现象

    实现原理
    首先识别出语音数据流,然后将语音数据流优先级提高
    使能Voice VLAN功能的接口,可以通过以下两种方式来实现对语音数据流的识别:
    ①通过收到报文的源MAC地址,即基于MAC地址的方式
    设备可以根据进入接口的数据报文中的源 MAC 地址宇段来判断该数据流是否为语音数据流,源MAC地址匹配OUI的报文被认为使语音数据流
    ②通过报文携带的VLAN Tag,即基于VLAN的方式
    设备可以根据进入接口的数据报文中VLAN ID匹配设置的Voice VLAN,则认为使语音数据流

    Voice VLAN的OUI地址
    OUI地址表示一个MAC地址段。例如,MAC地址为1–1–1,掩码为FFFF-FF00–0000,运算的结果就是OUI地址 0001–0000–0000。
    只要接入设备的 MAC 地址前24位和OUI地址的前 24 位匹配,那么使能Voice VLAN功能的接口将认为此数据流是语音数据流,接入的设备是语音设备。

    实验
    ①基于MAC地址:
    在这里插入图片描述

    [SW2] interface gigabitethemet 0/0/1 
    [SW2-GigabitEthernet0/0/1] port link-type hybrid 
    [SW2-GigabitEthernet0/0/1] port hybrid pvid vlan 3 
    [SW2-GigabitEthernet0/0/1] port hybrid untagged vlan 2 to 3 
    [SW2-GigabitEthernet0/0/1] quit 
    [SW2] interface gigabitethemet 0/0/2 
    [SW2-GigabitEthemetO/0/2] port link-type hybrid 
    [SW2-GigabitEthemetO/0/2] port hybrid untagged vlan 2 
    [SW2-GigabitEthernetO/0/2] quit
    配置OUI:
    [SW2] voice-vlan mac-address 0003-6B00-0000 mask ffff- ff00-0000 //配置Voice VLAN的OUI
    [Switch] interface gigabitetbernet 0/0/1 
    [Switch-GigabitEthernet0/0/1] voice-vlan 2 enable include-untagged //指定Vlan是Voice VLAN,同时使能接口的Voice VLAN功能
    [Switch-GigabitEthernet0/0/1] voice-vlan remark-mode mac-address //配置语音报文按照MAC地址提升优先级
    [Switch-GigabitEthernet0/0/1] quit
    
    最后用命令display voice-vlan 2 status
    

    ②基于VLAN
    在这里插入图片描述

    [SW2] interface gigabitethemet 0/0/1 
    [SW2-GigabitEthernet0/0/1] port link-type hybrid 
    [SW2-GigabitEthernet0/0/1] port hybrid pvid vlan 3 
    [SW2-GigabitEthernet0/0/1] port hybrid untagged vlan 2 to 3 
    [SW2-GigabitEthernet0/0/1] quit 
    [SW2] interface gigabitethemet 0/0/2 
    [SW2-GigabitEthemetO/0/2] port link-type hybrid 
    [SW2-GigabitEthemetO/0/2] port hybrid untagged vlan 2 
    [SW2-GigabitEthernetO/0/2] quit
    使能LLDP:
    [SW2]lldp enable //使能LLDP协议
    [SW2] interface gigabitethemet 0/0/1 
    [SW2-GigabitEthernet0/0/1] voice-vlan 2 enable  //指定Vlan是Voice VLAN,同时使能接口的Voice VLAN功能
    [SW2-GigabitEthernet0/0/1] voice-vlan remark-mode vlan //配置语音报文按照VLAN提升优先级
    [SW2-GigabitEthernet0/0/1] quit
    
    最后用命令display voice-vlan 2 status
    
    展开全文
  • 华三vlan配置

    千次阅读 2021-10-04 10:11:49
    基于MAC地址划分vlan 配置思路: 创建VLAN 100、VLAN 200。 配置Device A和Device C的上行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过。 配置 Device B 的下行端口为Trunk端口,并允许VLAN 100和VLAN 200...

    基于MAC地址划分vlan
    在这里插入图片描述

    配置思路:
    创建VLAN 100、VLAN 200。
    配置Device A和Device C的上行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过。
    配置 Device B 的下行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过;上行端口分别加入VLAN 100、VLAN 200。
    Laptop1和Laptop2的MAC地址分别与VLAN 100、VLAN 200关联。

    SWA与SWC的配置一致:
    创建vlan:
    vlan 100
    vlan 200

    将mac与vlan绑定:
    mac-vlan mac-address 000d-88f8-4e71 vlan 100
    mac-vlan mac-address 0014-222c-aa69 vlan 200

    配置链路类型为混合链路,并使其在发送VLAN 100和VLAN 200的报文时去掉VLAN Tag;开启端口的MAC-VLAN功能
    interface gigabitethernet 1/0/1
    port link-type hybrid
    port hybrid vlan 100 200 untagged
    mac-vlan enable

    端口类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过。
    interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 100 200

    SWB配置:
    vlan 100
    port gigabitethernet 1/0/13
    vlan 200
    port gigabitethernet 1/0/14
    interface gigabitethernet 1/0/3
    port link-type trunk
    port trunk permit vlan 100 200
    interface gigabitethernet 1/0/4
    port link-type trunk
    port trunk permit vlan 100 200

    查看:
    display mac-vlan all
    注意:
    基于MAC的VLAN只能在Hybrid端口上配置。
    基于MAC的VLAN的配置主要用于在用户的接入设备的下行端口上进行配置,因此不能与聚合功能同时使用。

    配置基于协议的vlan:
    实验室网络中大部分主机运行IPv4网络协议,另外为了教学需要还布置了IPv6实验局,因此,同时有些主机运行着IPv6网络协议。为了避免互相干扰,现要求基于网络协议将IPv4流量和IPv6流量二层互相隔离。
    在这里插入图片描述

    Device配置:
    创建VLAN 100,将端口GigabitEthernet1/0/11加入VLAN 100。
    vlan 100
    description protocol VLAN for IPv4
    port gigabitethernet 1/0/11

    创建VLAN 200,将端口GigabitEthernet1/0/12加入VLAN 200。
    vlan 200
    description protocol VLAN for IPv6
    port gigabitethernet 1/0/12

    在VLAN 200和VLAN 100视图下,分别为IPv4和IPv6协议创建协议模板。
    vlan 200
    protocol-vlan 1 ipv6
    vlan 100
    protocol-vlan 1 ipv4

    配置端口GigabitEthernet1/0/1为Hybrid端口,并在转发VLAN 100和VLAN 200的报文时去掉VLAN Tag。
    interface gigabitethernet 1/0/1
    port link-type hybrid
    port hybrid vlan 100 200 untagged

    配置端口GigabitEthernet1/0/1与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。
    interface gigabitethernet 1/0/1
    port hybrid protocol-vlan vlan 100 1
    port hybrid protocol-vlan vlan 200 1

    配置端口GigabitEthernet1/0/2为Hybrid端口,在转发VLAN 100和VLAN 200的报文时去掉VLAN Tag,与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。
    interface gigabitethernet 1/0/2
    port link-type hybrid
    port hybrid vlan 100 200 untagged
    port hybrid protocol-vlan vlan 100 1
    port hybrid protocol-vlan vlan 200 1

    将IPv4 Host A、IPv4 Host B和IPv4 Server配置在一个网段,比如192.168.100.0/24;将IPv6 Host A、IPv6 Host B和IPv6 Server配置在一个网段,比如2001::1/64
    查看Device上协议VLAN的配置:
    display protocol-vlan vlan all
    查看Device端口上已配置的协议VLAN的相关信息:
    display protocol-vlan interface
    注意:基于协议的VLAN只对Hybrid端口配置才有效

    基于IP子网的VLAN简介
    基于IP子网的VLAN是根据报文源IP地址及子网掩码来进行划分的。设备从端口接收到Untagged报文后,会根据报文的源地址来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。
    此特性主要用于将指定网段或IP地址发出的报文在指定的VLAN中传送
    基于IP子网的VLAN只对Hybrid端口配置有效
    在这里插入图片描述

    配置思路
    创建VLAN100、VLAN200,配置子网与VLAN的关联关系,并配置端口与VLAN的关联关系。

    配置步骤
    配置子网192.168.5.0/24与VLAN 100关联。
    vlan 100
    ip-subnet-vlan ip 192.168.5.0 255.255.255.0

    配置子网192.168.50.0/24与VLAN 200关联。
    vlan 200
    ip-subnet-vlan ip 192.168.50.0 255.255.255.0

    配置端口GigabitEthernet 1/0/11,使其允许通过VLAN 100的报文。
    interface GigabitEthernet 1/0/11
    port link-type hybrid
    port hybrid vlan 100 tagged

    配置端口GigabitEthernet 1/0/12,使其允许通过VLAN 200的报文。
    interface GigabitEthernet 1/0/12
    port link-type hybrid
    port hybrid vlan 200 tagged

    配置端口GigabitEthernet 1/0/1,使其和基于IP子网的VLAN 100、VLAN 200关联。
    interface GigabitEthernet 1/0/1
    port link-type hybrid
    port hybrid vlan 100 200 untagged
    port hybrid ip-subnet-vlan vlan 100
    port hybrid ip-subnet-vlan vlan 200

    查看所有VLAN的IP子网信息
    display ip-subnet-vlan vlan all

    查看端口GigabitEthernet 1/0/1上所配置的IP子网VLAN信息
    display ip-subnet-vlan interface GigabitEthernet 1/0/1

    Super vlan简介:
    随着网络的发展,网络地址资源日趋紧张,为了节省IP地址,Super VLAN的概念被提出来。Super VLAN又称为VLAN聚合(VLAN Aggregation),其原理是一个Super VLAN和多个Sub VLAN关联,Super VLAN内不能加入物理端口,但可以创建对应的VLAN接口,VLAN接口下可以配置IP地址;Sub VLAN可以加入物理端口,但不能创建对应的VLAN接口,所有Sub VLAN内的端口共用Super VLAN的VLAN接口IP地址,不同Sub VLAN之间二层相互隔离。当Sub VLAN内的用户需要进行三层通信时,将使用Super VLAN的IP地址作为网关地址,这样多个Sub VLAN共享一个网关地址,从而节省了IP地址资源。
    为了实现Sub VLAN之间的三层互通,在创建好Super VLAN和VLAN接口之后,用户需要开启设备的本地代理功能。用户在Super VLAN的VLAN接口上开启本地代理ARP功能后,Super VLAN利用本地代理ARP可以进行ARP请求和响应报文的转发与处理,从而实现了Sub VLAN之间的三层互通。

    Super vlan配置:
    组网需求
    创建Super VLAN 10,VLAN接口的IP地址为10.0.0.1/24。
    创建Sub VLAN:VLAN 2、VLAN 3、VLAN 5。
    端口GigabitEthernet1/0/1和端口GigabitEthernet1/0/2属于VLAN 2,端口GigabitEthernet1/0/3和端口GigabitEthernet1/0/4属于VLAN 3,端口GigabitEthernet1/0/5和端口GigabitEthernet1/0/6属于VLAN 5。
    各Sub VLAN的用户之间能够满足二层隔离和三层互通。

    在这里插入图片描述

    配置步骤:
    创建VLAN 10,配置VLAN接口的IP地址为10.0.0.1/24。
    vlan 10
    interface vlan-interface 10
    ip address 10.0.0.1 255.255.255.0

    为实现Super VLAN特性,开启设备的本地代理功能。
    interface vlan-interface 10
    local-proxy-arp enable

    创建VLAN 2,并添加端口GigabitEthernet1/0/1和端口GigabitEthernet1/0/2。
    vlan 2
    port gigabitethernet 1/0/1 gigabitethernet 1/0/2

    创建VLAN 3,并添加端口GigabitEthernet1/0/3和端口GigabitEthernet1/0/4。
    vlan 3
    port gigabitethernet 1/0/3 gigabitethernet 1/0/4

    创建VLAN 5,并添加端口GigabitEthernet1/0/5和端口GigabitEthernet1/0/6。
    vlan 5
    port gigabitethernet 1/0/5 gigabitethernet 1/0/6

    指定VLAN 10为Super VLAN,VLAN 2、VLAN 3和VLAN 5为Sub VLAN。
    vlan 10
    supervlan
    subvlan 2 3 5

    查看Super VLAN的相关信息,验证以上配置是否生效。
    display supervlan

    Isolate-user-VLAN采用两层VLAN结构,它在同一台设备上设置Isolate-user-VLAN和Secondary VLAN两类VLAN。
    Isolate-user-VLAN用于上行,不同的Secondary VLAN关联到同一个Isolate-user-VLAN。上行连接的设备只知道Isolate-user-VLAN,而不必关心Secondary VLAN,简化了网络配置,节省了VLAN资源。
    Secondary VLAN用于连接用户,Secondary VLAN之间二层报文互相隔离。如果希望实现同一Isolate-user-VLAN下Secondary VLAN用户之间报文的互通,可以通过配置上行设备(如图中Device A)的本地ARP代理功能来实现三层报文的互通。
    一个Isolate-user-VLAN可以和多个Secondary VLAN相对应。Isolate-user-VLAN下面的Secondary VLAN对上行设备不可见。
    如下图所示,设备Device B上启动了Isolate-user-VLAN功能。其中VLAN 10是Isolate-user-VLAN;VLAN 2、VLAN 5、VLAN 8是Secondary VLAN;VLAN 2、VLAN 5、VLAN 8都映射到VLAN 10;VLAN 2、VLAN 5、VLAN 8对Device A不可见
    在这里插入图片描述

    实验配置:
    组网需求
    Device A下接Device B、Device C。
    Device B上的VLAN 5为Isolate-user-VLAN,包含上行端口GigabitEthernet1/0/5和两个Secondary VLAN(VLAN 2和VLAN 3),VLAN 2包含端口GigabitEthernet1/0/2,VLAN 3包含端口GigabitEthernet1/0/1。
    Device C上的VLAN 6为Isolate-user-VLAN,包含上行端口GigabitEthernet1/0/5和两个Secondary VLAN(VLAN 3和VLAN 4),VLAN 3包含端口GigabitEthernet1/0/3,VLAN 4包含端口GigabitEthernet1/0/4。
    从Device A看,下接的Device B只有一个VLAN(VLAN 5),下接的设备C只有一个VLAN(VLAN 6)
    在这里插入图片描述

    配置步骤
    下面只列出Device B和Device C的配置过程。
    配置Device B
    配置VLAN 5为Isolate-user-VLAN。
    vlan 5
    isolate-user-vlan enable

    创建Secondary VLAN。
    vlan 2 to 3

    配置上行端口GigabitEthernet 1/0/5在VLAN 5中工作在promiscuous模式。
    interface gigabitethernet 1/0/5
    port isolate-user-vlan 5 promiscuous

    将下行端口GigabitEthernet 1/0/1、GigabitEthernet 1/0/2分别添加到VLAN 3、VLAN 2,并配置它们工作在host模式。
    interface gigabitethernet 1/0/1
    port access vlan 3
    port isolate-user-vlan host
    interface gigabitethernet 1/0/2
    port access vlan 2
    port isolate-user-vlan host

    配置Isolate-user-VLAN和Secondary VLAN间的映射关系。
    isolate-user-vlan 5 secondary 2 to 3

    配置Device C
    配置VLAN 6为Isolate-user-VLAN。
    vlan 6
    isolate-user-vlan enable

    创建Secondary VLAN。
    vlan 3 to 4

    配置上行端口GigabitEthernet 1/0/5在VLAN 6中工作在promiscuous模式。
    interface gigabitethernet 1/0/5
    port isolate-user-vlan 6 promiscuous

    将下行端口GigabitEthernet 1/0/3、GigabitEthernet 1/0/4分别添加到VLAN 3、VLAN 4,并配置它们工作在host模式。
    interface gigabitethernet 1/0/3
    port access vlan 3
    port isolate-user-vlan host
    interface gigabitethernet 1/0/4
    port access vlan 4
    port isolate-user-vlan host

    配置Isolate-user-VLAN和Secondary VLAN间的映射关系。
    isolate-user-vlan 6 secondary 3 to 4

    显示与验证
    显示Device B上的Isolate-user-VLAN配置情况。
    display isolate-user-vlan

    Voice VLAN:
    Voice VLAN是为用户的语音数据流而专门划分的VLAN。通过划分Voice VLAN并将连接语音设备的端口加入Voice VLAN,系统自动为语音报文修改QoS(Quality of Service,服务质量)参数,来提高语音数据报文优先级、保证通话质量。
    常见的语音设备有IP电话、IAD(Integrated Access Device,综合接入设备)等。本文中以IP电话为例进行说明
    设备可以根据进入端口的数据报文中的源MAC地址字段来判断该数据流是否为语音数据流。源MAC地址符合系统设置的语音设备

    OUI(Organizationally Unique Identifier,全球统一标识符)地址的报文被认为是语音数据流。
    用户可以预先设置OUI地址,也可以使用缺省的OUI地址作为判断标准。设备缺省的OUI地址如图所示。
    在这里插入图片描述
    通常意义下,OUI地址指的是MAC地址的前24位(二进制),是IEEE为不同设备供应商分配的一个全球唯一的标识符。本文中的OUI地址有别于通常意义的OUI地址,它是设备判断收到的报文是否为语音报文的依据,是voice vlan mac-address命令中的mac-address和oui-mask参数相与的结果。
    设备缺省的OUI地址可以手工删除,删除之后也可再次手工添加。

    Voice VLAN的自动模式和手动模式
    Voice VLAN的工作模式包括自动模式和手动模式,这个自动和手动指的是端口加入Voice VLAN的方式。

    自动模式:系统利用IP电话上电时发出的协议报文(Untagged报文),通过识别报文的源MAC,匹配OUI地址。匹配成功后,系统将自动把语音报文的入端口加入Voice VLAN,并下发ACL规则、配置报文的优先级。用户可以在设备上设置Voice VLAN的老化时间,当在老化时间内,系统没有从入端口收到任何语音报文时,系统将把该端口从Voice VLAN中删除。端口的添加/删除到Voice VLAN的过程由系统自动实现。自动模式适用于PC-IP电话串联接入(端口同时传输语音数据和普通业务数据)的组网方式,如下图所示。(当Voice VLAN正常工作时,如果遇到设备重新启动的情况,为保证已经建立的语音连接能够正常工作,系统会在重新启动完成后,将配置为自动模式的端口重新加入Voice VLAN,而不需要再次通过语音流触发。)

    主机与IP电话串联接入组网图
    在这里插入图片描述

    手动模式下,需要通过手工把IP电话接入端口加入Voice VLAN中。再通过识别报文的源MAC,匹配OUI地址。匹配成功后,系统将下发ACL规则、配置报文的优先级。端口的添加/删除到Voice VLAN的过程由管理员手动实现。手动模式适用于IP电话单独接入(端口仅传输语音报文)的组网方式,如下图所示。该组网方式可以使该端口专用于传输语音数据,最大限度避免业务数据对语音数据传输的影响。

    IP电话单独接入组网图
    在这里插入图片描述

    对于IP电话发出的携带Tag标签的报文,两种模式处理方式一致,只根据标签进行转发。
    由于IP电话类型较多,因此需要用户保证端口的链路类型与IP电话能够匹配,详细配合关系请见下表:
    IP电话发送Tagged语音数据
    不同类型端口支持Untagged语音数据配置要求
    在这里插入图片描述

    IP电话发送Untagged语音数据
    当IP电话发送Untagged语音数据,则端口的Voice VLAN工作模式只能为手工模式,不能为自动模式。
    不同类型端口支持Untagged语音数据配置要求
    在这里插入图片描述

    注意:
    如果用户的IP Phone发出的是Tagged语音流,且接入的端口上使能了802.1X认证和Guest VLAN,为保证各种功能的正常使用,请为Voice VLAN、端口的缺省VLAN和802.1X的Guest VLAN分配不同的VLAN ID。
    如果用户的IP Phone发出的是Untagged语音流,为实现Voice VLAN功能,只能将接入端口的缺省VLAN配置为Voice VLAN,此时将不能实现802.1X认证功能。

    Voice VLAN的安全模式和普通模式
    根据使能了Voice VLAN功能的端口对接收到的数据包的过滤机制又可以将Voice VLAN的工作模式分为普通模式和安全模式:
    普通模式下,端口加入Voice VLAN后,设备对于接收的语音报文不再一一进行识别,凡是带有Voice VLAN Tag的报文,设备将不再检查其源MAC地址是否为语音设备的OUI地址,均接收并在Voice VLAN中转发。对于缺省VLAN就是Voice VLAN的手工模式端口,会导致任意的Untagged报文都可以在Voice VLAN中传输。这样的处理方式很容易使Voice VLAN收到恶意用户的流量攻击。恶意用户可以构造大量带有Voice VLAN Tag的报文,占用Voice VLAN的带宽,影响正常的语音通信。
    安全模式下,设备将对每一个要进入Voice VLAN传输的报文进行源MAC匹配检查,对于不能匹配OUI地址的报文,则将其丢弃。
    对于比较安全的网络,用户可以配置Voice VLAN的普通模式,以减少检查报文的工作对系统资源的占用。
    注意:
    建议用户尽量不要在Voice VLAN中同时传输语音和业务数据。如确有此需要,请确认Voice VLAN的安全模式已关闭。

    Voice VLAN的安全/普通模式对报文的处理
    在这里插入图片描述

    自动模式下Voice VLAN的配置举例
    组网需求
    IP phone A的MAC地址为0011-1100-0001,下行连接PC A(MAC地址为0022-1100-0002),上行连接到Device A的GigabitEthernet1/0/1端口。

    IP phone B的MAC地址为0011-2200-0001,下行连接PC B(MAC地址为0022-2200-0002),上行连接到Device A的GigabitEthernet1/0/2端口。

    Device A使用Voice VLAN 2传输IP phone A产生的语音报文;使用Voice VLAN 3传输IP phone B产生的语音报文。

    GigabitEthernet1/0/1和GigabitEthernet1/0/2工作在自动模式,如果它们在30分钟内没有收到语音流,就将相应的Voice VLAN老化。

    组网图
    在这里插入图片描述

    配置步骤
    创建VLAN 2和VLAN 3。
    vlan 2 to 3

    设置Voice VLAN的老化时间为30分钟。
    voice vlan aging 30

    由于GigabitEthernet1/0/1端口可能会同时收到语音和数据两种流量,为了保证语音报文的质量以及带宽的高效利用,设置Voice VLAN工作在安全模式,即Voice VLAN只用于传输语音报文。(此步骤可省略,缺省情况下,Voice VLAN工作在安全模式)
    voice vlan security enable

    设置允许通过的OUI地址为MAC地址前缀为0011-1100-0000和0011-2200-0000,即当报文的前缀为0011-1100-0000或0011-2200-0000时,Device A会把它当成语音报文来处理。
    voice vlan mac-address 0011-1100-0001 mask ffff-ff00-0000 description IP phone A
    voice vlan mac-address 0011-2200-0001 mask ffff-ff00-0000 description IP phone B

    将端口GigabitEthernet1/0/1设定为Hybrid端口。
    interface gigabitethernet 1/0/1
    port link-type hybrid

    将端口GigabitEthernet1/0/1上Voice VLAN的工作模式设置为自动模式。(可选,缺省情况下,端口的Voice VLAN工作在自动模式。)
    interface gigabitethernet 1/0/1
    voice vlan mode auto

    使能端口Voice VLAN功能。
    interface gigabitethernet 1/0/1
    voice vlan 2 enable

    在GigabitEthernet1/0/2上进行相应的配置。
    interface gigabitethernet 1/0/2
    port link-type hybrid
    voice vlan mode auto
    voice vlan 3 enable

    显示当前系统支持的OUI地址、OUI地址掩码和描述信息。
    display voice vlan oui

    显示当前Voice VLAN的状态。
    display voice vlan state

    手动模式下Voice VLAN的配置举例
    组网需求
    创建VLAN 2为Voice VLAN,只允许语音报文通过。

    IP Phone类型为Untagged,接入端口是Hybrid类型端口GigabitEthernet1/0/1。

    端口GigabitEthernet1/0/1工作在手动模式,且允许OUI地址是0011-2200-0000、掩码是ffff-ff00-0000的语音报文通过,描述字符为test。

    组网图
    在这里插入图片描述

    配置步骤
    设置Voice VLAN为安全模式,使得Voice VLAN端口只允许合法的语音报文通过。(可选,系统缺省为安全模式)
    voice vlan security enable

    设置OUI地址0011-2200-0000是Voice VLAN的合法地址。
    voice vlan mac-address 0011-2200-0000 mask ffff-ff00-0000 description test

    创建VLAN 2。
    vlan 2

    设置端口GigabitEthernet1/0/1工作在手动模式。
    interface gigabitethernet 1/0/1
    undo voice vlan mode auto

    设置端口GigabitEthernet1/0/1为Hybrid类型。
    interface gigabitethernet 1/0/1
    port link-type hybrid

    设置Voice VLAN是端口GigabitEthernet1/0/1的缺省VLAN,且在该端口允许通过的Untagged VLAN列表中。
    interface gigabitethernet 1/0/1
    port hybrid pvid vlan 2
    port hybrid vlan 2 untagged

    使能端口GigabitEthernet1/0/1的Voice VLAN功能。
    voice vlan 2 enable

    显示当前系统支持的OUI地址、OUI地址掩码和描述信息。
    display voice vlan oui

    显示当前Voice VLAN的状态。
    display voice vlan state

    vlan映射配置:
    VLAN映射(VLAN Mapping)功能可以修改报文携带的VLAN Tag,提供下面4种映射关系:

    1:1 VLAN映射:将来自某一特定VLAN的报文所携带的VLAN Tag替换为新的VLAN Tag。
    N:1 VLAN映射:将来自两个或多个VLAN的报文所携带的不同VLAN Tag替换为相同的VLAN Tag。
    1:2 VLAN映射:为携带有一层VLAN Tag的报文打上外层VLAN Tag,使报文携带两层VLAN Tag。
    2:2 VLAN映射:将携带有两层VLAN Tag的报文的内、外层VLAN Tag都替换为新的VLAN Tag。
    如图所示,是1:1和N:1 VLAN映射的应用环境,其中用不同的VLAN来承载各家庭用户不同类型的业务(包括PC、VoD和VoIP)。
    在这里插入图片描述

    为了区分不同的用户,需要在楼道交换机处用不同的VLAN来承载不同用户的相同业务,即进行1:1 VLAN映射,这就要用到大量的VLAN。但汇聚层网络接入设备可提供的VLAN数量有限,因此需要在园区交换机上来进行VLAN的汇聚,用一个VLAN来承载原本由多个VLAN承载的不同用户的相同业务,即进行N:1 VLAN映射。

    1:2和2:2 VLAN映射的应用
    在这里插入图片描述

    如图所示,是1:2和2:2 VLAN映射的应用环境,VPN A中处于不同地理位置(Site 1和Site 2)的用户跨越了两个SP(Service Provider,服务提供商)——SP 1和SP 2的网络进行互通。

    在图中,Site 1和Site 2中的用户所在的VLAN分别为VLAN 2和VLAN 3,SP 1和SP 2分配给VPN A的VLAN分别为VLAN 10和VLAN 20。当Site 1中的报文进入SP 1的网络后,外层被打上了VLAN 10的VLAN Tag,这个过程就是1:2 VLAN映射。这样,VPN用户就可以自由规划自己网络中的VLAN ID,而不用担心与SP的VLAN ID相冲突,同时也缓解了SP的网络中VLAN ID紧缺的问题。

    当上述报文继续由SP 1的网络进入SP 2的网络后,由于SP 2分配给VPN A的VLAN与SP 1不同,因此需将该报文的外层VLAN Tag替换为VLAN 20的VLAN Tag,同时为了与Site 2中的用户互通,还需将其内层VLAN Tag替换为VLAN 3的VLAN Tag。这种同时修改内、外两层VLAN Tag的过程就是2:2 VLAN映射。

    vlan映射基本概念:
    在这里插入图片描述

    上行数据流:从用户网络发往汇聚层网络或SP网络的数据流,都称为上行数据流。
    下行数据流:从汇聚层网络或SP网络发往用户网络的数据流,都称为下行数据流。
    上行端口:发送上行数据流和接收下行数据流的端口称为上行端口。
    下行端口:发送下行数据流和接收上行数据流的端口称为下行端口。
    上行策略:负责上行数据流VLAN映射规则的QoS策略。
    下行策略:负责下行数据流VLAN映射规则的QoS策略。

    VLAN映射实现方式

    1. 1:1 VLAN映射实现方式
      在这里插入图片描述

    1:1 VLAN映射的实现方式如下:
    对于上行数据流,通过在下行端口上应用上行策略,将报文中CVLAN的VLAN Tag替换为SVLAN的VLAN Tag。
    对于下行数据流,通过在下行端口上应用下行策略,将报文中SVLAN的VLAN Tag替换为CVLAN的VLAN Tag。

    1. N:1 VLAN映射实现方式
      在这里插入图片描述
      N:1 VLAN映射的实现方式如下:
      对于上行数据流,通过在下行端口上应用上行策略,将来自两个或多个CVLAN的报文所携带的不同VLAN Tag都替换为SVLAN的VLAN Tag。
      对于下行数据流,通过查找SVLAN对应的DHCP Snooping表项中DHCP客户端的IP地址、MAC地址和CVLAN的绑定表项,将报文中SVLAN的VLAN Tag替换为CVLAN的VLAN Tag。

    2. 1:2 VLAN映射实现方式
      在这里插入图片描述
      1:2 VLAN映射的实现方式如下:
      对于上行数据流,通过在下行端口上应用上行策略,为端口收到的来自指定CVLAN的报文再加上一层SVLAN的VLAN Tag。
      对于下行数据流,通过将下行端口配置成Hybrid类型,并配置当端口发送SVLAN报文时不带VLAN Tag的方式,来将外层VLAN Tag剥离

    3. 2:2 VLAN映射实现方式
      在这里插入图片描述

    2:2 VLAN映射的实现方式如下:
    对于上行数据流,通过在下行端口上应用上行策略,将报文的外层VLAN Tag替换为新的VLAN Tag;通过在上行端口上应用上行策略,将报文的内层VLAN Tag替换为新的VLAN Tag。
    对于下行数据流,通过在下行端口上应用下行策略,将报文的内、外层VLAN Tag都替换为各自的原始VLAN Tag。
    注:在2:2 VLAN映射的实现中,根据实际的组网需要,也可以只替换外层VLAN Tag,或只替换内层VLAN Tag

    实验配置:
    1:1和N:1 VLAN映射配置举例

    1. 组网需求
      在某小区,服务提供商为每个家庭都提供了电脑上网(PC)、视频点播(VoD)和语音电话(VoIP)这三种数据服务,每个家庭都通过各自的家庭网关接入楼道交换机,并通过DHCP方式自动获取IP地址。
      服务提供商希望实现以下网络规划:在家庭网关上,分别将PC、VoD和VoIP业务依次划分到VLAN 1~3;在楼道交换机上,为了隔离不同家庭的同类业务,将每个家庭的每种业务都划分到不同的VLAN;而在园区交换机上,为了节省VLAN资源,将所有家庭的同类业务都划分到相同的VLAN,即分别将PC、VoD和VoIP业务依次划分到VLAN 501~503

    2. 组网图
      在这里插入图片描述

    3. 配置步骤
      (1)配置Switch A
      创建CVLAN和SVLAN。
      vlan 2 to 3
      vlan 101 to 102
      vlan 201 to 202
      vlan 301 to 302

    配置上行策略p1和p2:将不同用户的不同业务CVLAN映射到不同的SVLAN上。
    [SwitchA] traffic classifier c1
    if-match customer-vlan-id 1
    traffic classifier c2
    if-match customer-vlan-id 2
    traffic classifier c3
    if-match customer-vlan-id 3

    [SwitchA] traffic behavior b1
    remark service-vlan-id 101
    traffic behavior b2
    remark service-vlan-id 201
    traffic behavior b3
    remark service-vlan-id 301
    traffic behavior b4
    remark service-vlan-id 102
    traffic behavior b5
    remark service-vlan-id 202
    traffic behavior b6
    remark service-vlan-id 302

    [SwitchA] qos policy p1
    classifier c1 behavior b1
    classifier c2 behavior b2
    classifier c3 behavior b3

    [SwitchA] qos policy p2
    classifier c1 behavior b4
    classifier c2 behavior b5
    classifier c3 behavior b6

    配置下行策略p11和p22:将SVLAN映射回原来的CVLAN上。
    [SwitchA] traffic classifier c11
    if-match service-vlan-id 101
    traffic classifier c22
    if-match service-vlan-id 201
    traffic classifier c33
    if-match service-vlan-id 301
    traffic classifier c44
    if-match service-vlan-id 102
    traffic classifier c55
    if-match service-vlan-id 202
    traffic classifier c66
    if-match service-vlan-id 302

    [SwitchA] traffic behavior b11
    remark customer-vlan-id 1
    traffic behavior b22
    remark customer-vlan-id 2
    traffic behavior b33
    remark customer-vlan-id 3

    [SwitchA] qos policy p11
    classifier c11 behavior b11
    classifier c22 behavior b22
    classifier c33 behavior b33

    [SwitchA] qos policy p22
    classifier c44 behavior b11
    classifier c55 behavior b22
    classifier c66 behavior b33

    配置下行端口GigabitEthernet1/0/1为Trunk端口且允许CVLAN和SVLAN通过,使能该端口的基本QinQ功能,在该端口的入方向上应用上行策略p1,并在该端口的出方向上应用下行策略p11。
    [SwitchA] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 1 2 3 101 201 301
    qinq enable
    qos apply policy p1 inbound
    qos apply policy p11 outbound

    配置下行端口GigabitEthernet1/0/2为Trunk端口且允许CVLAN和SVLAN通过,使能该端口的基本QinQ功能,在该端口的入方向上应用上行策略p2,并在该端口的出方向上应用下行策略p22。
    [SwitchA] interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 1 2 3 102 202 302
    qinq enable
    qos apply policy p2 inbound
    qos apply policy p22 outbound

    配置上行端口GigabitEthernet1/0/3为Trunk端口且允许SVLAN通过。
    [SwitchA] interface gigabitethernet 1/0/3
    port link-type trunk
    port trunk permit vlan 101 201 301 102 202 302

    如果PC(发送不带VLAN Tag的报文)直接连接在楼道交换机上,则需把楼道交换机连接PC的端口配置成Access端口或者Trunk端口:
    当配置成Access端口时,要把端口加入到SVLAN;
    当配置成Trunk端口时,要把端口的缺省VLAN配置成SVLAN。

    (2)配置Switch B
    Switch B的配置与Switch A相似,配置过程略。

    (3)配置Switch C

    使能DHCP Snooping功能。
    [SwitchC] dhcp-snooping

    创建CVLAN和SVLAN,并在这些VLAN上分别使能ARP Detection功能。
    [SwitchC] vlan 101
    arp detection enable
    vlan 201
    arp detection enable
    vlan 301
    arp detection enable
    vlan 102
    arp detection enable
    vlan 202
    arp detection enable
    vlan 302
    arp detection enable
    vlan 103
    arp detection enable
    vlan 203
    arp detection enable
    vlan 303
    arp detection enable
    vlan 104
    arp detection enable
    vlan 204
    arp detection enable
    vlan 304
    arp detection enable
    vlan 501
    arp detection enable
    vlan 502
    arp detection enable
    vlan 503
    arp detection enable

    配置上行策略p1和p2:将不同用户的相同业务VLAN(CVLAN)映射到同一个VLAN(SVLAN)上。
    [SwitchC] traffic classifier c1
    if-match customer-vlan-id 101 to 102
    traffic classifier c2
    if-match customer-vlan-id 201 to 202
    traffic classifier c3
    if-match customer-vlan-id 301 to 302
    traffic classifier c4
    if-match customer-vlan-id 103 to 104
    traffic classifier c5
    if-match customer-vlan-id 203 to 204
    traffic classifier c6
    if-match customer-vlan-id 303 to 304

    [SwitchC] traffic behavior b1
    remark service-vlan-id 501
    traffic behavior b2
    remark service-vlan-id 502
    traffic behavior b3
    remark service-vlan-id 503

    [SwitchC] qos policy p1
    classifier c1 behavior b1 mode dot1q-tag-manipulation
    classifier c2 behavior b2 mode dot1q-tag-manipulation
    classifier c3 behavior b3 mode dot1q-tag-manipulation

    [SwitchC] qos policy p2
    classifier c4 behavior b1 mode dot1q-tag-manipulation
    classifier c5 behavior b2 mode dot1q-tag-manipulation
    classifier c6 behavior b3 mode dot1q-tag-manipulation

    配置下行端口GigabitEthernet1/0/1为Trunk端口且允许CVLAN和SVLAN通过,使能该端口的用户侧QinQ功能,并在该端口的入方向上应用上行策略p1。
    [SwitchC] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 101 201 301 102 202 302 501 502 503
    qinq enable downlink
    qos apply policy p1 inbound

    配置下行端口GigabitEthernet1/0/2为Trunk端口且允许CVLAN和SVLAN通过,使能该端口的用户侧QinQ功能,并在该端口的入方向上应用上行策略p2。
    [SwitchC] interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 103 203 303 104 204 304 501 502 503
    qinq enable downlink
    qos apply policy p2 inbound

    配置上行端口GigabitEthernet1/0/3为Trunk端口且允许SVLAN通过,配置该端口为DHCP Snooping信任端口和ARP信任端口,并使能该端口的网络侧QinQ功能。
    [SwitchC] interface gigabitethernet 1/0/3
    port link-type trunk
    port trunk permit vlan 501 502 503
    dhcp-snooping trust
    arp detection trust
    qinq enable uplink

    (4)配置Switch D
    配置端口GigabitEthernet1/0/1为Trunk端口且允许SVLAN通过。
    [SwitchD] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 501 502 503

    1:2和2:2 VLAN映射配置举例

    1. 组网需求
      VPN A中的站点1和站点2是某公司的两个分支机构,且分别利用VLAN 10和VLAN 30承载业务。由于分处不同地域,这两个分支机构采用了不同的服务提供商所提供的VPN接入服务,且SP 1和SP 2分别将VLAN 100和VLAN 200分配给这两个分支机构使用。
      该公司希望其下属的这两个分支机构可以跨越SP 1和SP 2的网络实现互通。

    2. 组网图
      在这里插入图片描述

    3. 配置步骤
      (1)配置PE 1
      配置上行策略test:为VLAN 10的报文添加VLAN 100的外层VLAN Tag。
      [PE1] traffic classifier test
      if-match customer-vlan-id 10

    [PE1] traffic behavior test
    nest top-most vlan-id 100

    [PE1] qos policy test
    classifier test behavior test

    配置下行端口GigabitEthernet1/0/1为Hybrid端口且允许VLAN 100的报文不携带VLAN Tag通过,使能该端口的基本QinQ功能,并在该端口的入方向上应用上行策略test。
    [PE1] interface gigabitethernet 1/0/1
    port link-type hybrid
    port hybrid vlan 100 untagged
    qinq enable
    qos apply policy test inbound

    配置上行端口GigabitEthernet1/0/2为Trunk端口且允许VLAN 100通过。
    [PE1] interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 100

    (2)配置PE 2
    配置端口GigabitEthernet1/0/1为Trunk端口且允许VLAN 100通过。
    [PE2] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 100

    配置端口GigabitEthernet1/0/2为Trunk端口且允许VLAN 100通过。
    [PE2] interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 100

    (3)配置PE 3
    配置下行端口的上行策略down_uplink:即下行端口对入方向报文的匹配规则流行为。
    [PE3] traffic classifier down_uplink
    if-match customer-vlan-id 10
    if-match service-vlan-id 100

    [PE3] traffic behavior down_uplink
    remark service-vlan-id 200

    [PE3] qos policy down_uplink
    classifier down_uplink behavior down_uplink

    配置下行端口的下行策略down_downlink:即下行端口对出方向报文的匹配规则和流行为。
    [PE3] traffic classifier down_downlink
    if-match customer-vlan-id 30
    if-match service-vlan-id 200

    [PE3] traffic behavior down_downlink
    remark customer-vlan-id 10
    remark service-vlan-id 100

    [PE3] qos policy down_downlink
    classifier down_downlink behavior down_downlink

    配置上行端口的上行策略up_uplink:即上行端口对出方向报文的匹配规则和流行为。
    [PE3] traffic classifier up_uplink
    if-match customer-vlan-id 10
    if-match service-vlan-id 200

    [PE3] traffic behavior up_uplink
    remark customer-vlan-id 30

    [PE3] qos policy up_uplink
    classifier up_uplink behavior up_uplink

    配置下行端口GigabitEthernet1/0/1为Trunk端口且允许VLAN 200通过,在该端口的入方向上应用上行策略down_uplink,并在该端口的出方向上应用下行策略down_downlink。
    [PE3] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 200
    qos apply policy down_uplink inbound
    qos apply policy down_downlink outbound

    配置上行端口GigabitEthernet1/0/2为Trunk端口且允许VLAN 200通过,并在该端口的出方向上应用上行策略up_uplink。
    [PE3] interface gigabitethernet 1/0/2
    port link-type trunk
    port trunk permit vlan 200
    qos apply policy up_uplink outbound

    (4)配置PE 4
    配置上行策略test:为VLAN 30的报文添加VLAN 200的外层VLAN Tag。
    [PE4] traffic classifier test
    if-match customer-vlan-id 30

    [PE4] traffic behavior test
    nest top-most vlan-id 200

    [PE4] qos policy test
    classifier test behavior test

    配置下行端口GigabitEthernet1/0/2为Hybrid端口且允许VLAN 200的报文不携带VLAN Tag通过,使能该端口的基本QinQ功能,并在该端口的入方向上应用上行策略test。
    [PE4] interface gigabitethernet 1/0/2
    port link-type hybrid
    port hybrid vlan 200 untagged
    qinq enable
    qos apply policy test inbound

    配置上行端口GigabitEthernet1/0/1为Trunk端口且允许VLAN 200通过。
    [PE4] interface gigabitethernet 1/0/1
    port link-type trunk
    port trunk permit vlan 200

    展开全文
  • 认识 VLAN

    千次阅读 2021-08-06 19:02:04
    1.冲突 冲突:两个节点同时发送数据的情况。 冲突域:产生冲突的范围 集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域。 本网段广播:发送的消息会...基于端口划分静态VLAN ...

    目录

    1.冲突

    2.VLAN

    VLAN原理

    VLAN(虚拟局域网)优点:

    VLAN 管理方式的分类

    VLAN的划分

    静态VLAN的创建步骤

    接口划分进对应的vlan

    需要熟记的指令

    实验过程:

     总结:

    VLAN 跨交换机的通信

    跨交换机相同 VLAN之间的通信

    实验过程:

    相同vlan间通信:

    不同vlan间通信(不同网段)

    单臂路由

    三层交换

    VLAN的封装方式:

    实施:

    实验:

     总结:

    三层交换机

    三层交换机原理

    缺点:

    路由器用途

    三层交换机和路由器的区别

    实验

    总结:





    1.冲突

    冲突:两个节点同时发送数据的情况。

    冲突域:产生冲突的范围

    集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域。

    本网段广播:发送的消息会传达给这个网段的全体成员。
    广域域:广播扩散的范围

    交换机/路由器的广播域:交换机的所有接口处于一个广播域中,路由器一个接口一个广播域。

    2.VLAN

    VLAN原理

    VLAN(虚拟局域网)优点:

     隔离了广播域 更易于管理 安全性

    VLAN 管理方式的分类

    静态VLAN
    基于交换机接口划进相应的VLAN          
    优点:简单 经济

    动态VLAN
    基于MAC地址划分动态VLAN,需要有额外的服务器支持     缺点: 复杂 成本高

    VLAN的划分

    VALN 的数量一共是4096个
    其中VLAN0, 4095系统保留,不可见也不可用
    VLAN1系统默认VLAN,用户可以使用这个VLAN,但是不能删除

    VLAN 2-4094 用户可以创建、使用、删除。

    静态VLAN的创建步骤

    交换机上创建VLAN

    1.创建一个vlan
    (系统视图)  [ ]vlan 2

     

    2.创建多个vlan
     创建多个不连续的vlan
    举例:一次性创建vlan3, vlan6, vlan9
    (系统视图)[ ]vlan bat 3 6 9

     

    3.创建多个连续的vlan
    举例:一次性创建vlan10,vlan11, vlan12, vlan13, vlan14, vlan15

    (系统视图)[ ] vlan bat 10 to 15
     

    接口划分进对应的vlan

    接口划分进对应的vlan
    1.进入接口
    (系统视图) [ ] interface e0/0/1)设置该接口的链路类型

    2.设置该接口的的链路类型

    [接口] port link-type access

    3.将该接口划分进对应的vlan

    [接口]port default vlan 3


    补充:交换机根据连接对象的不同,会有不同的链路类型。
    交换机连接的对象是电脑   那么接口链路类型为access(接入)

    注意: access这种类型的接口只能属于一个vlan
    交换机连接的对象是交换机--那么接口链路类型为trunk(主干)

    注意:trunk不属于住何vlan,它是一条仅有链路,用来在单条链路上承载不同的vlan流最,让其通过。

    需要熟记的指令

     [ ] clear configuration interface e0/0/1  

          清除接口下所有配置

     [ ]undo shutdown

            开启接口

     [ ]display mac-address

    查看 MAC地址表

    实验过程:

    三台电脑 PC1 IP:192.168.10.10/24  PC2 IP:192.168.10.20/24  PC3 IP:192.168.10.30/24

    PC1 交换机e0/0/ 1  PC2 交换机e0/0/2  PC3 交换机e0/0/3

    因为这三台电脑同一个网络ID 所以用交换机相连彼此之间可以通信 

    我们验证一下: 用PC1 ping PC2

    结果是可以通信的

    下面我们可以设置交换机 并划分分VLAN

    创建VLAN 2 3 5  并将接口划分进对应VLAN

     理论上VLAN 已经将这三台电脑划分成不同网段 下面是验证 

    电脑1 无法与电脑2 通信

     总结:

                了解了 VLAN 虚拟局域网的划分  知道管理方式 熟记划分指令 以便于用于工作 

    VLAN 跨交换机的通信

    跨交换机相同 VLAN之间的通信

     交换机连接的对象是交换机 那么接口链路类型为trunk(主干),注意: trunk不属于任何vlan.它是一条公有链路,用来在单条链路上承载不同的vlan流量,让其通过。

    VLAN跨交换机的传输过程:
    PC机经过发送方交换机某个接口发送数据,此时交换机会对应vlan信息表,给经过某接口的数据打上对应的标签,打上对应标签的数据经由trunk (主干)链路验证这个vlan ID是不是在trunk链路的白名单范围内,若是在白名单范围内,无条件放行,若不在白名单范围内,则该流量不予通过,当打了标签的数据到达接收方交换机后,接收.方交换机会解开这个数据对应的vlan标签,对照本地mac地址表和vlan信息表,将此数据转发到该vlan对应的端口上。

    实验过程:

    下面是验证猜想 PC1 ping PC5

    很显然是可以ping 同的 

    下面我们来划分不同的VLAN   前面我们已经知道相同VLAN间是可以通信的

    现在需要跨交换机 所以我们需要在 交换机与交换机之间的端口设为trunk 类型 形成一条公有链路

    并设定白名单 让不同打上vlan标签的数据通过 

     下面是划分 VLAN过程

     交换机 SW2 设定

    下面 更改 e0/0/1 e0/0/2 e0/0/3  的接口为 access类型 并划分进对应VLAN 

    vlan1 e0/01  vlan2  e/0/0/02  vlan3 e0/0/3 

    进入 g0/0/1 接口 改类型为trunk 类型  并设定白名单 允许VLAN 1 2 3通过 

     SW1 重复以上操作 创建 VLAN1 VLAN2 VLAN3 更改 e0/0/1 e0/0/2 e0/0/3  的接口为 access类型 并划分进对应VLAN      vlan1 e0/01  vlan2  e/0/0/02  vlan3 e0/0/3 

    进入 g0/0/1 接口 改类型为trunk 类型  并设定白名单 允许VLAN 1 2 3通过 

     这样我们就实现了相同VLAN 跨交换机之间的通信

    相同vlan间通信:


    情况一:同一台交换机相同vlan间通信,查看本地mac地址表,将打了相同pvid标签的数据包转发到对应的端口上去
    情况二:跨交换机,通过trunk技术实现多vlan数据通信,可以帮助我们实现相同vlan间通信。不同vlan间通信(不同网段)

    不同vlan间通信(不同网段)

    单臂路由

    组成:一台二层交换机和一台路由器

    三层交换

    组成:三层交换机
     

    VLAN的封装方式:

    ISL和802.1q协议

    802.1q公有协议   ISL思科私有协议

    实施:

    采用单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应于一个VLAN。由于物理路由接口只有一个,各子接口的数据在物理链路上传递要进行标记封装。Cisco设备支持ISL和802.1q协议。华为设备只支持802.1q。

    实验:

               实现不同VLAN 不同网段 之间的的通信

     交换机端设置:

    进入g0/0/1改trunk类型 设置白名单

    路由器端设置

     到这步所有设置完成 我们ping 一下  不同网段 不同vlan 是否可以实现通信

     下面是抓包 我们看下数据的走向

     总结:

                了解了相同VLAN之间的通信  相同VLAN跨交换机的通信  已经不同网段 不同VLAN之间通信的实现,牢记原理以及实现过程,在Cisco网络认证体系中,单臂路由是一个重要的学习知识点。通过单臂路由的学习,能够深入的了解VLAN(虚拟局域网)的划分、封装和通信原理,理解路由器子接口、ISL协议和802.1Q协议,是CCNA考试中经常考的点。

    三层交换机


    三层交换机要执行三层信息的硬件交换,路由处理器(三层引擎)必须将有关路由选择等的三层信息下载到硬件中。以便对数据包进行过处理。为完成在硬件中处理数据包的高层信息,会使用传统的MLS和基于CEF的MLS。

    传统的MLS
    使用传统的MLS时,交换机将流中第一个数据包转发给第三层引擎,后者以软件交换的方式对数
    据包进行过处理,对数据流中的第一个包进行路由处理后,第三层引擎对硬件交换组织进行编程
    ,使之为后续的数据包选择路由。
    这个过程被称为“一次路由多次交换”,也就是说交换机的二层引擎只需要处理数据流中的第一个数据包,而后续的数据全部由硬件来执行转发。这样实现了三层交换的线速转发。

    基于CEF的MLS
    与传统MLS不同的是,CEF预先根据路由表学习路由信息后,直接储存在FIB(转发信息库)
    REF预先根据ARP表生成邻接表,直接由硬件进行转发。
    传统MLS至少需要软件查询一次路由表
    建立转发条目,才能使用硬件进行转发。

    工作原理:
    ①主机A给B发送单播数据包
    ②交换机查找FIB表,找到下一跳地址
    3查找下一跳地址对应的邻接关系的2层封装信息

    ④转发

    三层交换机原理

    第三层交换工作在OSI七层网络模型中的第三层即网络层,是利用第三层协议中的IP包的包头信息来对后续数据业务流进行标记,具有同一标记的业务流的后续报文被交换到第二层数据链路层,从而打通源IP地址和目的IP地址之间的一条通路。这条通路经过第二层链路层。有了这条通路,三层交换机就没有必要每次将接收到的数据包进行拆包来判断路由,而是直接将数据包进行转发,将数据流进行交换。
    其原理是:假设两个使用IP协议的站点A、B通过第三层交换机进行通信,发送站点A在开始发送时,把自己的IP地址与B站的IP地址比较,判断B站是否与自己在同一子网内。若目的站B与发送站A在同一子网内,则进行二层的转发。若两个站点不在同一子网内,如发送站A要与目的站B通信,发送站A要向“缺省网关”发出ARP(地址解析)封包,而“缺省网关”的IP地址其实是三层交换机的三层交换模块。当发送站A对“缺省网关”的IP地址广播出一个ARP请求时,如果三层交换模块在以前的通信过程中已经知道B站的MAC地址,则向发送站A回复B的MAC地址。否则三层交换模块根据路由信息向B站广播一个ARP请求,B站得到此ARP请求后向三层交换模块回复其MAC地址,三层交换模块保存此地址并回复给发送站A,同时将B站的MAC地址发送到二层交换引擎的MAC地址表中。从这以后,当A向B发送的数据包便全部交给二层交换处理,信息得以高速交换。由于仅仅在路由过程中才需要三层处理,绝大部分数据都通过二层交换转发,因此三层交换机的速度很快,接近二层交换机的速度,同时比相同路由器的价格低很多。

    缺点:

    那这有什么缺点呢?缺点就是它是一个铁憨憨,只会通过MAC/IP地址来转发数据,确实不占用CPU但也没什么灵活性。打个比方的话就是三层交换机大概相当于二个斗脑简单四肢发达的筋肉男,脑子不太灵光但力大无穷。

    路由器用途

    路由器是做什么的呢?确实可以跨网段转发数据,但路由器真正的用途是计算路由。什么叫计算路由呢,这就要从互联网的结构说起了。大家知道早期互联网其实是军事用途,其目的在于构筑一个几乎无法被摧毁的信息交换网络。
    怎么做到无法摧毁呢﹖传统网络都有一个或者几个中枢,一旦被摧毁网络就瘫痪了。而互联网的理念就是像渔网那样把所有节点互相连接起来,这样不管摧毁哪个节点或者切断哪个线路,数据都可以绕路到达另一个节点,从而达到几乎坚不可推的目的。这样其实从一个节点到另一个节点有很多种选择,哪种才是最优的呢?专门有一个数学分支来研究这个问题,称之为图论。而选择路径也有很多种策略,落实到现实世界就是各种路由协议。如果网络结构不变,最短径路算好放在那就行了。但一旦网络发生变化,比如增加节点或着线路出现故障,那就要路由器来重新计算。由于路由协议不同,一部分节点甚至全部节点都要重新计算到其他节点的路由,这个计算量其实蛮大的。

    三层交换机和路由器的区别

    1. 主要功能不同 

    三层交换机同时具备了数据交换和路由转发两种功能,但其主要功能还是数据交换;而路由器仅具有路由转发这一种主要功能。

     2. 主要适用的环境不一样

    三层交换机的路由功能通常比较简单,因为它所面对的主要是简单的局域网连接

    路由功能更多的体现在不同类型网络之间的互联上,如局域网与广域网之间的连接、不同协议的网络之间的连接等,所以路由器主要是用于不同类型的网络之间。

    3. 性能体现不一样 

    路由器一般由基于cpu的软件路由引擎执行数据包交换,而三层交换机通过硬件执行数据包交换。三层交换机在对第一个数据流进行路由后,它将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。

    路由器的转发采用最长匹配的方式,实现复杂,通常使用软件来实现,转发效率较低。 正因如此,从整体性能上比较的话,三层交换机的性能要远优于路由器,非常适用于数据交换频繁的局域网中;而路由器虽然路由功能非常强大,但它的数据包转发效率远低于三层交换机,更适合于数据交换不是很频繁的不同类型网络的互联,如局域网与互联网的互联。

    实验

     

    单臂路由技术:当只有二层交换机时,又要实现不同vlan间通信时,需要用到单臂路由技术。

    三层交换实现不同vlan间路由:三层交换机可以配置vlanif接口,通过vlanif接口可以配置ip地址,成为不同vlan对应的网关,从而实现不同vlan间路由

    总结:

     牢记三层交换机的工作原理及工作方式 ,利用第三层协议中的IP包的包头信息来对后续数据业务流进行标记,具有同一标记的业务流的后续报文被交换到第二层数据链路层,从而打通源IP地址和目的IP地址之间的一条通路。这条通路经过第二层链路层。有了这条通路,三层交换机就没有必要每次将接收到的数据包进行拆包来判断路由,而是直接将数据包进行转发,将数据流进行交换。

    展开全文
  • VLAN特性 聚合、MUX VLAN、QinQ、映射

    万次阅读 多人点赞 2020-07-24 13:37:56
    文章目录一、VLAN聚合二、MUX VLAN三、QinQ四、VLAN Mapping五、拓扑六、基本配置与分析七、设备完整配置 VLAN特性 映射、聚合、MUX VLAN、QinQ;DHCP,DHCP中继,NAT,ACL。 一、VLAN聚合 聚合VLAN产生的背景: ...
  • 三、本征vlanvlan 1) 概述: 注:本征vlan没有tag字段,一般用来传输一些系统级别的流量 一、一般vlan 一般vlan ,例如图中 vlan 10 ,当pc1访问pc2时,pc1发送数据帧: smac:0.......A sip:10.1.1.1...
  • VLAN的基本配置

    千次阅读 2022-04-30 15:14:11
    VLAN的基本配置 原理概述: 交换机的VLAN端口可以分为Access、Trunk和Hybrid3种类型。Access端口是交换机上用来直接连接用户终端的端口,它只允许属于该端口的缺省VLAN的帧通过,Access端口发往用户终端的帧一定...
  • eNSP配置VLAN

    千次阅读 2022-01-16 15:31:09
    实验 配置VLAN 实验目的 掌握 VLAN 的创建方法 掌握 Access、 Trunk 和 Hybrid 类型接口的配置方法 掌握基于接口划分 VLAN 的配置方法 掌握基于 MAC 地址划分 VLAN 的配置方法 掌握 MAC 地址表及 VLAN 信息的查看...
  • VLAN原理讲解

    千次阅读 2022-01-20 12:31:02
    一、VLAN概述及产生原因 VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。 以太网是一种基于载波侦听多路访问/冲突检测CSMA/CD(Carrier Sense Multiple...
  • 简要介绍VLAN技术以及MA5680T支持的VLAN个数、VLAN类型和VLAN属性。 9.2 配置VLAN应用实例 本实例介绍如何通过MUX VLAN实现GPON接入业务,其他类型VLAN的应用实例 请参见“9.1 VLAN概述”。 9.3 增加VLAN 通过本任务...
  • Macvlan与IPvlan

    千次阅读 2021-02-08 11:17:31
    本文主要就macvlan和ipvlan的工作模式以及差异做简要介绍;同时,为便于形象的理解,还会涉及到一些实际操作命令。 macvlan 这里的macvlan是linux kernel提供的一种network driver类型,它有别于传统交换机上提供的...
  • 华为交换机配置Vlan

    千次阅读 2022-03-16 20:44:24
    华为交换机vlan配置,vlanif设置
  • VLAN基础

    千次阅读 2022-03-15 22:43:07
    vlan概述 VLAN的种类 静态vlan的配置 小结 广播域的概念 在传统的交换式以太网中,所有的用户都在同一个广播域中,当网络规模较大时,广播包的数量会急剧增加,当广播包的数量占到总量的30%时,网络的传输...
  • VLAN基础知识

    万次阅读 多人点赞 2018-05-21 13:10:56
    VLAN简介 定义: VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接通信,而VLAN间不能直接通信,从而将广播报文限制在一个VLAN...
  • Mux VLAN与Super VLAN-交换机高级特性

    千次阅读 2020-11-22 20:55:53
    文章目录前言Mux VLANSuper Vlan(Vlan聚合)端口隔离端口安全端口安全解决方案端口安全类型 前言   MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。通过MUX VLAN提供的二层流量隔离的机制...
  • 思科1 - 4:交换的概念、VLANVLAN 间路由考试
  • VLAN聚合

    千次阅读 2022-01-19 21:38:20
    简单的说,VLAN聚合(vlan Aggregation)技术允许网络管理员将一个ip网段用于多个vlan,例如将192.168.8.0/24同时用于vlan11、vlan12及vlan13(通常情况下,我们为了方便会给不同vlan划分不同网段,这样就可能造成...
  • 网卡VLAN功能简介

    热门讨论 2011-11-30 15:02:50
    相对交换机来说,电脑网卡对VLAN的处理比较简单。 一般地,对于接收到的以太网帧,不论带不带VLAN标签,也不论VLAN ID是多少,网卡都能够正常接收并将数据传递给操作系统和应用程序。通常,网卡在处理接收到的以太网...
  • 华为[ENSP]VLAN常用配置命令

    千次阅读 2022-04-06 18:55:59
    display vlan interface vlanif display interface vlanif description(VLANIF接口视图) display vlan 命令功能 display vlan命令用来查看所有VLAN的相关信息。 如果不指定任何可选参数,则显示所有...
  • VLANIF

    千次阅读 2021-08-08 00:20:58
    实验名称:VLANIF 综合案例 实验目标: 不同VLAN之间的PC互通 配置思路: 1.配置终端设备 -IP/掩码/网关 2.配置网络设备-交换 -初始化配置 -创建VLAN -配置trunk -配置access 3.配置网络设备-路由(网关) -确定网关...
  • 五种划分vlan的方式

    千次阅读 2022-02-10 16:26:27
    1 支持VLAN的划分方式 1.基于接口的划分方式:就是静态的把指定的接口划分到对应的VLAN内,那么它就固定在这个VLAN下了。 2.基于MAC地址划分VLAN:它只看用户的MAC地址,不把接口固定在某个VLAN下,当该接口收到一个...
  • vlan详解

    千次阅读 2020-03-11 18:14:56
    vlan详解 VLAN(Vitual Local Area Network,虚拟局域网)是将物理网络划分成多个逻辑局域网的技术。一个VLAN就是一个广播域,亦即一个逻辑子网,在其内的站点可位于不同物理LAN上,但站点间像在同一个普通局域网上...
  • VLAN基础&VLAN间路由联动OSPF实验

    千次阅读 2021-11-19 11:12:08
    VLAN 前言以及技术背景 随着网络中计算机的数量越来越多,传统的以太网网络开始面临广播泛滥以及安全性无法保障等各种问题、 VLAN(Virtual Local Area Network) 即虚拟局域网,是一个将物理局域网在逻辑上划分多个...
  • 网络基础之vlan

    千次阅读 2022-01-21 00:00:52
    文章目录什么是vlan传统以太网的问题虚拟局域网(vlan,Virtual LAN)为什么引入vlanvlan的作用VLAN的基本原理如何实现VLANVLAN的划分方式以太网二层接口类型Access接口VLAN的应用VLAN的规划应用场景-基于接口的VLAN...
  • 解析vlan

    千次阅读 2022-01-14 15:30:41
    文章目录一、关于VLAN1.什么是vlan?2.vlan的作用及优势二、eNSP划分VLAN实验三、总结 一、关于VLAN 1.什么是vlanVLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。 虚拟局域网(VLAN)是一组逻辑上的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 109,376
精华内容 43,750
关键字:

VLAn