精华内容
下载资源
问答
  • Command: default-information originate [metric cost] [metric-type type] 只有本地路由表中存在默认路由,该命令才能广播缺省路由到OSPF域内。(要先有默认路由,才触发向ospf域内通告) Command: default-...

     OSPF缺省路由

    Command: default-information originate [metric cost] [metric-type type]

    只有本地路由表中存在默认路由,该命令才能广播缺省路由OSPF域内。(要先有默认路由,才触发向ospf域内通告)

    Command: default-information originate always [metric cost] [metric-type type]

    即使本地路由表中不存在默认,该命令也会广播缺省路由always参数总是触发向OSPF域内通告缺省路由,如果外部路由不可达的情况下,可能会出现路由黑洞。)

    OSPF广播一条缺省路由时,正在广播缺省路由路由器将成为一个ASBR

    广播的缺省路由cost值默认为1,可以通过metric选项来更改cost值。metric不受default-metric命令影响。)

    OSPF的外部路由有两种类型(type:类型1路由的成本包括重分布路由的外部成本和OSPF成本。类型2路由的成本只包括外部成本。缺省是类型2

    Command:  default-information originate route-map route-map-name

    缺省路由的广播可使用route-map有条件实现。如果满足route-map的条件,缺省路由会被广播到OSPF域内(不需要路由表中存在默认路由,也不需要always关键词)

    Ex.
    router ospf 1
     log-adjacency-changes
     network 2.2.2.2 0.0.0.0 area 0
     network 172.16.1.0 0.0.0.255 area 0
     default-information originate route-map test
    !
    ip http server
    ip forward-protocol nd
    !
    access-list 1 permit 3.3.3.0 0.0.0.3
    !
    route-map test permit 10
     match ip address 1
    !

    以上的例子的意思是,如果路由表中存在3.3.3.0网段的路由,就往OSPF域内发布缺省路由。如果没有,就停止发布。这在实际应用中可以用来跟踪出口路由譬如跟踪连接外网的直连链路

    Command: default-metric cost

    OSPF中,重分布BGP路由的缺省metric1,所有其他重分布协议的缺省度量是20该命令可以改变重分布的缺省度量值,但不会影响已由redistribute命令指定的度量值。

    转载于:https://blog.51cto.com/lcbingo/578728

    展开全文
  • default-information originate command document
  • 实验27: default-information originate 1.实验目的 通过本实验可以掌握如何通过命令“default-information originate”向OSPF网络 注入一条默认路由。 注:本实验用R0的环回接口1来模拟Internet。 2.实验拓扑 ...
    实验27: default-information originate
    1. 实验目的
    通过本实验可以掌握如何通过命令“default-information originate”向OSPF 网络
    注入一条默认路由。
    注:本实验用R0的环回接口1 来模拟Internet。
    2. 实验拓扑
    本实验的拓扑结构如图所示。
     
    3. 实验步骤
    配置如下:
     
    r0(config)#no ip do loo
    r0(config)#lin c 0
    r0(config-line)#logg s
    r0(config-line)#exec-t 00
    r0(config-line)#exit
    r0(config)#int loo 1
    r0(config-if)#  
    *Mar  1 00:02:45.631: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
    r0(config-if)#ip add 1.1.1.1 255.255.255.0
    r0(config-if)#int s0/1
    *Mar  1 00:03:20.375: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
    *Mar  1 00:03:21.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
    r0(config-if)#int s0/1
    r0(config-if)#ip add 172.16.1.1 255.255.255.0
    r0(config-if)#no sh
    r0(config-if)#
    *Mar  1 00:03:38.475: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
    *Mar  1 00:03:39.475: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
    r0(config-if)#
    *Mar  1 00:03:49.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
    r0(config-if)#
    *Mar  1 00:04:12.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
    r0(config-if)#
    *Mar  1 00:05:52.619: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
    r0(config-if)#exit
    r0(config)#ip route 0.0.0.0 0.0.0.0 loo 1  
    r0(config)#router ospf 1
    r0(config-router)#net 1.1.1.0 0.0.0.255 area 0
    r0(config-router)#net 172.16.119.0 0.0.0.255 area 0
    r0(config-router)#net 172.16.1.0 0.0.0.255 area 0
    r0(config-router)#ex
    *Mar  1 00:08:03.623: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/1 from LOADING to FULL, Loading Done
    r0(config-router)#default-in
    r0(config-router)#default-information ori
    r0(config-router)#default-information originate
    r0(config-router)#do ping 172.16.2.1
     
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/49/88 ms
    r0(config-router)#do ping 3.3.3.3
     
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 48/76/120 ms
    r0(config)#do sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
     
    Gateway of last resort is 0.0.0.0 to network 0.0.0.0
     
         1.0.0.0/24 is subnetted, 1 subnets
    C       1.1.1.0 is directly connected, Loopback1
         2.0.0.0/32 is subnetted, 1 subnets
    O       2.2.2.2 [110/65] via 172.16.1.2, 00:11:22, Serial0/1
         3.0.0.0/32 is subnetted, 1 subnets
    O       3.3.3.3 [110/129] via 172.16.1.2, 00:11:22, Serial0/1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.1.0 is directly connected, Serial0/1
    O       172.16.2.0 [110/128] via 172.16.1.2, 00:11:22, Serial0/1
    S*   0.0.0.0/0 is directly connected, Loopback1
     
    r0(config)#do sh ip ospf da
     
                OSPF Router with ID (1.1.1.1) (Process ID 1)
     
                    Router Link States (Area 0)
     
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    1.1.1.1         1.1.1.1         789         0x80000003 0x00EE10 3
    2.2.2.2         2.2.2.2         804         0x80000004 0x0015B8 5
    3.3.3.3         3.3.3.3         894         0x80000003 0x008560 3
     
                    Type-5 AS External Link States
     
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         1.1.1.1         108         0x80000001 0x001D91 1
     
    r1(config)#int loo 1
    r1(config-if)#ip add 2.2..2
    *Mar  1 00:05:23.583: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
    r1(config-if)#ip add 2.2.2.2 255.255.255.0
    r1(config-if)#int s0/0
    r1(config-if)#ip add 172.16.1.2 255.255.255.0
    r1(config-if)#no sh
    r1(config-if)#exit
    r1(config)#int s0/
    *Mar  1 00:05:48.995: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
    *Mar  1 00:05:49.995: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
    r1(config)#int s0/1
    r1(config-if)#ip add 172.16.2.1 255.255.255.0
    r1(config-if)#no sh
    r1(config-if)#exit
    r1(config)#router ospf 1
    r1(config-router)#net 172.16.1.0 0.0.0.255 area 0
    r1(config-router)#net 172.16.2.0 0.0.0.255 area 0
    r1(config-router)#
    *Mar  1 00:06:33.831: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/1 from LOADING to FULL, Loading Done
    r1(config-router)#net 2.2.2.0 0.0.0.255 area 0
    r1(config-router)#exit
    r1(config)#ip  
    *Mar  1 00:08:03.291: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from LOADING to FULL, Loading Done
    r1(config)#do sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
     
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
     
         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1 [110/65] via 172.16.1.1, 00:14:57, Serial0/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback1
         3.0.0.0/32 is subnetted, 1 subnets
    O       3.3.3.3 [110/65] via 172.16.2.2, 00:14:57, Serial0/1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.1.0 is directly connected, Serial0/0
    C       172.16.2.0 is directly connected, Serial0/1
    O*E2 0.0.0.0/0 [110/1] via 172.16.1.1, 00:03:41, Serial0/0
    从上面R0 的路由表的输出,可以看到通过命令“default-information originate”
    确实可以向OSPF 区域注入一条默认路由。
    O*E2 0.0.0.0/0 [110/1] via 172.16.1.1, 00:03:41, Serial0/0
    r1(config)#do sh ip ospf da
     
                OSPF Router with ID (2.2.2.2) (Process ID 1)
     
                    Router Link States (Area 0)
     
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    1.1.1.1         1.1.1.1         945         0x80000003 0x00EE10 3
    2.2.2.2         2.2.2.2         959         0x80000004 0x0015B8 5
    3.3.3.3         3.3.3.3         1050        0x80000003 0x008560 3
     
                    Type-5 AS External Link States
     
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         1.1.1.1         264         0x80000001 0x001D91 1
    通过查看R4 的拓扑结构数据库可以看到,确实从外面注入了一条类型5 的LSA
     
     
    r2(config)#int loo 1
    r2(config-if)#ip add
    *Mar  1 00:01:53.915: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
    r2(config-if)#ip add 3.3.3.3 255.255.255.0
    r2(config-if)#int s0/0
    r2(config-if)#ip add 172.16.2.2 255.255.255.0
    r2(config-if)#no sh
    r2(config-if)#
    *Mar  1 00:02:17.255: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
    *Mar  1 00:02:18.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
    r2(config-if)#exit
    r2(config)#router ospf 1
    r2(config-router)#net 3.3.3.0 0.0.0.255
    % Incomplete command.
     
    r2(config-router)#net 3.3.3.0 0.0.0.255 area 0
    r2(config-router)#net 172.16.2.0 0.0.0.255 area 0
    r2(config-router)#   
    *Mar  1 00:06:33.459: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done
    r2(config-router)#


    本文转自gauyanm 51CTO博客,原文链接:http://blog.51cto.com/gauyanm/237883,如需转载请自行联系原作者
    展开全文
  • default-information originate 不能用于eigrp。 EIGRP没有这个命令,它引入缺省,一般都是重发布静态。 <br />redistribute static :重发布静态路由 将静态路由注入路由协议里面,让所有运行相同路由...

    default-information originate 不能用于eigrp。 EIGRP没有这个命令,它引入缺省,一般都是重发布静态。

    redistribute static  :重发布静态路由     将静态路由注入路由协议里面,让所有运行相同路由协议的路由器都能学到这条静态路由。
    default-information originate   引入缺省路由   这个,其实应该这样说,为别的运行相同路由协议的路由器引入缺省路由。意思就是说,敲下这条命令之后,这个路由器会通过路由协议告诉它的邻居,它有一条缺省路由,然后它的邻居就会产生一条指向这个路由器的缺省路由条目,所有发往未知网络的数据包都会发送给通告这条命令的路由器。但是,有一个前提条件,要让这个命令生效,路由器路由表里必须有缺省路由。意思是说,这个发出通告的路由器必须真正有缺省路由,不然不会通告。如果要强制通告,就是不管我本身有没有缺省路由,我都要通告,那么就要加个参数always: default-information originate always

    其实你这两条命令(在引入缺省路由方面)第一个一般都用在EIGRP上,第二个用在OSPF上。
    EIGRP的话,就是先配置一条静态缺省路由,例ip route 0.0.0.0 0.0.0.0 null0 ,再将这条路由重发布进EIGRP里面,让所有运行EIGRP的路由器都能知道那个路由器上有一个缺省的路由。

    如果不是为了引入缺省路由,仅仅是重发布静态路由的话,一般所有动态路由协议都是支持的

    展开全文
  • 区别: 1.default-information originate 必须要在本地配置默认路由,然后广播到OSPF区域。标记O*E2. default-information originate always不需要在本地配置默认路由,也可以广播到OSPF区域。 2.如果没有配置always...
    区别:
    1.default-information originate 必须要在本地配置默认路由,然后广播到OSPF区域。标记O*E2.
    default-information originate always不需要在本地配置默认路由,也可以广播到OSPF区域。
    2.如果没有配置always,并且默认路由是抖动的,那么OSPF需要在每次默认路由抖动时,向OSPF区域发送更新。
    如果使用always,则减少对OSPF数据库的操作,保持OSPF数据路的稳定。

    转载于:https://blog.51cto.com/vincent/99419

    展开全文
  • default-information originate 引入缺省路由 是为别的运行相同路由协议的路由器引入缺省路由。即敲下这条命令之后,这个路由器会通过路由协议告诉它的邻居,它有一条缺省路由,然后它的邻居就会产生一...
  • redistribute static :重发布静态...default-information originate 引入缺省路由 是为别的运行相同路由协议的路由器引入缺省路由。即敲下这条命令之后,这个路由器会通过路由协议告诉它的邻居,它有一条缺省路由,...
  • 实验拓朴: 实验配置: R1和R2 基本EBGP邻居关系 ...1. R2 BGP 配置default-in originate R1#sh ip bgp R2#sh ip bgp R1和R2 Bgp表里为空. 2. R2 BGP 配置default-in origin...
  • default-informationoriginate引入缺省路由这个,其实应该这样说,为别的运行相同路由协议的路由器引入缺省路由。意思就是说,敲下这条命令之后,这个路由器会通过路由协议告诉它的邻居,它有一条缺省路由,然后它的...
  • BGP配置之default-information originate

    千次阅读 2012-12-25 16:17:20
    在将这条路由重分发进BGP之前,先从路由器B的BGP配置中删除default-information originate命令。   核实是否有默认路由被通告?检查路由器A和路由器B的BGP表。   ...
  • area x nssa no-redistribution default-information-originate 的讲解 R1 : interface Loopback0   ip address 1.1.1.1 255.255.255.255 ! interface FastEthernet0/0   no ip address   ...
  • area 1 nssa default-information-originate 在R4上的路由信息: R4#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter...
  • 3.关于default-information originate 用于向网络中注入一条默认路由。 注意:这条命令用于将一条静态默认路由注入ospf,也就是说事先没有静态路由的话就没有效果了。  但如果在命令后加always的话,即使不存在静态...
  • ip route 0.0.0.0 0.0.0.0和default-information区别?第一条命令是指定一个默认路由,仅在本路由器有效,其他路由器不知道有一个默认路由的存在default information是将这个默认路由...information originate,注意...
  • OSPF默认路由生成是个很实际的问题,但是在使用中得出以下这些结论...default-information-originate always 二、、NSS区域中生成默认路由: 分为两种情况 1、ASBR上: area 44 nssa default-information-originate...
  • 2.另一种方法是先设置静态默认路由,然后在router rip用default-information originate通告出去Z-TEK USB转串口(好像是401,不带线,只是一个接口的),今天发现在笔记本上给台式机发送'a',台式机收到的是‘y'。...
  • ip default-gateway在禁用了ip routing的情况下使用,该路由器被当做默认网关。 ip default-network和ip route 0.0.0.0 0.0.0.0 则可以在启用路由选择协议下使用。 二、区别 ip default-network 与 ip route 0.0.0.0...
  • ip default-gateway在禁用了ip routing的情况下使用,该路由器被当做默认网关。 ip default-network和ip route 0.0.0.0 0.0.0.0 则可以在启用路由选择协议下使用。 二、区别 ip default-netwo...
  •  ip default-gateway在禁用了ip routing的情况下使用,该路由器被当做默认网关。  ip default-network和ip route 0.0.0.0 0.0.0.0 则可以在启用路由选择协议下使用。  二、区别  ip default-...
  • 1. ip default-gateway 关闭路由器routing功能(RXBoot模式),将路由器当作一台主机测试的时候为路由器设置的默认网关; 2. ip default-network 标记为几条静态路由(目的网络在必须存在路由),路由器从中选择开销...
  •  ip default-gateway在禁用了ip routing的情况下使用,该路由器被当做默认网关。  ip default-network和ip route 0.0.0.0 0.0.0.0 则可以在启用路由选择协议下使用。  二、区别  ip default-...
  • ip default-network IGRP/EIGRP:IP Default-Network所指定的网络必须在EIGRP进程中通告,或者将该路由重分布进EIGRP才会自动传递; RIP:ip default-network命令指定的网络则无需被显式的宣告进RIP,且一旦缺省...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,854
精华内容 1,141
关键字:

default-informationoriginate