mstp 订阅
多业务传送平台( Multi- Service Transport Platform,MSTP)技术是指基于SDH平台,同时实现TDM、ATM、以太网等业务的接入、处理和传送,提供统一网管的多业务传送平台。 [1]  MSTP充分利用SDH技术,特别是保护恢复能力和确保延时性能,加以改造后可以适应多业务应用,支持数据传输,简化了电路配置,加快了业务提供速度,改进了网络的扩展性,降低了运营维护成本。在PTN技术应用以前,MSTP技术是主要的传输承载网技术。 [1] 展开全文
多业务传送平台( Multi- Service Transport Platform,MSTP)技术是指基于SDH平台,同时实现TDM、ATM、以太网等业务的接入、处理和传送,提供统一网管的多业务传送平台。 [1]  MSTP充分利用SDH技术,特别是保护恢复能力和确保延时性能,加以改造后可以适应多业务应用,支持数据传输,简化了电路配置,加快了业务提供速度,改进了网络的扩展性,降低了运营维护成本。在PTN技术应用以前,MSTP技术是主要的传输承载网技术。 [1]
信息
英文缩写
MSTP
外文名
Multi-Service Transfer Platform
用    途
传输承载网技术
中文名
多业务传送平台
MSTP简介
随着时代的发展,多种网络传输形式出现在网络的应用当中,如文件、影音、图片以及数据传输,导致一定区域的网络容量无法满足大量的业务传输需求,这使得MSTP核心技术得以发展,其是一种基于同步数字体系当中的多业务的传输平台。其能够为多种形式的网络业务提供节点,实现平台之间的相互传输。并且提供统一化的管理,促进业务的正常运行。所谓的平台就是局域某一个平台的扩展,使得平台之间的传输更加流畅。MSTP核心技术是基于同步数据体系进行建立,进行相关业务的扩展。在实际的技术应用当中,这项技术还没有形成统一的名字,没有明确定义,主要是根据各个行业的需要进行信息传输,MSTP核心技术特性和内容发展的现状与相关的保准要求是一致的。 [2] 
收起全文
精华内容
下载资源
问答
  • MSTP

    2021-01-06 11:55:16
    MSTP:多生成树协议—可为每个vlan或者多个vlan为一组,构造一个生成树,实现网络的负载分担(均衡) -----------将sw1、Sw2分别做vlan10、vlan20的根网桥---------- [sw1]stp mode mstp ###将交换机配置成MSTP模式,...

    MSTP

    • MSTP:多生成树协议—可为每个vlan或者多个vlan为一组,构造一个生成树,实现网络的负载分担(均衡)

    -----------将sw1、Sw2分别做vlan10、vlan20的根网桥----------
    [sw1]stp mode mstp
    ###将交换机配置成MSTP模式,MSTP兼容sTP/RSTP。
    [Sw1 ]stp region-configuration
    ###进入MSTP域视图MSTP配置模式
    [ sw1-mst-region] region-name huawei1
    ###配置MSTP域的域名为huawei1,缺省为交换设备主控板上管理网口的Mac地址。
    [ Sw1-mst-region] revision-level 1
    ###配置MST域的MSTP修订级别为1,缺省情况下MSTP域的MSTP修订级别为0,需要将各设备的MSTP修订级别修改为一致
    手动配置多生成树实例和VLAN的映射关系,同一vlan的数据只能对应一个实例,而一个实例可以对应多个vlan (instance 1vlan 2 to 10)
    [Sw1-mst-region]instance 1 vlan 10
    ###将vlan 10加入实例1中
    [Sw1-mst-region]instance 2 vlan 20
    ###将vlan 20加入实例2中
    [Sw1-mst-region] check region-configuration
    ###查看MSTP域配置参数
    [Sw1-mst-region] active region-configuration
    ##激活MSTP域的配置(必须配置)
    [Sw1-mst-region] quit
    ###退出配置模式
    [Sw1]stp instance 1 root primary
    ###配置此交换机为实例1的主根桥
    [sw1]stp instance 2 root secondary
    ###配置此交换机为实例2的备份根桥

    展开全文
  • mstp

    2019-06-01 11:34:49
    MSTP(Multi-Service Transfer Platform)(基于SDH 的多业务传送平台)是指基于SDH 平台同时实现TDM、ATM、以太网等业务的接入、处理和传送,提供统一网管的多业务节点。多生成树(MST)使用修正的快速生成树(RSTP...

    MSTP(Multi-Service Transfer Platform)(基于SDH 的多业务传送平台)是指基于SDH 平台同时实现TDM、ATM、以太网等业务的接入、处理和传送,提供统一网管的多业务节点。
    多生成树(MST)使用修正的快速生成树(RSTP)协议,叫做多生成树协议(MSTP)
    MSTP(Multiple Spanning Tree Protocol,多生成树协议)
    国际:MSTP是多种技术与标准集成的结果,国际上没有专门的MSTP标准,只有MSTP所涉及的各单项技术的标准,其名称也有不同的叫法(如MSPP,NG-SDH等)。
    国内:2002年发布了MSTP首个行业标准"YD/T 1238-2002基于SDH的多业务传送节点技术要求"。
    入网许可:工信部对MSTP设备仅颁发进网试用批文,由于MSTP是在SDH基础上发展而来,一些MSTP设备使用的是SDH入网证。
    MSTP基于SDH 的多业务传送节点可根据网络需求应用在传送网的接入层、汇聚层,应用在骨干层的情况有待研究。
    城域网是当前电信运营商争夺的焦点,城域网组网技术种类繁多,大致包括基于SDH结构的城域网、基于以太网结构的城域网、基于ATM结构的城域网和基于DWDM结构的城域网。其实,SDH、ATM、 Ethernet 、WDM等各种技术也都在不断吸取其他技术的长处,互相取长补短,既要实现快速传输,又要满足多业务承载,另外还要提供电信级的QoS,各种城域网技术之间表现出一种融合的趋势。

    转载于:https://blog.51cto.com/14217014/2403527

    展开全文
  • MSTP+VRRP

    万次阅读 多人点赞 2020-08-04 00:14:48
    一、MSTP 二、MSTP 简介 三、拓扑 四、基础配置 五、配置与分析 六、VRRP配置 一、MSTP 1、作用 (1)防止二层环路与链路冗余 (2)基于VLAN的数据负载分担 小结 在MSTP中,最为关键的就是在阻塞链路时是基于接口所在...

    人品,才是一个人最硬的底牌。

    一、MSTP

    1、作用

    (1)防止二层环路与链路冗余
    (2)基于VLAN的数据负载分担

    2、端口角色

    端口角色: 4

    RP,DP; AP (RP备份) ; BP (DP备份)
    端口选举:同STP
    端口状态: 4种
    收敛时间:同RSTP
    拓扑变更:同RSTP
    拓扑变更的处理:同RSPT

    3、MSTP向下兼容

    STP, 失去快速收敛特性(连接STP的接口,其他接口不会变化)
    RSTP,保持快速收敛特性

    4、生成树与VLAN的关系

    一个或者多个VLAN可以共享一个生成树

    5、小结

    在MSTP中,最为关键的就是在阻塞链路时是基于接口所在vlan对应的生成树实例来对应接口角色;配置MSTP需要保证三个统一+一个激活,这个要点不要忘记;另外就是对于连接路由器的接口也要配置边缘接口,因为正常情况路由器所在的链路不会形成环路也不会发BPDU没有必要等待。

    二、MSTP 简介

    1、定义

    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE 802.1s中定义的生成树协议,通过生成多个生成树,来解决以太网环路问题。

    2、目的

    在以太网中部署MSTP协议后可实现如下功能:
    (1)形成多棵无环路的树,解决广播风暴并实现冗余备份。
    (2)多棵生成树在VLAN间实现负载均衡,不同VLAN的流量按照不同的路径转发。

    3、MSTP 出现的背景

    STP/RSTP 的缺陷

    RSTP在STP基础上进行了改进,实现了网络拓扑快速收敛。但RSTP和STP还存在同一个缺陷:由于局域网内所有的VLAN共享一棵生成树,因此无法在VLAN间实现数据流量的负载均衡,链路被阻塞后将不承载任何流量,还有可能造成部分VLAN的报文无法转发。

    4、MSTP 对 对 STP 和 和 RSTP 的改进

    为了弥补STP和RSTP的缺陷,IEEE于2002年发布的802.1s标准定义了MSTP。MSTP兼容STP和RSTP,既可以快速收敛,又提供了数据转发的多个冗余路径,在数据转发过程中实现VLAN数据的负载均衡。

    三、拓扑

    在这里插入图片描述

    四、基础配置

    1、如图配置底层信息(系统名称,接口地址)
    2、路由器和路由器,路由器和SW级连链路运行OSPF
    3、SW连接Router的链路接口配置为access;SW之间的级联链路配置为trunk,放行vlan自行决定

    AR2

    [AR2]ospf 1 router-id 2.2.2.2
    [AR2-ospf-1]area 0.0.0.0 
    [AR2-ospf-1]network 12.1.1.2 0.0.0.0 
    [AR2-ospf-1]network 100.1.1.2 0.0.0.0 
    
    [AR2]ip route-static 192.168.1.0 255.255.255.0 100.1.1.200
    [AR2]ip route-static 192.168.2.0 255.255.255.0 100.1.1.200
    
    [SW-1]int g0/0/24
    [SW-1-GigabitEthernet0/0/24]port link-type access
    [SW-1-GigabitEthernet0/0/24]port default vlan 100
    

    AR1配置类似

    五、配置与分析

    1、在SW运行MSTP来实现环路阻塞;与链路冗余;流量分担
    MSTP配置注意:同一个区域保证
    (1)所有SW域名一致
    (2)所有SW修订版本号一致
    (3)所有SW生成树实例和vlan映射关系一致
    (4)最后一定要记得激活生成树配置

    2、所有SW运行生成树模式为MSTP
    域名统一为MSTP;修订版本配置为0

    [SW-4]stp mode mstp 
    

    3、vlan 10对应实例 1; SW-1主根,SW-2备
    vlan 20对应实例 2; SW-2主根,SW-1备
    其余vlan 默认实例0,SW-1主根,SW-2备

    [SW-1]stp region-configuration      //配置多生成树实例
    [SW-1-mst-region]region-name MSTP   //修改本SW的域名为MSTP(默认为SW的背板MAC,全网统一)
    [SW-1-mst-region]revision-level 0   //修订版本号为0(默认为0,全网统一)
    [SW-1-mst-region]instance 1 vlan 10 //创建生成树实例1映射vlan 10
    [SW-1-mst-region]instance 2 vlan 20 //创建生成树实例2映射vlan 20
    
    [SW-1-mst-region]active region-configuration //激活以上对MSTP的配置 
    
    [SW-1]stp instance 0 root primary            //本SW-1为生成树实例0的主根桥
    [SW-1]stp instance 1 root primary            //本SW-1为生成树实例1的主根桥
    [SW-1]stp instance 2 root secondary          //本SW-1为生成树实例2的备份根桥
    

    SW-2配置类似

    [SW-1]dis stp region-configuration
    在这里插入图片描述
    4、所有连接终端的链路配置edge-port边缘接口

    接入层SW连接终端设备的接口配置为边缘接口,实现discarding到forwarding的跳跃过渡,避免因拓扑变化导致的无意义等待。

    [SW-3]int e0/0/1
    [SW-3-Ethernet0/0/1]port link-type access
    [SW-3-Ethernet0/0/1]port default vlan 10
    [SW-3-Ethernet0/0/1]stp edged-port enable //此接口的生成树状态配置为边缘接口(不受生成树计时器的影响)
    

    SW-1

    [SW-1-GigabitEthernet0/0/24]stp edged-port enable 
    

    SW-2

    [SW-2-GigabitEthernet0/0/24]stp edged-port enable 
    

    SW-4配置类似

    六、VRRP配置

    1、SW-1的vlanif 10为192.168.1.0的主网关,SW-2的vlanif 10作为备份192.168.1.0网段的虚拟网关地址为192.168.1.254

    [SW-1]int Vlanif 10
    [SW-1-Vlanif10]ip address 192.168.1.1 255.255.255.0
    [SW-1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.1.254
    //创建VRRP工作组,组编号为1,设置虚拟网关地址为192.168.1.254(工作组编号和虚拟网关必须一致)
    [SW-1-Vlanif10]vrrp vrid 1 priority 120
    //设置本VRRP工作组1在本路由器的优先级为120(默认100.越大越优先,优先者会成为数据的实际转发者)
    [SW-1]int Vlanif 20
    [SW-1-Vlanif20]ip address 192.168.2.1 255.255.255.0
    [SW-1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.2.254
    

    [SW-1]display vrrp brief
    在这里插入图片描述
    2、SW-2的vlanif 20为192.168.2.0的主网关,SW-1的vlanif 20作为备份192.168.2.0网段的虚拟网关地址为192.168.2.254

    [SW-2]int Vlanif 10
    [SW-2-Vlanif10]ip address 192.168.1.2 255.255.255.0
    [SW-2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.1.254
    //创建VRRP工作组,组编号为1,设置虚拟网关地址为192.168.1.254(工作组编号和虚拟网关必须一致)
    
    [SW-2]int Vlanif 20
    [SW-2-Vlanif20]ip address 192.168.2.2 255.255.255.0
    [SW-2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.2.254
    [SW-2-Vlanif20]vrrp vrid 2 priority 120
    //设置本VRRP工作组2在本路由器的优先级为120(默认100.越大越优先,优先者会成为数据的实际转发者)
    

    [SW-2]display vrrp brief
    在这里插入图片描述
    3、AR-1与AR-2的路由表中针对192.168.1.0和192.168.2.0路由信息的截图

    dis ip routing-table
    在这里插入图片描述
    dis ip routing-table
    在这里插入图片描述
    4、PC-1长pingPC-2 切断 SW-1与SW-3线路的截图,测试MSTP备份是否生效

    ping 192.168.2.100 -t
    在这里插入图片描述
    已生效

    5、PC-1长pingPC-2 关闭SW-1 截图,测试MSTP与BRRP的备份是否生效

    ping 192.168.2.100 -t
    在这里插入图片描述
    已生效


    在这里插入图片描述

    我是艺博东!古人云:以利相交,利尽则散;以势相交,势去则倾;以权相交,权失则弃;以情相交,情逝人伤。也欢迎你和我一起讨论,我们下期见。

    展开全文
  • MSTP配置MSTP配置

    2011-11-12 02:07:26
    MSTP配置MSTP配置MSTP配置MSTP配置MSTP配置
  • MSTP多区域生成树协议

    万次阅读 多人点赞 2018-05-22 13:20:44
    MSTP简介 多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE 802.1s中定义的生成树协议,通过生成多个生成树,来解决以太网环路问题。 目的: 在以太网中部署MSTP协议后可实现如下功能: 形成多棵...

    MSTP简介

    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE
    802.1s中定义的生成树协议,通过生成多个生成树,来解决以太网环路问题。

    目的:

    在以太网中部署MSTP协议后可实现如下功能:

    • 形成多棵无环路的树,解决广播风暴并实现冗余备份。
    • 多棵生成树在VLAN间实现负载均衡,不同VLAN的流量按照不同的路径转发。

    MSTP原理描述

    STP/RSTP的缺陷:

    RSTP在STP基础上进行了改进,实现了网络拓扑快速收敛。但RSTP和STP还存在同一个缺陷:由于局域网内所有的VLAN共享一棵生成树,因此无法在VLAN间实现数据流量的负载均衡,链路被阻塞后将不承载任何流量,还有可能造成部分VLAN的报文无法转发。

    MSTP对STP和RSTP的改进:

    • 为了弥补STP和RSTP的缺陷,IEEE于2002年发布的802.1S标准定义了MSTP。MSTP兼容STP和RSTP,既可以快速收敛,又提供了数据转发的多个冗余路径,在数据转发过程中实现VLAN数据的负载均衡。
    • MSTP把一个交换网络划分成多个域,每个域内形成多棵生成树,生成树之间彼此独立。每棵生成树叫做一个多生成树实例MSTI(Multiple Spanning Tree Instance),每个域叫做一个MST域(MST Region:Multiple Spanning Tree Region)。
    • 所谓生成树实例就是多个VLAN的一个集合。通过将多个VLAN捆绑到一个实例,可以节省通信开销和资源占用率。MSTP各个实例拓扑的计算相互独立,在这些实例上可以实现负载均衡。可以把多个相同拓扑结构的VLAN映射到一个实例里,这些VLAN在端口上的转发状态取决于端口在对应MSTP实例的状态。

    MSTP基本概念:

    • MST域(MST Region)

      ​ 都启动了MSTP。

      • 具有相同的域名。
      • 具有相同的VLAN到生成树实例映射配置。
      • 具有相同的MSTP修订级别配置。

      一个局域网可以存在多个MST域,各MST域之间在物理上直接或间接相连。用户可以通过MSTP配置命令把多台交换设备划分在同一个MST域内。

    • VLAN映射表:

    VLAN映射表是MST域的属性,它描述了VLAN和MSTI之间的映射关系。

    • CST

    公共生成树CST(Common Spanning Tree)是连接交换网络内所有MST域的一棵生成树。

    如果把每个MST域看作是一个节点,CST就是这些节点通过STP或RSTP协议计算生成的一棵生成树。

    • IST

      内部生成树IST(Internal Spanning Tree)是各MST域内的一棵生成树。

      IST是一个特殊的MSTI,MSTI的ID为0,通常称为MSTI0。

      IST是CIST在MST域中的一个片段。

    • SST

    运行STP或RSTP的交换设备只能属于一个生成树。

    MST域中只有一个交换设备,这个交换设备构成单生成树。

    • CIST

      公共和内部生成树CIST(Common and Internal Spanning Tree)是通过STP或RSTP协议计算生成的,连接一个交换网络内所有交换设备的单生成树。

    • 域根

      域根(Regional Root)分为IST域根和MSTI域根。

      一个MST域内可以生成多棵生成树,每棵生成树都称为一个MSTI。MSTI域根是每个多生成树实例的树根。

    • 总根

      总根是CIST(Common and Internal Spanning Tree)的根桥。

    • 主桥

      主桥(Master Bridge)也就是IST Master,它是域内距离总根最近的交换设备。

    • 端口角色

      根端口、指定端口、Alternate端口、Backup端口和边缘端口的作用同RSTP协议中定义。

      除边缘端口外,其他端口角色都参与MSTP的计算过程。

      同一端口在不同的生成树实例中可以担任不同的角色。

    端口角色:

    端口角色说明
    根端口在非根桥上,离根桥最近的端口是本交换设备的根端口。根交换设备没有根端口。根端口负责向树根方向转发数据。
    指定端口对一台交换设备而言,它的指定端口是向下游交换设备转发BPDU报文的端口。
    Alternate端口从配置BPDU报文发送角度来看,Alternate端口就是由于学习到其它网桥发送的配置BPDU报文而阻塞的端口。 从用户流量角度来看,Alternate端口提供了从指定桥到根的另一条可切换路径,作为根端口的备份端口。
    Backup端口从配置BPDU报文发送角度来看,Backup端口就是由于学习到自己发送的配置BPDU报文而阻塞的端口。 从用户流量角度来看,Backup端口作为指定端口的备份,提供了另外一条从根节点到叶节点的备份通路。
    Master端口1、 Master端口是MST域和总根相连的所有路径中最短路径上的端口,它是交换设备上连接MST域到总根的端口。 2、 Master端口是域中的报文去往总根的必经之路。 3、 Master端口是特殊域边缘端口,Master端口在CIST上的角色是Root Port,在其它各实例上的角色都是Master端口。
    域边缘端口域边缘端口是指位于MST域的边缘并连接其它MST域或SST的端口。
    边缘端口1、如果指定端口位于整个域的边缘,不再与任何交换设备连接,这种端口叫做边缘端口。2、 边缘端口一般与用户终端设备直接连接。 3、 端口使能MSTP功能后,会默认启用边缘端口自动探测功能,当端口在(2 × Hello Timer + 1)秒的时间内收不到BPDU报文,自动将端口设置为边缘端口,否则设置为非边缘端口。

    端口状态:

    MSTP定义的端口状态与RSTP协议中定义相同。

    注:根端口、Master端口、指定端口和域边缘端口支持Forwarding、Learning和Discarding状态,Alternate端口和Backup端口仅支持Discarding状态。

    MSTP报文:

    MSTP使用多生成树桥协议数据单元MST BPDU(Multiple Spanning Tree Bridge Protocol Data Unit)作为生成树计算的依据。MST BPDU报文用来计算生成树的拓扑、维护网络拓扑以及传达拓扑变化记录。

    STP中定义的配置BPDU、RSTP中定义的RST BPDU、MSTP中定义的MST BPDU及TCN BPDU差异对比如下:

    四种BPDU差异比较:

    版本类型名称
    00x00配置BPDU
    00x80TCN BPDU
    20x02RST BPDU
    30x02MST BPDU

    MSTP帧格式:

    这里写图片描述

    图:MSTP帧格式

    无论是域内的MST BPDU还是域间的,前35个字节和RST BPDU相同。

    从第36个字节开始是MSTP专有字段。最后的MSTI配置信息字段由若干MSTI配置信息组连缀而成。

    MSTP 报文字段解释:

    字段说明
    Protocol Identifier协议标识符。
    Protocol Version Identifier协议版本标识符,STP为0,RSTP为2,MSTP为3。
    BPDU TypeBPDU类型,MSTP为0x02。0x00:STP的Configuration BPDU0x80:STP的TCN BPDU(Topology Change Notification BPDU)0x02:RST BPDU(Rapid Spanning-Tree BPDU)或者MST BPDU(Multiple Spanning-Tree BPDU)
    CIST FlagsCIST标志字段。
    CIST Root IdentifierCIST的总根交换机ID。
    CIST External Path CostCIST外部路径开销指从本交换机所属的MST域到CIST根交换机的累计路径开销。CIST外部路径开销根据链路带宽计算。
    CIST Regional Root IdentifierCIST的域根交换机ID,即IST Master的ID。 如果总根在这个域内,那么域根交换机ID就是总根交换机ID。
    CIST Port Identifier本端口在IST中的指定端口ID。
    Message AgeBPDU报文的生存期。
    Max AgeBPDU报文的最大生存期,超时则认为到根交换机的链路故障。
    Hello TimeHello定时器,缺省为2秒。
    Forward DelayForward Delay定时器,缺省为15秒。
    Version 1 LengthVersion1 BPDU的长度,值固定为0。
    Version 3 LengthVersion3 BPDU的长度。
    MST Configuration IdentifierMST配置标识,表示MST域的标签信息,包含4个字段:Configuration Identifier Format Selector:固定为0。Configuration Name:“域名”,32字节长字符串。Revision Level:2字节非负整数。Configuration Digest:利用HMAC-MD5算法将域中VLAN和实例的映射关系加密成16字节的摘要。只有MST Configuration Identifier中的四个字段完全相同的,并且互联的交换机,才属于同一个域。
    CIST Internal Root Path CostCIST内部路径开销指从本端口到IST Master交换机的累计路径开销。CIST内部路径开销根据链路带宽计算。
    CIST Bridge IdentifierCIST的指定交换机ID。
    CIST Remaining HopsBPDU报文在CIST中的剩余跳数。
    MSTI Configuration Messages (may be absent)MSTI配置信息。每个MSTI的配置信息占16 bytes,如果有n个MSTI就占用n×16bytes。单个MSTI Configuration Messages的字段说明如下:MSTI Flags:MSTI标志。MSTI Regional Root Identifier:MSTI域根交换机ID。MSTI Internal Root Path Cost:MSTI内部路径开销指从本端口到MSTI域根交换机的累计路径开销。MSTI内部路径开销根据链路带宽计算。MSTI Bridge Priority:本交换机在MSTI中的指定交换机的优先级。MSTI Port Priority:本交换机在MSTI中的指定端口的优先级。MSTI Remaining Hops:BPDU报文在MSTI中的剩余跳数。

    MSTP报文抓包示例:

    这里写图片描述

    图:MST BPDU包示例

    MSTP报文格式可配置:

    目前MSTP的BPDU报文存在两种格式:

    • dot1s:IEEE802.1s规定的报文格式。
    • legacy:私有协议报文格式。

    如果端口收发报文格式为默认支持dot1s或者legacy,这样就存在一个缺点:需要人工识别对端的BPDU报文格式,然后手工配置命令来决定支持哪种格式。人工识别报文格式比较困难,且一旦配置错误,就有可能导致MSTP计算错误,出现环路。

    华为技术有限公司采用的端口收发MSTP报文格式可配置(stp compliance)功能,能够实现对BPDU报文格式的自适应:

    • auto
    • dot1s
    • legacy

    这样报文收发不但支持dot1s和legacy格式,还能通过auto方式根据收到的BPDU报文格式自动切换端口支持的BPDU报文格式,使报文格式与对端匹配。在自适应的情况下,端口初始支持dot1s格式,收到报文后,格式则和收到的报文格式保持一致。

    每个Hello Time时间内端口最多能发送BPDU的报文数可配置:

    Hello Time用于生成树协议定时发送配置消息维护生成树的稳定。如果交换设备在一段时间内没有收到BPDU报文,则会由于消息超时而对生成树进行重新计算。

    当交换设备成为根交换设备时,该交换设备会按照该设置值为时间间隔发送BPDU报文。非根交换设备采用根交换设备所设置的Hello Time时间值。

    华为技术有限公司数据通信设备提供的每个Hello Time时间内端口最多能够发送的BPDU报文个数可配置(Max Transmitted BPDU Number in Hello Time is Configurable)功能,可以设定当前端口在Hello Time时间内配置BPDU的最大发送数目。

    用户配置的数值越大,表示每Hello Time时间内发送的报文数越多。适当的设置该值可以限制端口每Hello Time时间内能发送的BPDU数目,防止在网络拓扑动荡时,BPDU占用过多的带宽资源。

    MSTP拓扑计算:

    MSTP可以将整个二层网络划分为多个MST域,各个域之间通过计算生成CST。域内则通过计算生成多棵生成树,每棵生成树都被称为是一个多生成树实例。其中实例0被称为IST,其他的多生成树实例为MSTI。MSTP同STP一样,使用配置消息进行生成树的计算,只是配置消息中携带的是设备上MSTP的配置信息。

    优先级向量:

    MSTI和CIST都是根据优先级向量来计算的,这些优先级向量信息都包含在MST BPDU中。各交换设备互相交换MST BPDU来生成MSTI和CIST。

    • 优先级向量简介

      • 参与CIST计算的优先级向量为:

        { 根交换设备ID,外部路径开销,域根ID,内部路径开销,指定交换设备ID,指定端口ID,接收端口ID }

      • 参与MSTI计算的优先级向量为:

        { 域根ID,内部路径开销,指定交换设备ID,指定端口ID,接收端口ID }

      括号中的向量的优先级从左到右依次递减。

    向量说明:

    向量名说明
    根交换设备ID根交换设备ID用于选择CIST中的根交换设备。根交换设备ID = Priority(16bits) + MAC(48bits)。其中Priority为MSTI0的优先级。
    外部路径开销(ERPC)从CIST的域根到达总根的路径开销。MST域内所有交换设备上保存的外部路径开销相同。若CIST根交换设备在域中,则域内所有交换设备上保存的外部路径开销为0。
    域根ID域根ID用于选择MSTI中的域根。域根ID = Priority(16bits) + MAC(48bits)。其中Priority为MSTI0的优先级。
    内部路径开销(IRPC)本桥到达域根的路径开销。域边缘端口保存的内部路径开销大于非域边缘端口保存的内部路径开销。
    指定交换设备IDCIST或MSTI实例的指定交换设备是本桥通往域根的最邻近的上游桥。如果本桥就是总根或域根,则指定交换设备为自己。
    指定端口ID指定交换设备上同本设备上根端口相连的端口。Port ID = Priority(4位) + 端口号(12位)。端口优先级必须是16的整数倍。
    接收端口ID接收到BPDU报文的端口。Port ID = Priority(4位) + 端口号(12位)。端口优先级必须是16的整数倍。
    • 比较原则

      同一向量比较,值最小的向量具有最高优先级。

      优先级向量比较原则如下。

      1. 首先,比较根交换设备ID。
      2. 如果根交换设备ID相同,再比较外部路径开销。
      3. 如果外部路径开销相同,再比较域根ID。
      4. 如果域根ID仍然相同,再比较内部路径开销。
      5. 如果内部路径仍然相同,再比较指定交换设备ID。
      6. 如果指定交换设备ID仍然相同,再比较指定端口ID。
      7. 如果指定端口ID还相同,再比较接收端口ID。

      如果端口接收到的BPDU内包含的配置消息优于端口上保存的配置消息,则端口上原来保存的配置消息被新收到的配置消息替代。端口同时更新交换设备保存的全局配置消息。反之,新收到的BPDU被丢弃。

    CIST中端口角色的选举:

    1、比价CIST的总根ID,越小越优。
    2、比较CIST到达总根的ERPC,越小越优。
    3、比较CIST域根的BID,越小越优。
    4、比较CIST到达域根的IPRC,越小越优。
    5、比较CIST中BPDU报文发送者的BID,越小越优。
    6、比较CIST中BPDU报文发送者的PID,越小越优。
    7、比较CIST中BPDU报文接收者的PID,越小越优。

    CIST的计算:

    经过比较配置消息后,在整个网络中选择一个优先级最高的交换设备作为CIST的树根。在每个MST域内MSTP通过计算生成IST;同时MSTP将每个MST域作为单台交换设备对待,通过计算在MST域间生成CST。CST和IST构成了整个交换设备网络的CIST。

    MSTI的计算:

    在MST域内,MSTP根据VLAN和生成树实例的映射关系,针对不同的VLAN生成不同的生成树实例。每棵生成树独立进行计算,计算过程与STP计算生成树的过程类似。

    MSTI的特点:

    • 每个MSTI独立计算自己的生成树,互不干扰。

    • 每个MSTI的生成树计算方法与STP基本相同。

    • 每个MSTI的生成树可以有不同的根,不同的拓扑。

    • 每个MSTI在自己的生成树内发送BPDU。

    • 每个MSTI的拓扑通过命令配置决定。

    • 每个端口在不同MSTI上的生成树参数可以不同。

    • 每个端口在不同MSTI上的角色、状态可以不同。

    • 在MST域内,沿着其对应的MSTI转发。

    • 在MST域间,沿着CST转发。

    MSTP对拓扑变化的处理:

    MSTP拓扑变化处理与RSTP拓扑变化处理过程类似。

    在RSTP中检测拓扑是否发生变化只有一个标准:一个非边缘端口迁移到Forwarding状态。

    • 为本交换设备的所有非边缘指定端口启动一个TC While Timer,该计时器值是Hello Time的两倍。

      在这个时间内,清空所有端口上学习到的MAC地址。

      同时,由非边缘端口向外发送RST BPDU,其中TC置位。一旦TC While Timer超时,则停止发送RST BPDU。

    • 其他交换设备接收到RST BPDU后,清空所有端口学习到MAC地址,除了收到RST BPDU的端口。然后也为自己所有的非边缘指定端口和根端口启动TC While Timer,重复上述过程。

    如此,网络中就会产生RST BPDU的泛洪。

    MSTP快速收敛机制:

    MSTP支持普通方式和增强方式两种P/A(Proposal/Agreement)机制:

    • 普通方式

      MSTP支持普通方式的P/A机制实现与RSTP支持的P/A机制实现相同。

    • 增强方式

    这里写图片描述

    图:增加方式的P/A机制

    在MSTP中,P/A机制工作过程如下:

    • 上游设备发送Proposal报文,请求进行快速迁移。下游设备接收到后,把与上游设备相连的端口设置为根端口,并阻塞所有非边缘端口。
    • 上游设备继续发送Agreement报文。下游设备接收到后,根端口转为Forwarding状态。
    • 下游设备回应Agreement报文。上游设备接收到后,把与下游设备相连的端口设置为指定端口,指定端口进入Forwarding状态。

    缺省情况下,华为数据通信设备使用增强的快速迁移机制。如果华为数据通信设备和其他制造商的设备进行互通,而其他制造商的设备P/A机制使用普通的快速迁移机制,此时,可在华为数据通信设备上通过设置P/A机制为普通的快速迁移机制,从而实现华为数据通信设备和其他制造商的设备进行互通。

    MSTP多进程:

    MSTP多进程是基于MSTP协议的增强性技术。此技术可将二层交换设备上的端口绑定到不同的进程中,并以进程为单位进行MSTP协议计算,不在同一个进程内的端口不参与此进程中的MSTP协议计算,从而实现各个进程内的生成树计算相互独立,互不影响。

    MSTP多进程机制并不只限于MSTP协议,RSTP和STP协议同样适用。

    优势:

    通过部署MSTP多进程可实现如下:

    • 极大地提升了在不同组网条件下生成树协议的可部署性。

      为了保证运行不同类型生成树协议的网络可靠运行,可将不同类型的生成树协议划分到不同的进程中,不同进程对应的网络进行独立的生成树协议计算。

    • 增强了组网的可靠性,对于大量的二层接入设备,可减少单台设备故障对整个网络的冲击。

      通过进程隔离不同的拓扑计算,即某台设备故障只影响其所在的进程对应的拓扑,不会影响其他进程拓扑计算。

    • 网络扩容时,可减少网络管理者维护量,从而提升了用户运维管理的方便性。

      当网络扩容时,只需要划分新的进程与原有网络对接,不需要调整原有网络的MSTP进程配置。如果是某个进程中进行了设备扩容,此时也只需要针对扩容的进程进行修改,而不需要调整其他进程中的配置。

    • 实现二层端口分割管理

      每个MSTP进程可以管理设备上的部分端口,即设备的二层端口资源被多个MSTP进程分割管理,每个MSTP进程上均可运行标准的MSTP。

    MSTP配置

    配置MSTP基本功能:

    配置MSTP的工作模式:

    stp mode mstp //配置交换设备的MSTP模式
    

    因为STP和MSTP不能互相识别报文,而MSTP和RSTP可以互相识别报文,所以若工作在MSTP工作模式下,交换设备会设置所有和运行STP的交换设备直接相连的端口工作在STP模式下,其他端口工作在MSTP模式下,实现运行不同生成树协议的设备之间的互通。

    配置MST域并激活:

    当两台交换设备的以下配置都相同时,这两台交换设备属于同一个MST域。

    • MST域的域名。
    • 多生成树实例和VLAN的映射关系。
    • MST域的修订级别。
    stp region-configuration //进入MST域视图
    region-name name //配置MST域的域名
    instance 1 vlan 2 to 3 //配置多生成树的实例与VLAN映射关系
    vlan-mapping modulo modulo //配置多生成树实例和VLAN按照缺省算法自动分配映射关系。缺省情况下,MST域内所有的VLAN都映射到生成树实例0。
    revision-level level //配置MST域的MSTP修订级别
    //缺省情况下,MST域的MSTP修订级别为0。
    //MSTP是标准协议,各厂商设备的MSTP修订级别一般都默认为0。如果某厂商的设备不为0,为保持MST域内计算,在部署MSTP时,需要将各设备的MSTP修订级别修改为一致。
    active region-configuration //激活MST域的配置
    

    配置根桥和备份根桥:

    stp instance 0 root primary //配置当前设备为根桥设备。 
    stp instance 0 root secondary//配置当前交换设备为备份根桥设备。 
    

    配置交换设备在指定实例中的优先级;

    stp instance 0 priority 32768 
    //配置交换设备在指定生成树实例中的优先级。 
    

    配置端口在指定生成树实例中的路径开销:

    stp pathcost-standard { dot1d-1998 | dot1t | legacy }
    //配置端口路径开销计算方法。 缺省情况下,路径开销的计算方法为IEEE 802.1t(dot1t)标准方法。
    
    //同一网络内所有交换设备的端口路径开销应使用相同的计算方法。
    
    stp instacne 0 cost cost //设置当前端口在指定生成树实例中的路径开销值。 
    
    • 配置端口路径开销计算方法为legacy时,参数cost取值范围是1~200000。

    • 配置端口路径开销计算方法为dot1d-1998时,参数cost取值范围是1~65535。

    • 配置端口路径开销计算方法为dot1t时,参数cost取值范围是1~200000000。

    配置端口在指定生成树实例中的优先级:

    stp instance 0 port priority 128
      //配置端口在指定生成树实例中的优先级。
    

    缺省情况下,端口的优先级数值为128。

    优先级数值的取值范围是0~240,步长为16。

    配置端口收发MSTP下一的报文格式:

    MSTP协议报文存在两种格式,一种为dot1s,即IEEE802.1s规定的报文格式,另一种为legacy,是一种私有报文格式。

    配置时,可以指定报文的格式,也可以配置MSTP协议报文格式自适应的功能,即根据收到的MSTP协议报文格式自动切换端口支持的MSTP协议报文格式,使报文格式与对端匹配。

    stp compliance { auto | dot1s legacy } 配置端口协议报文格式。

    stp config-digest-snoop //使能端口上配置摘要监听功能。

    MSTP配置举例:

    如下图,按要求配置各个区域。防止出现环路。

    配置文件:

    SW1:SW2和3与SW1类似。

    <SW1>dis current-configuration 
    #
    sysname SW1
    #
    vlan batch 2 to 20
    #
    stp instance 0 root primary
    stp instance 1 root primary
    stp instance 2 root secondary
    #
    stp region-configuration
     region-name HCNA
     revision-level 1
     instance 1 vlan 1 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    

    SW4:SW5和6配置和SW4配置类似:

    <SW4>dis current-configuration 
    #
    sysname SW4
    #
    vlan batch 2 to 20
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    #
    stp region-configuration
     region-name HCNP
     revision-level 2
     instance 1 vlan 1 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    

    SW7:8,9的配置和7的配置类似:

    [SW7]dis current-configuration 
    #
    sysname SW7
    #
    vlan batch 2 to 20
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    #
    stp region-configuration
     region-name HCIE
     instance 1 vlan 1 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    

    查看MSTP状态:

    这里写图片描述

    图:SW4各端口在不同示例下的状态

    参考文档:华为HedEx文档


    展开全文
  • MSTP原理MSTP原理

    2012-02-06 18:21:42
    详细介绍 MSTP原理 非常全面MSTP原理
  • MSTP详解及MSTP配置实例.doc
  • 交换机mstp

    2014-12-11 18:50:22
    本文讲述了交换机中mstp的知识以及技术。
  • MSTP业务概述

    2018-11-14 07:23:31
    电信数字电路业务谁在用?业务特性介绍;选择MSTP的原因;如何确定需求;如何购买MSTP业务
  • MSTP实验.doc

    2020-07-21 11:49:36
    MSTP实验.doc
  • MSTP培训资料

    2019-01-03 17:54:48
    公司培训资料,帮助大家更好认识MSTP技术,非常好,公司
  • 华为mstp配置实验

    2021-02-26 10:46:19
    华为mstp实验,请用eNSP打开
  • MSTP技术原理

    2016-03-26 17:28:41
    MSTP技术原理

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,600
精华内容 2,240
关键字:

mstp