精华内容
下载资源
问答
  • IRF

    千次阅读 2020-02-26 09:57:03
    IRF IRF技术具有管理渐变、网络扩展能力强、可靠性高等优点。 前提条件 两个系统启动后 配置swi-2 1、线路连接好,修改主机名 [H3C]sysname swi-1 [swi-1] 2、shutdown 用于IRF的端口 [swi-1]interface range Ten...

    IRF

    IRF技术具有管理渐变、网络扩展能力强、可靠性高等优点。

    前提条件

    两个系统启动后

    配置swi-2

    1、线路连接好,修改主机名

    [H3C]sysname swi-1
    [swi-1]
    
    

    2、shutdown 用于IRF的端口

    [swi-1]interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/50
    [swi-1-if-range]shutdown
    [swi-1-if-range]quit
    

    3、在swi-1 创建IRF端口2,将两个端口 与 IRF端口绑定

    例子:irf-port member-id/port-number
    
    [swi-1]irf-port 1/2
    [swi-1-irf-port1/2]port group interface Ten-GigabitEthernet 1/0/49
    You must perform the following tasks for a successful IRF setup:
    Save the configuration after completing IRF configuration.
    Execute the "irf-port-configuration active" command to activate the IRF ports.
    [swi-1-irf-port1/2]port group interface Ten-GigabitEthernet 1/0/50
    [swi-1-irf-port1/2]quit
    
    

    4、undo shutdown 用于irf的端口

    [swi-1]interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/50
    [swi-1-if-range]undo shutdown
    [swi-1-if-range]quit
    

    5、配置 swi-1 irf组中,默认成员编号为1 ,优先级为31 ,IRF 优先级,越大越是Master,保证其成为IRF中的主设备。

    [swi-1]irf member 1 priority 31
    

    6、保存配置

    [swi-1]quit
    <swi-1>save
    The current configuration will be written to the device. Are you sure? [Y/N]:y
    Please input the file name(*.cfg)[flash:/startup.cfg]
    (To leave the existing filename unchanged, press the enter key):
    Validating file. Please wait...
    Saved the current configuration to mainboard device successfully.
    

    7、激活IRF端口的配置

    <swi-1>sys
    System View: return to User View with Ctrl+Z.
    [swi-1]irf-port-configuration active
    

    配置swi-2

    1、配置swi-2 加入IRF组,成员编号为2,并重启设备使配置生效。

    [swi-2]irf member 1 renumber 2
    Renumbering the member ID may result in configuration change or loss. Continue?[Y/N]:y
    [swi-2]quit
    
    <swi-2>reboot
    Start to check configuration with next startup configuration file, please wait.........DONE!
    Current configuration may be lost after the reboot, save current configuration? [Y/N]:y
    Please input the file name(*.cfg)[flash:/startup.cfg]
    (To leave the existing filename unchanged, press the enter key):
    Validating file. Please wait...
    Saved the current configuration to mainboard device successfully.
    This command will reboot the device. Continue? [Y/N]:y
    

    2、shutdown 用于irf的端口

    swi-2 交换机重启后,系统的接口都已经变成了 如下:

    interface GigabitEthernet2/0/1
     port link-mode bridge
     combo enable fiber
    #
    interface GigabitEthernet2/0/2
     port link-mode bridge
     combo enable fiber
    
    

    所以,在接着配置端口的时候就都变成了2/0/X

    [swi-2]interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/50
    [swi-2-if-range]shutdown
    [swi-2-if-range]quit
    
    

    3、在swi-2 创建IRF端口1,将两个端口 与 IRF端口绑定

    例子:irf-port member-id/port-number
    
    [swi-2]irf-port 2/1
    [swi-2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/49
    [swi-2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/50
    [swi-2-irf-port2/1]quit
    

    4、undo shutdown 用于irf的端口

    [swi-2]interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/50
    [swi-2-if-range]undo shutdown
    [swi-2-if-range]quit
    

    5、保存配置

    [swi-2]quit
    <swi-2>save
    The current configuration will be written to the device. Are you sure? [Y/N]:y
    Please input the file name(*.cfg)[flash:/startup.cfg]
    (To leave the existing filename unchanged, press the enter key):
    flash:/startup.cfg exists, overwrite? [Y/N]:y
    Validating file. Please wait...
    Saved the current configuration to mainboard device successfully.
    
    

    6、激活IRF端口的配置

    <swi-2>sys
    System View: return to User View with Ctrl+Z.
    [swi-2]irf-port-configuration active
    
    到这里,两台设备会进行Master竞选,竞选失败的一方将自动重启,重启完成后IRF形成,系统名称统一为swi-1的主机名。
    
    

    验证

    当swi-2 启动,这时候swi-1 和swi-2的配置文件是一样的,甚至主机名都是一样的,并且包含两个交换机的所有端口。

    1/0/X 是swi-1 的对应端口;2/0/X 是swi-2的对应端口。

    irf配置如下:

    irf mac-address persistent timer
    irf auto-update enable
    undo irf link-delay
    irf member 1 priority 31
    irf member 2 priority 1
    
    irf-port 1/2
     port group interface Ten-GigabitEthernet1/0/49
     port group interface Ten-GigabitEthernet1/0/50
    #
    irf-port 2/1
     port group interface Ten-GigabitEthernet2/0/49
     port group interface Ten-GigabitEthernet2/0/50
    
    

    端口如下:

    interface Ten-GigabitEthernet1/0/49
     combo enable fiber
    #
    interface Ten-GigabitEthernet1/0/50
     combo enable fiber
    #
    interface Ten-GigabitEthernet2/0/49
     combo enable fiber
    #
    interface Ten-GigabitEthernet2/0/50
     combo enable fiber
    
    

    当这时候保存配置的时候,会发现多了一个slot 2:

    <swi-1>sav
    The current configuration will be written to the device. Are you sure? [Y/N]:y
    Please input the file name(*.cfg)[flash:/startup.cfg]
    (To leave the existing filename unchanged, press the enter key):
    flash:/startup.cfg exists, overwrite? [Y/N]:y
    Validating file. Please wait...
    Saved the current configuration to mainboard device successfully.
    Slot 2:
    Save next configuration file successfully.
    
    

    验证客户端到IRF

    swi-1 和swi-2 配置了IRF ,他们的配置是统一的,client模拟一个服务器两个网卡,当1/0/1断掉后,1.1.1.2和1.1.1.1之间还是畅通的。

    默认链路正常的情况下,client ping 5次,都从swi-1走了,抓包如下:

    当client到swi-1 之间的链路中断,数据将从g1/0/2 向swi-2通信。

    MAD检测

    BFD MAD检测

    MAD 检测 (Multi-Active Detection,多active检测)

    BFD 检测 (bidirectional forwarding detection,双向转发检测)

    ARP 检测 (Address Resolution Protocol,地址解析协议)

    为了防止万一IRF链路故障导致IRF分裂、网络中存在两个配置冲突的IRF,需要启用MAD检测功能。因为成员设备计较少,我们采用BFD MAD检测方式来检测IRF 的状态。

    BFD前提条件: 需要在swi-1和swi-2 之间增加一条心跳线用于检测,这条线不能用于其他任何数据传输。

    在swi-1和swi-2之间增加一条连接线 G1/0/3和G2/0/3:

    1、创建一个单独vlan 3用于 MAD ip检测通信,把接口加入vlan

    [swi-1]vlan 3
    [swi-1-vlan3]port GigabitEthernet 1/0/3 GigabitEthernet 2/0/3
    [swi-1-vlan3]quit
    

    2、创建vlan接口3 配置MAD IP地址

    [swi-1]interface Vlan-interface 3
    [swi-1-Vlan-interface3]mad bfd enable
    [swi-1-Vlan-interface3]mad ip address 192.168.1.1 30 member 1
    [swi-1-Vlan-interface3]mad ip address 192.168.1.2 30 member 2
    [swi-1-Vlan-interface3]quit
    

    3、在两个接口上关闭生成树功能。

    因为BFD MAD和生成树功互斥。

    [swi-1]interface GigabitEthernet 1/0/3
    [swi-1-GigabitEthernet1/0/3]undo stp enable
    [swi-1-GigabitEthernet1/0/3]inter gi 2/0/3
    [swi-1-GigabitEthernet2/0/3]undo stp enable
    [swi-1-GigabitEthernet2/0/3]quit
    
    

    4、配置完成后如下:

    interface Vlan-interface3
     mad bfd enable
     mad ip address 192.168.1.1 255.255.255.252 member 1
     mad ip address 192.168.1.2 255.255.255.252 member 2
    
    interface GigabitEthernet1/0/3
     port link-mode bridge
     port access vlan 3
     combo enable fiber
     undo stp enable
    
    interface GigabitEthernet2/0/3
     port link-mode bridge
     port access vlan 3
     combo enable fiber
     undo stp enable
    
    

    正常情况下,只可以ping通192.168.1.1 。

    当irf 链路1/0/49和1/0/50断裂后,inter vlan 3 接口和g1/0/3 随即也会变为down,最后提示 BFD MAD function enabled on Vlan-interface3 changed to the faulty state.

    [swi-1]interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/50
    [swi-1-if-range]shu
    [swi-1-if-range]shutdown
    %Nov  6 11:10:35:730 2018 swi-1 LLDP/6/LLDP_DELETE_NEIGHBOR: -Slot=2; Nearest bridge agent neighbor deleted on port Ten-GigabitEthernet2/0/49 (IfIndex 178), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet1/0/49.
    
    %Nov  6 11:10:36:231 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/49 changed to down.
    %Nov  6 11:10:36:231 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/49 changed to down.
    %Nov  6 11:10:36:261 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet2/0/49 changed to down.
    %Nov  6 11:10:36:261 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet2/0/49 changed to down.
    [swi-1-if-range]%Nov  6 11:10:36:045 2018 swi-1 LLDP/6/LLDP_DELETE_NEIGHBOR: -Slot=2; Nearest bridge agent neighbor deleted on port Ten-GigabitEthernet2/0/50 (IfIndex 179), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet1/0/50.
    
    %Nov  6 11:10:36:558 2018 swi-1 STM/3/STM_LINK_DOWN: IRF port 2 went down.
    %Nov  6 11:10:36:559 2018 swi-1 DEV/3/BOARD_REMOVED: Board was removed from slot 2, type is H3C S5820V2-54Q.
    %Nov  6 11:10:36:598 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/50 changed to down.
    %Nov  6 11:10:36:598 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/50 changed to down.
    %Nov  6 11:10:36:615 2018 swi-1 BFD/5/BFD_CHANGE_FSM: Sess[192.168.1.1/192.168.1.2, LD/RD:129/129, Interface:Vlan3, SessType:Ctrl, LinkType:INET], Ver:1, Sta: DOWN->INIT, Diag: 0 (No Diagnostic)
    %Nov  6 11:10:36:702 2018 swi-1 SHELL/5/SHELL_LOGOUT: Console logged out from con1.
    %Nov  6 11:10:37:457 2018 swi-1 BFD/5/BFD_MAD_INTERFACE_CHANGE_STATE: BFD MAD function enabled on Vlan-interface3 changed to the normal state.
    %Nov  6 11:10:37:857 2018 swi-1 BFD/5/BFD_CHANGE_FSM: Sess[192.168.1.1/192.168.1.2, LD/RD:129/129, Interface:Vlan3, SessType:Ctrl, LinkType:INET], Ver:1, Sta: INIT->UP, Diag: 0 (No Diagnostic)
    %Nov  6 11:10:37:898 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0/3 changed to down.
    %Nov  6 11:10:37:898 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/3 changed to down.
    %Nov  6 11:10:37:898 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Vlan-interface3 changed to down.
    %Nov  6 11:10:37:898 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Vlan-interface3 changed to down.
    %Nov  6 11:10:42:861 2018 swi-1 BFD/5/BFD_CHANGE_FSM: Sess[192.168.1.1/192.168.1.2, LD/RD:129/129, Interface:Vlan3, SessType:Ctrl, LinkType:INET], Ver:1, Sta: UP->DOWN, Diag: 1 (Control Detection Time Expired)
    %Nov  6 11:10:47:455 2018 swi-1 BFD/4/BFD_MAD_INTERFACE_CHANGE_STATE: BFD MAD function enabled on Vlan-interface3 changed to the faulty state.
    
    

    而查看1/0/3的配置是没有 shutdown的:

    [swi-1-if-range]display current-configuration interface GigabitEthernet 1/0/3
    #
    interface GigabitEthernet1/0/3
     port link-mode bridge
     port access vlan 3
     combo enable fiber
     undo stp enable
    #
    return
    [swi-1-if-range]dis
    [swi-1-if-range]display inter
    [swi-1-if-range]display interface gi
    [swi-1-if-range]display interface GigabitEthernet 1/0/3
    GigabitEthernet1/0/3
    Current state: DOWN
    Line protocol state: DOWN
    
    

    当irf 链路1/0/49和1/0/50恢复后,swi-1和swi-2 的两个IRF 会重新进行选举master,因为之前配置swi-1的优先级搞swi-1成为master,swi-2 成为Standby将自动重启后形成IRF拓扑,inter vlan 3 接口和g1/0/3 随即也会变为up。

    [swi-1-if-range]undo shutdown
    [swi-1-if-range]%Nov  6 11:17:26:972 2018 swi-1 STM/6/STM_LINK_UP: IRF port 2 came up.
    %Nov  6 11:17:26:972 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/49 changed to up.
    %Nov  6 11:17:26:973 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/49 changed to up.
    %Nov  6 11:17:26:976 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created on port Ten-GigabitEthernet1/0/49 (IfIndex 50), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet2/0/49.
    
    %Nov  6 11:17:26:981 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/50 changed to up.
    %Nov  6 11:17:26:981 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/50 changed to up.
    %Nov  6 11:17:26:985 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created on port Ten-GigabitEthernet1/0/50 (IfIndex 51), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet2/0/50.
    
    %Nov  6 11:17:27:196 2018 swi-1 STM/4/STM_MERGE: IRF merge occurred.
    quit
    [swi-1]%Nov  6 11:17:31:566 2018 swi-1 STM/3/STM_LINK_DOWN: IRF port 2 went down.
    %Nov  6 11:17:31:566 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/49 changed to down.
    %Nov  6 11:17:31:566 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/49 changed to down.
    %Nov  6 11:17:31:566 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/50 changed to down.
    %Nov  6 11:17:31:566 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/50 changed to down.
    %Nov  6 11:17:36:646 2018 swi-1 STM/6/STM_LINK_UP: IRF port 2 came up.
    %Nov  6 11:17:36:646 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/49 changed to up.
    %Nov  6 11:17:36:646 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/49 changed to up.
    %Nov  6 11:17:37:570 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet1/0/50 changed to up.
    %Nov  6 11:17:37:570 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet1/0/50 changed to up.
    %Nov  6 11:17:57:898 2018 swi-1 DEV/2/BOARD_STATE_FAULT: Board state changed to Fault on slot 2, type is unknown.
    %Nov  6 11:17:58:215 2018 swi-1 HA/5/HA_BATCHBACKUP_STARTED: Batch backup of standby board in slot 2 started.
    %Nov  6 11:17:59:056 2018 swi-1 DEV/5/BOARD_STATE_NORMAL: Board state changed to Normal on slot 2, type is H3C S5820V2-54Q.
    %Nov  6 11:18:01:762 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created on port Ten-GigabitEthernet1/0/49 (IfIndex 50), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet2/0/49.
    
    %Nov  6 11:18:01:762 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created on port Ten-GigabitEthernet1/0/50 (IfIndex 51), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet2/0/50.
    
    %Nov  6 11:18:01:688 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: -Slot=2; Nearest bridge agent neighbor created on port Ten-GigabitEthernet2/0/49 (IfIndex 178), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet1/0/49.
    
    %Nov  6 11:18:01:689 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: -Slot=2; Nearest bridge agent neighbor created on port Ten-GigabitEthernet2/0/50 (IfIndex 179), neighbor's chassis ID is 22ce-0ad0-0100, port ID is Ten-GigabitEthernet1/0/50.
    
    %Nov  6 11:18:01:765 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet2/0/49 changed to up.
    %Nov  6 11:18:01:766 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet2/0/49 changed to up.
    %Nov  6 11:18:01:766 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Ten-GigabitEthernet2/0/50 changed to up.
    %Nov  6 11:18:01:766 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Ten-GigabitEthernet2/0/50 changed to up.
    %Nov  6 11:18:02:449 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0/3 changed to up.
    %Nov  6 11:18:02:453 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/3 changed to up.
    %Nov  6 11:18:02:453 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface Vlan-interface3 changed to up.
    %Nov  6 11:18:02:453 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface Vlan-interface3 changed to up.
    %Nov  6 11:18:02:454 2018 swi-1 IFNET/3/PHY_UPDOWN: Physical state on the interface GigabitEthernet2/0/3 changed to up.
    %Nov  6 11:18:02:454 2018 swi-1 IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet2/0/3 changed to up.
    %Nov  6 11:18:02:470 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created on port GigabitEthernet1/0/3 (IfIndex 4), neighbor's chassis ID is 22ce-0ad0-0100, port ID is GigabitEthernet2/0/3.
    
    %Nov  6 11:18:02:443 2018 swi-1 LLDP/6/LLDP_CREATE_NEIGHBOR: -Slot=2; Nearest bridge agent neighbor created on port GigabitEthernet2/0/3 (IfIndex 132), neighbor's chassis ID is 22ce-0ad0-0100, port ID is GigabitEthernet1/0/3.
    
    

    LACP MAD检测

    1、创建一个动态聚合端口,并使能LACP MAD 检测功能。

    [swi-1]interface Bridge-Aggregation 2
    [swi-1-Bridge-Aggregation2]link-aggregation mode dynamic
    [swi-1-Bridge-Aggregation2]mad enable
    [swi-1-Bridge-Aggregation2]quit
    

    2、在聚合端口组中添加成员端口

    [swi-1]interface GigabitEthernet 1/0/2
    [swi-1-GigabitEthernet1/0/2]port link-aggregation group 2
    [swi-1-GigabitEthernet1/0/2]quit
    [swi-1]interface GigabitEthernet 2/0/2
    [swi-1-GigabitEthernet2/0/2]port link-aggregation group 2
    [swi-1-GigabitEthernet1/0/2]quit
    

    当配置到这的时候,你会发现2/0/2的为down

    3、中间设备配置

    创建动态聚合端口,并将与irf中各成员设备相连的线加入动态聚合端口组。

    [swi-4]interface Bridge-Aggregation 2
    [swi-4-Bridge-Aggregation2]link-aggregation mode dynamic
    [swi-4-Bridge-Aggregation2]quit
    
    [swi-4]interface range GigabitEthernet 1/0/1 to GigabitEthernet 1/0/2
    [swi-4-if-range]port link-aggregation group 2
    [swi-4-if-range]quit
    

    当配置到这的时候,你会发现2/0/2的为up了。

    4、检测效果

    当swi-1和swi-2 之间的 1/0/49和1/0/50 链路down了之后,IRF会发生分裂,产生两个IRF,两个IRF会通过LACP保温的扩展部分将本IRF的activeID传送到对端IRF,由于swi-1的activeID较小,因此该IRF将处于Active状态,设备swi-2所在的irf处于recovery状态。

    同时swi-2连接client的链路会转为down状态,是由MAD shutdown的。

    注意:

    当swi-1和swi-2 之间的 1/0/49和1/0/50 链路恢复之后,会重新选择master,那么swi-2 没有成为master 就会自动重启后成为standby,恢复IRF。

    三个MAD 检测对比

    MAD检测方式优势限制
    LACP MAD检测速度快,利用现有聚合组网即可实现,无需占用额外端口和接口组网中需要中间设备,并且该设备必须为支持LACP扩展功能的H3C交换机
    BFD MAD检测速度较快,组网形式灵活,对其他设备没有要求需要使用额外的端口和三层接口,这些端口和接口不能再传输普通业务流量
    ARP MAD对其他设备没有要求,在使用中间设备的组网中不需要占用额外端口检测速度慢于前两种,需要配置专用三层接口

    交换重新加入组的步骤

    按照“配置swi-2” 步骤部署即可。

    展开全文
  • irf

    2019-09-18 06:33:53
    IRF系统的性能和端口密度是IRF内部所有设备性能和端口数量的总和。因此,IRF技术能够轻易的将设备的交换能力、用户端口的密度扩大数倍,从而大幅度提高了设备的性能。 解释 编辑 IRF: interest rate forward ...

    弹性架构
    编辑
    是杭州华三通信技术有限公司(简称:H3C公司)融合高端交换机的技术,在中低端交换机上推出的创新性建设网络核心的新技术。它将帮助用户设计和实施高可用性、高可扩展性和高可靠性的千兆以太网核心和汇聚主干。
    在堆叠之前要先了解堆叠设备的规格,一个堆叠最多支持多少个设备,或者最多支持多少个端口。
    在堆叠之前要确定堆叠设备的版本,要保证所有堆叠设备的版本相同。在系统启动时、新Unit加入时、merge时都会进行配置比较。配置比较时将以最小ID的Unit的配置作为参照基准。比较结果不同的Unit将把基准配置保存为临时文件,然后重启。重启时将采用这个临时文件作为自己的配置。
    为增加堆叠的可靠性,尽量使用环形堆叠。
    堆叠/IRF设备的版本、配置必须相同。
    IRF设备堆叠端口相连时一定是UP端口和另一台设备的DOWN端口相连。
    IRF 是Intelligent Resilient Framework的简称,即智能弹性架构。在使用上,IRF和传统的三层堆叠技术有一点类似。简单来说,就是支持IRF的多台交换设备可以互相连接起来形成一个“联合设备”,我们将这台“联合设备”称为一个Fabric,而将组成Fabric的每个设备称为一个Unit。多个Unit组成Fabric后,无论在管理还是在使用上,就成为了一个整体。也就是说,用户可以将这多台设备看成一台单一设备进行管理和使用。这样既可以通过增加设备来扩展端口数量和交换能力,同时也通过多台设备之间的互相备份增强了设备的可靠性。
    使用IRF堆叠时候交换机无需启用STP。

    优点
    编辑
    简化管理 IRF架构形成之后,可以连接到任何一台设备的任何一个端口就以登录统一的逻辑设备,通过对单台设备的配置达到管理整个智能弹性系统以及系统内所有成员设备的效果,而不用物理连接到每台成员设备上分别对它们进行配置和管理。
    简化业务 IRF形成的逻辑设备中运行的各种控制协议也是作为单一设备统一运行的,例如路由协议会作为单一设备统一计算,而随着跨设备链路聚合技术的应用,可以替代原有的生成树协议,这样就可以省去了设备间大量协议报文的交互,简化了网络运行,缩短了网络动荡时的收敛时间。
    弹性扩展 可以按照用户需求实现弹性扩展,保证用户投资。并且新增的设备加入或离开IRF架构时可以实现“热插拔”,不影响其他设备的正常运行。
    高可靠 IRF的高可靠性体现在链路,设备和协议三个方面。成员设备之间物理端口支持聚合功能,IRF系统和上、下层设备之间的物理连接也支持聚合功能,这样通过多链路备份提高了链路的可靠性;IRF系统由多台成员设备组成,一旦Master设备故障,系统会迅速自动选举新的Master,以保证通过系统的业务不中断,从而实现了设备级的1:N备份;IRF系统会有实时的协议热备份功能负责将协议的配置信息备份到其他所有成员设备,从而实现1:N的协议可靠性。
    高性能 对于高端交换机来说,性能和端口密度的提升会受到硬件结构的限制。而IRF系统的性能和端口密度是IRF内部所有设备性能和端口数量的总和。因此,IRF技术能够轻易的将设备的交换能力、用户端口的密度扩大数倍,从而大幅度提高了设备的性能。

    解释
    编辑
    IRF: interest rate forward 利率期货合约
    利率期货合约是指由交易双方订立的,约定在未来某日以成交时约定的价格交收一定数量的某种利率相关商品(即各种债务凭证)的标准化契约。利率期货合约由交易所设计推出,投资者须照标准合约进行交易。

    函数
    编辑
    IRF脉冲响应函数
    Impulse Response Function 在信号与系统学科中,冲激响应(或叫脉冲响应)一般是指系统在输入为单位冲激函数时的输出(响应)。对于连续时间系统来说,冲激响应一般用函数h(t)来表示。对于无随机噪声的确定性线性系统,当输入信号为一脉冲函数 δ(t) 时,系统的输出响应 h(t)称为脉冲响应函数。

    道路联盟
    编辑
    International Road Federation 国际道路联盟(IRF)成立于1948年,是一个非政府非赢利性的国际组织,共有70余个国家的政府和私营会员。IRF在华盛顿、日内瓦和布鲁塞尔设有三个项目中心,在国际道路交通基础设施发展中起到了积极的推动作用。国际路联的宗旨就是鼓励与推动建设和养护更加实用、安全的道路及道路网络。国际路联作为一个对公路建设和融资感兴趣的国际组织,在世界道路建设和发展的各个方面都有广泛的参与。它所支持的许多国际道路项目都致力于推动跨境道路基础设施的改进,以此促进经贸的发展和地区融合。国际路联在中国和欧洲的道路基础设施项目就是要复兴连接欧洲和远东地区洲际公路的基础设施,帮助复苏中亚经济。

    整流器
    编辑
    international rectifier 整流器是把交流电转换成直流电的装置,可用于供电装置及侦测无线电信号等。整流器可以真空管,引燃管,固态矽半导体二极管,汞弧等制成。相反,一套把直流电转换成交流电的装置,则称为“逆变器” (inverter)。

    调节因子
    编辑
    干扰素调节因子
    Interferon regulatory factors ,IRFs,干扰素调节因子(IRFs)是调节干扰素(IFN)、干扰素刺激性应答基因(ISG)及其它相关基因表达的重要转录因子,通过调节IFN、ISG和其它密切相关基因表达而发挥多种生物学效应。(免疫学)

    展开全文
  • IRF_project:IRF项目-源码

    2021-03-15 09:18:43
    IRF_project:IRF项目
  • IRF智能弹性构架-IRF2.0技术白皮书.pdf
  • IRF智能弹性构架-IRF2.0技术介绍.pdf
  • 迭代随机森林(iRF) R包iRF实现了迭代随机森林,这是一种迭代增长加权决策树的集合,并通过分析决策路径上特征的使用来检测高阶特征交互的方法。 此版本使用Andy Liaw和Matthew Weiner的R包randomForest的源代码...
  • IRF6708S2和IRF6728M DirectFET MOSFET芯片组.pdf
  • IRF配置.txt

    2019-06-10 15:32:24
    irf-port 1/2 进入IRF视图组-----------------irf port1/2 1/2后边的2不能与下边2/1后边1数字一样否则无法激活 port group int Te 1/1/1 将物理端口绑定到IRF端口 port group int Te 1/1/2 将物理端口绑定到IRF端口 ...
  • IRF配置

    2021-03-20 15:58:48
    IRF配置 华三堆叠配置
    #SW1
    <Sysname> system-view
    [Sysname] irf member 1 priority 20		#默认irf优先级1
    [Sysname] interface range ten-gigabitethernet 1/0/51 to ten-gigabitethernet 1/0/52
    [Sysname-if-range] shutdown
    [Sysname-if-range] quit
    
    [Sysname] irf-port 1/2
    [Sysname-irf-port1/2] port group interface ten-gigabitethernet 1/0/51
    [Sysname-irf-port1/2] port group interface ten-gigabitethernet 1/0/52
    [Sysname-irf-port1/2] quit
    [Sysname] save
    
    [Sysname] interface range ten-gigabitethernet 1/0/51 to ten-gigabitethernet 1/0/52
    [Sysname-if-range] undo shutdown
    [Sysname-if-range] quit
    
    [Sysname] irf-port-configuration active
    
    #SW2
    <Sysname> system-view
    [Sysname] irf member 1 renumber 2
    [Sysname] quit
    <Sysname> reboot
    
    [Sysname] interface range ten-gigabitethernet 2/0/51 to ten-gigabitethernet 2/0/52
    [Sysname-if-range] shutdown
    [Sysname-if-range] quit
    
    [Sysname] irf-port 2/1
    [Sysname-irf-port2/1] port group interface ten-gigabitethernet 2/0/51
    [Sysname-irf-port2/1] port group interface ten-gigabitethernet 2/0/52
    [Sysname-irf-port2/1] quit
    [Sysname] save
    
    [Sysname] interface range ten-gigabitethernet 2/0/51 to ten-gigabitethernet 2/0/52
    [Sysname-if-range] undo shutdown
    [Sysname-if-range] quit
    
    [Sysname] irf-port-configuration active
    

    华为istack见https://blog.csdn.net/a371933136/article/details/111772828

    展开全文
  • IRF 实验

    2021-06-29 19:50:23
    实验拓扑 注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中...分析:根据需求,交换机 IRF 设备 ID 与设备编号一致,所以需要修改 SW2,SW3,SW4 的 IRF 设备 ID,并保存配置后,重启生效后才可进行后续配置 步骤 1

    IRF(堆叠)

    定义:

    • 智能弹性架构
    • H3C的堆叠技术
    • 通过把多台交换机虚拟成一台逻辑设备来提高1可靠性和性能

    优势:

    • 大幅度简化配置管理
    • 整体提高设备性能
    • 设备拓展便捷
    • 大幅度提高设备可靠性

    Master设备选举规则:

    • 优先级大的优先,默认优先级为1
    • 系统运行时间长的优先
    • MAC地址小的优先

    IRF形成必要条件:

    • 堆叠口中的物理接口必须是万兆以上接口
    • 一台设备上最多有两个堆叠
    • 一台设备的1号堆叠口必须连接到另一台设备的2号堆叠口

    Ethernet0/0 10M
    FastEthernet0/1 100M
    GigabitEthernet0/0 1000M
    Ten-GigabitEthernet0/0 10000M
    Forty-GigabitEthernet0/0 40000M

    配置步骤:

    1. 更改设备编号
    2. 保存配置,手动重启更改了设备ID的交换机
    3. 手动shutdown要加入到堆叠口中的物理口
    4. 创建虚拟堆叠口,并加入相应的物理口
    5. 手动开启物理口
    6. 保存配置
    7. 激活IRF配置

    注:步骤不能出差错,否则IRF会起不来

    实验拓扑

    在这里插入图片描述

    注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中设备名称末尾数字为 1 的设备,R2 或 SW2 对应拓扑中设备名称末尾数字为 2
    的设备,以此类推;此拓扑请严格按照图示接口连接线缆

    实验需求

    1. SW1,SW2,SW3,SW4 组成一台 IRF 堆叠设备
    2. 交换机 IRF 设备 ID 与设备编号一致

    注意!堆叠接口必须使用万兆以上接口。连线需要使用4万M线!!!

    实验解法

    分析:根据需求,交换机 IRF 设备 ID 与设备编号一致,所以需要修改 SW2,SW3,SW4 的 IRF 设备 ID,并保存配置后,重启生效后才可进行后续配置

    步骤 1:修改 SW2 的 IRF 设备 ID 为 2,保存配置,并重启生效

    [SW2]irf member 1 renumber 2
    [SW2]save
    [SW2]reboot
    

    步骤 2:SW3 和 SW4 修改 IRF 设备 ID 方法与 SW2 一致,重启后,通过命令 display irf 确认设备 ID 已修改
    步骤 3:在 SW1 上手动关闭堆叠物理口 F1/0/53 和 F1/0/54 口

    ### 我们把端口加入逻缉堆叠口时要,手动关闭接口,物理关闭没用
    [H3C-irf-port1/1]int f 1/0/53
    [H3C-FortyGigE1/0/53]shutdown
    [H3C-FortyGigE1/0/53]int f1/0/54
    [H3C-FortyGigE1/0/54]shutdown
    

    步骤 4:在 SW1 上创建堆叠口 IRF-PORT1/1,并加入物理口 F1/0/53和物理口 F1/0/54

    ### 创建逻缉堆叠口
    [H3C]irf-port 1/1
    ### 加入逻缉堆叠口
    [H3C-irf-port1/1]port group interface FortyGigE 1/0/53
    [H3C-irf-port1/1]port group interface FortyGigE 1/0/54
    

    步骤 5:在 SW1 上手动开启之前关闭的堆叠物理口 F1/0/53 和 F1/0/54

    ### 创建逻缉堆叠口
    /* 因为模拟器有BUG,创建逻缉堆叠口2/1会导致IRF起不来,真实设备没问题 */
    [H3C]irf-port 2/2
    [H3C]int ran f 1/0/53 to f1/0/54
    [H3C-if-range]undo shutdown
    

    步骤 6:在 SW1 上保存配置并激活 IRF 配置

    ### 激活irf配置前要先保存配置,因为一但激活配置,双方就会开始选举,选举失败后会自动重启
    [H3C]save
    [H3C]irf-port-configuration active
    

    步骤 8:SW2,SW3 和 SW4 配置方法与 SW1 一致,配置时注意设备 ID 已变更
    例SW2

    [H3C]irf member 1 renumber 2
    [H3C]int ran f2/0/53 to f2/0/54
    [H3C-if-range]shutdown
    [H3C-if-range]quit
    [H3C]irf
    [H3C]irf-port 2/2
    [H3C-irf-port2/2]port group interface f2/0/53
    [H3C-irf-port2/2]port group interface f2/0/54
    [H3C-irf-port2/2]quit
    [H3C]int ran f2/0/53 to f2/0/54
    [H3C-if-range]undo sh
    [H3C-if-range]undo shutdown
    [H3C-if-range]quit
    [H3C]save
    [H3C]quit
    <H3C>reboot
    

    步骤 9:SW2,SW3 和 SW4 配置完成后,所有交换机会自动选举 Master 设备,选举失败的设备会自动重启,重启完成后堆叠建立完成,所有 Slave 设备的配置会与 Master 设备同步

    <H3C>disp irf   ### 查看irf配置
    MemberID    Role    Priority  CPU-Mac         Description
     *+1        Master  1         a654-b0d4-0104  ---			* 表示master  + 表示当前设备
       2        Standby 1         a654-ba31-0204  ---
    --------------------------------------------------
     * indicates the device is the master.
     + indicates the device through which the user logs in.
    
     The bridge MAC of the IRF is: a654-b0d4-0100
     Auto upgrade                : yes
     Mac persistent              : 6 min
     Domain ID                   : 0
    
    展开全文
  • 1、IRF2技术原理与应用实践 2、IRF2.0技术白皮书介绍.pdf 3、IRF2.0技术白皮书介绍.pdf
  • IRF830pdf资料

    2017-09-21 09:14:47
    IRF830系列资料,包括IRF830,IRF830A、IRF830F、IRF830AS-AL等的封装,参数等。是大家选择的不二选择。希望对大家有帮助
  • IRF技术介绍

    2014-12-21 18:15:05
    IRF堆叠技术交流,IRF技术介绍2.0版本
  • IRF系列(四):基于IRF2的网络安全设计思路.pdf
  • irf配置

    2020-05-28 11:10:18
    在S1上创建设备irf端口2,与物理端口xg1/0/49绑定,并保存配置 [S2]int Ten-GigabitEthernet 1/0/49 [S2-Ten-GigabitEthernet1/0/49]shutdown [S2]irf-port 1/2 [S2-irf-port1/2]port group interface Ten-...
  • IRF1405说明书

    2018-04-13 08:01:19
    IRF1405的说明书
  • IRF3.1

    2019-01-30 10:43:25
    IRF3.1技术 简介 IRF3.1是一种网络设备纵向虚拟化技术。通过将多台PEX设备虚拟为父设备的远程业务板,使所有接入层或汇聚层设备虚拟化为一台设备,从而以较低的成本提高父设备的接口密度,同时可以简化网络拓扑,...
  • IRF_Project-源码

    2021-02-25 02:03:11
    IRF_Project
  • irf540技术手册

    2018-04-30 23:55:06
    irf540n的生产厂家是SANYO 、IR、VISHAY,封装类型为TO-220AB。  IRF540N、场效应管,VDss=100V、ID=33A、单片机不能直接驱动,因为IRF540N的VGS=20V,即驱动电压应在20V左右,单片机输出的驱动电压一般在5V以下,...
  • irf540中文手册

    2018-11-17 11:58:02
    从官网那翻译过来的。数据没有改过。没有缺页。irf540中文手册。
  • IRF系列高压MOS管

    2019-04-25 15:24:20
    IRF系列高压MOS管,高压MOS管----IRF系列包括大部分mos的耐压耐流和功率
  • IRF技术

    2019-07-01 14:10:00
    IRF虚拟化技术的英文简称,是当前企业IT技术领域的关注焦点,采用虚拟化来优化IT架构,提升IT系统运行效率是当前技术发展的方向。 对于基础网络来说,在一套物理网络上采用VLAN或VRF技术划分出多个相互隔离的逻辑...
  • IRF2技术.zip

    2020-04-16 09:03:14
    堆叠技术,IRF2,介绍文档,为小白开创先河,
  • irf命令参考

    2014-08-21 19:27:05
    华三irf的配置详细步骤,学习堆叠,欢迎下载
  • IRF 配置

    2017-05-26 23:33:47
    IRF配置思路[s1]irf member 1 renumber 1Ten-GigabitEthernet1/0/49Ten-GigabitEthernet1/0/50将两个接口down掉irf-port 1/2port group interface Ten-GigabitEthernet1/0/49port group interface Ten-GigabitEth...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,274
精华内容 909
关键字:

irf