精华内容
下载资源
问答
  • 一步安装 docker-cedocker-compose 的脚本,功能如下: 1、卸载旧版本 2、安装需要的依赖软件包 3、设置 yum 源,使用清华镜像仓库,速度很快 4、安装 docker-ce 5、安装docker-compose,从国内镜像 get....
  • docker-ce-18.06.1.zip

    2019-10-14 17:14:33
    docker-ce-18.06.1离线安装包及安装脚本适用于CentOS7.5
  • docker-ce-19.03.4 linux64位

    2019-10-30 14:40:44
    docker-ce-19.03.4 linux64位 二进制安装包
  • 这里准备了一份docker-ce-v18的离线包供下载。 也可以自己手动下载最新包,下载方法如下: mkdir /apps/docker-ce-v18 yum install --downloadonly --downloaddir=/apps/docker-ce-v18 \ yum-utils device-...
  • 安装docker,sudo dpkg -i docker-ce_17.03.2~ce-0~ubuntu-xenial_amd64.deb所使用的文件
  • docker-ce-17.03.0.rar

    2020-03-26 23:06:57
    docker-ce-17.03.0 rpm安装包额外附国内镜像地址,可下载所有版本docker的rpm安装包
  • docker-io, docker-ce, docker-ee 区别

    万次阅读 2019-05-16 12:58:15
    docker-ce 是社区版本,适用于刚刚开始docker 和开发基于docker研发的应用开发者或者小型团队。Ubuntu默认安装的是docker-ce, 版本号是 17.* ,最新版是 17.12。以下是官方描述: Docker Community Edition ...
    • docker-io, docker-engin 是以前早期的版本,版本号是 1.*,默认centos7 安装的是docker-io,最新版是 1.13。
    • docker-ce 是社区版本,适用于刚刚开始docker 和开发基于docker研发的应用开发者或者小型团队。Ubuntu默认安装的是docker-ce,以下是官方描述:

    Docker Community Edition (CE) is ideal for developers and small teams looking to get started with Docker and experimenting with container-based apps. Docker CE has three types of update channels, stable, test, and nightly:

    • Stable gives you latest releases for general availability.
    • Test gives pre-releases that are ready for testing before general availability.
    • Nightly gives you latest builds of work in progress for the next major release.
      For more information about Docker CE, see Docker Community Edition.
    • docker-eedocker的企业版,适用于企业级开发,同样也适用于开发、分发和运行商务级别的应用的IT 团队。

    Docker Enterprise is designed for enterprise development as well as IT teams who build, ship, and run business-critical applications in production and at scale. Docker Enterprise is integrated, certified, and supported to provide enterprises with the most secure container platform in the industry. For more info about Docker Enterprise, including purchasing options, see Docker Enterprise.

    ps: docker-ce 和docker-ee 的可用版本是根据year-month 来的

    参考:

    展开全文
  • 运行 :$ sudo yum install docker-ce docker-ce-cli containerd.io 之后出现 错误: 问题: package docker-ce-3:19.03.11-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be...

    安装DOCKER引擎

    具体安装步骤不会的可以参考菜鸟教程哦,写的比较详细;

    安装最新版本的Docker Engine和容器,或者转到下一步安装特定版本:

    运行 :$ sudo yum install docker-ce docker-ce-cli containerd.io
    

    之后出现

    错误:
     问题: package docker-ce-3:19.03.11-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
      - cannot install the best candidate for the job
      - package containerd.io-1.2.10-3.2.el7.x86_64 is excluded
      - package containerd.io-1.2.13-3.1.el7.x86_64 is excluded
      - package containerd.io-1.2.13-3.2.el7.x86_64 is excluded
      - package containerd.io-1.2.2-3.3.el7.x86_64 is excluded
      - package containerd.io-1.2.2-3.el7.x86_64 is excluded
      - package containerd.io-1.2.4-3.1.el7.x86_64 is excluded
      - package containerd.io-1.2.5-3.1.el7.x86_64 is excluded
      - package containerd.io-1.2.6-3.3.el7.x86_64 is excluded
    (尝试添加 '--skip-broken' 来跳过无法安装的软件包 或 '--nobest' 来不只使用最佳选择的软件包)
    

    解决方案:
    进入阿里云镜像地址:https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/
    找到你想要的或者最新的containerd.io包,拼接在阿里云地址后面,
    例如:

    yum install -y https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.13-3.1.el7.x86_64.rpm
    

    然后再次执行:

    yum install docker-ce docker-ce-cli containerd.io
    

    便可完成安装!
    补充:如果再遇到:

    file /usr/share/man/man1/docker-attach.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
      file /usr/share/man/man1/docker-build.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
      file /usr/share/man/man1/docker-commit.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
      file /usr/share/man/man1/docker-container-prune.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
      file /usr/share/man/man1/docker-container.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
      file /usr/share/man/man1/docker-cp.1.gz from install of docker-ce-cli-1:19.03.11-3.el7.x86_64 conflicts with file from package podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
    

    运行:

    yum remove podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
    

    会显示:

    [root@localhost qyx]# yum remove podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch
    模块依赖问题
    
     问题 1: conflicting requests
      - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020191114033549:073fa5fe-0.x86_64
     问题 2: conflicting requests
      - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020191113222731:16b3ab4d-0.x86_64
    依赖关系解决。
    =============================================================================================================
     软件包               架构       版本                                                   仓库            大小
    =============================================================================================================
    移除:
     podman-manpages      noarch     1.4.2-5.module_el8.1.0+237+63e26edc                    @AppStream     134 k
    移除依赖的软件包:
     cockpit-podman       noarch     4-1.module_el8.1.0+237+63e26edc                        @AppStream     5.1 M
    清除未被使用的依赖关系:
     libvarlink           x86_64     18-3.el8                                               @anaconda      129 k
     oci-systemd-hook     x86_64     1:0.1.15-2.git2d0b8a3.module_el8.1.0+237+63e26edc      @AppStream      74 k
     podman               x86_64     1.4.2-5.module_el8.1.0+237+63e26edc                    @AppStream      51 M
    
    事务概要
    =============================================================================================================
    移除  5 软件包
    
    将会释放空间:56 M
    确定吗?[y/N]: y
    运行事务检查
    事务检查成功。
    运行事务测试
    事务测试成功。
    运行事务
      准备中  :                                                                                              1/1 
      运行脚本: cockpit-podman-4-1.module_el8.1.0+237+63e26edc.noarch                                        1/1 
      删除    : cockpit-podman-4-1.module_el8.1.0+237+63e26edc.noarch                                        1/5 
      删除    : podman-1.4.2-5.module_el8.1.0+237+63e26edc.x86_64                                            2/5 
      运行脚本: podman-1.4.2-5.module_el8.1.0+237+63e26edc.x86_64                                            2/5 
      删除    : podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch                                   3/5 
      删除    : oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module_el8.1.0+237+63e26edc.x86_64                    4/5 
      删除    : libvarlink-18-3.el8.x86_64                                                                   5/5 
      运行脚本: libvarlink-18-3.el8.x86_64                                                                   5/5 
      验证    : cockpit-podman-4-1.module_el8.1.0+237+63e26edc.noarch                                        1/5 
      验证    : libvarlink-18-3.el8.x86_64                                                                   2/5 
      验证    : oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module_el8.1.0+237+63e26edc.x86_64                    3/5 
      验证    : podman-1.4.2-5.module_el8.1.0+237+63e26edc.x86_64                                            4/5 
      验证    : podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch                                   5/5 
    
    已移除:
      podman-manpages-1.4.2-5.module_el8.1.0+237+63e26edc.noarch                                                 
      cockpit-podman-4-1.module_el8.1.0+237+63e26edc.noarch                                                      
      libvarlink-18-3.el8.x86_64                                                                                 
      oci-systemd-hook-1:0.1.15-2.git2d0b8a3.module_el8.1.0+237+63e26edc.x86_64                                  
      podman-1.4.2-5.module_el8.1.0+237+63e26edc.x86_64                                                          
    
    完毕!
    
    

    重复执行:

    sudo yum install docker-ce docker-ce-cli containerd.io
    

    安装完成。踩坑一晚上,觉得有帮助就点个赞吧。

    展开全文
  • ansible-role-docker-ce:在CentOSFedoraRHEL(Redhat)UbuntuDebianMintRaspbian上安装Docker CE的角色
  • docker-io, docker-ce, docker-ee的 区别

    千次阅读 2019-11-06 18:19:28
    docker-io, docker-engin 是...docker-ce 是社区版本,适用于刚刚开始docker 和开发基于docker研发的应用开发者或者小型团队。Ubuntu默认安装的是docker-ce,以下是官方描述: Docker Community Edition (CE) is ide...

    docker-io, docker-engin 是以前早期的版本,版本号是 1.*,默认centos7 安装的是docker-io,最新版是 1.13。
    docker-ce 是社区版本,适用于刚刚开始docker 和开发基于docker研发的应用开发者或者小型团队。Ubuntu默认安装的是docker-ce,以下是官方描述:
    Docker Community Edition (CE) is ideal for developers and small teams looking to get started with Docker and experimenting with container-based apps. Docker CE has three types of update channels, stable, test, and nightly:

    Stable gives you latest releases for general availability.
    Test gives pre-releases that are ready for testing before general availability.
    Nightly gives you latest builds of work in progress for the next major release.
    For more information about Docker CE, see Docker Community Edition.
    docker-ee 是docker的企业版,适用于企业级开发,同样也适用于开发、分发和运行商务级别的应用的IT 团队。
    Docker Enterprise is designed for enterprise development as well as IT teams who build, ship, and run business-critical applications in production and at scale. Docker Enterprise is integrated, certified, and supported to provide enterprises with the most secure container platform in the industry. For more info about Docker Enterprise, including purchasing options, see Docker Enterprise.

    ps: docker-ce 和docker-ee 的可用版本是根据year-month 来的

    文章为转载文
    原文链接:https://blog.csdn.net/zsy_1991/article/details/90261419

    展开全文
  • docker-ce-17.03.2.ce-1.el7.centos.x86_64.rpm docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch.rpm
  • 本文介绍了ubuntu17.10安装docker-ce的方法,分享给大家,具体如下: 系统要求:centos 7 64位,centos-extras存储库必须启用。 卸载旧版Docker 查询当前的Docker版本 $ docker -v 如果存在已安装的Docker,卸载 ...
  • docker-ce.repo

    2019-08-06 19:20:14
    docker-ce.repo 一个小插件 搭建python3网络爬虫 docker-ce.repo
  • 包含docker-ce-17.12.1.ce-1.el7.centos.x86_64.rpm和docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch.rpm 依次执行: yum localinstall docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch.rpm -y yum local...
  • ubuntu 16.04 docker 离线安装包 docker-ce_18.03.1 上传到服务器,执行安装命令 # sudo dpkg -i libltdl7_2.4.6-0.1_amd64.deb # sudo dpkg -i libseccomp2...# sudo dpkg -i docker-ce_18.03.1~ce-0~ubuntu_amd64.deb
  • 离线环境下,在centos7.6系统上安装docker-ce-19.03,nvidia-docker2.4版本,其中docker-ce-19.03在docker-local.tar压缩文件里面,nvidia-docker2在nvidia-docker2.zip文件中,希望对你有帮助。
  • 报错 [root@server1 ~]# yum install -y docker-ce 已加载插件:fastestmirror, langpacks base | 3.6 kB 00:00:00 docker-ce-stable | 3.5 kB 00:00:0

    报错

    [root@server1 ~]# yum install -y docker-ce
    已加载插件:fastestmirror, langpacks
    base                                                                 | 3.6 kB  00:00:00     
    docker-ce-stable                                                     | 3.5 kB  00:00:00     
    (1/2): docker-ce-stable/7/x86_64/updateinfo                          |   55 B  00:00:01     
    (2/2): docker-ce-stable/7/x86_64/primary_db                          |  58 kB  00:00:07     
    Determining fastest mirrors
     * base: 
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 docker-ce.x86_64.3.20.10.5-3.el7 将被 安装
    --> 正在处理依赖关系 container-selinux >= 2:2.74,它被软件包 3:docker-ce-20.10.5-3.el7.x86_64 需要
    --> 正在处理依赖关系 containerd.io >= 1.4.1,它被软件包 3:docker-ce-20.10.5-3.el7.x86_64 需要
    --> 正在处理依赖关系 docker-ce-cli,它被软件包 3:docker-ce-20.10.5-3.el7.x86_64 需要
    --> 正在处理依赖关系 docker-ce-rootless-extras,它被软件包 3:docker-ce-20.10.5-3.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 containerd.io.x86_64.0.1.4.4-3.1.el7 将被 安装
    --> 正在处理依赖关系 container-selinux >= 2:2.74,它被软件包 containerd.io-1.4.4-3.1.el7.x86_64 需要
    ---> 软件包 docker-ce.x86_64.3.20.10.5-3.el7 将被 安装
    --> 正在处理依赖关系 container-selinux >= 2:2.74,它被软件包 3:docker-ce-20.10.5-3.el7.x86_64 需要
    ---> 软件包 docker-ce-cli.x86_64.1.20.10.5-3.el7 将被 安装
    ---> 软件包 docker-ce-rootless-extras.x86_64.0.20.10.5-3.el7 将被 安装
    --> 正在处理依赖关系 fuse-overlayfs >= 0.7,它被软件包 docker-ce-rootless-extras-20.10.5-3.el7.x86_64 需要
    --> 正在处理依赖关系 slirp4netns >= 0.4,它被软件包 docker-ce-rootless-extras-20.10.5-3.el7.x86_64 需要
    --> 解决依赖关系完成
    错误:软件包:docker-ce-rootless-extras-20.10.5-3.el7.x86_64 (docker-ce-stable)
              需要:slirp4netns >= 0.4
    错误:软件包:3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stable)
              需要:container-selinux >= 2:2.74
    错误:软件包:containerd.io-1.4.4-3.1.el7.x86_64 (docker-ce-stable)
              需要:container-selinux >= 2:2.74
    错误:软件包:docker-ce-rootless-extras-20.10.5-3.el7.x86_64 (docker-ce-stable)
              需要:fuse-overlayfs >= 0.7
     您可以尝试添加 --skip-broken 选项来解决该问题
     您可以尝试执行:rpm -Va --nofiles --nodigest

    解决方法

    yum clean all
    yum makecache
    展开全文
  • docker-ceDOCKER ENGINE - COMMUNITY 卸载旧版本 目前我没遇到,但是还是卸载一下比较好 sudo apt-get remove docker docker-engine docker.io containerd runc 更新现有的包列表 sudo apt-get update 安装...
  • @[TOC](安装docker-ce报错——Error: Package:docker-ce-rootless-extras-20.10.3-3.el7.x86_64 (docker-ce-stable)) 一、情况说明: 在安装docker-ce遇到container-selinux的情况 二、故障原因: 根据这个报错可以...
  • 产生问题的安装步骤 sudo yum-config-manager -y --add-repohttps://download.docker.... sudo yum install -y docker-ce-17.03.1.ce-1.el7.centos 异常信息 Loaded plugins: fastestmirror,...
  • centos7 安装docker-ce docker-compose

    千次阅读 2019-09-24 17:31:50
    centos7 安装docker-ce docker-compose安装依赖更换repo安装docker-ce验证docker安装docker-compose 安装依赖 yum install -y yum-utils device-mapper-persistent-data lvm2 更换repo yum-config-manager --add-...
  • centos7.5下的docker-ce-18.06.1离线安装包及安装脚本
  • CentOS下的docker-ce 18.06.1。docker-18.06.1-ce.tgz
  • 首先来说一下 docker 版本的选择问题,可以看一下下面这段引言,就能知道一个大概的选择了。...Ubuntu默认安装的是docker-ce ,docker-ce 是社区版本,适用于刚刚开始docker 和开发基于docker研发的应用开发者或者小...
  • 包含docker-ce-18.02.0.ce-1.el7.centos.x86_64.rpm和docker-ce-selinux-17.05.0.ce-1.el7.centos.noarch.rpm 依次执行: yum localinstall docker-ce-selinux-17.05.0.ce-1.el7.centos.noarch.rpm -y yum local...
  • docker-ce-18.09.9 linux64位 二进制安装包
  • docker依赖包docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch.rpm
  • CentOS7 x86_64 docker-ce-18.06.0.ce-3.el7.x86_64.rpm 安装: yum -y install docker-ce-18.06.0.ce-3.el7.x86_64.rpm
  • Error: Package: 3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stable) Requires: container-selinux >= 2:2.74 二、解决思路 Error: Package: 3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stab
  • docker-ce-selinux-17.05.0.ce-1.el7.centos.noarch.rpm离线安装包。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 70,352
精华内容 28,140
关键字:

docker-ce