精华内容
下载资源
问答
  • windows10下cuda10.0+pytorch安装 win10查看cuda当前版本 控制面板找到NVDIA控制面板窗口左下角系统信息选择组件选项,查看文件名为NVCUDA.DLL的产品名称CUDA后面跟的就是版本。(我8.0.0) 下载CUDA10.0 (查看...

    windows10下cuda10.0+pytorch安装

    win10查看cuda当前版本

    • 控制面板找到NVDIA控制面板
    • 窗口左下角系统信息
    • 选择组件选项,查看文件名为NVCUDA.DLL的产品名称CUDA后面跟的就是版本。(我8.0.0)
      在这里插入图片描述

    下载CUDA10.0

    (查看CUDA Toolkit历史版本官方链接:https://developer.nvidia.com/cuda-toolkit-archive )

    选择系统对应的版本 https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Windows&target_arch=x86_64&target_version=10&target_type=exelocal

    环境变量设置

    环境变量-系统变量中

    新加了CUDA_PATH和CUDA_PATHV10_0

    再添加:

    CUDA_BIN_PATH  %CUDA_PATH%\bin
    CUDA_LIB_PATH  %CUDA_PATH%\lib\x64
    CUDA_SDK_BIN_PATH  %CUDA_SDK_PATH%\bin\win64
    CUDA_SDK_LIB_PATH  %CUDA_SDK_PATH%\common\lib\x64
    CUDA_SDK_PATH  C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0

    输入 nvcc -V 显示驱动版本信息。

    安装指定版本pytorch

    看pytorch官网: https://pytorch.org/get-started/locally

    哦豁发现官网中当前支持的cuda版本10.1,千辛万苦下的10.0,担心版本不匹配直接在线可能下完也GG。

    来到网页 https://download.pytorch.org/whl/torch_stable.html

    找寻自己适合的版本下载至本地:我选择 cu100/torch-1.0.1-cp36-cp36m-win_amd64.whl

    (显然:cu后面是cuda版本10.0/torch版本-python版本-电脑系统版本)

    【emmmmmm但是这个下载时间还是太长了点,吃完饭睡个觉醒过来 就下完了】

    pip直接安装:

    cmd到下载目录下:pip install XXX.whl

    安装后python环境里输入:import torch查看

    但是因为安装完import pytorch报错DLL,网上搜索发现要更换python版本。emmmm然而我电脑只安装了一个python版本我不想删,然后躲不开的又来到了anaconda。

    anaconda安装:

    anaconda安装参考 https://blog.csdn.net/ITLearnHall/article/details/81708148

    下载地址使用清华源,有梯子也不建议用官网慢哭了:https://mirrors.tuna.tsinghua.edu.cn/anaconda/archive/?C=M&O=D

    HTTPError坑解决见: https://blog.csdn.net/Insylol/article/details/88798061

    一些anaconda常见命令:
    #会列出当前安装的所有pyhon环境
    conda info -e   
    #创建并激活一个环境
    conda create --name [environ name] python=[版本号]  
    # 激活环境
    activate [environ name] 
    # 查看当前python版本
    python -V  
    # 退出
    deactivate 
    
      

      进入anaconda py3.6.X的环境里:再次cd到pytorch的.whl安装目录,pip install。根据提示升级相关内容。

      最后测试成功
      在这里插入图片描述

      PS:注意cu100/torch-1.0.1-cp36-cp36m-win_amd64.whl中36代表你安装的python版本

      转载自:https://blog.csdn.net/qq_40307434/article/details/104330367

      展开全文
    • Windows10 + cuda10.0 + pytorch1.2.0 + torchvision0.4.0环境配置 先附上我使用的文件的百度链接,后续也有下载路径,可以根据自己的需要下载 链接:https://pan.baidu.com/s/1vy7NwfL25_uFvFNpWj19Ig 提取码:fa68...

      Windows10 + cuda10.0 + pytorch1.2.0 + torchvision0.4.0环境配置

      先附上我使用的文件的百度链接,后续也有下载路径,可以根据自己的需要下载
      链接:https://pan.baidu.com/s/1vy7NwfL25_uFvFNpWj19Ig
      提取码:fa68
      要安装pytorch,首先要配置好python环境,个人建议使用anaconda安装,首先到官网上下载anaconda。
      在这里插入图片描述

      大概长这样,然后双击运行,一路的next和agree就可以了,最后一步请看图,
      在这里插入图片描述

      一定要勾上这个勾,虽然他官方不建议,但是其实这个的目的只是为了自动配置环境变量,要是不勾的话就自己配置就可以了,否则是没法用的,所以还是老老实实勾上吧。
      安装完之后打开终端,就电脑左下角输入cmd打开就可以,然后在终端中输入python
      在这里插入图片描述

      如图输入python后会看的安装的版本时间等信息,那么就恭喜你安装完了,然后就可以按照pytorch了。
      简单说一下pytorch的环境配置,这里以pytorch1.2.0为例,可以按照这个方法安装任何版本。
      首先先要下载cuda和cudnn,先看cuda,附上网址:
      https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Windows&target_arch=x86_64&target_version=10&target_type=exelocal
      在这里插入图片描述

      如图可以选择自己需要的cuda版本,我选的是cuda10.0,然后再下载cudnn,附网址:
      https://developer.nvidia.com/cudnn
      在这里插入图片描述

      如图点击download,进去之后需要注册登录一下,不过可以微信或者qq登录,还挺人性化,登录之后可以看见这些
      在这里插入图片描述

      如果需要更多的版本,可以点击Archived cuDNN Releases,然后就能看见这样一翻景象,
      在这里插入图片描述

      选择自己想要的,后面写的很清楚是,一定要选适合自己的cuda版本的,我选的是7.4.1,然后就可以进行安装了。
      双击cuda的安装包,
      在这里插入图片描述

      最好是不要更改这个地址,直接点击ok
      在这里插入图片描述

      然后就同意并继续,这里选择自定义,然后一直下一步安装即可,安装好cuda后,将cudnn的压缩包解压,找到这个路径C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0,可以看到很多的文件夹,找到cudnn中同名的三个文件夹
      在这里插入图片描述

      将这三个文件夹中的文件分别复制到cuda中的同名文件夹中,cuda的安装就这样愉快的结束了。然后打开终端,输入nvcc -V,即可查看安装的版本。
      在这里插入图片描述

      折腾了半天,终于可以按照pytorch了,这里给两种方法,第一种是简单的,直接在终端中输入命令:

      pip install torch==1.2.0 torchvision==0.4.0 -f https://download.pytorch.org/whl/torch_stable.html
      

      如果这样的方式安装特别慢,那还有另一种办法,就是直接安装whl文件,那么就需要先下载一下这两个文件了。
      https://download.pytorch.org/whl/torch_stable.html
      进入这个网址里面可以下载torch和torchvision
      在这里插入图片描述
      在这里插入图片描述

      要下载cu开头的文件,不要下载cpu开头的,而且cu的版本要和自己安装的cuda版本一致。下载好之后,在下载的位置直接打开终端,然后输入
      pip install torch-1.2.0-cp36-cp36m-win_amd64.whl
      pip install torchvision-0.4.0-cp36-cp36m-win_amd64.whl
      全部安装完成之后,别忘了,重启一下电脑。

      展开全文
    • win10+cuda10.0+pytorch安装

      2021-01-06 21:00:01
      简介 由于PyTorch在中国大陆的...CUDA内核显卡 NVIDIA Quadro P4000 1、进入Pytorch官网https://pytorch.org/ 看到该部分类容后,根据自己的电脑配置,选择相应的选项。 Package 建议使用pip,这样才会提供Run this Co
    • Ubuntu16.04 + CUDA10.0 + Pytorch1.0.0 安装

      千次阅读 2020-03-20 21:05:05
      1. 查看CUDA版本 ...我的是 CUDA10.0 2. 安装Pytorch 2.1 打开Pytorch网址https://pytorch.org/ 2.2如果安装最新的Pytorch,则执行默认命令: conda install pytorch torchvision cudatoolkit=...

      1. 查看CUDA版本

          cat /usr/local/cuda/version.txt

      我的是 CUDA10.0

      2. 安装Pytorch

      2.1 打开Pytorch网址 https://pytorch.org/  

        2.2 如果安装最新的Pytorch,则执行默认命令: 

      conda install pytorch torchvision cudatoolkit=10.1 -c pytorch
      

      我需要运行的的程序要求pytorch1.0.0版本,所以选择1.0.0版本的安装:

      conda install pytorch==1.0.0 torchvision==0.2.1 cuda100 -c pytorch
      

      3. 安装后,终端输入 conda list, 显示如下:

        

      或则终端输入 python,import torch,无异常,则表明安装成功!

      展开全文
    • 服务器配置:RTX 2080 8G cuda10.0 这里安装的 版本为 pytorch1.1.0 torchvision0.3.0 ,使用conda 可以进行正确安装, 安装命令来自 pytorch 官方. 正确可用的安装方法如下:(亲测可用) conda create -n nice...
      • 🥇 版权: 本文由【墨理】原创、在CSDN首发、感谢查阅


      👋 服务器配置


      • Ubuntu 18.04.5 LTS
      • RTX 2080 8G cuda10.0

      一个表格对应信息【比较陈旧】

      1


      🎉 pytorch 0.4.0 安装


      对 Pytorch0.4.0 环境搭建有兴趣同学,可直接参考我的这篇博文

      Conda 环境为适配 pytorch=0.4.0 会安装 Python 运行需要的 cudatoolkit 8.0


      安装命令如下

      conda install pytorch=0.4.0 -c pytorch
      
      conda install torchvision=0.1.6
      
      # 或者
       
      pip install torchvision==0.1.6 
      

      📔 pytorch 1.1.0 安装


      • 这里安装的 版本为 pytorch1.1.0 torchvision0.3.0 ,使用 conda 可以进行正确安装,安装命令来自 pytorch 官方.

      正确可用的安装方法如下:(亲测可用)


      conda create -n nice python=3.6.9
      
      conda activate nice
      
      conda install pytorch==1.1.0 torchvision==0.3.0 cudatoolkit=10.0 -c pytorch
      
      pip install opencv-python
      
      pip install scipy
      
      pip install thop
      
      

      📕 pytorch==1.4.0 安装


      安装命令来自 pytorch 官方.

      conda create -n torch14 python=3.6.6
      
      conda activate torch14
      
      conda install pytorch==1.4.0 torchvision==0.5.0 cudatoolkit=10.0 -c pytorch
      
      pip install opencv-python
      
      pip install scipy
      
      pip install thop
      
      

      📗 pytorch==1.5.0 安装


      # CUDA 9.2
      conda install pytorch==1.5.0 torchvision==0.6.0 cudatoolkit=9.2 -c pytorch
      
      # CUDA 10.1
      conda install pytorch==1.5.0 torchvision==0.6.0 cudatoolkit=10.1 -c pytorch
      
      # CUDA 10.2
      conda install pytorch==1.5.0 torchvision==0.6.0 cudatoolkit=10.2 -c pytorch
      
      # CPU Only
      conda install pytorch==1.5.0 torchvision==0.6.0 cpuonly -c pytorch
      

      📘 关于 cudatoolkit 版本的探讨【❤️墨理学AI❤️】


      这里当遇到 cudatoolkit 版本导致的一些 Cuda、Cudnn 报错时,你会需要了解【❤️ 特别补充 ❤️】

      • 我们可以发现,官方标准的安装命令格式如上,很多时候,我们可能会需要根据自己服务器的Cuda版本来适当设置 cudatoolkit=8.X、 cudatoolkit=9.X 或者 cudatoolkit=10.X ;

      • 在Conda Python 环境中,cudatoolkit 版本和 pytorch 版本是有一定匹配关系的

      • 只要服务器 Root 用户安装的 cudatoolkit 版本足够高,比如11.2,那么你个人 环境中的cudatoolkit=11.2 及其以下,就都是可以顺利运行的;

      • Conda 独立环境中可使用 conda install cudatoolkit=x.0 安装正确的 cudatoolkit 版本来解决

      • 于此,我的相关处理思路如下

      首先 search 当前可以安装的 cudatoolkit

      conda search cudatoolkit
      
      Loading channels: done
      Name                       Version                   Build  Channel        
      cudatoolkit                5.5rc1                       p0  defaults       
      cudatoolkit                5.5.1                        p0  defaults       
      cudatoolkit                6.0                          p0  defaults       
      cudatoolkit                7.0                           1  defaults       
      cudatoolkit                7.5                           0  defaults       
      cudatoolkit                7.5                           2  defaults       
      cudatoolkit                8.0                           1  defaults       
      cudatoolkit                8.0                           3  defaults       
      cudatoolkit                9.0                  h13b8566_0  defaults       
      cudatoolkit                9.2                           0  defaults       
      cudatoolkit                10.0.130                      0  defaults       
      cudatoolkit                10.1.168                      0  defaults       
      cudatoolkit                10.1.243             h6bb024c_0  defaults       
      cudatoolkit                10.2.89              hfd86e86_0  defaults       
      cudatoolkit                10.2.89              hfd86e86_1  defaults       
      cudatoolkit                11.0.221             h6bb024c_0  defaults       
      cudatoolkit                11.3.1               h2bc3f7f_2  defaults    
      

      故而,当前可以考虑采用的安装命令有【我会根据Pytorch版本适配需求安装即可】

      • conda install cudatoolkit=7.0
      • conda install cudatoolkit=8.0
      • conda install cudatoolkit=9.0
      • conda install cudatoolkit=10.0.*
      • conda install cudatoolkit=11.0.*

      📘 pytorch==1.6.0 安装


      
      # CUDA 9.2
      conda install pytorch==1.6.0 torchvision==0.7.0 cudatoolkit=9.2 -c pytorch
      
      # CUDA 10.1
      conda install pytorch==1.6.0 torchvision==0.7.0 cudatoolkit=10.1 -c pytorch
      
      # CUDA 10.2
      conda install pytorch==1.6.0 torchvision==0.7.0 cudatoolkit=10.2 -c pytorch
      
      # CPU Only
      conda install pytorch==1.6.0 torchvision==0.7.0 cpuonly -c pytorch
      
      

      📙 安装测试【判定torch安装是否成功】


      print 为 True 则安装成功

      python 
      
      Python 3.7.6 (default, Jan  8 2020, 19:59:22) 
      [GCC 7.3.0] :: Anaconda, Inc. on linux
      Type "help", "copyright", "credits" or "license" for more information.
      
      >>> import torch
      >>> import torchvision
      
      >>> print(torch.cuda.is_available())
      True
      
      >>> print(torch.__version__)
      1.5.0
      
      

      📜 Linux下 pytorch 1.8的极简安装【2021夏补充】


      进入 pytorch 主页

      根据你的机型进行选择

      1-0

      copy 给出的命令 到 服务器 shell 命令窗口,执行即可

      pip3 install torch==1.8.1+cu111 torchvision==0.9.1+cu111 torchaudio==0.8.1 -f https://download.pytorch.org/whl/lts/1.8/torch_lts.html
      

      这里需要注意的是 cudatoolkit 的版本

      # CUDA 10.2
      conda install pytorch==1.8.0 torchvision==0.9.0 torchaudio==0.8.0 cudatoolkit=10.2 -c pytorch
      
      # CUDA 11.1
      conda install pytorch==1.8.0 torchvision==0.9.0 torchaudio==0.8.0 cudatoolkit=11.1 -c pytorch -c conda-forge
      
      # CPU Only
      conda install pytorch==1.8.0 torchvision==0.9.0 torchaudio==0.8.0 cpuonly -c pytorch
      

      💅 这里涉及到一个 conda 和 pip 下载方式的问题


      • 首先,不论哪种 方式,都是可以的,但是都建议 配置 源 进行 下载加速
      • 我自己平时 习惯会首先使用 pip 来进行 安装
      • 推荐 conda 和 pip 的 加速配置方式如下
      • conda 主要功能是在服务器中 搭建自己独立环境【不影响其他人】

      anaconda conda 切换为国内源 |windows 和 Linux配置方法

      linux和window设置 pip 镜像源 | 最实用的环境下载加速设置


      🟧 其它版本 pytorch 的安装


      打开这个页面,下方均有对应的 conda 和 pip 安装 命令


      结合 自己 电脑 cuda 版本进行选择即可

      2-0


      🚀 你那么好看,别把有趣弄丢了


      9-9


      展开全文
    • 2.cuda10.0对应cudnn安装 2.1 cuda10.0下载链接如下,按图中所示下载即可。 https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Windows&target_arch=x86_64&target_version=10&...
    • ubuntu-cuda10.0安装pytorch(ubuntu16.04)

      千次阅读 2020-04-07 09:01:45
      pytorch网址: ...CUDA 10.0 pip install torch1.2.0 torchvision0.4.0 -f https://download.pytorch.org/whl/torch_stable.html 参考:https://blog.csdn.net/gdymind/...
    • 默认在windows安装下安装好anoconda3 和cuda10.0 1.官网选择操作系统和python版本 https://pytorch.org/get-started/locally/ 2. 官网上显示安装命令为 conda install pytorch torchvision cudatoolkit=10.1 -c ...
    • 安装环境准备: 1.首先你需要安装Anaconda: ... 需要注意Anaconda自带的python版本。...2.其次你需要安装CUDA 10.0对应的cuDNN v7(见相应的博客教程)。 安装pytorch 官网(https://pytorch.org/get-started/l...
    • cuda10.0安装失败与解决 关于电脑对应cuda版本问题,网上有太多介绍就不再叙述了,请看此网址...
    • 工欲善其事,必先利其器 显卡驱动版本和cuda版本? 今天两台电脑训练时发现速度比平时慢了,以为是...这时发现自己代码里的device = torch.device("cuda:0" if torch.cuda.is_available() else "cpu")让我后背一凉..
    • 打开英伟达官网找到CUDA-Enabled GeForce Products寻找有没有自己对应的显卡型号,如果有才能下载。 2、安装CUDA 进入CUDA下载链接,根据电脑的属性点击。下载完成后点击安装即可。我下载的是10 ...
    • win10+GPU+CUDA10.0配置Pytorch环境

      千次阅读 2019-09-03 13:43:24
      安装细节: 1.cuda安装选择自定义安装比较好,且要将Driver ...否则就有CUDA driver version is insufficient for CUDA runtime version,是说driver驱动程序的版本太低,以致cuda不能运行。 2.记录一下测试路径...
    • Ubuntu18.04+CUDA10.0+pytorch(gpu版1.4安装)

      千次阅读 2020-06-10 18:31:49
      最近被坑死了,安装了CUDA10.1,安装了pytorch1.4版本,但是torch.cuda.is_available()返回false, 郁闷好久。。。。 zhenghan@zhenghan:~$ pip install torch==1.4.0+cu101 torchvision==0.5.0+cu101 -f ...
    • 一、下载cuda-10.0的deb安装包并双击进行安装,然后如果有附加的补丁也一并安装 sudo dpkg -i cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb sudo apt-key add /var/cuda-repo-<ve...
    • 一、前言 CenterNet有两个,本文的CenterNet对应的论文是:Objects as Points 对应Github地址:xingyizhou/CenterNet Win10版本点击这里:【目标检测】Win10+CUDA10.0+CUDNN7.5搭建CenterNet环境 下面这两篇博客也对...
    • CenterNet有两个,本文的CenterNet对应的论文是:Objects as Points 对应Github地址:xingyizhou/CenterNet ...下面这两篇博客也对我帮助很...(绝对详细)CenterNet训练自己的数据(pytorch0.4.1) 环境安装 https://g...
    • cuda10.0 python3.5 tensorflow1.14.0 pip install tensorflow-gpu==1.14.0 -i http://pypi.douban.com/simple --trusted-host pypi.douban.com torch1.2 cu100/torch-1.2.0-cp35-cp35m-win_amd64.whl ...
    • cuda10.0环境安装Pytorch

      千次阅读 2020-08-08 13:16:17
      前置环境需要安装cuda10.0对应的cudnn 不在赘述,如需查看请参考这两篇博客(面向小白的,十分详细): 手把手教你win10安装Paddlepaddle-GPU(一) 手把手教你win10安装Paddlepaddle-GPU(二) 尴尬的是,官网好像比较...
    • 最开始安装cuda10.0对应pytorch时候,命令如下: conda install pytorch torchvision torchaudio cudatoolkit=10.0 正确命令: conda install pytorch==1.2.0 torchvision==0.4.0 cudatoolkit=10.0 可以看到不仅...
    • Pytorch 1.4.0 + cuda10.0 安装

      万次阅读 热门讨论 2020-04-17 10:54:58
      官网给的是Pytorch 1.2.0 + cuda10.0 安装. 而一般如果是cuda10.0直接安装pytorch会显示cuda unavailable。 解决 pip install torch==1.4.0+cu100 torchvision==0.5.0+cu100 -f ...
    • 正常情况下cuda10.0对应的最高pytorch版本为1.4.0 查看,但在cuda10.0的情况下也可以安装高版本的pytorch,并成功运行如下: 安装命令,PyToch和Torchvision版本需要对应,参考: pip install torch==1.7.1 ...
    • 在此找到对应的版本:https://download.pytorch.org/whl/cu100/torch_stable.html 找到对应版本的torch链接(36对应python版本3.6): $ wget https://download.pytorch.org/whl/cu100/torch-1.1.0-cp36...
    • 本文旨在CUDA10.0+cudnn7.6的情况下是的TF2和Pytorch共存。 前提 已经安装了CUDA10.0+cudnn7.6+TF2-GPU+python3.6(若未安装,可以参考之前博客) pytorch安装 1.查看官网 去官网找指令,只发...
    • linux 18.04 cuda10.0使用pip安装pytorch

      千次阅读 2020-05-02 20:10:33
      linux 18.04 cuda10.0使用pip安装pytorch背景解决方法 背景 在pycharm中导入包import torch时报如下错误: ModuleNotFoundError: No module named ‘torch’ 解决方法 (1)下载torch-1.3.0+cu100-cp36-cp36m-linux_...
    • 前言:因为需要用到pytorch框架,所以我这个新手就来尝试用conda直接从官网下载下来,但由于本人人品过于差,安装了清华源,下载还是的慢的一批,然后下一点就直接失败,然后尝试了翻墙,还是失败。安装了两天,一直...
    • win10+cuda10.0+conda安装pytorch

      千次阅读 2019-11-01 12:35:24
      准备:anaconda3.7,cuda10.0,cudnn7.6 新手小白自己安装真的是太痛苦了,感谢网友们提供的各种思路。尝试了很多,终于装成功了。 根据网友提供的安装好了tensorflow2.0-gpu,安装成功,再次诚心感谢各位大佬提供...
    • CUDA10.0 + cuDNN 7.6.5 安装可自行百度 教程很多。 conda create --name pytracking python=3.7 conda activate pytracking conda install pytorch torchvision cudatoolkit=10.0 -c pytorch 有的时候上面的...

    空空如也

    空空如也

    1 2 3 4 5 ... 20
    收藏数 1,723
    精华内容 689
    关键字:

    cuda10.0对应的pytorch