精华内容
下载资源
问答
  • 文章目录@[toc] 实现拓扑图步骤一:实验前准备步骤二:设备配置步骤三:配置验证 实现拓扑图 步骤一:实验前准备 ​ 本实验使用的是eNSP v1.2.00.500,CE12800系统版本Version 8.130 (CE12800 V800R013C00SPC560B...
  • 集中式网关VXLAN实验

    2021-01-04 17:32:21
    此实验部署的是集中式网关VXLAN,另外还有分布式网关VXLAN。现网环境中的主机为虚拟机,此处用物理机代替。实验环境:模拟器采用eNSP,用CE12808交换机实现VXLAN。 二、实验拓扑   IP地址、VLAN以及VXLAN的规划如...

    一、背景

      由于现网中涉及到了VXLAN,所以简单的了解了一下VXLAN,并将学习到的知识记录下来,以便后续查看。此实验部署的是集中式网关VXLAN,另外还有分布式网关VXLAN。现网环境中的主机为虚拟机,此处用物理机代替。实验环境:模拟器采用eNSP,用CE12808交换机实现VXLAN。

    二、实验拓扑

      IP地址、VLAN以及VXLAN的规划如下图所示。
    在这里插入图片描述

    三、配置文件

    3.1基础配置

    3.1.1核心交换机CE1

    interface GE1/0/1
     undo portswitch                                //将接口模式转换为三层
     undo shutdown                                  //启用接口,CE12808的接口默认是shutdown的
     ip address 10.0.12.1 255.255.255.252                             
     
    interface GE1/0/2
     undo portswitch
     undo shutdown
     ip address 10.0.13.1 255.255.255.252
    
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255           //配置VTEP IP地址,用LoopBack的原因是为了VXLAN以及OSPF协议的稳定性
    

    3.1.2汇聚交换机CE2

    interface GE1/0/1
     undo portswitch
     undo shutdown
     ip address 10.0.12.2 255.255.255.252
    
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    

    3.1.3汇聚交换机CE3

    interface GE1/0/2
     undo portswitch
     undo shutdown
     ip address 10.0.13.2 255.255.255.252
    
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    

    3.2配置OSPF

      在CE1,CE2,CE3上配置OSPF,使得VTPE IP地址三层互通、以便VXLAN隧道能正常建立。

    3.2.1CE1

    ospf 1                                  //创建OSPF进程
     area 0.0.0.0                           //创建OSPF区域
      network 1.1.1.1 0.0.0.0               //宣告VTEP IP地址
      network 10.0.12.0 0.0.0.3             //宣告互联地址网段,使得OSPF邻居能正常建立
      network 10.0.13.0 0.0.0.3             //宣告互联地址网段,使得OSPF邻居能正常建立
    

    3.2.2CE2

    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.0.12.0 0.0.0.3
    

    3.2.3CE3

    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.0.13.0 0.0.0.3
    

    3.2.4配置情况查看

      当OSPF协议配置完成后,在交换机上查看一下路由表,看交换机是否已经学习到其他VTEP的IP地址。
    在这里插入图片描述
      可见,上图交换机已经学习到了其他交换机上所配置的VTEP IP地址。

    3.3VXLAN配置

    3.3.1CE1

      由于是配置集中式网关VXLAN,所以需要在核心交换机CE1上面配置VXLAN的网关,即PC的网关地址。

    bridge-domain 10               //创建桥域BD,类似VLAN的广播域
     vxlan vni 10                  //创建VXLAN网络标识符VNI(可以与BD不同),类似VLAN ID
    
    bridge-domain 20
     vxlan vni 20
    
    interface Vbdif10                                 //创建VXLAN三层接口,类似vlanif接口
     ip address 192.168.10.254 255.255.255.0            //配置网关地址
    
    interface Vbdif20
     ip address 192.168.20.254 255.255.255.0
    
    interface Vbdif30
     ip address 192.168.30.254 255.255.255.0
    
    interface Nve1                                     //创建NVE(网络虚拟化边缘)接口
     source 1.1.1.1                                    //VXLAN隧道封装的源地址
     vni 10 head-end peer-list 2.2.2.2               //配置头端复制列表,针对BUM报文
     vni 20 head-end peer-list 2.2.2.2
     vni 30 head-end peer-list 3.3.3.3
    

    3.3.2CE2

      配置汇聚交换机,即VXLAN的接入点,此实验为以VLAN模式接入到VXLAN网络;

    bridge-domain 10
     vxlan vni 10
     
    bridge-domain 20
     vxlan vni 20
    
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list 1.1.1.1
     vni 20 head-end peer-list 1.1.1.1
    
    interface GE1/0/3
     undo shutdown                   //启用接口
    
    interface GE1/0/3.10 mode l2                       //创建二层子接口
     encapsulation dot1q vid 10                        //只解封装携带vlan-tag 10的数据帧
     bridge-domain 10                                //将vlan10的数据帧封装到VXLAN隧道中
    
    interface GE1/0/3.20 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    
    interface GE1/0/2
     undo shutdown
    
    interface GE1/0/2.20 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    
    

    3.3.3 CE3

      配置与CE2类似

    bridge-domain 30
     vxlan vni 30
    
    interface Nve1
     source 3.3.3.3
     vni 30 head-end peer-list 1.1.1.1
    
    interface GE1/0/1
     undo shutdown
    
    interface GE1/0/1.30 mode l2
     encapsulation dot1q vid 30
     bridge-domain 30
    

    3.3.4接入交换机配置:LWS1

      接入交换机需要创建相应的接入VLAN,并放通。

    vlan batch 10 20        //同时创建VLAN 10和VLAN	20
     
    interface Ethernet0/0/3
     port link-type trunk                           //将接口模式设置为Trunk,允许多个VLAN通过
     undo port trunk allow-pass vlan 1              //拒绝默认vlan通过
     port trunk allow-pass vlan 10 20               //允许指定vlan通过
    
    interface Ethernet0/0/1
     port link-type access                       //将接口模式设置为access
     port default vlan 10                        //将接口模默认vlan设置为10
    
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20
    

    3.3.5接入交换机配置:LWS2

    vlan 20
    
    interface Ethernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
    
    interface Ethernet0/0/1
     port link-type access
     port default vlan 20
    

    3.3.6接入交换机配置:LWS3

    vlan 30
    
    interface Ethernet0/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 30
    
    interface Ethernet0/0/2
     port link-type access
     port default vlan 30
    

    3.3.7PC配置

      注意,配置PC之后,一定要点击“应用”,否则配置不生效。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    四、验证

    4.1测试PC到自己网关的连通性,并抓包查看

    在这里插入图片描述
      当用PC1ping网关的时候,用Wireshark在CE2的GE1/0/1上抓包,并分析抓包的结果。
    在这里插入图片描述
      由抓包结果可见。PC1ping自己的网关的报文是经过VXLAN封装了的,也就是说原始MAC帧被封装到了VXLAN隧道中。隧道的源IP地址为CE2的VTEP IP地址,目的IP地址为CE1的VTEP IP地址,VNI为1010;原始数据帧的源IP地址为192.168.10.1,目的IP地址为192.168.10.254;抓包结果符合预期。

    4.2测试PC与不同网段之间的通信

      PC1 ping PC3,并在CE2的GE1/0/1口抓包查看。
    在这里插入图片描述
      CE2的GE1/0/1接口抓包接口如下:可以看到此时的报文为VXLAN报文
    在这里插入图片描述
      在CE2的GE1/0/2接口抓包如下:可以看到此时报文不是VXLAN报文,即交换机已经把VXLAN报文解封装了。
    在这里插入图片描述

    4.3测试PC与不同网段之间的通信

      PC1 ping PC4,并在CE2的GE1/0/1上和CE3的1/0/2接口抓包
    在这里插入图片描述
    CE2的GE1/0/1抓包如下:
    在这里插入图片描述
    CE3的GE1/0/2

    在这里插入图片描述
      可以看见,此时报文的原始MAC信息没有被改变,但是VXLAN的VTEP是经过了改变的,即原始MAC报文先被送到CE1(网关),VTEP IP为:2.2.2.2----1.1.1.1(VXLAN:10),然后CE1再转发给PC4,此时VTEP IP的源目IP地址为1.1.1.1----3.3.3.3(VXLAN:30)

    五、总结

      1,相同VXLAN(VNI)的头端复制列表不能同时指向两个或多个VTEP。
    如:
      vni 10 head-end peer-list 2.2.2.2
      vni 10 head-end peer-list 3.3.3.3
    解决方法:注意VXLAN的组网

      2,由于eNSP的原因,设置vxlan vni的时候,一定不要超过100,否则会出现bug;如ping不通。

    展开全文
  • 本文以华为eNSP模拟器为工具,设计并实现了一个典型的EVPN配置集中式网关的应用场景,并完成了相应的配置。 阅读本文,您需要对EVPN有一定的了解,如果您对此还存在困惑,欢迎查阅我博客内的其他文章,相信您一定会...

    今天给大家介绍EVPN的相关内容。本文以华为eNSP模拟器为工具,设计并实现了一个典型的EVPN配置集中式网关的应用场景,并完成了相应的配置。
    阅读本文,您需要对EVPN有一定的了解,如果您对此还存在困惑,欢迎查阅我博客内的其他文章,相信您一定会有所收获!
    推荐阅读文章:
    VXLAN详解(一)
    VXLAN详解(二)
    VXLAN详解(三)
    VXLAN中EVPN技术详解(一)——EVPN实现VXLAN隧道控制
    VXLAN中EVPN技术详解(二)——EVPN与VXLAN分布式网关

    一、实验拓扑及要求

    在这里插入图片描述
    实验拓扑如上所示,现在要求使用配置如图所示的数据中心集中式网关,并要求VXLAN隧道使用EVPN技术实现。

    二、实验配置命令

    (一)开启EVPN路由协议相关配置命令

    要使得CE设备开启EVPN相关协议,就必须在全局模式下使能EVPN,相关配置命令如下:

    evpn-overlay enable
    

    (二)BGP配置相关命令

    在实现EVPN相关配置,就必须先配置BGP的EVPN对等体,与常见的BGP对等体配置和MPLS BGP配置类似,唯一区别的地方在于后面的l2vpn-family evpn下使能EVPN对等体,相关配置命令如下:

    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
    #
    

    (三)BD域配置相关命令

    要想配置EVPN,就必须给BD域配置RD和RT值,相关配置如下所示:

    bridge-domain 10
     vxlan vni 10
     evpn
      route-distinguisher 100:11
      vpn-target 100:1 export-extcommunity
      vpn-target 100:1 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 20
     evpn
      route-distinguisher 100:21
      vpn-target 100:2 export-extcommunity
      vpn-target 100:2 import-extcommunity
    #
    

    注意:同一个VXLAN对应的BD域中RT值应该配置的相同,这样才能实现Type 3路由的发送和接受正常。

    (四)NVE隧道配置相关命令

    与手动指定NVE隧道时的配置不同,在这里NVE隧道的配置我们使用的是EVPN传递Type 3路由,指导NVE隧道的建立,相关配置命令如下:

    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     vni 20 head-end peer-list protocol bgp
    #
    

    三、实验效果

    在理论上,按照上述配置,四台设备之间是可以互通的,但是还是由于华为eNSP对CE设备支持中的BUG,导致我们并不能实现预期的效果,但是我们可以看到VXLAN隧道和EVPN路由还是实现了正常传递的。
    在这里插入图片描述
    在这里插入图片描述

    四、附录——CE1和CE2相关配置命令

    CE1:

    evpn-overlay enable
    #
    bridge-domain 10
     vxlan vni 10
     evpn
      route-distinguisher 100:11
      vpn-target 100:1 export-extcommunity
      vpn-target 100:1 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 20
     evpn
      route-distinguisher 100:21
      vpn-target 100:2 export-extcommunity
      vpn-target 100:2 import-extcommunity
    #
    interface Vbdif10
     ip address 192.168.10.254 255.255.255.0
    #
    interface Vbdif20
     ip address 192.168.20.254 255.255.255.0
    #
    interface GE1/0/0
     undo portswitch
     undo shutdown
     ip address 155.1.11.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     vni 20 head-end peer-list protocol bgp
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 155.1.11.0 0.0.0.255
    

    CE2:

    evpn-overlay enable
    #
    bridge-domain 10
     vxlan vni 10
     evpn
      route-distinguisher 100:12
      vpn-target 100:1 export-extcommunity
      vpn-target 100:1 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 20
     evpn
      route-distinguisher 100:22
      vpn-target 100:2 export-extcommunity
      vpn-target 100:2 import-extcommunity
    #
    interface GE1/0/0
     undo portswitch
     undo shutdown
     ip address 155.1.12.2 255.255.255.0
    #
    interface GE1/0/1
     undo shutdown
    #
    interface GE1/0/1.10 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface GE1/0/1.20 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list protocol bgp
     vni 20 head-end peer-list protocol bgp
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 155.1.12.0 0.0.0.255
    

    原创不易,转载请说明出处:https://blog.csdn.net/weixin_40228200/article/details/119715560

    展开全文
  • 根据三层网关部署方式的不同,VXLAN三层网关又可以分为集中式网关和分布式网关。集中式网关是指将三层网关集中部署在一台设备上,所有跨子网的流量都经过三层网关进行转发,实现流量的集中管理。
  • 实验拓扑: 实验工具:华为模拟器 实验思路: 1、三台CE设备配置接口IP并运行OSPF互相宣告...4、在CE2上配置VLAN三层网关,并分别与CE1和CE3建立VXLAN隧道。 实验规划: VLAN 10 30 网段 192.168.1

    实验拓扑:

    实验工具:华为模拟器

    实验思路:

    1、三台CE设备配置接口IP并运行OSPF互相宣告自身网段,使三台CE设备互相三层可达。

    2、分别在CE1和CE3上配置业务接入点,并建立VXLAN隧道。此时当PC1和PC2处于同网段同vlan时可二层互访。

    3、添加PC3连接LSW2,与PC1/2处于不同网段不同vlan。

    4、在CE2上配置VXLAN三层网关,并分别与CE1和CE3建立VXLAN隧道。

    实验规划:

    VLAN1030
    网段192.168.10.0/24192.168.30.0/24
    网关192.168.10.254192.168.30.254
    二层VNI1030
    BD1030
    PC

    PC1: 192.168.10.1

    PC2: 192.168.10.2

    PC3: 192.168.30.1

    CE1

    lo0: 10.10.10.10/32

    g1/0/0: 12.1.1.1/24

    CE2

    lo0: 20.20.20.20/32

    g1/0/0: 12.1.1.2/24

    g1/0/1: 23.1.1.2/24

    CE3

    lo0: 30.30.30.30/32

    g1/0/0: 23.1.1.3/24

    PC1

    192.168.10.1/24

    vlan10

    vxlan10

    PC2

    1921.68.10.2/24

    vlan10

    vxlan10

    LSW

    上行trunk,下行acccess

    实验步骤:

    第一步:基础配置

    1、配置各CE设备lo0接口和GE接口ip,配置ospf宣告自身网络

    2、两台LSW配置上行接口类型为trunk,下行接口类型为access并设置vlan

    CE1

    sys im

    sys CE1

    int lo0

    ip add 10.10.10.10 32

    q

    int g1/0/0

    undo ports

    ip ad 12.1.1.1 24

    undo sh

    q

    ospf

    area 0

    net 12.1.1.0 0.0.0.255

    net 10.10.10.10 0.0.0.0

    q

    q

    CE2

    sys im

    sys CE2

    int lo0

    ip add 20.20.20.20 32

    q

    int g1/0/0

    undo ports

    ip ad 12.1.1.2 24

    undo sh

    q

    int g1/0/1

    undo ports

    ip ad 23.1.1.2 24

    undo sh

    q

    ospf

    area 0

    net 12.1.1.0 0.0.0.255

    net 23.1.1.0 0.0.0.255

    net 20.20.20.20 0.0.0.0

    q

    q

    CE3

    sys im

    sys CE3

    int lo0

    ip add 30.30.30.30 32

    q

    int g1/0/0

    undo ports

    ip ad 23.1.1.3 24

    undo sh

    q

    ospf

    area 0

    net 23.1.1.0 0.0.0.255

    net 30.30.30.30 0.0.0.0

    q

    q

    SW1

    sys

    sys SW1

    int g0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    stp disable

    q

    vlan 10

    q

    int g0/0/1

    port li ac

    port de vl 10

    stp dis

    q

    SW2

    sys

    sys SW2

    int g0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    stp disable

    q

    vlan 10

    q

    int g0/0/1

    port li ac

    port de vl 10

    stp dis

    q

    第二步:配置vxlan业务接入口和vxlan隧道

    1、CE1和CE3上配置下行接口的子接口,配置解封装vlan10和绑定bd10

    2、配置CE1和CE3之间vxlan隧道

    CE1&CE3

    vxlan业务接入点

    vlan 10

    q   

    bridge-domain 10

    vxlan vni 1

    q

    int g1/0/1

    un sh

    q

    int g1/0/1.10 mode l2    

    encapsulation dot1q vid 10

    bridge-domain 10

    q

    CE1

    vxlan隧道

    int nve1

    source 10.10.10.10

    vni 1 head-end peer-list 30.30.30.30

    q

    CE3

    vxlan隧道

    int nve1

    source 30.30.30.30

    vni 1 head-end peer-list 10.10.10.10

    q

    验证:

    1、dis vxlan tunel, dis vxlan vni

    2、抓包验证,PC1和PC2同网段(192.168.10.0/24)经1-3隧道互通

    第三步:CE2配置vxlan三层网关

    1、配置CE1-CE2和CE2-CE3之间vxlan隧道

    2、CE2配置vxlan三层网关(192.168.10.254/24,vbdif)

    CE1&CE3

    int nv1

    vni 1 head-end peer-list 20.20.20.20

    q

    CE2

    br 10

    vxlan vni 1

    q

    int nv1

    sou 20.20.20.20

    vni 1 he pe 10.10.10.10

    vni 1 he pe 30.30.30.30

    q

    int Vbdif 10

    ip ad 192.168.10.254 24

    q

    验证:

    PC之间、PC与网关之间互通

    在CE2 g1/0/0抓包可以从源目地址看出,PC1 ping PC2走1-3隧道,PC1 ping网关走1-2隧道

    (PS:华为模拟器1.3.00.100版本有bug,CE设备间VXLAN隧道全互联无法联通,需去掉CE1和CE3之间的隧道,但如此一来结果为PC与网关联通,而PC间不通。改为使用版本1.3.00.200T可以全互联。)

    第四步:

    添加一台PC3(192.168.30.3,vlan30),CE2和CE3上配置隧道(vni 3),CE2配置网关192.168.30.254

    SW2

    vlan 30                    

    q

    int g0/0/3

    port li ac

    port default vlan 30

    stp dis

    q

    CE3

    bridge-domain 30

    vxlan vni 3

    q

    int g1/0/1.30 mo l2

    encapsulation dot1q vid 30

    bridge-domain 30

    q

    int nv1

    vni 3 he pe 20.20.20.20

    q

    CE2

    bridge-domain 30

    vxlan vni 3

    q

    int Vbdif 30

    ip ad 192.168.30.254 24

    q

    int nv1

    vni 3 he pe 30.30.30.30

    q

    验证:

    PC间都可以互相访问,并且抓包可以看到,第一个包是发出ARP广播包找本端网关

    1
    2
    3
    4

    第一个包,PC3没有10段路由,arp广播找30网关。找到网关后,向对端(192.168.10.1)发ping包,通过隧道到达对端。客户端由于等待时间过长显示超时。

    PC3 ping PC2时,在CE3上抓到4个包可以看到交互过程。

    CE3 int g1/0/1 70:7b:e8:a9:40:8f,PC3 54:89:98:bb:31:92,PC2 54:89:98:69:19:63。

    139:vlan30,Ethernet II, Src: HuaweiTe_bb:31:92 (54:89:98:bb:31:92), Dst: 70:7b:e8:a9:40:8f (70:7b:e8:a9:40:8f)。PC3->g1/0/1.30

    140:vlan10,Ethernet II, Src: 70:7b:e8:a9:40:8f (70:7b:e8:a9:40:8f), Dst: HuaweiTe_69:19:63 (54:89:98:69:19:63)。g1/0/1.10->PC2

    141:vlan10,Ethernet II, Src: HuaweiTe_69:19:63 (54:89:98:69:19:63), Dst: 70:7b:e8:a9:40:8f (70:7b:e8:a9:40:8f)。PC2->g1/0/1.10

    142:vlan30,Ethernet II, Src: 70:7b:e8:a9:40:8f (70:7b:e8:a9:40:8f), Dst: HuaweiTe_bb:31:92 (54:89:98:bb:31:92)。g1/0/1.30->PC3

    关于vlan tag:

    华为交换机接口默认是hybrid模式,所以二层VTEPCE3 int g1/0/0会将进入隧道的包vlan tag去掉,从隧道发往下行的包会打上本地的vlan tag,即vxlan隧道中的UDP包内容中都没有vlan tag。

    而CE3 int g1/0/1.xx子接口中配置了子接口的vlan号,所以子接口能够判断是否进行转发。

    展开全文
  • 主要是VXLAN应用场景下,集中式双活网关的配置方式。 阅读本文,您需要对VXLAN等基础理论知识有基本的了解。 推荐阅读文章: VXLAN详解(一) VXLAN详解(二) VXLAN配置实例(一)——VXLAN基本配置 VXLAN配置实例...

    今天给大家介绍VXLAN的相关内容。本文以华为eNSP模拟器为工具,设计并实现了一个典型的VXLAN的应用场景,并完成了相应的配置。主要是VXLAN应用场景下,集中式双活网关的配置方式。
    阅读本文,您需要对VXLAN等基础理论知识有基本的了解。
    推荐阅读文章:
    VXLAN详解(一)
    VXLAN详解(二)
    VXLAN配置实例(一)——VXLAN基本配置
    VXLAN配置实例(二)——VXLAN跨子网互通

    一、实验拓扑及目的

    在这里插入图片描述
    实验拓扑如上所示,现在要求配置VXLAN,实现PC1的网关配置在CE2和CE3设备上,CE2和CE3设备配置集中式双活网关。

    二、实验配置命令

    由于VXLAN集中式网关的配置已经在VXLAN配置实例(二)——VXLAN跨子网互通介绍过了,因此本文主要介绍VXLAN双活网关的配思路。
    所谓VXLAN双活网关,其实就是在两个网关设备上,配置相同的VYTEP,这样由于underlay运行的路由协议,就会自动的把访问网关的流量以基于流的负载分担方式转发向网关。因此,在本例中,双活网关CE2和CE3,要配置IP地址相同的LoopBack0,以实现双活网关功能。相关配置如下:

    bridge-domain 10
     vxlan vni 10
    #
    interface Vbdif10
     ip address 192.168.10.254 255.255.255.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list 1.1.1.1
    #
    

    CE2和CE3上都要配置上述的完全相同的配置命令。

    三、实验现象

    (一)AR1上路由表

    在这里插入图片描述

    (二)查看VXLAN状态

    在这里插入图片描述

    (三)PC访问网关

    在这里插入图片描述

    (四)抓包查看

    在这里插入图片描述

    四、附录——CE2设备配置相关命令

    bridge-domain 10
     vxlan vni 10
    #
    interface Vbdif10
     ip address 192.168.10.254 255.255.255.0
    #
    interface GE1/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.12.2 255.255.255.0
    #
    interface GE1/0/1
     undo portswitch
     undo shutdown
     ip address 10.1.23.2 255.255.255.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list 1.1.1.1
    #
    interface NULL0
    #
    ospf 1
     area 0.0.0.0
      network 0.0.0.0 255.255.255.255
    

    原创不易,转载请说明出处:https://blog.csdn.net/weixin_40228200/article/details/119479086

    展开全文
  • Device1的配置文件#sysname Device1#assign forward nvo3 acl extend enable //仅CE6870EI、CE6875EI需要配置此步骤#bridge-domain 10vxlan vni 5010#bridge-domain 20vxlan vni 5020#interface 10GE1/0/1undo ...
  • 10.871/18.672/45.525 ms 4.3.2 配置Overlay(static Ingress Replication VxLAN) 基于"Static Ingress Replication"实现的VxLAN,是流量驱动的MAC地址泛洪和学习,没有控制层面。 4.3.2.1 配置VTEP(N9K1和N9K-2) ...
  • VXLAN网关

    千次阅读 2018-05-03 22:42:52
    VXLAN网关    首先,补充一下现在流行的OverLay技术: VXLAN: VXLAN是将以太网报文封装成UDP报文进行隧道传输,UDP目的端口为4798(可修改),标准5元组方式有利于在IP网络转发过程中进行负载分担;隔离标识...
  • 这几天使用ENSP进行VXLAN集中式网关测试,废话少说,直接上拓扑图: 可以看出来,CE2是spine,CE1和CE3是leaf,LSW1和LSW2模拟OVS。spine作为用户的三层网关。
  • 前面通过四个实验大概了解了一下VXLAN隧道的建立过程,包括二层的头端复制实验、集中式VXLAN网关和分布式VXLAN网关,而使用华为模拟器eNSP做的实验因为模拟器问题没有成功。不过这四个实验都有一个共同点,那就是都...
  • VXLAN详解(三)

    2021-08-07 17:00:02
    本文主要介绍了VXLAN技术与网络虚拟化的关系、VXLAN的主要优点和VXLAN的网关配置 一、VXLAN技术与网络虚拟化 VXLAN技术的本质是实现二层VPN,即实现跨三层网络实现二层底层网络互通。VXLAN的实现存在两次虚拟化: 第...
  • “灵魂拷问分布式系统需要统一的网关吗?网关会带来哪些优势?引入网关会带来灾难吗?分布式系统的设计大体上分为中心化和非中心化,像现在流行的微服务模式,本质上是把各种业务拆分为独立的进程来实...
  • 1,网关的功能 1.1 与客户端建立连接 这个应该是网关最基本的网功了,一个服务做为网关,所有客户端来的消息都必须先到达这里。客户端与网关采用TCP长连接。 1.2 消息过滤 客户端可能给服务器发送任何消息,合法...
  • 采用集中式VXLANIP网关方案时,不同VXLAN之间的流量以及VXLAN访问外界网络的流量全部由集中式VXLAN IP网关处理,网关压力较大,并加剧了网络带宽资源的消耗。如图3-5所示,在分布式VXLAN IP网关方案中,每台VTEP...
  • 通过EVPN网关为同一租户的不同子网提供三层互联,并为其提供与外部网络的三层互联。 EVPN不仅继承了MP-BGP和VXLAN的优势,还提供了新的功能。EVPN具有如下特点: 简化配置:通过MP-BGP实现VTEP自动发现、VXLAN隧道...
  • sdn局域网设置步骤

    2021-03-28 19:01:32
    加密后发送,木马藏匿于加密流量中,从而避开安全检测,实施恶意活动。 老方法是用中间人技术,分析其中的行为和内容,再次加密后发送,但是有局限性,破坏了数据的完整性,耗时久,网络性能下降。...
  • 集中式无线网络实验

    2021-08-13 03:49:12
    [no]: yes自动射频管理 实验目的:了解集中式无线网络控制器的初始化及其配置过程 实验2 无线网络控制器的Interfaces配置实验 实验指导: Management Interface: 是一个默认的接口,主要作用是带内(in-band)管理...
  • 文章目录 一、从银行架构谈起,看架构为什么从集中式到微服务 传统厂商像IBM怎么样做核心银行系统呢? 二、互联网架构演进之路,这个过程经历什么样的变化? 那为什么要往微服务去转变呢? 我们看一下微服务架构模型...
  • 边缘计算网关和智能网关区别?发布时间:2021-07-02 16:24:00点击:从物理设备的角度来看,边缘计算网关和普通智能网关的区别,几乎就没有。一颗中央处理器,一堆各种网络接口(以太网,无线网,专有总线,串口等等)...
  • 更具体说,它涉及一种通过docker容器自动化构建网关边缘计算服务的方法背景技术:随着物联网终端设备数量的快速增加,由于网络带宽有限,高昂的传输成本和较高的响应时延等问题,传统基于云服务的集中式数据处理方式...
  • 本文以华为eNSP模拟器为工具,设计并实现了一个典型的EVPN配置分布式网关的应用场景,并完成了相应的配置。 阅读本文,您需要对EVPN有一定的了解,如果您对此还存在困惑,欢迎查阅我博客内的其他文章,相信您一定会...
  • 1、什么是网关 1)网关是车内网络的中心枢纽,可跨功能域(动力底盘域、、车身控制域、信息娱乐域、驾驶...3)未来联网车辆中部署的网关可分为两种类型:集中式网关和域网关; 图1. 集中式网关与域网关...
  • 今天继续给大家介绍VXLAN技术,本文主要内容是EVPN技术的主要应用——VXLAN分布式网关。本文从VXLAN分布式网关实现的角度,对EVPN的实现进行了详细的讲解。 阅读本文,您需要有一定的VXLAN技术基础,如果您对此还...
  • 从项目的角度分析 考虑成本因素,要确定接入交换机的型号,是否支持 3 层功能,要考虑同 IP 段的使用人员分布位置,集中式适合部署在接入,分布 式适合部署在汇聚还要考虑流量模型,横向流量高适合部署在接入,纵向...
  • Apache APISIX 进行集中式身份认证优点 从传统到新模式 如下图所示,左侧的图为我们展示了一种比较常见的传统身份认证方法。每一个应用服务模块去开发一个单独的身份认证模块,用来支持身份认证的一套流程处理。但...
  • Zuul网关生产部署实践

    千次阅读 2019-02-11 13:05:17
    Zuul是Netflix开源的微服务网关,在Netflix经过大规模生产验证,在业界很多公司有落地案例。 本文介绍Zuul网关的一些生产部署实践。 Zuul参考部署架构 上图是一个可供参考的Zuul部署架构,总体可以简化为一个三层...
  • 在《微服务网关——需求篇》中,我们讨论了微服务网关的需求,本文将对微服务网关进行设计。考虑到实际情况的差异,这里实际给出的是设计选项,最终设计基于实际场景来确定。网关功能性设计路由一般情况...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 23,873
精华内容 9,549
关键字:

集中式网关