精华内容
下载资源
问答
  • 思科三层交换机实现不同VLAN间互相访问配置
    千次阅读
    2020-12-28 21:41:57

    思科三层交换机实现不同VLAN间互相访问配置

    案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一台思科三层交换机来实现(可以实现VLAN间路由,同时可提供更多的接口来接入主机)。

    思科三层交换机VLAN间路由配置步骤:

    1、配置干道(TRUNK)

    在接口模式下声明该接口为trunk模式的命令格式:

    Switch(config-if)#switchport mode turnk

    指定接口封装类型的命令格式:

    Switch(config-if)#switchport trunk encapsulation {dot1q|ISL}

    注:dot1q封装类型为802.1q,一般在交换机默认封装dot1q类型

    2、配置VLAN

    在私有模式下进入vlan database声明VLAN的命令格式:

    Switch#vlan database

    Switch(vlan)#vlan vlan_number

    进入相应接口,将该接口划分到指定VLAN内的格式:

    Switch(config-if)#switch port mode access

    Switch(config-if)#switchport access vlan vlan_number

    3、配置VLAN间路由

    思科三层交换机的路由模块和交换模块直接通过思科交换机的背板总线连接,因此只需要在三层交换机的路由模块上定义与VLAN数量相当的逻辑接口,并和VLAN 对应,然后为这些接口分配IP地址即可。

    首先要在在思科三层交换机上打开路由功能,命令格式如下:

    Switch(config)#ip routing

    为VLAN分配地址的命令格式如下:

    Switch(config)#interface vlan vlan_number

    Switch(config)#ip add ip_adress netmask

    更多相关内容
  • 一、VLAN间通信方式 1.3 层交换机 2.路由器上每个 vlan 分配一个独立的接口 3.子接口做单臂路由 二、单臂路由 1、. SW1交换机的名称改为 SW1  Switch>enable # 进入特权模式  Switch#config ...

    一、VLAN间通信方式

    1.3 层交换机

    2.路由器上每个 vlan 分配一个独立的接口

    3.子接口做单臂路由

    二、单臂路由

    VLAN间互通的几种方式,现网项目中都会用到,一分钟了解下

     

    1、. SW1交换机的名称改为 SW1

      Switch>enable # 进入特权模式

      Switch#config terminal # 进入全局模式

      Switch(config)#hostname SW1 #交换机的名称改为SW1

    2. SW1交换机上创建VLAN 2和VLAN 3

      SW1(config)#vlan2 # 创建vlan2

      SW1(config-vlan)#exit # 退出vlan2

      SW1(config)vlan 3  # 创建vlan3

      SW1(config-vlan)exit  # 退出vlan3

    3. SW1交换机连接到电脑的接口配置为access口,并且允许需要通过的VLAN ID号

      SW1(config)#interface fastEthernet 1/1  # 进入到接口1/1

      SW1(config-if)#switchport mode access  # 配置接口为access口

      SW1(config-if)#switchport access vlan 2  # 配置接口允许的vlan2

      SW1(config-if)#exit  # 退出接口1/1

      SW1(config)#interface fastEthernet 2/1  # 进入到接口2/1

      SW1(config-if)#switchport mode access  # 配置接口为access口

      SW1(config-if)#switchport access vlan 3  # 配置接口允许的vlan 3

      SW1(config-if)#exit  # 退出接口2/1

    4. SW1交换机连接到路由器R1的F0/1接口配置为Trunk口,并允许vlan 2 和vlan 3通过

    SW1(config)#interface fastEthernet 0/1  # 进入到接口0/1

    SW1(config-if)#switchport mode trunk  # 配置接口为trunk口,trunk口允许多个VLAN通过。

    SW1(config-if)#switchport trunk allowed vlan 2,3  # 配置turnk口允许vlan2 和vlan3通过,除了vlan2和vlan3,其他所有的vlan默认拒绝所有

    5. R1交换机连接到SW1交换机的接口启动

      Switch>   # 进入到用户模式

      Switch>enable  # 进入到特权模式,该模式下的权限只允许查看命令

      Swtich#config terminal  # 进入到全局模式,

     # 该模式下的权限可以配置任何命令,如果想要执行查询命令,只需要在命令行首部加上 do命令 后面接需要查询的命令

      Switch(config)#hostname R1  # 更改路由器的为R1

      R1(config)#interface fastEthernet 0/0  # 进入到接口0/0

      R1(config-if)#no shutdown  # 启动接口,路由器的接口状态默认是shutdown

      R1(config-if)#exit  # 退出该接口

    6. R1的接口F0/0上创建两个子接口,分别是F0/0.1对应的vlan2、F0/0.2对应的vlan 3

      每个子接口必须封装dot1Q协议,并且标记相应的vlan id号,dot1Q协议主要是标记vlan的id号

      每个子接口必须配置ip地址,而且该接口的ip地址必须和相应的vlan的在同一个网段

      R1(config)#interface fastEthernet0/0.1  # 进入到F0/0.1接口

      R1(config-subif)#encapsulation dot1Q 2   # 将vlan2封装在F0/0.1接口

      R1(config-subif)#ip address 192.168.2.1 255.255.255.0  

    # 配置接口的ip地址,该ip地址作为vlan 2内的电脑的网关

      R1(config-subif)#exit  # 退出F0/0.1接口

      R1(config)#interface fastEthernet 0/0.2  # 进入到F0/0.1接口

      R1(config-subif)#encapsulation dot1Q 3  # 将vlan3封装在F0/0.2接口

      R1(config-subif)#ip address 192.168.3.1 255.255.255.0  # 配置ip地址,该ip地址作为vlan3内 的电脑的网关。

     

    欢迎关注转发零基础学网络的小伙伴们,关注分享该WX Gongzhonghao:   华亿网络实验室  或  huayinetwork

    Gongzhonghao内免费下载资料及网络技术视频,及最新考试认证信息,持续分享干货网络技术!

    展开全文
  • 思科交换机不同vlan互通

    千次阅读 2022-01-10 15:03:37
    交换机实现不同vlan相互通信,基础网络知识

    思科交换机实现不同vlan互通实验

    【实验目的】

    在一台交换机上实现不同vlan相互通信

    【实验设备】

    网络设备: 交换机 * 1

    终端设备:PC 主机 * 2

    【实验规划】

    实现现vlan100与vlan200互通

    Vlan 100   IP :192.168.1.1/24

    Vlan 200   IP:192.168.2.1/24

    主机1   IP :192.168.1.100/24

    主机2   IP :192.168.2.100/24

    【实验配置】

    PC配置

    PC1:设备IP:192.168.1.100/24

                网关IP: 192.168.1.1

    PC2: 配置IP:192.168.2.100/24

    网关IP: 192.168.2.1

    交换机配置:

    vlan 100  

    vlan 200  --创建vlan

    int vlan 100

    no shut

    ip add 192.168.1.1/24

    int vlan 200

    no shut

    ip add 192.168.2.1/24 --vlan配ip地址

    interface FastEthernet0/1  

    switchport access vlan 100   

    interface FastEthernet0/10

    switchport access vlan 200 --给端口配vlan

    ip routing   --开启路由功能,实现不同vlan互通

    【实验结果】

     

    展开全文
  • 交换机配置信息如下交换机Asysname swa#vlan batch 10interface Vlanif1#interface Vlanif10ip address 192.168.10.1 255.255.255.0#interface Ethernet0/0/1port link-type accessport default vlan 10#interface ...

    交换机配置信息如下

    交换机A

    sysname swa

    #

    vlan batch 10

    interface Vlanif1

    #

    interface Vlanif10

    ip address 192.168.10.1 255.255.255.0

    #

    interface Ethernet0/0/1

    port link-type access

    port default vlan 10

    #

    interface GigabitEthernet0/0/1

    #

    interface GigabitEthernet0/0/2

    port link-type trunk

    port trunk allow-pass vlan 10

    #

    #

    ip route-static 192.168.30.0 255.255.255.0 192.168.10.254

    #

    交换机B

    sysname SWB

    #

    vlan batch 20

    #

    interface Vlanif1

    #

    interface Vlanif20

    ip address 192.168.20.1 255.255.255.0

    #

    interface Ethernet0/0/1

    port link-type access

    port default vlan 20

    #

    interface GigabitEthernet0/0/1

    #

    interface GigabitEthernet0/0/2

    port link-type trunk

    port trunk allow-pass vlan 20

    #

    ip route-static 192.168.30.0 255.255.255.0 192.168.20.254

    #

    交换机C

    sysname SWC

    #

    vlan batch 10 20 30

    interface Vlanif1

    #

    interface Vlanif10

    ip address 192.168.10.254 255.255.255.0

    #

    interface Vlanif20

    ip address 192.168.20.254 255.255.255.0

    #

    interface Vlanif30

    ip address 192.168.30.254 255.255.255.0

    #

    interface Ethernet0/0/1

    port link-type access

    port default vlan 30

    #

    interface GigabitEthernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 20

    #

    interface GigabitEthernet0/0/2

    port link-type trunk

    port trunk allow-pass vlan 10

    #

    展开全文
  • 通过三层交换机实现vlan间互通

    万次阅读 2017-11-21 21:34:21
    一、配置思科2960交换机 创建vlan Switch> Switch>enable Switch#vlan database Switch(vlan)#vlan 10 name vlan10 VLAN 10 added:  Name: vlan10 Switch(vlan)#vlan 20 name vlan20 VLAN 20 added:  
  • eNSP两台三层交换机不同VLAN互通

    千次阅读 2021-08-20 10:26:26
    拓扑图如上 1. PC设置IP PC15:192.168.10.10/24 网关:10.1 PC19:192.168.20.10/24 网关: 20.1 ...# vlan batch 10 20 # inter face vlanif 10 ip address 192.168.10.1 24 ip address 192.168.20.1...
  • 1 ,实验名称:二层交换机不同VLAN实现互通 (华为)2,实验环境:(1)PC1 PC2(2)二层交换机两台(3)三层交换机一台(路由功能)3,实验拓扑:2 配置步骤:(1)配置PC1:IP :192.168.10.1子网掩码:255.255.255.0网关:192...
  • 华三三层交换机vlan互通配置的坑

    千次阅读 2021-11-06 15:58:48
    开始配置交换机 可以先关闭stp,然后提前把网线都插上,也可以先不插,按照后边的步骤一步一步来 [H3C]undo stp global enable #这是关闭指令 [H3C]stp global enable #这是开启指令 用于电脑1 <H3C>sys [H3C...
  • 利用单个三层交换机实现不同vlan不同网段之间互通(华为和cisco) 版权声明:本文为CSDN博主「Yeliang Wu」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。 原文链接:...
  • 本次使用ensp模拟器模拟两台华为三层交换机如何配置不同网段不同vlan之间如何互通。网络拓补图如下图所示: IP地址如下: pc1:10.1.1.2 / 24 pc2 :10.1.2.2 / 24 pc3:192.168.1.2 /24 pc4:192.168.2.2 / 24 ...
  • 华为交换机:三层交换机实现vlan间通信 实验环境介绍 一、划分vlan并将相应的接口加入VLAN swh1配置 swh2配置 swh3配置 二、配置trunk并允许所有vlan通过 三、核心交换机swh4的配置 四、验证结果 实验环境介绍 一、...
  • 不同网段的设备之间如何互访?有朋友提到关于交换机如何实现不同网段的互访?这个交换机完全可以实现,在实际项目中,交换机实现不同网段的互访用的也比较多,那么今天我们一起来看下。
  • 花式方法解决不同vlan的主机互通

    千次阅读 2021-04-19 22:56:18
    在局域网内,我们会用 VLAN不同的用户、不同的部门、不同用途的区域进行分组,一个 VLAN 区分一组用户,便于管理和使用。 什么是 VLAN ?...如何实现不同 VLAN 的主机通信呢? VLAN 隔离二层
  • 通过配置三层交换机或路由器实现VLAN的通信,通过路由器实现vlan通信(单臂路由)在路由器与交换机的端口上配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为...通过路由器实现跨交换机vlan间通信。
  • 不同vlan互通交换机配置实验实验一:单台交换机上实现不同vlan互通实验二:两台台交换机上实现不同vlan互通1实验三:两台台交换机上实现不同vlan互通2 本文将通过三个实验来演示不同vlan互通的配置 实验一:单台...
  • 利用三层交换机的路由功能,通过识别数据包的IP地址,查找路由表进行选路转发,三层交换机利用直连路由可以实现不同VLAN之间的相互访问; 三层交换机给接口配置IP地址,采用SVI(交换虚拟接口)的方式实现VLAN间互连...
  • 在一台交换机中实现不同vlan不同网段相互通信 Pc1: Pc2: Sw1: <Huawei>system-view 1、创建vlan [Huawei]vlan 2 [Huawei-vlan2]quit [Huawei]vlan 3 [Huawei-vlan3]quit 2、进入接口配置 [Huawei]...
  • ensp模拟交换机不同VLAN不同网段之间互通
  • 拓扑图: Switch配置: Switch>enable 进入使能特权模式 Switch#config terminal 进入...ZSZZ(config-vlan)#vlan 20 创建vlan20 ZSZZ(config-vlan)#exit 退出当前模式 ZSZZ(config)#interface fastEtherne...
  • 之后在交换机1与交换机2之间vlan3不能通信,交换机2与交换机3之间vlan4不能通信。写出配置并解释 2012-12-26 12:11 上传 下载附件 (31.39 KB) 2.看下面的图,分析哪几个pc可能通信,那几个不能通信,并解释。 ...
  • Router的配置清单:[V200R003C00] system-view[Huawei]sysname Router[Router]vlan batch 100 200 300 999[Router]dhcp enable[Router]ip pool ForVlan100[Router-ip-pool-ForVlan100]network 192.168.10.0 mask 255...
  • 版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。 ... 一、试验拓扑 ...PC1和PC3属于VLAN 10 ,PC2和PC四属于VLAN 20,实现不同VLAN之间的相互通讯 三、试验过程...
  • 2、配置交换机LSW2 <Huawei>sys [Huawei]undo info-center enable [Huawei]vlan 2 [Huawei-vlan2]quit [Huawei]vlan 3 [Huawei-vlan3]quit [Huawei]int e0/0/1 [Huawei-Ethernet0/0/1]port link-type access ...
  • ·掌握通过三层交换机实现VLAN间通信的配置方法 ·掌握通过以太网Trunk链路实现VLAN间通信的配置方法 拓扑图 图1.4 三层交换实验拓扑图 场景 在企业网络中,通过使用三层交换机可以简便的实现...
  • H3C交换机VLAN间互访设置详解H3C CAS云计算管理平台可以为企业数据中心的云计算基础架构提供业界先进的虚拟化与云业务运营解决方案。下面是小编整理的关于H3C交换机VLAN间互访设置,希望大家认真阅读!一、组网需求...
  • 1.只使用Vlan的trunk接口和access接口实现两个二层交换机上属于不同Vlan的PC互通 port trunk pvid vlan 10 提前配置好IP地址及端口地址 LSW10配置: # sysname LSW10 # vlan batch 10 to 20 100 # interface ...
  • 利用三层交换机实现Vlan间互通PPT课件.pptx
  • 目录 前言 一、单臂路由技术 1、定义 2、技术方式 ... 单臂路由是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,654
精华内容 3,461
关键字:

不同交换机vlan间互通