精华内容
下载资源
问答
  • eNsp实验之EasyIP

    2021-01-09 19:37:21
    eNsp实验之EasyIP
  • NAT之Easy IP

    万次阅读 2019-10-29 17:34:13
    NAT之Easy IP 允许多个私网地址转换成一个公网IP,很常用 CAL用来做匹配范围时,没有默认隐含允许所有的规则 PC1(IP地址) IP地址:192.168.31.1 子网掩码:255.255.255.0 网关:192.168.31.254 PC2(IP地址) ...

    实验拓扑图:

    实验配置思路:

    1. 配置路由器接口的IP地址
    2. 出口的缺省路由
    3. 在R1上使用ACL匹配IP地址
    4. 在R1的出接口上应用ACL转换成公网IP地址
    5. 在这里插入图片描述
      内网私网地址出包时转换成公网接口G0/0/1当前的IP地址

    实验摘要重点命令:

    [R1]acl 2000     //配置ACL200
    [R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255     //允许192.168.1.X网段
    [R1-acl-basic-2000]quit     //退出
    [R1]interface g0/0/1     //进入接口
    [R1-GigabitEthernet0/0/1]nat outbound 2000     //当ACL2000应用于出接口转换为公网IP
    [R1-GigabitEthernet0/0/1]quit     //退出
    [R1]
    

    实验详细配置步骤:

    配置接口IP地址

    R1——配置接口IP地址

    <Huawei>system-view     //进入全局配置模式
    [Huawei]undo info-center enable     //关闭信息告警提示	
    [Huawei]sysname R1     //改名
    [R1]interface g0/0/0     //进入接口
    [R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24     //设置IP地址
    [R1-GigabitEthernet0/0/0]quit
    [R1]interface g0/0/1     //进入接口
    [R1-GigabitEthernet0/0/1]ip address 12.1.1.1 29     //设置IP地址
    [R1-GigabitEthernet0/0/1]quit
    [R1]
    

    R2——配置接口IP地址

    <Huawei>system-view     //进入全局配置模式 
    [Huawei]undo info-center enable     //关闭信息告警提示 
    [Huawei]sysname R2     //改名
    [R2]interface g0/0/0     //进入接口
    [R2-GigabitEthernet0/0/0]ip address 12.1.1.6 29     //设置IP地址
    [R2-GigabitEthernet0/0/0]quit     //退出
    [R2]int LoopBack 0     //进入环回接口
    [R2-LoopBack0]ip address 9.9.9.9 24     //配置IP地址
    [R2-LoopBack0]quit     //退出
    [R2]
    

    配置静态路由

    R1——配置去往外网公网的默认路由

    [R1]ip route-static 0.0.0.0 0 12.1.1.6     //默认路由
    

    配置ACL

    R1——配置ACL

    ACP匹配内网私网段地址
    ACL用来做匹配范围时,没有默认隐含允许所有的规则

    [R1]acl 2000     //配置ACL200
    [R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255     //允许192.168.1.X网段
    [R1-acl-basic-2000]quit     //退出
    

    调用ACL

    R1——调用ACL

    到外网口调用ACL

    内网的私网地址出包时转换成公网接口G0/0/1的IP地址

    [R1]interface g0/0/1     //进入接口
    [R1-GigabitEthernet0/0/1]nat outbound 2000     //当ACL2000应用于出接口转换为公网IP
    [R1-GigabitEthernet0/0/1]quit     //退出
    [R1]
    

    测试

    PC1——测试外网公网的9.9.9.9的路由

    PC>ping 9.9.9.9
    
    Ping 9.9.9.9: 32 data bytes, Press Ctrl_C to break
    Request timeout!
    From 9.9.9.9: bytes=32 seq=2 ttl=254 time=63 ms
    From 9.9.9.9: bytes=32 seq=3 ttl=254 time=47 ms
    From 9.9.9.9: bytes=32 seq=4 ttl=254 time=63 ms
    From 9.9.9.9: bytes=32 seq=5 ttl=254 time=47 ms
    
    --- 9.9.9.9 ping statistics ---
      5 packet(s) transmitted
      4 packet(s) received
      20.00% packet loss
      round-trip min/avg/max = 0/55/63 ms
    
    PC>
    

    PC2——测试外网公网的9.9.9.9的路由

    PC>ping 9.9.9.9
    
    Ping 9.9.9.9: 32 data bytes, Press Ctrl_C to break
    From 9.9.9.9: bytes=32 seq=1 ttl=254 time=63 ms
    From 9.9.9.9: bytes=32 seq=2 ttl=254 time=63 ms
    From 9.9.9.9: bytes=32 seq=3 ttl=254 time=78 ms
    From 9.9.9.9: bytes=32 seq=4 ttl=254 time=47 ms
    From 9.9.9.9: bytes=32 seq=5 ttl=254 time=62 ms
    
    --- 9.9.9.9 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/62/78 ms
    
    PC>
    
    展开全文
  • Easy IP 配置

    2020-06-27 16:56:53
    Easy IP 配置 4.1 问题 4.2 方案 搭建实验环境,如图-1所示。 图-1 4.3 步骤 实现此案例需要按照如下步骤进行。 1)pc配置 PC-1: 10.1.1.1 255.255.255.0 10.1.1.254 PC-2: 10.1.2.1 255.255.255.0 10.1.2....

    Easy IP 配置
    4.1 问题
    4.2 方案
    搭建实验环境,如图-1所示。

    在这里插入图片描述
    图-1

    4.3 步骤
    实现此案例需要按照如下步骤进行。
    1)pc配置

    PC-1:
      10.1.1.1
      255.255.255.0
      10.1.1.254
    PC-2:
      10.1.2.1
      255.255.255.0
      10.1.2.254
    PC-3:
      10.1.3.78
      255.255.255.0
      10.1.3.254
    

    2)sw配置

    [SW]vlan batch 10 20 30 66
    [SW]interface gi0/0/1
    [SW-GigabitEthernet0/0/1]port link access 
    [SW-GigabitEthernet0/0/1]port default vlan  10
    [SW-GigabitEthernet0/0/1]quit
    [SW]interface GigabitEthernet 0/0/2
    [SW-GigabitEthernet0/0/2]port link access
    [SW-GigabitEthernet0/0/2]port default vlan  30 
    [SW-GigabitEthernet0/0/2]quit
    [SW]interface GigabitEthernet 0/0/3
    [SW-GigabitEthernet0/0/3]port default vlan  66
    [SW-GigabitEthernet0/0/3]quit
    [SW]interface GigabitEthernet 0/0/4
    [SW-GigabitEthernet0/0/4]port default vlan  20
    [SW-GigabitEthernet0/0/4]quit
    
    [SW]interface Vlanif  10
    [SW-Vlanif10]ip address 10.1.1.254 24
    [SW-Vlanif10]quit
    [SW]interface Vlanif  20
    [SW-Vlanif20]ip address 10.1.2.254 24
    [SW-Vlanif20]quit
    [SW]interface Vlanif  30
    [SW-Vlanif30]ip address 10.1.3.254 24
    [SW-Vlanif30]quit
    [SW]interface Vlanif  66
    [SW-Vlanif6]ip address 10.1.66.1 24
    [SW-Vlanif6]quit
    [SW]ip route-static 0.0.0.0  0 10.1.66.254
    

    3)AR1配置

    [R1]interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/0]ip address 10.1.66.254 24
    [R1-GigabitEthernet0/0/0]quit
    [R1]interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/1]ip address  100.1.1.1 24
    [R1-GigabitEthernet0/0/1]quit
    [R1]ip route-static  0.0.0.0 0   100.1.1.2
    [R1]ip route-static  10.1.1.0 24 10.1.66.1
    [R1]ip route-static  10.1.2.0 24 10.1.66.1
    [R1]ip route-static  10.1.3.0 24 10.1.66.1
    

    4)AR2配置

    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]ip address 200.1.1.254 24
    [R2-GigabitEthernet0/0/0]quit
    [R2]interface GigabitEthernet 0/0/1
    [R2-GigabitEthernet0/0/1]ip address  100.1.1.2 24
    [R2-GigabitEthernet0/0/1]quit
    

    5)server配置

    Server-1:
      200.1.1.1
      255.255.255.0
      200.1.1.254
    

    6)AR1配置NAT (配置ACL)

    [R1]acl 2000
    [R1-acl-basic-2000]rule 10 permit  source  10.1.1.0 0.0.0.255
    [R1-acl-basic-2000]rule 20 permit  source  10.1.2.1 0.0.0.254
    [R1-acl-basic-2000]rule 30 deny    source  10.1.3.78 0.0.0.0
    [R1-acl-basic-2000]rule 40 permit  source  10.1.3.0 0.0.0.255
    [R1-acl-basic-2000]quit
    [R1]interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound 2000
    [R1]display  nat outbound
     NAT Outbound Information:
     --------------------------------------------------------------------------
     Interface                     Acl     Address-group/IP/Interface      Type
     --------------------------------------------------------------------------
     GigabitEthernet0/0/1         2000                      100.1.1.1    easyip  
     --------------------------------------------------------------------------
      Total : 1
    

    4)PC1/2/3测试与Server-1的互通性,如图-10所示
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    图-10
    分享方法
    根据终端设备配置ACL,然后再边界设备设置NAT

    展开全文
  • Easy ip 简单配置实验

    千次阅读 2019-11-04 23:02:37
    Easy ip 简单配置实验 实验topo: 配置前提须知: 配置nat的出口路由器必须使用AR 出口路由器上需要一条默认路由指向ISP 接口动态获取IP地址时,会自动获得一个默认路由指向ISP 接口动态获得IP地址也需要开启DHCP ...

    Easy ip 简单配置实验

    实验topo:

    在这里插入图片描述

    配置前提须知:

    1. 配置nat的出口路由器必须使用AR
    2. 出口路由器上需要一条默认路由指向ISP
    3. 接口动态获取IP地址时,会自动获得一个默认路由指向ISP
    4. 接口动态获得IP地址也需要开启DHCP

    实验配置:

    1. 配置接口:
    [chukou]
    dhcp enable  --开启DHCP
    interface GigabitEthernet0/0/0
     ip address 192.168.1.1 255.255.255.0
    interface GigabitEthernet0/0/1
     ip address dhcp-alloc  --接口动态获取ip地址
    
    [isp]
    interface Ethernet0/0/0
     ip address 200.200.200.200 255.255.255.0
     dhcp select interface
    interface Ethernet0/0/1
     ip address 200.1.1.1 255.255.255.0       
    
    1. ISP上配置接口DHCP给出口路由器下放IP地址
    DHCP enable
    interface Ethernet0/0/0
     dhcp select interface
    
    1. 配置ACL抓取流量:
    acl number 2000   --配置基本acl即可
     rule 5 permit source 192.168.1.0 0.0.0.255 
    
    1. 在出口路由器上做NAT:
    interface GigabitEthernet0/0/1
     nat outbound 2000  --在出接口
    

    实验结果测试

    PC1 PING ISP:
    在这里插入图片描述
    PC1 PING ISP内的主机:
    在这里插入图片描述

    代码(全配置) 如图配置后直接粘贴

    [chukou]
    [V200R003C00]
    #
    sysname chukou
    #
    dhcp enable
    #
    acl number 2000  
     rule 5 permit source 192.168.1.0 0.0.0.255 
    #
    interface GigabitEthernet0/0/0            
     ip address 192.168.1.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     nat outbound 2000
     ip address dhcp-alloc
    #
    
    <isp>dis cu
    #
    sysname isp
    #
    dhcp enable
    #
    interface Ethernet0/0/0
     ip address 200.200.200.200 255.255.255.0
     dhcp select interface
    #
    interface Ethernet0/0/1
     ip address 200.1.1.1 255.255.255.0       
    #
    
    展开全文
  • EASYIP/pat NAT

    2021-01-04 14:28:15
    所谓easyIP就是指多个私有IP转换成一个共有IP 第一种方法,portID(端口号):范围1-65535。 1.若数据是基于TCP/UDP,就说明有端口号,目标端口号若是10000,源端口号是20000,那么回来就是20000,以此类推。也就是将...

    所谓easyIP就是指多个私有IP转换成一个共有IP
    第一种方法,portID(端口号):范围1-65535。
    1.若数据是基于TCP/UDP,就说明有端口号,目标端口号若是10000,源端口号是20000,那么回来就是20000,以此类推。也就是将源端口号借过来用。因为端口号是随机的,如果端口号一样。那么第一个10000的人过来,若第二个也是10000,那么以此类推+1,但是在回来的时候会映射回10000。借用传输层的源端口号映射
    2.若为ping包(ICMP);以太网;IP:不能借用端口号的类型,基于IP封装里必须有一个字段,专门用来进行多对一的地址映射。用法与端口号类似。ICMP中就为LE字段:专门作为映射。若直接基于IP封装的,基于IP封装本身,必须有一个字段专门用来多对一的端口映射。

    ping包属于ICMP协议,ICMP协议是基于IP数据进行封装,所以在进行多对一的映射时,ICMP必须专门有一个字段(LE为5)用来一一对应的映射

    产生数据过程:OSI模型数据封装
    传输过程交换:路由技术(查表)
    接收数据过程:解封装过程

    展开全文
  • 华为设备配置Easy IP 地址转换

    千次阅读 2019-02-03 18:18:35
    2、配置easy IP 地址转换 3、地址映射 实验拓扑:   实验配置: [ar1]int g0/0/0 [ar1-GigabitEthernet0/0/0]ip add 192.168.1.254 24 [ar1-GigabitEthernet0/0/0]un shu [ar1]int g0/0/2 [ar1-...
  • 1.私网用户通过Easy IP访问Internet 二、注意事项 1.easy-ip 没有 Server-map 表 三、Easy IP(出接口地址方式) 1.出接口地址方式是利用出接口的公网 IP 做源 NAT 转换。同时转换 IP 和端口 四、简单配置 sysname ...
  • 华为 eNSP easy ip转换实验+NAT服务器

    千次阅读 2020-09-13 16:29:01
    一、Easyip转换实验 Easy ip——允许将多个内部地址映射到网关出接口地址上的不同端口 基础拓扑图,如下: AR1 system-view int g0/0/2 ip add 192.168.1.254 24 int g0/0/0 ip add 202.10.10.1 29 ip route-...
  • 华为综合实验(EasyIP、RIP、OSPF)一:实验环境二:实验拓补图三:实验需求四:实验步骤 一:实验环境 ENSP 二:实验拓补图 三:实验需求 实现全网互通 四:实验步骤 配置R5 配置R4 配置R3 配置R2 配置SW1...
  • NAT中关于easy ip配置的一些问题

    千次阅读 2018-02-19 11:05:59
    EASY ip的简单配置案例 一.拓扑图是上面配置的那个,右边为公网,左面为私网。首先先配置公网路由器IP以及PC的IP和网关。之后再运行OSPF,使得公网可以互通。R3配置: ...
  • 动态NAT3.NAPT4.easy IP5.NAT的特性二:NAT实验配置详解2.1:实验环境2.2:实验拓扑图2.3实验步骤与配置2.4实验总结:如图所示,实验成功,通过NAT技术,确实可以实现私网和公网之间的通信,以及缓解IPV4地址短缺的...
  • 目录一、实验需求1.1需求一1.2需求二1.3需求三二、实验环境三、实验步骤3.1 配置SW23.2 配置 SW33.3 配置SW13.4 配置R...●要求PC1、PC2、PC3、PC4通过Easyip可以ping通PC5。 1.3需求三 ●要求云服务器通过“NAT server
  • 静态NAT、动态NAT以及EasyIP 静态NAT实验拓扑图 实验步骤 sw1 <Huawei>sys [Huawei]sysname SW1 [SW1]vlan batch 10 20 30 40 Info: This operation may take a few seconds. Please wait for a moment......
  • 一、网络拓扑图二、实验步骤:1、搭建拓扑图,规划好内网和外网的IP,以及PC机的IP地址和网关。2、按照上图配置好路由器上的IP,以及PC机的IP和路由,并在内网路由上配置一条通往外网的默认路由条目。3、验证PC1与PC...
  • display nat :显示nat 信息 debugging nat :对nat进行调试 reset nat session:擦除nat连接配置 ...easy ip:出接口无法预合 nat server:公网->私网(主动连接) basic-nat 搭建好拓扑...
  • Easy IP 如何配置?

    千次阅读 2020-04-08 22:22:30
    --- Interface Acl Address-group/IP/Interface Type -------------------------------------------------------------------------- GigabitEthernet0/0/1 2000 100.1.1.1 easyip --------------------------------...
  • 2.3.3 配置AR2:2.3.4 配置云终端2.4 实验验证2.5 外网绑定内网三、实验总结3.1 静态NAT3.2 动态NAT3.3 EasyIP3
  • 文章目录一、实验环境二、实验目的2.1 实验目的12.2 实验目的22.3 实验目的3三、...R3上引路由3.14 在R2上配置EasyIP并映射出去3.15 配置R1三、实验验证3.1 验证目的13.2 验证目的23.3 验证目的3 一、实验环境 5台交
  • 目录一、前言二、学习目标三、NAT应用场景四、静态NAT五、动态NAT六、Easy IP七、NAT服务器八、实验配置8.1 实验要求8.2 配置操作8.2 验证 一、前言 随着Internet的发展和网络应用的增多, IPv4地址枯竭已经成为制约...
  • 公司路由器外部接口G0/0/2是动态IP,要求内部网络10.1.1.0/24利用外部接口G0/0/2上网(访问Server3)。 搭建实验环境 实现此案例需要按照如下步骤进行。 acl 2000 rule 5 permit source 10.1.1.0 0.0.0.255 int g0...
  • 将某公司内部的主机通过配置单臂路由、OSPF、RIP、引入路由、Easy IP技术来实现公司内部网络能够访问互联网。 ●实验拓扑图 在华为模拟器中新建如下图所示拓扑图 ●实验步骤 1.路由器R1配置 interface GigabitEther

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 36,176
精华内容 14,470
关键字:

easyip