精华内容
下载资源
问答
  • MUX VLAN

    万次阅读 多人点赞 2018-05-21 13:14:48
    MUX VLAN简介: 产生背景: MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。 例如,在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,希望企业内部员工之间可以...

    MUX VLAN简介:

    产生背景:

    MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。

    例如,在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,希望企业内部员工之间可以互相交流,而企业客户之间是隔离的,不能够互相访问。

    为了实现所有用户都可访问企业服务器,可通过配置VLAN间通信实现。如果企业规模很大,拥有大量的用户,那么就要为不能互相访问的用户都分配VLAN,这不但需要耗费大量的VLAN ID,还增加了网络管理者的工作量同时也增加了维护量。

    通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相交流,而企业客户之间是隔离的。

    基本概念:

    MUX VLAN分为主VLAN和从VLAN,从VLAN又分为隔离型从VLAN和互通型从VLAN。

    • 主VLAN(Principal VLAN):Principal port可以和MUX VLAN内的所有接口进行通信。
    • 隔离型从VLAN(Separate VLAN):Separate port只能和Principal port进行通信,和其他类型的接口实现完全隔离。
      每个隔离型从VLAN必须绑定一个主VLAN。
    • 互通型从VLAN(Group VLAN):Group port可以和Principal port进行通信,在同一组内的接口也可互相通信,但不能和其他组接口或Separate port通信。
      每个互通型从VLAN必须绑定一个主VLAN。

    配置MUX VLAN:

    配置注意事项:

    • 如果指定VLAN已经用于主VLAN或从VLAN,那么该VLAN不能再用于创建VLANIF接口,或者在VLAN Mapping、VLAN Stacking、Super-VLAN、Sub-VLAN的配置中使用。
    • 禁止接口MAC地址学习功能或限制接口MAC地址学习数量会影响MUX VLAN功能的正常使用。
    • 不能在同一接口上配置MUX VLAN和接口安全功能。
    • 不能在同一接口上配置MUX VLAN和MAC认证功能。
    • 不能在同一接口上配置MUX VLAN和802.1x认证功能。
    • 当同时配置DHCP Snooping和MUX VLAN时,如果DHCP Server在MUX VLAN的从VLAN侧,而DHCP Client在主VLAN侧,则会导致DHCP Client不能正常获取IP地址。因此请将DHCP Server配置在主VLAN侧。
    • 接口使能MUX VLAN功能后,该接口不可再配置VLAN Mapping、VLAN Stacking。

    配置MUX VLAN:

    拓扑:

    PC1,2为组VLAN,组内成员可以实现互通,同时可以与主VLAN互通,而与隔离VLAN不能互通。

    PC3为主VLAN成员,可以与所用组VLAN和隔离VLAN内所有成员通信。

    PC6,7属于隔离VLAN组,隔离VLAN内成员不能互相通信,只能与主VLAN内成员通信。

    这里写图片描述

    图:MUX VLAN拓扑图

    配置命令:

    <SW>dis current-configuration 
    #
    sysname SW
    #
    vlan batch 10 20 30
    #
    vlan 10
     mux-vlan //配置vlan10位 MUX valn
     subordinate separate 30 //配置隔离型从VLAN
     subordinate group 20 //配置互通型从VLAN
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 20
     port mux-vlan enable //使能接口的MUX VLAN功能。
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 10
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 30
     port mux-vlan enable
    #
    

    配置跨设备MUX VLAN示列:

    在企业网络中,企业希望某些部门之间的员工是互相隔离的,某些部门之间的员工是可以互相访问的,并且所有部门的员工都可以访问公司的某些服务器。

    为了解决上述问题,可在设备上部署MUX VLAN功能。将企业服务器划分在主VLAN内,需要互相访问的部门员工划分在互通型从VLAN内,需要互相隔离的部门员工划分在隔离型从VLAN内,即可解决上述问题,且不会耗费大量的VLAN ID。

    拓扑需求:

    如下图所示,PC1,2和PC5,6是连接在不同交换机上的主机,属于同一个VLAN3,VLAN3为组VALN。

    PC3,4 和PC 7,8是连接在不同交换机上的主机,属于同一个VLAN4,VLAN4为隔离VALN。

    PC9为交换机SW1上的一台服务器A,PC10为交换机SW2上的一台服务器B。PC9,10同属于VLAN2,VLAN2为主VLAN。

    这里写图片描述

    图: 跨设备MUX VLNA通信

    配置命令行:

    SW1和SW2配置完全相同。

    <SW1>dis current-configuration 
    #
    sysname SW1
    #
    vlan batch 2 to 4
    #
    vlan 2
     mux-vlan
     subordinate separate 4
     subordinate group 3
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 3
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 3
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 4
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 4
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 2
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/6
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    

    注意:ensp模拟器上暂时不支持port mux-vlan enable vlan 3,该命令。当mux vlan跨设备是,需要在交换机互联接口trunk上配置,port mux-vlan enable vlan 3 。开启trunk上的mux vlan。一般部署在汇聚层。
    上面的实验中,不能配置这条命令。所以跨设备的隔离vlan也是可以通信的。例如PC3和PC7可以通信。


    参考文档:华为HedEx文档


    展开全文
  • MUX Vlan

    2021-04-03 08:53:51
    MUX Vlan MUX Vlan技术产生的背景 vlan技术所实现的是:处于同一vlan下设备之间的通信。实际应用中会出现另外一种需求,需要不同vlan间实现通信或者同一Vlan下限制不能通信。因此,基于需求的多样性,从而诞生出 MUX...

    MUX Vlan

    MUX Vlan技术产生的背景

    vlan技术所实现的是:处于同一vlan下设备之间的通信。实际应用中会出现另外一种需求,需要不同vlan间实现通信或者同一Vlan下限制不能通信。因此,基于需求的多样性,从而诞生出 MUX Vlan 技术,来实现不同Vlan之间和同一Vlan之间的各种通信需求。

    MUX Vlan技术,用于解决什么需求

    • MUX Vlan技术解决的需求:实现不同Vlan之间的通信或者限制同一Vlan下的设备不能通信*

    MUX Vlan技术的通信原理,以及如何实现

    • 主Vlan (Principal Vlan)

    加入主Vlan(Principal Vlan)的接口,它们和MUX Vlan内所有的接口都可进行通信。

    • 从Vlan (Subordinate Vlan)

    Subordinate Vlan分为两种,一种是互通型Subordinate Vlan(Group Vlan),另外一种是隔离型Subordinate Vlan(Separate Vlan)。每个Group Vlan 和 Separate Vlan 都必须与一个 主Vlan(Principal Vlan) 绑定

    加入Group Vlan 的接口可以和主Vlan以及属于同一个Group Vlan的用户之间进行通信,而属于不同Group Vlan 下的用户则不能通信,另外,Group Vlan 也无法与 Separate Vlan 进行通信。

    加入Separate Vlan 的接口只能与主Vlan(Principal Vlan) 进行通信,而无法与其他类型的接口进行通信(包括同属于一个Separate Vlan 下的其他接口)

    实际案例

    如图:
    在这里插入图片描述

    要求:

    (1)部门A的员工之间可互相通信,部门B的员工之间可互相通信。但部门A的员工和部门B的员工之间不可通信。

    (2)部门A成员和部门B成员都可访问公共服务器

    (3)访客部门C的任意PC只能访问公共服务器,不能访问其他任何设备,包括其他访客PC

    实现演示步骤:

    (1) 批量创建Vlan
    vlan batch 100 101 102 109
    (2)配置MUX Vlan中的Group Vlan 和 Separate Vlan
    vlan 100
    mux-vlan
    subordinate group vlan 101 102
    subordinate separate vlan 109
    quit
    (3)配置接口加入Vlan,并且使MUX Vlan 开启
    interface g0/0/1
    port link-type access
    port default vlan 100
    port mux-vlan enable
    quit

    其他接口加入Vlan的步骤同上

    (4)完成上述配置后可以检验一下
    display mux-vlan
    在这里插入图片描述显示如此,则配置成功
    (5)检查通信情况
    PC1 IP:1.1.1.101
    PC2 IP:1.1.1.102
    PC3 IP:1.1.1.203
    PC4 IP:1.1.1.204
    PC5 IP:1.1.1.5
    PC6 IP:1.1.1.6
    服务器 IP:1.1.1.100

    Start:

    检验同一部门之间是否可通信
    A部门员工之间可互相通信

    检验不同部门之间是否可通信
    在这里插入图片描述在这里插入图片描述

    检验A/B部门员工是否可以与公共服务器通信
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

    检验访客与服务器和访客之间的通信
    在这里插入图片描述

    展开全文
  • Mux VLAN

    2021-08-04 10:16:42
    什么是Mux VLAN 简单来说就是通过Mux VLAN来做到VLAN内的隔离。把一个VLAN拆分成主VLAN与子VLANVLAN principole Vlan ,这个是对外显示的VLAN,类似于BGP联邦的概念 mux vlan 不支持创建svi接口 子VLAN 通过...

    什么是Mux VLAN

    简单来说就是通过Mux VLAN来做到VLAN内的隔离。把一个VLAN拆分成主VLAN与子VLAN

    主VLAN

    principole Vlan ,这个是对外显示的VLAN,类似于BGP联邦的概念
    mux vlan 不支持创建svi接口

    子VLAN

    通过子vlan可以把主vlan划分为若干个vlan,这若干vlan彼此隔离,但都能与主vlan的成员互通
    子vlan又分为Group vlan与separate vlan
    Group vlan----组VLAN

    可以与主vlan成员以及自身所属子vlan内的成员通信

    Separate vlan ---- 隔离vlan

    该vlan内的成员可以与主vlan成员通信,但不能与自身所属子vlan成员通信

    拓扑

    在这里插入图片描述

    PC1与PC2属于子VLAN内的组vlan 成员
    PC3与PC4属于子VLAN内的隔离vlan成员
    server 1 是主vlan内的成员
    要求

    pc1能与pc3、server1通信
    pc3能与server 1通信,但不能与其他pc通信

    先配置PC与Server的IP地址,这里不做演示

    交换机

    先创建三个vlan 10 2000 2001

    vlan batch 10 2000 to 2001
    

    vlan 10设置为主vlan,并设置vlan 2000与vlan 2001为子vlan 的组vlan 与 隔离vlan

    vlan 10
     mux-vlan
     subordinate separate 2001
     subordinate group 2000
    

    接口绑定设置

    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 2000
     stp edged-port enable     //启用边缘端口特性
     port mux-vlan enable      //接口启用mux-vlan
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 2000
     stp edged-port enable
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 2001
     stp edged-port enable
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 2001
     stp edged-port enable
     port mux-vlan enable
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 10
     stp edged-port enable
     port mux-vlan enable
    

    检测

    pc1 ping pc2、pc3、serever 1
    应达到要求:pc2 通 、server 1通、pc2,pc3不通

    在这里插入图片描述
    在这里插入图片描述

    pc3 ping server 1、pc1、pc2、pc4
    要求:server 1通、其他不通
    在这里插入图片描述

    展开全文
  • mux vlan

    2021-04-02 21:48:11
    配置思路:将划分4个vlan,财务部属于vlan10【组vlan】,市场部属于vlan20【组wlan】,外来访客属于vlan30【隔离vlan】server属于vlan40【组vlan】(配置之前可以理解mux vlan的原理) 步骤:1、端口的access\trunk...

    问题:公司内部员工(财务部、市场部)可以访问server,外来访客可以访问server,外来访客不能互通,外来访客不能与企业员工互通。

    配置思路:将划分4个vlan,财务部属于vlan10【组vlan】,市场部属于vlan20【组wlan】,外来访客属于vlan30【隔离vlan】server属于vlan40【组vlan】(配置之前可以理解mux vlan的原理)

    步骤:1、端口的access\trunk配置

    2、划分vlan

    3、配置好主机的ip地址【同网段全网通】------配置好后,全部主机之间能通信

    4、配置mux vlan,启动端口mux vlan 

    5、测试成功即可

     

     

     

    【不成功可以·在评论留言,一起探讨】

     

     

     

    展开全文
  • VLAN特性 聚合、MUX VLAN、QinQ、映射

    万次阅读 多人点赞 2020-07-24 13:37:56
    文章目录一、VLAN聚合二、MUX VLAN三、QinQ四、VLAN Mapping五、拓扑六、基本配置与分析七、设备完整配置 VLAN特性 映射、聚合、MUX VLAN、QinQ;DHCP,DHCP中继,NAT,ACL。 一、VLAN聚合 聚合VLAN产生的背景: ...
  • 今天给大家介绍MUIX VLAN的相关理论知识,同时使用华为...MUX VLAN存在主VLAN(Subordinate VLAN)、隔离性VLAN(Separate VLAN)、**互通性VLAN(Group VLAN)**三种类型的VLAN。其中隔离性VLAN和互通型VLAN又被称为从
  • MUX VLAN 原理与实验

    2021-04-11 19:10:17
    MUX VLAN 原理与实验MUX VLAN目的MUX VLAN原理实验实验配置 MUX VLAN目的 对不同的用户实现网络隔离 节约VLAN 项目如果都使用VLAN的方式进行隔离,可能会因为VLAN的数量多少受到限制 MUX VLAN原理 MUX VLAN包括两个...
  • MUX VLAN笔记

    2020-02-22 16:43:12
    【】MUX VLANVLAN、从VLAN(互通型、隔离型) 配置: 配置主从VLANvlan 100 mux-vlan //主VLAN subordinate group 10 20 //互通型从vlan subordinate separate 30 //隔离型从vlan ...
  • 华为MUX VLAN原理和实验

    千次阅读 2020-12-12 20:38:25
    MUX VLAN也包括了两个类型的vlan,也就是主vlan和从vlan,跟VLAN聚合的规划有些相似,但是从vlan又划分为两种类型(隔离型从vlan和互通型从vlan)。 其中主端口可以和MUX VLAN内的所有端口进行通信;隔离型从v
  • MUX VLAN基础配置

    2021-04-05 22:23:54
    mux-vlan #将当前VLAN指定为Principal VLAN subordinate group 101 102 #指定当前VLAN指定为Group VLAN subordinate separate 109 #指定当前VLAN的Separate VLAN quit #配置接口加入VLAN并使能MUX VLAN功能 int E0...
  • MUX VLAN配置

    2017-11-03 14:10:16
    7.1 MUX VLAN简介产生背景MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。例如,在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,希望企业内部员工之间可以互相交流,...
  • Mux VLAN配置

    2019-08-07 09:54:59
    MUX VLAN 提供了一种在VLAN的端口间进行二层流量隔离的机制 group 可以互访 separate不能互访 先配置好每个设备的ip地址 进入交换机配置 [Huawei]vlan bat 10 20 100 [Huawei]vlan 100 [Huawei-vlan100]subordinate...
  • MUX VLAN配置实现

    2020-02-21 19:40:40
    MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相通信,而企业外来访客之间的互访是隔离的。 为了实现报文之间的二层隔离...
  • 华为 MUX VLAN

    万次阅读 2014-01-21 11:25:35
    MUX VLAN  MUX VLAN介绍- 基本概念 作用:MUX VLAN(Multiplex vlan )提供了一种在VLAN内的端口间进行二层流量隔离的机制。 需求:在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,...
  • 1.配置MUX VLAN 二、注意事项 1.一个主VLAN下,只能配置一个隔离型从VLAN 2.在同一个主VLAN下,隔离型从VLAN和互通型从VLAN,的VLAN ID不能相同 3.在MUX VLAN中,所有终端设备连接的交换机端口必须以是access类型或...
  • MUX VLAN(Multiplex VLAN

    2019-06-11 14:31:09
    MUX VLAN简介: 产生背景: MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。 例如,在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,希望企业内部员工之间可以互相...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 793
精华内容 317
关键字:

muxvlan