精华内容
下载资源
问答
  • 级联网络

    千次阅读 2019-10-21 16:39:14
    级联 (计算机科学) 级联(cascade)在计算机科学里指多个对象之间的映射关系,建立数据之间的级联关系提高管理效率 中文名 级联 外文名 Cascade 类型 映射关系 另指 用来设计一对多关系 重复性的操作十分...

    目录

    级联

    mtcnn级联人脸检测网络

     


    级联

    级联(cascade)在计算机科学里指多个对象之间的映射关系,建立数据之间的级联关系提高管理效率

    中文名  级联

    外文名  Cascade

    类    型  映射关系

    另    指  用来设计一对多关系

    重复性的操作十分烦琐,尤其是在处理多个彼此关联对象情况下,此时我们可以使用级联(Cascade)操作。级联 在关联映射中是个重要的概念,指当主动方对象执行操作时,被关联对象(被动方)是否同步执行同一操作。

    级联还指用来设计一对多关系。例如一个表存放老师的信息:表A(姓名,性别,年龄),姓名为主键。还有一张表存放老师所教的班级信息:表B(姓名,班级)。他们通过姓名来级联。级联的操作有级联更新,级联删除。 在启用一个级联更新选项后,就可在存在相匹配的外键值的前提下更改一个主键值。系统会相应地更新所有匹配的外键值。如果在表A中将姓名为张三的记录改为李四,那么表B中的姓名为张三的所有记录也会随着改为李四。级联删除与更新相类似。如果在表A中将姓名为张三的记录删除,那么表B中的姓名为张三的所有记录也将删除。

    mtcnn级联人脸检测网络

    论文名称:Joint Face Detection and Alignment Using Multitask Cascaded Convolutional Networks

    论文地址:https://arxiv.org/abs/1604.02878

    这是个人写的第一篇论文解读,如有考虑不到或者解释不清楚的地方,请在下方留言。

    摘要:
    简单来说,作者提出了一种使用三个卷积网络做级联,来检测人脸区域和人脸的5个关键点检测。同时,提出了一种新的online hard sample mining 训练技巧来提高模型的判别能力。

    模型结构:


    三个级联网络分别是pnet,rnet,onet。pnet采用全卷积结构,最后一部分是三个兄弟层,分别完成人脸分类,人脸框回归,和人脸关键点检测三个任务。另外两个网络的结构大致相似,只是在网络的后端使用全连接层。同时三个网络的在训练的时候的输入大小不一样。除了输出层,激活函数使用Prelu。

    损失函数:
    每个网络都有三个任务:分类,定位,关键点定位。所以每个网络都有三个损失函数,也就是多任务学习(Multi-task),MTCNN因此得名。

    对分类任务而言,因为是二类分类,即仅仅判断是否是人脸区域,所以损失函数使用二类交叉熵(Binary Cross Entropy)。 

    对于框回归任务而言,网络得到的结果不是框的坐标。我们知道,一个框能用四个数字表示它的位置,即左上角的x,y坐标,框的width,height,这四个参数。为了将获得位置信息变成一个回归问题,我们希望网络学到的是产生的框和Ground Truth的偏置距离,框回归的标签就不应该是以上描述一个框位置的那四个参数,而是样本框的左上角坐标和右下角坐标相对于GT左上角的坐标和右下角坐标的偏置比例。如果没接触过什么是偏置比例,强烈推荐看下rcnn的那篇论文,即RCNN系列的第一篇。

    框回归任务直接使用欧式距离作为损失函数。

    对于人脸的关键点检测任务而言,也同样使用欧式距离作为损失函数。

    总的损失函数的设计如下:

    det只的是分类任务,box指的是框回归任务,landmark指的是关键点检测任务。N是一个min-batch的数目。aj是这三类任务的控制参数,这三个参数哪一个大,说明网络对于对应的任务就更加看重。

    如文中写道,aj描述了任务的重要性,以及训练不同网络的参数设置是如何的。另外是一个很重要的参数,下标i是说,对应batch中的某一个样本,上标j是说,对于某一类任务。这个参数的取值是0或者1。也就是说,对于一个样本xi,当且仅当分类任务对xi的判断结果是阳性,才是1,否则为0。也就是说,框回归任务和关键点检测任务只在分类结果为阳性的时候才会加入训练。

    训练数据的制作:
    论文使用的人脸检测的数据集是WIDER FACE,对关键点检测使用的数据集是CelebA。

    第一步

    从WIDER FACE中随机crop出样本,判断样本的GT的IOU,如果IOU大于0.65,则得到一个正样本;如果IOU大于0.45,则得到一个part样本;如果IOU小于0.3,则得到了一个负样本。IOU在0.3-0.45之间的样本,被认为是不重要的,没有学习价值的样本。

    对分类任务使用正样本和负样本,对框回归任务使用正样本和part样本,对关键点检测直接使用CelebA的标签再加上处理成偏置比例即可。

    第二步

    从用上一步得到的数据训练pnet,将WIDER FACE中的整张图片送入pnet,得到了结果再和GT计算IOU,同样用上面的方式采集正负样本和part样本,作为对onet训练的数据集。

    第三步

    同第二步的思路。

    以上三步得到的数据都要resize到所训练网络的输入大小。

    训练技巧:
    使用了online hard sample mining。思路是对一个batch的loss值进行排序,只对前70%最大的loss值计算梯度。

    作者认为,这样做可以忽略对检测器不太有帮助的样本,而更加注重那些难分类,难学习的样本,对它们进行学习。

    (不过我不太明白为啥作者是这是一种全新的online hard sample mining,因为传统的不也是这样做吗!!!)

    测试:
    作者考虑到了多尺度问题,因此在输入图像之前,做了一个图像金字塔。总过程如图所示:

     

    展开全文
  • Proposal, Tracking and Segmentation (PTS) - 用于视频对象分割的级联网络
  • 级联网络和金字塔光流的旋转不变人脸检测.pdf
  • 基于级联网络和残差特征的人脸特征点定位
  • 介绍了一种由三级级联网络构成的取样器,论述了分式线性变换级联网络分解法,并利用奇偶模法计算被测材料的复电磁参数。该方法适用于糊状及粉末状材料电磁参数的测量。给出了多种材料测量实例和数据,并根据不同测量...
  • 改进堆叠级联网络在脑肿瘤分割的研究与实现[摘要] 众所周知,深度学习的方法己经广泛地被应用到图像处理领域,其中以Unet为代表的全卷积网络己被广泛用于医学图像分割领域,它曾是2015年获得ISBI细胞追踪挑战赛冠军...
  • 张量流的多步骤级联网络用于脑肿瘤分割 这是我们在Python3,tensorflow和Keras上的BraTS2019论文实现。 整个肿瘤....................................肿瘤核心......................增强肿瘤 拟议方法的示意图 ...
  • 本文是递归级联网络和 VTN 网络论文,及其代码的一些解读。 一、递归级联网络 递归级联网络论文地址:递归级联网络论文 1. 前人工作 之前的工作尝试通过对一些现有网络进行堆叠来建模的,但是每一层网络的输入和...

    本文是递归级联网络和 VTN 网络论文,及其代码的一些解读。

    一、递归级联网络

    递归级联网络论文地址:递归级联网络论文

    1. 前人工作

    之前的工作尝试通过对一些现有网络进行堆叠来建模的,但是每一层网络的输入和任务各不相同,并且是对每一层依次单独训练的(先训练之前的层,将之前层的参数固定下来后再训练后面的层),每一层都会计算 warped image 和 fixed image 之间的相似性损失,这导致了当堆叠到很少层(大约3层)之后,实际效果就不再有任何提升了。

    这是因为复杂变形场一般有着较大的位移,所以网络直接预测复杂的形变场不易实现,同时逐层训练的网络结构中,每一层都是各学各的,所以无论怎么级联,都很难达到很好的效果。

    2.递归级联网络

    递归级联网络是一个端到端的无监督模型,理论上它可以基于任意网络来做,当模型的级联的层数越多时,模型的效果越好。

    上图是用递归级联网络对肝脏 CT 数据进行配准的示意图,moving image 通过每一层后不断的产生扭曲,最终对齐到 fixed image。图中的 ϕk\phi_k 表示一个预测流场(predicted flow field)。

    对于递归级联网络中“递归”和“级联”的含义,我的个人理解是,级联就是把多个子网络串联起来形成一个级联块,这些子网络可相同,也可不同。而递归就是把级联块重复的使用多次,并且所有级联块具有相同的参数。

    RCN2

    上图是递归级联网络的结构示意图。

    递归级联网络的每一层的输入都是经过前几层处理后的图像(warped image)和固定图像(fixed image),并且舍弃了逐层训练的方式,而是采用联合训练的方式,只在最后一层来计算 warped image 和 fixed image 之间的相似度,通过反向传播更新前面的所有层。这样一来,每一层只需要学习简单的变形场,所有层级联之后就达到很好的效果。

    文章中递归级联网络所使用的基础网络是 VTN 和 VoxelMorph,前者占用的显存更少。文章建议在级联时第一个网络是仿射网络(affine network),也就是级联时第一个网络为仿射网络,后面跟着若干其他子网络。

    每个子网络会根据输入的 fixed image 和 warped image 来预测一个变形流场(deformable flow field),每一层的子网络可以相同,也可以不同,方便起见一般会选择相同的子网络。

    图像重采样使用的是(多)线性插值,在超出原图边界的采样点上使用最近点插值。

    参数共享级联,即递归。本文提出的递归结构有两种形式,即假设一共有 nn 个级联块,第一种递归形式是把这 nn 个级联块重复使用两次,因此就得到了 2n2n 个级联块。第二种递归形式是把每个级联块就地使用 rr 次,那么就得到了 rnrn 个级联块。举例来说,比如级联块是 ABCD,若重复三次,则第一种方式的结果为 ABCDABCDABCD,第二种的结果为 AAABBBCCCDDD。后者的效果更好。训练的时候为了节省显存开支没有使用递归,在测试的时候才用。

    二、VTN

    VTN 论文地址:VTN 论文

    VTN 是 Volume Tweening Network 的缩写,其论文发表时间和递归级联网络几乎一致,给我的感觉是作者做了一次实验,发了两篇论文。VTN 论文中没有单独给出 VTN 网络的代码,而是给出了递归级联网络的 github 地址(见第三部分)。

    VTN 是一种基于无监督的学习方法的端对端网络框架,用来进行 3D 医学图像的配准。有三个创新点:

    • 端对端的级联方案,这是为了解决大尺度变形的问题
    • 有效的结合了仿射配准网络
    • 使用一个额外的可逆性损失(invertibility loss)来鼓励后向一致性(backward consistency)

    VTN 网络是在光流估计(Optical flow estimation)和 STN(Spatial Transformer Networks) 的基础上做的,前者是为了识别在同一场景不同角度的两张图片中像素点之间的相关性;后者是为了学习一个定位网络来产生一个合适的变换以拉直输入图片。
    VTN
    上图是 VTN 级联的示意图,其中配准子网络用来寻找 fixed image 和当前 moving image 之间的变形场,fixed image 还会和当前 moving image 产生一个相似性损失来指导训练,有颜色的实线表示损失是怎么计算的,有颜色的虚线表示梯度是怎么反向传播的,因为每一层都可微,所以当前层产生的梯度可以传播到之前的所有层。

    VTN 是由多个子网络级联而成的,每个级联的子网络可以产生一个变换来让 moving image 和 fixed image 对齐。当前层只根据前一层的输出(warped image)和 fixed image 来产生变换(transform),而前人所提出的网络除了上述两个输入,还要输入最初的 moving image。这种级联子网络的想法来自于 FlowNet 2.0。VTN 网络的结构包括仿射(affine)配准和可变形(deformable)配准两个过程,一般是一个仿射配准网络,后面跟多个可变形配准网络。此外还加入了可逆性损失来鼓励后向一致性,以达到更高的精度。

    affine

    上图是仿射配准网络的示意图,其中四边形上方是通道数,四边形越大表示分辨率越高。

    仿射配准子网络用仿射变换来对齐输入图像(fixed image and moving image),它只被用作第一个子网络。仿射配准网络的卷积部分和下面的密度可变形网络的编码器部分是一模一样的,在一系列卷积操作后是一个全连接层,以形成一个仿射流场,即一个 3×33\times3 的转换矩阵 A 和一个 3 维的位移向量 b。应该是对应旋转和平移操作中的参数。
    dense
    上图是密度可变形网络的示意图,其中从卷积到反卷积的连线即跳跃连接。

    密度可变形(dense deformable)配准子网络用作所有的后续子网络,其目的是让配准更加完善,它采用编码器-解码器结构,并且使用跳跃连接,该子网络会输出一个密度流场(dense flow field)和一个3通道的体积特征图(volume feature map)。


    就递归级联网络和 VTN 网络的论文来看,两者的表述是有点矛盾的;从递归级联网络的代码来看,VTN 网络指的只是上述中的密度可变形网络,而递归级联网络则是一个仿射配准网络后面跟上多个 VTN 网络(密度可变形网络)。此外,递归级联网络的论文中说只有在最后一层才计算 warped image 和 fixed image 之间的相似性损失,而在 VTN 的论文中(VTN 的网络示意图中),是每层都计算相似性损失的。

    三、代码

    递归级联网络代码的github地址:递归级联网络

    代码中文件的调用结构如下:

    RCN

    VTN 网络的结构:

    VTN-structure

    VTNAffineStem 网络的结构和 VTN 网络中前半部分的卷积(conv1~conv6_1)相同,在此之后是一个全连接层将输出转化为一个 3×33\times 3 的转换矩阵 A 和一个 3 维的位移向量 b。

    在 VTNAffineStem 的代码中,除了一系列卷积和全连接操作之后,还有一些代码,数学系的师兄说其作用是正交约束,师兄给出的推导过程如下:

    假设 A2=C=[cij]A^2=C=[c_{ij}] 具有三个特征值 k1,k2,k3k_1,k_2,k_3,希望它们均接近 1 等价于最小化下式:
    k1+1k1+k2+1k2+k3+1k3=(k1+k2+k3)+(k2k3+k1k3+k1k2k1k2k3) k_1+\frac{1}{k_1}+k_2+\frac{1}{k_2}+k_3+\frac{1}{k_3}=(k_1+k_2+k_3)+(\frac{k_2k_3+k_1k_3+k_1k_2}{k_1k_2k_3})
    CC 的特征多项式为(一次项前面的系数是所有可能的二阶主子式的和):
    p(k)=C1i<j3(ciicjjcijcjik+tr(C)k2k3) p(k)=|C|-\sum_{1\leq i< j\leq3}(c_{ii}c_{jj}-c_{ij}c_{ji}k+tr(C)k^2-k^3)
    其中 trtrCC 的迹,利用特征多项式根与系数的关系可得:
    k1+k2+k3=tr(C)=c11+c22+c33=σ1 k_1+k_2+k_3=tr(C)=c_{11}+c_{22}+c_{33}=\sigma_1

    k2k3+k1k3+k1k2=1i<j3(ciicjjcijcji=σ2) k_2k_3+k_1k_3+k_1k_2=\sum_{1\leq i<j\leq3}(c_{ii}c_{jj}-c_{ij}c_{ji}=\sigma_2)

    k1k2k3=C=σ3 k_1k_2k_3=|C|=\sigma_3

    所有待优化的目标函数变为:
    σ1+σ2σ3 \sigma_1+\frac{\sigma_2}{\sigma_3}
    这个函数的最小值为 6,代码中减去 6 是为了让最小值成为 0。


    2020.0809更新

    四、实验

    基础网络可以是VTN或者VoxelMorph,前者最多可以级联10次,后者最多可以级联5次。在肝脏CT图像和脑部MRI图像上做了实验。在CT数据集上是从数据集中随便拿两张图片做配准,而在MRI数据集上是将其他图片配准到一个固定的图谱(atlas)。选用的肝脏CT数据集有:MSD、BFH、SLIVER、LiTS、LSPIG,脑部MRI数据集有:ADNI、ABIDE、ADHD、LPBA,LPBA数据集用作测试,其他用作训练。

    在VTN中相关系数被用作相似度度量标准,batch size设为4,需要迭代训练10w次,选用Adam优化器,初始学习率为10410^{-4},之后经过6×1046\times10^4次迭代减半,再经过8×1048\times10^4次迭代减半。

    选用的baseline为VTN、VoxelMorph以及SyN、Elastix B-spline模型。使用Dice值来衡量模型的效果,其公式如下:
    Dice(A,B)=2ABA+B \operatorname{Dice}(A, B)=2 \cdot \frac{|A \cap B|}{|A|+|B|}
    此外在某些数据集中是有地标标注信息的,所以可以将配准后地标点的平均距离作为额外的衡量标准。

    在预处理阶段,先将所有图像中不必要的部分裁掉,然后重采样到128×128×128128\times128\times128大小。脑部MRI图像还需要先用FreeSurfer去除头骨。

    上图展示了在LPBA数据集上配准结果,第四行的分割中一共有5个解剖结构,蓝色代表固定图像的分割,红色的代表配准后图像的分割。
    在这里插入图片描述

    从上表1可以发现,递归级联网络的效果超过了其他的模型,并且其效果不受基础网络的限制。
    在这里插入图片描述

    上表展示了当级联次数不同时,模型的表现,可以发现当VTN级联3次时,已经超过了表1中的VTN(ADDD) 模型了。当级联越多时,进行配准需要的时间也会线性增加。
    在这里插入图片描述

    上图中横坐标是级联次数,纵坐标是效果,可以发现当级联次数越多时,效果是逐渐提升的。
    在这里插入图片描述

    由于级联块的参数是共享的,所以可以级联到很深,上图中2×52\times5之类的就表示有5个参数共享的级联块,重复了2次。

    此外还将VoxelMorph的通道数double进行了实验,发现效果有提升,但是不如递归级联网络,并且参数量变为了原来的4倍。

    展开全文
  • 实时性很强,而且精度比较高的语义分割网络,将不同分辨率的图像作为输入,在后端将不同分辨率的特征进行结合,得到更精细的语义分割结果。
  • nn-Net级联网络中使用的One-hot Encodings的作用one-hot encodings的来源one-hot编码如何实现为什么要使用one-hot在图像分割中的应用nnUnet one-hot encodings的来源 one-hot encodings为独热编码,也就是一位有效...

    one-hot encodings的来源

    one-hot encodings为独热编码,也就是一位有效编码。它是分类变量作为二进制向量的表示形式。

    one-hot编码如何实现

    • 首先,要求将分类值(如类别0,类别1,类别2)映射到整数值(0,1,2);
    • 然后,每个整数值被表示为二进制向量(00,01,10);
    • 那么,其one-hot编码形式为001,010,100(有几类就有几位数字,是第几类就在那个位置上置1,其他位置置0)

    可以这样理解,对于每一个特征,如果它有m个可能值(分为m类),那么经过独热编码后,就变成了m个二元特征(m位);并且,这些特征互斥,每次只有一个激活(为1)。因此,数据会变成稀疏的。
    –from Jayden yang的One-hot编码笔记

    为什么要使用one-hot

    1. 解决了分类器不好处理属性数据的问题;
      直接原因是现在多分类cnn网络的输出通常是softmax层(激活函数),而它的输出是一个概率分布,从而要求输入的标签也以概率分布的形式出现,进而计算交叉熵。

    这里所说的概率分布指的是:下文所提到的三分类问题,如001,010,100,作为标签,其实可以将某像素的标签001看做在第0类上的概率为1,其他类别的概率为0;这样的话就可以直接和交叉熵的结果(概率分布)进行如交叉熵的loss计算或准确度计算,举个例子:该像素的预测结果为0.3 0.3 0.4,则loss=(0.30)2+(0.30)2+(0.41)2loss=\sqrt{(0.3-0)^2 +(0.3-0)^2 +(0.4-1)^2}方便计算。

    1. 在一定程度上也起到了扩充特征的作用。
      在回归、聚类、分类等机器学习算法中,特征之间距离的计算或相似度计算常常基于欧式空间。如果使用one-hot编码将离散特征的取值,扩展到欧式空间,则离散特征的某个取值就映射到欧式空间的某个点。
      将离散特征使用one-hot编码,会让特征之间的距离计算更合理。

    人的一个离散型特征 如工作类型,有三个取值,
    不使用one-hot编码:x_1=(1),x_2=(2),x_3=(3),此时三个之间的距离
    d(x_1,x_2)=1,
    d(x_1,x_3)=2,
    d(x_2,x_3)=1;x_1和x_3之间的距离是不合逻辑的。
    使用one-hot编码:x_1=(1,0,0),x_2=(0,1,0),x_3=(0,0,1),此时三个之间的距离
    d(x_1,x_2) = d(x_1,x_3) = d(x_2,x_3) = 2\sqrt{2}

    –from 数据预处理之One-hot编码

    在图像分割中的应用nnUnet

    在nnUNet中看到这种用法,是使用Cascaded Net时,将级联的前一个网络的低分辨率的分割结果上采样到原分辨率后,进行one-hot编码,编码结果作为一个独立的通道attach到高分辨率的原图像之后,也就是第二个网络的输入是full resolution的具有“R-G-B-onehot”通道的图像。

    • 但是这里one-hot编码之后是直接像普通图像一样送进网络进行卷积呢?还是送到crossEntropy作为loss参考呢?暂时还不知道。
    展开全文
  • 企业现网网络规划使用OSPF路由协议。 现在用户希望能够实现分支之间的VPN互联。 配置思路 企业网络管理员可以采用如下思路进行分析: 由于分支是采用动态地址接入公网的,分支之间互相不知道对方的公网地址,因此...


    提示:以下是本篇文章正文内容,下面案例可供参考

    配置shortcut方式DSVPN示例(OSPF路由协议)

    组网需求

    某大型企业有总部(Hub)和多个分支(Spoke1、Spoke2……,举例中仅使用两个分支),分布在不同地域,总部和分支的子网环境会经常出现变动。分支采用动态地址接入公网。企业现网网络规划使用OSPF路由协议。

    现在用户希望能够实现分支之间的VPN互联。
    在这里插入图片描述
    配置思路

    企业网络管理员可以采用如下思路进行分析:

    • 由于分支是采用动态地址接入公网的,分支之间互相不知道对方的公网地址,因此必须采用DSVPN来实现分支之间的VPN互联。
    • 由于分支数量较多,因此采用shortcut方式的DSVPN。
    • 由于分支和总部的子网环境经常出现变动,为简化维护并根据企业网络规划,选择部署OSPF路由协议来实现分支/总部间的通信。

    在这里插入图片描述
    配置:
    AR1

    #
    interface GigabitEthernet0/0/0
     ip address 11.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 192.168.0.1 255.255.255.0 
    #
    interface Tunnel0/0/0
     ip address 172.16.1.1 255.255.255.0 
     tunnel-protocol gre p2mp
     source GigabitEthernet0/0/0
     ospf network-type p2mp
     nhrp redirect
     nhrp entry multicast dynamic
    #
    ospf 1 
     area 0.0.0.0 
      network 172.16.1.1 0.0.0.0 
      network 192.168.0.1 0.0.0.0 
    #
    ospf 2 
     area 0.0.0.1 
      network 11.1.1.1 0.0.0.0 
    #
    

    AR2

    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 192.168.1.1 255.255.255.0 
    #
    interface Tunnel0/0/0
     ip address 172.16.1.2 255.255.255.0 
     tunnel-protocol gre p2mp
     source 12.1.1.1
     ospf network-type p2mp
     nhrp shortcut
     nhrp entry 172.16.1.1 11.1.1.1 register
    #
    ospf 1 
     area 0.0.0.0 
      network 172.16.1.2 0.0.0.0 
      network 192.168.1.1 0.0.0.0 
    #
    ospf 2 
     area 0.0.0.1 
      network 12.1.1.1 0.0.0.0 
    #
    

    AR3

    #
    interface GigabitEthernet0/0/0
     ip address 13.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 192.168.2.1 255.255.255.0 
    #
    interface Tunnel0/0/0
     ip address 172.16.1.3 255.255.255.0 
     tunnel-protocol gre p2mp
     source GigabitEthernet0/0/0
     ospf network-type p2mp
     nhrp shortcut
     nhrp entry 172.16.1.1 11.1.1.1 register
    #
    ospf 1 
     area 0.0.0.0 
      network 172.16.1.3 0.0.0.0 
      network 192.168.2.1 0.0.0.0 
    #
    ospf 2 
     area 0.0.0.1 
      network 13.1.1.1 0.0.0.0 
    #
    

    R1

    #
    interface Ethernet0/0/0
     ip address 11.1.1.2 255.255.255.0
    #
    interface Ethernet0/0/1
     ip address 12.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/0
     ip address 13.1.1.2 255.255.255.0
    #
    ospf 2
     area 0.0.0.1
      network 11.1.1.2 0.0.0.0
      network 12.1.1.2 0.0.0.0
      network 13.1.1.2 0.0.0.0
    #
    

    测试一下:R2第一次去R3需要向R1请求nhrp表,找到后可以直接与R3通信
    在这里插入图片描述

    在R2上查看nhrp peer
    在这里插入图片描述
    R3
    在这里插入图片描述
    可以看到AR2去AR3直接去,不用到AR1中转,实现了分支间的直接互联。

    正常情况下,配置接口网络模式为p2mp模式,R2与R3相互通信需要经过R1中转,不可以直接互通。

    如果修改接口网络模式为broadcast模式,R2与R3通信可以直接通信,不用R1中转,但是需要选举DR/BDR,而且需要修改非DR的ospf-dr-priority为0,放弃选举来固定DR位置。虽然可以实现分支间的vpn互联,但是在DSVPN Hub级联情况下,不可以实现分支间互联,如下面的实验。

    p2mp模式下,配置shortcut以及reflect可以实现分支间的vpn互联

    Hub级联网络部署DSVPN

    同一台级联总部R1(R2和R3)下的Spoke与Spoke之间建立动态mGRE隧道的原理同DSVPN基本原理一样。当R2下的Spoke需要与R3下的Spoke建立动态mGRE隧道时,源Spoke将向R2发送NHRP地址解析请求,该地址解析请求经R2转发后最终到达R1(总部),R1(总部)再将NHRP地址解析请求发送至R3,并最终到达目的Spoke,从而实现在级联场景下建立Spoke与Spoke之间的动态mGRE隧道。

    对上图进行扩展,要实现AR7与AR8之间的vpn互联
    在这里插入图片描述
    R2、R3新增配置

    #
    interface Tunnel0/0/0
     nhrp redirect
     nhrp entry multicast dynamic
    #
    
    

    R7

    #
    interface GigabitEthernet0/0/0
     ip address 17.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 192.168.3.1 255.255.255.0 
    #
    interface Tunnel0/0/0
     ip address 172.16.1.4 255.255.255.0 
     tunnel-protocol gre p2mp
     source GigabitEthernet0/0/0
     ospf network-type p2mp
     nhrp shortcut
     nhrp entry 172.16.1.2 12.1.1.1 register
    #
    ospf 1 
     area 0.0.0.0 
      network 172.16.1.4 0.0.0.0 
      network 192.168.3.1 0.0.0.0 
    #
    ospf 2 
     area 0.0.0.1 
      network 17.1.1.1 0.0.0.0 
    #
    

    R8略

    R7去R8测试一下:第一次会向上级递归查询nhrp表直到R1,找到后之后互联
    在这里插入图片描述
    查看nhrp表
    在这里插入图片描述

    展开全文
  • 实际任务中,往往会需要多步训练,或者将两个网络拼成一个网络,那么将新的小模型拼接在已经训练好的主干网络上训练,如何做到只训练新支,而不破坏原主干网络已经训练好的weight,这就需要锁住训练,保证网络只更新...
  • 级联网络cascade-rcnn/HTC

    2019-12-30 18:04:07
    1.CASCADE
  • 基于两种基础网络 VTN 和 VoxelMorph 构建了递归级联网络(递归级联网络可以构建于任何基础网络之上,并不局限于 VTN 和 VoxelMorph)。下图总结了我们与传统算法以及与基础网络相比的总体性能。可以看到,递归级联...
  • 深度学习(十八)级联网络(2)

    千次阅读 热门讨论 2018-06-16 12:28:15
    sorry,笔记正在上传。。。
  • 目录 setting 数据处理中的.mat文件 model network experiment   python train_sub.py -opt options/train/train_noise_blur_sr.json tensorboard --logdir tb_logger/ --port 6008 处理数据的代码可以...
  • 网络自身的特性[网络越深则越耗时]. 为了解决上述难题而提出了基于CNN的级联框架,具有性能好且识别能力强的特点.级联思想在人脸检测的运用: 在特征图上用滑动窗口,特征图上每个点对应于原始图像的一部分;人脸关键...
  • 图2:用于肝脏配准的递归级联网络效果图 递归级联网络可以构建于任何已有的基础网络之上,通过无监督、端到端的方式学习到深度递归的渐进配准。 除此之外,我们还提出了一种 shared-weight 级联技术,可以在测试中...
  • 级联相关网络

    千次阅读 2018-06-11 19:52:46
    级联相关神经网络是从一个小网络开始,自动训练和添加隐含单元,最终形成一个多层的结构。级联相关神经网络具有以下优点:学习速度快;自己决定神经元个数和深度;训练集变化之后还能保持原有的结构(这个是缺点还是...
  • concatenation级联神经网络

    千次阅读 2019-08-06 22:10:03
    级联相关神经网络是从一个小网络开始,自动训练和添加隐含单元,最终形成一个多层的结构。级联相关神经网络具有以下优点:学习速度快;自己决定神经元个数和深度;训练集变化之后还能保持原有的结构;不需要后向传播...
  • 各级Blumlein型脉冲形成网络充电电压的不一致是影响级联脉冲形成网络电压传输效率的因素之一,为了使级联网络的充电电压一致,设计了一种多路充电电源。每路电源由脉冲变压器,IGBT,初级储能电容组成,IGBT的同步...
  • 级联细化网络原文+翻译

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,866
精华内容 746
关键字:

级联网络