精华内容
下载资源
问答
  • 为什么VLAN能隔离广播域,...我自己想不太通,是因为VLAN能划分网段, 那为什么VLAN能划分网段呢? VLAN都是需要在交换机接口上进行配置实现。 而交换机不具备划分网段的功能? 望不吝赐教,感激不尽!
  • 问题描述:AAA.BBB.CCC.DDD根据DDD每255个进行划分网段,并且每个网段AAA.BBB.CCC相同 代码: /** * AAA.BBB.CCC.DDD根据DDD每255个进行划分页 * @param startIp * @param endIp * @return */ public ...

    问题描述:AAA.BBB.CCC.DDD根据DDD每255个进行划分网段,并且每个网段AAA.BBB.CCC相同

    代码:

    /**
    	 * AAA.BBB.CCC.DDD根据DDD每255个进行划分页
    	 * @param startIp
    	 * @param endIp
    	 * @return
    	 */
    	public static long getNetPageBetweenIps(String startIp,String endIp){
    		String[] start=startIp.split("\\.");
    		String[] end=endIp.split("\\.");
    		String startZero=start[0]+"."+start[1]+"."+start[2]+"."+"0";//网段补齐
    		String end255=end[0]+"."+end[1]+"."+end[2]+"."+"255";
    		System.out.println("---startIp is:"+startIp+"---endIp is:"+endIp);
    		System.out.println("---startZero is:"+startZero+"---end255 is:"+end255);
    		long startL=ipToLong(startZero);
    		long endL=ipToLong(end255);
    		long scopBetween=endL-startL+1;
    		long page=scopBetween/256;
    		if(scopBetween%256 != 0){
    			//log.error("produce problem when operator pageNum");
    			System.out.print("operator have problem:"+scopBetween%256);
    		}
    		System.out.println("pageNum is:"+page);
    		return page;
    	}
    	/**
    	 * 获取当前页网段
    	 * @param startIp   被划分网段的开始Ip
    	 * @param endIp		被划分网段的结束Ip
    	 * @param total		被划分网段按照255进行网段划分的总页码
    	 * @param currentPage  当前页码
    	 * @return
    	 */
    	public static String getCurrentPageNetSegments(String startIp,String endIp,long total,long currentPage){
    		String result="";
    		System.out.println("CurrentPage is:"+currentPage);
    		if(total==1){
    			result=startIp+"-"+endIp;
    		}else if(total>1 && currentPage<total){//
    			if(currentPage==1){
    				String[] curIpA=startIp.split("\\.");
    				result=startIp;
    				result+="-"+curIpA[0]+"."+curIpA[1]+"."+curIpA[2]+"."+"255";
    			}else{
    				long curIpL=ipToLong(startIp)+256*(currentPage-1);
    				System.out.println("curIpL is:"+curIpL);
    				String curIpS=getIpFromLong(curIpL);
    				String[] curIpA=curIpS.split("\\.");
    				result=curIpA[0]+"."+curIpA[1]+"."+curIpA[2]+"."+"0";
    				result+="-"+curIpA[0]+"."+curIpA[1]+"."+curIpA[2]+"."+"255";
    			}
    		}else{//currentPage==total
    			String[] curIpA=endIp.split("\\.");
    			result=curIpA[0]+"."+curIpA[1]+"."+curIpA[2]+"."+"0";
    			result+="-"+endIp;
    		}
    		return result;
    	}

    /**
     * Ip地址转化为long型   data>>num 二进制向右移num位 =data/2的num次方
     * @param ipAddr
     * @return
     * @throws IllegalArgumentException
     */
    public static long ipToLong(String ipAddr) throws IllegalArgumentException {
    	if (!ipCheck(ipAddr)) {
    		throw new IllegalArgumentException("Illegal ip address: " + ipAddr);
    	}
    	long result = 0;
    	String[] tmp = ipAddr.split("\\.");
    	for (String part : tmp)
    		result = result << 8 | Integer.parseInt(part);
    	return result;
    }
    /**
     * 判断是否为Ip
     * @param text
     * @return
     */
    public static boolean ipCheck(String text) {
    	if (text != null && !text.isEmpty()) {
    		// 定义正则表达式
    		String regex = "^(1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]\\d|[1-9])\\.(1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]\\d|\\d)\\.(1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]\\d|\\d)\\.(1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]\\d|\\d)$";
    		// 判断ip地址是否与正则表达式匹配
    		if (text.matches(regex)) {
    			// 返回判断信息
    			return true;
    		} else {
    			// 返回判断信息
    			return false;
    		}
    	}
    	return false;
    }

    /**
     * 把long类型的Ip转为一般Ip类型:xx.xx.xx.xx
     * @param ip
     * @return
     */
    public static String getIpFromLong(Long ip){
        String s1 = String.valueOf((ip & 4278190080L) / 16777216L);
        String s2 = String.valueOf((ip & 16711680L) / 65536L);
        String s3 = String.valueOf((ip & 65280L) / 256L);
        String s4 = String.valueOf(ip & 255L);
        return s1 + "." + s2 + "." + s3 + "." + s4;
    }


    展开全文
  • 如何划分网段

    2013-04-02 18:54:22
    如果你还不会划分子网的话,那你赶快下载吧!
  • 虚拟局域网(VLAN)是一种逻辑分隔的技术,能有效的防止交换网络的...建立虚拟局域网划分网段测试 打开GNS3,把设备拖放到拓扑操作区,标记IP,VLAN等备注,设置好后打开运行 设置好所有PC设备IP地址,用PC1 ...

    前言

    虚拟局域网(VLAN)是一种逻辑分隔的技术,能有效的防止交换网络的过量广播,相邻的端口不会接收到其他VLAN中产生的广播,节省成本,提高效率以及安全性,并且便于网络管理。

    一、VLAN的概念

    为了防止广播风暴导致网络通信陷入瘫痪,我们可以使用两种方式分隔广播域的方法来解决这个问题

    1. 物理分隔
      例如 路由器
    2. 逻辑分隔
      在交换机中划分多个VLAN,每个VLAN就是一个广播域。
      在这里插入图片描述

    优势

    1. 控制广播
    2. 增强网络安全性
    3. 简化网络管理

    二、Vlan原理测试

    测试目的

    建立了VLAN是否真的能起到隔离的作用呢?下面通过建立虚拟局域网来进行测试。

    测试环境
    1. GNS3软件
    2. 1台交换机设备
    3. 4台PC设备
    测试步骤

    建立虚拟局域网划分网段测试
    打开GNS3,把设备拖放到拓扑操作区,标记IP,VLAN等备注,设置好后打开运行
    在这里插入图片描述
    设置好所有PC设备IP地址,用PC1 ping一下网络是否通畅
    在这里插入图片描述
    PC设置互联互通之后,打开交换机,关闭路由功能,建立vlan2和vlan3,设置一下名称
    在这里插入图片描述
    查看vlan是否被创建
    在这里插入图片描述
    查看VLAN被创建后,把接口1/1添加到vlan2中,接口1/0用同样的操作添加到vlan2中
    在这里插入图片描述
    查看接口1/0,1/1是否添加到vlan2中
    在这里插入图片描述
    确认接口1/0和1/1被添加好后,把1/2和1/3添加到vlan3中
    在这里插入图片描述
    查看接口是否被添加
    在这里插入图片描述
    确认被添加后,用PC1 ping一下,发现相同VLAN中的PC2可以互联互通,而不同VLAN下的PC3和PC4则不能
    在这里插入图片描述
    用PC3 ping一下,同样,相同VLAN中的PC4可以互通,不同VLAN中的PC1和PC2则不能
    在这里插入图片描述

    总结
    主要命令:
    vlan 10,20          						创建vlan
    show vlan-switchport brief					查看vlan目录
    switchport mode access						接入链路
    switchport access vlan 10					链路添加到vlan10
    switchport access vlan 20					链路添加到vlan20
    

    4台pc设备原本所属同一网段,本应可以互联互通,通过此次测试实现了建立虚拟局域网,有效的划分了网段,只有在同一个VLAN内的设备可以互联互通,而不同的VLAN中的设备无法进行通讯,提高了网络的安全性。

    展开全文
  • 交换机划分网段配置

    2021-01-26 15:49:13
    一、三层交换主机: 1、建立VLAN: vlan1 #(管理主VLAN) vlan 10 vlan 20 vlan 30 2、业务网关: interface Vlan-interface10 ip address 192.168.1.1 255.255.255.0 #interface Vlan-interface20 ...

    一、三层交换主机:
    1、建立VLAN:

    vlan1	#(管理主VLAN)
    vlan 10
    vlan 20
    vlan 30
    

    2、业务网关:

    interface Vlan-interface10
    ip address 192.168.1.1 255.255.255.0
    #interface Vlan-interface20
    ip address 192.168.2.1 255.255.255.0
    #interface Vlan-interface30
    ip address 192.168.3.1 255.255.255.0
    

    3、与路由器互联地址:

    #交换机侧:
    vlan 100
    #interface Vlan-interface100
    ip address 192.168.0.2 255.255.255.252
    #路由器侧:
    #interface ethernet1/0/1
    ip address 192.168.0.2 255.255.255.252
    

    4、交换机缺省路由:

    ip route-static 0.0.0.0 0.0.0.0 192.168.0.1
    

    二、路由器配置
    1、向交换机的回程路由:

    ip route-static 192.168.1.0 255.255.255.0 192.168.0.2
    ip route-static 192.168.2.0 255.255.255.0 192.168.0.2
    ip route-static 192.168.3.0 255.255.255.0 192.168.0.2
    

    2、路由器缺省路由:

    ip route-static 0.0.0.0 0.0.0.0 *.*.*.* (公网地址)
    

    3、NAT转换:

    acl number 2000
    rule 0 permit
    interface ethernet0/1
    port link-mode route
    nat outbound 2000
    ip address *.*.*.* (公网地址)255.255.255.252
    #
    interface ethernet0/2
    port link-mode route
    ip address 192.168.0.1 255.255.255.252
    

    对应设备:
    交换机:华为S27、S37、S57…华三:S31、S36、S51、S55、S58、S75…
    路由器:华为AR12/AR22/AR32/NE系列…
    华为三层:MSR900/MSR20/MSR30/MSR50/SR系列

    展开全文
  • 划分网段和子网掩码 子网划分

    千次阅读 2018-06-07 11:40:47
    所以C网段中最多划分6个子网数 例如, 对B类网络135.41.0.0/16需要划分为20个能容纳200台主机的网络(即:子网)。因为16,即:2的4次方的5次方,所以,子网位只须占用5位主机位就可划分成32个子网,可以满足划分成...
    自己复习所用

    我们都知道,IP是由四段数字组成,在此,我们先来了解一下3类常用的IP
    A类IP段 1.0.0.0 到126.255.255.255 (0段和127段不使用)
    B类IP段 128.0.0.0 到191.255.255.255
    C类IP段 192.0.0.0 到223.255.255.255
    XP默认分配的子网掩码每段只有255或0
    A类的默认子网掩码 255.0.0.0 一个子网最多可以容纳1658万多台电脑
    B类的默认子网掩码 255.255.0.0 一个子网最多可以容纳6万台电脑
    C类的默认子网掩码 255.255.255.0 一个子网最多可以容纳254台电脑

    子网掩码切换至二进制,我们会发现,所有的子网掩码是由一串连续的1和一串连续的0组成的(一共4段,每段8位,一共32位数)。
    255.0.0.0 11111111.00000000.00000000.00000000
    255.255.0.0 11111111.11111111.00000000.00000000
    255.255.255.0 11111111.11111111.11111111.00000000
    这是A/B/C三类默认子网掩码的二进制形式,其实,还有好多种子网掩码,只要是一串连续的1(不少于8个)和一串连续的0就可以了(每段都是8位)。如 11111111.11111111.11111000.00000000,这也是一段合法的子网掩码。子网掩码决定的是一个子网的计算机数目,计算公式是2的m次方,其中,我们可以把m看到是后面的多少个0。如255.255.255.0转换成二进制,那就是 11111111.11111111.11111111.00000000,后面有8个0,那m就是8,255.255.255.0这个子网掩码可以容纳 2的8次方(台)电脑,也就是256台,但是有两个IP是不能用的,那就是最后一段不能为0和255,减去这两台,就是254台。


    A类的某个地址为 12.10.10.3/8,这里的最后一个"8"说明该地址的子网掩码为8位,而199.42.26.0/28表示网络199.42.26.0的子网掩码位数有28位。


    当知道子网掩码位就可以算出他的子网掩码

    比如上面的 子网掩码为八 他的子网掩码的二进制就是前面八个数字为1 ,后面为0就是

    11111111.00000000.00000000.00000000

    转化为十进制就是255.0.0.0这就是 子网掩码为8位的子网掩码

    知道这这个方法后其实很容易就知道当知道一个IP的子网掩码位时,我们很容易就能求出他的子网掩码


    通过子网掩码也可以求出这个子网掩码最多可以放多少台电脑



    比如子网掩码 是255.255.248.0

    把将其转换为二进制的四段数字(每段要是8位,如果是0,可以写成8个0,也就是00000000)

    11111111.1111111.11111000.00000000
    然后,数数后面有几颗0,一共是有11颗,那就是2的11次方,等于2048 (注意:主机号中全0是保留地址,全1是广播地址,所以它们不算可用主号地址。网络号也是一样的。子网号是可以用全0和全1的),所以这个子网掩码最多可以容纳2048-2=2046台电脑。

    通过逆向思维我们就可以算出当我们知道公司有多少台电脑时,子网掩码怎么分配最为合适


    对一个网络进行子网划分时,基本上就是将它分成小的网络

    子网划分是通过借用IP地址的若干位主机位来充当子网地址从而将原网络划分为若干子网而实现的。
    划分子网时,随着子网地址借用主机位数的增多,子网的数目随之增加,而每个子网中的可用主机数逐渐减少。以C类网络为例,原有8位主机位,2的8次方即256个主机地址,默认子网掩码255.255.255.0。借用1位主机位,产生2个子网,每个子网有126个主机地址;借用2位主机位,产生4个子网,每个子网有62个主机地址……每个网中,第一个IP地址(即主机部分全部为0的IP)和最后一个IP(即主机部分全部为1的IP)不能分配给主机使用,所以每个子网的可用IP地址数为总IP地址数量减2;根据子网ID借用的主机位数,我们可以计算出划分的子网数、掩码、每个子网主机数,列表如下:
    ① 划分子网数 ② 子网位数 ③子网掩码(二进制) ④ 子网掩码(十进制) ⑤ 每个子网主机数
    ① 1~2 ② 1 ③ 11111111.11111111.11111111.10000000 ④ 255.255.255.128 ⑤ 126
    ① 3~4 ② 2 ③ 11111111.11111111.11111111.11000000 ④ 255.255.255.192 ⑤ 62
    ① 5~8 ② 3 ③ 11111111.11111111.11111111.11100000 ④ 255.255.255.224 ⑤ 30
    ① 9~16 ② 4 ③ 11111111.11111111.11111111.11110000 ④ 255.255.255.240 ⑤ 14
    ① 17~32 ② 5 ③ 11111111.11111111.11111111.11111000 ④ 255.255.255.248 ⑤ 6
    ① 33~64 ② 6 ③ 11111111.11111111.11111111.11111100 ④ 255.255.255.252 ⑤ 2
    如上表所示的C类网络中,若子网占用7位主机位时,主机位只剩一位,无论设为0还是1,都意味着主机位是全0或全1。由于主机位全0表示本网络,全1留作广播地址,这时子网实际没有可用主机地址,所以主机位至少应保留2位。所以C网段中最多划分6个子网数
    例如,对B类网络135.41.0.0/16需要划分为20个能容纳200台主机的网络(即:子网)。因为16<20<32,即:2的4次方<20<2的5次方,所以,子网位只须占用5位主机位就可划分成32个子网,可以满足划分成20个子网的要求。B类网络的默认子网掩码是255.255.0.0,转换为二进制为11111111.11111111.00000000.00000000。现在子网又占用了5位主机位,根据子网掩码的定义,划分子网后的子网掩码应该为11111111.11111111.11111000.00000000,转换为十进制应该为255.255.248.0。现在我们再来看一看每个子网的主机数。子网中可用主机位还有11位,2的11次方=2048,去掉主机位全0和全1的情况,还有2046个主机ID可以分配,而子网能容纳200台主机就能满足需求,按照上述方式划分子网,每个子网能容纳的主机数目远大于需求的主机数目,造成了IP地址资源的浪费。为了更有效地利用资源,我们也可以根据子网所需主机数来划分子网。还以上例来说,128<200<256,即2^7<200<2^8,也就是说,在B类网络的16位主机位中,保留8位主机位,其它的16-8=8位当成子网位,可以将B类网络135. 41.0.0划分成256(2^8)个能容纳256-1-1=254台(去掉全0全1情况)主机的子网。此时的子网掩码为11111111.11111111.11111111.00000000,转换为十进制为255.255.255.0。

    广播地址是下一个子网号减一

    C类地址例子:网络地址192.168.10.0;子网掩码255.255.255.192(/26)
    子网掩码转为二进制数为 11111111.11111111.11111111.11000000
    1.子网数=2*2=4(ip subnet zero命令启用)
    2.主机数=2的6次方-2=62
    3.有效子网:block size=256-192=64;所以第一个子网为192.168.10.0,第二个为192.168.10.64,第三个为192.168.10.128,第四个为192.168.10.192。
    4.广播地址:下个子网-1.所以第一和第二个子网的广播地址分别是192.168.10.63和192.168.10.127  192.168.10.191

    5.有效主机范围是:第一个子网的主机地址是192.168.10.1到192.168.10.62;第二个是192.168.10.65到192.168.10.126
    B类地址例子1:网络地址:172.16.0.0;子网掩码255.255.192.0(/18)
    1.子网数=2*2=4(ip subnet zero命令启用)
    2.主机数=2的14次方-2=16382
    3.有效子网:block size=256-192=64;所以第一个子网为172.16.0.0,第二个子网为172.16.64.0,第三个子网为172.16.128.0,最后1个为172.16.192.0
    4.广播地址:下个子网-1.所以前2个子网的广播地址分别是172.16.63.255和172.16.127.255。
    5.有效主机范围是:第一个子网的主机地址是172.16.0.1到172.16.63.254;第二个是172.16.64.1到172.16.127.254



















    展开全文
  • 网络位:表示IP地址所属的网段 主机位:用来唯一标识一个网段内的某一台设备 IP地址的作用 可以实现同一网段或跨网段的通信 IP地址的分类 A类地址:0.0.0.0 -- 127.255.255.255 B类地址:128.0.0.0 -- 191.255.255...
  • 网段划分

    2020-05-18 15:45:30
    IP地址分为两个部分, 网络号和主机号 网络号: 保证相互连接的两个网段具有不同的标识; 主机号: 同一网段内, 主机之间具有相同的网络号, 但是必须有不同的主机号;...随着Internet的飞速发展,这种划分方案的局
  • iptables网段划分

    2017-11-13 21:30:00
    iptables网段分段处理 24指的是32-24共2^8-2台主机 32是只单独的纯IP iptables禁止IP段划分 1.#屏蔽单个IP的命令是 2.iptables-IINPUT-s123.45.6.7-jDROP 3.#封整个段即从123.0.0.1到123.255.255.254的命令 4....
  • F5划分虚拟网段

    2012-01-07 22:01:26
    这个事我自己在工程中进行的截图,希望大家喜欢
  • 网段划分

    2016-09-04 22:25:00
    以上网段划分表示:前面26位表示网络地址后面6位表示主机地址 那么看最后8位: 00 ----- 01----- 10 ----- 11 分为了4个网段就,即: 192.168.1.0 --- 192.168.1.63 192.168.1.64---192.168.1.127 192.168....
  • IPV4网段划分

    2019-09-21 03:29:44
    IPV4的地址分类及网络号的范围如下: A类地址  (1)A类地址第1字节为网络地址,其它3个字节为主机地址。  (2)A类地址范围:1.0.0.1—126.255.255.254  (3)A类地址中的私有地址和保留地址: ① 10.X.X.X...
  • 在同一网段划分不同VLAN

    千次阅读 2020-03-17 23:56:58
    在同一网段划分不同VLAN 1.在不同网段划分vlan,与在同一网段划分vlan的区别? 划分VLAN其IP地址可能是在一个网段内,其主要作用是为了防止网络风暴 2.设置vlan与设置不同的网段有什么区别? 通过交换机划分2个VLAN ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,208
精华内容 883
关键字:

划分网段