精华内容
下载资源
问答
  • 三层交换配置路由
  • 三层交换配置

    2011-12-21 11:01:45
    三层交换 (双线备份) 网络设备调试技术
  • Cisco 三层交换配置金典案例 个人觉得非常不错
  • 三层交换配置路由

    千次阅读 2019-05-01 16:53:47
    三层交换配置路由 问题 三层交换机实现了VLAN间互通后,还要与其他网络进行通信,这样就需要有相关的路由机制。 1)交换接口配置为三层接口实现路由间通信 方案 三层交换机既然具有三层功能,也就可以实现与路由器...

    三层交换配置路由

    问题

    三层交换机实现了VLAN间互通后,还要与其他网络进行通信,这样就需要有相关的路由机制。
    1)交换接口配置为三层接口实现路由间通信

    方案

    三层交换机既然具有三层功能,也就可以实现与路由器相似的配置。既可以把交换接口配置为三层接口,也可以在其上配置静态、动态路由。通过对三层交换机的路由配置,实现VLAN与其他网络的互通。
    网络的拓扑结构如图所示:
    在这里插入图片描述

    步骤

    实现此案例需要按照如下步骤进行。

    步骤一:VLAN等配置与上面2 三层交换vlan间通信通完全一致,不再赘述

    步骤二:将三层交换的Fa0/23口配置为三层路由端口,并配置IP地址

    三层交换机的物理端口默认是二层端口,只具有二层特性,不能配置IP地址。把二层端口配置为三层端口后,该端口就具备路由功能了,可以配置IP地址,但同时也就关闭了其二层特性,比如不能把三层端口加入VLAN。
    二层端口(交换机上的端口默认都是二层端口)默认是激活状态,那些没有使用到的端口为了安全应该手工将其禁用(shutdown);而三层端口(路由器上的端口或是三层交换机上被配置成路由端口的端口)默认是禁用状态,在使用之前务必要将其激活(no shutdown)。

    tarenasw-3L(config)#interface f0/23
    tarenasw-3L(config-if)#no switchport 
    tarenasw-3L(config-if)#ip address 192.168.10.2 255.255.255.0
    tarenasw-3L(config-if)#no shutdown
    

    步骤三:配置路由器的端口IP地址

    tarena-rouer(config)#interface f0/0
    tarena-rouer(config-if)#ip address 192.168.10.1 255.255.255.0
    tarena-rouer(config-if)#no shutdown
    tarena-rouer(config-if)#interface f0/1
    tarena-rouer(config-if)#ip address 200.1.1.1 255.255.255.0
    tarena-rouer(config-if)#no shutdown
    

    步骤四:在三层交换机上配置默认路由,以便VLAN内主机可以与外界网络互联

    tarenasw-3L(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1
    tarenasw-3L(config)#exit
    tarenasw-3L#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is 192.168.10.1 to network 0.0.0.0
    C    192.168.1.0/24 is directly connected, Vlan1
    C    192.168.2.0/24 is directly connected, Vlan2
    C    192.168.3.0/24 is directly connected, Vlan3
    C    192.168.10.0/24 is directly connected, FastEthernet0/23
    S*   0.0.0.0/0 [1/0] via 192.168.10.1
    

    步骤五:在路由器上配置到达三个VLAN网络的静路由

    tarena-rouer(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#ip route 192.168.2.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#ip route 192.168.3.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#exit
    tarena-rouer#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    S    192.168.1.0/24 [1/0] via 192.168.10.2
    S    192.168.2.0/24 [1/0] via 192.168.10.2
    S    192.168.3.0/24 [1/0] via 192.168.10.2
    C    192.168.10.0/24 is directly connected, FastEthernet0/0
    C    200.1.1.0/24 is directly connected, FastEthernet0/1
    tarena-rouer#
    

    步骤六:在Server上测试与三个VLAN的连通性

    SERVER>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address.........: FE80::2E0:8FFF:FE14:BB43
    IP Address......................: 200.1.1.10
    Subnet Mask.....................: 255.255.255.0
    Default Gateway.................: 200.1.1.1
    SERVER>ping 192.168.1.10
    Pinging 192.168.1.10 with 32 bytes of data:
    Request timed out.
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 192.168.1.10:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>ping 192.168.2.10
    Pinging 192.168.2.10 with 32 bytes of data:
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.2.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    SERVER>ping 192.168.3.10
    Pinging 192.168.3.10 with 32 bytes of data:
    Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.3.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>
    
    展开全文
  • 三层交换 VLAN 互访配置,里面有详细的设计步骤
  • 三层交换配置.doc

    2009-01-13 09:49:13
    三层交换配置 比较全面的三层交换机配置实例(带命令解释哟!) 比较全面的三层交换机配置实例(带命令解释哟!)
  • 三层交换VLAN配置

    2009-04-10 13:38:01
    Cisco三层交换VLAN配置,什么是三层交换和VLAN
  • 三层交换配置及RIP动态路由

    千次阅读 2019-09-23 20:42:14
    三层交换vlan间通信 1.1 问题 VLAN实现了广播域的隔离,同时也将VLAN间的通信隔离了。三层交换技术使得VLAN间可以通信。 通过三层交换实现VLAN间通信 1.2 方案 为了解决了传统路由器低速、复杂所造成的网络...

    三层交换vlan间通信

    1.1 问题

    VLAN实现了广播域的隔离,同时也将VLAN间的通信隔离了。三层交换技术使得VLAN间可以通信。

    • 通过三层交换实现VLAN间通信

    1.2 方案

    为了解决了传统路由器低速、复杂所造成的网络瓶颈问题,引入了三层交换技术。它根据实际应用时的情况,灵活地在网络第二层或者第三层进行网络分段。具有三层交换功能的设备是一个带有第三层路由功能的第二层交换机。

    简单地说,三层交换技术就是:二层交换技术+三层转发技术。

    三层交换实现的拓扑如图-1所示:

    图-1

    1.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:在连接PC的交换机上划分3个VLAN,并按图-1把PC机加入相应VLAN

    1. tarenasw-3L (config)#vlan 2 //vlan1是默认VLAN,不需创建
    2. tarenasw-3L (config-vlan)#vlan 3
    3. tarenasw-3L (config-vlan)#exit
    4. tarenasw-3L (config)#interface f0/1
    5. tarenasw-3L (config-if)#switchport mode access
    6. tarenasw-3L (config-if)#switchport access vlan 1
    7. tarenasw-3L (config-if)#interface f0/2
    8. tarenasw-3L (config-if)#switchport mode access
    9. tarenasw-3L (config-if)#switchport access vlan 2
    10. tarenasw-3L (config-if)#interface f0/3
    11. tarenasw-3L (config-if)#switchport mode access
    12. tarenasw-3L (config-if)#switchport access vlan 3

    步骤二:查看划分完的VLAN信息

    VLAN1是默认VLAN,不需单独创建,也不能改名。所有端口默认都在VLAN1中。

    1. tarenasw-2L#show vlan
    2. VLAN Name Status Ports
    3. ---- ----------------------- --------- ---------------------
    4. 1 default active Fa0/1, Fa0/4, Fa0/5, Fa0/6
    5. Fa0/7, Fa0/8, Fa0/9, Fa0/10
    6. Fa0/11, Fa0/12, Fa0/13, Fa0/14
    7. Fa0/15, Fa0/16, Fa0/17, Fa0/18
    8. Fa0/19, Fa0/20, Fa0/21, Fa0/22
    9. Fa0/23, Fa0/24, Gig1/1, Gig1/2
    10. 2 vlan0002 active Fa0/2
    11. 3 vlan0003 active Fa0/3

    步骤三:为vlan1、vlan2、vlan3分别设置管理IP并开启三层交换机路由功能

    1. tarenasw-3L #enable
    2. tarenasw-3L #configure terminal
    3. tarenasw-3L (config)#ip routing //开启三层交换机路由功能
    4. tarenasw-3L (config)#interface vlan 1
    5. tarenasw-3L (config-if)#ip address 192.168.1.254 255.255.255.0
    6. tarenasw-3L (config-if)#no shutdown
    7. tarenasw-3L (config-if)#exit
    8. tarenasw-3L (config)#interface vlan 2
    9. tarenasw-3L (config-if)#ip address 192.168.2.254 255.255.255.0
    10. tarenasw-3L (config-if)#no shutdown
    11. tarenasw-3L (config-if)#exit
    12. tarenasw-3L (config)#interface vlan 3
    13. tarenasw-3L (config-if)#ip address 192.168.3.254 255.255.255.0
    14. tarenasw-3L (config-if)#no shutdown

    步骤四:给客户端配置IP地址并测试网络连通性如图-2图-3所示

    图-2

    图-3

    在PC1三上测试网络连通性

    1. PC1>ping 192.168.3.1
    2. Pinging 192.168.3.1 with 32 bytes of data:
    3. Reply from 192.168.3.1: bytes=32 time=11ms TTL=128
    4. Reply from 192.168.3.1: bytes=32 time=1ms TTL=128
    5. Reply from 192.168.3.1: bytes=32 time=1ms TTL=128
    6. Reply from 192.168.3.1: bytes=32 time=4ms TTL=128
    7. Ping statistics for 192.168.3.1:
    8. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    9. Approximate round trip times in milli-seconds:
    10. Minimum = 1ms, Maximum = 11ms, Average = 4ms

    2 案例2:多交换机vlan间通信

    2.1 问题

    三层交换机将接入层交换机汇聚到一起后还需实现了多交换机间不同VLAN的通信。

    2.2 方案

    三层交换机连接其他交换机的链路需配置为中继链路,三层交换机接口配置trunk模式需先封装,sw1规划vlan1、vlan2、vlan3,Sw2规划vlan4、vlan5并按图-4给相应vlan配置对应网段的IP。

    网络的拓扑结构如图-4所示:

    图-4

    2.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:配置三层交换机

    1)三层交换机创建vlan并配置vlan的虚端口IP并开启路由功能

    1. Switch>enable
    2. Switch#configure terminal
    3. Switch(config)#vlan 2
    4. Switch(config-vlan)#vlan 3
    5. Switch(config-vlan)#vlan 4
    6. Switch(config-vlan)#vlan 5
    7. Switch(config)#interface vlan 1
    8. Switch(config-if)#ip address 192.168.1.254 255.255.255.0
    9. Switch(config-if)#no shutdown
    10. Switch(config)#interface vlan 2
    11. Switch(config-if)#ip address 192.168.2.254 255.255.255.0
    12. Switch(config-if)#no shutdown
    13. Switch(config)#interface vlan 3
    14. Switch(config-if)#ip address 192.168.3.254 255.255.255.0
    15. Switch(config-if)#no shutdown
    16. Switch(config)#interface vlan 4
    17. Switch(config-if)#ip address 192.168.4.254 255.255.255.0
    18. Switch(config-if)#no shutdown
    19. Switch(config)#interface vlan 5
    20. Switch(config-if)#ip address 192.168.5.254 255.255.255.0
    21. Switch(config-if)#no shutdown
    22. Switch(config)#ip routing //开启路由功能

    2)三层交换的Fa0/23、Fa0/24设置为中继链路模式

    1. Switch(config)#interface range f0/23-24
    2. Switch (config-if-range)#switchport trunk encapsulation dot1q
    3. Switch (config-if-range)#switchport mode trunk

    步骤二:配置二层交换机

    1)Sw1创建vlan2、 vlan3并将端口加入vlan

    1. Sw1(config)#vlan 2
    2. Sw1(config-vlan)#vlan 3
    3. Sw1(config)#interface fastEthernet 0/2
    4. Sw1(config-if)#switchport access vlan 2
    5. Sw1(config)#interface fastEthernet 0/3
    6. Sw1(config-if)#switchport access vlan 3
    7. Sw1(config)#interface fastEthernet 0/5
    8. Sw1(config-if)#switchport mode trunk //连接三层交换机的接口配置为trunk模式

    2)Sw2创建vlan4、 vlan5并将端口加入vlan

    1. Sw2(config)#vlan 4
    2. Sw2(config-vlan)#vlan 5
    3. Sw2(config)#interface fastEthernet 0/1
    4. Sw2(config-if)#switchport access vlan 4
    5. Sw2(config)#interface f0/2
    6. Sw2(config-if)#switchport access vlan 5

    步骤三:按图-4配置IP并测试网络的连通性

    1. PC>ipconfig
    2. FastEthernet0 Connection:(default port)
    3. Link-local IPv6 Address.........: FE80::2D0:D3FF:FE2E:5D25
    4. IP Address......................: 192.168.1.1
    5. Subnet Mask.....................: 255.255.255.0
    6. Default Gateway.................: 192.168.1.254
    7. PC>ping 192.168.4.1
    8. Pinging 192.168.4.1 with 32 bytes of data:
    9. Reply from 192.168.4.1: bytes=32 time=0ms TTL=127
    10. Reply from 192.168.4.1: bytes=32 time=0ms TTL=127
    11. Reply from 192.168.4.1: bytes=32 time=0ms TTL=127
    12. Reply from 192.168.4.1: bytes=32 time=0ms TTL=127
    13. Ping statistics for 192.168.4.1:
    14. Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    15. Approximate round trip times in milli-seconds:
    16. Minimum = 0ms, Maximum = 0ms, Average = 0ms
    17. PC>ping 192.168.5.1
    18. Pinging 192.168.5.1 with 32 bytes of data:
    19. Reply from 192.168.5.1: bytes=32 time=0ms TTL=127
    20. Reply from 192.168.5.1: bytes=32 time=0ms TTL=127
    21. Reply from 192.168.5.1: bytes=32 time=0ms TTL=127
    22. Reply from 192.168.5.1: bytes=32 time=0ms TTL=127
    23. Ping statistics for 192.168.5.1:
    24. Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    25. Approximate round trip times in milli-seconds:
    26. Minimum = 0ms, Maximum = 0ms, Average = 0ms

    3 案例3:三层交换配置路由

    3.1 问题

    三层交换机实现了VLAN间互通后,还要与其他网络进行通信,这样就需要有相关的路由机制。

    • 交换接口配置为三层接口实现路由间通信

    3.2 方案

    三层交换机既然具有三层功能,也就可以实现与路由器相似的配置。既可以把交换接口配置为三层接口,也可以在其上配置静态、动态路由。通过对三层交换机的路由配置,实现VLAN与其他网络的互通。

    网络的拓扑结构如图-5所示:

    图-5

    3.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:多交换机vlan通信与案例2完全一致,不再赘述

    步骤二:将三层交换的Fa0/6口配置为三层路由端口,并配置IP地址

    三层交换机的物理端口默认是二层端口,只具有二层特性,不能配置IP地址。把二层端口配置为三层端口后,该端口就具备路由功能了,可以配置IP地址,但同时也就关闭了其二层特性,比如不能把三层端口加入VLAN。

    二层端口(交换机上的端口默认都是二层端口)默认是激活状态,那些没有使用到的端口为了安全应该手工将其禁用(shutdown);而 三层端口(路由器上的端口或是三层交换机上被配置成路由端口的端口)默认是禁用状态,在使用之前务必要将其激活(no shutdown)。

    1. Switch(config)#interface f0/6
    2. Switch(config-if)#no switchport
    3. Switch(config-if)#ip address 192.168.6.1 255.255.255.0
    4. Switch(config-if)#no shutdown

    步骤三:配置路由器的端口IP地址

    1. Switch(config)#interface f0/0
    2. Switch(config-if)#ip address 192.168.6.2 255.255.255.0
    3. Switch(config-if)#no shutdown
    4. Switch(config-if)#interface f0/1
    5. Switch(config-if)#ip address 192.168.7.254 255.255.255.0
    6. Switch(config-if)#no shutdown

    步骤四:在三层交换机上配置静态路由,以便VLAN内主机可以与外界网络互联

    1. Switch(config)#ip route 192.168.7.0 255.255.255.0 192.168.6.2
    2. Switch(config)#exit
    3. Switch#show ip route
    4. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    5. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    6. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    7. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    8. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    9. * - candidate default, U - per-user static route, o - ODR
    10. P - periodic downloaded static route
    11. Gateway of last resort is not set
    12. C 192.168.1.0/24 is directly connected, Vlan1
    13. C 192.168.2.0/24 is directly connected, Vlan2
    14. C 192.168.3.0/24 is directly connected, Vlan3
    15. C 192.168.4.0/24 is directly connected, Vlan4
    16. C 192.168.5.0/24 is directly connected, Vlan5
    17. C 192.168.6.0/24 is directly connected, FastEthernet0/6
    18. S 192.168.7.0/24 [1/0] via 192.168.6.2

    步骤五:在路由器上配置到达三个VLAN网络的静路由

    1. tarena-rouer(config)#ip route 192.168.1.0 255.255.255.0 192.168.6.1
    2. tarena-rouer(config)#ip route 192.168.2.0 255.255.255.0 192.168.6.1
    3. tarena-rouer(config)#ip route 192.168.3.0 255.255.255.0 192.168.6.1
    4. tarena-rouer(config)#ip route 192.168.4.0 255.255.255.0 192.168.6.1
    5. tarena-rouer(config)#ip route 192.168.5.0 255.255.255.0 192.168.6.1
    6. tarena-rouer(config)#exit
    7. tarena-rouer#show ip route
    8. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    9. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    10. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    11. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    12. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    13. * - candidate default, U - per-user static route, o - ODR
    14. P - periodic downloaded static route
    15. Gateway of last resort is not set
    16. S 192.168.1.0/24 [1/0] via 192.168.6.1
    17. S 192.168.2.0/24 [1/0] via 192.168.6.1
    18. S 192.168.3.0/24 [1/0] via 192.168.6.1
    19. S 192.168.4.0/24 [1/0] via 192.168.6.1
    20. S 192.168.5.0/24 [1/0] via 192.168.6.1
    21. C 192.168.6.0/24 is directly connected, FastEthernet0/0
    22. C 192.168.7.0/24 is directly connected, FastEthernet0/1
    23. tarena-rouer#

    步骤六:在PC上测试与VLAN的连通性

    1. PC>ipconfig
    2. FastEthernet0 Connection:(default port)
    3. Link-local IPv6 Address.........: FE80::2E0:8FFF:FE14:BB43
    4. IP Address......................: 192.168.7.1
    5. Subnet Mask.....................: 255.255.255.0
    6. Default Gateway.................: 192.168.7.254
    7. SERVER>ping 192.168.1.1
    8. Pinging 192.168.1.1 with 32 bytes of data:
    9. Request timed out.
    10. Reply from 192.168.1.1: bytes=32 time=0ms TTL=126
    11. Reply from 192.168.1.1: bytes=32 time=0ms TTL=126
    12. Reply from 192.168.1.1: bytes=32 time=1ms TTL=126
    13. Ping statistics for 192.168.1.1:
    14. Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    15. Approximate round trip times in milli-seconds:
    16. Minimum = 0ms, Maximum = 1ms, Average = 0ms
    17. SERVER>ping 192.168.2.10
    18. Pinging 192.168.2.1 with 32 bytes of data:
    19. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    20. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    21. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    22. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    23. Ping statistics for 192.168.2.1:
    24. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    25. Approximate round trip times in milli-seconds:
    26. Minimum = 0ms, Maximum = 0ms, Average = 0ms
    27. SERVER>ping 192.168.3.1
    28. Pinging 192.168.3.1 with 32 bytes of data:
    29. Reply from 192.168.3.1: bytes=32 time=1ms TTL=126
    30. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    31. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    32. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    33. Ping statistics for 192.168.3.1:
    34. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    35. Approximate round trip times in milli-seconds:
    36. Minimum = 0ms, Maximum = 1ms, Average = 0ms

    4 案例4:RIP动态路由配置

    4.1 问题

    在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他路由器更新信息时又会消耗网络资源)。

    然而在大型网络中,网络非常多,而且很有可能因为某些因素的影响,网络拓扑会有轻微变化。这时如果仍然采用静态路由就非常不方便了。

    • 通过RIP实现路由间通信

    4.2 方案

    动态路由协议配置灵活,路由器会发送自身的路由信息给其他路由器,同时也会接收其他路由器发来的路由信息建立自己的路由表。这样在路由 器上就不必像静态路由那样为每个目标地址都配置路由,因为路由器可以通过协议学习这些路由。网络拓扑改变,路由信息也会自动更新,无需管理员干预。

    网络拓扑如图-6所示:

    图-6

    4.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:按图-6配置路由接口IP分别(与以前路由配置接口IP方法一致不再赘述配置)

    步骤二:在三台路由上配置RIP路由协议

    1. tarena-router1(config)#router rip
    2. tarena-router1(config-router)#version 2
    3. tarena-router1(config-router)#no auto-summary
    4. tarena-router1(config-router)#network 192.168.1.0
    5. tarena-router1(config-router)#network 192.168.2.0
    6. tarena-router2(config)#router rip
    7. tarena-router2(config-router)#version 2
    8. tarena-router2(config-router)#no auto-summary
    9. tarena-router2(config-router)#network 192.168.3.0
    10. tarena-router2(config-router)#network 192.168.2.0
    11. tarena-router3(config)#router rip
    12. tarena-router3(config-router)#version 2
    13. tarena-router3(config-router)#no auto-summary
    14. tarena-router3(config-router)#network 192.168.3.0
    15. tarena-router3(config-router)#network 192.168.4.0

    步骤三:分别在三台路由器上查看路由表

    注意以R开头的路由,这些路由表示通过RIP协议从其他运行RIP的路由器学习过来的路由。每条路由都写明了目标网络、下一跳IP地址以及从自己哪个端口发出去。

    1. tarena-router1#show ip route
    2. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    3. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    4. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    5. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    6. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    7. * - candidate default, U - per-user static route, o - ODR
    8. P - periodic downloaded static route
    9. Gateway of last resort is not set
    10. C 192.168.1.0/24 is directly connected, FastEthernet0/0
    11. C 192.168.2.0/24 is directly connected, FastEthernet0/1
    12. R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:26, FastEthernet0/1
    13. R 192.168.4.0/24 [120/2] via 192.168.2.2, 00:00:26, FastEthernet0/1
    14. tarena-router2#show ip route
    15. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    16. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    17. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    18. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    19. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    20. * - candidate default, U - per-user static route, o - ODR
    21. P - periodic downloaded static route
    22. Gateway of last resort is not set
    23. R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:04, FastEthernet0/1
    24. C 192.168.2.0/24 is directly connected, FastEthernet0/1
    25. C 192.168.3.0/24 is directly connected, FastEthernet0/0
    26. R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:09, FastEthernet0/0
    27. tarena-router3#show ip route
    28. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    29. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    30. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    31. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    32. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    33. * - candidate default, U - per-user static route, o - ODR
    34. P - periodic downloaded static route
    35. Gateway of last resort is not set
    36. R 192.168.1.0/24 [120/2] via 192.168.3.1, 00:00:20, FastEthernet0/0
    37. R 192.168.2.0/24 [120/1] via 192.168.3.1, 00:00:20, FastEthernet0/0
    38. C 192.168.3.0/24 is directly connected, FastEthernet0/0
    39. C 192.168.4.0/24 is directly connected, FastEthernet0/1

    步骤四:在PC上测试到主机的通信

    1. PC>ping 192.168.4.1
    2. Pinging 192.168.4.1 with 32 bytes of data:
    3. Reply from 192.168.4.1: bytes=32 time=0ms TTL=125
    4. Reply from 192.168.4.1: bytes=32 time=0ms TTL=125
    5. Reply from 192.168.4.1: bytes=32 time=0ms TTL=125
    6. Reply from 192.168.4.1: bytes=32 time=0ms TTL=125
    7. Ping statistics for 192.168.4.1:
    8. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    9. Approximate round trip times in milli-seconds:
    10. Minimum = 0ms, Maximum = 0ms, Average = 0ms

    5 案例5:三层交换配置RIP动态路由

    5.1 问题

    在三层交换机上配置RIP路由协议,以三层交换机代替路由器。

    • 通过RIP实现路由间通信

    5.2 方案

    动态路由协议配置灵活,路由器会发送自身的路由信息给其他路由器,同时也会接收其他路由器发来的路由信息建立自己的路由表。这样在路由 器上就不必像静态路由那样为每个目标地址都配置路由,因为路由器可以通过协议学习这些路由。网络拓扑改变,路由信息也会自动更新,无需管理员干预。

    网络拓扑如图-7所示:

    图-7

    5.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:VLAN以及端口配置与上面3三层交换配置路由完全一致,不再赘述配置

    步骤二:将上面【案例3:在三层交换机与路由器上配置路由】中的静态路由删除

    1. tarenasw-3L (config)#no ip route 192.168.7.0 192.168.6.2
    2. tarena-router(config)#no ip route 192.168.1.0 255.255.255.0 192.168.6.1
    3. tarena-router(config)#no ip route 192.168.2.0 255.255.255.0 192.168.6.1
    4. tarena-router(config)#no ip route 192.168.3.0 255.255.255.0 192.168.6.1
    5. tarena-router(config)#no ip route 192.168.4.0 255.255.255.0 192.168.6.1
    6. tarena-router(config)#no ip route 192.168.5.0 255.255.255.0 192.168.6.1

    步骤三:分别在三层交换机和路由器上配置RIP路由协议

    RIP路由协议在配置network时,只需要配置该路由器所直连的主类网络,不与该路由器直连的网络不需要包含在network中。

    RIP默认工作在第一版本下,但是RIP-V1是有类路由协议,而且通过广播的方式进行路由更新,无论是功能上还是效率上都有一些缺陷,这些缺陷RIP-V2可以弥补。在使用时建议采用RIP-V2而不是RIP-V1。

    1. tarenasw-3L(config)#router rip
    2. tarenasw-3L(config-router)#version 2
    3. tarenasw-3L(config-router)#no auto-summary
    4. tarenasw-3L(config-router)#network 192.168.1.0
    5. tarenasw-3L(config-router)#network 192.168.2.0
    6. tarenasw-3L(config-router)#network 192.168.3.0
    7. tarenasw-3L(config-router)#network 192.168.4.0
    8. tarenasw-3L(config-router)#network 192.168.5.0
    9. tarenasw-3L(config-router)#network 192.168.6.0
    10. tarena-router(config)#router rip
    11. tarena-router(config-router)#version 2
    12. tarenasw-3L(config-router)#no auto-summary
    13. tarena-router(config-router)#network 192.168.6.0
    14. tarena-router(config-router)#network 192.168.7.0

    步骤四:分别在三层交换机和路由器上查看路由表

    注意以R开头的路由,这些路由表示通过RIP协议从其他运行RIP的路由器学习过来的路由。每条路由都写明了目标网络、下一跳IP地址以及从自己哪个端口发出去。

    1. tarenasw-3L#show ip route
    2. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    3. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    4. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    5. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    6. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    7. * - candidate default, U - per-user static route, o - ODR
    8. P - periodic downloaded static route
    9. Gateway of last resort is not set
    10. C 192.168.1.0/24 is directly connected, Vlan1
    11. C 192.168.2.0/24 is directly connected, Vlan2
    12. C 192.168.3.0/24 is directly connected, Vlan3
    13. C 192.168.4.0/24 is directly connected, Vlan4
    14. C 192.168.5.0/24 is directly connected, Vlan5
    15. C 192.168.6.0/24 is directly connected, FastEthernet0/6
    16. R 192.168.7.0/24 [120/1] via 192.168.6.2, 00:00:12, FastEthernet0/6 0
    17. Router#show ip route
    18. Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    19. D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    20. N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    21. E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    22. i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    23. * - candidate default, U - per-user static route, o - ODR
    24. P - periodic downloaded static route
    25. Gateway of last resort is not set
    26. R 192.168.1.0/24 [120/1] via 192.168.6.1, 00:00:25, FastEthernet0/0
    27. R 192.168.2.0/24 [120/1] via 192.168.6.1, 00:00:25, FastEthernet0/0
    28. R 192.168.3.0/24 [120/1] via 192.168.6.1, 00:00:25, FastEthernet0/0
    29. R 192.168.4.0/24 [120/1] via 192.168.6.1, 00:00:25, FastEthernet0/0
    30. R 192.168.5.0/24 [120/1] via 192.168.6.1, 00:00:25, FastEthernet0/0
    31. C 192.168.6.0/24 is directly connected, FastEthernet0/0
    32. C 192.168.7.0/24 is directly connected, FastEthernet0/1

    步骤五:在PC上测试到五个VLAN中主机的通信

    1. PC>ipconfig
    2. FastEthernet0 Connection:(default port)
    3. Link-local IPv6 Address.........: FE80::2E0:8FFF:FE14:BB43
    4. IP Address......................: 192.168.7.1
    5. Subnet Mask.....................: 255.255.255.0
    6. Default Gateway.................: 192.168.7.254
    7. SERVER>ping 192.168.1.1
    8. Pinging 192.168.1.10 with 32 bytes of data:
    9. Reply from 192.168.1.1: bytes=32 time=0ms TTL=126
    10. Reply from 192.168.1.1: bytes=32 time=0ms TTL=126
    11. Reply from 192.168.1.1: bytes=32 time=0ms TTL=126
    12. Reply from 192.168.1.1: bytes=32 time=1ms TTL=126
    13. Ping statistics for 192.168.1.1:
    14. Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    15. Approximate round trip times in milli-seconds:
    16. Minimum = 0ms, Maximum = 1ms, Average = 0ms
    17. PC >ping 192.168.2.10
    18. Pinging 192.168.2.10 with 32 bytes of data:
    19. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    20. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    21. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    22. Reply from 192.168.2.1: bytes=32 time=0ms TTL=126
    23. Ping statistics for 192.168.2.1:
    24. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    25. Approximate round trip times in milli-seconds:
    26. Minimum = 0ms, Maximum = 0ms, Average = 0ms
    27. PC >ping 192.168.3.1
    28. Pinging 192.168.3.10 with 32 bytes of data:
    29. Reply from 192.168.3.1: bytes=32 time=1ms TTL=126
    30. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    31. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    32. Reply from 192.168.3.1: bytes=32 time=0ms TTL=126
    33. Ping statistics for 192.168.3.1:
    34. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    35. Approximate round trip times in milli-seconds:
    36. Minimum = 0ms, Maximum = 1ms, Average = 0ms
    37. PC >
    38. 31% /misc/nfsdir SERVER>ping 192.168.3.10
    39. Pinging 192.168.3.10 with 32 bytes of data:
    40. Reply from 192.168.4.1: bytes=32 time=1ms TTL=126
    41. Reply from 192.168.4.1: bytes=32 time=0ms TTL=126
    42. Reply from 192.168.4.1: bytes=32 time=0ms TTL=126
    43. Reply from 192.168.4.1: bytes=32 time=0ms TTL=126
    44. Ping statistics for 192.168.4.1:
    45. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    46. Approximate round trip times in milli-seconds:
    47. Minimum = 0ms, Maximum = 1ms, Average = 0ms
    48. PC>
    49. 31% /misc/nfsdir
    50. SERVER>ping 192.168.5.1
    51. Pinging 192.168.5.1 with 32 bytes of data:
    52. Reply from 192.168.5.1: bytes=32 time=1ms TTL=126
    53. Reply from 192.168.5.1: bytes=32 time=0ms TTL=126
    54. Reply from 192.168.5.1: bytes=32 time=0ms TTL=126
    55. Reply from 192.168.5.1: bytes=32 time=0ms TTL=126
    56. Ping statistics for 192.168.5.1:
    57. Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    58. Approximate round trip times in milli-seconds:
    59. Minimum = 0ms, Maximum = 1ms, Average = 0ms
    60. 31% /misc/nfsdir

    转载于:https://www.cnblogs.com/xiaoren112/p/8257620.html

    展开全文
  • 搞懂三层交换配置路由配置详解

    千次阅读 2020-03-27 18:23:03
    三层交换机上配置路由,实现全网互通。 使用eNSP搭建实验环境 步骤 实现此案例需要按照如下步骤进行。 1)交换机配置见上一篇博客 三层交换机配置 2)配置路由 [SW3]vlan 6 [SW3]int g0/0/3 [SW3 -...

    在三层交换机上配置路由,实现全网互通。
    使用eNSP搭建实验环境
    在这里插入图片描述

    步骤

    实现此案例需要按照如下步骤进行。

    1)交换机配置见上一篇博客

    三层交换机配置
    2)配置路由

    [SW3]vlan 6
    [SW3]int g0/0/3
    [SW3 -GigabitEthernet0/0/3]port link-type access
    [SW3 -GigabitEthernet0/0/3]port default vlan 6
    [SW3]int Vlanif 6
    [SW3-Vlanif6]ip add 192.168.6.254 24
    [SW3]ip route-static 192.168.7.0 255.255.255.0 192.168.6.1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.6.1 24
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.7.254 24
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.6.254
    [R1]dis ip ro
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11       
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
            0.0.0.0/0   Static  60   0          RD   192.168.6.254   GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.6.0/24  Direct  0    0           D   192.168.6.1     GigabitEthernet
    0/0/0
        192.168.6.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
      192.168.6.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
        192.168.7.0/24  Direct  0    0           D   192.168.7.254   GigabitEthernet
    0/0/1
      192.168.7.254/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
      192.168.7.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    3)测试PC间互通

    展开全文
  • 三层交换配置路由实现全网互通

    千次阅读 2018-11-27 12:34:31
    实验拓扑  实验步骤 [sw1]vlan batch 2 3 [sw1]interface Ethernet 0/0/1 [sw1-Ethernet0/0/1]port link-type access [sw1-Ethernet0/0/1]port default vlan 2 ...[sw1]interface Ethernet0/0/2 ...

    实验拓扑

     实验步骤

    [sw1]vlan batch 2 3
    [sw1]interface Ethernet 0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default vlan 2

     

    [sw1]interface Ethernet0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port default vlan 2

     

    [sw1]interface Ethernet0/0/3
    [sw1-Ethernet0/0/3]port link-type access
    [sw1-Ethernet0/0/3]port default vlan 3

     

    [sw1]interface GigabitEthernet 0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type trunk
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all

     

    [sw2]vlan batch 4 5
    [sw2]interface Ethernet 0/0/1
    [sw2-Ethernet0/0/1]port link-type access
    [sw2-Ethernet0/0/1]port default vlan 4

     

    [sw2]interface Ethernet 0/0/2
    [sw2-Ethernet0/0/2]port link-type access
    [sw2-Ethernet0/0/2]port default vlan 5

     

    [sw2]interface GigabitEthernet 0/0/2
    [sw2-GigabitEthernet0/0/2]port link-type trunk
    [sw2-GigabitEthernet0/0/2]port trunk allow-pass vlan all

     

    [sw3]vlan batch 2 to 5
    [sw3]interface GigabitEthernet 0/0/1
    [sw3-GigabitEthernet0/0/1]port link-type trunk
    [sw3-GigabitEthernet0/0/1]port trunk allow-pass vlan all

     

    [sw3]interface GigabitEthernet 0/0/2
    [sw3-GigabitEthernet0/0/2]port link-type trunk
    [sw3-GigabitEthernet0/0/2]port trunk allow-pass vlan all

     

    [sw3]interface Vlanif 2
    [sw3-Vlanif2]ip address 192.168.1.254 24
    [sw3-Vlanif2]undo shutdown

     

    [sw3]interface Vlanif 3
    [sw3-Vlanif3]ip address 192.168.2.254 24
    [sw3-Vlanif3]undo shutdown

     

    [sw3]interface Vlanif 4
    [sw3-Vlanif4]ip address 192.168.3.254 24
    [sw3-Vlanif4]undo shutdown

     

    [sw3]interface Vlanif 5
    [sw3-Vlanif5]ip address 192.168.4.254 24
    [sw3-Vlanif5]undo shutdown

     


    [sw3]vlan 6
    [sw3]interface GigabitEthernet 0/0/3
    [sw3-GigabitEthernet0/0/3]port link-type access
    [sw3-GigabitEthernet0/0/3]port default vlan 6

     

    [sw3]interface Vlanif 6
    [sw3-Vlanif6]ip address 192.168.5.1 24
    [sw3-Vlanif6]undo shutdown

     

    [sw3]ip route-static 192.168.6.254 255.255.255.0 192.168.5.2

     

    [AR1]interface GigabitEthernet 0/0/0
    [AR1-GigabitEthernet0/0/0]ip address 192.168.5.2 24
    [AR1-GigabitEthernet0/0/0]undo shutdown


    [AR1]interface GigabitEthernet 0/0/1
    [AR1-GigabitEthernet0/0/1]ip address 192.168.6.254 24
    [AR1-GigabitEthernet0/0/1]undo shutdown
    [AR1]ip route-static 0.0.0.0 0.0.0.0 192.168.5.1

     

     

     

     

    展开全文
  • 1)交换接口配置三层接口实现路由间通信 三层交换机既然具有三层功能,也就可以实现与路由器相似的配置。既可以把交换接口配置三层接口,也可以在其上配置静态、动态路由。通过对三层交换机的路由配置,实现VLAN...
  • 思科高级配置(三层交换配置路由)

    千次阅读 2019-05-15 21:18:15
    既可以把交换接口配置三层接口,也可以在其上配置静态、动态路由。通过对三层交换机的路由配置,实现VLAN与其他网络的互通。 网络的拓扑结构如所示: 步骤 实现此案例需要按照如下步骤进行。 步...
  • 思科设备三层交换配置路由实现互通

    千次阅读 多人点赞 2018-12-15 06:04:49
    实验拓扑:  
  • H3C三层交换VLAN配置实例
  • 掌握通过三层交换机实现VLAN间通信的配置方法 掌握通过以太网Trunk链路实现VLAN间通信的配置方法 掌握在不同VLAN间配置动态路由协议OSPF的方法
  • 华为eNSP——三层交换配置

    千次阅读 2019-11-09 11:23:06
    1,配置sw2交换机 <Huawei>sys [Huawei]sysname SW2 [SW2]vlan batch 10 20 ##创建vlan10 20 [SW2]int e0/0/2 [SW2-Ethernet0/0/2]port link-type access ##设置access [SW2-Ethernet0/0/2]port default vlan ...
  • 2008三层交换与路由综合配置.pdf 2008三层交换与路由综合配置.pdf
  • 交换机基本配置三层交换:【工程实验室】在路由器上配置Telnet、利用三层交换机实现VLAN间路由、跨交换机实现VLAN、交换机基本配置、在交换机上配置Telnet、利用单臂路由实现VLAN间路由、端口聚合配置、交换机的...
  • 实验目的:让PC-1通过动态获取IP地址 实验拓扑: 实验步骤:  
  • 三层交换配置常用命令

    千次阅读 2009-08-12 18:50:00
    三层交换相关知识一、在路由器上配置单臂路由router(config)#interface fastEthernet 0/0router(config-if)#no shutdownrouter(config-if)#exitrouter(config)#interface fastEthernet 0/0.1router(config-subif)#...
  • 三层交换与路由器之间连接配置

    千次阅读 2020-06-23 13:44:48
    今天配置三层交换配置如下: <Huawei>sys [Huawei]vlan batch 10 20 [Huawei]un in en Info: Information center is disabled. [Huawei]int gi 0/0/2 [Huawei-GigabitEthernet0/0/2]port link-type access ...
  • 思科三层交换机的配置及其实例, 相信肯定能给你帮助!
  • 使用Cisco Packet Tracer模拟器实现Cisco三层交换机实现Vlan间路由的配置脚本,内含每一步的详细操作及注释说明,包括配置接入层交换机、配置核心交换机、配置firewall路由器、配置ISP互联网路由器、配置分公司...
  • H3C 3600 三层交换配置实例

    千次阅读 2017-09-19 10:48:00
    举例讲解H3C配置三层交换机4个步骤详细用法,配置三层交换机通用的四个步骤就是:划分VLAN,并描述;给VLAN划网关;给VLAN指定端口;配置路由协议;学会这几个步骤之后就能解决所有的配置三层交换机的问题。 ...
  • 因为交换机的特殊性,通常存在多个接口需要做相同的配置,如将多个接口划入相同VLAN,这时就需要一种能够快速配置接口的方法。
  • 二、三层交换配置HSRP(热备份)

    千次阅读 2019-05-09 19:28:01
    目标: 以三层交换机代替路由器作为网关设备...步骤一:分别为三层交换机和路由器配置IP并开启三层交换机路由功能。 SM1(config)#ip routing SM1(config)#interface vlan 1 SM1(config-if)#ip address 192.168.1.25...
  • 思科 三层交换 DHCP 的配置

    千次阅读 2018-12-22 16:06:54
    思科 三层交换 DHCP 的配置 :   拓扑结构:   步骤: 在SW1和SW2上分别完成VLAN配置,并在VLAN中添加相应的端口成员,同时配置Trunk端口      在L3Switch 上创建VLAN10 和VLAN20 ,并配置VLAN10 的虚...
  • 配置单核心三层交换两层网络

    千次阅读 2019-11-17 20:16:25
    配置单核心三层交换两层网络 实验环境要求: 1、安装winxp、win7或winsrv 2003的pc机一台 2、cisco Packet Tracer7.0模拟器 总体目标:使用三层交换为核心,搭建总部、分公司、互联网拓扑结构。合理分配IP地址,配置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 137,980
精华内容 55,192
关键字:

三层交换配置