精华内容
下载资源
问答
  • 这是学习HCNP时的路由过滤&路由引入的实验!可参考博客:https://blog.csdn.net/qq_45668124/article/details/106646203
  • 一实验步骤 配置各台设备的ip地址 测试直连的连通性 配置RIP OSPF和ISIS路由协议 RIP路由引入到 OSPF中OSPF路由引入到 RIP中 ISIS路由引入到 OSPF中OSPF路由引入到ISIS中 路由的聚合 测试实验结果 二配置命令及其...
  • 4.将PC1 的路由引入OSPF中 [R1]ospf 1 [R1-ospf-1]import-route direct 5.将 PC2重发布到RIP中 [R4]rip [R4-rip-1]import-route direct 6.在R2 和R3上进行双点双向重发布 [R3]rip [R3-rip-1]import-route ospf 1 ...
  • 一实验步骤 配置各台设备的 ip 地址 测试直连的连通性 配置 RIP OSPF和 ISIS路由协议 RIP 路由引入到 OSPF 中 OSPF 路由引入到 RIP 中 ISIS路由引入到 OSPF 中 OSPF路由引入到 ISIS 中 路由的聚合 测试实验结果 二...
  • 路由过滤&路由引入实验

    千次阅读 2020-06-09 17:04:28
    本篇是路由过滤和路由引入的综合实验!


    实验参考【王文杰-在线文档库】
    实验拓扑【下载】

    路由过滤&路由引入实验

    如下拓扑图:

    路由过滤&路由引入实验
    实验需求

    1. 按照图示配置 IP 地址,R1,R5 上使用 loopback 口模拟业务网段
    2. R1 和 R2 运行 RIPv2,R2,R3,R4 和 R5 运行 OSPF,并在 R2 上进行单点双向路由引入
    3. 使用路由过滤,使 R3 区域无法学习到172.16.X.X/24网段的双数路由,要求使用 ACL 进行匹配
    4. 使用路由过滤,使 R4 区域无法学习到172.16.X.X/24网段的单数路由,要求使用 ACL 进行匹配
    5. 使用路由过滤,使 RIP 区域无法学习到 R5 的业务网段路由,要求使用 ip-prefix 进行匹配
    6. OSPF 区域不允许出现 RIP 协议报文

    基本配置

    # AR1基础配置
     sysname AR1
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 172.16.1.1 255.255.255.0 
    #
    interface LoopBack1
     ip address 172.16.2.2 255.255.255.0 
    #
    interface LoopBack2
     ip address 172.16.3.3 255.255.255.0 
    #
    interface LoopBack3
     ip address 172.16.4.4 255.255.255.0 
    
    # AR2基础配置
     sysname AR2
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 23.1.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/2
     ip address 24.1.1.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    
    # AR3基础配置
     sysname AR3
    #
    interface GigabitEthernet0/0/0
     ip address 23.1.1.3 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 35.1.1.3 255.255.255.0 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255 
    
    # AR4基础配置
     sysname AR4
    #
    interface GigabitEthernet0/0/0
     ip address 24.1.1.4 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 45.1.1.4 255.255.255.0
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    
    # AR5基础配置
     sysname AR5
    #
    interface GigabitEthernet0/0/0
     ip address 35.1.1.5 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 45.1.1.5 255.255.255.0 
    #
    interface LoopBack0
     ip address 192.168.1.1 255.255.255.0 
    #
    interface LoopBack1
     ip address 192.168.2.2 255.255.255.0 
    #
    interface LoopBack2
     ip address 192.168.3.3 255.255.255.0 
    #
    interface LoopBack3
     ip address 192.168.4.4 255.255.255.0 
    #                                         
    interface LoopBack4
     ip address 5.5.5.5 255.255.255.255 
    

    配置IGP

    • 配置RIPv2
    [AR1]rip
    [AR1-rip-1]v 2
    [AR1-rip-1]net 12.0.0.0
    [AR1-rip-1]net 172.16.0.0
    
    [AR2]rip
    [AR2-rip-1]v 2
    [AR2-rip-1]net 12.0.0.0
    
    • 配置OSPF
    [AR2]ospf router-id 2.2.2.2
    [AR2-ospf-1]area 0
    [AR2-ospf-1-area-0.0.0.0]net 23.1.1.0 0.0.0.255
    [AR2-ospf-1-area-0.0.0.0]net 24.1.1.0 0.0.0.255
    
    [AR3]ospf router-id 3.3.3.3
    [AR3-ospf-1]area 0
    [AR3-ospf-1-area-0.0.0.0]net 35.1.1.0 0.0.0.255
    [AR3-ospf-1-area-0.0.0.0]net 23.1.1.0 0.0.0.255
    
    [AR4]ospf router-id 4.4.4.4
    [AR4-ospf-1]area 0
    [AR4-ospf-1-area-0.0.0.0]net 45.1.1.0 0.0.0.255
    [AR4-ospf-1-area-0.0.0.0]net 24.1.1.0 0.0.0.255
    
    [AR5]ospf router-id 5.5.5.5
    [AR5-ospf-1]area 0
    [AR5-ospf-1-area-0.0.0.0]net 35.1.1.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.0]net 45.1.1.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.0]net 192.168.1.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.0]net 192.168.2.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.0]net 192.168.3.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.0]net 192.168.4.0 0.0.0.255
    
    • 配置单点双向映入
    [AR2]ospf 1
    [AR2-ospf-1]import-route rip 1
    [AR2-ospf-1]rip 1
    [AR2-rip-1]import-route ospf 1
    

    在R1上查路由表看是否有R5的业务网段的路由

    配置路由过滤

    • 使用ACL进行匹配,使R3无法学习到172.16.x.x/24的双数路由
    [AR3]acl 2000
    [AR3-acl-basic-2000]rule 5 deny source 172.16.0.0 0.0.6.0
    [AR3-acl-basic-2000]rule 10 permit source any 
    # OSPF使用filter-policy工具调用ACL
    [AR3-acl-basic-2000]ospf 
    [AR3-ospf-1]filter-policy 2000 import
    

    在R3上查看OSPF路由表,是否还有相应的路由

    • 使用ACL进行匹配,是R4无法学习到172.16.x.x/24的单数路由
    [AR4]acl 2000
    [AR4-acl-basic-2000]rule 5 deny source 172.16.1.0 0.0.2.0    
    [AR4-acl-basic-2000]rule 10 permit source any  
    
    # OSPF使用filter-policy工具调用ACL
    [AR4]ospf 
    [AR4-ospf-1]filter-policy 2000 import 
    

    在R4上查看OSPF路由表,是否还有相应的路由

    • 使用IP-Prefix进行匹配,使RIP区域无法学习到R5的业务网段
    # 利用IP-Prefix对路由进行匹配
    [AR2]ip ip-prefix bad permit 192.168.0.0 21 less-equal 32
    
    # 利用Route-Policy调用IP-Prefix
    [AR2]route-policy bad deny node 5
    [AR2-route-policy]if-match ip-prefix bad 
    [AR2]route-policy bad permit node 10  //默认允许所有通过
    
    # 基于RIP引用OSPF时调用路由策略
    [AR2]rip 
    [AR2-rip-1]import-route ospf 1 route-policy bad
    
    • 必须要创建空节点,如果没有匹配到,默认是拒绝
    • 在R1查看RIP路由表,查看是否还有R5的业务网段
    • OSPF区域不允许出现RIP协议报文
    [AR2]rip 1
    [AR2-rip-1]silent-interface g0/0/1
    [AR2-rip-1]silent-interface g0/0/2
    
    以上内容均属原创,如有不详或错误,敬请指出。
    
    本文作者: 坏坏
    展开全文
  • 路由引入与控制

    千次阅读 2018-12-11 14:32:54
    通过配置路由引入可以实现不同协议间的路由信息交互,但是随着网络环境的变化,或者设计 及操作上的不当则很可能造成路由环路及次优路径的产生,这将造成网络资源的不必要耗费,更严 重的将导致通信产生故障。因此为了...

    通过配置路由引入可以实现不同协议间的路由信息交互,但是随着网络环境的变化,或者设计
    及操作上的不当则很可能造成路由环路及次优路径的产生,这将造成网络资源的不必要耗费,更严
    重的将导致通信产生故障。因此为了避免这些网络问题的产生,则需要在进行路由引入的操作时增
    加一些限定条件,即借助路由策略来实现路由控制。

    1.路由策略介绍
    路由策略是一种比基于目标网络进行路由更加灵活的数据包路由转发机制,路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。应用了路由策略,
    路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器。
    在特定的场景中,路由策略的6种过滤器也能单独使用,实现路由过滤。若设备支持 BGP to IGP功能,还能在GP引入BGP路由时,使用BGP私有属性作为匹配条件。
    2.路由策略原理
    一个 Route-Policy由多个节点构成,路由进入路由策略后,按节点序号从小到大依次检查各个节点是否匹配。一个节点包括多个 match和 apply子句。 if-match子句用来定义该节点的匹配条件, apply子句用
    来定义通过过滤的路由行为。 if-match子句的过滤规则关系是“与”,即该节点的所有 f-match子句都必须匹配
    Route-Policy节点间的过滤关系是“或”,即只要通过了一个节点的过滤,就可通过该 Route-Policy。如果
    没有通过任何一个节点的过滤,路由信息将无法通过该 Route-Policy。对于同一个 Route-Policy节点,在匹
    配过程中,各个 match子句间是“与”的关系,即路由信息必须同时满足所有匹配条件,才可以执行 apply
    子句的动作。
    当路由与该节点的所有 -match子句都匹配成功后,进入匹配模式选择,不再匹配其他节点。匹配模式
    分为 permit和deny两种:如果匹配模式是 permit,那么路由将被允许通过,并且执行该节点的Appy子句
    对路由信息的一些属性进行设置;如果匹配模式是deny,路由将被拒绝通过。
    3.路由选路工具
    路由策略中|- match子句中匹配的的6种过滤器包括访问控制列表( Access Control List,ACL)、地
    址前缀列表、AS路径过滤器、团体属性过滤器、扩展团体属性过滤器和RD属性过滤器。这6种过滤器具有各
    自的匹配条件和匹配模式,因此这6种过滤器在以下特定情况中可以单独使用,实现路由过滤。下面我们把常
    用的访问控制列表和地址前缀列表进行讲解
    访问控制列表( Access Control List,ACL)是由 permit或deny语句组成的一系列有顺序规则的集合
    它通过匹配报文的信息实现对报文的分类。根据ACL定义的规则判断哪些报文可以接收,哪些报文需要拒绝
    从而实现对报文的过滤。ACL本身只是一组规则,只能区分某一类报文,无法实现过滤报文的功能。对这类报
    文的处理方法,需要由引用ACL的具体功能来决定。
    同时每个ACL作为一个规则组,可以包含多个规则。规则通过规则1D(rue-d)来标识,规则|D可以
    由用户进行配置,也可以由系统自动根据步长生成。一个ACL中所有规则均按照规则D从小到大排序。规则
    D之间会留下一定的间隔。如果不指定规则|D时,具体间隔大小由“ACL的步长”来设定。用户可以根据规
    则|D方便地把新规则插入到规则组的某一位置。当报文到达设备时,查找引擎从报文中取出信息组成查找键值
    键值与ACL中的规则进行匹配,只要有一条规则和报文匹配,就停止查找,称为命中规则。查找完所有规则
    如果没有符合条件的规则,称为未命中规则。华为ACL缺省隐含最后一条规则为 permit。ACL类型根据不同
    的划分规则可以有不同的分类。
    1.按照创建ACL时的命名方式分类
    (1)数字型ACL
    (2)命名型ACL
    2.按照ACL的功能分类

    (1)基于接口的ACL根据报文的入接口定义规则,实现对报文的匹配过滤。通过命令 traffic- filter调用
    ACL。
    (2)基本ACL可使用报文的源P地址、VPN实例、分片标记和时间段信息来定义规则。
    (3)高级ACL既可使用报文的源P地址,也可使用目的地址、IP优先級、ToS、DSCP、|P协议类型、
    CMP类型、TCP源端口/目的端口、UDP源端口/目的端口号等来定义规则。高级访问控制列表可以定义比
    基本访问控制列表更准确、更丰富、更灵活的规则。
    (4)二层ACL可根据报文的以太网帧头信息来定义规则,如根据源MAC地址、目的MAC地址、以太帧协议类型等。
    二,策略路由介绍
    传统的路由转发原理是首先根据报文的目的地址查找路由表,然后进行报文转发。但是目前越来越多的用
    户希望能够在传统路由转发的基础上根据自己定义的策略进行报文转发和选路。策略路由使网络管理者不仅能
    够根据报文的目的地址,而且能够根据报文的源地址、报文大小和链路质量等属性来制定策略路由,以改变数
    据包转发路径,满足用户需求。
    ( Policy- Based Routing,PBR)是一种依据用户制定的策略进行路由选择的机制,分为本地策
    策略路由
    略路由、接口策略路由和智能策略路由( Smart Policy Routing,SPR)。根据用户实际需求制定策略进行路
    由选择,增强路由选择的灵活性和可控性,使不同的数据流通过不同的链路进行发送,提高链路的利用效率。
    在满足业务服务质量的前提下,选择费用较低的链路传输业务数据,从而降低企业数据服务的成本。策略路由
    支持基于ACL、报文长度等信息,来灵活地指定数据包的转发路径。
    1,本地策略路由原理
    本地策略路由仅对本机下发的报文进行处理,对转发的报文不起作用。一条本地策略路由可以配置多个策略点,并且这些策略点具有不同的优先级,本机下发报文优先匹配优先级高的策略点。
    如图42所示,本机下发报文时,根据本地策略路由节点的优先级,依次匹配各节点绑定的匹配规则,本地策略路由支持基于ACL或报文长度的匹配规则。
    如果找到了匹配的本地策略路由节点,则按照以下步骤发送报文。
    1.查看用户是否设置了报文的优先级
    (1)如果用户设置了报文的优先级,首先根据用户设置的优先级设置报文的优先级,然后继续向下执行。
    (2)如果用户未设置报文的优先级,则继续执行
    2.查看用户是否设置了本地策略路由的出接口
    (1)如果用户设置了出接口,将报文从出接口发送出去,不再执行后续步骤
    (2)如果用户未设置出接口,则继续执行
    3.查看用户是否设置了本地策略路由的下一跳(用户可以设置两个下一跳以达到负载分担的目的)
    (1)如果用户设置了策略路由的下一跳,将报文发往下一跳,不再继续执行。
    (2)如果用户未设置下一跳,按照正常流程根据报文的目的地址查找路由。如果没有查找到路由,则继
    续执行
    4.查看用户是否设置了本地策略路由的缺省出接口
    (1)如果用户设置了缺省出接口,将报文从缺省出接口发送出去,不再执行后续步骤
    (2)如果用户未设置缺省出接口,则继续执行。
    查看用户是否设置了本地策略路由的缺省下
    (1)如果用户设置了缺省下一跳,将报文发往缺省下一跳,不再继续执行。
    (2)如果用户未设置缺省下一跳,则继续执行。
    6.根据目的地址查找路由
    丢弃报文,产生| CMP UNREACH消息,如果没有找到匹配的本地策略路由节点,按照发送P报文的一般流程,根据目的地址查找路由。
    3接口策略路由原理
    接口策略路由只对转发的报文起作用,对本地下发的报文(比如本地的Png报文)不起作用。接口策略路由通过在流行为中配置重定向实现,只对接口入方向的报文生效。缺省情况下,设备按照路由表的下一跳进行报文转发,如果配置了接口策略路由,则设备按照接口策略路由指定的下一跳进行转发。
    在按照接口策略路由指定的下一跳进行报文转发时,如果设备上没有该下一跳|P地址对应的ARP表项,设备会触发ARP学习。如果一直学习不到下一跳P地址对应的ARP表项,则报文按照路由表指定的下一跳进行转发;如果设备上有或者学习到了此ARP表项,则按照接口策略路由指定的下一跳|P地址进行报文转发。
    4.智能策略路由原理
    智能策略路由是基于业务需求的策略路由,通过匹配链路质量和网络业务对链路质量的需求,实现智能选路.随着网络业务需求的多样化,业务数据的集中放置,链路质量对网络业务越来越重要。越来越多的用户把关注点从网络的连通性转移到业务的可用性上,如业务的可获得性、响应速度和业务质量等。这些复杂的业务需求给传统的基于逐跳的路由协议提出了挑战,它们无法感知链路的质量和业务的需求,所以带给用户的业务体验也得不到保障,即使路由可达,但链路质量可能已经很差甚至无法正常转发报文了。智能策略路由( Smartblicy Routing.SPR)就是在这一背景下产生的一种策略路由,它可以主动探测链路质量并匹配业务的需求从而选择一条最优链路转发业务数据,可以有效地避免网络黑洞、网络震荡等问题
    SPR支持通过以下属性对业务进行区分:
    SPR支持通过以下属性对业务进行区分
    (1)根据协议类型区分:|P,TCP,UDP,GRE,lGMP,IP|NP,OSPF,ICMP。
    (2)根据报文应用区分:DSCP,TOS, IP Precedence, Fragment,VPN,TCP-flag。
    (3)根据报文信息区分: Source IP Address, Destination| P Address, Protocol, Source Port, Destination
    Port, Source IP Prefi, Destination IP Prefiⅸx。
    不同的业务对链路的时延D( Delay)、抖动时间J( Jitter、丢包率L(Los以及综合度量指标( Composite
    Measure Indicator,cM)有不同的要求,如果业务对链路的某一项质量参数没有要求,就不需要配置该参
    数的阈值。

    展开全文
  • 路由引入原理与配置

    千次阅读 2020-09-12 22:19:35
    路由引入 一个网段进入路由协议方法: 宣告 ---协议内部路由 直连 路由引入 其他路由协议路由 ( 将外部路由协议引入内部路由协议,将内部路由协议重发布置外部路由协议) 动态路由协议可以把其他...

     路由引入

     

    一个网段进入路由协议方法:

     

     宣告   ---协议内部路由

     直连

    路由引入

     其他路由协议路由

    ( 将外部路由协议引入内部路由协议,将内部路由协议重发布置外部路由协议)

     

     

    动态路由协议可以把其他路由协议的路由进行引入操作

     

    ​       直连     ---不能引入

     

    ​       静态    ---不能引入

     动态   ---可以引入其他

     

    引入的命令

    (先进入内部或外部路由协议再进行重发布)

     

    import-route   direct|ospf|bgp|isis|static       {cost  }

     

     

     

    路由引入的原理

     

    路由引入是一种复制路由表的操作,把被引入路由在路由表中所有的标志路由以及属于这个被引入路由协议的直连复制进相应路由协议,并初始化开销。该操作是一种距离矢量的操作。

     

    (引入时默认优先级类型为2(不携带引入路由协议的度量值),外部路由协议引入后自动生成成种子度量值)

     

     

     

    路由引入的过滤和参数修改需要路由工具route-policy

    (可通过ACL或前缀列表进行路由策略)

     

     

    路由引入的次优路径与环路

     

    次优路径一般发生在双点或者多点路由引入环境中,路由选择优先级小的一方到达时会走次优路径。

     

    次优路径的解决:

     

     OSPF 的内外俩种不同路由优先级会出现水平分割效应(ospf内部路由的优先级比其他动态协议低,外部比其他高),ospf内部路由可以避免次优路由。

     

     通过路由过滤实现

      通过filter-policy过滤工具过滤掉在相应路由域形成次优路径的路由

    [R1]ip ip-prefix xx permit 2.2.2.2 32

    [R1-isis-1]import-route isis level-2 into level-1 filter-policy ip-prefix xx

     通过修改路由优先级

      preference 命令修改

    [R1]interface g0/0/1

    [R1-GigabitEthernet0/0/1]isis dis-priority 88

     

     

    如果选择最佳的修改方案,涉及在路由增加或者修改场景下依然有效的解决方案建议选择修改路由优先级。

     

     

     

    路由环路

     

    通过路由引入的策略route-policy来完成水平分割的效果

    ((设内部边界路由器有两个路由出口通往外部路由协议)将内部路由的两个出口做重发布时打上标记,再做路由策略时将一个口设置成路由入口时另一个口拒绝此路由转发。

         则该标记流量从一口进入就不会从2口 回来,这样就可以避免因路由延时形成环路)

     

    [r2]route-policy tar permit node 10

    [r2-route-policy]apply tag 100

    [r2-isis-1]import-route ospf route-policy tag

       

    [r3]route-policy tag deny node 10

    [r3-route-policy]if-match tag 100

    [r3]route-policy tag permit node 20

    [r3-ospf-100]import-route isis route-policy tag

     

     

     

     

    ACL与ip-prefix的区别

     

    ACL一般用来匹配流量,也可用来匹配路由但是前缀相同掩码不同的时候不能区分。

     

    ​    10.1.0.0/24    0000001   0.0.0.1 255.255.255.254

     

    ​    10.1.0.0/16  10.1.0.0 0.0.255.255

     

    ​    10.1.0.0/22

     

    acl通过反掩码匹配,反掩码匹配的原理是二进制的0匹配,1是不在乎

     

     

     

    ip-prefix一般用来匹配路由

     

    ip-prefix通过掩码匹配,能够区别相同前缀不同掩码的路由

     

    反码在范围匹配的时候有优势,掩码没有优势,前缀列表是通过大于小于来实现范围匹配的

     

     

     

    展开全文
  • R1上拥有一条静态路由192.168.1.0/24并且将其引入到了OSPF中,R2拥有一条2.2.2.0/24的路由(LoopBack 0 接口上配置)并将其通告到了OSPF,R5拥有一条5.5.5.0/24的路由(LoopBack 0 接口上配置)并将其通告到了ISIS中...

    题目:

           现在有如下拓扑图,此网络拥有A、B两个区域。A区域运行了OSPF协议,B区域运行了ISIS协议。R1上拥有一条静态路由192.168.1.0/24并且将其引入到了OSPF中,R2拥有一条2.2.2.0/24的路由(LoopBack 0 接口上配置)并将其通告到了OSPF,R5拥有一条5.5.5.0/24的路由(LoopBack 0 接口上配置)并将其通告到了ISIS中。
           现在需要将OSPF和ISIS产生的路由双点双向引入即在R3和R4上相互映入OSPF和ISIS路由,但时引入的过程中会产生路由回馈、路由环路、次优路径问题怎样解决?
    在这里插入图片描述

    1.参考以下配置各自做通A、B两个区域,并完成基础配置。
    R1配置:
    
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 10.1.12.1 24
    [R1-GigabitEthernet0/0/0]q
    [R1]ip route-static 192.168.1.0 24 NULL 0
    [R1]ospf 1 router-id 1.1.1.1
    [R1-ospf-1]a 0
    [R1-ospf-1-area-0.0.0.0]network 10.1.12.1 0.0.0.0
    [R1-ospf-1-area-0.0.0.0]q
    [R1-ospf-1]import-route static cost 2 type 1
    
    R2配置:
    [R2]int LoopBack 0
    [R2-LoopBack0]ip add 2.2.2.2 24
    [R2-LoopBack0]ospf network-type broadcast 
    [R2-LoopBack0]q
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 10.1.12.2 24
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 10.1.23.2 24
    [R2-GigabitEthernet0/0/1]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip add 10.1.24.2 24
    [R2-GigabitEthernet0/0/2]q
    [R2]ospf 1 router-id 2.2.2.2
    [R2-ospf-1]a 0
    [R2-ospf-1-area-0.0.0.0]network 10.1.0.0 0.0.255.255
    [R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    
    R3的配置:
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 10.1.23.3 24
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 10.1.35.3 24
    [R3-GigabitEthernet0/0/1]q
    [R3]ospf 1 router-id 3.3.3.3
    [R3-ospf-1]a 0
    [R3-ospf-1-area-0.0.0.0]network 10.1.23.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]q
    [R3-ospf-1]q
    [R3]isis 1
    [R3-isis-1] is-level level-2
    [R3-isis-1] network-entity 49.0001.0000.0000.0003.00
    [R3-isis-1]int g0/0/1
    [R3-GigabitEthernet0/0/1]isis enable 1
    
    R4配置:
    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 10.1.24.4 24
    [R4-GigabitEthernet0/0/1]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip add 10.1.45.4 24
    [R4-GigabitEthernet0/0/0]q
    [R4]ospf 1 router-id 4.4.4.4
    [R4-ospf-1]a 0
    [R4-ospf-1-area-0.0.0.0]network 10.1.24.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.0]q
    [R4-ospf-1]q
    [R4]isis 1
    [R4-isis-1] is-level level-2
    [R4-isis-1] network-entity 49.0001.0000.0000.0004.00
    [R4-isis-1]q
    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]isis enable 1
    
    R5配置:
    [R5]int LoopBack 0
    [R5-LoopBack0]ip add 5.5.5.5 24
    [R5-LoopBack0]q
    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip add 10.1.35.5 24
    [R5-GigabitEthernet0/0/0]int g0/0/1
    [R5-GigabitEthernet0/0/1]ip add 10.1.45.5 24
    [R5-GigabitEthernet0/0/1]q
    [R5]isis 1
    [R5-isis-1] is-level level-2
    [R5-isis-1] network-entity 49.0001.0000.0000.0005.00
    [R5-isis-1]q
    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]isis enable  1
    [R5-GigabitEthernet0/0/0]int g0/0/1
    [R5-GigabitEthernet0/0/1]isis enable  1
    [R5-GigabitEthernet0/0/1]int loo 0
    [R5-LoopBack0]isis enable  1
    

           查看R3的OSPF和ISIS路由表:
    在这里插入图片描述

    在这里插入图片描述

    2.在R3上将OSPF的路由引入到ISIS中、R4上将OSPF的路由引入到ISIS中。

           此时就会产生次优路径问题:因为R1将外部路由192.168.1.0/24引入到OSPF时的优先级是150(参考上图),但是R3将OSPF的路由引入到ISIS时,去往192.168.1.0/24的路由优先级是15,导致R4在访问192.168.1.0/24时下一跳会变成10.1.45.5,而不是最优的10.1.23.2。
    在这里插入图片描述

           解决办法:在R4修改外部路由的优先级为10。

    [R4]ospf 1
    [R4-ospf-1]preference ase 10
    

    查看R4的路由表,R4在访问192.168.1.0/24时下一跳会变成10.1.23.2。
    在这里插入图片描述
           R4上将OSPF的路由引入到ISIS中同理会导致R3产生次优路径问题,解决办法在R3上执行相同的配置。

    3.在R4上将ISIS的路由引入到OSPF中。

           产生的问题:(1)路由回馈:由于在R3上将OSPF的路由引入到了ISIS中,再将R4的ISIS引入到OSPF时,会将已经引入到ISIS的OSPF路由通过R4回馈给OSPF;在R4的OSPF进程上成功引入ISIS的路由之后,此时R3的ISIS进程上引入的OSPF路由,又会将R4引入的ISIS路由回馈给自己的ISIS进程。
    (2)次优路径:因为R4的ISIS引入到OSPF时,之前ISIS的路由会变成OSPF的内部优先级10,导致R3去往5.5.5.0/24的路由下一跳会变成10.1.23.2这个不是最优的。
    在这里插入图片描述

           解决办法:(1)在执行OSPF路由引入到ISIS时,在R3上将引入的路由打上tag 10,在R4上打上tag 20,然后R4配置一条路由策略拒绝tag 10的路由从ISIS再次引入到OSPF中,允许其他路由引入并打上tag 30;配置R3上配置一条路由策略将tag等于30的路由拒绝掉,再将其他路由引入到ISIS并打上tag 10。
    (2)在R3上配置一条路由策略将tag等于30的路由的优先级修改成20

           在进行配置之前需要在R3、R4、R5的ISIS视图下执行前两条条命令:

    [R3]isis 
    [R3-isis-1]cost-style wide
    [R3-isis-1]import-route ospf 1 tag 10
    
    [R4]isis 
    [R4-isis-1]cost-style wide
    [R4-isis-1]import-route ospf 1 tag 20
    

           查看ISIS的LSDB已经成功打上tag:
    在这里插入图片描述
    在这里插入图片描述

    [R4]route-policy ItO deny node 10
    Info: New Sequence of this List.
    [R4-route-policy]if-match tag 10
    [R4-route-policy]q
    [R4]route-policy ItO permit node 20
    Info: New Sequence of this List.
    [R4-route-policy]apply tag 30
    [R4-route-policy]q
    [R4]ospf 1
    [R4-ospf-1]import-route isis 1 route-policy ItO
    
    [R3]route-policy OtI deny node 10
    Info: New Sequence of this List.
    [R3-route-policy]if-match tag 30
    [R3-route-policy]q
    [R3]route-policy OtI permit node 20
    Info: New Sequence of this List.
    [R3-route-policy]apply tag 10
    [R3-route-policy]q
    [R3]isis
    [R3-isis-1]import-route ospf 1 route-policy OtI 
    
    [R3]route-policy ase permit node 10
    Info: New Sequence of this List.
    [R3-route-policy]if-match tag 30
    [R3-route-policy]apply preference 20
    [R3-route-policy]q
    [R3]ospf 1
    [R3-ospf-1]preference ase route-policy ase 10    //匹配route-policy的路由优先级改为20,不匹配的改为10
    
    4.在R3上将ISIS的路由引入到OSPF中。

           产生的问题:和上面的类似(1)路由回馈:由于在R4上将OSPF的路由引入到了ISIS中,再将R3的ISIS路由引入到OSPF时,会将已经引入到ISIS的OSPF路由通过R3回馈给OSPF;在R3的OSPF进程上成功引入ISIS的路由之后,此时R4的ISIS进程上引入的OSPF路由,又会将R3引入的ISIS路由回馈给自己的ISIS进程。
    (2)次优路径:因为R3的ISIS引入到OSPF时,之前ISIS的路由会变成OSPF的内部优先级10,导致R4去往5.5.5.0/24的路由下一跳会变成10.1.24.2这个不是最优的。
           解决办法:(1)在R3配置一条路由策略拒绝tag 20的路由从ISIS再次引入到OSPF中,允许其他路由引入并打上tag 40;配置R3上配置一条路由策略将tag等于40的路由拒绝掉,再将其他路由引入到ISIS并打上tag 10。
    (2)在R4上配置一条路由策略将tag等于40的路由的优先级修改成20。

    [R3]route-policy ItO deny node 10
    Info: New Sequence of this List.
    [R3-route-policy]if-match tag 20
    [R3-route-policy]q
    [R3]route-policy ItO permit node 20
    Info: New Sequence of this List.
    [R3-route-policy]apply tag 40
    [R3-route-policy]q
    [R3]ospf 1
    [R3-ospf-1]import-rout isis 1 route-policy ItO 
    
    [R4]route-policy OtI deny node 10
    Info: New Sequence of this List.
    [R4-route-policy]if-match tag 40
    [R4-route-policy]q
    [R4]route-policy OtI permit node 20
    Info: New Sequence of this List.
    [R4-route-policy]apply tag 20
    [R4]isis
    [R4-isis-1]import-route ospf 1 route-policy OtI 
    
    [R4]route-policy ase permit node 10
    Info: New Sequence of this List.
    [R4-route-policy]if-match tag 40
    [R4-route-policy]apply preference 20
    [R4-route-policy]q
    [R4]ospf 1
    [R4-ospf-1]preference ase route-policy ase 10
    

           查看R3路由表,和没做通全网时的路由表完全相同,现在全网互通:
    在这里插入图片描述
    在这里插入图片描述
     

    总结:
    R3 :
    OSPF to ISIS:自生路由打上tag 10 permit;tag 30 deny
    ISIS to OSPF:deny tag 20;自生路由打上tag 40 permit 
    ase :tag 30 permit preference 20 
    
    R4:
    OSPF to ISIS:自生路由打上tag 20 permit;tag 40 deny
    ISIS to OSPF:deny tag 10;自生路由打上tag 30 permit
    ase:tag 40 permit preference 20 
    

    在这里插入图片描述

    展开全文
  • 双点双向路由引入案例

    千次阅读 2020-07-16 09:51:45
    双点双向路由引入案例: 在大型复杂的IP网络中,会存在多种路由协议,为了是网络中路径互通,必然会在多种协议之间进行重分布使路由信息的共享.在进行多点双向重分布时,由于路由协议优先级的不同,会引起次优路径的问题...
  • 华为双点双向路由引入

    千次阅读 2019-11-14 11:25:38
    华为双点双向路由引入 topology 2 还未引入时R2路由表信息 1、R1将RIP引入中间系统 注:R1将RIP引入中间系统,R1的路由表是不受影响的,R3会通过R1的引入学习到路由信息并通过ISP(链路数据包)同步给R2;本身R2通过...
  • 路由引入实验

    2013-06-08 09:40:34
    动态路由ospf 和静态rip 配置运用模拟工具
  • 在大型复杂的IP网络中,会存在多种路由协议,为了是网络中路径互通,必然会在多种协议之间进行重分布使路由信息的共享.在进行多点双向重分布时,由于路由协议优先级的不同,会引起次优路径的问题。 首先我们搭建一个如图...
  • 这篇文章来记录不同协议之间路由引入的一个问题。前面的示例大家可以看这篇文章: https://blog.csdn.net/weixin_43997530/article/details/108908937 从图中我们可以看出,公司的网络拓扑.
  • HUAWEI(13)——路由引入

    千次阅读 2019-05-04 17:42:55
    路由引入实验文档 实验拓扑: IP地址规划: 设备名称 接口 IP地址 默认网关 子网掩码 AR1 GE0/0/0 10.1.12.1 ...
  • ospf路由引入

    千次阅读 2020-02-01 20:14:12
    network 192.168.1.0 255.255.255.0 --此时,不仅将network宣告到ospf...--导入默认路由: [r1-ospf-1]default-route-advertise always :always的目的,是当接口不稳定时,还产生此默认外部路由 从上图,可以...
  • 路由重分布-路由引入

    2020-02-07 13:49:49
    ciscorouter ospfred static华为ospfimport staticH3Cospf 1import-route路由引入,即路由重分布,多个运行不同路由协议的网络,通过asbr(自治系统边界路由器)互相交换路由信息。如果这些网是不同的路由协议,那么...
  • 静态路由(英语:Static routing) 一种路由的方式,路由项(routing entry)由手动配置,而非动态决定。与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是由...
  • H3CSE路由-路由引入

    千次阅读 2018-02-26 17:45:19
    路由引入:将路由信息从一种协议导入到另一种协议中被引入的路由信息是 ASBR 设备 IP路由表中 以 某种路由形式 存在的 路由信息(1)acl或前缀列表匹配 10.0.0.0/24(2)route-policy 策略名 deny node 10 if-...
  • HCIE之路-11 路由引入,路由控制 路由引入基础,路由策略基础,策略路由基础,PBR基础 路由引入时注意哪些点
  • 本篇是路由过滤和路由引入的综合实验练习!
  • ISIS的路由引入

    千次阅读 2019-09-18 07:18:21
    这条路由引入为什么要加level-1 因为路由引入默认level-2在ISIS里面传播的,AR1识别不了level-2,所以改一成level-1,才能引入 AR2上的配置 interface GigabitEthernet0/0/0 ip address 10.0.12.2 255.255.255.0...
  • 静态路由和直连路由引入配置
  • 实验说明: 1.按照图示配置IP地址,R5的Lookback地址为192.168.1.0/24网段;R6的Lookback地址为192.168.2.0/24,绿色区域为ospf10,橙色...3.根据下方图示做路由引入也就是在R3上做ospf引入到ospf20;R4上做ospf20引...
  • 问题描述 ospf和rip协议的双点双向会造成路由环路,双点单向引入也会路由环路。 问题产生的环境
  • 当OSPF引入外部路由时,缺省情况下引入的外部路由不继承原有路由的cost值,而是设置缺省cost值为1。 如果不希望引入的外部路由采用缺省的cost值,可以使用命令default { cost { cost | inherit-metric }改变引入的...
  • 路由引入技术总结

    千次阅读 2017-10-07 17:34:42
    路由引入技术总结网络中由于各种不同的路由协议的度量值和计算方法的差异,不同路由域的路由协议间是无法进行路由学习的,为了解决不同路由域不同路由协议间的路由的学习,提出了路由引入技术,思科网络中将此称之为...
  • 那么只能在R2的rip协议配置出方向的filter-policy,那么问题来了,由于地址前缀列表的默认规则是拒绝的,如果我这里只允许2.0、3.0网段通过的话,那么接下来的路由引入中的ospf路由R2是不能向R1发布的。所以这里应该...
  • 利用路由策略来解决路由引入过程中产生的次优路径和环路问题:如左边拓扑图所示:在一个运行ospf的区域和rip区域,在AR2上进入ospf进程引入直连路由,ospf引入的外部路由优先级默认为 150,在AR5上进入rip进程引入...
  • 华为OSPF路由引入外部路由type1 or 2

    千次阅读 2020-08-11 16:55:26
    华为OSPF路由引入外部路由type1 or 2应用场景OSPF 的路由分类开销值计算公式配置举例查看SwitchC的ABR和ASBR信息 应用场景 引入其他路由协议,扩充OSPF的路由信息 OSPF 的路由分类 区域内部路由:指一个自治系统...
  • 由于两个ISIS区域之间使用EBGP相连接,所以L2类型路由器无法传递,所以就需要使用EBGP的设备进行路由引入。 由于BGP的路由优先级为255所以双向引入时不需要靠考虑防环

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 154,439
精华内容 61,775
关键字:

路由引入