精华内容
下载资源
问答
  • SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。 Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx //后面参数tx意思是监控0/0接口...

    SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。

    Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx   //后面参数tx意思是监控0/0接口发送的流量,默认为both,即监控收发的流量

    Switch(config)#monitor session 1 destination interface fastEthernet 0/1   //把session 1里面接口(fastEthernet 0/0)的流量复制一份发送到fastEthernet 0/1,destination fa0/1接口不能正常收发流量,只能接收镜像过来的流量

     

    RSPAN:远端的设备端口口监控;源端口和目的端口不在同一台交换机上。

     

    在源端口交换机上配置:

    Switch1(config)#vlan100   //vlan号必须独立于现网使用的vlan,不能和业务vlan相同,

    Switch1(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch1(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch1(config)#monitor session 2 source interface Gig 0/1   //配置要抓取原端口的流量

    Switch1(config)#monitor session 2 destination remote vlan 100   //目的端口配置为SPAN的vlan

     

    在目的端口交换机上配置:

    Switch2(config)#vlan100   //vlan要和被抓取流量端口的交换机vlan要一致

    Switch2(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch2(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch2(config)#monitor session 3 destination interface Gig 0/2   //配置要抓取原端口的流量,这里的session 号不需要和Switch1的一致

    Switch1(config)#monitor session 3 source remote vlan 100   //目的端口配置为SPAN的vlan号

     

    Switch#show monitor   //查看端口镜像配置

     

    参考思科官网:https://www.cisco.com/c/zh_cn/support/docs/switches/catalyst-6500-series-switches/10570-41.html

    展开全文
  • 镜像口
    1. 查看交换机端口的基本情况,输入命令 show ip int bri,可以查看端口状态,FastEthernet表示百兆以太网端口,GigabitEthernet表示千兆以太网端口。
      这里写图片描述

    2. 输入conf t,进入配置模式。
      这里写图片描述

      • 设置源镜像口,设置1到5口为源镜像,monitor session 1 source interface gigabitEthernet 1/0/1- 5 ,其中gigabitEthernet1/0/1表示千兆端口1,如果是百兆的话就换成fastEthernet,这里的gigabitEthernet1/0/1或者fastEthernet 0/1要与步骤3中查看到的端口信息一致。 (5后面没有参数表上both,监听双向数据,5后面加上rx只监听接收数据,5后面加tx只监听发送数据。)
        这里写图片描述
      • 配置目的镜像口,设置6为镜像口,monitor session 1 destination interface gigabitEthernet 1/0/6,使端口6为目的镜像口。
        这里写图片描述
    3. 输入exit,退出设置模式。

    4. 查看镜像口配置情况,输入命令show monitor
      这里写图片描述

    5. 最后输入 wr ,保存设置
      这里写图片描述


    其他:
    1. 镜像口配置错误,则删除镜像口。进入配置模式,输入no monitor session x ,删去配置错误的session就好。
    这里写图片描述

    展开全文
  • IPV4 DHCP中继服务器之思科交换机配置 标题:IPV4 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置 一、DHCP服务器配置 网络拓扑图 DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100....

    IPV4 && IPV6 DHCP中继服务器之思科交换机配置

    标题:IPV4 &&IPV6 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置
    在这里插入图片描述

    一、DHCP服务器配置

    网络拓扑图
    DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100.30.0/24
    DHCP服务器:100.100.100.100/24 默认网关:100.100.100.1
    大家都知道的不同VLAN之间的计算机不能互相访问的,如果要为3个VLAN划分不同的网段需要3个dhcp server,而dhcp中继功能解决了只需要配置一个dhcp server,通过交换机的中继功能也能划分不同网段。我的实验环境如下:
    默认网关设置在思科交换机VLAN1,VLAN2,VLAN3。
    VLAN1:接口1-12 IP V4 ADDRESS:100.100.100.1 IPV6 2020:0:0:1::1 /64
    VLAN2:接口13-24 IP V4 ADDRESS:100.100.20.1 IPV6 2020:0:0:2::1 /64
    VLAN3:接口25-36 IP V4 ADDRESS:100.100.30.1 IPV6 2020:0:0:3::1 /64

    1.1 IPV4 IPV6 DHCP网口配置

    配置网口-----与交换机直连
    [root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp59s0f1
    TYPE=Ethernet
    BOOTPROTO=none
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=yes #开启接口IPV6
    IPV6_AUTOCONF=yes #开启接口IPV6
    IPV6_DEFROUTE=yes #开启接口IPV6
    IPV6_FAILURE_FATAL=no
    NAME=enp59s0f1
    UUID=3efbc07c-7439-4a05-afa7-ab079d2cd5c3
    DEVICE=enp59s0f1
    ONBOOT=yes #每次开机自动link up 接口
    IPV6ADDR=2020:0:0:1::2/64 #IPV6 地址
    IPV6_DEFAULTGW=2020:0:0:1::1#IPV6 默认网关
    IPADDR=100.100.100.100 #确保IPV4地址在DHCP配置文件的IP池中
    PREFIX=24 #IPV4 掩码
    GATEWAY=100.100.100.1 #IPV4 默认网关

    开启网口
    [root@localhost ~]# ifup enp59s0f1

    1.2 DHCP服务配置和开启

    安装dhcp服务
    CentOS
    RPM 安装:rpm -ivh dhcp-4.2.5-42.el7.x86_64
    YUM源安装:yum -y install dhcp
    配置yum源方式如下:
    [root@localhost ~]# cat /etc/yum.repos.d/rhel.repo
    [CentOS]
    name=CentOS
    #baseurl=http://x.x.x.x/CentOS/Packages/ #使用http源
    baseurl=f"ile:///mnt/CentOS" #使用本地镜像源
    gpgcheck=0
    enabled=1

    安装dhcp服务后,在/etc/dhcpd/目录下生成2个配置文件,
    [root@localhost ~]# ls /etc/dhcp/
    dhclient.d dhcpd6.conf dhcpd.conf
    其中
    dhcpd6.conf 配置IPV6 , IPV6国家倡导发展大趋势,大家可以尝试下。
    dhcpd.conf配置IPV4

    租约释放时间设置注意:default-lease-time 默认释放时间,不要设置太短,也不建议设置2周以上,IP被霸占着不释放,导致IP池资源紧张,一般设置可根据业务使用情况合理设定。
    dhcp-rebinding-time 租约期满续订失败,重新请求续约IP时间
    dhcp-renewal-time 租约部分过期重新续订IP时间

    配置文件分别如下:

    [root@localhost dhcp]# cat dhcpd.conf 
    # dhcpd.conf
    option domain-name "example.org";
    option domain-name-servers ns1.example.org, ns2.example.org;
    default-lease-time 86400;
    max-lease-time 172800;
    # This is a very basic subnet declaration.
    subnet 100.100.100.0 netmask 255.255.255.0 {
      range 100.100.100.100 100.100.100.105;
      option routers 100.100.10.1;
    }
    subnet 100.100.20.0 netmask 255.255.255.0 {
      range 100.100.20.100 100.100.20.200;
      option routers 100.100.20.1;
    }
    subnet 100.100.30.0 netmask 255.255.255.0 {
      range 100.100.30.100 100.100.30.200;
      option routers 100.100.30.1;
    }
    [root@localhost dhcp]# cat dhcpd6.conf 
    default-lease-time 86400;
    
    preferred-lifetime 43200;
    
    option dhcp-renewal-time 30000;
    
    option dhcp-rebinding-time 30000;
    
    option dhcp6.domain-search "localhost.localdomain";
    
    option dhcp6.name-servers 2020::10:2;
    
    #option dhcpd6.bootfile-url code 59 = string;
    
    DHCPDARGS="enp59s0f1";
    
    allow leasequery;
    allow booting;
    allow bootp;
    option dhcp6.info-refresh-time 21600;
    
    option dhcp6.bootfile-url code 59 = string;
    
    option dhcp6.client-arch-type code 61 = array of unsigned integer 16;
    
    #dhcpv6-lease-file-name "/var/lib/dhcpd/dhcpd6.leases"; 
    
    subnet6 2020:0:0:1::0/64 {
    
        option dhcp6.bootfile-url "tftp://[2020::10:2]/BOOTX64.efi";
        #range for clients
        range6 2020:0:0:1::3 2020:0:0:1::ffff;
        #prefix range for delefation to sub-routers
        prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    
        #range6 2020:0:0:1::0 temporary;
    
    }
    subnet6 2020:0:0:2::0/64 {
    
            range6 2020:0:0:2::2 2020:0:0:2::ffff;
    
     	prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    }
    subnet6 2020:0:0:3::0/64 {
    
    	range6 2020:0:0:3::2 2020:0:0:3::ffff;
    
    	prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    
    }
    #开启dhcp ipv4服务
    [root@localhost dhcp]#systemctl start dhcpd.service
    #开启dhcp ipv6服务
    [root@localhost dhcp]#systemctl start dhcpd6.service
    

    二、思科交换机配置DHCP中继

    2.1 思科交换机IPV4 dhcp中继设置

    admin#  configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    #创建vlan 2 (port口13-24划到vlan2)
    admin(config)#vlan 2
    admin(config-vlan)#interface range gigabitEthernet 1/0/13-24
    admin(config-if-range)#switchport access vlan 2                 
    admin(config-if-range)#exit
    #创建vlan 3 (port口25-36划到vlan3)
    admin(config)#vlan 3
    admin(config-vlan)#interface range gigabitEthernet 1/0/25-36
    admin(config-if-range)#switchport access vlan 3                 
    admin(config-if)#no shutdown
    admin(config-if-range)#exit
    #vlan 2 设置ip地址和dhcp中继访问地址
    admin(config-vlan)#int vlan 2
    admin(config-if)#ip address 100.100.20.1 255.255.255.0
    admin(config-if)#ip helper-address 100.100.100.100
    admin(config-if)#no shutdown
    admin(config-if)#exit
    #vlan 3 设置ip地址和dhcp中继访问地址
    admin(config)#int vlan 3                           
    admin(config-if)#ip address 100.100.30.1 255.255.255.0
    admin(config-if)#ip helper-address 100.100.100.100    
    admin(config-if)#no shutdown
    admin(config-if)#exit
    #开启三层route 不同网段可以互相访问
    admin(config)#ip routing
    #show arp 地址
    admin#show arp            
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  100.100.20.1            -   70d3.79aa.fc41  ARPA   Vlan2
    Internet  100.100.30.1            -   70d3.79aa.fc42  ARPA   Vlan3
    Internet  100.100.100.1           -   70d3.79aa.fc40  ARPA   Vlan1
    Internet  100.100.100.100         0   5820.b102.b31f  ARPA   Vlan1
    

    2.2 思科交换机IPV6 dhcp中继设置

    #IPV6 交换机设置config文件如下:
    admin#  configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    admin(config)#vlan 2
    admin(config-vlan)#ipv6 address 2020:0:0:2::1/64
    admin(config-vlan)#ipv6 dhcp relay destination 2020:0:0:1::2
    admin(config-vlan)#ipv6 enable
    admin(config)#vlan 3
    admin(config-vlan)#ipv6 address 2020:0:0:3::1/64
    admin(config-vlan)#ipv6 dhcp relay destination 2020:0:0:1::2
    admin(config-vlan)#ipv6 enable
    admin(config)#vlan 1
    admin(config-vlan)#ipv6 address 2020:0:0:1::1/64
    admin(config-vlan)#ipv6 enable
    admin(config)#end
    
    查看已获取到IPV6地址
    admin#show ipv6 neighbors 
    IPv6 Address                              Age Link-layer Addr State Interface
    2020:0:0:1::2                               0 5820.b102.b31f  REACH Vl1
    2020::1:5A20:B1FF:FE02:B31F                10 5820.b102.b31f  STALE Vl1
    FE80::5A20:B1FF:FE02:B31F                   0 5820.b102.b31f  REACH Vl1
    2020:0:0:2::D3                             10 a4ae.120e.d8a8  STALE Vl2
    2020::2:A6AE:12FF:FE0E:D8A8                10 a4ae.120e.d8a8  STALE Vl2
    FE80::A6AE:12FF:FE0E:D8A8                  10 a4ae.120e.d8a8  STALE Vl2
    2020::3:320E:D5FF:FEFF:1FEC                10 300e.d5ff.1fec  STALE Vl3
    FE80::320E:D5FF:FEFF:1FEC                   0 300e.d5ff.1fec  REACH Vl3
    
    

    添加静态路由

    DHCP server 要访问其他vlan或跨网段的IP地址,需配置路由表信息。
    DHCP server 隶属vlan1 ipv6地址:2020:0:0:1::2
    节点2 隶属vlan 2 ipv6地址:2020::2:A6AE:12FF:FE0E:D8A8
    节点3 隶属vlan 3 ipv6地址:2020::3:320E:D5FF:FEFF:1FEC
    想访问节点2&& 节点3的网段,添加如下路由信息:

    [root@localhost ~]# ip -6 route add  2020:0:0:3::0/64 via  2020:0:0:1::1
    [root@localhost ~]# ip -6 route add  2020:0:0:2::0/64 via  2020:0:0:1::1
    [root@localhost Desktop]# ip -6 route
    2020::1 dev enp59s0f1  proto static  metric 100 
    2020:0:0:1::1 dev enp59s0f1  metric 0 
        cache 
    2020:0:0:1::/64 dev enp59s0f1  proto kernel  metric 256 
    2020:0:0:2::/64 via 2020:0:0:1::1 dev enp59s0f1  metric 1024 
    2020:0:0:3::/64 via 2020:0:0:1::1 dev enp59s0f1  metric 1024 
    
    访问实例:
    [root@localhost ~]# ipmitool -6 -H 2020::3:320E:D5FF:FEFF:1FEC -U admin -P admin mc info
    Device ID                 : 32
    Device Revision           : 1
    Firmware Revision         : 1.55
    IPMI Version              : 2.0
    Manufacturer ID           : 0
    Manufacturer Name         : Unknown
    Product ID                : 514 (0x0202)
    Product Name              : Unknown (0x202)
    Device Available          : yes
    Provides Device SDRs      : no
    Additional Device Support :
        Sensor Device
        SDR Repository Device
        SEL Device
        FRU Inventory Device
        IPMB Event Receiver
        IPMB Event Generator
        Chassis Device
    Aux Firmware Rev Info     : 
        0x01
        0x00
        0x00
        0x00
    
    
    展开全文
  • 为此我们可以设置Cisco交换机的SPAN (Switched Port Analyzer交换端口分析器)特性, 或早期的“端口镜像”、“监控端口”功能。侦听的对象可以是一个或多个交换机端口,或者整个VLAN。如果要侦听的端口(“源端口”)...

    幻灯片1.JPG

    在交换以太网的环境下,一般两台工作站之间的通讯是不会被第三者侦听到的。在某些情况下,我们可能会需要进行这样的侦听,如:协议分析、流量分析、***检测。为此我们可以设置Cisco交换机的SPAN (Switched Port Analyzer交换端口分析器)特性, 或早期的“端口镜像”、“监控端口”功能。侦听的对象可以是一个或多个交换机端口,或者整个VLAN。如果要侦听的端口(“源端口”)或VLAN和连接监控工作站的端口(“目标端口”)在同一台交换机上,我们只需配置SPAN; 如果不在同一台交换机上,需要配置RSPAN (Remote SPAN)。

    把交换机一个(数个)端口(源端口)的流量完全拷贝一份,从另外一个端口(目的端口)发出去,以便网络管理人员从目的端口通过分析源端口的流量来找出网络存在问题的原因

    幻灯片2.JPG

    • 思科端口镜像类型

    • SPAN指源和目的端口都在同一台机

    • RSPAN指源和目的端口不在同一台机

    • VSPAN可以镜像整个或数个VLAN到一个目的端口

    幻灯片3.JPG

    我们用端口镜像1来镜像3-23号端口

    monitor session 1 source interface Gi1/0/3 - 23 

    monitor session 1 destination interface Gi1/0/1

    镜像端口2来镜像24号端口

    monitor session 2 source interface Gi1/0/24 

    monitor session 2 destination interface Gi1/0/2


    幻灯片5.JPG


    幻灯片6.JPG

    幻灯片7.JPG

    幻灯片8.JPG


    展开全文
  • 思科交换机配置笔记

    2020-04-03 16:05:33
    取消设置 取消设置只需要在前面加个no,如下: sw2960(config-if-range)#no ...在配置模式中查看接口状态需要加 do 前缀 sw2960(config)#do show ip interface brief Interface IP-Address OK? Method Status ...
  • 思科交换机相关配置 一、基础操作 进入交换机界面为一般用户模式 switch> 输入命令 enable进入特权用户模式 switch# 输入命令config terminal进入全局配置模式 switch(config)# 输入命令int xxx可进入端口或者...
  • 思科CISCO交换机端口镜像配置

    千次阅读 2014-06-18 13:34:01
    思科(CISCO)交换机配置镜像(SPAN)端口思科培训机构  Switch(config)# monitor session 1 source interface fastethernet 4/10  Switch(config)# monitor session 1 filter vlan 57  Switch(config)# monitor ...
  • 如果使用交换机做为整个公司接入互联网的网关,那么,想监控整个网络的数据,需要把交换机的某个端口设置为镜像口,让其他所有端口的数据都通过这个镜像口,达到监控的目的。 如何设置交换机的镜像端口呢?以下以...
  • 思科 华为 华三 锐捷 镜像 端口
  • 华为思科交换机基本配置 一、华为H3C配置 1.h3C交换机WEB管理用户配置 在系统试图[H3C]下,输入localuser XXX(WEB user name) XXX(WEB user password) 1(权限,当该值为0的时候只具有guest权限,1为管理员权限) ...
  • CISCO交换机端口镜像配置

    千次阅读 2017-11-12 16:34:00
    镜像口配置 大多数交换机都支持镜像技术,这可以对交换机进行方便的故障诊断。我们称之为“mirroring ”或“Spanning ”。...Cisco3550可以配置2个镜像口案例:将端口2~5镜像到端口61、镜像口配置Switch>enable...
  • 要想管理好一个网络,网络抓包分析...今天不讲抓包,主要是讲如何配置思科交换机镜像端口为抓包做好准备. 用控制线连接上交换机,打开超级终端,如果交换机配置了远程 ,那也可以直接telnet连接交换机进行配置。 例如...
  • 什么是计算机网络?...一、PT介绍–思科 1、PT介绍(界面、路由器、交换机、线缆、工具…) 1-网卡接口:RJ-45 2-电话接口:RJ-11 3-双绞线:直通线、交叉线、全反线(CONSOLE线)(双绞线最长100m,但实际2
  • 配置 GigabitEthernet0/0/1 为镜像接口,GigabitEthernet0/0/2 为观察接口,观察接口索引号为 1。镜像 GigabitEthernet0/0/1 上的双向业务流量到 GigabitEthernet0/0/2 上。 system-view [Quidway] observe-port 1 ...
  • H3C 交换机镜像端口配置 mirroring-group 1 local 设置本地镜像组 1 mirroring-group 1 mirroring-port GigabitEthernet 1/0/1 both 设置镜像源端 G1/0/1 到目标端口 mirroring-group 1 mirroring-port ...
  • Cisco 交换机配置端口镜像 命令 全局模式下 Sw(config)#monitor session 1 destination interface f0/24 Sw(config)#monitor session 1 source interface f0/1 – 23 both Sw(config)#exit Sw#copy running-...
  • 思科,华为等主流交换机镜像模式配置 镜像模式   大多数交换机都支持镜像技术,这可以对交换机进行方便的故障诊断。我们称之为“mirroring ”或“Spanning ”。 端口镜像(Port Mirroring)可以让用户将所有的...
  • 实现原理:将所有端口镜像报文引入一个观察端口,通过观察端口内部环回(配置loopback internal), 将报文在vlan内广播到其它若干实际观察端口,报文出端口时剥除vlan id。 配置举例: 预留vlan3500(for ...
  • 交换机的基本配置_百度文库交换机的管理方式基本分为两种:带内管理和带外管理。通过交换机的Console端口管理交换机属于带外管理,不占用交换机的网络接口,其特点是需要使用配置线缆,近距离配置。第一次配置交换机...
  • 1.1配置镜像(SPAN)端口 Switch(config)# monitor session 1 source interface fastethernet 4/10 Switch(config)# monitor session 1 filter vlan 57 Switch(config)# monitor session 1 destination interface ...
  • 查看交换机端口的基本情况,输入命令 show ip int bri,可以查看端口状态 ...设置源镜像口,设置1到20口为源端口镜像 Switch(config)#monitor session 1 source interface gigabitEthernet ...
  • 交换机端口镜像

    千次阅读 2019-01-10 10:36:21
    为此我们可以设置Cisco交换机的SPAN (Switched Port Analyzer交换端口分析器)特性, 或早期的“端口镜像”、“监控端口”功能。侦听的对象可以是一个或多个交换机端口,或者整个VLAN。如果要侦听的端口(“源端口”)或...
  • 1、思科CISCO交换机1.1配置镜像(SPAN)端口Switch(config)#monitorsession1sourceinterfacefastethernet4/10Switch(config)#monitorsession1filtervlan57Switch(config)#monitorsession1destinatio...
  • 1. Quidway 3026端口镜像配置方法: 以下例子中,镜像端口为e0/18,被镜像端口为e0/3,输入如下命令配置镜像:  配置镜像端口: Quidway(config)#monitor-port e 0/18(e0/18作为镜像端口)  配置被镜像端口...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 423
精华内容 169
关键字:

思科交换机配置镜像口