精华内容
下载资源
问答
  • MSTP+VRRP+OSPF经典案例
  • 11.6.1 基本ospf配置

    2017-11-17 13:47:27
    思科11.6.1基本OSPF配置实验,自己做的答案,欢迎下载
  • 华为ospf路由配置实例操作
  • ospf配置实验拓扑图。利用华为ensp仿真软件打开。包含完整的IP地址配置,区域配置。
  • CiscoOSPF配置

    2017-05-31 23:54:50
    本实验报告为路由器的OSPF配置,利用ospf协议实现个路由下的PC能够互相通信。内有实验拓扑图和详细的配置步骤。模拟器为Cisco Packet Tracer 6.0.
  • H3C OSPF配置实例

    2012-03-22 11:11:12
    OSPF配置实例,这是基于H3C(华三)路由器的OSPF基本配置,希望对各位有用。
  • 锐捷 ospf配置

    2011-12-12 21:20:17
    锐捷网络设备 OSPF单区域基本配置 OSPF(Open Shortest Path First,开放式最短路径优先)协议,是目前网络中应用最广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态(link...
  • OSPF配置命令总结

    千次阅读 2020-10-26 15:29:58
    abr-summary(OSPF区域) //用来在区域边界路由器(ABR)上配置路由聚合。 area(OSPF) //用来创建OSPF区域,并进入OSPF区域视图。 asbr-summary //用来设置自治系统边界路由器(ASBR)对OSPF引入的路由...

    整理了一下OSPF的一些命令,以便今后查阅,基本概括了常用的所有命令(有些到了IE阶段,我都没见到过。。。有需要可以收藏备用!)

    还有没有整理的可以在评论区指出一下~~

    abr-summary(OSPF区域) 	 //用来在区域边界路由器(ABR)上配置路由聚合。
    area(OSPF)				 //用来创建OSPF区域,并进入OSPF区域视图。
    asbr-summary 			 //用来设置自治系统边界路由器(ASBR)对OSPF引入的路由进行路由聚合。
    authentication-mode(OSPF区域)   //用来指定OSPF区域所使用的验证模式及验证口令。
    bandwidth-reference(OSPF)      //用来设置通过公式计算接口开销所依据的带宽参考值。
    bfd all-interfaces(OSPF)  	    //用来在OSPF进程下使能BFD特性。
    default(OSPF) 		            //用来配置引入外部路由时的缺省参数,包括OSPF引入外部路由的开销、类型(Type1或Type2)、标记和路由数量。
    default-cost(OSPF区域)         //用来指定OSPF发送到Stub区域或NSSA区域的Type3缺省路由的开销。
    default-route-advertise(OSPF) //用来将缺省路由通告到普通OSPF区域。
    description(OSPF) 			   //用来为OSPF进程配置描述信息。
    description(OSPF区域) 		   //用来为OSPF区域配置描述信息。
    display default-parameter ospf //用来显示OSPF默认配置信息。
    display gtsm statistics 	   //用来查看接口板上的GTSM统计信息。
    display ospf abr-asbr 		   //用来显示OSPF的区域边界路由器和自治系统边界路由器信息。
    display ospf asbr-summary 	   //用来查看OSPF的路由聚合信息。
    display ospf bfd session 	   //用来查看使能BFD特性邻居的信息。
    display ospf brief 			   //用来查看OSPF的概要信息。
    display ospf cumulative 	   //用来显示OSPF的统计信息。
    display ospf error 			   //用来查看OSPF的错误信息。
    display ospf global-statistics //用来查看OSPF协议的全局统计信息。如果不指定OSPF进程号,该命令将显示所有OSPF进程的概要信息。
    display ospf graceful-restart  //用来查看OSPF GR的状态信息。
    display ospf interface         //用来显示OSPF的接口信息。
    display ospf lsdb 			   //用来显示OSPF的链路状态数据库(LSDB)信息。
    display ospf migp-routing 	   //用来显示OSPF的MIGP(Multicast IGP)路由信息。
    display ospf mesh-group        //用来查看OSPF Mesh-Group的概要信息。
    display ospf nexthop 		   //用来显示OSPF的下一跳信息。
    display ospf peer 			   //用来显示OSPF中各区域邻居的信息。
    display ospf request-queue     //用来显示OSPF的请求列表信息。
    display ospf retrans-queue     //用来显示OSPF的重传列表信息。
    display ospf routing 		   //用来显示OSPF路由表的信息。
    display ospf sham-link 		   //用来查看OSPF区域的伪连接信息。
    display ospf spf-statistics    //用来查看OSPF进程下路由计算的统计信息。
    display ospf statistics updated-lsa //用来查看LSDB内频繁更新的LSA信息。
    display ospf vlink 			   //用来显示OSPF的虚连接信息。
    display snmp-agent trap feature-name ospf all //用来查看OSPF模块的所有告警信息。
    dn-bit-set 					   //用来禁止设置OSPF LSA的DN位。
    dn-bit-check 				   //用来禁止检查OSPF LSA的DN位。
    domain-id(OSPF) 			   //用来配置OSPF域标识符。
    eca-route-type compatible 	   //用来将OSPF VPN扩展团体属性的路由类型设置为0x8000。
    enable log 					   //用来打开日志信息显示功能。
    filter export(OSPF区域) 	   //用来配置对区域内出方向的Type3 LSA进行过滤。
    filter import(OSPF区域) 	   //用来配置对区域内入方向的Type3 LSA进行过滤。
    filter-lsa-out peer 		   //用来在P2MP网络中对指定邻居发送的LSA进行过滤。
    filter-policy export(OSPF)    //用来按照过滤策略,设置对引入的路由在向外发布时进行过滤。
    filter-policy import(OSPF)    //用来按照过滤策略,设置OSPF对接收的路由进行过滤。
    flooding-control         	   //用来使能OSPF更新LSA泛洪的控制功能。
    frr(OSPF)					   //用来创建并进入OSPF FRR(Fast Reroute)视图。
    frr-policy route(OSPF FRR)    //用来配置OSPF IP FRR的备份路由过滤策略,即OSPF备份路由是否加入路由表。
    frr-priority static low 	   //用来指定利用LFA算法计算备份下一跳和备份出接口,使动态备份路径的优先级高于静态备份路径的优先级。
    graceful-restart(OSPF)		   //用来使能OSPF GR(平滑重启)功能。
    graceful-restart helper-role(OSPF) //用来配置设备平滑重启Helper模式。
    gtsm default-action 		   //用来设置未匹配GTSM策略的报文的缺省动作。
    gtsm log drop-packet		   //用来打开单板的LOG信息开关,在单板GTSM丢弃报文时记录LOG信息。
    import-route(OSPF) 		   //用来引入其他路由协议学习到的路由信息。
    local-mt filter-policy(OSPF) //用来配置OSPF本地MT(Local Multicast-Topology)特性的策略。
    local-mt enable(OSPF) 		  //用来使能OSPF本地MT(Local Multicast-Topology)特性,即本地组播拓扑特性。
    loop-free-alternate(OSPF FRR)//用来使能OSPF IP FRR功能,利用LFA算法计算备份下一跳和备份出接口。
    lsa-arrival-interval 		  //用来设置OSPF LSA接收的时间间隔。
    lsa-originate-interval 	      //用来设置OSPF LSA的更新时间间隔。
    lsdb-overflow-limit   	      //用来设置OSPF的LSDB中External LSA的最大条目数。
    maxage-lsa route-calculate-delay(OSPF) //用来使能OSPF LSA频繁振荡时路由延迟计算功能。
    maximum load-balancing(OSPF) //用来设置进行负载分担的等价路由的最大数量。
    maximum-routes 				  //用来设置OSPF支持的不同类型路由的最大数量。
    mesh-group enable 			  //用来使能Mesh-Group特性。
    network(OSPF区域) 			  //用来指定运行OSPF协议的接口和接口所属的区域。
    nexthop(OSPF) 				  //用来设置等价路由的优先级。
    nssa(OSPF区域)				  //用来配置OSPF区域为NSSA区域。
    opaque-capability enable 	  //用来使能opaque-lsa能力,从而OSPF进程可以生成Opaque LSA,并能从邻居设备接收Opaque LSA。
    ospf 						  //用来创建并运行OSPF进程。
    ospf authentication-mode 	  //用来设置相邻设备之间的验证模式及验证字。
    ospf bfd 					  //用来在使能OSPF的特定接口下配置BFD特性或配置BFD会话的参数值。
    ospf bfd block 				  //用来阻塞接口动态创建BFD特性。
    ospf cost 					  //用来配置接口上运行OSPF协议所需的开销。
    ospf dr-priority 			  //用来设置接口在选举DR时的优先级。
    ospf enable 				  //用来在接口上使能OSPF。
    ospf filter-lsa-out 		  //用来配置对OSPF接口出方向的LSA进行过滤。
    ospf frr block 				  //用来阻止指定OSPF接口的FRR能力。
    ospf maxage-lsa auto-protect disable //用来去使能OSPF异常老化触发的主备倒换功能。
    ospf mib-binding 			  //用来将OSPF进程绑定到SNMP上,并对SNMP的请求做出响应。
    ospf mtu-enable 			  //用来使能接口在发送DD报文时填充MTU值,同时还会检查邻居DD报文所携带的MTU是否超过本端的MTU值。
    ospf network-type 			  //用来设置OSPF接口的网络类型。
    ospf p2mp-mask-ignore 		  //用来设置在P2MP网络上忽略对网络掩码的检查。
    ospf router-id auto-recover disable //用来禁止检测到Router ID冲突后的自动恢复功能。
    ospf smart-discover 		  //用来在接口上使能Smart-discover功能。
    ospf suppress-flapping peer   //用来设置指定接口的OSPF邻居震荡抑制的检测参数。
    ospf suppress-flapping peer disable //用来在指定接口去使能OSPF邻居震荡抑制功能。 
    ospf suppress-flapping peer hold-down //用来设置Hold-down邻居震荡抑制模式和抑制持续时间。
    ospf suppress-flapping peer hold-max-cost disable //用来取消Hold-max-cost邻居震荡抑制模式。
    ospf timer dead 			  //用来设置OSPF的邻居失效时间。
    ospf timer hello 			  //用来设置接口发送Hello报文的时间间隔。
    ospf timer poll 			  //用来配置NBMA网络上发送轮询Hello报文的时间间隔。
    ospf timer retransmit 		  //用来设置接口重传LSA的时间间隔。
    ospf trans-delay 			  //用来设置接口上发送LSA过程中的传输延迟时间。
    ospf valid-ttl-hops			  //用来使能OSPF GTSM特性,并配置需要检测的TTL值。
    peer(OSPF) 				  //用来在NBMA网络上指定相邻路由器的IP地址,并配置DR选举权。
    preference(OSPF) 			  //用来设置OSPF协议路由的优先级。
    prefix-priority(OSPF) 		  //配置OSPF路由的收敛优先级。
    reset gtsm statistics 		  //用来清除单板上的GTSM统计信息。
    reset ospf counters 	      //用来将OSPF计数器清零。
    reset ospf counters maxage-lsa //用来将达到最大老化时间的Router LSA的计数器清零。
    reset ospf process 			  //用来重启OSPF进程。
    reset ospf redistribution 	  //用来重新引入路由。
    reset ospf suppress-flapping peer //用来强制OSPF接口退出邻居震荡抑制阶段。
    retransmission-limit 		  //用来使能重传限制特性,并配置最大重传限制数。
    route-tag 					  //用来配置VPN的路由标记(VPN Route Tag)。
    rfc1583 compatible   		  //用来将RFC2328定义的规则配置成RFC1583定义的规则。
    sham-hello enable(OSPF) 	  //用来使能OSPF的sham-hello功能。
    sham-link(OSPF区域) 		  //用来配置伪连接,并配置伪连接的参数。
    silent-interface(OSPF) 	  //用来禁止接口接收和发送OSPF报文。
    snmp-agent trap enable feature-name ospf //用来打开OSPF模块的告警开关。
    spf-schedule-interval 		  //用来设置OSPF路由计算时间间隔。
    stub(OSPF区域) 			  //用来将一个区域设置为Stub区域。
    stub-router(OSPF) 			  //用来配置Stub路由器。
    suppress-flapping peer disable(OSPF) //用来全局去使能OSPF邻居震荡抑制功能。
    vlink-peer(OSPF区域) 		  //用来创建并配置虚连接。
    vpn-instance-capability simple(OSPF)//用来禁止路由环路检测,直接进行路由计算。 
    
    展开全文
  • 路由器多区域 OSPF 配置 实训三十四 路由器多区域 OSPF 配置 定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),在单一自治系统(AS)内部工作。...

    路由器多区域 OSPF 配置

    实训三十四 路由器多区域 OSPF 配置

    定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法内部网关协议IGP),在单一自治系统(AS)内部工作。

    概述:开放式最短路径优先(Open Shortest Path First,OSPF)是广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。在网络中使用OSPF协议后,大部分路由将由OSPF协议自行计算和生成,无须网络管理员人工配置,当网络拓扑发生变化时,协议可以自动计算、更正路由,极大地方便了网络管理。但如果使用时不结合具体网络应用环境,不做好细致的规划,OSPF协议的使用效果会大打折扣,甚至引发故障。  

    OSPF协议是一种链路状态协议。每个路由器负责发现、维护与邻居的关系,并将已知的邻居列表和链路费用LSU(Link State Update)报文描述,通过可靠的泛洪与自治系统AS(Autonomous System)内的其他路由器周期性交互,学习到整个自治系统的网络拓扑结构;并通过自治系统边界的路由器注入其他AS的路由信息,从而得到整个Internet的路由信息。每隔一个特定时间或当链路状态发生变化时,重新生成LSA,路由器通过泛洪机制将新LSA通告出去,以便实现路由的实时更新。

    优点

    (1)OSPF适合在大范围的网络:OSPF协议当中对于路由的跳数,它是没有限制的,所以OSPF协议能用在许多场合,同时也支持更加广泛的网络规模。只要是在组播的网络中,OSPF协议能够支持数十台路由器一起运作。

    (2)组播触发式更新:OSPF协议在收敛完成后,会以触发方式发送拓扑变化的信息给其他路由器,这样就可以减少网络宽带的利用率;同时,可以减小干扰,特别是在使用组播网络结构,对外发出信息时,它对其他设备不构成其他影响

    (3)收敛速度快:如果网络结构出现改变,OSPF协议的系统会以最快的速度发出新的报文,从而使新的拓扑情况很快扩散到整个网络;而且,OSPF采用周期较短的HELLO报文来维护邻居状态。

    (4)以开销作为度量值:OSPF协议在设计时,就考虑到了链路带宽对路由度量值的影响。OSPF协议是以开销值作为标准,而链路开销和链路带宽,正好形成了反比的关系,带宽越是高,开销就会越小,这样一来,OSPF选路主要基于带宽因素。

    (5)OSPF协议的设计是为了避免路由环路:在使用最短路径的算法下,收到路由中的链路状态,然后生成路径,这样不会产生环路。

    (6)应用广泛:广泛的应用在互联网上,其他会有大量的应用实例。证明这是使用最广泛的IPG之一

    缺点

    (1)OSPF协议的配置对于技术水平要求很高,配置比较复杂的。因为网络会根据具体的参数,给整个网络划分区域或者标注某个属性,所以各种情况都会非常复杂,这就要求网络分析员对OSPF协议的配置要相当了解,不但要求具有普通的网络知识技术,还要有更深层的技术理解,只有具备这样的人员,才能完成OSPF协议的配置和日常维护。

    (2)路由其自身的负载分担能力是很低的。OSPF路由协议会根据几个主要的因素,生成优先级不同的接口。然而在同一个区域内,路由协议只会通过优先级最高的那个接口。只要是接口优先级低于最高优先级,那么路由就不会通过。在这个基础上,不同等级的路由,无法相互承担负载,只能独自运行。

    OSPF的数据包:
    Hello包
    DBD–数据库描述包
    LSR–链路状态请求
    LSU–链路状态更新 携带各种LSA
    LSack–链路状态确认

     

    一、实验目的

    1.掌握多区域 OSPF 的配置

    2.理解 OSPF 区域的意义

    二、应用环境 

    在大规模网络中,我们通常划分区域减少资源消耗,并将拓扑的变化本地化。 

    三、实验设备

    1.路由器三台

    2.网线 三条

    3.pc二台

    四、 

    实验拓扑

     

    五、实验要求

    路由器

    接口

    IP地址

    RA

    G0/3

    192.168.1.1/24

    G0/4

    192.168.0.1/24

    RB

    G0/3

    192.168.1.2/24

    G0/4

    192.168.2.1/24

    RC

    G0/3

    192.168.3.1/24

    G0/4

    192.168.2.2/24

    六、实验步骤

    第一步:参照上表配置各接口地址,并测试连通性

    路由器 A 的配置

    face g0/4 RA#config !进入全局模式

    RA_config#interface g0/3 !进入接口模式

    RA_config_g0/3#ip add 192.168.1.1 255.255.255.0 !设置 IP 地址

    RA_config_g0/3#no shutdown  开启接口

    RA_config_g0/3#exit !退出接口模式

    RA_config#

    RA_config#inter G0/4

    RA_config_g0/4#ip add 192.168.0.1 255.255.255.0

    RA_config_g0/4#no shutdown

    RA_config_g0/4#exit

    路由器 B C 的配置步骤同路由器 A 一样。

    第二步:路由器 A 的配置

    RA#confing

    RA_config#router ospf 1 !启动 OSPF 进程,进程号为 1

    RA_config_ospf_1#network 192.168.1.0 255.255.255.0 area 1 !宣称 IP 地址到 1 区域

    RA_config_ospf_1#network 192.168.0.0 255.255.255.0 area 1 !注意要写掩码和区域号

    RA_config_ospf_100#^Z !按 ctrl+z,直接进入特权模式

    第三步:路由器 B 的配置 

    Router-B#confing

    RB_config#router ospf 1

    RB_config_ospf_1#network 192.168.1.0 255.255.255.0 area 1 !注意区域的划分在接口上

    RB_config_ospf_1#network 192.168.2.0 255.255.255.0 area 0

    Router-B_config_ospf_100#^Z

    第四步:路由器 C 的配置

    Router-C#confing

    RC_config#router ospf 1

    RC_config_ospf_1#network 192.168.2.0 255.255.255.0 area 0

    RC_config_ospf_1#network 192.168.3.0 255.255.255.0 area 0

    Router-C_config_ospf_100#^Z

    第五步:查看路由表 

    RA_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    C 192.168.0.0/24 is directly connected, GigaEthernet0/4

    C 192.168.1.0/24 is directly connected, GigaEthernet0/3

    O IA 192.168.2.0/24 [110,2] via 192.168.1.2(on GigaEthernet0/3)

    O IA 192.168.3.0/24 [110,3] via 192.168.1.2(on GigaEthernet0/3) !区域间的路由

    RB_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2VRF ID: 0

    O 192.168.0.0/24 [110,2] via 192.168.1.1(on GigaEthernet0/3)

    C 192.168.1.0/24 is directly connected, GigaEthernet0/3

    C 192.168.2.0/24 is directly connected, GigaEthernet0/4

    O 192.168.3.0/24 [110,2] via 192.168.2.2(on GigaEthernet0/4)

    !对 ABR 来说是区域内的路由

    RC_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    O IA 192.168.0.0/24 [110,3] via 192.168.2.1(on GigaEthernet0/4)

    O IA 192.168.1.0/24 [110,2] via 192.168.2.1(on GigaEthernet0/4) !区域间的路由

    C 192.168.2.0/24 is directly connected, GigaEthernet0/4

    C 192.168.3.0/24 is directly connected, GigaEthernet0/3

    七、注意事项和排错

    1.区域的划分在接口上进行

    2.必须有 area 0 存在

    3. 宣称 IP 地址时要写掩码 

    八、配置序列

    路由器 A 的序列

    RA_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption

    !

    hostname RA

    !

    gbsc group default

    !

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast!

    interface GigaEthernet0/3

    ip address 192.168.1.1 255.255.255.0 !查看 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.0.1 255.255.255.0 !查看 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.1.0 255.255.255.0 area 1

    network 192.168.0.0 255.255.255.0 area 1 !查看 ospf 宣称的网段到哪个区域

    !

    路由器 B 的序列

    RB_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption

    !

    hostname RB

    !

    gbsc group default!

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/3

    ip address 192.168.1.2 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.2.1 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.1.0 255.255.255.0 area 1

    network 192.168.2.0 255.255.255.0 area 0 !查看 ospf 宣称的网段到哪个区域

    !

    路由器 C 的序列

    RC_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption!

    hostname RC

    !

    gbsc group default

    !

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/3

    ip address 192.168.3.1 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.2.2 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.2.0 255.255.255.0 area 0

    network 192.168.3.0 255.255.255.0 area 0 !查看 ospf 宣称的网段到哪个区域

    !

    九、共同思考

    1.为什么必须有 area 0 存在?

    2.在路由器 A 和 C 宣告网段的时候有其他的方法吗?

    十、课后练习

    请将地址改为 10.0.0.0/25 重复以上实验

    十一、相关命令详解

    router ospf process-id

    network address mask area area-id

    此命令激活 OSPF 路由协议,并且进入路由器配置模式,然后配置 OSPF 运行的接口以及接口的区

    ID。 可以用命令 no router ospf process-id 去掉 ospf 进程

    展开全文
  • CISCO路由器交换机OSPF配置视频教程
  • 主要介绍了华为5700交换机OSPF配置,适合自学及初学者学习参考
  • 思科OSPF配置示例

    2009-07-27 09:11:07
    思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令
  • OSPF配置技巧

    2014-12-23 16:00:30
    OSPF配置技巧实验
  • ensp-ospf配置

    2020-02-14 17:58:48
    OSPF配置 · OSPF基础 » 更多推荐... 35个面试详解,170道挑战题,1460个精彩问答 | 最全Java面试宝典 ; display: inline-block; width: 468px; height: 60px;">; vertical-align: bottom;" data-load-...
     
     
    

    戚源

    </div><!--end: blogTitle 博客的标题和副标题 -->
    <div id="navigator">
    
    新随笔
    展开全文
  • pc1 和pc2ip配置 AR1配置: [Huawei]int g0/0/0 [Huawei-GigabitEthernet0/0/0]ip add 1.0.0.2 8 [Huawei-GigabitEthernet0/0/0]int g0/0/1 [Huawei-GigabitEthernet0/0/1]ip add 3.0.0.1 8 [Huawei-...

    实验一:拓扑图如下

     pc1 和pc2ip配置

     AR1配置:

    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 1.0.0.2 8
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 3.0.0.1 8
    
    [Huawei-GigabitEthernet0/0/1]int loopback 0
    [Huawei-LoopBack0]ip add 4.4.4.4 24
    [Huawei-LoopBack0]quit
    
    [Huawei]ospf 1 router-id 4.4.4.4
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]network 1.0.0.0 0.255.255.255
    [Huawei-ospf-1-area-0.0.0.0]network 3.0.0.0 0.255.255.255
    [Huawei-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.255

     AR2配置:

    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 3.0.0.2 8
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 4.0.0.1 8
    
    [Huawei-GigabitEthernet0/0/1]int loopback0
    [Huawei-LoopBack0]ip add 5.5.5.5 24
    [Huawei-LoopBack0]quit
    
    [Huawei]ospf 1 router-id 5.5.5.5
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]network 3.0.0.0 0.255.255.255
    [Huawei-ospf-1-area-0.0.0.0]network 5.5.5.5 0.0.0.255
    
    [Huawei-ospf-1-area-0.0.0.0]area 1
    [Huawei-ospf-1-area-0.0.0.1]network 4.0.0.0 0.255.255.255
    

     AR3配置:

    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 4.0.0.2 8
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 2.0.0.2 8
    
    [Huawei-GigabitEthernet0/0/0]int loop0
    [Huawei-LoopBack0]ip add 6.6.6.6 24
    [Huawei-LoopBack0]quit
    [Huawei]ospf 1 router-id 6.6.6.6
    [Huawei-ospf-1]area 1
    [Huawei-ospf-1-area-0.0.0.1]network 2.0.0.0 0.255.255.255
    [Huawei-ospf-1-area-0.0.0.1]network 4.0.0.0 0.255.255.255
    [Huawei-ospf-1-area-0.0.0.1]network 6.6.6.6 0.0.0.255
    

     Pc1和pc2互ping

     

    实验二:拓扑图如下

     提前配置好主机IP地址以及端口IP地址

    R1配置

    [R1]ospf 1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255

    R2配置

    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]quit
    [R2-ospf-1]area 1
    [R2-ospf-1-area-0.0.0.1]network 192.168.3.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.1]network 192.168.4.0 0.0.0.255

    R3配置

    [R3]ospf 1
    [R3-ospf-1]area 1
    [R3-ospf-1-area-0.0.0.1]network 192.168.4.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.1]network 192.168.5.0 0.0.0.255

    pc1 ping pc3

     pc1 ping pc2

     pc2 ping pc3

    实验三:拓扑图如下

    提前配置好主机IP地址以及端口IP地址

    AR1配置

    [AR1]ospf 1 router-id 1.1.1.1
    [AR1-ospf-1]area 10
    [AR1-ospf-1-area-0.0.0.10]network 192.168.1.0 0.0.0.255
    [AR1-ospf-1-area-0.0.0.10]network 192.168.2.0 0.0.0.255
    

    AR2配置

    [AR2]ospf 1 router-id 2.2.2.2
    [AR2-ospf-1]area 10
    [AR2-ospf-1-area-0.0.0.10]network 192.168.2.0 0.0.0.255
    [AR2-ospf-1-area-0.0.0.10]area 0
    [AR2-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255

    AR3配置

    [AR3]ospf 1 router-id 3.3.3.3
    [AR3-ospf-1]area 0
    [AR3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [AR3-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255

    AR4配置

    [AR4]ospf 1 router-id 4.4.4.4
    [AR4-ospf-1]area 0
    [AR4-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    [AR4-ospf-1-area-0.0.0.0]area 20
    [AR4-ospf-1-area-0.0.0.20]network 192.168.5.0 0.0.0.255

    AR5配置

    [AR5]ospf 1 router-id 5.5.5.5
    [AR5-ospf-1]area 20
    [AR5-ospf-1-area-0.0.0.20]network 192.168.5.0 0.0.0.255
    [AR5-ospf-1-area-0.0.0.20]network 192.168.6.0 0.0.0.255

    pc1 ping pc2

    实验四:拓扑图如下

     提前配置好主机IP地址以及端口IP地址

    R1配置

    [R1]ospf 1
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 10.0.1.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.1]network 10.0.15.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.1]network 10.0.35.0 0.0.0.255

    R2配置

    [R2]ospf 1
    [R2-ospf-1]area 1
    [R2-ospf-1-area-0.0.0.1]network 10.0.15.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.1]quit
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255

    R3配置

    [R3]ospf 1
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]network 10.0.26.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.2]quit
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255

    R4配置

    [R4]ospf 1
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]network 10.0.26.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 10.0.46.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 10.0.2.0 0.0.0.255

    R5配置

    [R5]ospf 1
    [R5-ospf-1]area 2
    [R5-ospf-1-area-0.0.0.2]network 10.0.46.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.2]quit
    [R5-ospf-1]area 0
    [R5-ospf-1-area-0.0.0.0]network 10.0.4.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255

    R6配置

    [R6]ospf 1
    [R6-ospf-1]area 1
    [R6-ospf-1-area-0.0.0.1]network 10.0.35.0 0.0.0.255
    [R6-ospf-1-area-0.0.0.1]quit
    [R6-ospf-1]area 0
    [R6-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    [R6-ospf-1-area-0.0.0.0]network 10.0.3.0 0.0.0.255
    [R6-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255

    pc1 ping pc2

    pc1 ping pc3

     pc1 ping pc4

     

    展开全文
  • ensp简单ospf配置

    千次阅读 2020-10-23 11:11:03
    拓扑图: 1、R1配置 R2、R3、R4参考配置 (1)配ip地址 <Huawei>sys [Huawei]un in en [Huawei]sysn R1 [R1]int s0/0/0 [R1-Serial0/0/0]ip add 192.200.10.5 30 ...配置ospf :先设置区域 ,在
  • 华为三层交换机的OSPF协议的配置教程,配置实例详细说明,手把手教会你,内容完整易懂,重点突出,重点详细
  • 华为OSPF配置练习

    千次阅读 2021-03-12 19:07:45
    华为OSPF配置练习一、拓扑以及需求二、所需技术以及简单配置(1)OSPF(2)RIP(3)虚链路(4)重发布三、配置思路(1)打通0域(2)打通RIP域外(3)连接各域1、使用虚链路2、使用双向重发布四、验证(1)连通性...
  • 根据能够学习的路由器种类来区分Router ID 选取规则自动选取手动选取DR和BDRDR和BDR的选取自动选取手动选取OSPF的组播地址OSPF的度量值为COST(成本)OSPF多区(非骨干区域)路由器类型链路状态通告(LSA)命令与实验...
  • 2.图中实现pc4和pc5进行通信,而且L1和L3处于不同的OSPF区域如何配置呢? 配置如下: [r1]dis cu version 7.1.075, Alpha 7571 sysname r1 ospf 1 area 0.0.0.0 network 192.168.1.0 0.0.0.255 network 192.168....
  • ospf配置详解

    2018-12-19 11:57:58
    ospf单区域多区域路由配置详解,里面包括配置命令以及拓扑图
  • ospf配置

    千次阅读 2020-12-13 14:05:27
    配置ospf [R1]ospf 1 启动OSPF [R1-ospf-1]area 1 选择区域 [R1-ospf-1-area-0.0.0.1]network 1.1.1.0 0.0.0.255 Router id:默认采用本地最大环回地址,如果没有环回,则默认使用本地最大物理接口IP地址,建议...
  • 今天给大家带来一道很有趣的OSPF题目,本文通过构造一个很特殊的OSPF环境,体现出OSPF网络类型的妙用。...(一)OSPF配置相关命令 (二)静态ARP表项配置相关命令 三、实现现象 四、附录——AR1、AR2配置命令 ...
  • 华三 h3c ospf配置

    千次阅读 2020-12-21 15:49:47
    因为区域2没有和骨干区域...[R1-LoopBack0]ip address 1.1.1.1 32-----环回口,用来给ospf配置router-id,如果配置了多个环回口地址,router-id取最大的那个地址;如果没有配置环回口地址的话,router-id取物理端口IP..
  • OSPF配置及实现

    千次阅读 2020-06-28 18:08:57
    OSPF基础配置命令 ospf的基础配置包含以下三个动作: 创建ospf进程 创建ospf区域 在特定接口上激活ospf 1、创建ospf进程 在系统视图下使用ospf命令,参数Process-ID(进程号)、Router-ID Process-ID只具有...
  • 多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置
  • ENSP配置 实例六 OSPF配置

    千次阅读 2020-06-19 11:58:43
    ENSP配置 实例六 OSPF配置 R1 [R1]interface e0/0/0 [R1-Ethernet0/0/0]ip add 192.168.1.254 24 [R1-Ethernet0/0/0]int e0/0/1 [R1-Ethernet0/0/1]ip add 10.0.12.1 24 [R1]ospf 1 router-id 1.1.1.1 [R1-ospf-1]...
  • 该实验中有3台路由器,组成2个OSPF区域; R1、R2组成Area 0,R2、R3组成Area 1; 各接口的ip地址如上图所示 实验目的: 在三台路由器上运行OSPF协议,使R1、R3可以相互ping通; 配置配置各个路由器的ip...
  • OSPF配置及MD5验证

    2021-06-01 20:38:18
    OSPF配置及其验证 一、ospf基础知识 封装 以太网/IP/OSPF IP头部:89ospf 88eigrp 本质特性:链路状态型的路由协议 区域:(0-4294967295)非骨干区域全部连接到区域0上 区域划分属于接口划分(同一个交换机...
  • RIP与OSPF配置

    2019-01-30 14:13:31
    路由与交换技术:RIP与OSPF配置。 包括实验目的、实验要求、实验拓扑、具体过程、心得体会等内容。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 36,833
精华内容 14,733
关键字:

opsf配置