精华内容
下载资源
问答
  • Linux下安装TensorFlow模块准备:centos7python2.7tensorflow-0.5.0-cp27-none-linux_x86_64.whl安装:[root@localhost ~]# pip install tensorflow-0.5.0-cp27-none-linux_x86_64.whlDEPRECATION: Python 2.7 will ...

    Linux下安装TensorFlow模块

    准备:

    centos7

    python2.7

    tensorflow-0.5.0-cp27-none-linux_x86_64.whl

    安装:

    [root@localhost ~]# pip install tensorflow-0.5.0-cp27-none-linux_x86_64.whl

    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.

    Processing ./tensorflow-0.5.0-cp27-none-linux_x86_64.whl

    Collecting six>=1.10.0 (from tensorflow==0.5.0)

    Downloading https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl

    Collecting numpy>=1.9.2 (from tensorflow==0.5.0)

    Downloading https://files.pythonhosted.org/packages/1f/c7/198496417c9c2f6226616cff7dedf2115a4f4d0276613bab842ec8ac1e23/numpy-1.16.4-cp27-cp27mu-manylinux1_x86_64.whl (17.0MB)

    |████████████████████████████████| 17.0MB 182kB/s

    Installing collected packages: six, numpy, tensorflow

    Successfully installed numpy-1.16.4 six-1.12.0 tensorflow-0.5.0

    调用TensorFlow模块:

    [root@localhost ~]# python

    Python 2.7.5 (default, Nov 20 2015, 02:00:19)

    [GCC 4.8.5 20150623 (Red Hat 4.8.5-4)] on linux2

    Type "help", "copyright", "credits" or "license" for more information.

    >>> import tensorflow as tf

    >>>

    这样就算成功了。

    附:

    展开全文
  • 安装命令pip install https://storage.googleapis.com/tensorflow/mac/tensorflow-0.5.0-py2-none-any.whl3. 但是,由于googleapis不可访问,所以将whl文件下载到本地百度云地址 http://pan.baidu.com/s/1ntjaMnf...

    方法一:

    python 2.7版本

    1. 首先,我已经有了pip

    2.安装命令

    pip install https://storage.googleapis.com/tensorflow/mac/tensorflow-0.5.0-py2-none-any.whl

    3. 但是,由于googleapis不可访问,所以将whl文件下载到本地

    百度云地址 http://pan.baidu.com/s/1ntjaMnf 密码:sznb.

    4.下载后,通过客户端 pip install 路径/文件。但是由于我使用的是python 3,所以安装失败。报错如下:

    tensorflow-0.5.0-py2-none-any.whl is not a supported wheel on this platform.

    5.更新pip,使用python 2.7

    下载 get-pip.py from https://bootstrap.pypa.io/get-pip.py

    运行 python2.7 get-pip.py for installing pip2.7

    python2.7 -m pip install https://storage.googleapis.com/tensorflow/mac/tensorflow-0.5.0-py2-none-any.whl

    6. 但是 由于一些文件在system下,mac自带防御系统(SIP)不允许运行

    现在的解决办法是取消SIP机制,具体做法是:

    重启电脑,按住Command+R(直到出现苹果标志)进入Recovery Mode(恢复模式)

    左上角菜单里找到实用工具 -> 终端

    输入csrutil disable回车

    重启Mac即可

    如果想重新启动SIP机制重复上述步骤改用csrutil enable即可

    7. 最后运行 sudo python2.7 -m pip install /Users/tianf/Downloads/tensorflow-0.5.0-py2-none-any.whl

    8. 安装成功

    方法二:anaconda

    命令:conda install -c https://conda.anaconda.org/jjhelmus tensorflow

    展开全文
  • 1、Python 安装1.1 python 下载在Python的官网 www.python.org ...1.2 Python 安装A.双击下载好的安装包,弹出如下界面:这里要注意的是,将python加入到windows的环境变量中,如果忘记打勾,则需要手工加到...

    1、Python 安装

    1.1 python 下载

    在Python的官网 www.python.org 中找到最新版本的Python安装包,点击进行下载,请注意,当你的电脑是32位的机器,请选择32位的安装包,如果是64位的,请选择64位的安装包;

    8d87a821ca1ac1f0646972b0487d3c77.png

    1.2 Python 安装

    A.双击下载好的安装包,弹出如下界面:

    这里要注意的是,将python加入到windows的环境变量中,如果忘记打勾,则需要手工加到环境变量中;在这里我选择的是自定义安装,点击“自定义安装”进行下一步操作;

    c39d8fa70d1b6db70672a26f3f6b401d.png

    9234296aede9913c1838ff64c0660302.png

    B.进入到下一步后,选择需要安装的组件,然后点击下一步:

    25aa6db18058c7ccc27d23a37e2f2f29.png

    C.在这里可以自定义路径选择安装:

    9c29dc76320863e3c3686b1008f8c7c0.png

    D.点击下一步后,就开始真正安装了:

    d1478b6cbe85e42bbd7bd440959e25a6.png

    E:安装完成后,会有一个安装成功的提示界面:

    775e2e53d8cdf6e38ec41cf72ac2b13b.png

    1.3 Python 测试

    python安装好之后,我们要检测一下是否安装成功,用系统管理员打开命令行工具cmd,输入“python -V”,然后敲回车,如果出现如下界面,则表示我们安装成功了;

    57ee52a4f26d284e49620246d525bcdf.png

    2、pip及numpy安装

    2.1 下载

    图片:

    23f80d0afe8a37a6995d042ca78b90ff.png

    注意选择版本:这里cp36指对应Python的版本,还要注意后面的64,是你的系统

    2.2 安装pip

    下载完成之后,解压到一个文件夹,用cmd进入这个解压好的文件夹,输入:Python setup.py install

    Python setup.py install

    2.3 安装numpy

    打开cmd,进入whl安装包的存放目录,输入命令行:pip install numpy文件名.whl

    pip install numpy文件名.whl

    随机生成矩阵测试:

    b845969d8349a989051b6b7ad5f6da2a.png

    3、Tensorflow安装

    TensorFlow可以通过两种方式进行安装。一是”native” pip,二是Anaconda。

    3.1 准备

    A、windows10

    B、Python3.5.2(之前电脑上是安装的就是这个版本,如果你安装了,不知道版本的话可以在命令窗口输入"python --version",会显示你已安装的Python的版本号)

    C、Anaconda3-5.0.1-Windows-x86_64.exe (windows下安装注意选择windows x86 64位就好)

    3.2 Anaconda3-5.0.1 安装

    3.2.1 Anaconda下载

    3.2.2 Anaconda安装

    双击exe安装:

    2a8a80c2bb09d040995775c8dfb4e766.png

    新建环境:

    注意: 选择Python环境为对应安装的版本!

    0bac594170ac0f39e9ea5b0bcb8a0f86.png

    92ff5c55631ed9b4075df55dec6d51a7.png

    测试打开Terminal:

    e5a6e98b455bc686949921ce7883898a.png

    3.3 安装virtualenv

    61f340ad8e7b27c6d2431bbbec0f35d6.png

    3.4 Tensorflow在线安装

    注意: 保持pip版本较新

    如果安装Tensorflow出现如下提示,按照提示升级pip即可:

    f811245a79d588b613d781556d73dad2.png

    成功升级pip-19.3.1:

    b3a4a5fbe5157685092bc11f00ee64d7.png

    输入以下命令安装Tensorflow:

    pip install --ignore-installed --upgrade tensorflow

    等待。。。

    dae05f013b7d61591df0886df8399adb.png

    展开全文
  • 安装步骤:模型源码:https://github.com/tensorflow/models1、下载源码后解压,修改文件夹名为models(以下步骤中涉及到路径的地方需要根据自己的实际情况而定)2、安装protoc:打开网址...,我这里下载的是proto-3.7.1-...

    安装步骤:

    模型源码:https://github.com/tensorflow/models

    1、下载源码后解压,修改文件夹名为models

    (以下步骤中涉及到路径的地方需要根据自己的实际情况而定)

    2、安装protoc:

    打开网址https://github.com/protocolbuffers/protobuf/releases,,我这里下载的是proto-3.7.1-win64.zip,根据自己的电脑配置来。

    下载后复制到与models同名的文件夹下,解压,生成:bin、include。将bin文件夹下的protoc.exe复制到C:\Windows\System32文件夹下。cmd打开命令行界面,输入命令protoc,出现如下界面说明安装成功:

    3、编译proto文件

    在models/research下运行Windows PowerShell(注意,这里必须是PowerShell,运行cmd会报错),输入如下命令:

    Get-ChildItem object_detection/protos/*.proto | Resolve-Path -Relative | %{ protoc $_ --python_out=. }

    运行完成后,可以检查object_detection/protos/文件夹,如果每个proto文件都成了对应的以py为后缀的python源码,就说明编译成功了。

    4、添加环境变量

    在Anaconda\Lib\site-packages添加一个路径文件,如tensorflow_model.pth,必须以.pth为后缀,写上你要加入的模块文件所在的目录名称,如下图:

    5、运行models/research下的setup.py

    python setup.py build

    python setup.py install

    6、安装完成测试

    在models/research下运行如下命令:

    python object_detection/builders/model_builder_test.py

    出现如下信息,说明已安装成功:

    7、执行已经训练好的模型

    在research文件夹下运行命令:jupyter notebook,接着在jupyter中打开object_detection文件夹,并单击object_detection_tutorial.ipynb运行试例文件。如下所示:

    运行所有代码后的结果如下:

    以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持我们。

    本文标题: windows10下安装TensorFlow Object Detection API的步骤

    本文地址: http://www.cppcns.com/jiaoben/python/262187.html

    展开全文
  • 深度学习现在打得火热,TensorFlow为Google开源的新一代深度学习框架,其中阿尔法狗就是来源于此。Tensor(张量)意味着N维数组,Flow(流)意味着基于数据流图的计算,TensorFlow为张量从图象的一端流动到另一端计算...
  • 1.首先确保已经安装python,然后用pip来安装matplotlib模块。2.进入到cmd窗口下,建议执行python -m pip install -U pip setuptools进行升级。3.如果之前已经安装了Numpy,则需要先卸载之前的安装,因为每个...
  • 感谢作者:https://www.jianshu.com/p/3e91bc60e219 挺好的
  • 感同身受,我之前也是这个问题,安装显示成功了,但是import 却说没有。...要验证这一点很简单,你打开 cmd ,输入 python,然后import tensorflow,看看是不是成功了?如果还是报没有模块的错误,那见鬼...
  • 2.如果之前已经安装了Numpy,则需要先卸载之前的安装,因为每个Tensorflow都有一个版本的numpy对应,故要卸载之前numpy 卸载numpy命令: pip uninstall numpy 3.输入命令安装python -m pip install --upgra...
  • win10安装tensorflow 安装了两次都报错 缺少模块,自己记录下 一般是 python版本与tensorflow版本不匹配导致的,各种各样的报错。这种问题类似与java工程的jar包冲突,解决思路是找到对应的版本,防止不兼容即可。 ...
  • 序言:Tensorflow1的版本问题:重要提示:本教程面向TensorFlow1.14,它(在编写本教程时)是TensorFlow2.x之前的最新稳定版本。 Tensorflow 1.15也已发布,但似乎显示出不稳定性问题。TensorFlow 1.9的版本可以在这里...
  • 安装新工具总是能遇到各种各样奇怪的问题!...(1)安装python3.7的anaconda3,再安装tenserflow 1.12之后输入代码import tensorflow as tf 显示找不到.dll模块。 解决方法:将tensorflow的版本降低为1.4,pyt...
  • 2.TensorFlow 环境的准备:本人使用 macOS,Python 版本直接使用 anaconda 的集成包,我们使用 anaconda 来管理环境,为 TensorFlow 创建独立的 Python 环境。创建一个名为 tensorflowPython 环境:conda...
  • os: ubuntu14.04.4 python: 2.7.13 tensorflow-gpu: 1.4.1 cuda: 8.0.44-1 cudnn: cudnn-8.0-linux-x64-v6.0-tgz...1.安装支持gpu设置的tensorflow-gpu pip install tensorflow-gpu==1.4.1 -i http://pypi.do...
  • 目录1、Python 安装1.1 python 下载1.2 Python 安装1.3 Python 测试2、pip及numpy安装2.1 下载2.2 安装pip2.3 安装numpy3、Tensorflow安装3.1 准备3.2 Anaconda3-5.0.1 安装3.2.1 Anaconda下载 1、Python 安装 1.1 ...
  • Python3.8.1安装Tensorflow问题

    万次阅读 2020-03-28 15:46:03
    通过pip安装Tensorflow2.1.0版本 出现“ImportError: DLL load failed: 找不到指定的模块”错误。尝试了以下解决方法 (1)网上搜索Python3.8.1没有匹配的TensorFlow版本,因此尝试降python版本。稳定的python版本...
  • 最近打算开始研究一下机器学习,今天在windows上装tensorflow花了点功夫,其实前面的步骤不难,只要依次装好python3.5,numpy,tensorflow就行了,有一点要注意的是目前只有python3.5能装tensorflow,最新版的python...
  • python 3.6 安装 tensorflow

    2020-03-20 13:16:07
    今天使用 python 3.6 安装 tensorflow 2.1 版本的时候出现了一个错误 (ノへ ̄、): ImportError:DLL加载失败:找不到指定的模块 … 重新安装之后也不行,之后去 github 上找到了问题,原来是 tensorflow 的版本太高...
  • 首先,开始时使用的centos6.8安装的python3.7,在安装TensorFlow是提示各种glibc版本过低,后来将系统换到了centos7.5,依然提示版本过低,然后尝试着使用python3.6竟然成功了,后来没办法又重新安装了Ubuntu19.04,...
  • 因为之前一直用的python3.7,虽然网上很多建议装python3.5版本tensorflow的,还是执着的选择了python3.7,就遇到一些问题一.先装了支持python3.7的Anaconda3PATH点或者不点都可,Anaconda3会再搭建一个python,点了...
  • 今天用Anaconda安装tensorflow出现各种坑,用pip安装tensorflow后在测试: import tensorflow as tf 出现报错: ImportError: DLL load failed: 找不到指定的模块的问题 也行是我电脑问题,这种安装总是出问题,后面...
  • 现在win10 Python3.6.8直接用命令pip安装TensorFlow能安装成功,但进行导入使用总是报错,不能导入一些模块。由于已经安装了很多包,担心降低Python版本及其环境影响使用,就一直想查找其他方法进行安装TensorFlow,...
  • 前两天笔者实验室新进了俩煤气灶(技嘉 AORUS),老高兴了。...结果 import tensorflow 之后GG return load_dynamic(name, filename, file) File "C:UserssiriuAppDataLocalProgramsPythonPython...
  • pythonTensorFlow,Keras环境搭建

    千次阅读 2019-07-24 14:11:18
    python,TensorFlow及Keras的安装python安装代码的运行:模块的安装和导入安装TensorFlow安装Keras方法 python安装 我是windows系统,去官网下载exe格式的安装包,双击进行安装。原生软件缺点是里面缺少很多包,用...
  • 如何基于python3.7安装Tensorflow

    千次阅读 2019-06-27 11:34:48
    安装TensorFlow的方法有很多,主流的是通过Anaconda,以及Pycharm这类的软件来进行TensorFlow的安装。 我自己试过这两种方法,但通过pycharm来安装时,容易出现找不到TensorFlow模块的错误; 推荐通过Anaconda来装,...
  • 若是你也遇到这个问题,说明你也没有理解tensorflow到底在哪里。当安装了anaconda3.6后,在PyCharm中设置interpreter,...就会发现在PyCharm中写入import tensorflwo as tf 时,就会报错,提示没有tensorflow模块,...
  • 背景:win10 python3.7 最终安装tensorflow2.0.0 一开始利用pip install直接安装,地址为境外网站,看了一眼安装时长15h,直接放弃,于是到网上找高效的安装方法。 花了一天时间尝试了利用anaconda、下载whl包等方法...
  • 安装Pythontensorflow报错:AttributeError: module ‘tensorflow’ has no attribute ‘Session’ 这不是安装问题,而是tensorflow2.0版本删除了Session模块,可以改用: with tf.compat.v1.Session() as ...
  • Win10+Anaconda+python3.6安装Tensorflow

    千次阅读 2017-10-31 17:35:29
    网上的blog都说使用命令行,conda新建python空间,然后激活安装tensorflow,照着安装后出现各种问题。 tensorflow模块找不到。 各种找原因,以为是自己python3.6版本不兼容,以为是没有安装cudnn,结果

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 581
精华内容 232
关键字:

python安装tensorflow模块

python 订阅