精华内容
下载资源
问答
  • OSPF下发默认路由

    2009-05-20 09:37:32
    ospf-下发默认路由 主要是讲OSPF下发默认路由的一些东西,很有用。
  • 本次实验的目标是全网互通 且为ospf配置一个stub区域和一个nssa区域 实验开始先为所以路由打上必打命令 undo ter mon(取消提示) sysname R1 (为路由器命名) user-int con 0 idle-timeout 0 0(命令永不超时) 再为...

    在这里插入图片描述
    本次实验的目标是全网互通 且为ospf配置一个stub区域和一个nssa区域

    • 实验开始先为所以路由打上必打命令
    • undo ter mon(取消提示)
    • sysname R1 (为路由器命名)
    • user-int con 0
    • idle-timeout 0 0(命令永不超时)
      再为所以路由配置好接口IP和loopback地址
    • system-view(进入系统视图)
    • int g0/0/0(进入接口g0/0/0)
    • ip add 12.1.1.1 24(为其设置ip地址)
    • undo shut(取消关闭)
    • int loop 0(进入环回口0)
    • ip add 1.1.1.1 32(为其配置环回地址)
    • quit(返回)
      每个路由器的配置都同理配置 然后可以开始为ospf建邻居了
    • ospf 1 router-id 1.1.1.1(进入ospf进程1 设置其router id为1.1.1.1)
    • area 1(进入area1)
    • network 12.1.1.0 0.0.0.255(宣告自己的直连网段)
    • network 1.1.1.1 0.0.0.0(宣告自己的直连网段)
    • quit(返回)
    • quit(返回)
    • 注:R1只在area 1区域内 所以只要在area 1 中宣告 其他路由端口分别在不同area区域的要进入其他区域分别宣告
      其他ospf成员路由同上配置就行 这里要注意的是area 3区域没有和area 0区域直连 要创建虚链路 帮助area 0跨越area 2从area 0获取完整lsdb 需要在r3和r4上创建一条虚链路
      R3:area 2(进入area区域2)
      vlink-peer 4.4.4.4(配置虚链路对端router-id)
      R4:area 2(进入area区域2)
      vlink-peer 3.3.3.3(配置虚链路对端router-id)
      display ospf vlink 查看虚链路建立状态
      配置ospf结束后 产看display ospf peer查看邻居建立情况
      再用display ip routing-table 查看路由表是不是把ospf成员的路由都学完整了
      确认后 再开始为R5和R6配置RIP
      R5:
    • router-id 5.5.5.5
    • rip 1
    • version 2
    • undo summary
    • network 56.0.0.0
      R6:
    • router-id 6.6.6.6
    • rip 1
    • version 2
    • undo summary
    • network 56.0.0.0
    • network 6.6.6.6
      这样rip也配置完了 记得查看路由表 是不是真的学到了
      然后再r5上做路由重分发
    • rip 1
    • import-route ospf 1 cost 0
    • quit
    • ospf 1
    • area 3
    • import-route rip 1 cost 100
      - 注:rip 1 和 ospf 1的数字应该和其进程号一致
      完成后查看所有路由的路由表是不是全部学到了 确认学到后开始建立stub区域和nssa区域
      stub区域配置
      R1
    • stub no-summary(带no-summary是完全末梢区域)
      R2
    • stub no-summary(要给stub区域内的路由上都打上)
      NSSA区域配置
      R4
    • nssa no-summary (带no-summary是完全次末节区域)
      都配置完后分别由ABR下发一条默认路由 指向自己
      此处应该在R5上打
    • ospf 1
    • area 3
    • default-route-advertise always cost 0(ospf下下发一条默认路由给所有ospf成员 stub区域的将由该区域ABR指向)
    • quit
    • quit
    • rip 1
    • default-route originate cost 0(rip下下发一条默认路由给所有rip成员)
    展开全文
  • OSPF下放默认路由的方法及场景

    千次阅读 2020-02-24 14:26:45
    OSPF下放默认路由的方法及场景

    OSPF下放默认路由的方法及场景

    一、OSPF下放默认路由的方法

    default-route-advise (always)

    如果本路由器没有默认路由但是需要下放默认路由这个时候才需要加上always 。

    二、OSPF下放默认路由的场景

    1. 在出口路由器中下放默认路由。如图,我们在内网运行ospf,现在访问ISP上的一个地址8.8.8.8,R1作为出口路由器配置了一条默认路由。R1可以正常访问8.8.8.8。
      在这里插入图片描述
      R1可以正常访问8.8.8.8,但是R2、R3是没有去8.8.8.8的路由的,所以此时需要在R1上下放默认路由。在这里插入图片描述
      查看R2、R3的路由表是否收到默认路由。
      在这里插入图片描述
      在这里插入图片描述
      测试能否ping通8.8.8.8。
      在这里插入图片描述在这里插入图片描述
    2. ABR 在stub和totally-stub上下发默认路由。如图所示,在R1、R2、R3之间配置ospf area 0 ,在R2、R5之间配置ospf stub 。
      在这里插入图片描述
      查看R5的路由表,发现收到了一条默认路由,(此时我没有在任何路由器上下放默认路由)所以在stub上的ABR 会自动下放默认路由。

    在这里插入图片描述
    将stub区域修改为totally-stub区域,并重启ospf进程查看路由表,发现而在totally-stub区域中与stub区域是一样的也会自动下放默认路由,与stub区域的区别就是,totally-stub区域会连三类LSA一起过滤只剩这条自动下放的默认。
    在这里插入图片描述
    3. ABR在 nssa和完全totally-nssa上下发默认路由。如图所示,按照图中的区域配置ospf 。
    在这里插入图片描述
    在R3中查看路由表,在没有手动配置下放默认路由的情况下,nssa区域的ABR自动下放默认路由。
    在这里插入图片描述
    现在把nssa区域配置修改为totally-nssa区域,并重启ospf进程,再查看R3的路由表。发现在totally-nssa区域中的这条默认路由是3类。
    在这里插入图片描述

    展开全文
  • 有的时候,我们不知道我们的目标具体网络是什么,但是我们知道如何转发数据报文,比如出公网,这是因为我们求助了默认网关,这个就好比默认路由的作用。在OSPF网络中,若存在大量的外部路由,不仅会占用路由器的CPU...

    目录

    一、实验原理

    二、实验拓扑

    三、实验步骤 

    四、实验过程

    总结 


    实验难度3
    实验复杂度4

     

     

    一、实验原理

    有的时候,我们不知道我们的目标具体网络是什么,但是我们知道如何转发数据报文,比如出公网,这是因为我们求助了默认网关,这个就好比默认路由的作用。在OSPF网络中,若存在大量的外部路由,不仅会占用路由器的CPU与内存资源,而且会增加网络管理人员的管理麻烦,所以,我们可以使用一种类似网关的作用来解决此类问题。我们在边界路由器ASBR注入一条OSPF默认路由,然后它就传播给整个OSPF区域,所有的路由器都知道最后的求助网关是谁了。OSPF注入默认路由的方式有两种,一种是直接使用default-information originate alwayls命令强行注入,不管是否存在默认路由都可以;另外一种是手工配置默认路由+default-information originate,这种方式就必须要有默认路由存在才可以,否则会注入默认路由失败的。

    二、实验拓扑

     

    三、实验步骤 

    1.搭建如图所示的网络拓扑;

    2.初始化各路由器,配置相应的IP地址,测试直连网络的连通性;

    3.配置如图所示OSPF路由协议与RIP路由协议;

    4.把OSPF协议路由重分发到RIP路由中,修改度量值为5;

    5.在R2上使用default-information originate always命令进行强注入OSPF默认路由,在R4上查看效果;

    6.在R2上配置默认路由,下一跳指向Null0,在R2上使用default-information originate进行注入默认路由,在R4上查看效果。

    四、实验过程

    1.搭建如图所示的网络拓扑;

    略。

    2.初始化各路由器,配置相应的IP地址,测试直连网络的连通性;

    略。

    3.配置如图所示OSPF路由协议与RIP路由协议;

    (1)配置OSPF路由协议

    (2)配置RIP路由协议

    4.把OSPF协议路由重分发到RIP路由中,修改度量值为5;

    效果:

    5.在R2上使用default-information originate always命令进行强注入OSPF默认路由,在R4上查看效果;

    效果:

    学多一点:

    在这里我们看到R4是有OSPF默认路由的,这个度量值为1,路由类型为OE 2的,我们可以修改这个参数,如下:

    6.在R2上配置默认路由,下一跳指向Null0,在R2上使用default-information originate进行注入默认路由,在R4上查看效果。

    (1)删除上一个实验的默认路由配置

    (2)配置默认路由,下一跳指向Null0

    (3)在R2上使用default-information originate进行注入默认路由

    (4)效果

    注意:

    1.在注入OSPF默认路由时,这个OSPF默认路由的度量值都为O E2类型,度量值都为1;

    2.default-information originate命令是注入已经存在的默认路由,若没有存在的默认路由,那么OSPF默认路由注入将会失败;

    3.default-information originate always命令是强行注入默认路由,不管是否存在默认路由。

    代码解析:

    R2(config-router)#default-information originate always   //强行注入默认路由,不管是否本身存在默认路由

    R2(config-router)#default-information originate always metric-type 1  //强行注入默认路由,且把路由类型修改为OE1类型

    R2(config-router)#default-information originate    //注入已经存在的默认路由

    总结 

    本章节的实验内容难度适中,不过有一个重分发的内容超纲了,这个是后面的一个内容,现在可以不用管它,做出实验效果为主。好了,我们在下一个章节再见,加油!

    展开全文
  • 使用RIP、OSPF发布默认路由

    千次阅读 2020-04-07 10:18:36
    原理概述 默认路由是指目的地址和掩码都是0的路由条目。...RIP和OSPF这两种路由协议都可以通过配置使路由器对协议邻居发布默认路由,并且可以设置该路由的度量值。 实验目的 理解默认路由的应用场景 掌握RIP发布默...

    原理概述

    默认路由是指目的地址和掩码都是0的路由条目。当路由器无精确匹配的路由时,就可以通过默认路由进行报文转发。合理使用默认路由,可以在很大程度上减少本地路由表的大小,节约设备资源。默认路由可以在路由器上手工配置,也可以由路由协议自动发布。RIP和OSPF这两种路由协议都可以通过配置使路由器对协议邻居发布默认路由,并且可以设置该路由的度量值。

    实验目的

    • 理解默认路由的应用场景
    • 掌握RIP发布默认路由的配置
    • 掌握OSPF发布默认路由的配置

    实验内容

    路由器R1分别连接两家公司网络,R1左侧公司A内部网络RIP协议,公司B内部网络运行OSPF协议。由于业务发展需要,两家公司人员需要能够互相通信,但是为了保护自身网络的私密性,双方都不愿意对方知道自己网络的明细路由。这种情况下需要配置路由协议以自动发布默认路由的方式来完成此需求。

    实验拓扑

    在这里插入图片描述
    在这里插入图片描述

    实验配置

    R1的配置:
    #
    interface GigabitEthernet0/0/0
    ip address 172.16.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 192.168.2.1 255.255.255.0
    #
    ospf 1
    default-route-advertise always
    area 0.0.0.0
    network 192.168.2.0 0.0.0.255
    #
    rip 1
    undo summary
    default-route originate
    version 2
    network 172.16.0.0

    R2的配置:
    #
    interface GigabitEthernet0/0/0
    ip address 172.16.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 172.16.1.254 255.255.255.0
    #
    rip 1
    undo summary
    version 2
    network 172.16.0.0

    R3的配置:
    #
    interface GigabitEthernet0/0/0
    ip address 192.168.1.254 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 192.168.2.3 255.255.255.0
    #
    ospf 1
    area 0.0.0.0
    network 192.168.1.0 0.0.0.255
    network 192.168.2.0 0.0.0.255

    展开全文
  • OSPF默认路由

    2009-08-28 18:06:29
    默认路由也是一条路由,具有路由的基本功能,也有下一跳,和前往的网络,... 那么OSPF怎么产生默认路由的呢,这完全取决这条默认路由将被通告给哪种类型的区域,在OSPF中,有这么几种区域:标准区域、stub区域、tota...
  • NSSA有两种方式宣告默认路由,第一种areaarea-idnssano-summary第二种areaarea-idnssadefault-information-originate那么这两种方式的Metric值一样吗?如果不一样,分别是多少?对于我上面那张图,默认情况下第一种...
  • 将某公司内部的主机通过配置单臂路由OSPF、RIP、引入路由、Easy IP技术来实现公司内部网络能够访问互联网。 ●实验拓扑图 在华为模拟器中新建如下图所示拓扑图 ●实验步骤 1.路由器R1配置 interface GigabitEther
  • OSPF 默认路由

    千次阅读 2019-04-01 22:45:03
  • Cisco ospf 默认路由综合实验 一、实验拓扑: R1、R2模拟内部网络路由器,运行OSPF协议,R3模拟互联网路由器,现需要通过R2上配置默认路由,让R1能学习到R3的3.3.3.3路由条目。 二、实验步骤: R1: interface...
  • Stub区域:拒四型,五型LSA,区域的ABR会自动产生一...STUB区域内不能存在ASBR,即自治系统外部的路由不能在STUB区域内传播。 STUB区域内不能存在虚连接。 Totally stub区域:三四五都拒绝,这个三类是指不允许其他区域
  • ospf有一个变通的方法,就是通过default-route-advertise命令,将自己作为默认路由的下一跳宣告到ospf区域内,这样,ospf里的其他路由器就会将缺省流量发送给自己,然后本路由器再根据其他协议的路由表进行转发。...
  • OSPF路由过滤、汇总和默认路由

    千次阅读 2020-05-18 09:00:20
    OSPF路由过滤、汇总和默认路由 1、路由过滤 1类LSA和2类LSA不能进行过滤,因为链路状态逻辑要求区域内的所有路由器维持完全相同的LSDB;否则会导致SPF无法正常工作和计算出的路由出错。 因此OSPF只有一下过滤方法:...
  • 传播OSPF默认路由

    2011-10-13 09:55:48
     default-information originate //生成一条默认路由下发OSPF域中 ! ip classless ip route 0.0.0.0 0.0.0.0 10.0.2.2 //创建默认路由指向ISP     R3配置: interface Loopback1  ip address ...
  • R3(config)#ip route 0.0.0.0 0.0.0.0 se2/0 R3(config)#router ospf 1 R3(config-router)#default-information originate 向OSPF网络注入一条默认路由 4.在ISP的边界路由器上配置去企业网内部的静态路由,使得到...
  • 配置OSPF引入缺省路由

    千次阅读 2020-08-22 09:34:05
    从路由器上注射一条默认 0/0 路由OSPF 中去,只允许用 OSPF 自身的机制,禁止使用静态 0/0 再分发的方法。 解决: OSPF 不能通过 import-route 命令从其它协议引入缺省路由,如果想把缺省路由引入到OSPF 路由区域...
  • 一、关键术语OSPF,NSSA,METRIC类型二、设备类型和版本设备类型 版本 备注ZXR10 T128 与版本无关ZXR10 T64G 与版本无关三、网络拓扑 ...按照规划:核心NE80向整个OSPF下发缺省路由;各地市ABR...
  • OSPF有哪些下放默认路由的方法 分为大致两种: 一、手工下放默认路由 default-route-advertise 下放默认路由,必须要保证本地有默认路由。 default-route-advertise always 无论本地是否有默认路由,都会下放一条...
  • OSPF,NSSA,METRIC类型 二、设备类型和版本 设备类型 版本 备注ZXR10 T128 与版本无关ZXR10 T64G 与版本无关 三、网络拓扑 组网介绍: 某省的NE80或T128都属于OSPF骨干区域,每个地市都有一个独立...
  • ospf特殊区域,默认路由,汇总,认证 一:OSPF特殊区域: LSA types allowed per area type. Area Type 1&2 3 4 5 7 Backb...
  • 华为OSPF NSSA区域对默认路由的处理 题注: 用华为eNSP做OSPF多区域实验时,发现NSSA区域存在ABR自动导入Type 7default route的问题。记录下来供探讨学习。 一、实验环境 eNSP,所有路由器使用Route模拟。根据...
  • 在此总结练习中,您将配置 在此总结练习中,您将配置 PPP、OSPF、DHCP、NAT 和到 ISP 的默认路由。然后您需要检验您的配置。。然后您需要检验您的配置。
  • OSPF协议特性之认证、汇总、默认路由、完全末节区域 一、stub完全末节区域 1、释义:末节区域是指ospf协议区域中,最末端的区域。如图中R1和R2之间的area1。其中协议规定规定area0不能配置为末节区域。 因为实际...
  • 配置汇总路由EIGRP的自动汇总功能在有些高版本的IOS中默认是关闭的;在某些低版本的ios中默认是打开的,可以用show running-config|inc rotue查看是否打开。EIGRP自动汇总只针对自己产生的(直连路由路由,对于...
  • 示例图 一.实验目的 1.完成上述要求 二.注意事项 三.简单配置 AR1 sysname AR1 # interface GigabitEthernet0/0/0 ip address 10.0.13.1 255.... ospf timer hello 15 # interface LoopBack1 ip address 10.0.1.1

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,098
精华内容 439
关键字:

ospf下发默认路由