精华内容
下载资源
问答
  • RIP协议
    千次阅读
    2021-07-19 21:36:13

    一、RIP协议

    RIP协议是一种内部网关协议(IGP),底层是贝尔曼福特算法,是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的世界,只与自己相邻的路由器交换信息,范围限制在 15跳之内,再远,它就不关心了。所以rip只适用于小区域。Rip协议运行在 UDP 协议之上,使用 520 端口,使用 224.0.0.9 作为组播地址,向外组播路由信息

    工作原理:RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hopcount)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。如果到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。

    4层     UDP  520     
    
    计时器   周期  30s    hold 180s    flash  240s   抑制时间  180s
    

    rip的更新规则

    1. 如果没有则学习
    2. 如果有-判断是否同源
      	1)如果同源无条件学习
      	2)如果不同源--判断开销
           	(1)开销比现有小    学习
           	(2)开销比现有大    忽略
           	(3)开销相同       负载均衡
    

    出现路由环路的现象

    • 跳数会无限增大
    • 数据会在环路循环直到跳数减为0

    防环的方法

    1. 水平分割
      当路由从一个接口进就不能在此接口出;为了避免重复更新尤其在MA网段。

    2. 毒性逆转(也称反向中毒)
      类似于一种触发更新的机制,当网络节点发生突变后,本地会向所有邻居发出一个带毒的数据包(起始跳数为16跳),意思为此节点不可达,要求邻居删除学习到的相关路由。

    Cisco中在邻居收到这个带毒的数据包后,会将这个带毒的数据包返回给本地,代表邻居收到了该条消息。

    华为中不会将这个带毒的数据包返回给本地,而是在本地发送这个带毒的数据包时,会多发几次,也就是说华为的毒性逆转水平分割,不存在逆转行为;仅进行毒性行为,它会多周期几次。

    1. 触发更新
      拓扑发生变更时,路由器立即发送更新消息,而不等更新计时器超时。
      正常情况下,路由器会定期将路由表发送给邻居路由器。而触发更新就是立刻发送路由更新信息,以响应某些变化。检测到网络故障的路由器会立即发送一个更新信息给邻居路由器,并依次产生触发更新通知它们的邻居路由器,使整个网络上的路由器在最短的时间内收到更新信息,从而快速了解整个网络的变化。但这样也是有问题存在,有可能包含更新信息的数据包被某些网络中的链路丢失或损坏,其他路由器没能及时收到触发更新,因此就产生了结合抑制的触发更新,抑制规则要求一旦路由无效,在抑制时间内,到达同一目的地有同样或更差度量值的路由将会被忽略,这样触发更新将有时间传遍整个网络,从而避免了已经损坏的路由重新插入到已经收到触发更新的邻居中,也就解决了路由环路的问题。

    2. 抑制计时器 (即控制更新时间)
      为正在重新收敛的网络增加了应变能力,引入了某种程度的怀疑量;当收到一条路由更新的跳数大于路由表中已记录的该条路由的跳数时,将会启动抑制计时器。
      抑制计时器用于阻止定期更新的消息在不恰当的时间内重置一个已经坏掉的路由。抑制计时器告诉路由器把可能影响路由的任何改变暂时保持一段时间,抑制时间通常比更新信息发送到整个网络的时间要长。当路由器从邻居接收到以前能够访问的网络现在不能访问的更新后,就将该路由标记为不可访问,并启动一个抑制计时器,如果再次收到从邻居发送来的更新信息,包含一个比原来路径具有更好度量值的路由,就标记为可以访问,并取消抑制计时器。如果在抑制计时器超时之前从不同邻居收到的更新信息包含的度量值比以前的更差,更新将被忽略,这样可以有更多的时间让更新信息传遍整个网络。

    3. 最大跳数
      15跳,16跳不可达;控制协议的工作半径。
      距离矢量路由算法可以通过IP头中的生存时间(TTL)来 纠错,但路由环路问题可能首先要求无穷计数。为了避免这个延时问题,距离矢量协议定义了一个最大值,这个数字是指最大的度量值(如rip协议最大值为16),比如跳数。也就是说,路由更新信息可以向不可到达的网络的路由中的路由器发送15次,一旦达到最大值16,就视为网络不可到达,存在故障,将不再接受来自访问该网络的任何路由更新信息。

    宣告问题

    rip的包

    + update
    + request
    + reply
    

    二、OSPF协议

     RIP	距离矢量型	传递信息沿途路由器都会更改计算	内容携带的是矢量信息(路由表)		分布式计算
    
    OSPF	链路状态型	递信息沿途不会被更改 	   		内容携带的是链路状态信息(拓扑信息)  集中式计算
    

    OSPF的传递拓扑信息(LSA)的前提是路由器之间需要建立邻居关系

    OSPF的运算过程

     1. OSPF建立邻居
    
     2. OSPF洪范LSA
    
     3. LSDB同步
    
     4. 运行SPF算法
    
        1) 第一步以自己为根计算到达其他路由器节点的最短路径树----计算树干
        2)第二步计算路由器节点上的网段信息----计算树叶
    

    router-id

    唯一性
     
    手动指定
    
    自动选举     有回环先选回环,多回环选大的,没回环选物理接口,多接口选大的
    

    DR/BDR

    DR/BDR——指定路由器 /备份的指定路由器

    解决ospf在多路网络中邻居数量过多以及信息重复传递问题

    选举DR/BDR

    1. 先看接口优先级(0-255默认是1),数值大的优先,0表示无选举权。
    2. 如果优先级一致,router-id大的优先。
    

    命令

      接口下  ospf dr-priority  X
    

    不能抢占,如果要抢占需要重启OSPF进程 >reset ospf process

    drother 224.0.0.6 发 收224.0.0.5

    dr/bdr 224.0.0.6 收 发 224.0.0.5

    OSPF邻居转态

    1. down  
    2. init   
    3. tow-way      邻居关系---邻居表-----dis ospf peer(brief)    用到包为hello、DBD(空) 
    
    1. exstart      邻接关系---LSDB -----dis ospf lsdb   		用到的包为DBD(非空)LSR  LSU LSACK
    2. exchange
    3. loading
    4. full
    

    OSPF包

    • hello
    • DBD
    • LSR
    • LSU
    • LSACK

    OSPF开销

    ​ cost=10^8/接口带宽 开销是路径叠加值

    修改开销

    ​	修改接口带宽
    
    ​	接口下  ospf cost X
    

    ABR

    ABR 区域边界路由器,area border router,位于一个或多个OSPF区域边界上、将这些区域连接到主干网络的路由器。ABR被认为同时是OSPF主干和相连区域的成员。因此,它们同时维护着描述主干拓扑和其他区域拓扑的路由选择表。

    ASBR(自治系统边界路由器):ASBR位于OSPF自主系统和非OSPF网络之间。ASBR可以运行OSPF和另一路由选择协议(如RIP),把OSPF上的路由发布到其他路由协议上。ASBR必须处于非存根OSPF区域中。
      由ASBR发出的LSA5,用于向自治系统区域通告网络拓扑。

    metric值包含cost值,每个协议的metric标准都不同。

    metric:路由算法确定到达目的地的最佳路径的计量标准。
    常用metric有:路径长度、可靠性、延迟、带宽、负载等。
    在路径长度这一类中,不同协议有不同标准。如:RIP依据跳数,OSPF依据cost,EIGRP主要依据带宽K1和延时K3。

    通常一个路由算法基于多个metric,并最终形成一个复合metric来作为选路标准。
    metric越小越好-和优先级一样。

    更多相关内容
  • RIP是Routing Information Protocol(路由信息协议)的简称。它是一种较为简单的内部网关协议IGP(Interior Gateway Protocol),主要应用于规模较小的网络中,...对于更为复杂的环境和大型网络,一般不使用RIP协议
  • RIP协议模拟实验

    2018-11-08 18:34:00
    利用思科模拟器对动态协议进行验证,用到的路由器、交换机和PC端。
  • RIP协议

    2022-02-23 16:03:56
    RIP 是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为度量值来衡量到达目的地址的距离。在 RIP 网络中,缺省情况下,设备到与它直接相连网络的跳数为 0,通过一个设备可达的网络的跳...

    RIP 基本原理

    RIP 是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为度量值来衡量到达目的地址的距离。在 RIP 网络中,缺省情况下,设备到与它直接相连网络的跳数为 0,通过一个设备可达的网络的跳数为 1,其余依此类推。也就是说,度量值等于从本网络到达目的网络间的设备数量。为限制收敛时间,RIP 规定度量值取 0~15 之间的整数,大于或等于 16 的跳数被定义为无穷大,即目的网络或主机不可达。由于这个限制,使得 RIP 不可能在大型网络中得到应用

    RIP 路由表的形成

    RIP 启动时的初始路由表仅包含本设备的一些直连接口路由。通过相邻设备互相学习路由表项,才能实现各网段路由互通。

    图 1 RIP 路由表形成过程
    在这里插入图片描述

    • RIP 协议启动之后,RouterA 会向相邻的路由器广播一个 Request 报文。
    • 当 RouterB 从接口接收到 RouterA 发送的 Request 报文后,把自己的路由表封装在 Respone
      报文内,然后向该接口对应的网络广播。
    • RouterA 根据 RouterB 发送的 Response 报文,形成自己的路由表。

    RIP 的更新与维护
    RIP 协议在更新和维护路由信息时主要使用四个定时器:更新定时器、老化定时器、垃圾收集定时器、抑制定时器

    RIP 路由与定时器之间的关系
    RIP 的更新信息发布是由更新定时器控制的,默认为每 30 秒发送一次。

    rip版本

    RIP 包括 RIP-1 和 RIP-2 两个版本,RIP-2 对 RIP-1 进行了扩充,使其更具有优势。
    RIP-1 与 RIP-2 的比较
    RIP-1(即 RIP version1)是有类别路由协议(Classful Routing Protocol),它只支持以广播方式发布协议报文,报文格式如图 1 所示。RIP-1 的协议报文中没有携带掩码信息,它只能识别 A、B、C类这样的自然网段的路由,因此 RIP-1 无法支持路由聚合,也不支持不连续子网(Discontiguous Subnet)。
    RIP-2(即 RIP version2)是一种无分类路由协议(Classless Routing Protocol)
    支持外部路由标记(Route Tag),可以在路由策略中根据 Tag 对路由进行灵活的控制。

    • 报文中携带掩码信息,支持路由聚合和 CIDR(Classless Inter-Domain Routing)。
    • 支持指定下一跳,在广播网上可以选择到最优下一跳地址。
    • 支持以组播方式发送更新报文,只有支持 RIP-2 的设备才能收到协议报文,减少资源消耗。
    • 支持对协议报文进行验证,并提供明文验证和 MD5 验证两种方式,增强安全性

    解决路由环路的方式

    水平分割和毒性反转 可以有效的防止路由环路。
    水平分割(Split Horizon)的原理是,RIP 从某个接口学到的路由,不会从该接口再发回给邻居路由器。这样不但减少了带宽消耗,还可以防止路由环路。
    毒性反转(Poison Reverse)的原理是,RIP 从某个接口学到路由后,将该路由的开销设置为 16(即指明该路由不可达),并从原接口发回邻居路由器。利用这种方式,可以清除对方路由表中的无用路由。

    rip基本配置

    在这里插入图片描述
    距离矢量路由协议

    • 使用组播地址(224.0.0.9)发送路由信息 ,当路由器接交换机时,可能连接多个路由器,使用组播就可以让多个路由器同时收到路由信息。
    • 适用于小型网络(最大跳 15)
    • 每三十秒更新一次路由信息
    • 主类网络(有类):major-net ,使用自然掩码的网段:例如12.1.1.0/24—>12.0.0.0 ,192.168.1.0/24—>192.168.1.0,172.16.1.0/24—>172.16.0.0
    ① 配置各路由器的接口 IP 
    a) 配置 R1 
    <Huawei>system-view 
    [Huawei]un in en 
    [Huawei]sysn R1 
    [R1]int gig 0/0/1 
    [R1-GigabitEthernet0/0/1]ip address 192.168.1.1 24 
    [R1-GigabitEthernet0/0/1] 
    b) 配置 R2 
    <Huawei>system-view 
    [Huawei]Un in en 
    [Huawei]sysn R2 
    [R2]int gig 0/0/2 
    [R2-GigabitEthernet0/0/2]ip add 192.168.1.2 24 
    [R2-GigabitEthernet0/0/2]int gig 0/0/1 
    [R2-GigabitEthernet0/0/1]ip add 10.1.1.1 24 
    [R2-GigabitEthernet0/0/1]quit 
    c) 配置 R3 
    <Huawei>system-view 
    [Huawei]Un in en 
    [Huawei]sysn R3
    [R3]int gig 0/0/2 
    [R3-GigabitEthernet0/0/2]ip add 10.1.1.2 24 
    [R3-GigabitEthernet0/0/2]int gig 0/0/1 
    [R3-GigabitEthernet0/0/1]ip add 172.16.1.1 24 
    [R3-GigabitEthernet0/0/1]quit 
    d) 配置 R4 
    <Huawei>system-view  
    [Huawei]Un in en 
    [Huawei]sysn R4 
    [R4]int gig 0/0/2 
    [R4-GigabitEthernet0/0/2]ip add 172.16.1.2 24 
    [R4-GigabitEthernet0/0/2]quit 
    
    
    ② 配置各个路由器的 RIP 功能 
    a) 配置 R1 
    [R1]rip //进入 RIP 配置 
    [R1-rip-1]network 192.168.1.0 //宣告网络 
    [R1-rip-1]quit 
    b) 配置 R2 
    [R2]rip 
    [R2-rip-1]network 192.168.1.0 
    [R2-rip-1]network 10.0.0.0 
    [R2-rip-1]quit 
    c) 配置 R3 
    [R3]rip 
    [R3-rip-1]network 10.0.0.0 
    [R3-rip-1]network 172.16.0.0 
    [R3-rip-1]quit 
    d) 配置 R4 
    [R4]rip 
    [R4-rip-1]network 172.16.0.0 
    [R4-rip-1]quit 
    
    

    查看各路由器上 RIP 信息 :使用 display rip 1 route
    配置RIP路由协议 :rip network 172.16.0.0(与次路由器直连的所有接口)
    抑制接口:(静默接口)silent-interface e0/0/0 将接口e0/0/0配置成默认接口,rip路由更新不在从该接口发送。pc不需要学习路由器,所以不需要接受路由信息。

    RIP 引入外部路由

    routerB为中间路由
    [RouterB] rip 100 
    [RouterB-rip-100] default-cost 3 
    [RouterB-rip-100] import-route rip 200 
    [RouterB-rip-100] quit 
    [RouterB] rip 200 
    [RouterB-rip-200] import-route rip 100 
    [RouterB-rip-200] quit
    
    展开全文
  • rip协议

    2022-05-16 09:33:29
    4、配置RIP协议 5、测试1:PC1 是否能和 PC2 正常通信 RIP 默认为 version 1,RIPv1 为距离矢量路由协议,边界自动汇总。由于RIPv1 为有类路由协议,无法关闭自动汇总。 解决办法:使用版本2,关闭自动...

    一、实验目的


    1. 掌握RIPv1的基本配置
    2. 掌握RIPv2的基本配置
    3. 了解RIP手动汇总、协议认证、默认路由分

    二、关键命令


           Router(config)#router rip

    (启动进程)

    Router(config-router)#network X.X.X.X

    (RIP 主类宣告)

    Router(config-router)#versiton 2

    (将 RIP 版本切换成 version2。)

    Router(config-router)#no auto-summary

    (关闭自动汇总(仅在 RIP version2 下有效))

    *Router(config-router)#default-information originate

    (下发默认路由(根据需求配置))

    *Router(config-if)#ip summary-address rip ip mask

    (接口手动汇总(根据需求配置))

    三、实验步骤


    1、实验拓扑图如下:

    2、R1配置:

    Router>enable
    Router# config terminal
    Router(config)#hostname R1
    R1(config)#interface fa0/0
    R1(config-if)#ip address 10.10.10.254 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#interface fa0/1
    R1(config-if)#ip address 10.12.12.1 255.255.255.252
    R1(config-ig)#no shutdown

    R3

    2、R2配置

    Router(config)#hostname R2
    R2(config)#interface fa0/1
    R2(config-if)#ip address 10.12.12.2 255.255.255.252
    R2(config-if)#no shutdown
    R2(config-if)#interface fa0/0
    R2(config-if)#ip address 10.23.23.1 255.255.255.252
    R2(config-if)#no shutdown

    3、R3配置

    Router(config)#hostname R3
    R3(config)#interface fa0/0
    R3(config-if)#ip address 10.23.23.2 255.255.255.252
    R3(config-if)#no shutdown
    R3(config-if)#interface fa0/1
    R3(config-if)#ip address 10.10.20.254 255.255.255.0
    R3(config-if)#no shutdown

    4、配置RIP协议

    R1:
    R1(config)#router rip
    R1(config-router)#network 10.0.0.0
    R2 :
    R2(config)#router rip
    R2(config-router)#network 10.0.0.0
    R3:
    R3(config)#router rip
    R3(config-router)#network 10.0.0.0

     

    5、测试 1:PC1 是否能和 PC2 正常通信

    RIP 默认为 version 1,RIPv1 为距离矢量路由协议,边界自动汇总。由于 RIPv1 为有类路由协议,无法关闭自动汇总。

    解决办法:使用版本2,关闭自动汇总。

    R1:
    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#no auto-summary
    R2:
    R2(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#no auto-summary
    R3:
    R3(config)#router rip
    R3(config-router)#version 2
    R3(config-router)#no auto-summary

     6、测试 2:两台 PC 机能否通信

     

    展开全文
  • 西安电子科技大学计算机通信网络实验三 RIP协议原理及配置
  • RIP协议的研究与仿真

    2021-01-29 17:15:48
    为了解决小型网络中自治系统内部路由信息的传递,采用了基于距离向量的路由选择协议RIP。通过对RIP协议的特点、工作原理、报文格式等...仿真结果验证了RIP协议的实现方法,为RIP协议在实际网络中的正确部署提供了参考。
  • RIP协议代码.rar

    2020-05-17 14:14:13
    《计算机网络》(computer networking)课后习题中RIP协议实现代码。包括node0、node1、node2、node3和proc3五个文件。
  • 基于RIP协议搭建某高校的校园网,论文设计与实现,学生可以学习参考
  • 使用C语言进行RIP协议的模拟实现,对学习RIP协议有一定指导意义
  • RIP协议模拟,有图示,比较形象的实现了该协议的模拟。
  • 浅析rip协议

    2019-02-20 14:01:23
    RIP协议是一种在网关与主机之间交换路由选择信息的标准,本ppt对其进行了简要介绍
  • 使用Java制作可视化界面,实现Rip协议的工作流程。
  • RIP协议是一种动态路由协议。RIP协议基于距离矢量算法。使用“跳数”来衡量到达目标地址的路由距离,实现RIP协议
  • 路由协议与交换技术实验配置
  • RIP协议详解

    2022-07-07 16:33:28
    毒性反转和水平分割都可避免路由环路的产生,但是两者原则上为互斥的,即RIP网络中RIP路由器不会同时开启水平分割和毒性反转功能。通常,RIP网络中的路由器都会配置触发更新功能, 然后再水平分割和毒性反转功能中...

    1、协议内容

    RIP(Routing information Protocol) 是比较古老的动态路由协议,是一种基于距离矢量算法来计算到
    达目的网络的最佳路径路由协议,RIP报文承载于UDP报文,使用UDP端口520,属于应用层协议。
    在RIP协议中,路由根据到达目的地的跳数作为路由选择的度量值。

       

    2、路由交换过程

        (1)RIP更新方式

    网络初始化后,每一台使用RIP协议的路由器,通过间隔30秒向邻居路由器广播同步路由表配置同
    步报文,同时邻居也会不断广播同步路由表报文,经过收敛事件后,每台路由器都会包含去往整个
    自制系统内所有路由器的路由信息。
            (注:在整个系统稳定的状态下,路由信息交换也是会持续进行。)

    所谓逐跳,如上图所示,拓扑更新时,B首先更新本地路由表,然后将自己的路由表信息广播至自
    治系统内的邻居路由器,如图上的路由器A,然后A开始路由信息的学习,然后再向A的邻居们进行
    广播同步。

        (2)距离向量算法

            使用RIP协议的路由器会对邻居路由器广播发送来的的报文进行以下处理:

                 a.将邻居路由器R发送来的路由表中所有条目的距离字段加一,并将吓一跳地址都更改为R。
                       (路由表项目条目的三个关键字段:目的地网络N,距离D,吓一跳路由器X)
                  b.逐条分析更新过后的路由表:
                    若条目中的目的网络不在自身路由表中,则将该路由条目加入到自身路由表中;
                    若条目中的目的网络在自身路由表中且下一跳同时为R,则使用该条目替换自身路由
                    表该条记录;
                    若条目中的目的网络在自身路由表中但下一跳不同为R,则比较距离D,系统优先考虑
                    距离更小对的条目。
                  c.若180s后还没有收到RIP网络中某一路由器的更新路由表,则把该路由器标记为不可
                    达距离,即把距离设置为16;
                 d.返回。

         (3)RIP报文封装过程

              RIP报文消息都是封装在UDP报文中,端口号是520,而UDP报文是封装在IP报文中的,
              IP把报文封装在以太帧中。

    RIPv1: a.对于请求消息或周期性的响应消息,IP报文的目的地址为广播IP地址255.255.255.255,
                    源地址为发送该请求消息或响应消息的接口的IP地址,协议字段为0x11。以太帧的目的
                    地址为广播MAC地址ff-ff-ff-ff-ff-ff,源地址为发送该请求消息或响应消息的接口的MAC地
                    址,类型字段是0x0800。

                b.对于为了回应请求消息而发送的响应消息,IP报文的目的地址为发送请求消息的接口的
                   IP地址,源地址为发送该响应消息的接口的IP地址,协议字段的值为0x11。以太帧的目
                   的地址为发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地
                   址,类型字段是0x0800。

    RIPv2: a.对于请求消息或周期性的响应消息,IP报文的目的地址可以是组播IP地址224.0.0.9(这
                  个组播地址是对应所有运行RIP-2的路由器的),也可以是广播IP地址255.255.255.255,
                  源地址为发送该请求消息或响应消息的接口的IP地址,协议字段为0x11。以太帧的目的地
                   址为广播MAC地址ff-ff-ff-ff-ff-ff,也可以是某个选定的组播MAC地址,源地址为发送该请
                  求消息或响应消息的接口的MAC地址,类型字段是0x0800

                b.对于为了回应请求消息而发送的响应消息,IP报文的目的地址为发送请求消息的接口的IP
                   地址,源地址为发送该响应消息的接口的IP地址,协议字段的值为0x11。以太帧的目的
                   地址为发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,
                    类型字段是0x0800

    注:RIP-2要比RIP-1少占用计算机的处理资源,因为计算机在网络层就可以把携带有RIP-2消息的
            报文丢弃,而必须在传输层才能把携带有RIP-1消息的报文丢弃。

    3、RIP报文格式

    (1)报文类型:

    请求报文:RIP路由器开始启动后,立即向其他所有邻居路由器发送RIP请求消息,以获取整个RIP
                      网络的网络信息;
                      RIP网络运行过程中,根据自身需要可向邻居发送请求报文。

    响应报文:RIP路由器收到请求报文后,会立即发出RIP响应报文;
                      RIP网络中,路由器总是间隔30秒向邻居发送响应报文,告知邻居当前路由表信息。

    (2)报文格式:

    RIPv1:

            RIP报文字段

    字段含义

    所占字节

    描述

    Command

    命令

    1

    表示报文类型,值为1时表示请求Request报文,向直连路由器请求全部或部分路由信息

    值为2时表示Response报文,一个Response报文最多携带25个路由条目,多于25会发送多个Response

    Version

    版本号

    1

    RIP共有两个版本,值为1代表RIPv1,值为2代表RIPv2

    Must be zero

    未使用

    2

    未使用

    Addr fam id

    地址表示符

    2

    值为2时表示IP协议。如果是请求整个路由表的Request报文,则值为0,同时Request报文有且只有一个路由条目,路由的目的网段为0.0.0.0,度量值为16。

    Must be zero

    未使用

    2

    未使用

    IP address

    IP地址

    4

    路由的目的网络地址

    Must be zero

    未使用

    4

    未使用

    Must bu zero

    未使用

    4

    未使用

    Metric

    度量值

    4

    路由的度量值,也记为跳数 

    RIPv2: 

            RIP报文字段

    字段含义

    所占字节

    描述

    Command

    命令

    1

    表示报文类型,值为1时表示请求Request报文,向直连路由器请求全部或部分路由信息

    值为2时表示Response报文,一个Response报文最多携带25个路由条目,多于25会发送多个Response

    Version

    版本号

    1

    RIP共有两个版本,值为1代表RIPv1,值为2代表RIPv2

    Must bu zero

    未使用

    2

    未使用

    Addr fam id

    地址表示符

    2

    值为2时表示IP协议。如果是请求整个路由表的Request报文,则值为0,同时Request报文有且只有一个路由条目,路由的目的网段为0.0.0.0,度量值为16。

    Route Tag

    未使用

    2

    标记外部路由器或者引入到RIPv2协议中的路由

    IP address

    IP地址

    4

    路由的目的网络地址

    Subnet Mask

    未使用

    4

    用于标记IPV4地址的网络和子网部分

    NextHop

    未使用

    4

    表示比通告路由器地址更好的下一跳地址。若为0.0.0.0,则说明通告路由器地址为最优下一跳。

    Metric

    度量值

    4

    路由的度量值,也记为跳数

    4、RIP定时器机制----三个倒计时计时器

    (1)更新计时器:路由器每隔30s就会发送更新信息,为防止同一时间所有路由器发报文,添加了5s
         对的偏移,在[25,35]之间取值;(收到RIP请求消息时,不影响更新计时器)

    (2)过期计时器:在180s内未收到该路由器的任何信息,就将其设为不可达,即将该表项的距离字段
         设置为16。

    (3)刷新计时器(Holddown):一条记录失效后不会,立即删除,而是等待指定时间后删除,一般为12
        0s,目的是将该无效路由告知所有邻居,倒计时至0时,立即删除该无效路由。

    注:

    a.每一条路由表项对应两个定时器:老化定时器和垃圾收集定时器。当学到一条路由并添加
       到路由表中时,老化定时器启动。如果老化定时器超时,设备仍没有收邻居发来的更新报
    文,则把该路由的度量值置为16(表示路由不可达),并启动垃圾收集定时器。如果垃圾收
    集定时器超时,设备仍然没有收到更新报文,则在路由表中删除该条目。

    b.如果在没有触发更新的前提下,一个路由表项最多需要300秒才能被删除(老化时间+垃圾收集时间);
       如果存在触发更新,那么一个路由条目最多需要120秒才能被删除(即为老化时间).

    5、RIP环路问题

    (1)产生环路的原因:RIP网络中某一段网络的故障,由于收敛速度过慢,部分路由器认为该网
        络仍然可达,导致路由不断更新导致距离计数至无穷大。

    (2)防环机制:

    a.最大跳数:当一个路由条目作为更新信息发送给邻居路由器时,路由条目会自加1跳,通过设定
        最大跳数15防止路由条目被无限转发。同时16跳可作为路由不可达标记。

    b.触发更新:当网络出现拓扑变更后,路由器会立即产生更新通告,并广播通知所有直连邻居,不
       需要考虑30秒的更新计时器。为减少带宽和资源占用,触发更新消息只包含更新的路由条目。

    c.水平分割:RIP路由器路由表中的某条条目信息由路由器的a口学习而来,则路由器a口向外发送
        响应消息时,不会包含该路由项的信息。

    d.毒性反转:RIP路由器路由表中的某条不可达路由条目信息由路由器的a口学习而来,则路由器a口
       向外发送响应消息时,会包含该路由信息,但Metric会设置为16,不可达

    注:毒性反转和水平分割都可避免路由环路的产生,但是两者原则上为互斥的,即RIP网络中RIP路
       由器不会同时开启水平分割和毒性反转功能。通常,RIP网络中的路由器都会配置触发更新功能,
       然后再水平分割和毒性反转功能中选择其一开启。

    6.RIP问题

                                    “好消息传的块,坏消息传的慢”

    7.比较RIPv1 RIPv2

    维度

    RIPv1

    RIPv2

    更新方式

    广播 255.255.255.255

    广播/组播 224.0.0.9

    协议类别

    有类

    无类

    CIDR

    不支持

    支持

    VLSM

    不支持

    支持

    路由聚合

    不支持

    支持

    报文认证

    不支持

    支持

    路由标记tag

    不携带

    携带

    下一跳地址

    不携带

    携带

    掩码信息

    不携带

    携带

    展开全文
  • RIP协议原理及配置实验报告.pdfRIP协议原理及配置实验报告.pdfRIP协议原理及配置实验报告.pdfRIP协议原理及配置实验报告.pdfRIP协议原理及配置实验报告.pdfRIP协议原理及配置实验报告.pdf
  • 路由选择协议(一) RIP协议

    千次阅读 2022-04-27 09:59:52
    在介绍路由协议(RIP、OSPF、BGP)之前会向大家介绍补充一些基本的概念,以便能够更容易的理解本文。 废话不多说我们开始! 一、自治系统 自治系统(Autonomous system)通俗的讲就是我们把全球互联网分成若干个区域,...
  • RIP协议编程

    2015-12-29 10:50:50
    RIP协议编程 ,里面有路由表的转发,是基于距离向量算法的,挺不错的

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 45,626
精华内容 18,250
关键字:

RIP协议