精华内容
下载资源
问答
  • 原本使用jdk12版本,后来为了和基友们玩minecraft,就安装了jdk1.8,但是后来java -version的jdk版本为1.8而无法改为12 问题: 环境变量已修改为jdk12 但在命令框输入java -version时为1.8版本 根据网上的办法,...

    导语:

    原本使用jdk12版本,后来为了和基友们玩minecraft,就安装了jdk1.8,但是后来java -version的jdk版本为1.8而无法改为12

    问题:

    环境变量已修改为jdk12
    环境变量
    但在命令框输入java -version时为1.8版本
    命令框中显示的jdk版本
    根据网上的办法,需要删除以下的一些文件:
    C:\ProgramData\Oracle\Java\javapath;
    C:\Windows\System32目录下的三个java开头的.exe文件
    然而我的电脑并没有这些文件

    解决问题的过程:

    然后我就详细地看了看配置环境变量的信息,然后就在Path中找到了这个:
    在这里插入图片描述
    如第一条环境变量所示:C:\Program Files (x86)\Common Files\Oracle\Java\javapath;
    然后我就到这个文件夹看了看,正是网上说的要删除的几个文件:
    在这里插入图片描述

    解决方法:

    因为jdk1.8安装时会自动配置一个环境变量在path里并置顶了,所以只需要把自己配置的jdk12的环境变量上移到jdk1.8自动配置的环境变量之前即可
    也可以删除jdk1.8自动配置的环境变量
    在这里插入图片描述

    展开全文
  • **问题:**原本使用jdk1.8版本,换成11版本之后,环境变量配置完还是1.8,不生效 **解决:**因为jdk1.8安装时会自动配置一个环境变量在path里并置顶了,所以只需要把自己配置的jdk11的环境变量上移到jdk1.8自动配置...

    **问题:**原本使用jdk1.8版本,换成11版本之后,环境变量配置完还是1.8,不生效
    **解决:**因为jdk1.8安装时会自动配置一个环境变量在path里并置顶了,所以只需要把自己配置的jdk11的环境变量上移到jdk1.8自动配置的环境变量之前(把1上移到2前边)即可
    也可以删除jdk1.8自动配置的环境变量path下目录

    展开全文
  • jdk版本问题-实现不同版本切换

    千次阅读 2020-05-19 15:31:13
    由于我需要用Grami工具,jdk版本为1.8。但是安装最新的neo4j-community-4.0.4显示这个版本的jdk太低了。因此没办法只能安装两个jdk,实现不同版本jdk的切换。 1、两个子JAVA_HOME8、JAVA_HOME13和一个总JAVA_HOME ...

    由于我需要用Grami工具,jdk版本为1.8。但是安装最新的neo4j-community-4.0.4显示这个版本的jdk太低了。因此没办法只能安装两个jdk,实现不同版本jdk的切换。

    1、两个子JAVA_HOME8、JAVA_HOME13和一个总JAVA_HOME

    2、设置Path

    3、添加CLASSPATH变量

    4、验证----每次切换jdk版本只需要改变JAVA_HOME就可以了

    命令java -version javac

    cmd窗口关闭重新开始

    二、笔记本中按照上述办法后,控制台输出版本依然是1.8;怎么改都是1.8。解决过程如下

    1.删除C:\Windows\System32目录下的与java相关的运行程序

    列如java.exe,javax.exe,javac.exe  如果没有相关java程序请忽略

    2、删除C:\Program Files (x86)\Common Files\Oracle\Java\javapath、C:\ProgramData\Oracle\Java\javapath(因为path中配置了引用)的javapath的快捷图标和Java相关的运行程序

    如果没有相关java程序请忽略

    3、从注册表中删除jdk的默认启动的版本

    (1)win+r 输入regedit

    (2)HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft的Java Development Kit的CurrentVersion项的值

    直接把1.8和1.8.0_251删除

    (3)HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft的Java Runtime Environment的CurrentVersion项的值

    同样修改。

     

    展开全文
  • spring boot版本要求jdk版本问题

    千次阅读 2019-09-19 18:45:01
    SpringBoot 版本jdk 版本兼容问题 1、jdk 1.7+springboot 1.4.0可以运行 2、jdk1.7 +springboot 2.0.0不能运行,Spring Boot 2.0 要求 Java 8 作为最低版本。许多现有的 API 已更新,以利用 Java 8 ...

    SpringBoot 版本 与 jdk 版本兼容问题
    1、jdk 1.7+springboot 1.4.0可以运行
    2、jdk1.7 +springboot 2.0.0不能运行,Spring Boot 2.0 要求 Java 8 作为最低版本。许多现有的 API 已更新,以利用 Java 8 的特性,例如:接口上的默认方法,函数回调以及新的 API,如javax.time。如果您当前正在使用 Java 7 或更早版本,则在开发 Spring Boot 2.0 应用程序之前,您需要升级您的 JDK。

    JDK版本导致 Unsupported major.minor version 52.0 error

    tanford parser和jdk版本对应关系

    J2SE 8 = 52,

    J2SE 7 = 51,

    J2SE 6.0 = 50,

    J2SE 5.0 = 49,

    JDK 1.4 = 48,

    JDK 1.3 = 47,

    JDK 1.2 = 46,

    JDK 1.1 = 45

     

    转载于:https://my.oschina.net/cs20160712/blog/3042947

    展开全文
  • java打包jdk版本问题

    千次阅读 2016-05-11 13:55:10
    目前公司jdk大多数版本都使用的1.6,最近要求升级jdk为1.8.由于应用非常多,所以在升级过程中出现了一部分应用以及升为1.8,一部分仍然保持1.6的版本。这里就出现了jdk打包版本的问题: ...关于jdk版本和minor_version
  • 解决Nexus 3.XX Jdk版本问题 Nexus 3++版本 必须要Jdk1.8 一、在启动Nexus 3++版本的时候抛错 ubuntu@10-9-17-59:~/Develop/Nexus/nexus-3.15.2-01/bin$ ./nexus start No suitable Java Virtual Machine could be ...
  • 有关下载javafx与JDK版本问题的解决

    千次阅读 2020-01-01 01:21:46
    第一步,网上有在eclipse中下载javafx的教程,文章最后也附带链接,如果不能成功安装并允许代码,说明可能是JDK版本问题;两种解决办法: 1.eclipse里有自己的JDK配置,感兴趣的可以自己再下一个配,但是过程麻烦,....
  • jenkins jdk版本问题报错

    千次阅读 2018-07-12 15:16:25
    在做平台定制项目时,使用客户的开发环境:JDK1.6,MAVEN3.2.2,此时如果编译平台组件可能会有问题。例如:PTP项目必须使用JDK1.5版本编译,因为1.6版本相比很多接口类增加了接口,在切换到JDK1.6后很多类将会无法...
  • Eclipse导入项目常见问题----jdk版本问题(有个红色感叹号)01 我们导入项目时,有时会看到项目上有一个【红色的感叹号!】,这说明该项目的jdk版本和你的电脑安装的jdk版本不匹配。可能导入的项目时jkd1.6,1.8等等...
  • springmvc与jdk版本问题

    千次阅读 2017-07-12 08:34:44
    jdk版本没有升级的时候,本地的springmvc框架运行的好好的,突然有一天,启动tomcat直接报错,如下:     看到这个错误,我想想了想自己最近好像没动什么代码,我目前的环境是spring3+jdk8. 提示的错误中,...
  • linux安装weblogic对应jdk版本问题

    千次阅读 2018-05-22 10:58:26
    前段时间去另一个项目组帮忙,需要搭建weblogic环境来给我的webservice提供服务,一开始手头没有linux环境下的安装包,便从官网下载了最新的weblogic12c,执行安装时出现如下报错:对错误信息理解的不是很明确,但是...
  • weblogic部署jdk版本问题

    千次阅读 2019-01-04 14:58:42
    然后 weblogic 上边安装也没有问题, 可以正常访问. 过了些天. 又需要一个别的静态页面的时候,我加上去,然后准备更新上weblogic控制台更新一下应用的时候, 意外情况,weblogic控制台直接挂了.无奈重...
  • IDEA导入项目后出现JDK版本问题

    千次阅读 2020-01-06 21:54:55
    > Project Structure -->... 继续看图如下,选择对应的JDK版本 2. 以上还没改完,在点击File --> Settings --> 搜索 Java Compiler,然后如下图 以上选择完后就可以了 ...
  • 关于exlipse启动时jdk版本问题

    千次阅读 2014-12-24 10:58:15
    要注意几点问题: 1.你的eclipse位数对应的问题,假如你是32位的...可以在eclipse安装根目录的eclipse.ini文件中修改eclipse启动时使用的jdk安装位置的bin文件夹中的javaw.exe文件的位置 图中第一行-vm下面的
  • 今天新创建一个as项目突然报错: ...我明明安装了这个版本jdk啊, 令我一脸的懵逼,打开as的配置看一下: file--project structure--SDK-location看到她自己找到c盘program file里边的那个jdk了 这个jd...
  • idea部署web项目时Tomcat与jdk版本问题

    千次阅读 2019-05-21 21:32:50
    2:jdk 版本 jdk1.8.0_111 在idea部署web项目时,当启动tomcat时,后台提示如下错误: 前台页面提示如下错误: 二:问题排查 1:从报错信息可以看出这三种:编译错误,转换异常,找不到index.jsp ...
  • 本来东西在自己的电脑,自己的tomcat上都很正常,但是把接口的导成war包发布给实施的时候,就出现了问题,之后实施的这群人真是啥也不懂,所问非所答的一直就强调程序出错,之后找了好久才知道是jdk版本问题。...
  • 昨天在执行mybatis逆向工程时,在运行主函数时,出现了如下异常: 这个问题在百度,谷歌都搜不到满意的答案。...就有疑问:是不是因为MySQL版本和MySQL驱动包版本不一致导致。因为当时我的MySQL版本是8.
  • 在Eclipse中新建了一个Maven工程, 然后把项目的jdk版本更改为1.7, 结果每次使用Maven > Update project的时候JDK版本都恢复成1.5。
  • 启动myeclipse后提示一下错误 ...问题是eclipse的编辑jdk版本不对。 解决方法 右键--》(1)properties->java bauild path->libraries-->点击add library..-->选择jre...-->alternate JRE,若没有可用jdk选择instal
  • 解决:IDEA中项目JDK版本问题

    千次阅读 2020-01-09 15:14:39
    1、 2、点击Modules,查看是不是一致: 3、 4、在Settings里找到 java Compiler查看jdk是否一致:
  • com.google.zxing jar与JDK版本问题

    千次阅读 2019-09-29 12:43:13
    最近因项目需要,使用了com.google.zxing进行二维码生成和解码...开发过程遇到了zxing组件无法调用的问题,后将tomcat的jdk调整为1.7后,问题得到解决。即zxing的3.3.0版本至少需要jdk1.7的版本才支持。曾使用过zxin...
  • idea 开发的时候遇到jdk版本问题

    千次阅读 2017-03-27 11:51:44
    java: -source 1.6 中不支持 multi-catch 语句(请使用 -source 7 或更高版本以启用 multi-catch 语句) 但是自己的jdk用的的确是1.7的,找了很久,总算找到解决方法 即找到 file--》project structure ---》...
  • 解决maven项目自动修改jdk版本问题

    千次阅读 2016-09-22 15:03:38
    在使用maven的时候,老是会碰到一个问题–>update project的时候,java compiler的版本就变成了1.5。我们结合官方文档来解决这个问题
  • 快捷方式无法使用,定位到快捷方式所在...,它会要求你选择JDK,如果你在安装oracle之前已经安装JDK的话,那么这时候你可以选择两种路径。一种是E:\app***\product\11.2.0\dbhome_1\jdk\bin下的java.exe,选择...
  • 在开发中遇到类似的问题,即部署到tomcat上跑时抛出java.lang.UnsupportedClassVersionError: Bad version number in .class file,原因是引用的jxl.jar 使用JDK 版本高于我机器上的JDK版本, 具体如下, 不再赘述。...
  • jetty--jetty所需要的jdk版本问题

    千次阅读 2015-12-20 15:09:05
    错误: UnsupportedClassVersionError: org/eclipse/jetty/servlet/listener/ELContextCleaner :...在maven中使用默认version 也就是最好的jetty时候,会报异常,自己的jdk是1.6,换成了1.8之后完美解决 下面是搜到的 j
  • 编译android4.0出现jdk版本问题

    万次阅读 2013-11-12 15:02:49
    编译android4.0,提示错误信息: Checking build tools versions... ...前两天听一个报告,android2.2之前的使用jdk1.5,android2.3之后的使用jdk1.6,并非最新版本就合适,找到真正对应的版本才能正确编译。
  • 先前好几次遇到这样的状况:在学校编写好的项目,回寝室后用自己... JRE不一致也是可以的,至此由于jdk版本问题导致的eclipse项目导入出错问题就解决了。 →传送门: 将web项目导入到eclipse中常见错误
  • 在按着网上教程安装完成oracle之后,悲剧的发现我开始栏的SQL Developer无法打开。定位到快捷方式所在文件夹后,发现此快捷方式链接到的是一个BAT文件。删除这个快捷方式,然后将F:\app\***\product\11.2.0\dbhome_1...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 599,700
精华内容 239,880
关键字:

jdk版本问题