精华内容
下载资源
问答
  • 2020年下半年网络工程师下午真题及答案解析,全网最清晰,答案最正确的软考真题资料,小任老师出品,必属精品!
  • 2019年下半年网络工程师下午真题及答案解析。全网最清晰,答案最正确的真题资料,小任出品,必属精品!
  • 软考网络工程师下午题命令归纳(完全版合集)
  • 2020 年下半年网络工程师下午真题及答案
  • 2019下半年网络工程师下午真题及解析。群文件里面也有很多资料,自行下载就好了,有很多成功上岸的朋友可以一起聊聊,学习下经验,对于考试有什么疑问的,也可以来多问问,不要两耳不闻窗外事,一心只读圣贤书就好,...
  • 网络工程师下午试题解析汇总
  • 2018年下半年(11月份)软考 网络工程师 下午真题及答案解析,全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 2019年上半年(5月)软考网络工程师下午真题及答案解析。全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 2018年上半年网络工程师下午真题及答案解析
  • 2017年下半年(11月份)软考 网络工程师下午真题及答案解析,全网最清晰,答案最正确的真题资料。小任老师出品,必属精品。
  • 2018年下半年网络工程师下午真题及答案解析,真题保证答案正确!
  • 网络工程师下午试题解析汇总。学完它下午的考试肯定能顺利通过。
  • 2019年5月网络工程师下午试题解析.pdf
  • 网络工程师下午试题

    2018-08-30 10:43:16
    历年网络工程师中级职称考试下午试题,本人就是通过这套试题完成的网络工程师中级考试。
  • 2018年下半年网络工程师下午真题及答案解析 真题保证答案正确! 1个积分
  • 软考网络工程师下午题知识点汇总

    千次阅读 多人点赞 2020-09-06 21:55:48
    下午题基础知识整理 华为交换机配置基础 1.vlan的配置 2.vlan与trunk配置案例 3.以太网端口有三种链路类型:Access、Hybrid和Trunk 4.Hybrid端口发送数据的处理 5.交换机管理IP的设置 6.MSTP负载均衡的例子 华为...


    去年已经拿到这个证书了,小小整理一下,都比较基础,软考网络工程师下午题的难度最多就到这种程度(配置方面)。 上午题需要的评论回复邮箱,我发PDF过去,这里就不整理了 (狗头偷懒)

    在这里插入图片描述
    建议多刷题(51CTO小程序,每日打卡),该记记该背背。

    华为交换机配置基础

    1.vlan的配置

    华为设备中划分VLAN的方式有:

    • 静态的划分:基于接口
    • 动态划分:基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、Ip地址)。
      其中基于接口划分VLAN,是最简单,最常见的划分方式。
      基于接口划分VLAN指的是根据交换机的接口来划分VLAN。需要网络管理员预先给交换机的每个接口配置不同的PVID即可。

    2.vlan与trunk配置案例

    <HUAWEI> system-view
    [HUAWEl]sysname SwitchA
    SwitchA]vlan batch23//批量创建VLAN2和VLAN3
    [SwitchA]interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1]port link-type access//设置接口类型为access
    [SwitchA-GigabitEthernet1/0/1]port default vlan 2//将接口GE1/0/1加入VLAN2
    [SwitchA-GigabitEthernet1/0/1]quit
    [SwitchA]interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2]portlink-type access
    [SwitchA-GigabitEthernet1/0/2]port default vlan 3//将接口GE1/0/2加入VLAN3
    [SwitchA-GigabitEthernet1/0/2]quit
    [SwitchA-GigabitEthernet1/0/2]interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3]port link-type trunk//设置接口类型为trunk
    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan2 3//允许该接口上透传VLAN2和VLAN3到上层交换机
    YSwitchA-GigabitEthernet1/0/3]quit
    

    3.以太网端口有三种链路类型:Access、Hybrid和Trunk

    • Acces类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    • Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    • Hybrid类型的端口是华为设备中的一种新的端口类型,其特点是可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,既可以用于交换机之间连接,也可以用于连接用户的计算机。

    注意:
    Hybrid端囗和Trunk端囗是有区别的:
    在接收数据时,Hybrid端口和Trunk端口处理方法是一样的,唯一不同之处在发送数据时,Hybrid端口可以允许多个VLAN的报文发送时不打标签,而runk端口只允许缺省VLAN的报文发送时不打标签。
    缺省VLAN:通常Access端口只属于1个VLAN,所以它的缺省VLAN1,无需设置。而Hybrid端口和Trunk端口可以属于多个VLAN,因此需要设置缺省VLANID。缺省情况下,Hybrid端口和Trunk端囗的缺省VLAN为VLAN1所有华为交换机的默认接口类型为hybrid。

    4.Hybrid端口发送数据的处理

    当端口接收到不带VLANTag的报文后,则将报文转发到属于缺省VLAN的端口(如果设置了端囗的缺省VLANID)。当端口发送带有VLAN Tag的报文时,如果该报文的VLANID与端口缺省的VLANID相同,则系统将去掉报文的VLANTag,然后再发送该报文。

    [Switch-Ethernet0/1]interface Ethernet 0/1   \\进入ethernet 0/1接口
    [Switch-Ethernet0/1]port link-type hybrid  \\设置接口类型为hybrid
    [Switch-Ethernet0/1]port hybrid pvid vlan 10  \\接口的PVID是vlan10
    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged  //对VLAN为10、20的报文,剥掉VLAN Tag
    

    5.交换机管理IP的设置

    华为部分设备有Meth接口,一个专门用于带外管理的接口,不能用于业务数据的传输。如果是二层的接入交换机,需求远程管理这台机器,则需要给这台机器配置个管理IP。通过ssh,telnet等的带内管理,通常默认的管理vlan是vlan1,也可以自己设置为其他Vlan。
    下面以s5700为例,介绍使用用Vlan5作为管理Vlan,管理IP地址为192.168.1.1/24的配置、用户可以通过GigabitEthernet 0/0/1的接口连接到Vlanif5.

    <55700>system-view/进入系统视图
    [S5700-vlan5]quit
    [S5700linterface Vlanif5//进入Vlanif5
    [S5700-Vlanifs]Jip address 192.168.1.124//设置Vlanif5网关192.168.1.1掩码255.255.255.0
    [S5700-Vlanif5]quit/退出
    [S5700]interface GigabitEthernet0/0/1	//进入物理端口GE0/0/1
    [S5700-GigabitEthermet0/0/1]port link-type access	//设置端口access模式
    [S5700-GigabitEthermet0/0/1]port default vlan 5	//将此端口划分到Vlan5
    [S5700-GigabitEthemet0/0/1]quit	//退出
    [S5700]aaa
    //进入aaa
    [S5700-aaa]local-user admin passwordcipher 123456//创建用户admin设置密码为123456密码加密方式为cipher
    [55700-aaa]local-user admin privilege level15//设置admin最高权限等级15
    [S5700-aaa]local-user admin service-type telnet ssh//授权admin用户可以使用telnet、ssh
    [S5700-aaa]quit/退出
    [S5700]user-interfacevty04
    [S5700-ui-vtyO-4Jauthentication-mode aaa
    

    6.MSTP负载均衡的例子

    如左图所示,四台交换机都运行MSTP。它们彼此相连形成了一个有冗余链路的环网。为实现接入层交换机上的VLAN2VLAN10和VLAN11
    VLAN20的分别在不同的STP域中,实现流量负载分担:
    因此需要配置两个MSTl,即MSTI1对应Vlan2-
    Vlan10和MSTl2对应Vlan11-20。他们经过MSTP之后,生成的无环路拓扑如图所示。
    在这里插入图片描述

    (1)交换机的MSTP区域配置
    在交换机A上创建一个相同的MST域(域名为RG1)、两个多生树实例MSTl1和MSTl2,然后为Vlan2-10映射到MSTl1,Vlan11-20映射到MSTI2。最后激活MST域配置。

    [SwitchA]stp region-configuration
    [SwitchA-mst-region]region-name RG1
    [SwitchA-mst-region]instance 1 vlan 2 to 10
    [SwitchA-mst-region]instance 2 vlan 11 to 20
    [SwitchA-mst-region]active region-configuration
    [SwitchA-mst-region]quit
    

    注意:因为这4台交换机都在同一个域(域名相同)才能起作用,因此其他三台设备也进行同样的配置。

    (2)配置MSTI1与MSTI2的根桥与备份根桥

    [SwitchA]stp instance 1 root primary	//配置switchA为MSTI1的根桥
    [SwitchA]stp instance 2 root secondary	//配置SwitchA为MSTI2的备份根桥
    [SwitchB]stp instance 1 root secondary	//配置Switch8为MST11的备份根桥
    [SwitchB]stp instance 2 root primary	//配置SwitchB为MSTI2的根桥
    

    (3)分别配置MSTI1和MSTI2中要被阻塞的端口,消除二层环路

    [Switch A-D]stp pathcost-standard legacy	//配置采用华为的私有端口路径开销计算方法,四台设备同样的标准
    
    [SwitchC]interface gigabitethernet 0/0/2
    [SwitchC-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchC-GigabitEthernet0/0/2]quit
    
    [SwitchD]interface gigabitethernet 0/0/2
    [SwitchD-GigabitEthernet0/0/2]stp instance 2 cost 20000	//设置端口GE0/0/2在实例MSTI2中的路径开销值为20000
    [SwitchD-GigabitEthernet0/0/2]quit
    

    在这里插入图片描述

    (4)在四台交换机上全局使能MSTP,使以上MSTP配置生效,消除二层环路

    [SwitchA]stp enable
    [SwitchB]stp enable
    [SwitchC]stp enable
    [SwitchD]stp enable
    

    (5)将与终端PC相连的端口去使能MSTP

    [SwitchC]interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1]stp disable
    [SwitchC-GigabitEthernet0/0/1]quit
    

    (6)在两个实例对应的根桥设备的指定端口上配置根保护功能

    [SwitchA]interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1]stp root-protection
    [SwitchB]interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1]stp root-protection
    

    (7)最后在各交换机上创建ID号为2~20的共19个VLAN,然后把四台交换机间的直连链路的端口配置为Trunk类型,并允许这19个VLAN通过。把连接PC的链路端口设置为Access类型,加入对应的VLAN

    [SwitchA]vlan batch 2 to 20
    [SwitchA]interface g0/0/1
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    [SwitchA]interface g0/0/2
    [SwitchA-GigabitEthernet0/0/1]port link-type trunk
    [SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 20
    
    
    dis stp brief
    

    华为路由器配置基础

    路由协议或路由种类相应路由的优先级
    DIRECT0
    OSPF10
    IS-IS15
    STATIC60
    RIP100

    DHCP配置

    DHCP的三种角色
    DHCP组网中,包括以下三种角色:
    DHCP客户端:通过DHCP协议请求获取P地址等网络参数的设备。例如,lP电话、PC、手机、无盘工站等。
    DHCP服务器:负责为DHCP客户端分配网络参数的设备。
    DHCP中继(可选):负责转发DHCP服务器和DHCP客户端之间的DHCP报文,协助DHCP服务器向DHCP客户端动态分配网络参数的设备。

    dhcp relay:dhcp select relay,使能接口的DHCP中继功能(缺省情况下未使能)

    在这里插入图片描述
    (1)使能DHCP服务

    <Huawei>system-view
    [Huawei]sysname Router
    [Router]dhcp enable
    

    (2)配置接口加入VLAN

    #配置Eth2/0/0接口加入VLAN10。
    [Router]vlan batch 10 to 11
    [Router]interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 10
    [Router-Ethernet2/0/0] quit
    

    (3)配置VLANIF11接口地址

    [Router]interface vlanif 11
    [Router-Vlanif11]ip address 10.1.2.1 24
    [Router-Vlanif11]quit
    

    (4)配置接口地址池

    配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。
    [Router]interface vlanif 10
    [Router-Vlanif10]dhcp select interface
    [Router-Vlanif10]dhcp server lease day 30
    [Router-Vlanif10]dhcp server domain-name huawei.com
    [Router-Vlanif10]dhcp server dns-list 10.1.1.2
    [Router-Vlanif10]dhcp server excluded-ip-address 10.1.1.2
    [Router-Vlanif10]dhcp server statuc-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
    

    ACL

    分类编号范围支持的过滤选项
    基本ACL2000~2999匹配条件较少,只能通过源lP地址和时间段来进行流量匹配,在一些只需要进行简单匹配的功能可以使用。
    高级ACL3000~3999匹配条件较为全面,通过源P地址、目的IP地址、To5、时间段、协议类型、优先级、ICMP报文类型和ICMP报文码等多个维度来对进行流量匹配,在大部分功能中都可使用高级ACL来进行精确流量匹配。
    基于MAC地址的ACL4000~4999由于数据链路层使用MAC地址来进行寻址,所以在控制数据链路层帧时需要通过MAC地址来对流量进行分类。基于MAC地址的ACL就可以通过源MAC地址、目的MAC地址、co5、协议码等维度来进行流量匹配。

    ACL规则

    acl number 2004
    rule 0 deny 202.38.0.0 0.0.255.255
    rule 10 permit 202.38.160.0 0.0.0.255
    
    
    配置好的ACL,应用到相应的接口才会生效。
    interface GigabitEthernet 0/0/1
    traffic-filter inbound acl 2004  //在接口上应用ACL,进行报文过滤,某些类型的设备可以使用packet-filter 3000
    
    ACL应用规则
    1.标准访问控制列表,靠近目标网络
    2.高级访问控制列表,靠近源网络
    

    两条规则结合则表示禁止一个大网段(202.38.0.0)上的主机但允许其中的一小部分主机(202.38.160.0)的访问。

    具体:
    acl number 3001
    rule deny source 192.168.2.0 0.0.0.255 destination 192.168.3.0 0.0.0.255

    在这里插入图片描述
    对内网地址192.168.1.12/24访问外网做限制,使其无法访问所有WEB界面

    acl number 3005		//定义用于报文过滤的访问控制
    description deny_source_ip_www
    rule 5 deny tcp source 192.168.1.12 0 destination-port eq www
    rule 10 permit tcp source 192.168.1.12 0
    
    interface g0/0/1
    ip address 192.168.1.2 255.255.255.0
    traffic-filter inbound acl 3005
    

    交换机进行ACL配置应用的例子
    1、先定义ACL

    [Switch]acl 3001   //新建一个高级ACL
    [Switch-acl-adv-3001]rule 5 deny ip source 192.168.5.0 0.0.0.255 destination 192.168.2.0 0.0.0.255   //禁止5网段访问2网段
    [Switch-acl-adv-3001]rule 100 permit ip		//允许访问任何网段
    

    2、配置基于ACL的流分类

    [Switch]traffic classifer tc1	//创建流分类
    [Switch-classifier-tc1]if-match acl 3001	//将ACL与流分类关联
    

    3、配置流行为

    [Switch]traffic behavior tb1	//创建流行为
    [Switch-behavior-tb1]deny	//配置流行为动作为拒绝报文通过
    

    4、配置流策略

    [Switch]traffic policy tp1	//创建流策略
    [Switch-trafficpolicy-tp1]classifier tc1 behavior tb1	//将流分类tc1与流行为tb1关联
    

    5、在接口下应用流策略

    [Switch]interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1]traffic-policy tp1 inbound	//流策略应用在接口入方向
    

    华为防火墙配置

    防火墙

    路由器的安全规则定义再接口上,而防火墙的安全规则定义在安全区域之间
    Local
    Trust
    DMZ
    Untrust

    域间的数据流分两个方向:
    入方向(inbound):数据由低级别的安全区域向高级别的安全区域传输的方向;
    出方向(outbound):数据由高级别的安全区域向低级别的安全区域传输的方向。

    防火墙的安全区域规则:

    • 本域内不同接口间不过滤直接转发
    • 进、出接口相同的报文被丢弃
    • 接口没有加入域之前不能转发包文

    在这里插入图片描述

    配置区域dmz
    [Eudemon]firewall zone name dmz1
    [Eudemon-zone-dmz1]set priority 70
    
    把接口加入到区域中
    把相应的接口加入到相应的区域中去
    配置接口Ethernet 1/0/0加入到防火墙DMZ域
    [Eudemon]firewall zone dmz
    [Eudemon-zone-dmz]add interface ethernet 1/0/0
    

    IP包过滤技术介绍
    对防火墙需要转发的数据包,先获取包头信息,然后和设定的规则进行比较,根据比较的结果对数据包进行转发或者丢弃。而实现包过滤的核心技术是访问控制列表
    五元组:源地址、目的地址、源端口、目的端口、协议号

    在区域间应用访问控制列表
    例子:创建编号为3001的访问控制列表。

    [华为]acl number 3001
    #配置ACL规则,允许特定用户从外部网访问内部服务器。
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.30 destination129.38.1.10
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.20
    [华为-acl-adv-3001]rule permit tcp source 202.39.2.3 0 destination 129.38.1.30
    下面的配置是在包过滤应用中引用ACL
    policy interzone trust untrust outbound 
    #将ACL规则3000作用于Trust区域到untrust区域间的出方向。
    [华为-Interzone-trust-untrust]packet-filter 3000 outbound
    #将ACL规则3001作用于Trust区域到Untrust区域间的入方向。
    [华为-Interzone-trust-untrust]packet-filter 3001 inbound
    #在Trust区域和Untrust区域之间使能FTP协议的应用协议检测。
    [华为-Interzone-trust-untrust]detec tftp
    

    Nat Server配置

    Nat Server 里面有 NAT Server配置案例
    内部服务器(Nat Server)功能是使用一个公网地址来代表内部服务器对外地址。在防火墙上,专门为内部的服务器配置一个对外的公网地址来代表私网地址。对于外网用户来说,防火墙上配置的外网地址就是服务器的地址。

    使用NAT可以灵活地添加内部服务器,通过配置内部服务器,可将相应的外部地址、端口等映射到内部的服务器上,提供了外部网络可访问内部服务器的功能。

    配置内部Web和FTP服务器。

    [USG] nat server wwwserver protocol tcp global 202.169.10.1 80 inside 192.168.20.2 8080
    [USG] nat server ftpserver protocol tcp global 202.169.10.1 ftp inside 192.168.20.3 ftp
    

    Easy IP配置

    Easy IP的概念很简单,当进行地址转换时,直接使用接口的公有IP地址作为转换后的源地址。同时它也利用访问控制列表控制哪些内部地址可以地址转换

    应用级网关ALG

    在这里插入图片描述
    NAT ALG实现原理
    配置:
    在系统视图下执行下列命令则使能了相应协议的ALG功能
    nat alg enable {ftp|h323|icmp|ras|qq|msn}

    在域间视图下为应用层协议配置ASPF检测
    firewall interzone trust untrust
    detect ftp 开启ASPF 和 NAT ALG。 这两个的命令是共用的

    双机热备

    防火墙入侵与检测 day04 防火墙双机热备

    在这里插入图片描述
    VGMP组管理

    • 状态一致性管理
      VGMP管理组控制所有的VRRP备份组统一切换。
    • 抢占管理
      当原来出现故障的主设备故障恢复时,其优先级也会恢复,此时可以重新将自己的状态抢占为主。

    HRP基本概念

    • HRP(Huawei Redundancy Protocol)协议,用来将主防火墙关键配置和连接状态等数据向备防火墙上同步。
    • 首包会话快速备份
    • 更新报文会话快速备份

    防火墙双机热备三大协议

    • VRRP 是 主备
    • VGMP 是 状态切换一致性
    • HRP 是 配置会话表的同步

     

    交换机三种端口

    交换机三种端口类型特点:
    以太网端口有三种链路类型:Access、Hybrid和Trunk。
    ■ Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    ■ Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
    ■ Hybrid 端口和Trunk 端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    交换机接口出入数据处理过程:
    ■ Access端口收报文:收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)
    ■ Access端口发报文:将报文的VLAN信息剥离,直接发送出去
    ■ trunk端口收报文:收到一个报文,判断是否有VLAN信息:如果有,判断该trunk端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃;如果没有VLAN信息则打上端口的PVID,并进行交换转发。
    ■ trunk端口发报文:比较将要发送报文的VLAN信息和端口的PVID,如果不相等则直接发送。如果两者相等则剥离VLAN信息,再发送。
    ■ hybrid 端口收报文:收到一个报文,判断是否有VLAN信息:如果有,则判断该hybrid 端口是否允许该VLAN的数据进入(在untagged和tagged列表中的都算允许通过,这个就相当于trunk的allow-pass vlan),如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用);如果没有则打上端口的PVID,并进行交换转发。
    ■ hybrid 端口发报文:1)、判断该VLAN在本端口的属性(disp interface即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)2)、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送.

    [Switch1]vlan 5 //创建 VLAN5 
    [Switch1-vlan5]management-vlan //设备 VLAN5 为管理 VLAN 
    [Switch1-vlan5]quit 
    [Switch1]interface vlanif 5 //创建管理 VLAN 的 VLANIF 接口 
    [Switch1-Vlanif5]ip add 10.10.1.1 24 //配置 VLANIF 接口 IP 地址 
    [Switch1-Vlanif5]quit 
    
    
    [Switch1]telnet server enable //Telnet 默认是关闭的,需要打开 
    [Switch1]user-interface vty 0 4 //开启 VTY 线路模式 
    [Switch1-ui-vty0-4]protocol inbound telnet //配置 Telnet 协议 
    [Switch1-ui-vty0-4]authentication-mode aaa //配置认证方式 
    [Switch1-ui-vty0-4]quit
    
    [Switch1]int g0/0/10
    [Switch1-GigabitEthernet0/0/10]port link-type trunk  //配置上联接口类型(trunk)
    [Switch1-GigabitEthernet0/0/10]port trunk allow-pass vlan all  //允许所有 VLAN 通过
    
    [SW2]interface Ethernet 0/0/2 
    [SW2-Ethernet0/0/2]port link-type access //配置接口类型为 access
    [SW2-Ethernet0/0/2]port default vlan 10 //将接口加入 VLAN10
    [SW2-Ethernet0/0/2]quit
    
    [Huawei-GigabitEthernet0/0/1]port link-type hybrid //配置接口类型为 hybrid 
    [Huawei-GigabitEthernet0/0/1]port hybrid pvid vlan 10 //配置接口的 PVID 
    [Huawei-GigabitEthernet0/0/1]port hybrid untagged vlan 10 30 //配置接口的 untgged vlan
    

    端口
    1.配置POP3服务器时,邮件服务器中默认开放TCP的 (D) 端口。
    A、21
    B、25
    C、53
    D、110
    2.电子邮件应用程序利用POP3协议( D )。
    A. 创建邮件 B. 加密邮件 C. 发送邮件 D. 接收邮件

    FTP服务器使用20和21两个网络端口与FTP客户端进行通信。主动模式下,FTP服务器的21端口用于传输FTP的控制命令,20端口用于传输文件数据

    HTTP:80 Telnet:23
    SNMP消息全部通过UDP端口161接收,只有Trap信息采用UDP端口162。 SNMP用的是无连接的UDP协议
    IMAP4端口 143


    Linux:
    inetd.conf 是 系统超级服务进程inetd的配置文件
    lilo.conf 是 操作系统启动程序LILO的配置文件
    httpd.conf 是 web服务器Apache的配置文件
    resolv.conf是 DNS解析的配置文件

    在Linux操作系统中,与DHCP相关的主要配置文件如下:
    DHCP服务器配置文件 /etc/dhcpd.conf(DHCP服务的主配置文件)
    启动DHCP服务的脚本 /etc/rc.d/ink.d/dhcpd
    执行DHCP服务的程序 /usr/sbin/dhcpd
    记录客户端租用信息的文件 /var/state/dhcpd.leases(保存客户端租约信息的文件)
    重启DNS服务器:service named restart

    对称加密算法:DES、3DES、RC5、IDEA 适用于大量数据加密
    公开密匙(非对称)加密算法:RSA、DSA、ECC 加密速度慢,计算量大,不适合会话通信

    1、OSPF默认的Hello报文发送间隔时间是 4秒,
    Hello用于发现邻居,保证邻居之间keepalive,keepalive,是在TCP中一个可以检测死连接的机制。
    来建立和维护相邻邻居路由器之间的链接关系
    默认的Hello报文的发送间隔是10秒,默认无效时间间隔是Hello时间间隔的 4倍,即如果在40秒内没有从特定的邻居接收到这种分组,路由器就认为那个邻居不存在了。
    Hello组播地址为224.0.0.5
    2、在进行域名解析过程中,当主域名服务器查找不到IP地址时,由(转发域名服务器)负责域名解析
    3、路由器的描述中,路由器的串口之间通常是 点对点连接
    4、OSPF协议把网络划分成 4种区域,其中(存根区域)不接受本地自治系统以外的路由信息,对自治系统以外的目标采用默认路由0.0.0.0
    5、帧中继: 本地管理接口类型:提供面向连接的服务,高效的数据链路技术,充分复用了光纤通信和数字网络技术的优势。
    6、运行OSPF协议的路由器在选举 DR/BDR之前,DR是路由器自身,备份指定路由器(BDR)
    7、内部网关协议(IGP):在同一个自治系统内交换路由信息。IGP的主要目的是发现和计算自治域内的路由信息
    IGP使用的路由协议有:RIP、OSPF、IS-IS

    在这里插入图片描述

    展开全文
  • 某单位由于业务要求,在六层的大楼内同时部署有线和无线网络,楼外停车场部署无线网络网络拓扑如图1-1所示。 问题1(8分) 1.该网络规划中,相较于以旁路方式部署,将AC直连部署存在的问题是( 1 )。相较于部署...

    试题一(20分)

    某单位由于业务要求,在六层的大楼内同时部署有线和无线网络,楼外停车场部署无线网络。网络拓扑如图1-1所示。

     

    问题1(8分)

    1.该网络规划中,相较于以旁路方式部署,将AC直连部署存在的问题是( 1 )。相较于部署在核心层,将AC部署在接入层存在的问题是( 2 )。

    2.在不增加网络设备的情况下,防止外网用户对本网络进行攻击,隐藏内部网NAT策略通常配置在( 3 ) 。

    (3)备选答案:

    A.AC    B.Switch   C.Router

    3.某用户通过手机连接该网络的WIFI信号,使用WEB页面进行认证后上网,无线网络使用的认证方式是( 4 )认证。

    (4)备选答案:

    A. PPPoE    B. Portal    C. IEEE 802.1x

    问题2(8分)

    1.若停车场需要部署3个相邻的AP,在进行2.4GHz频段规划时,为避免频道相互干扰,可以采用的信道是( 5 )。

    (5)备选答案:

    A.1、4、7    B.1、6、9    C.1、6、11

    2.若在大楼内相邻的办公室共用1台AP会造成信号衰减,造成信号衰减的是( 6 )

    (6)备选答案

    A.调制方案     B.传输距离    C.设备老化    D.障碍物

    3.在网络规划中,对AP供电方式可以采取( 7 )供电或DC电源适配器供电。

    4.不考虑其他因素的情况下,若室内AP区域信号场强>-60dBm,停车场AP区域的场强>-70dBm,则用户在( 8 )区域的上网体验好。

    问题3(4分)

    在结构化布线系统中,核心交换机到楼层交换机的布线通常称为( 9 ) ,拟采用50/125微米多模光纤进行互连,使用1000Base-SE以太网标准,传输的最大距离约是( 10 )米。

    (9)备选答案:

    A.设备间子系统   B.管理子系统   C.干线子系统

    (10)备选答案:

    A. 100    B.550    C.5000

    试题二(20分)

    某企业内部局域网拓扑如图2-1所示,局域网内分为办公区和服务器区。

    图2-1中,办公区域的业务网段为10.1.1.0/24,服务器区网段为10.2.1.0,业务网段、服务网段的网关均在防火墙上,网关分别对应为10.1.1.254、10.2.1.254;防火墙设置DHCP服务器,为办公区终端自动下发IP地址,并通过NAT实现用户访问互联网。防火墙外网出口IP地址为100.1.1.2/28,办公区用户IP池为100.1.1.10-100.1.1.15。

    问题1(6分)

    防火墙常用工作模式有透明模式、路由模式、混合模式,图2-1中的出口防火墙工作于( 1 )模式;防火墙为办公区用户动态分配IP地址,需在防火墙完成开启( 2 )。

    功能:Server2为WEB服务器,服务端口为TCP 443,外网用户通过https://100.1.1.9:8443访问,在防火墙上需要配置( 3 )。

    (3)备选答案:

    A.nat server policy _web protocol tcp global 100.1.1.9 8443 inside 10.2.1.2 443 unr-route

    B.nat server policy _web protocol tcp global 10.2.1.2 8443 inside 100.1.1.9 443 unr-route

    C.nat server policy _web protocol tcp global 100.1.1.9 443 inside 10.2.1.2 8443 unr-route

    D.nat server policy _web protocol tcp global 10.2.1.2 inside 10.2.1.2 8443 unr-route

    问题2(14分)

    为了使局城网中10.1.1.0/24网段的用户可以正常访问Internet,需要在防火墙上完成NAT、安全策略等配置,请根据需求完善以下配置。

    #将对应接口加入trust或者untrust区域。

    [FW] firewall zone trust

    [FW-zone-trust] add interface( 4 )

    [FW-zone-trust] quit

    [FW] firewall zone untrust

    [FW-zone-untrust] add interface ( 5 )

    [FW-zone-untrust]quit

    #配置安全策略,允许局域网指定网段与Internet进行报文交互。

    [FW] security-policy

    [FW-policy security]rule name policy1

    #将局域网作为源信任区域,将互联网作为非信任区域

    [FW-policy-security-rule-policy1]souree-zone( 6 )

    [FW-policy-seeurity-rule-policy1]destination-zone untrust

    #指定局域网办公区域的用户访同互联网

    [FW-policy-security-rule-policy1]source-address( 7 )

    #指定安全策略为允许

    [FW-policy-security-rule-policy1] action( 8 )

    [FW-policy-security-rule-policy1] quit

    [FW-policy-seeurity] quit

    置NAT地址池,配置时开启允许端口地址转换,实现公网地址复用。

    [FW] nat address-group address group1

    [FW-address-group-addressgroup1] mode pat

    [FW-address-group-addressgroup1]section 0 ( 9 )

    配置源NAT策略,实现局城网指定网段访问Internet时自动进行源地址转换。

    [FW] nat policy

    [FW-policy nat]rule name policy_nat 1

    #指定具体哪线区域为信任和非信任区域

    [FW-policy-nat-rule policy_nat 1] source-zone trust

    [PW-policy-nat-rule policy_nat 1] destination zone untrust

    #指定局域网源IP地址

    [FW-policy-nat-rule policy_nat 1] source-address 10.1.1.0 24

    [FW-policy-nat-rule-policy_nat 1]action source-nat address-group ( 10 )

    [FW-policy-nat-rule-policy_nat 1]quit

    [PW-policy-nat] quit

    试题三(20分)

    某公司网络拓扑如图3-1所示,其中出口路由器R2连接Internet,PC所在网段为10.1.1.0/24,服务IP地址为10.2.2.22/24,R2连接的Internet出口网关地址为110.125.0.1/28。各路由端口及所对应的IP地址信息如表3-1所示。假设各个路由器和主机均完成了各个接口IP地址的配置。

    问题1(6分)

    通过静态路由配置使路由器R1经过路由器R2作为主链路连接Internet;R1->R3-> R2->Internet作为备份链路;路由器R3经过路由器R2作为主链路连接Internet;R3->R1->R2->Internet作为备份链路。

    请按要求补全命令或回答问题。

    R1上的配置片段

    [R1]ip route-static 0.0.0.0 0.0.0.0 ( 1 )

    [R1]ip route-static 0.0.0.0 0.0.0.0 ( 2 ) preference 100

    R2上的配置片段:

    [R2]ip route-static ( 3 ) 110.125.0.1

    以下两条命令的作用是( 4 )

    [R2]ip route-static 10.2.2.0 0.255.255.255 10.12.0.1

    [R2]ip route-static 10.2.2.0 0.255.255.255 10.23.0.3 preference 100

    问题2(3分)

    通过在R1、R2和R3上配置双向转发检测(Bidirectional Forwarding Detelet) 实现链路故障快速检测和静态路由的自动切换。

    以R3为例配置R3和R2之间的BFD会话,请补全下列命令

    [R3]( 5 )

    [R3-bfd] quit

    [R3]bfd 1 bind peer-ip( 6 )source-ip ( 7 ) auto

    [R3-bfd-session-1]commit

    [R3-bfd-session-1]quit

    问题3(6分)

    通过配置虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)通过交换机S1双归属到R1和R3,从而保证链路发生故障时服务面的业务不中断,R1为主路由,R3为备份路由,且虚拟浮动IP地址为10.2.2.10。

    根据上述配置要求,服务器的网关地址应配置为( 8 )。

    在R1上配置与R3的VRRP虚拟组相互备份:

    [R1]int g0/0/1

    //创建VRRP虚拟组

    [R1-GigabitEthernet0/0/1]vrrp vrid 1 virtual-ip ( 9 )

    //配置优先级为120

    [R1-GigabitEthernet0/0/1]vvrp vrid1 priority 120

    下面这条命令的作用是 ( 10 )

    [R1-GigabitEthernet0/0/1]vrrp vrid 1 preempt-mode timer delay2

    //跟踪GE0/0/0端口,如果GE0/0/0端口down,优先级自动减30

    [R1-GigabitEthernet0/0/1]vrrp vrid 1 track interface GE0/0/0 seduced 30

    请问R1为什么要跟踪GE0/0/0端口?

    答:( 11 )

    问题4(5分)

    通过配置ACL限制PC所在网段在2021年11月6日上午9点至下午5点之间不能访问服务器的Web服务(工作在80端口),对园区内其它网段无访问限制。

    定义满足上述要求ACL的命令片段如下,请补全命令。

    [XXX]( 12 ) ftime 9:00 to 17:00 2021/11/6

    [XXX]acl 3001

    [XXX-acl-adv-3001]rule ( 13 ) tcp destination-port eq 80 source destination

    10.2.2.22 0.0.0.0 time-range( 14 )

    上述ACL最佳配置设备是 ( 15 )。

    试题四(15分)

    某公司办公网络拓扑结构如图4-1所示,其中,在交换机Switch上启用DHCP为客户端分配IP地址。公司内部网络采用基于子网的VLAN划分。

    问题1(5分)

    由于公司业务特点需要,大部分工作人员无固定工位。故公司内部网络采用基于子网划分VLAN并采用DHCP策略VLAN功能为客户端分配IP地址。请根据以上描述,填写下面的空白。

    DHCP策略VLAN功能可实现新加入网络主机和DHCP服务器之间DHCP报文的互通,使新加入网络主机通过DHCP服务器获得合法IP地址及网络配置等参数。

    在基于子网划分VLAN的网络中,如果设备收到的是Untagged帧,设备将根据报文中的( 1 ),确定用户主机添加的VLAN ID。新加入网络的主机在申请到合法的IP地址前采用源IP地址( 2 )进行临时通信,此时,该主机无法加入任何VLAN,设备会为该报文打上接口的缺省VLAN ID( 3 )。由于接口的缺省VLAN ID与DHCP服务器所在VLAN ID不同,因此主机不会收到IP地址及网络配置等参数配置信息。DHCP策略VLAN功能可使设备修改收到的DHCP报文的( 4 )VLANTag,将VLAN ID设置为( 5 )所在VLAN ID,从而实现新加入网络主机与DHCP服务器之间DHCP报文的互通,获得合法的IP地址及网络配置参数。该主机发送的报文可以通过基于子网划分VLAN的方式加入对应的VLAN。

    (1)~(5)备选答案:

    A.255.255.255.255    B.内层     C.外层     D.源IP地址    E.DHCP服务器

    F.1    G.0.0.0.0      H.源MAC地址    I. 1023

    问题2(10分)

    根据业务要求,在部门A中,新加入的MAC地址为0081-01FA-2134,主机HOST A需要加入VLAN10并获取相应IP地址配置,连接在交换机SwitchB的GE0/0/3接口上的主机需加入VLAN20并获取相应IP地址配置,部门B中的所有主机应加入VLAN30并获取相应IP地址配置。

    请根据以上要求,将下面配置代码的空白部分补充完整。

    1.在SwichA上配置VLAN30的接口地址池功能

    #在SwitchA上创建VLAN,并配置VLANIF接口的IP地址。

    system-view

    [HUAWEI] sysname SwitchA

    [SwitchA]( 6 ) enable

    [SwitchA]vlan batch 10 20 30

    [SwitchA]interface vlanif 30

    [SwitchA-Vlanif30]ip address ( 7 ) 24

    [SwitchA-Vlanif30]quit

    [SwitchA]interface vlanif 30

    [SwitchA-Vlanif30]dhcp select ( 8 )  //使能VLANIF接口地址池

    [SwitchA-Vlanif30]quit

    [SwitchA]interface gigabitethernet 0/0/2   //配置接口加入相应VLAN

    [SwitehA-GigabitEthernet0/0/2]port link-type ( 9 )

    [SwitehA-GigabitEthernet0/0/2]port trunk allow-pass vlan 30

    [SwitchA-GigabitEthernet0/0/2]quit

    //VLAN10和VLAN20的配置略

    2.在SwitchC上与主机HostC和HostD相连的接口GE0/0/2配置基于子网划分VLAN功能,并配置接口为Hybrid Untagged类型。

    system-view

    [HUAWEI] sysname SwitchC

    [SwitchC]dhcp enable

    [SwitchC]vlan batch 30

    [SwitchC]interface ( 10 )

    [SwitchC-GigabitEthernet0/0/1]port link-type trunk

    [SwitchC-GigabitEthernet0/0/1]port trunk allow-pass vlan30

    [SwitchC-GigabitEthernet0/0/1]quit

    [SwitchC]interface gigabitethernet 0/0/2

    [SwitchC-GigabitEthernet0/0/2] ( 11 ) enable

    [SwitchC-GigabitEthernet0/0/2]quit ( 12 ) untagged vlan30

    [SwitchC-GigabitEthernet0/0/2]

    //SwitchB基于子网划分VLAN配置略

    3.在SwitchB上分别配置基于MAC地址和基于的DHCP策略VLAN功能

    [SwitchB]vlan 10

    [SwitchB vlan 10]iF-subnet-vlaniF 10.10.10.1 24

    [SwitchB vlan 10]dhcp policy-vlan ( 13 )

    [SwitchB vlan 10]quit

    [SwitchB]vlan 20

    [SwitchB vlan 20]iF-subnet-vlan iF 10.10.20.1 24

    [SwitchB vlan 20]dhcp policy-vlan ( 14 ) gigabitethernet0/0/3

    [SwitchB vlan 20]quit

    4.在SwitchC上配置普通的DHCP策略VLAN功能

    [SwitchC]vlan 30

    [SwitchB vlan 30]iF-subnet-vlan iF 10.10.30.1 24

    [SwitchB vlan 30]dhcp policy-vlan ( 15 )

    [SwitchB vlan 30]quit

    (6)~(15)备选答案:

    A.port     B.dhcp     C.interface     D.mac-address   E.ip-subnet-vlan

    F.generic   G.10.10.30.1    H.hybird   I.trunk     J.gigabitethernet0/0/1

    2021年下半年网络工程师下午真题答案及解析

    试题一(20分) 单击此链接查看真题解析视频https://ke.qq.com/course/261351

    问题1(8分)

    (1)对AC的吞吐量和数据处理能力要求比较高,AC容易成为整个无线网络带宽的瓶颈。

    (2)导致吞吐量下降

    (3) C

    (4) B

    问题2(8分)

    (5) C    (6) D    (7) POE     (8)室内

    问题3(4分)

    (9)C     (10) В

    试题二(20分)

    问题1(6分)

    (1)路由模式    (2)DHCP服务    (3)A

    问题2(14分)

    (4)GE0/0/1   (5)GE0/0/3    (6)trust   (7)10.1.1.0 24    (8)permit  

    (9)100.1.1.10 100.1.1.15     (10)address group 1

    试题三(20分)

    问题1(6分)

    (1)10.12.0.2     (2)10.13.1.3     (3)0.0.0.0 0.0.0.0

    (4)配置去往服务器网段的浮动静态路由,经R1路由器转发为主链路优先选择,经R3路由器转发为备份链路。当主链接故障时使用。

    问题2(3分)

    (5)BFD   (6)10.23.0.1  (7)10.23.0.3

    问题3(6分)

    (8) 10.2.2.10   (9)10.2.2.10     (10)配置VRRP为抢占模式,延时2秒抢占

    (11)当上联接口失效时,R3路由器能及时抢占主设备,为服务器实现数据转发,保证业务不中断。

    问题4(5分)

    (12)time-range  (13)deny   (14)ftime     (15)路由器R2的GE2/0/0接口的入方向

    试题四(15分)

    问题1(5分)

    (1)D  (2)G  (3)F   (4)C   (5)E

    问题2(10分)

    (6)B   (7)G   (8)C   (9)I   (10)J   (11)E   (12)H   (13)D

    更多网络工程师真题文档资料下载

    2021年下半年网络工程师上午真题及答案解析.pdf-软考等考文档类资源-CSDN下载

    2021年下半年网络工程师下午真题及答案解析.pdf-软考等考文档类资源-CSDN下载

    展开全文
  • 2017年下半年网络工程师下午试题及参考答,网络工程师参考者必看!
  • 后续把答案发上来 2018年下半年网络工程师考试下午真题
  • 2020年下半年网络工程师下午真题及答案

    万次阅读 多人点赞 2020-11-10 16:38:43
    试题一(20分) 某校园宿舍WLAN网络...2020年下半年网络工程师下午答案及解析 试题一(20分) 单击此链接查看真题解析视频https://ke.qq.com/course/261351?tuin=7d818187 问题1(10分) 一、小任老师网...

    试题一(20分)

        某校园宿舍WLAN网络拓扑结构如图1-1所示,数据规划如表1-1内容所示。该网络采用敏捷分布式组网在每个宿舍部署一个APAP连接到中心AP,所有AP和中心AP统一由AC进行集中管理,为每个宿舍提供高质量的WLAN网络覆盖。

     

    2020年下半年网络工程师下午答案及解析

    试题一(20分)   单击此链接查看真题解析视频https://ke.qq.com/course/261351?tuin=7d818187

    问题1(10分)

     

    一、小任老师网络工程师视频教程

    1、网络工程师_基础知识视频 https://edu.51cto.com/course/1187.html

    2、上午历年真题解析视频https://edu.51cto.com/course/4925.html

    3、下午历年真题解析视频 https://edu.51cto.com/course/2017.html

    二、小任老师高级网络规划设计师视频教程

    1、网络规划设计师-综合知识视频精讲 http://edu.51cto.com/course/course_id-1219.html

    2、上午历年真题解析视频http://edu.51cto.com/course/course_id-6081.html

    3、下午案例分析历年真题解析视频 http://edu.51cto.com/course/course_id-1545.html

    4、论文写作技巧精讲视频 http://edu.51cto.com/course/course_id-1792.html

    展开全文
  • 网络工程师,2020年,下午试题,答案
  • 1、第一时间发布2016年下半年软考网络工程师真题...2、为未来参加网络工程师考试的学员展现网络工程师最新的考题形式,考察要点,助其有重点的复习软考网络工程师这门考试。CSDN徐朋老师 多年计算机软考培训、辅导经验
  • 2019年上半年网络工程师下午真题及答案,需要参加软考的同学可以来看看,下载后能给大家带来帮助就行。
  • 2018下半年网络工程师下午真题 应用技术,
  • 2019年上半年网络工程师上午、下午真题及答案解析
  • 2019下半年网络工程师真题(包括上午和下午题目及解析),需要参加软考的同学可以来看看,能给大家带来帮助就行。
  • 2018年下半年网络工程师上午-下午真题及答案解析

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,671
精华内容 2,268
关键字:

网络工程师下午题