精华内容
下载资源
问答
  • 浮动静态路由及负载均衡

    千次阅读 2019-05-16 21:53:56
    浮动静态路由:一种特殊的静态路由,通过配置去往相同的目的网段,但是优先级不同的静态路由,为了保证在网络中优先级较高的路由,即主路由失效的情况下,提供备份路由。正常情况下,备份路由时不会出现在路由表中的...

    一。原理简述

    浮动静态路由:一种特殊的静态路由,通过配置去往相同的目的网段,但是优先级不同的静态路由,为了保证在网络中优先级较高的路由,即主路由失效的情况下,提供备份路由。正常情况下,备份路由时不会出现在路由表中的。

    负载均衡:当数据有多条可选路径前往同一目的网络,可以通过配置相同优先级开销的静态路由来实现负载均衡,使得数据的传输均衡的分配到多条路径上,从而可以实现数据分流、减少单条路径负载过重的情况。然而当其中某一条路径失效时,其他的路径仍然是可以正常的传输数据的,同时也起到了冗余的作用。

    二。实验目的

    (1)理解浮动静态路由的应用场景;

    (2)掌握浮动静态路由的配置方法;

    (3)掌握浮动静态路由的测试方法;

    (4)掌握静态路由负载均衡的配置方法;

    (5)掌握静态路由负载均衡的测试方法;

    三。实验内容

    本实验通过浮动静态路由来实现总部与各个分部、分布与分部之间的正常通信,而且分部之间再通信时,之间的直连链路为主用链路,通过总部的链路为备用链路。

    四。实验拓扑

    五。实验操作

    1.基本配置

    根据该实验的要求进行相应的基础配置,使用ping命令检测各直连链路的连通性。

    2.两分部间、总部与两分部间的通信的实现

    若要实现部门与部门之间的正常通信,使用配置静态路由方法来实现。在R1上配置目的网段为主机PC-2所在网段的静态路由,同理,在R3上配置目的网段为主机PC-1所在网段的静态路由,同时在R2上配置到达两台主机的目的网段的静态路由。

    [R1]ip route-static 192.168.20.0 24 10.0.13.3
    
    [R2]ip route-static 192.168.10.0 24 10.0.12.1 
    [R2]ip route-static 192.168.20.0 24 10.0.23.3 
    
    [R3-GigabitEthernet0/0/0]ip ad 192.168.20.1 24

    配置完成后,可以查看一下R1的路由表,你会发现表中存在以主机PC-2所在网段为目的网段的路由条目,其下一跳是路由器R3。

    尝试去测试主机PC-1与主机PC-2之间的连通性,会发现其可以正常通信。

    现在可以使用tracert命令,在主机PC-1上测试所经过的网关。

    通过观察发现数据包是经过R1和R3到达主机PC-2的。

    同理可以查看路由器R3的路由表,观察它的路由条目,同时测试其与主机PC-1之间的连通性,和其所经过的网关。

    在总部路由器R2上测试其与分部之间的连通性。

    通过上述的配置和测试,可以实现总部路由器R2正常访问两个分部主机PC-1和主机PC-2的网络。

    3.配置浮动静态路由来实现路由备份

    现在需要实现的是当两部分间通信时,直连链路为主用链路,通过总部的链路为备用链路,就是指当主用链路发生故障时,可以使用备用链路保障两部分网络间的正常通信,同时这里的浮动静态路由还实现了网络冗余。

    我们现在可以在R1上配置静态路由,目的网段是主机PC-2所在的网段,掩码为24位,下一跳是R2,同时将优先级设置为100(默认为60)。配置过后,查看其路由表。

    因为备份路由条目是不显示在路由表中的,可以使用display ip routing-table protocol static 命令仅查看静态路由的路由信息。

    从上面的静态路由的路由信息中可以看出:目的地址为PC-2所在网段的两条优先级为100和60的静态路由条目都已存在。

    同样的操作,在R3上做同样的配置。

    过程分析:现在R1上去往相同的目的网段存在两条不同的路由条目,首先会比较它们的优先级。优先级高的,即对应的优先级数值较小的路由条目将被选为主用路由。通过比较,另一条路由状态则为Inactive,作为备份路由,不会被加入到路由表中。只有当Active的路由条目失效时,备份链路(优先级为100的路由条目)才会被加入到路由表中。

    当与配置的静态路由下一跳地址相关的接口处于down状态后该静态路由表项会被标记为Inactive状态并从当前的路由表中移除。

    接下来,将路由器R1上的S1/0/1接口关闭,使用shutdown命令,模拟发生故障,验证使用备用链路。

    可以观察到此时优先级为100的路由条目已经添加到路由表中。 

    同时再使用display ip routing-table protocol static 命令仅查看静态路由的路由信息,可以观察到此时的优先级为100的静态路由条目的状态为Active,优先级为60的状态为Inactive。

    测试主机PC-1与主机PC-2之间的连通性,同时查看此时PC-1与PC-2之间通信时所经过的网关。

    此时的通信经过了备用链路到达的PC-2。

    默认情况下,静态路由只能感知到直连接口的状态,可通过静态路由与NQA、BFD等检测特性联动的方式来增强静态路由的智能度。

    4.通过负载均衡实现网络优化

    即同时使用主备两条链路来支撑两分部之间的通信。

    现在恢复R1上的S1/0/1接口的正常状态,并配置目的网段为主机PC-2所在网段,掩码为24位,下一跳为R2,优先级不变的静态路由。配置过后,查看R1上的路由表。

    可以看出现在去往192.168.20.0网段拥有两条下一跳不同的路由条目,即实现了负载均衡。

    测试主机PC-1与主机PC-2之间的通信。

    同时在R3上作出与R1上相同的配置内容。

    通过配置针对相同目的地址但优先级不同的静态路由,可以在路由器上实现路径备份的功能。而通过配置针对相同目的地址且优先级相同的静态路由,不仅互为备份还能实现负载均衡。

    当路由器路由表中存在到达同一目的地的多条等价路径时,路由器在转发到达该目的地的数据包会根据逐包、逐流、逐目的等负载均衡算法将数据包分布在相应的链路上发送。

     

    展开全文
  • 华为浮动静态路由及负载均衡

    千次阅读 2019-09-01 16:06:39
    浮动静态路由及负载均衡 ** 概述: 浮动静态路由是通过配置去往同一网段,但优先级不同的静态路由,保证在网络中优先级较高的路由(即主路由)失效的情况下,提供备份路由。备份路由一般不会出现在路由表中。只有...

    **

    浮动静态路由及负载均衡

    **

    1. 概述:
      
      浮动静态路由是通过配置去往同一网段,但优先级不同的静态路由,保证在网络中优先级较高的路由(即主路由)失效的情况下,提供备份路由。备份路由一般不会出现在路由表中。只有主链路失效时,浮动路由才会浮出来。
    2. 实验拓扑
      

    在这里插入图片描述

    1. 实验要求网络互通;
      采用静态路由实现PC1与PC2链路冗余负载均衡;
      PC1与PC2之间通信时,采用浮动静态路由实现。链路pc1-R2-R3-pc2为主链路,另一条为备份链路。

    2.   配置思路
      

    规划网段配置相应地址
    配置主链路静态路由
    配置浮动路由实现备份
    配置负载均衡

    基本配置

    R1

    system-view
    [Huawei]int e0/0/0
    [Huawei-Ethernet0/0/0]undo shutdown
    [Huawei-Ethernet0/0/0]ip add 10.1.1.2 24
    [Huawei-Ethernet0/0/0]quit
    [Huawei]int e0/0/1
    [Huawei-Ethernet0/0/1]undo shutdown
    [Huawei-Ethernet0/0/1]ip add 192.168.10.254 24
    [Huawei-Ethernet0/0/1]quit
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]undo shutdown
    [Huawei-GigabitEthernet0/0/0]ip add 10.3.3.1 24
    [Huawei-GigabitEthernet0/0/0]quit
    [Huawei]

    R2

    system-view
    [Huawei]int e0/0/0
    [Huawei-Ethernet0/0/0]undo shutdown
    [Huawei-Ethernet0/0/0]ip add 10.1.1.1 24
    [Huawei-Ethernet0/0/0]quit
    [Huawei]int e0/0/1
    [Huawei-Ethernet0/0/1]undo shutdown
    [Huawei-Ethernet0/0/1]ip add 10.2.2.1 24
    [Huawei-Ethernet0/0/1]quit

    R3

    system-view
    [Huawei]sysname R3
    [R3]int e0/0/0
    [R3-Ethernet0/0/0]undo shutdown
    [R3-Ethernet0/0/0]ip add 10.2.2.2 24
    [R3-Ethernet0/0/0]int e0/0/1
    [R3-Ethernet0/0/1]undo shutdown
    [R3-Ethernet0/0/1]ip add 192.168.20.254 24
    [R3-Ethernet0/0/1]int g0/0/0
    [R3-GigabitEthernet0/0/0]undo shutdown
    [R3-GigabitEthernet0/0/0]ip add 10.3.3.2 24
    [R3-GigabitEthernet0/0/0]quit
    配置主链路静态路由

    R1
    [Huawei]ip route-static 192.168.20.0 24 10.3.3.2
    R2
    [Huawei]ip route-static 192.168.10.0 24 10.1.1.2
    [Huawei]ip route-static 192.168.20.0 24 10.2.2.2
    R3
    [Huawei]ip
    route-static 192.168.10.0 24 10.3.3.1
    配置备份链路
    R1
    [R1]ip route-static 192.168.20.0 24 10.1.1.1 preference 100 //优先级默认为60
    R3
    [R3]ip route-static 192.168.20.0 24 10.2.2.1 preference 100
    在R1上查看静态路由的路由信息
    在这里插入图片描述

    路由显示到目的地址pc2有两条优先级为60和100的静态路由.
    然后关闭路由器R1的接口g/0/0/0,测试备份链路
    [R1]interface g0/0/0
    [R1-GigabitEthernet0/0/0]shutdown
    配置负载均衡
    R1
    [R1]interface g0/0/0
    [R1-GigabitEthernet0/0/0]undo shutdown
    [R1]ip route-static 192.168.20.0 255.255.255.0 10.1.11
    R3
    [R3]ip route-static 192.168.10.0 255.255.255.0 10.2.2.1
    查看R1路由表
    在这里插入图片描述

    看到去往192.168.20.0网段有两条不同吓一跳的路由条目,及实现负载均衡。

    展开全文
  • **浮动静态路由,一种特殊的静态路由,通过配置去往相同的目的网段,但优先级不同的静态路由,保证网络中优先级较高的路由,即主路由失效的情况下,提供备份路由。正常情况下,备份路由不会出现在路由表中。 负载...

    浮动静态路由,一种特殊的静态路由,通过配置去往相同的目的网段,但优先级不同的静态路由,保证网络中优先级较高的路由,即主路由失效的情况下,提供备份路由。正常情况下,备份路由不会出现在路由表中。
    负载均衡,当数据有多条可选路径前往同一目的网络,可以通过配置相同优先级和开销的静态路由实现负载均衡,使得数据传输均衡地分配到多条路径上,从而实现数据分流,而当其中一条路径失效时,其他路径仍能正常传输,也起到冗余作用。

    在这里插入图片描述

    配置R1接口IP 静态路由
    [R1]int g 0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.10.1 24
    [R1]int s 1/0/0
    [R1-Serial1/0/0]ip add 10.0.12.1 24
    [R1]int s 1/0/1
    [R1-Serial1/0/1]ip add 10.0.13.1 24	
    [R1]ip route-static 192.168.20.0 24 10.0.13.3
    
    R2配置接口IP 静态路由
    [R2]int s 1/0/0
    [R2-Serial1/0/0]ip add 10.0.12.2 24
    [R2]int s 1/0/1
    [R2-Serial1/0/1]ip add 10.0.23.2 24
    [R2]ip route-static 192.168.20.0 24 10.0.23.3
    [R2]ip route-static 192.168.10.0 24 10.0.12.1
    
    R3配置接口IP 静态路由
    [R3]int g 0/0/0
    [R3-GigabitEthernet0/0/0]ip add 192.168.20.1 24
    [R3]int s 1/0/0
    [R3-Serial1/0/0]ip add 10.0.23.3 24
    [R3]int s 1/0/1
    [R3-Serial1/0/1]ip add 10.0.13.3 24
    [R3]ip route-static 192.168.10.0 24 10.0.13.1
    

    此时PC1 PC2 均可互相通信。
    在这里插入图片描述

    在PC1上使用tracert命令测试所经过的网关。可以观察到数据包是经过R1和R3到达主机PC2的。
    在这里插入图片描述
    PC2上可以观察到数据包是经过R3和R1到达目的主机PC1的。
    在这里插入图片描述
    路由器R2测试PC1 PC2主机的连通性。
    在这里插入图片描述
    现在需要实现两台主机通信时,直连链路R1到R3为主用链路,R1通过R2的链路为备用链路,即当主链路发生故障时,可以使用备用链路通信。使用浮动静态路由实现网络冗余。

     在R1上配置静态路由,目的网段+掩码+下一跳。优先级设置为100(默认60[R1]ip route-static 192.168.20.0 24 10.0.12.2 preference 100
    

    在R1上使用 display ip routing-table protocol static命令查看静态路由信息。
    在这里插入图片描述
    可以看到R1上去往相同的目的网段存在两条不同的路由条目,首先会比较它们的优先级,对应的优先级数值较小的路由条目将被选为主用路由。R1去往R3的下一跳为10.0.13.3,优先级60,状态Active,为主链路。R1去往R2的下一跳为10.0.12.2,优先级100,状态Inactive,为备用链路。

    在R3上做和R1同样的对称配置。
    [R3]ip route-static 192.168.10.0 24 10.0.23.2 preference 100
    

    在这里插入图片描述
    可以看到R3去往R1的主链路下一跳为10.0.13.1,优先级60,状态Active。R3去往R2的备用链路下一跳为10.0.23.2,优先级100,状态Inactive.

    下面将R1上的S1/0/1接口关闭,测试备份链路。
    [R1]int s 1/0/1
    [R1-Serial1/0/1]shutdown
    

    PC1仍能和PC2通信。
    在这里插入图片描述

    在这里插入图片描述
    可以观察到R1上主链路接口S1/0/1关闭后,备用链路R1到R2的状态为Active,下一跳为10.0.12.2

    在这里插入图片描述
    PC1上使用tracert命令,再次验证了两台主机通信使用备用链路R1到R2到R3到目的主机PC2。

    通过负载均衡实现网络优化,备用链路上的带宽多处为闲置状态,通过配置实现负载均衡。利用主备链路来支撑两PC间的通信。

    恢复R1上S1/0/1的接口
    [R1]int s 1/0/1
    [R1-Serial1/0/1]undo shutdown
    [R1-Serial1/0/1]ip route-static 192.168.20.0 24 10.0.12.2
    

    在这里插入图片描述
    使用display ip routing-table命令查看R1上的路由表,可以看到去往192.168.20.0网段拥有两条下一跳不同的路由条目,即实现了负载均衡。

    在R3上做同样的配置
    [R3]ip route-static 192.168.10.0 24 10.0.23.2
    

    在这里插入图片描述
    R3上也有去往192.168.10.0的目的网段拥有两条下一跳不同的路由条目。

    通过配置针对相同目的地址但优先级不同的静态路由,可以在路由器上实现路径备份的功能。而通过相同目的地址且优先级相同的静态路由,不仅互为备份还能实现负载均衡。

    展开全文
  • 实验目的:浮动静态路由负载均衡1、拓扑2、配置地址R1配置interfaceGigabitEthernet0/0/0ipaddress200.1.1.1255.255.255.0#interfaceGigabitEthernet0/0/1ipaddress200.1.3.1255.255.255.0#...

    实验目的:浮动静态路由、负载均衡

    1

    、拓扑

    2

    、配置地址

    R1

    配置

    interface GigabitEthernet0/0/0

    ip address 200.1.1.1 255.255.255.0

    #

    interface GigabitEthernet0/0/1

    ip address 200.1.3.1 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    ip address 192.168.1.254 255.255.255.0

    查看接口地址配置

    [AR1]display ip interface  brief

    *down: administratively down

    ^down: standby

    (l): loopback

    (s): spoofing

    The number of interface that is UP in Physical is 4

    The number of interface that is DOWN in Physical is 0

    The number of interface that is UP in Protocol is 4

    The number of interface that is DOWN in Protocol is 0

    展开全文
  • 配置浮动静态路由和实现路由备份4. 通过负载均衡实现网络优化思考题:P161 前言   实验1-1里已写出实验内容和要求,由于是同一个实验不再给说明,此报告只包括具体实验+思考题 实验拓扑图编制表 不知markdown...
  • 1、路由 1.1什么是路由 想要将数据从一个网络发送到另一个网络,我们需要使用路由器来帮助我们转发数据。路由是指路由器从一个接口上收到数据包,根据数据包的目的地址进行定向并转发到另一个接口的过程。 ...
  • 浮动静态路由是通过配置去往同一网段,但优先级不同的静态路由,保证在网络中优先级较高的路由(即主路由)失效的情况下,提供备份路由。备份路由一般不会出现在路由表中。只有主链路失效时,浮动路由才会浮出来。 2...
  • 通过浮动静态路由实现网络的路由备份及负载均衡 实验:R1、R2、R3分别模拟分公司A、总部、分公司B 的出口路由 通过浮动静态路由实现网络的负载均衡 R1 <Huawei>sys[Huawei]sysn R1[R1]int g0/0/0[R1-...
  • 静态路由

    2019-08-17 20:44:46
    配置命令:ip route + 目标网段 +掩码 +下一跳 思科静态路由协议配置 ip route 192.168.30.0 255.255.255.0 下一跳地址 源:你在哪台设备上... 华为浮动静态路由及负载均衡:浮动静态路由是通过配置去往同一网...
  • 目录前言静态路由应用场景静态...另外,静态路由还可以实现负载均衡和路由备份。因此,学习并掌握好静态路由的应用与配置是非常必要的。 静态路由配置简单,并且无需像动态路由那样占用路由器的CPU资源来计算和分
  • 4.3.4 实验7:浮动静态路由 76 4.3.5 实验8:ip default-network 79 4.4 RIP命令汇总 81 第5章 EIGRP 82 5.1 EIGRP概述 82 5.2 实验1:EIGRP基本配置 82 5.3 EIGRP负载均衡、汇总和认证 90 5.3.1 实验2:EIGRP负载...

空空如也

空空如也

1 2
收藏数 24
精华内容 9
关键字:

浮动静态路由及负载均衡