精华内容
下载资源
问答
  • TomcatJDK版本对应关系
    千次阅读
    2020-03-15 14:26:30

    参考:http://tomcat.apache.org/whichversion.html

    Servlet SpecJSP SpecEL SpecWebSocket SpecAuthentication (JASIC) SpecApache Tomcat VersionLatest Released VersionSupported Java Versions
    5.03.04.02.02.010.0.x10.0.0-M18 and later
    4.02.33.01.11.19.0.x9.0.318 and later
    3.12.33.01.11.18.5.x8.5.517 and later
    3.12.33.01.1N/A8.0.x (superseded)8.0.53 (superseded)7 and later
    3.02.22.21.1N/A7.0.x7.0.1006 and later
    (7 and later for WebSocket)
    2.52.12.1N/AN/A6.0.x (archived)6.0.53 (archived)5 and later
    2.42.0N/AN/AN/A5.5.x (archived)5.5.36 (archived)1.4 and later
    2.31.2N/AN/AN/A4.1.x (archived)4.1.40 (archived)1.3 and later
    2.21.1N/AN/AN/A3.3.x (archived)3.3.2 (archived)1.1 and later
    更多相关内容
  • TomcatJDK版本对应关系为: Servlet规格 JSP规范 EL规格 WebSocket规范 JASPIC规格 Apache Tomcat版本 最新发行版本 支持的Java版本 4.0 2.3 3.0 1.1 1.1 9.0.x 9.0.27 8及更高版本 3.1 2.3 3.0 1.1 1.1 ...
  • TomcatJDK 版本对应

    2021-11-30 15:53:59
    官网下载Tomcat压缩包解压后,执行启动...357) at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495) 以后下载Tomcat时需要注意版本要与自己电脑上的JDK版本对应,否则会导致Tomcat启动失败!

    官网下载Tomcat压缩包解压后,执行启动命令,虽然显示Tomcat启动成功,但是无法访问http://localhost:8080

    scxMacBook-Pro:bin scx$ ./startup.sh
    Using CATALINA_BASE:   /Users/scx/software/apache-tomcat-10.1.0-M7
    Using CATALINA_HOME:   /Users/scx/software/apache-tomcat-10.1.0-M7
    Using CATALINA_TMPDIR: /Users/scx/software/apache-tomcat-10.1.0-M7/temp
    Using JRE_HOME:        /Library/Java/JavaVirtualMachines/jdk1.8.0_191.jdk/Contents/Home
    Using CLASSPATH:       /Users/scx/software/apache-tomcat-10.1.0-M7/bin/bootstrap.jar:/Users/scx/software/apache-tomcat-10.1.0-M7/bin/tomcat-juli.jar
    Using CATALINA_OPTS:
    Tomcat started.
    

    网上查了半天都没查到原因,后来执行shutdown时发现报错,根据报错意思大概猜测是版本问题,又查了些资料才知道版本对应关系

    scxdeMacBook-Pro:bin scx$ ./shutdown.sh
    Using CATALINA_BASE:   /Users/scx/software/tomcat
    Using CATALINA_HOME:   /Users/scx/software/tomcat
    Using CATALINA_TMPDIR: /Users/scx/software/tomcat/temp
    Using JRE_HOME:        /Library/Java/JavaVirtualMachines/jdk1.8.0_191.jdk/Contents/Home
    Using CLASSPATH:       /Users/scx/software/tomcat/bin/bootstrap.jar:/Users/scx/software/tomcat/bin/tomcat-juli.jar
    Using CATALINA_OPTS:
    Error: A JNI error has occurred, please check your installation and try again
    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/catalina/startup/Bootstrap has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    	at java.lang.ClassLoader.defineClass1(Native Method)
    	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
    	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    	at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
    	at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
    	at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
    	at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)
    

    以后下载Tomcat时需要注意版本要与自己电脑上的JDK版本对应,否则会导致Tomcat启动失败!
    在这里插入图片描述

    展开全文
  • 在面临以下两种情景时,我们常常讨论TomcatJDK版本对应关系。 一是:安装哪种版本JDK,可以使tomcat运行起来; 二是:安装哪种版本JDK+Tomcat组合,可以让我用某版本JDK编写的网站运行起来。 其实,这两种...

    在面临以下两种情景时,我们常常讨论Tomcat和JDK版本的对应关系。

    一是:安装哪种版本的JDK,可以使tomcat运行起来;

    二是:安装哪种版本的JDK+Tomcat组合,可以让我用某版本JDK编写的网站运行起来。

    其实,这两种问题有一个共同的答案:低版本JDK无法运行高版本JDK编译的代码。

    tomcat官网(http://tomcat.apache.org/whichversion.html)给出了tomcat和JDK版本的匹配情况:

    e39f336e25d08627dca1d733bbb2c288.png

    我安装了tomcat9和JDK1.7,当我启动tomcat时报错(Unsupportedmajor.minorversion 52.0):

    (52.0是java编码器的内部编号,JDK1.4–48.0,JDK1.5–49.0,JDK1.6–50.0,JDK1.7–51.0,JDK1.8–52.0)

    b630f20f4abcbb6f5a0016bbd7e4ca0f.png

    出现这个问题的原因是:本地安装的JDK1.7和tomcat9不兼容,tomcat9需要在1.8版本以上的JDK环境上才能正常运行。另外,下载的Tomcat的RUNNING.txt也有当前版本所需JDK说明:

    Apache Tomcat 9.0 requires a Java Standard Edition RuntimeEnvironment (JRE) version 8 or later.

    展开全文
  • tomcatjdk版本对应关系图

    千次阅读 2019-06-16 18:34:27
    下图是tomcatjdk对应版本: 因tomcatjdk版本都在不断变化,因此请前往tomcat官网进行查证,官网版本对应关系地址:http://tomcat.apache.org/whichversion.html ...

    下图是tomcat与jdk的对应版本:
    在这里插入图片描述
    因tomcat与jdk版本都在不断变化,因此请前往tomcat官网进行查证,官网版本对应关系地址:http://tomcat.apache.org/whichversion.html

    展开全文
  • 我们在安装Tomcat时一定要注意匹配对应JDK版本,不然辛辛苦苦装完后发现TomcatJDK版本不匹配岂不是要哭死!还好Tomcat官方已经为我们列出了安装Tomcat版本时需要的JDK版本,网址如下: Tomcat版本JDK版本...
  • 这篇文章主要介绍了TomcatJDK版本对应关系以及Tomcat版本特性,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值
  • TomcatJDK版本对应关系,Tomcat版本特性

    万次阅读 多人点赞 2019-10-18 11:44:13
    文章目录Alpha / Beta / StableApache Tomcat 9.xApache Tomcat 8.xApache Tomcat 7.xApache Tomcat 6.x Apache Tomcat是一个开源软件实现...不同版本的Servlet和JSP规范可使用不同版本的Apache TomcatTomcatJDK...
  • tomcat对应jdk版本问题

    千次阅读 2018-11-21 16:10:13
    一般是和jdk版本保持一致的,也就是说tomcat6用>=jdk6版本就可以了。通常情况下,可以依次类推的。 tomcat8.0可以兼容jdk1.6,而tomcat6.0不可以兼容jdk1.8 tomcat版本高->jdk版本低 不会出问题...
  • Tomcat对应JDK版本

    2022-01-10 17:12:15
    Tomcat对应JDK版本
  • tomcatjdk版本对应关系 - 家乐先生 - 博客园#根据服务器jdk版本查看安装哪个版本tomcat 可参考:https://tomcat.apache.org/whichversion.html 如下图: #如果需要修改tomcat端口号 tomchttps://...
  • JDKtomcat版本对照

    2015-10-02 14:27:39
    JDKtomcat版本对照,Tomacat版本跟随JDK更新
  • tomcat7-jdk1.6+redis session共享所有依赖包: tomcat-redis-session-manager.jar jedis.jar commons-pool.jar 以及Tomcat对应的配置示例,亲测可用
  • 它建立在Tomcat 8.0.x和8.5.x之上,并实现了Servlet 4.0,JSP 2.3,EL 3.0,WebSocket 1.1 和JASPIC 1.1规范(Java EE 8平台要求的版本)。除此之外,它还包括以下重要改进: 添加对HTTP / 2的支持(需要在Java 9上...
  • jdktomcat版本对应

    万次阅读 2018-05-17 13:34:54
    Servlet SpecJSP SpecEL SpecWebSocket SpecJASPIC SpecApache Tomcat versionActual release revisionSupported Java Versions4.0TBD (2.4?)TBD (3.1?)TBD (1.2?)1.19.0.x9.0.0.M4 (alpha)8 and later3.12.33.01.11...
  • tomcatjdk 版本 对应关系

    千次阅读 2020-04-16 16:50:49
    当我们在谈论TomcatJDK版本对应关系的时候,我们实际上在讨论两个问题。 第一个是,我们想安装了某个版本Tomcat(比如Tomcat7),需要安装哪个版本JDK,才能把Tomcat运行起来。 第二个是,如果我们安装...
  • tomcat版本和支持的jdk版本匹配表

    千次阅读 2022-01-15 21:06:18

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 82,595
精华内容 33,038
关键字:

tomcat10对应jdk版本

友情链接: massive-ironman-master.zip