精华内容
下载资源
问答
  • 2022-03-28 12:19:36

    搭建环境

    首先要根据目标服务需要的环境,在本地搭建尽量相同的环境,如python版本、pip版本等。

    确认依赖包名与版本

    在其他环境中找到要安装的依赖包名及版本并导出:pip freeze > requirements.txt,requirements.txt中即为要的包信息。

    下载安装包

    在本地搭建python环境中,下载安装包到文件夹中:

    1. 下载单个离线包: pip download -d 文件夹名 <package_name>
    2. 批量下载离线包:pip download -d 文件夹名 -r requirements.txt

    注:下载离线包时,也会自动下载依赖的包,比如下载tourch,会自动下载其他依赖。

    离线安装

    在目标服务器python环境中,链接到资源文件夹中,并执行安装:

    1. 安装单个离线包: pip install --no-index --find-links=/资源文件夹/ <package_name>
    2. 批量安装离线包:pip install --no-index --find-links=/资源文件夹/ -r requirements.txt
    更多相关内容
  • IDEA中Maven依赖包下载不了的问题解决方案汇总

    万次阅读 多人点赞 2018-04-25 14:11:16
    这个依赖包下载不了的问题真的是很烦,之前一直把下载不上的依赖剪切再粘贴到pom.xml文件中,保存它就自动下载了,但是今天怎么剪切粘贴都没用,所以就花了点时间在网上各种搜解决方案,试了一些之后终于从根本上解决了...

    这个依赖包下载不了的问题真的是很烦,之前一直把下载不上的依赖剪切再粘贴到pom.xml文件中,保存它就自动下载了,但是今天怎么剪切粘贴都没用,所以就花了点时间在网上各种搜解决方案,试了一些之后终于从根本上解决了问题,所以写个博客把解决这个问题的方案汇总一下!

     

    1. 先是对图上的两个位置一番狂点进行刷新,然并卵...

    于是又按照博客上的指示去寻找 Settings -> Build,Execution,Deployment -> Build Tools -> Maven -> Ignored Files 

    如下图:

    然而这个对我依然没有什么帮助,但还是要记录一下的,并感谢这位博主哥哥!!!

    原文地址: https://blog.csdn.net/qq_35981283/article/details/73928035

     

    2.之后我又找了一些关于配置的, Settings -> Build,Execution,Deployment -> Build Tools -> Maven -> Importing,如下图:

    然而...还是没有什么卵用...到了这一步我发现该设置的都设置好了,虽然这些设置并没有解决我的问题,但还是要记录一下的,说不定有人会因为设置问题导致依赖包下载不下来...

     

    3.重点来了,这次我又找到了一篇博客,彻底解决了我的问题. 右击Maven项目,操作如下图:

    点击Open'settings.xml' , 刚开始这个位置是Create 'settings.xml' ,打开之后添加在里面添加了镜像服务器:

    然后,我又按照最前面的方法进行Reimport,依赖包终于开始下载了!!! 内牛满面啊... 可能这个大家都设置过,但还是要记录一下的,毕竟实实在在的解决了我的问题,附一份代码:

    ========================耀眼的故意引起注意的分隔线========================

    (2020.04.09 补一下:评论区有大佬们讨论说url中用http不好使(就是下载不了,或者下载缓慢的问题),所以此处可以换成https进行尝试~)(这个有点重要)(看我一眼)(~~~~~)

        <mirrors>
            <mirror>
                <id>nexus</id>
                <name>internal nexus repository</name>
                <!-- <url>http://192.168.1.100:8081/nexus/content/groups/public/</url>-->
                <url>http://repo.maven.apache.org/maven2</url>
                <mirrorOf>central</mirrorOf>
            </mirror>
        </mirrors>

    原文地址: https://blog.csdn.net/sky19891212/article/details/43924831

    真的是非常感谢这位博主大哥!!! 

     

    4..好不容易下载下来之后,发现右边报红了,我眼瞎了吗,眼瞎了吗,瞎了吗... 

    然后就去网上搜了一下,有两种解决方式:

     

        1.把pom.xml中对应的依赖先删除,然后刷新右侧,之后再把依赖粘贴到pom.xml中,再次刷新右侧就好了

        2.从本地仓库将对应的包删除掉,然后让maven重新下载

    原文地址: https://blog.csdn.net/u010003835/article/details/78480626

    也感谢这位博主哥哥!!!

     

    至此之后,我可能再也不用担心依赖包下载的问题了,十分开心...

     

    ========================华丽的分割线========================

    2020.04.09 补充:(汲取评论区中遇到的,且文章中并未涉及到的解决方法)

    1.Settings -> Build,Execution,Deployment -> Build Tools -> Maven -> Work offline

    评论区一大佬说了,这个尽量不要勾选,可以尝试修改此项解决问题。

    (哪个大佬呢,就是这个,欢迎光顾,万一发现啥宝藏文章岂不是赚翻了,传送门:https://me.csdn.net/qq_43384381

    2. Settings -> Build,Execution,Deployment -> Build Tools -> Maven -> Maven home directory

    2019版的IDEA,要注意maven版本兼容问题,评论区另一个大佬(大佬专用传送门:https://me.csdn.net/stonennnn)说,2019.3版本的IDEA用3.6.1的maven兼容不了,换了最新的maven3.6.3好使。(maven各个版本可自行下载哟~)

    我最近刚换了2019.3版本的IDEA,默默看了一眼自己的maven版本:3.6.1

    (所以,实在没办法的可以尝试更换maven版本,我这边2019.3和maven3.6.1貌似挺般配…没出现什么异常。)

     

    ========================华丽的分割线========================

    2020.07.09 补充:(汲取评论区中遇到的,且文章中并未涉及到的解决方法)

    评论区一位大佬留下了自己宝贵的经验(大佬传送门:https://me.csdn.net/weixin_44039506):

    1. 如果配置那些都没有什么问题,ping 镜像库也能ping通,但是防火墙没关闭也不行,一定要关闭防火墙!!!

    (个人感觉正常外网环境下,应该不会出现这种被墙的情况?弟弟我没遇到过这种情况,但实在解决不了问题的朋友可以尝试一下。)

     

    展开全文
  • 更换依赖包下载源 通过pip install安装依赖包是在国外的源下载,有的速度会特别慢,比较小的包还好,像tensorflow这样比较大的包,就会下很久。 我们可以通过指定国内的源进行下载安装 pip install -i ...

    更换依赖包的下载源

    通过pip install安装依赖包是在国外的源下载,有的速度会特别慢,比较小的包还好,像tensorflow这样比较大的包,就会下很久。
    我们可以通过指定国内的源进行下载安装

    pip install -i https://pypi.tuna.tsinghua.edu.cn/simple tensorflow
    

    阿里云
    http://mirrors.aliyun.com/pypi/simple/

    中国科技大学
    https://pypi.mirrors.ustc.edu.cn/simple/

    豆瓣(douban)
    http://pypi.douban.com/simple/

    清华大学
    https://pypi.tuna.tsinghua.edu.cn/simple/

    中国科学技术大学
    http://pypi.mirrors.ustc.edu.cn/simple/

    升级依赖包

    pip install -U tensorflow
    
    pip install --upgrade tensorflow
    
    pip install -i https://pypi.tuna.tsinghua.edu.cn/simple -U tensorflow
    

    卸载依赖包

    pip uninstall tensorflow
    

    选择特定的python环境

    很多人的电脑会同时安装了python2和python3,并且可能python2和3都添加至环境变量了,这个时候当你想为python2和3其中的一个环境安装依赖包的时候,就可以使用以下命令:

    python3 –m pip install tensorflow
    

    这里的python3是环境变量名称

    离线安装

    有时候,我们也会需要使用离线安装的方式。一般是两种方式:
    第一种的话,是下载依赖包的whl文件,然后直接在文件的路径下打开cmd,执行以下命令:

    pip install tensorflow-1.14.0-cp27-cp27m-macosx_10_11_x86_64.whl
    

    第二种的话,有些依赖包没有提供whl文件,只有tar.gz文件,这个时候,你就需要先进行解压,然后进行解压的目录,打开cmd,执行以下命令:

    python setup.py install 
    

    python的依赖包可以去这个网站找到:PYPI

    指定依赖包的版本

    pip install tensorflow==1.14.0
    

    升级包时无法卸载旧版本的包

    pip install -U --ignore-installed openv-python
    

    例如在对tensorflow进行升级时,需要对wrapt也进行更新,但却报错无法卸载旧版本的包,导致无法升级
    ERROR: Cannot uninstall ‘wrapt’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

    这个可以换成以下的更新命令:

    pip install -U --ignore-installed wrapt enum34 simplejson netaddr
    

    批量安装依赖包

    在线批量安装

    首先,我们需要创建一个txt文件,名为requirements.txt,格式为下:

    sklearn==0.0      
    subprocess32==3.2.7      
    tablestore==4.3.4      
    tensorboard==1.8.0      
    tensorflow==1.8.0 
    

    接着,就可以执行我们的批量安装命令了。

    pip install -r requirements.txt
    

    离线批量安装

    我们仍然需要创建一个txt文件,名为requirements.txt,格式为下:

    redis-3.2.1-py2.py3-none-any.whl
    py2neo-4.3.0.tar.gz
    

    接着,执行命令

    pip install --no-index --find-links=d:\packages -r requirements.txt
    

    下载超时

    如果依赖包比较大,网络又比较差,很经常出现超时的问题。
    通过以下命令解决:
    pip --default-timeout=10000 install -i https://pypi.tuna.tsinghua.edu.cn/simple pyspark

    –default-timeout=10000:设置超时时间;
    -i:详见上述

    欢迎关注同名公众号:“我就算饿死也不做程序员”。
    交个朋友,一起交流,一起学习,一起进步。在这里插入图片描述

    展开全文
  • Spring MVC框架的各种依赖包下载

    热门讨论 2017-01-24 01:51:20
    本资源包括Spring MVC框架下的各种依赖包,同过本资源,可以快速搭建Spring MVC框架。
  • paddlepaddle、paddlehub依赖包下载并离线安装

    千次阅读 热门讨论 2019-12-12 16:59:19
    paddlepaddle、paddlehub依赖包下载并离线安装 1.通过有网环境下载好paddlepaddle、paddlehub并生成requirements文件 1.首先得有paddlepaddle的各依赖包的版本和目录,所以需在已安装好的环境下生成requirements...

    paddlepaddle、paddlehub依赖包下载并离线安装

    1.通过有网环境下载好paddlepaddle、paddlehub并生成requirements文件

    1.首先得有paddlepaddle的各依赖包的版本和目录,所以需在已安装好的环境下生成requirements文件。(此处建议先搭建虚拟环境,在虚拟环境下安装以避免生成的requirements.txt文件过大,且包含其他包)
    2.python创建虚拟环境:
    (1)使用 conda create -n your_env_name pip python=X.X(2.7、3.6等)命令创建python版本为X.X、名字为your_env_name的虚拟环境。your_env_name文件可以在Anaconda安装目录envs文件下找到。

    conda create -n visual pip python=3.6
    

    (2)激活虚拟环境
    Linux: source activate your_env_name(虚拟环境名称)
    Windows: activate your_env_name(虚拟环境名称)

    activate visual
    

    (3)查看虚拟环境内的包

    conda list
    

    (3)requirements文件生成(此时在激活的虚拟环境下进行,且环境下已经下载好paddlepaddle、paddlehub包及其依赖包)

    1.安装requirements.txt依赖:

     pip install -r requirements.txt
    

    2.生成requirements.txt:

    pip freeze > requirements.txt
    

    此处为我已经生成好的paddlepaddle、paddlehub的requiremenst.txt文件,需要自取。
    百度云盘:提取码:91ke
    链接:https://pan.baidu.com/s/1JjyBse5VRxTRYCem6YFQ9A

    2.根据生成的requirements.txt文件进行包的下载

    1.将生成的requirements.txt文件放入一个文件夹,如下图:
    在这里插入图片描述2.进行包下载:先切换到requirements.txt所在的文件夹,如图:
    在这里插入图片描述
    然后输入以下代码:

    pip download -r requirements.txt
    

    等待其下载即可。此处为下载好的安装包,需要自取。
    百度云盘:提取码:ygr3
    链接:https://pan.baidu.com/s/1L8QYomsSZa0UwxYrXiqykw

    3.批量安装各种包

    1.此处由于requirements.txt和各种安装包均在同一目录下(packages),将packages拷贝到离线环境下,输入以下代码即可安装:
    pip install --no-index --find-links=文件夹路径 -r requirements.txt

    pip install --no-index --find-links=C:\Users\Administrator\packages -r requirements.txt
    

    2.此时paddlepaddle离线包已经安装好了,我们通过python测试一下:
    在这里插入图片描述
    测试成功!
    通过各种依赖包离线安装paddlepaddle、paddlehub就完成啦!

    展开全文
  • python第三方依赖包下载地址大全

    千次阅读 2018-11-22 11:07:54
    从网上翻出来的,上传到我博客上,存一下 https://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy --依赖包大全 https://pypi.org/project/ls-thrift-py-hadoop/1-cdh3u2/#files --其他依赖包下载的官方路径 ...
  • 虽然我们可以使用 curl 或者 wget 等命令来下载网上的软件包,但是一般我们执行安装命令的时候,却会提示我们还要先安装一些其他的依赖软件包,然后又要再下载其他的软件包,这样太费时费力了。 于是,下面我们要...
  • 最近在家里配置AndroidStudio,因为各种尝试,下了很多免安装版本,也都运行了几次,但是以前能够编译运行通过的例子,现在却无法运行通过了。于是在网上搜索了一番,最后找到了一个解决办法,下面我总结一下: ...
  • 相信大家用idea的时候也会遇到相同的问题,我最开始的解决方案是把maven本地仓库删除重新下载,非常苦恼,但是今天get到了新的解决方案,在settings.xml中加入以下配置 <mirror> <id>nexus</id>...
  • 然后就是在添加依赖包,这样就可以解决缺少一系列jedisPool方法的问题了!!! 首先先介绍要进行jedis包,这是一个关于java链接redis的jar包,类似于jdbc这种东西吧,我也不是很好给她一个定义,下载地址比较好找:...
  • 依赖包下载命令

    千次阅读 2019-08-26 23:30:28
    这里提供了一种获取依赖关系的命令,助力各位摆脱离线环境的痛苦。 yum install <安装包> --downloadonly --downloaddir=./ libaio-devel 有用不在字多,一个命令,顶的上一篇文章!!! ...
  • maven依赖包快速下载

    千次阅读 2021-07-09 13:51:16
    在离线环境进行maven项目开发时,总会遇到需要频繁添加jar包依赖来进行功能拓展,然而某一个jar的引入,又会需要间接依赖很多其他的类库,一个一个地下载又很麻烦。当然你也可以在外网搭建一套同样的开发环境,...
  • jeesite依赖包

    2015-08-27 17:20:45
    jeesite依赖包
  • Ubuntu下载依赖包

    千次阅读 2021-01-31 17:42:36
    Ubuntu下载依赖包 适用场景 无外网访问的局域网环境。 方法一 在能访问外网的设备上将依赖包全部下载下来,局域网环境离线安装包。 找到所依赖的包 apt-cache depends <package> #. 下载所依赖的包 apt ...
  • elasticsearch client依赖包下载方法

    万次阅读 2017-06-13 17:31:55
    elasticsearch client依赖包的maven配置
  • go下载指定版本的依赖包

    千次阅读 2021-08-26 22:55:47
    在go语言开发中,要下载各种各样的依赖包,这些依赖包版本有的以vX.YY.ZZ结尾,有的以v0.0.0-20160315200505-970db520ece7结尾。这里以下载github.com/btcsuite/btcd v0.21.0-beta版本为例,进行说明。
  • golang下载所有的依赖包

    千次阅读 2021-06-30 11:15:02
    有时候,我们发现一个开源项目,但是又不想打开IDEA来运行,通过cmd命令直接下载所有的依赖包运行就可以。 1、通过go env 命令查看我的代理服务器是不是国内的仓库(如果是国外的可能有些会被Q) 2、通过命令所有的...
  • vue.js下载依赖包node_modules

    千次阅读 2021-07-18 15:33:56
    因为这个包太大了,而且,我们运行项目的时候,如果没有依赖包,重新下载依赖包就可以了,很方便的,接下来给大家介绍介绍具体步骤: 首先我要把项目中的依赖包删掉 可以看到,现在文件夹里已经没有node_...
  • ubuntu 下载完整deb包及依赖包

    千次阅读 2021-12-02 10:12:26
    下载deb 依赖包 apt-get download $(apt-cache depends --recurse --no-recommends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances --no-pre-depends XXX | grep -v i386 | grep "^\w") ...
  • Linux依赖包下载

    千次阅读 2017-04-10 09:31:59
    Centos和Redhat7版本开始支持下载yum安装包 6版本可以通过插件支持该...下载安装包及依赖包 $ sudo yum install --downloadonly 默认情况下,一个下载的RPM包会保存在下面的目录中:/var/cache/yum/x86_64/[centos
  • Linux oracle 11gR2安装说明及依赖包全套

    千次下载 热门讨论 2012-12-25 15:46:32
    Linux oracle 11gR2安装数目及依赖包(找了好久才弄齐)。免费分享给大家。compat-libstdc++-33-3.2.3-61.i386.rpm,unixODBC-2.2.11-10.el5.i386.rpm等等。以及db_install.rsp文件。 安装步骤在 ...
  • go.mod依赖包下载

    千次阅读 2019-10-08 22:49:03
    依赖包下载的过程中会出现部分包无法下载,需要设置代理 GOPROXY=https://goproxy.io/ 若代码下载到GOPATH路径下需要进行如下设置 GO111MODULE=on 项目依赖下载如下 GOPROXY=...
  • spring依赖包

    热门讨论 2011-11-22 10:01:21
    相应依赖包,不需要下载,给我自己用得,资源描述
  • springboot下载依赖包

    千次阅读 2019-11-14 15:56:15
    1.环境变量自己配置, 2.配置阿里云镜像和本地仓库 <localRepository>D:\Apache\maven\repository</localRepository> <mirror> <id>alimaven<...aliyun maven&l...
  • flutter中下载依赖包

    千次阅读 2020-08-26 15:07:09
    下载安装依赖包 用于检索当前 Package 所依赖的其它 Package。如果 pubspec.lock 文件已经存在,则根据该文件中保存的依赖项版本获取对应的依赖项。如有必要,将会创建或更新该文件。 flutter packages get / ...
  • 由于最近需要在无互联网环境的ubuntu上安装软件包,而往往每个软件包都需要很多依赖项,依赖项还有各自的依赖项,手动查找下载非常麻烦。 在一些早期的ubuntu上连C编译器也没有预装,需要安装gcc等编译器才能进行下...
  • golang 自动下载所有依赖包

    千次阅读 2020-07-02 12:08:00
    1.下载全部依赖包: CMD项目目录下运行下面指令可以自动获取依赖包 go get -d -v ./... 2.设置代理: 配置代理地址:https://goproxy.io,在idea中可以直接配置go moudle的代理地址为这个url; 作者:Zhoudao ...
  • Android Studio项目依赖包下载到本地的jar或aar的路径
  • 首先确保你安装了maven 然后命令行可以使用 然后新建一个文件夹 把pom.xml文件放进去 在当前目录下打开命令行 输入命令: ...会直接将所有的jar包下载到 target文件夹 并在target/dependency文件夹 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 726,328
精华内容 290,531
关键字:

依赖包下载