精华内容
下载资源
问答
  • CISCO ROUTE-MAP

    2021-09-16 18:45:01
    强制指定源地址的下一跳 match定义匹配条件 match ip address匹配访问...match route-type匹配指定类型的路由 match tag根据路由的标记进行匹配 set定义动作 set metric设置路由协议的度量值 set metric-type设

    强制指定源地址的下一跳

    match定义匹配条件

    match ip address匹配访问列表或前缀列表 
    match interface匹配下一跳出接口为指定接口之一的路由 
    match ip next-hop匹配下一跳地址为特定访问列表中被允许的那些路由 
    match metric匹配具有指定度量值的路由 
    match route-type匹配指定类型的路由 
    match tag根据路由的标记进行匹配

    set定义动作

    set metric设置路由协议的度量值 
    set metric-type设置目标路由协议的度量值类型 
    set default interface指定如何发送这样的分组 
    set interface指定如何发送这样的分组 
    set ipdefault next-hop指定转发的下一跳 
    set ip next-hop指定转发的下一跳 
    set next-hop指定下一跳的地址,指定BGP的下一跳 
    set tag

    route-map例题

     

    思路: 首先完成基本配置先不急写静态 
    1.先在R1上创建一个acl列表允许10这个网段 
    ip access-list standard 1 
    [acl列表]+[基本1-100]+[列表名称] 
    permit 192.168.10.0 0.0.0.255 
    [允许]+[要被允许的网段]+[反掩码]
    2.然后route-map 1 permit 10 
    [1是acl列表名称]+[允许]+[10] 10的意思是route-map的命令是从上往下 
    读的是一条一条执行的,假如有别的命令是十以上的那就先执行十以上的命 令一个一个排着队的执行的
    3.在route-map里匹配acl的名称 match ip address 1 
    4.指定route-map的下一跳                         #如下图 
    set ip next-hop 10.1.1.1 10.2.2.1
    5.进入R1里的G0/2 里把route-map应用到接口 
    ip policy route-map 1                         #1是acl的名称 
    6.最后在写个回程路由 vIOS2: ip route 192.168.10.0 255.255.255.0 10.1.1.1                                                         #写一个回程路由回到vIOS1 
    vIOS3: 
    ip route 192.168.10.0 255.255.255.0 10.2.2.1  #写一个回程路由回到vIOS1
    7.注:10.1.1.0 这个段是主 10.2.2.0 这里是备 
    把主down掉 备就可以起来 
    int g0/0 shutdown 
    去ping 192.168.100.3 
    PC1是100.100.100.1                             #主 
    PC2是100.100.100.3                             #备
    vIOS1:                            #首先完成基本的IP地址配置先不急写静态 
    ip access-list standard 1         #创建一个基本的acl列表,列表名称为1,扩展是100 后面的 
    ermit 192.168.10.0 0.0.0.255      #先在R1上创建一个acl列表允许10这个网段 
    exit                              #退出 
    route-map 1 permit 10             #route-map的命令是从上往下读的是一条一条执行 的,假如有别的命令是十以上的那就先执行十以上的命令一个一个排着队的执行的 
    match ip addresss 1               #在route-map里匹配acl的名称 
    set ip next-hop 10.1.1.2 10.2.2.2 #定义一个下一跳地址,10.1.1.2断掉了就从 10.2.2.2走 
    exit                              #退出 
    int gi0/2                         #进入R1里的e0/2 里把route-map应用到接口 
    ip policy route-map 1             #应用到接口 R1下面的PC3
    ping 100.100.100.1是可以ping通的 
    
    vIOS2: 
    ip route 192.168.10.0 255.255.255.0 10.1.1.1 #写一个回程路由回到vIOS1 
    vIOS3: 
    ip route 192.168.10.0 255.255.255.0 10.2.2.1
    展开全文
  • 锐捷三层交换机route-map设置

    千次阅读 2021-11-19 11:43:41
    要求:在S3、S4交换机中引入路由时,需要进行路由标记。...S3(config)#route-map SET_TAG permit 10 S3(config-route-map)#match interface vlan 10 S3(config-route-map)#set tag 10 S3(config-route-m

    要求:在S3、S4交换机中引入路由时,需要进行路由标记。其中,生产网段(vlan10)标记为10;办公网段(vlan20)标记为20。因业务联通需要,所有增加的网络终端数据之间的通信,一并划入办公网段进行路由标记,路由图定义为SET_TAG


    S3(config)#route-map SET_TAG permit 10
    S3(config-route-map)#match interface vlan 10
    S3(config-route-map)#set tag 10
    S3(config-route-map)#exit
    S3(config)#route-map SET_TAG permit 20
    S3(config-route-map)#match interface vlan 20
    S3(config-route-map)#set tag 20             
    S3(config-route-map)#exit   
    S3(config)#router ospf 1     
    S3(config-router)#redistribute connected subnets metric-type 1 route-map SET_TAG
    S4(config)#route-map SET_TAG permit 10
    S4(config-route-map)#match interface vlan 10
    S4(config-route-map)#set tag 10
    S4(config-route-map)#exit
    S4(config)#route-map SET_TAG permit 20
    S4(config-route-map)#match interface vlan 20
    S4(config-route-map)#set tag 20             
    S4(config-route-map)#exit   
    S4(config)#router ospf 1     
    S4(config-router)#redistribute connected subnets metric-type 1 route-map SET_TAG


     

    展开全文
  • 本文将为各位介绍深信服下一代防火墙(NGAF)BGP路由过滤基于路由映射(route-map)实施步骤,感兴趣的同学麻烦点个赞~~ 目录 方案概述 实施步骤 方案实施预置条件 配置访问列表 配置路由映射(Route-...

    hi!兄弟们好!

            本文将为各位介绍深信服下一代防火墙(NGAF)BGP路由过滤基于路由映射(Route-map)实施步骤,感兴趣的同学麻烦点个赞~~

    目录

            方案概述

            实施步骤

                    方案实施预置条件

                    配置访问列表

                    配置路由映射(Route-map)并调用访问列表(ACL)

                    邻居配置调用路由映射(Route-map)

                    验证BGP路由过滤结果

                            访问列表(ACL)未匹配的路由前缀

                            访问列表(ACL)匹配的路由前缀


            方案概述

            本方案试用于深信服下一代防火墙(NGAF)8.0.7版本,其它版本暂未测试可能存在配置差异,如涉及其它版本具体配置请提前与深信服技术支持(4006306430)获取联系。

            该配置方案先使用访问列表(ACL)抓取BGP路由前缀,使用路由映射(Route-map)调用访问列表(ACL)并在邻居(Peer)配置中针对具体邻居进行路由映射(Route-map)入站规则匹配,最终实现BGP入站方向的路由前缀过滤。

            实施步骤

                    方案实施预置条件

            深信服下一代防火墙(NGAF)正常与邻居建立BGP对等体关系,且可以正常学习到对端发布的路由明细,验证BGP对等体是否正常建立的方式可以点击查看路由标签查看是否学到BGP类型的路由前缀,后续的路由过滤将也将以这个标签学习到的前缀为基础。

    验证BGP是否正常运行

            如图所示,以上为设备正常学习到的BGP类型路由条目,存在即代表已经正确建立BGP对等体关系,且可以正常学习路由明细。

            深信服下一代防火墙(NGAF)BGP路由基础配置略。

                    配置访问列表

            访问列表是我们常见的抓取路由条目的工具,本实施方案也将基于访问列表(ACL)进行路由前缀抓取,该配置需与路由前缀长度严格匹配,深信服下一代防火墙(NGAF)的BGP访问列表默认动作为拒绝,故同一编号的访问列表无需配置匹配所有路由前缀(0.0.0.0/0)的拒绝匹配规则。

    路由匹配场景下使用允许规则抓取路由前缀

             如上图所示,需要创建2个编号的访问列表规则,访问列表1抓取路由前缀方便Route-map调用进行路由过滤,访问列表2用于抓取访问列表1没匹配中的剩余路由条目,并在Route-map中进行路由允许。

                    配置路由映射(Route-map)并调用访问列表(ACL)

            使用路由映射(Route-map)的作用是为了过滤或放行访问列表(ACL)抓取的路由前缀,故在创建路由映射(Route-map)规则前需先确保访问列表(ACL)已被正确配置。

             如上图所示,名为“test”名称的路由映射(Route-map)规则调用了访问列表(ACL)编号为1的访问列表(ACL),对应动作为拒绝。该配置的含义是,拒绝被访问列表(ACL)编号为1匹配的路由前缀写入深信服下一代防火墙(NGAF)路由表中。 

    路由映射(Route-map)优先级值越高越劣

            如上图所示,配置第二条以“test”为规则的路由映射(Route-map)条目,并调用访问列表(ACL)编号为2的匹配规则,需注意,由于深信服下一代防火墙(NGAF)按优先级值从小到大匹配,所以允许规则的路由映射(Route-map)条目优先级值必须高于第一条拒绝规则的路由映射(Route-map)条目。

            多条不同名的路由映射(Route-map)条目无需关注优先级配置。以邻居配置中调用的路由映射(Route-map)条目作为路由映射(Route-map)过滤最终效果。

                    邻居配置调用路由映射(Route-map)

            以上均为前置配置,该操作尚未对BGP邻居写入深信服下一代防火墙(NGAF)的路由明细进行实际操作,不会影响用户业务可随时进行配置的增删改查,但对邻居配置中已经引用的路由映射(Route-map)或访问列表(ACL)的任何操作将实时影响BGP邻居写入深信服下一代防火墙(NGAF)明细路由,此时需提要前评估变更风险。

            在邻居配置中引用之前配置的路由映射(Route-map)规则即可。

                    验证BGP路由过滤结果

            验证前请确保您已经按前文进行了相关路由策略配置,后文仅作为BGP路由过滤的效果验证。

                            访问列表(ACL)未匹配的路由前缀

            可看到如果没有进行任何路由过滤前,在路由表中可以查看到BGP邻居写入深信服下一代防火墙(NGAF)路由表的路由条目。

                            访问列表(ACL)匹配的路由前缀

            我们现在针对目标网段进行访问列表(ACL)的前缀匹配,注意动作为允许。

            点击提交后,可以在访问列表(ACL)最后发现最新添加的允许匹配规则。

            再次查询,发现访问列表(ACL)匹配中的路由前缀已经不在深信服下一代防火墙(NGAF)的路由表内,由此判断路由过滤成功。

    展开全文
  • map ipsdx1 interface GigabitEthernet0/2 ip address 218.85.224.100 255.255.255.252 ip nat outside ip policy route-map ipsdx2 ip nat pool ipsdx1 219.85.224.200 219.85.224.200 netmask 255.255.255.252 ip ...

    wan1:218.85.224.100

    wan2:219.85.224.200

    内网 : 192.168.201.x 和192.168.202.x走wan1

    192.168.203.x走wan2

    其他网段随机wan1和wan2

    一、 思科路由器:

    interface GigabitEthernet0/1

    ip address 219.85.224.200 255.255.255.252

    ip nat outside

    ip policy route-map ipsdx1

    interface GigabitEthernet0/2

    ip address 218.85.224.100 255.255.255.252

    ip nat outside

    ip policy route-map ipsdx2

    ip nat pool ipsdx1 219.85.224.200 219.85.224.200 netmask 255.255.255.252

    ip nat pool ipsdx2 218.85.224.100 218.85.224.100 netmask 255.255.255.252

    ip nat inside source list 101 interface GigabitEthernet0/1 overload

    ip nat inside source list 102 interface GigabitEthernet0/2 overload

    ip nat inside source list 103 interface GigabitEthernet0/2 overload

    access-list 102 permit ip 192.168.201.0 0.0.0.255 any

    access-list 103 permit ip 192.168.202.0 0.0.0.255 any

    route-map aaa permit 5

    match ip address 102 103

    set ip next-hop 218.85.224.100

    access-list 104 permit ip 192.168.203.0 0.0.0.255 any

    route-map bbb permit 6

    match ip address 104

    set ip next-hop 219.85.224.200

    二、华为路由器

    interface gigabitethernet 0/0/1

    ip address 218.8.8.8

    nat outbound 102

    acl number 102

    rule 5 permit ip source 192.168.201.0 0.0.0.255

    rule 6 permit ip source 192.168.202.0 0.0.0.255

    acl number 103

    rule 7 permit ip source 192.168.201.1 0.0.0.0 destination 218.85.224.100 0.0.0.0

    rule 8 permit ip source 192.168.202.0 0.0.0.255 destination 218.85.224.100 0.0.0.0

    traffic classifier aaa operator or

    if-match acl 103

    traffic behavior aaa

    redirect ip-nexthop 218.85.224.100

    traffic policy aaa

    classifier aaa behavior aaa

    或者

    acl number 3000

    rule 10 permit ip source 10.0.0.0 0.0.0.255 destination 10.10.55.2 0

    acl number 3001

    rule 94 permit ip source 94.4.19.0 0.0.0.255 destination 10.10.55.3 0

    rule 192 permit ip source 192.168.2.0 0.0.0.255 destination 10.10.55.3 0

    traffic classifier aaa operator or

    if-match acl 3000

    traffic classifier bbb operator or

    if-match acl 3001

    traffic behavior aaa

    redirect ip-nexthop 10.10.55.2

    traffic behavior bbb

    redirect ip-nexthop 10.10.55.3

    traffic policy aaa match-order config

    classifier aaa behavior aaa

    traffic policy bbb match-order config

    classifier bbb behavior bbb

    展开全文
  • 一、Route-map概述 1.技术背景 首先来初步认识一下route-map。看上图,我们在R2上,将OSPF路由重发布进RIP,前面已经说过了,在重发布时,可以使用metric关键字来设置路由被重发布进RIP后的metric,这里设置为1,...
  • OpenStreetMap-Route-Planner

    2021-05-26 19:11:41
    OpenStreetMap_RoutePlanner 2. 问题解决 需要安装这个依赖: cpp-io2d 编译的时候会有问题,需要 gcc 是 7.4 以上, ubuntu16.04 默认是 5.0,需要升级一下 P0267_RefImpl/issues/126 Ubuntu16.04安装gcc7 ...
  • Error: Cannot find module ‘@nestjs/core/router/route-path-factory’ 原因 nest 版本过低 解决方法 将nest 升级至最新版本 nest update -f -t latest
  • 路由策略-1

    2021-05-17 11:24:48
    Route-map在重分发中的应用 ①为路由器配置IP地址,实现直连连通 ②R1上配置环回接口,地址分别为:1.1.1.1/32 1.1.1.2/32 1.1.1.3/32 ③R3上配置环回接口,地址为:3.3.3.3/32 ④R1、R2上运行RIPv2,R2、R3...
  • 并且还有许多features,只有明白了这些参数的意思,后续设计stub区域的时候,才不会困惑,并且对于EIGRP还有汇总,EIGRP的汇总是我最喜欢的特性了,可以随时随地的进行汇总,leak-map可能是比较陌生的参数了,我习惯...
  • 一、网络设计 R1、R2、R3、R4、R5 1.BGP网络拓扑发展演变 2.BGP路由黑洞、路由同步、IBGP水平分割 ① 配置接口ip ...② R1和R2、R4和R5互相配置静态路由指向对方 ...R4(config)#ip route 5.5.5.5 255.25...
  • BGP路由过滤的配置

    2021-08-19 18:21:10
    access-list 1 permit 172.16.0.0 0.0.0.255 access-list 1 permit 172.16.1.0 0.0.0.255 route-map bgpfilter deny 10 match ip address 1 route-map bgpfilter permit 20 router bgp 64512 neighbor 10.1.255.2 ...
  • 顾名思义,就是将传进来的routes数组转成一个Map结构的数据结构,key是path,value是对应的组件信息,至于为什么要转换呢?这个咱们下面会讲。咱们先实现转换。 // src/my-router.js function createRouteMap(routes...
  • BGP路径控制

    2021-07-08 14:41:16
    route-map)#route-map WT1 permit 30 R4(config-route-map)#route-map WT2 permit 10 R4(config-route-map)#match ip add prefix-list 2 R4(config-route-map)#set weight 200 R4(config-route-map)#route-map WT2 ...
  • 假设: 您的公司已设置AWS Direct Connect以将本地连接到Amazon VPC实例。两个直接连接在两个不同的位置终止直接连接位置。您正在本地使用两个路由器,R1和R2(每个直接连接一个)。R1和R2它们之间的没有连通性。...
  • Route-map路由图,用于实现不同协议之间路由过滤。(其中一个功能) 一、路由重分发 重分布总是向外执行的。这意味着执行重分布的路由器不更改其路由表。只有接收重分布路由的下行路由器会把路由添加...
  • 神州数码DCRS-5200-28交换机简单配置:vlan接口表:vlan vlan名管理地址子网掩码所属端口vlan1shiju151.36.16.250255.255.254.0vlan2teshangang151.36.19.250255.255.255.011,12, vlan 3chengxi151.36.20.250255.255...
  • BGP的总结

    2020-12-18 23:42:47
    bgp]aggregate 20.1.0.0 22 [r1]ip ip-prefix b deny 20.1.1.0 24 [r1]ip ip-prefix b permit 0.0.0.0 0 le 32 [r1]bgp 1 [r1-bgp]filter-policy ip-prefix b export 3、 route-map 在bgp协议中直接调用route-map;...
  • ( { routes.map((route, i) => ( key={route.key || i} path={route.path} exact={route.exact} strict={route.strict} location={route.location} sensitive={route.sensitive} children={route.children} render=...
  • route

    2020-12-31 06:57:52
    一、Route-map概述1.技术背景首先来初步认识一下route-map。看上图,我们在R2上,将OSPF路由重发布进RIP,前面已经说过了,在重发布时,可以使用metric关键字来设置路由被重发布进RIP后的metric,这里设置为1,那么...
  • 使用 路由策略对特定路由修改Local Preference 值 实现负载分担: 在R2上: [R2]ip ip-prefix 1 permit 10.0.1.1 32 [R2]route-policy 1 permit node 10 [R2-route-policy]if-match ip-prefix 1 [R2-route-policy]...
  • OSPF选路原则

    2020-12-22 14:11:54
    OSPF作为一种可以支持多区域的链路状态路由协议,相应的路由条目也是比较复杂的。路由条目标识中有O(intra-area)、O IA(inter-area)、O E1(external计算内部度量)、OE2(external不计算内部度量)、O N1(NSSA区域中的...
  • 【华为路由器基本ACL过滤配置】

    千次阅读 2021-12-12 00:04:43
    华为路由器基本ACL过滤
  • 匹配依据 掩码长度 掩码长度范围 地址前缀匹配规则:顺序匹配、唯一匹配、默认拒绝 通配掩码匹配路由原则 ip prefix-list配置举例 route-map route-map类似于脚本语言。默认动作是拒绝所有 需要有一条放行所有 ...
  • 对于路由反射器将route-map应用到反射路由,请确保在routerbgp模式下包含bgproute-reflectorallow-outbound-policy。 路由映射是路由映射条目的有序列表。每个条目最多可指定四组不同的条款: Matching Conditions ...
  • 路由-RIP

    2021-02-07 16:45:13
    首先我们在R2上建立一个loopback接口,并将它宣告到RIP中,然后用ACL来匹配这个接口,建立route-map调用这个 ACL,最后在 default-information originate命令后调用这个route-map R2: access-list 1 permit 2.2.2.2...
  • spring.cloud.gateway.filter.map-request-header.enabled true 启用 map-request-header filter. spring.cloud.gateway.filter.modify-request-body.enabled true 启用 modify-request-body filter. spring.cloud....
  • CCIE-MPLS路由传递

    2021-09-19 22:00:26
     为了完成以上的路由区分问题 , 需要引入一个参数 : RT (Route Target) no bgp default route-target filter 来关闭该检测 重分布后VPN V4学到的路由已导入BGP VRF数据库 Export Map & Import Map  Export Map ...
  • Vue Baidu Map踩坑记录

    2020-12-26 13:17:09
    Vue Baidu Map踩坑记录修改驾车路线起点、途经点、终点图标路书 只回放最后一段路径 控制回放速度路书 取消掉下动画自定义图注标签,点击后隐藏 修改驾车路线起点、途经点、终点图标 <bm-driving> :start=...
  • PBR+多出口NAT+IP SLA

    2020-12-24 18:24:55
    PBR策咯路由(Policy-Based Routing)route-map的一种应用,基于策略的路由比传统的路由能力更强,使用更灵活,它使网络管理者不仅能够根据目的地址而且能够根据协议类型、报文大小、应用或IP源地址来选择转发路径。...
  • /** *Copy right 2008-2021 by Jacky Zong. ...package route import ( "context" "fmt" "k8s.io/client-go/util/workqueue" queue "k8s.io/client-go/util/workqueue" "k8s.io/cloud-provider-alibaba-clo...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 57,133
精华内容 22,853
关键字:

route-map