精华内容
下载资源
问答
  • 安装新的vue3.0 将npm的仓库地址改为淘宝镜像:npm config set registry https://registry.npm.taobao.org --global 然后执行:cnpm install -g @vue/cli” 。注意是cnpm了,不是npm。 npm install出现"Unexpected ...

    卸载旧的vue2.0

    npm uninstall vue-cli -g 或 yarn global remove vue-cli 。

    安装新的vue3.0

    将npm的仓库地址改为淘宝镜像:npm config set registry https://registry.npm.taobao.org --global
    然后执行:cnpm install -g @vue/cli” 。注意是cnpm了,不是npm。

    npm install出现"Unexpected end of JSON input while parsing near"错误解决方法

    npm cache clean --force 指令来清除node_cache文件夹缓存。

    查看node vue npm cnpm版本

    **** -v vue -V 或者 vue -version

    vue2.0项目到3.0转接

    桥接工具npm install -g @vue/cli-init ,下载完后打开vue2.0的项目 npm run dev 运行就可以了。

    3.0直接vue ui打开设计界面,2.0创建项目呢

    https://blog.csdn.net/qq_42417923/article/details/80894507

    新安装vue,配置环境变量和cache和global文件夹

    https://blog.csdn.net/sunboylife/article/details/102814140 安装vue,不过安装cli用上面的方法。
    https://www.cnblogs.com/zhouyu2017/p/6485265.html 环境配置部分。

    展开全文
  • 上次老师跟大家分享了Vue之菜单权限控制的知识,今天跟大家分享下Vue3.0升级的知识。1 自身性能的变动众所周知,vue3.0在去年开放了源码,并且今年将发出真正的可用于开发的版本。那么我们今天就带着大家了解下 ...
    d54ebcabae39c0d513b7e65446cf933b.gif阅读本文约需要5分钟

    大家好,我是你们的导师,我每天都会在这里给大家分享一些干货内容(当然了,周末也要允许老师休息一下哈)。上次老师跟大家分享了Vue之菜单权限控制的知识,今天跟大家分享下Vue之3.0升级的知识。

    1 自身性能的变动众所周知,vue3.0在去年开放了源码,并且今年将发出真正的可用于开发的版本。那么我们今天就带着大家了解下 vue3.0,到底进化了什么,会对我们的开发有什么影响?一、更快带来更快的改动主要有两方面1、vue3重新审视了 vdom,更改了自身对于 vdom的对比算法。vdom从之前的每次更新,都进行一次完整遍历对比,改为了切分区块树,来进行动态内容更新。也就是只更新 vdom的绑定了动态数据的部分,把速度提高了6倍;2、 把 definePerproty改为了 proxy,对于 JavaScript引擎更加友好,响应更加高效。二、更小之前 vue的代码,只有一个 vue对象进来,所有的东西都在 vue上,这样的话其实所有你没用到的东西也没有办法扔掉,因为它们全都已经被添加到 vue这个全局对象上了。vue3的话,一些不是每个应用都需要的功能,我们就做成了按需引入。用 ES module imports按需引入,举例来说,内置组件像 keep-alive、transition,指令的配合的运行时比如 v-model、v-for、帮助函数,各种工具函数。比如 async component、使用 mixins、或者是 memoize都可以做成按需引入。2 写法上将发生的变动一、加强了 typescript的支持,虽然我们在 vue2已经可以使用 typescript了,但是再 vue3中,进一步加强了对 typescript的支持,很可能以后你就需要用 typescript来写 vue了;二、改为使用函数式写法,如果你使用 Function-based API,那如下图所示:c16290a29fed79f83b358eae6e88300e.png我们可以看到,这里面的变化在于 watch、mounted等等生命周期,从属性变成了方法。除此之外我们可以直接把 watch、onMounted等作为了一个方法从 vue中拿出,如下面代码:9685a64ff692a18637cf5f637e03eb50.png开发这样的做法好处之一,就是让我们可以更好地进行 tree-shaking,从侧面上帮助了我们更小的目标。今天就分享这么多,Vue 3.0升级,学会了多少欢迎在留言区评论,对于有价值的留言,我们都会一一回复的。如果觉得文章对你有一丢丢帮助,请点右下角【在看】,让更多人看到该文章。36a2dc922049998abdaa944e8dc079e9.gif

    9409754ebfd450ab51844e2089e93a49.png

    展开全文
  • Vue脚手架3.0出来也蛮久了,秉着前人先踩坑的习惯,最近才开始升级。整个过程还是蛮顺利的,不过也有一些小小的问题,简单记录起来。系统版本:Windows 7 64位(公司限制无法使用管理员权限)命令程序:PowerShell...
    81b145e827e84dde143c98603c4cc3da.png

    Vue脚手架3.0出来也蛮久了,秉着前人先踩坑的习惯,最近才开始升级。整个过程还是蛮顺利的,不过也有一些小小的问题,简单记录起来。

    系统版本:Windows 7 64位(公司限制无法使用管理员权限)

    命令程序:PowerShell(公司限制无法使用CMD)

    官方文档 https://cli.vuejs.org/zh/guide/

    关于Node.js版本升级

    Vue-cli 3.0需要8.9或者更高的node,官方推荐8.11+,我check了一下本机的node版本,有点老,才7.0,于是需要先解决版本升级的问题。

    先从官网下载node安装包,由于公司是Windows的机器,而且不开放管理员权限,无法直接通过msi文件安装,于是选择了下载zip免安装包,下载后直接解压,覆盖原来的node目录的文件即可升级。

    然而一开始选择的最新版node目前使用有问题,安装npm包的时候一直报错 asyncWrite is not a function,半天定位不到原因,后来在stackoverflow上看到这个问题,通过降级到8.11.2来解决(所以最新版还是不知道什么原因和怎么解决emmm)。

    https://stackoverflow.com/questions/50597159/npm-err-asyncwrite-is-not-a-function

    ac28aca9f5b25a9bbdf2990d5b8e0f2b.png

    附上Node的相关下载地址。

    官网下载 https://nodejs.org/zh-cn/download/

    历史版本 https://nodejs.org/zh-cn/download/releases/

    我选的版本 https://nodejs.org/download/release/v8.11.2/node-v8.11.2-win-x64.zip

    关于Node的环境变量

    直接通过安装包安装的node现在都不需要配置这个了,会自动设置好,但如果跟我一样,没有管理员权限,通过zip解压的话,第一次使用node需要关联上这个path。

    方法也比较简单,就直接截图示范了,path的内容就是你的node的路径。

    b622db337dec3c8e4efa186c46534470.png

    安装Vue-CLI 3.0

    本来以为要踩坑也得等到使用的时候才会踩,安装怎么说也得很顺利吧,然而现实就是比较残酷,安装的时候就踩了个大坑。

    根据官方文档说明,卸载了旧版脚手架之后,使用 npm install -g @vue/cli 就可以直接安装,但是频繁报错,说存在无法识别的标记,如下图:

    262d0abdf8bd77a819e8b17c927df422.png

    并且这个问题,百度和谷歌都找不到原因,根本没有人提问,我能怎么办,我很绝望啊!

    幸亏天无绝人之路,有位同事对PowerShell比较熟,一眼就帮我看出问题所在,是@引起的,在CMD是可以直接这么安装,但是在PS,@是个特殊字符,需要进行转义,需要在@前面加上`,再次尝试 ,转义后立即可以安装了,感动到哭。

    210e0e0d1a78646750ead804593f3f73.png

    修改Vue项目配置

    3.0的目录结构比2.0精简了好多,具体的这里不细说了,官方文档也说的很清晰,这里附上我在用的vue.config.js文件给大家参考。

    配置文档说明 https://cli.vuejs.org/zh/config/

    8b5a2188849774f346b9797385df2b2b.png

    作者: 程沛权

    来源:http://chengpeiquan.com

    展开全文
  • src="https://img-ask.csdnimg.cn/upload/1618465408268.png" width="389" /><img alt="" height="261" src="https://img-ask.csdnimg.cn/upload/1618465416558.png" width="728" />我在项目中把npm版本降级到了3.0...
  • Vue2.0升级3.0或4.0和创建Vue3.0

    千次阅读 2020-07-12 16:25:36
    Vue 2.0升级3.0和4.0 首先用npm uninstall vue-cli -g来卸载Vue2.0 再用npm install -g @vue/cli来下载Vue3.0或4.0 Vue3.0创建 1、 vue create 项目的名字 2、 按 ↓ 选择“Manually select features”,再...

    Vue 2.0升级3.0和4.0

    • 首先用npm uninstall vue-cli -g来卸载Vue2.0

    • 再用npm install -g @vue/cli来下载Vue3.0或4.0

    Vue3.0创建

    1、 vue create 项目的名字

    2、 按 ↓ 选择“Manually select features”,再按 Enter

    • default是默认配置

    • Manually select features是手动配置

    3、 选择你需要的配置项

    • 通过↑ ↓ 箭头选择你要配置的项,按 空格 是选中,按 a 是全选,按 i 是反选。具体每个配置项表示什么意思在下面会有说明

    • 里面有个Linter/Formatter这个是控制代码格式(选上是严谨)一般都不选

    • 里面可以选择

    1.Badel 必须选的

    2.Router 路由

    3.Vuex

    4.CSS

    • 选择是否使用history router

    No

    后面的可以一路回车就行了

    展开全文
  • vue2.0 升级vue3.0

    2021-03-10 20:49:19
    vue -v 图片版本已经是3.0 查看版本,如果版本是2.0,先卸载 卸载npm uninstall -g vue-cli 安装3.0手脚架npm install -g @vue/cli 创建项目vue create project_name
  • vue2.0升级vue3.0报错

    2019-08-01 12:31:10
    vue2.0升级vue3.0报错 报错误[Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render functions, or use the ...
  • 1.3.0版本包括了默认预设配置和用户自定义设置 ...vue-cli 3.0 搭建 1. 安装或升级 Node.js vue-cli官网对于node版本有明确要求 Vue CLI 需要 Node.js 8.9 或更高版本 (推荐 8.11.0+) 2.安装 vue-cli 3.0 npm insta
  • 报这个错误就用以下方法
  • vue2.0升级3.0报错node_global已存在 先执行命令npm uninstall -g vue-cli 再执行npm install -g @vue/cli
  • (更新) 之前没留意,原来我更新的是vue-cli4了,感谢评论里大大的提醒,我以下的过程是升级到了4的前几天在跟同事合作开发的时候,被迫用vue-cli3.0构建,最近终于闲下来学习了一下vue-cli3.0的简单构建。之前我是用...
  • 如何升级Vue的版本 vue2.9.6升级vue3.0卸载原来的版本安装新版本通过GUI界面创建项目 卸载原来的版本 由于目前的vue3.0支持通过UI界面创建vue项目,所以对于学vue前端的人来说是相当大的诱惑。界面效果如下图所示 ...
  • Vue2.0升级Vue3.0注意

    2021-03-30 11:53:42
  • 这篇文章主要介绍下vue-cli3.0项目搭建,项目结构和配置等整理一下,分享给大家。 一、介绍 Vue CLI 是一个基于 Vue.js 进行快速开发的完整系统。 通过@vue/cli实现的交互式的项目脚手架。 通过@vue/cli+@vue/...
  • vue3.0 API文档地址: ...3.使用vue add vue-next命令,将项目升级3.0(如果报错可以尝试将vuecli升级到最新版本) 或者直接使用 vite 创建Vue3.0项目 npm i vite npm init vite-app <project-name>
  • vue3.0 升级内容 全部用TS重写的(响应式、vdom、模本编译) 性能提升,减少代码量 会调整部分API Proxy重写响应式 vue2.x 马上要过时了吗 vue3.0从正式发布到推广,还需要一段时间 vue2.x应用范围广,有大量项目...
  • Vue2.0项目工程升级3.0

    千次阅读 2020-07-16 15:31:34
    下面就简单分享一下我的升级过程因为我构建项目都是基于3.0的,所以对于2.0的用户可以先升级一下脚手架工具 已经装了2.0的话就需要先卸载 npm uninstall vue-cli -g 或 yarn global remove vue-cli 安装新版本...
  • vue-cli 3.0+简 介vue-cli 3.0相对2.x进行了断裂式的升级,配置方式有了巨大的改变,同时性能也有了很大的提升。最新的4.x延续了3.x,没有断裂式升级,只是增加部分新特性和局部优化。vue-cli 3.0+ 内置了webpack4,...
  • vue3.0笔记一:vue3.0生命周期以及Setup

    千次阅读 2020-12-24 17:09:09
    vue3.0的学习以及对技术更新升级内容的整理与使用,这里分析下他的生命周期。 vue官方入口 目录: 一、图示vue2.0到vue3.0改变 二、解析图示的改变 三、官方对生命周期钩子的解释 四、官方对Setup 的详细...
  • vue安装或升级3.0

    万次阅读 2018-10-30 11:06:14
    如果你已经全局安装了旧版本的 vue-cli (1.x 或 2.x),你需要先通过 npm uninstall vue-cli -g 或 yarn global remove vue-cli 卸载它。 Node 版本要求 Vue CLI 需要 Node.js 8.9 或更高版本 (推荐 ...
  • vue3.0正式版已经发布几个月了,ui框架也跟进的差不多了,咱也得紧跟潮流不能落伍,所以趁着空闲就升级了项目vue框架,由vue2.6升级vue3.0,总结下升级过程中的遇到的问题及解决方法。 一、项目简介 基于vue2框架...
  • Vue3.0+Element Plus搭建项目一、升级 vue-cli二、新建vue3.0项目三、安装Element Plus 一、升级 vue-cli 首先在终端输入以下命令,查看脚手架版本 vue -V 本次使用用 vue-cli@4.5以上的版本,执行以下命令进行...
  • Vue 3.0 升级指南

    2020-11-27 16:46:00
    大咖揭秘Java人都栽在了哪?...>> 本文由葡萄城技术团队原创并首发 转载请注明出处:葡萄城官网,葡萄城为开发者提供专业的开发工具、解决方案和服务,赋能开发者。...2020年9月18日Vue 3.0正式发布,...
  • vue-cli 3.0+简 介vue-cli 3.0相对2.x进行了断裂式的升级,配置方式有了巨大的改变,同时性能也有了很大的提升。最新的4.x延续了3.x,没有断裂式升级,只是增加部分新特性和局部优化。vue-cli 3.0+ 内置了webpack4,...
  • 解决vue-cli2.9.6升级3.0失败 相信有些人会遇到跟我一样的情况,升级个vue-cli3.0,明明按照下列办法进行操作了,但是版本就是依旧2.9.6 $npm uninstall vue-cli -g //卸载vue-cli旧版本</br> $npm install -g...
  • 升级脚手架到vue-cli3.0版本的时候出现了这个报错: [Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 579
精华内容 231
关键字:

vue升级3.0

vue 订阅