精华内容
下载资源
问答
  • Python 3.8.0 is out, but I haven't been able to find any post on how to update to python 3.8 using conda - maybe they will wait for the official release? Any suggestions?解决方案You can update your ...

    Python 3.8.0 is out, but I haven't been able to find any post on how to update to python 3.8 using conda - maybe they will wait for the official release? Any suggestions?

    解决方案

    You can update your python version to 3.8 in conda using the command

    conda install -c anaconda python=3.8

    as per https://anaconda.org/anaconda/python. Though not all packages support 3.8 yet, running

    conda update --all

    may resolve some dependency failures. You can also create a new environment called py38 using this command

    conda create -n py38 python=3.8

    Edit - note that the conda install option will potentially take a while to solve the environment, and if you try to abort this midway through you will lose your Python installation (usually this means it will resort to non-conda pre-installed system Python installation).

    展开全文
  • python36 -m venv . # 执行后正常创建 C:\Windows\System32\cmd.exe>python38 -m venv . # 执行后报错:Error: [WinError 2] 系统找不到指定的文件。 # 文件夹正常创建,缺少了很多文件 ps1:先提出问题,解决...
    C:\Windows\System32\cmd.exe>python36 -m venv .
    # 执行后正常创建
    C:\Windows\System32\cmd.exe>python38 -m venv .
    # 执行后报错:Error: [WinError 2] 系统找不到指定的文件。
    # 文件夹正常创建,缺少了很多文件

     

    ps1:先提出问题,解决后再来更新

     

     

    展开全文
  • 1.首先清楚M1和以往的Mac的区别 M1的默认终端是zsh,...安装pip curl https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py sudo python2 get-pip.py 然后: pip install pyenv-virtualenv 安装nvm curl -o- ...

    1.首先清楚M1和以往的Mac的区别

    • M1的默认终端是zsh,所以操作的是~.zshrc或者~.zprofile;在里面的东西,作为命令时才能被识别。此外,M1是ARM架构芯片
    • 以往的Mac默认终端是bash,操作的是~.bashrc或者~.bash_profile
      ~目录下的文件

    2.设置终端的打开方式为:访达->其他工具–终端–右键显示简介–Rosetta

    请添加图片描述
    在这里插入图片描述

    3.安装xcode,去App Strore中搜索xcode,安装即可

    4.安装brew,brew相当于ubuntu中的apt-get

    在m1中安装intel版homebrew:

    arch -x86_64 /bin/bash -c "$(curl -fsSL https://cdn.jsdelivr.net/gh/ineo6/homebrew-install/install.sh)"
    

    在m1中,安装ARM版homebrew,ARM版brew感觉还有很多问题,可以安装,但是到时候安装一些其他东西的时候,可能会出现莫名其妙的错,基本都是ARM架构的问题:

    /bin/bash -c "$(curl -fsSL https://gitee.com/huwei1024/HomebrewCN/raw/master/Homebrew.sh)"
    

    将intel版的brew去个别名:ibrew,将以下命令~.zshrc中

    alias ibrew="arch -x86_64 brew"
    

    继续在~.zshrc中加:

    export LDFLAGS="-L/usr/local/opt/zlib/lib"
    export CPPFLAGS="-I/usr/local/opt/zlib/include"
    

    不要忘记source ~.zshrc重新加载终端

    测试ibrew

    ibrew -v
    

    6.安装pyenv

    先来:

    git -C $(brew --repository homebrew/core) checkout master
    

    然后:

    ibrew install pyenv zlib bzip2
    

    最后神级命令:在stackoverflow上面的高赞回答,亲测有效![请添加图片描述](https://img-blog.csdnimg.cn/5a2b3455165446eab04664126fe482ae.png

    CFLAGS="-I$(ibrew --prefix openssl)/include -I$(ibrew --prefix bzip2)/include -I$(ibrew --prefix readline)/include -I$(xcrun --show-sdk-path)/usr/include" LDFLAGS="-L$(ibrew --prefix openssl)/lib -L$(ibrew --prefix readline)/lib -L$(ibrew --prefix zlib)/lib -L$(ibrew --prefix bzip2)/lib" arch -x86_64 pyenv install --patch 3.6.8 < <(curl -sSL https://github.com/python/cpython/commit/8ea6353.patch\?full_index\=1)
    

    请添加图片描述
    然后:
    在~.zshrc中添加:

    alias ipyenv="arch -x86_64 pyenv"
    

    7.安装pip

    curl https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py
    
    sudo python2 get-pip.py
    

    然后:

    pip install pyenv-virtualenv
    

    安装nvm

    curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.38.0/install.sh | bash
    

    然后:

    export NVM_DIR="$HOME/.nvm"
    [ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh"  # This loads nvm
    [ -s "$NVM_DIR/bash_completion" ] && \. "$NVM_DIR/bash_completion"  # This loads nvm bash_completion
    

    然后下载npm:具体版本可以进行url变化

    https://nodejs.org/download/release/v14.15.0/
    

    最后下载yarn:

    npm install -g yarn@1.22.4
    
    展开全文
  • Fatal error in launcher: Unable to create process using ‘“C:\Users\zhudan\appdata\local\programs\python\python36\python.exe” “C:\Users\zhudan\AppData\Local\Programs\Python\Python36\Scripts\pip.exe...

    C:>pip install opencv-python
    Fatal error in launcher: Unable to create process using ‘“C:\Users\zhudan\appdata\local\programs\python\python36\python.exe” “C:\Users\zhudan\AppData\Local\Programs\Python\Python36\Scripts\pip.exe” install opencv-python’

    C:>

    C:\Users\zhudan\AppData\Local\Programs\Python\Python38\Scripts>pip install opencv-python
    Looking in indexes: https://pypi.tuna.tsinghua.edu.cn/simple/
    WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘ConnectTimeoutError(<pip._vendor.urllib3.connection.HTTPSConnection object at 0x0000022B330514F0>, ‘Connection to pypi.tuna.tsinghua.edu.cn timed out. (connect timeout=15)’)’: /simple/opencv-python/
    Collecting opencv-python
    Downloading https://pypi.tuna.tsinghua.edu.cn/packages/5c/6c/cdf7b1ad23d29262a8af85e1d6154ad71ce0085ea1b09c355eb13046d92e/opencv_python-4.4.0.42-cp38-cp38-win_amd64.whl (33.5 MB)
    |████████████████████████████████| 33.5 MB 2.2 MB/s
    Requirement already satisfied: numpy>=1.17.3 in C:\Users\zhudan\appdata\local\programs\python\python38\lib\site-packages (from opencv-python) (1.19.1)
    Installing collected packages: opencv-python
    Successfully installed opencv-python-4.4.0.42

    C:\Users\zhudan\AppData\Local\Programs\Python\Python38\Scripts>

    展开全文
  • centos 7 python3.6升级到python3.8

    千次阅读 2020-07-03 10:35:27
    1、下载python3.8安装包 a、下载: cd /usr/download wget https://www.python.org/ftp/python/3.8.1/Python-3.8.1.tgz b、解压文件: tar -xvf Python-3.8.1.tgz 2、移除旧版本 a、删除旧版本的软链接 rm ...
  • ubuntu安装了python2,python3.6,python3.8,修改默认版本的pip cd /usr/bin 其中pip3之指向python3.8,改成指向3.6,只需修改pip3即可 将python3.8改成3.6即可完成切换
  • Python安装包(3.63.8)及Pycharm安装及汉化包 官网下载安装包速度较慢,百度网盘是不是要相对快快一些呢?害,这里有你想要的! 链接: https://pan.baidu.com/s/1o6JFwrR_T4MoREYngbhROg 提取码: o5t7 二维码:...
  • docker-python-chrome驱动程序 带有Chromedriver的Python,用于运行自动化测试 快速尝试 $ git clone ... 3.8 , latest (基于python3.8, ) 3.8-selenium (基于安装了Sele
  • 默认python3指向python3.6,系统自带的,如果修改软连接,将python3指向python3.8,则可能会出现 ModuleNotFoundError: No module named 'apt_pkg 可能还会出现其他的问题,当然改了python3指向python3.8也有其他...
  • 本文列举了Python3.6、3.7、3.8三个版本的新特性,学习它们有助于提高对Python的了解,跟上最新的潮流。一、Python3.6新特性1、新的格式化字符串方式新的格式化字符串方式,即在普通字符串前添加 f ...
  • 本文列举了Python3.6、3.7、3.8三个版本的新特性,学习它们有助于提高对Python的了解,跟上最新的潮流。一、Python3.6新特性1、新的格式化字符串方式新的格式化字符串方式,即在普通字符串前添加 f ...
  • Ubuntu 18.04.3 LTS apt方式 使用root用户或具有sudo访问权限的用户身份运行以下命令 apt update apt install software-properties-common add-apt-repository ppa:...apt install python3.8 python3.8 ...
  • Ubuntu18.04将Python3.6升级到Python3.7 更新资源 sudo su apt update apt -y upgrade apt -y autoremove 安装Python3.7 sudo apt -y install python3.7 删除旧的软连接 sudo rm -rf /usr/bin/python3 sudo ...
  • python3.6,3.7,3.8的一些差异

    千次阅读 2020-09-06 21:14:13
    用了太长时间的python3.6和2.7,对于新的知识了解的太少了。python 3.7, python 3.8的一些特性都不太了解,感觉有些原地打转。python3.6的typing还是刷leetcode才学到的,最近在看classic computer Science problems ...
  • Ubuntu18.04下Python版本切换软链接,python3.6、python3.7、python3.8切换 sudo update-alternatives --config python3 选择想要切换的版本。 查看python的版本 python3 --verison

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 12,927
精华内容 5,170
关键字:

python3.6升级3.8

python 订阅